HMI編輯軟體操作手冊

HMI Programming Software User Manual Help

(Edition 2.0)


Introduction

介紹

歡迎使用HMI編輯軟體
 人機系列產品所開發設計的規劃軟體

 感謝您購買HMI編輯軟體。在此手冊中，包含HMI編輯軟體的操作說明以及特點介紹。

注：

  1. HMI編輯軟體中，所有程式和文件的版權， 請依軟體授權合約書，授權給使用者。在大陸，台灣及國際法律的規範下，任何違反軟體授權合約書的行為都不被允許。
  2. 本公司致力於提供使用者兼具功能與操作性的人機產品與正確的說明文件。然而，若您發現仍有未盡之處或錯誤時，請與本公司聯絡。
  3. 無論上述規定，本公司對於因使用本產品所導致的損害或任何第三方訴訟，不負任何法律責任。
  4. 本手冊與實際的產品操作可能有差異。關於產品的最新訊息，請參考產品所附文件(如readme.txt等)或本公司其他的相關的文件。
  5. 產品內容可能包含本公司或第三方的無形資產或智慧財產，這並不表示本公司授權使用者或第三方使用這些專利資產。

警告事項

  1. 請勿使用人機開關作為緊急開關。基於安全理由，所有的工業機械和系統都必須裝備機械式手動緊急開關。
  2. 請勿使用可能導致人員受傷或設備損壞的人機開關。當人機、處理器和電線發生故障，導致輸出停留在ON或OFF時，將產生嚴重的意外發生。


Documentation Conventions

文件説明

產品相關的縮寫與用語

本手冊中使用用語的涵義如下。

用語 | 說明
軟體 | 代表HMI編輯軟體，及其包含的相關HMI產品的應用程式。
運行軟體 | 代表PC組態軟體，小型的HMI/SCADA運行程式。
人機應用 | 代表HMI編輯軟體在PC上建立的人機規劃畫面。
目標人機 | 可執行HMI編輯軟體，並下載及顯示畫面的人機或電腦。
HMI單元 | 所有的HMI人機產品。
T系列 | T 系列人機產品。
X系列 | X 系列人機產品。
控制器 | 代表可程式邏輯控制器(PLCs)、運動控制器、溫度控制器、變頻器的控制器等等。

本手冊中使用縮寫的涵義如下。

縮寫 | 相應人機
HMI | 所有HMI人機產品。


系統要求

安裝 HMI編輯軟體的基本作業系統環境如下。

硬碟空間

約需320MB的可用硬碟空間以進行安裝；安裝過程需兩倍(640MB)的可用空間。

 記憶體

記憶體需求與作業系統相同。然而，當使用者的專案中使用了大量的高彩點陣圖時，建議使用1024MB以上的記憶體。

 支援作業系統：

Windows 2000™ SP4
Windows XP™ SP2 (for all flavors of XP such as Home, Media Center, Tablet PC 包含各種版本的XP，如Home、Meida Center及Tablet PC)
Windows Server 2003™
Windows Vista™
Windows 7™


Software Installation

安裝軟體

安裝軟體

安裝HMI編輯軟體的基本作業系統環境如下。

  1. 請先關閉所有運行中的程式。
  2. 點選本軟體安裝檔，並執行setup.exe。
  3. 依螢幕之提示操作安裝。

  4. 路徑C：\Program Files\HMI Designer為HMI編輯軟體預設的安裝儲存位置。如果您希望儲存在別的位置，可以從〔Change〕

    裡去更改路徑。

安裝後，系統會建立一個HMI Designer的程式群組；同時，桌面會新增 HMI軟體大師圖示 。Windows™的開始工具列中，出現HMI Designer，在開始 > 所有程式 > HMI Designer。


The Features of the Software

軟體特性

(A) 字的“位”的使用

編號 | 功能 | 物件
01 | 觸控操作 | 畫面物件
02 | 顯現 | 畫面物件
03 | 寫入地址 | 位按鈕, 切換開關
04 | 監視地址 | 位按鈕, 位指示燈, 切換開關, 圖像顯示器, 訊息顯示器, GIF顯示器
05 | 觸發位, 清除觸發位 | 曲線圖, 二維分佈圖, 路徑顯示器
06 | 顏色控制位 | 線, 矩形, 圓, 橢圓, 多段線, 多邊形


軟體的限制範圍

(A) 單一專案的限制

編號 | 項目 | 最大值
01 | 人機應用總數 | 128
02 | 語言總數 | 10
03 | 每種語言的預設字體總數 | 20 (非預設字體總數為無限制)

(B) 單一人機應用的限制

編號 | 項目 | 最大值
01 | 標籤總數 | 無限制
02 | 巨集總數(Macro) | 無限制
03 | 單一畫面的物件總數 | 無限制
04 | 通訊連線總數 | 4/16
05 | 一般用戶記憶區 ($U) | 131072 字
06 | 電池保護記憶區 ($N) | 131072 字
07 | 畫面總數 | 7999
08 | 密碼總數 | 用戶密碼：8 開發者密碼：1
09 | 數位警報區總數 | 64
10 | 類比警報區總數 | 64
11 | 配方區總數 | 16
12 | 配方大小 | 8192字
13 | 單一配方區的配方總數 | 65535
14 | 數據收集器總數 | 16
15 | 取樣大小(個別記憶區) | 1023 字
16 | 取樣總數(個別記憶區) | 65535
17 | 排程總数 | 80
18 | 單壹目錄下的文件總數 | 4096 註: 超出限制的文件需要存放到新的文件夾中。使用軟件可以自動每天或每月創建新的文件夾，具體設定詳見 章節3.1.4 預設文件夾.


專案開發流程


主選單

主選單包含了以下的11個選單項目：檔案、編輯、檢視、畫面、繪圖、物件、專案、人機應用、工具、視窗 和 說明。


檔案選單

圖示 | 選單項目 | 快捷鍵 | 說明
 | 開新檔案 | Ctrl+N | 新建專案。
 | 開啟舊檔... | Ctrl+O | 開啟現有的專案。
 | 關閉 |  | 結束當前的專案。
 | 儲存檔案 | Ctrl+S | 儲存當前的專案。
 | 另存新檔... |  | 以新檔名儲存當前專案。
 | <最近開啟的檔案名稱> |  | 開啟指定的專案。
 | 結束 |  | 結束本軟體。


編輯選單

圖示 | 選單項目 | 彈出菜單項目 | 快捷鍵 | 說明
 | 復原 |  | Ctrl+Z | 復原上一個動作。
 | 重做 |  | Ctrl+Y | 重做前一個復原的動作。
 | 剪下 |  | Ctrl+X | 剪下選取的部分，並暫時存放於剪貼簿。
 | 複製 |  | Ctrl+C | 複製選取的部分，並暫時存放於剪貼簿。
 | 貼上 |  | Ctrl+V | 在當前畫面，貼上剪貼簿的內容
 | 刪除 |  | Del | 刪除選取的部份。
 | 多重複製 |  |  | 多重複製選取的物件。
 | 搜尋與替換 | 搜尋 |  | 搜尋指定的文字。
 |  | 替換 |  | 以其他文字替換指定的文字。
 |  | 搜尋巨集 |  | 搜尋運用在人機上指定的巨集。
 | 顯示網格 |  |  | 設定是否顯示網格。
 | 靠齊網格 |  |  | 設定物件是否靠齊網格排列。
 | 網格設置 |  |  | 開啟網格設置對話框。
 | 全選 |  | Ctrl+A | 選擇當前畫面中，所有的物件。
 | 集群 |  |  | 將選取的物件集群。
 | 解散 |  |  | 解散選取的集群物件。
 | 釘住 |  |  | 釘住選取的物件，使物件無法被移動。
 | 放開 |  |  | 放開選取的物件，使釘住的物件可移動。
 |  | 自動調整文字大小 |  | 設定是否自動調整文字大小。
 | 對齊 | 左 |  | 使選取物件的左邊對齊參考物件的左邊排列。所有物件水平地移動，與參考物件的左邊界對齊。
 |  | 垂直中 |  | 使選取物件的垂直中線對齊參考物件的中線排列。所有物件水平地移動，與參考物件的垂直中線對齊。
 |  | 右 |  | 使選取物件的右邊對齊參考物件的右邊排列。所有物件水平地移動，與參考物件的右邊界對齊。
 |  | 上 |  | 使選取物件的上方對齊參考物件的上方排列。所有物件垂直地移動，與參考物件的上邊界對齊。
 |  | 水平中 |  | 使選取物件的水平中線對齊參考物件的中線排列。所有物件垂直地移動，與參考物件的水平中線對齊。
 |  | 下 |  | 使選取物件的下方對齊參考物件的下方排列。所有物件垂直地移動，與參考物件的下邊界對齊。
 |  | 網格 |  | 設定物件是否對齊網格排列。
 | 等間距 | 水平方向 |  | 使所選物件之間的水平間距相等。
 |  | 垂直方向 |  | 使所選物件之間的垂直間距相等。
 |  | 水平與垂直方向 |  | 使所選物件之間的水平和垂直間距都相等。
 | 使同尺寸 | 寬 |  | 使選取物件與參考物件同寬。
 |  | 高 |  | 使選取物件與參考物件同高。
 |  | 寬與高 |  | 使選取物件與參考物件同寬與同高。
 | 微移 | 微左 |  | 移動一圖元；當勾選『靠齊網格』，選取物件向左微移至最靠近物件左上角的網格。
 |  | 右 |  | 使選取物件向右微移。當未勾選『靠齊網格』，所有選取的物件向右移動一圖元；當勾選『靠齊網格』，選取物件向右微移至最靠近物件左上角的網格。
 |  | 上 |  | 移動一圖元；當勾選『靠齊網格』，選取物件向上微移至最靠近物件左上角的網格。
 |  | 下 |  | 使選取物件向下微移。當未勾選『靠齊網格』，所有選取的物件向下移動一圖元；當勾選『靠齊網格』，選取物件向下微移至最靠近物件左上角的網格。
 | 層次 | 拿到最上層 |  | 將選取的物件移到最上層。
 |  | 拿到上一層 |  | 將選取物件上移一層。
 |  | 放到下一層 |  | 將選取物件下移一層。
 |  | 放到最下層 |  | 將選取的物件移到最下層。
 | 設定順序 |  |  | 設定當前畫面上的物件順序。
 | 物件屬性… |  |  | 開啟選取物件的屬性對話框。
 | 存為預設值 |  |  | 儲存選取物件為此種類物件的預設值，預設物件儲存在物件庫的物件目錄下。
 | 存到物件庫 |  |  | 儲存選取物件到物件庫。
 | 存為全局物件 |  |  | 儲存選取物件為全局物件，儲存在物件庫的全局(Global)目錄下。全局物件可被全局物件副本使用。

提示：
1使用快捷鍵[Shift+Click]，可在選取的物件中選擇參考物件。
2使用快捷鍵[Ctrl+Click]，可新增選取物件。


檢視選單

圖示 | 選單項目 | 彈出菜單項目 | 說明
 | 地址 | 寫入/監視 | 顯示全部畫面中，每一個物件的寫入地址和監視地址。
 |  | 寫入 | 顯示全部畫面中，每一個物件的寫入地址。
 |  | 監視 | 顯示全部畫面中，每一個物件的監視地址。
 |  | 讀取 | 顯示全部畫面中，每一個物件的讀取地址。
 |  | 通知 | 顯示全部畫面中，每一個物件的通知地址。
 |  | 觸控使能 | 顯示全部畫面中，每一個物件的觸控使能地址。
 |  | 顯現使能 | 設定是否於工具列圖示或物件，游標停留的位置上顯示提示。
 | 顯示提示 |  | 設定是否於工具列圖示或物件，游標停留的位置上顯示提示。
 | 縮放 | 25% | 以正常尺寸的25%，顯示畫面。
 |  | 50% | 以正常尺寸的50%，顯示畫面。
 |  | 70% | 以正常尺寸的70%，顯示畫面。
 |  | 80% | 以正常尺寸的80%，顯示畫面。
 |  | 90% | 以正常尺寸的 9 0%，顯示畫面。
 |  | 100% | 以正常尺寸的100%，顯示畫面。
 |  | 150% | 以正常尺寸的150%，顯示畫面。
 |  | 200% | 以正常尺寸的200%，顯示畫面。
 |  | 300% | 以正常尺寸的300%，顯示畫面。
 | 正常尺寸 |  | 以正常尺寸顯示畫面。
 | 專案管理員 |  | 設定是否顯示『專案管理員』視窗。
 | 畫面管理員 |  | 設定是否顯示『畫面管理員』視窗。
 | 畫面全覽 |  | 設定是否顯示『畫面全覽』視窗。
 | 連線全覽 |  | 設定是否顯示『連線全覽』視窗。
 | 物件庫 |  | 設定是否顯示『物件庫』視窗。
 | 巨集指令屬性 |  | 設定是否顯示『巨集指令屬性』視窗。
 | 物件表 |  | 設定是否顯示『物件表』視窗。
 | 輸出入表 |  | 設定是否顯示『輸出入表』視窗。
 | 標準工具列 |  | 設定是否顯示標準工具列。
 | 物件工具列 |  | 設定是否顯示物件工具列。
 | 繪圖工具列 |  | 設定是否顯示繪圖工具列。
 | 文本工具列 |  | 設定是否顯示文本工具列。
 | 編輯工具列 |  | 設定是否顯示編輯工具列。
 | 地址工具列 |  | 設定是否顯示地址工具列。
 | 圖片工具列 |  | 設定是否顯示圖片工具列。
 | 狀態列 |  | 設定是否顯示狀態列。
 | 半透明顯示物件對話框 |  | 設定是否以半透明方式顯示物件屬性對話框。此選項可使用戶看見屬性對話框底下的物件。
 | <語言名稱> |  | 顯示選取物件所使用的語言。


畫面選單

圖示 | 選單項目 | 說明
 | 新畫面... | 在當前人機應用新建畫面。
 | 開啟畫面... | 開啟當前人機應用中現有的畫面。
 | 關閉畫面 | 關閉當前畫面。
 | 關閉全部畫面 | 關閉所有開啟的畫面。
 | 剪下畫面 | 剪下當前畫面，並暫時存放於剪貼簿。
 | 複製畫面 | 複製當前畫面，並暫時存放於剪貼簿。
 | 貼上畫面 | 於當前人機應用，插入剪貼簿中的畫面。
 | 刪除畫面 | 刪除當前畫面。
 | 縮放畫面... | 縮放當前畫面。
 | 導出畫面... | 導出當前畫面到檔案。
 | 導入畫面... | 從檔案導入畫面至當前人機應用。
 | 存當前畫面為圖片檔... | 儲存當前畫面為圖片檔案。
 | 存畫面為圖片檔... | 開啟存畫面為圖片檔對話框。用戶可在對話框中，儲存每個選取的畫面為圖片檔案。
 | 參加保護 | 添加畫面到畫面保護列表。
 | 退出保護 | 從保護列表中移除畫面保護。
 | 啟用保護 | 啟動列表保護中所用的畫面保護。
 | 停止保護 | 停止保護列表中所用畫面保護。
 | 畫面屬性 | 開啟當前畫面的屬性對話框。


繪圖選單

圖示 | 選單項目 | 說明
 | 符號 | 在畫面上放置預設的符號。
 | 線 | 在畫面上放置預設的線。
 | 水平線 | 在畫面上放置預設的水平線。
 | 垂直線 | 在畫面上放置預設的垂直線。
 | 連接線 | 在畫面上放置預設的連接線。
 | 矩形 | 在畫面上放置預設的矩形。
 | 圓角矩形 | 在畫面上放置預設的圓角矩形。
 | 截角矩形 | 在畫面上放置預設的截角矩形。
 | 圓 | 在畫面上放置預設的圓。
 | 橢圓 | 在畫面上放置預設的橢圓。
 | 弧 | 在畫面上放置預設的弧。
 | 扇形 | 在畫面上放置預設的扇形。
 | 多邊形 | 在畫面上放置預設的多邊形。
 | 文字 | 在畫面上放置預設的文字。
 | 圖片 | 在畫面上放置預設的圖片。
 | 刻度 | 在畫面上放置預設的刻度。
 | 表格 | 在畫面上放置預設的表格。


物件選單

圖示 | 選單項目 | 彈出菜單項目 | 說明
 | 位按鈕 |  | 在畫面上放置預設位按鈕。
 | 切換開關 |  | 在畫面上放置預設切換開關。
 | 畫面按鈕 |  | 在畫面上放置預設畫面按鈕。
 | 功能按鈕 |  | 在畫面上放置預設畫面按鈕。
 | 滑動類比開關 |  | 在畫面上放置預設滑動類比開關。
 | 更多按鈕 | 字按鈕 | 在畫面上放置預設字按鈕。
 |  | 多態按鈕 | 在畫面上放置預設多態按鈕 。
 |  | 單選按鈕 | 在畫面上放置預設單選按鈕。
 |  | 鍵盤按鈕 | 在畫面上放置預設鍵盤按鈕。
 |  | 捲動按鈕 | 在畫面上放置預設捲動按鈕。
 |  | 捲動條 | 在畫面上放置預設捲動條。
 |  | 步進按鈕 | 在畫面上放置預設步進按鈕。
 |  | 選頁器 | 在畫面上放置預設選頁器。
 | 數值輸入器 |  | 在畫面上放置預設數值輸入器。
 | 數值顯示器 |  | 在畫面上放置預設數值顯示器。
 | 進階數值顯示器 |  | 在畫面上放置預設進階數值顯示器。
 | ASCII字符輸入器 |  | 在畫面上放置預設ASCII字符輸入器。
 | ASCII字符顯示器 |  | 在畫面上放置預設ASCII字符顯示器。
 | 位指示燈 |  | 在畫面上放置預設位指示燈。
 | 多態指示燈 |  | 在畫面上放置預設多態指示燈。
 | 訊息顯示器 |  | 在畫面上放置預設訊息顯示器。
 | 時間/日期 | 時間顯示器 | 在畫面上放置預設時間顯示器。
 |  | 日期顯示器 | 在畫面上放置預設日期顯示器。
 |  | 週日顯示器 | 在畫面上放置預設週日顯示器。
 | 儀表 |  | 在畫面上放置預設儀表。
 | 動態圖 | 動態線 | 在畫面上放置預設動態線。
 |  | 動態圓 | 在畫面上放置預設動態圓。
 |  | 動態方塊 | 在畫面上放置預設動態方塊。
 |  | G IF圖 | 在畫面上放置預設GIF圖。
 |  | 圖片顯示器 | 在畫面上放置預設圖片顯示器。
 |  | 動畫 | 在畫面上放置預設動畫。
 |  | 路徑顯示器 | 在畫面上放置預設路徑顯示器 。
 | 管線 |  | 在畫面上放置預設管線。
 | 圖表 | 柱狀圖 | 在畫面上放置預設柱狀圖。
 |  | 曲線圖 | 在畫面上放置預設曲線圖。
 |  | 扇形圖 | 在畫面上放置預設扇形圖。
 |  | 二維分佈圖 | 在畫面上放置預設二維分佈圖。
 |  | 旋轉指示燈 | 在畫面上放置預設旋轉指示燈。
 | 警報顯示器 |  | 在畫面上放置預設警報顯示器。
 | 歷史顯示 | 歷史數據顯示器 | 在畫面上放置預設歷史數據顯示器。
 |  | 歷史訊息顯示器 | 在畫面上放置預設歷史訊息顯示器。
 |  | 歷史趨勢圖 | 在畫面上放置預設歷史趨勢圖。
 |  | 單筆記錄曲線圖 | 在畫面上放置預設單筆記錄曲線圖。
 |  | 歷史二維分佈圖 | 在畫面上放置預設歷史二維分佈圖。
 |  | 歷史雷達圖 | 在畫面上放置預設歷史雷達圖。
 |  | 操作記錄顯示器 | 在畫面上放置預設操作記錄顯示器。
 | 配方選擇器 |  | 在畫面上放置預設配方選擇器。
 | 配方表 |  | 在畫面上放置預設配方表。
 | 次連線表 |  | 在畫面上放置預設次連線表。
 | 排程設置表 |  | 在畫面上放置默認的排程設置表。
 | 窗口畫面顯示器 |  | 在畫面上放置默認的窗口畫面顯示器。
 | 全局物件副本 |  | 在畫面上放置預設全局物件副本。
 | 相機顯示器 |  | 在畫面上放置預設USB相機顯示器。


專案選單

圖示 | 選單項目 |  | 彈出菜單項目 | 說明
 | 資訊與保護... |  |  | 開啟專案資訊與保護對話框。此對話框顯示專案的基本資訊和專案保護的屬性設定。
 | 語言 |  |  | 開啟語言對話框，對話框最多可設定10組專案指定語言。
 | 字體範本... |  |  | 開啟字體範本對話框。每一個語言可設定20個常用的字體範本。
 | 圖片資料庫... |  |  | 開啟圖片資料庫對話框。用戶可以在此對話框導入圖片，並設定所導入的圖片。
 | 聲音庫... |  |  | 開啟聲音庫對話框。用戶可以在此對話框，導入所需的聲音檔。
 | 文字庫... |  |  | 開啟文字庫。用戶可以在此對話框導入文字、導出文字和編輯文字。
 | 全局標籤... |  |  | 開啟全局標籤視窗。用戶可以在全局標籤視窗，定義全局標籤。
 | 全局巨集 | 原生腳本 | 新增... | 新增全局原生腳本 。
 |  |  | 編輯 | 編輯全局原生腳本。
 |  |  | 刪除 | 刪除全局原生腳本。
 |  | VB腳本 | 新增... | 新增全局VB腳本 。
 |  |  | 編輯 | 編輯全局 VB腳本 。
 |  |  | 刪除 | 刪除全局VB 腳本。
 | 新增人機應用... |  |  | 新增人機應用。
 | 導入人機應用... |  |  | 從PLF檔導入人機應用。
 | 刪除人機應用... |  |  | 刪除選取的人機應用。


人機應用選單

圖示 | 選單項目 |  | 彈出菜單項目 | 說明
 | 當前人機應用 |  | <人機應用名稱> | 選擇一人機應用為當前人機應用。
 | 連線 |  | 新增... | 在當前人機應用，新增通訊連線。
 |  |  | 屬性 | 選取連線，並開啟此連線的屬性對話框。
 |  |  | 刪除 | 選取欲刪除的連線。
 |  |  | 通訊驅動程式一覽表... | 開啟通訊驅動程式一覽表對話框，顯示人機所支援的所有通訊驅動。用戶可使用此對話框，導出通訊驅動一覽表為CSV檔。
 | 標籤... |  |  | 開啟當前人機應用的標籤視窗，用戶可在此視窗中設定當前人機應用的標籤。
 | 聲音表... |  |  | 開啟聲音表對話框，用戶可以在此對話框中，設定當前人機應用的聲音表。
 | 一般設置... |  |  | 開啟一般設置對話框，用戶可以在此對話框中，設定當前人機應用的一般設置。
 | 命令與狀態... |  |  | 開啟命令與狀態對話框。用戶可以在此對話框中，設定當前人機應用的命令區與狀態字。
 | 時鐘... |  |  | 開啟時鐘對話框，用戶可以在此對話框中，設定當前人機應用的時鐘屬性。
 | 密碼... |  |  | 開啟密碼對話框。用戶可以在此對話框中，設定當前人機應用的密碼。
 | 數位警報區 |  | 新增 | 在當前人機應用，新增數位警報區。
 |  |  | 屬性 | 選擇一數位警報區，開啟其屬性對話框。
 |  |  | 刪除 | 刪除數位警報區。
 | 類比警報區 |  | 新增 | 在當前人機應用，新增類比警報區。
 |  |  | 屬性 | 選擇一類比警報區，開啟其屬性對話框。
 |  |  | 刪除 | 刪除類比警報區。
 | 導出警報區... |  |  | 開啟導出警報區對話框。導出選擇好的警報區到CSV檔或者XML檔。
 | 導入警報區... |  |  | 從CSV或者XML檔把警報數據導入警報區。
 | 配方區 |  | 新增... | 在當前人機應用，新增配方區。
 |  |  | 屬性 | 選擇一配方區，並開啟其屬性對話框。
 |  |  | 刪除 | 刪除配方區。
 |  |  | 導出... | 開啟導出配方區屬性對話框。導出選擇好的配方區到RBF檔。
 |  |  | 導入... | 從RBF文件導入配方區。
 | 數據收集器 |  | 新增... | 在當前人機應用，新增數據收集器。
 |  |  | 屬性 | 選擇一數據收集器，並開啟其屬性對話框。
 |  |  | 刪除 | 刪除數據收集器。
 |  |  | 導出... | 開啟導出數據收集器屬性對話框。導出選定的數據收集區到DLF檔。
 |  |  | 導入... | 從DLF文檔件導入配方區 。
 | 操作記錄... |  |  | 開啟操作記錄對話框，用戶可以在此對話框設定當前人機應用的操作記 錄。
 | 排程... |  | 屬性 | 打開排程對話方塊，用戶可以在此對話方塊設定當前人機應用的排程。
 |  |  | 導出... | 導出排程到SCF文件。
 |  |  | 導入... | 從SCF文件導入排程。
 | 巨集 | 原生腳本 | 新增... | 在當前人機應用，新增原生腳本 。
 |  |  | 編輯 | 在當前人機應用，選擇欲編輯的原生腳本 。
 |  |  | 刪除 | 在當前人機應用，選擇欲刪除的原生腳本 。
 |  | VB腳本 | 新增... | 在當前人機應用，新增 VB腳本 。
 |  |  | 編輯 | 在當前人機應用，選擇欲編輯的 VB腳本 。
 |  |  | 刪除 | 在當前人機應用，選擇欲刪除的 VB腳本 。
 | 編譯... |  |  | 編譯當前人機應用，建立運行時的數據。用戶可以下載此數據到人機，人機將會依用戶所規劃的數據運行。
 | 產生人機運行包(PRP)檔案... |  |  | 產生當前人機應用的人機運行包檔案，PRP檔案包含運行數據和系統程式。用戶不需專案檔案，藉由下載PRP檔至人機，即可更新人機。人機亦可從USB儲存裝置讀取PRP檔更新。
 | 建立ROM圖像... |  |  | 當前應用程式生成的ROM檔。ROM燒錄檔包含運行時的資料和系統程式。可以更新自己的微型SD卡載入ROM燒錄檔。 本功能只有英文操作介面才提供。
 | 下載數據至觸控屏... |  |  | 下載數據到人機。
 | 上載數據至電腦... |  |  | 從人機上載數據至電腦。
 | 導出人機應用... |  |  | 導出當前人機應用至PLF檔。


工具選單

圖示 | 選單項目 | 彈出菜單項目 |  | 說明
 | 語言選擇 | 自動 |  | 當選擇此選項:
 |  |  |  | 作業系統預設語言 | 本軟體使用者介面所使用的語言
 |  |  |  | 中文(簡體) | 中文(簡體)
 |  |  |  | 中文(繁體) | 中文(繁體)
 |  |  |  | 其他 | 英文
 |  | 英文 |  | 選擇英文為本軟體使用者介面的預設語言。
 |  | 中文(簡體) |  | 選擇中文(簡體)為本軟體使用者介面的預設語言。
 |  | 中文(繁體) |  | 選擇中文(繁體)為本軟體使用者介面的預設語言。
 | 模擬運行(離線) |  |  | 在未連線狀態下，模擬運行當前人機應用。
 | 模擬運行(連線) |  |  | 在連線狀態下，模擬運行當前人機應用。
 | 設置穿透通訊 | 序列埠穿透 | 設置 | 開啟設置穿透通訊對話框。
 |  |  | 開始 | 開始穿透通訊。
 |  |  | 結束 | 結束穿透通訊。
 |  | 乙太網穿透 | 設置 | 開啟設置穿透通訊對話框。
 |  |  | 開始 | 開啟設置穿透通訊對話框。
 |  |  | 結束 | 結束穿透通訊。
 | 透過BIOS更新OS0 |  |  | 透過BIOS更新人機系統程式OS0。當人機的系統程式毀損時，可使用此項操作更新OS0，然後人機就可以正常使用了。
 | 導出文字... |  |  | 導出當前人機應用的文字為PTX檔。
 | 導入文字... |  |  | 導入PTX檔於選取的人機應用中。
 | TextEditor |  |  | 使用 TextEditor 程式編輯PTX檔案的文字。


視窗選單

圖示 | 選單項目 | 說明
 | 重疊顯示 | 安排視窗重疊顯示。
 | 垂直並排 | 安排視窗在不重疊下，垂直並排顯示。
 | 水平並排 | 安排視窗在不重疊下，水平並排顯示。
 | 安排圖示 | 安排圖示於視窗底部。
 | 復原 | 將視窗回復至原始的大小與位置。
 | 最大化 | 視窗最大化顯示。
 | 已開視窗清單 | 顯示已開啟的視窗抬頭清單。用戶可以點選視窗的抬頭，則該視窗會顯示於最上方。
 | Windows... | 開啟Windows對話框，從對話框中可選擇啟動、儲存或結束視窗。


說明選單

圖示 | 選單項目 | 說明
 | 搜尋 | 搜尋所想要搜查的內容，關鍵字和章節。
 | 內容 | 瀏覽內容總表和其說明文件，以及如何使用本軟體的詳細說明圖文。 總計包含有500多個主題和1000多個圖，採用 HTML格式。
 | 索引 | 您可以使用索引直接跳到特定的主題或是大多數常用的功能以及本軟體所提供的使用特點等。
 | 關於觸控大師... | 開啟關於觸控大師對話框，顯示本軟體的版本。
 | 新版本發行說明 | 本次發行的軟體版本跟上一版本之間的程式修正與功能改進，本說明文件對此提供詳細的說明。


標準工具列

圖示 | 工具提示 | 說明
 | 開新檔案 | 新建專案。
 | 開啟舊檔 | 開啟現有的專案。
 | 儲存檔案 | 儲存當前專案。
 | 剪下 | 剪下選取的內容，並暫時存放於剪貼簿。
 | 複製 | 複製選取的內容，並暫時存放於剪貼簿。
 | 貼上 | 將剪貼簿的內容置於當前畫面。
 | 復原 | 復原上一個動作。
 | 重做 | 重做前一個復原的動作。
 | 新增畫面 | 在當前人機應用，新建一個新畫面。
 | 畫面屬性 | 開啟當前畫面的畫面屬性對話框。
 | 前一畫面 | 使當前畫面的前一個畫面(以畫面編號計算)，為當前畫面。
 | 下一畫面 | 使當前畫面的下一個畫面(以畫面編號計算)，為當前畫面。
 | 放大 | 使畫面放大。
 | 縮小 | 使畫面縮小。
 | 正常大小 | 使畫面回復至正常大小。
 | 狀態0 | 顯示當前畫面中，全部物件的狀態0設定。
 | 狀態1 | 顯示當前畫面中，全部物件的狀態1設定。
 | 狀態 | 顯示當前畫面中，全部物件的狀態1設定。
 | 編譯 | 編譯當前人機應用，建立運行時的數據。用戶可以下載此數據到人機，人機將會依用戶所規劃的數據運行。
 | 下載 | 顯示下載視窗畫面，可以根據所需要的下載條件進行設置，然後下載數據至人機。
 | 立即下載 | 使用當前設定的下載條件，立即下載數據至人機。
 | 運行模擬(離線) | 在未連線狀態下，模擬運行當前人機應用。
 | 關於觸控大師 | 開啟關於觸控大師對話框。


物件工具列

圖示 | 工具提示 | 說明
 | 位按鈕 | 在畫面上放置預設位按鈕。
 | 字按鈕 | 在畫面上放置預設字按鈕。
 | 畫面按鈕 | 在畫面上放置預設畫面按鈕。
 | 選頁器 | 在畫面上放置預設選頁器。
 | 功能按鈕 | 在畫面上放置預設功能按鈕。
 | 鍵盤按鈕 | 在畫面上放置預設鍵盤按鈕。
 | 捲動按鈕 | 在畫面上放置預設捲動按鈕。
 | 捲動條 | 在畫面上放置預設捲動條。
 | 單選按鈕 | 在畫面上放置預設單選按鈕。
 | 步進按鈕 | 在畫面上放置預設步進按鈕。
 | 切換開關 | 在畫面上放置預設切換開關。
 | 多態按鈕 | 在畫面上放置預設多態按鈕。
 | 滑動類比開關 | 在畫面上放置預設滑動類比開關。
 | 數值輸入器 | 在畫面上放置預設數值輸入器。
 | ASCII 字符輸入器 | 在畫面上放置預設 ASCII 字符輸入器。
 | 進階數值顯示器 | 在畫面上放置預設進階數值顯示器。
 | 位指示燈 | 在畫面上放置預設位指示燈。
 | 多態指示燈 | 在畫面上放置預設多態指示燈。
 | 數值顯示器 | 在畫面上放置預設數值顯示器。
 | ASCII 字符顯示器 | 在畫面上放置預設 ASCII 字符顯示器。
 | 訊息顯示器 | 在畫面上放置預設訊息顯示器。
 | 時間顯示器 | 在畫面上放置預設時間顯示器。
 | 日期顯示器 | 在畫面上放置預設日期顯示器。
 | 週日顯示器 | 在畫面上放置預設週日顯示器。
 | 儀表 | 在畫面上放置預設儀表。
 | 動態圓 | 在畫面上放置預設動態圓。
 | 動態方塊 | 在畫面上放置預設動態方塊。
 | GIF顯示器 | 在畫面上放置預設GIF顯示器。
 | 圖片顯示器 | 在畫面上放置預設圖片顯示器。
 | 動畫 | 在畫面上放置預設動畫。
 | 路徑顯示器 | 在畫面上放置路徑顯示器 。
 | 管線 | 在畫面上放置預設管線。
 | 柱狀圖 | 在畫面上放置預設柱狀圖。
 | 曲線圖 | 在畫面上放置預設曲線圖。
 | 扇形圖 | 在畫面上放置預設扇形圖。
 | 曲線圖 | 在畫面上放置預設曲線圖。
 | 扇形圖 | 在畫面上放置預設扇形圖 。
 | 警報顯示器 | 在畫面上放置預設警報顯示器。
 | 歷史數據顯示器 | 在畫面上放置預設歷史趨勢圖。
 | 歷史訊息顯示器 | 在畫面上放置預設歷史訊息顯示器。
 | 歷史趨勢圖 | 在畫面上放置預設歷史趨勢圖。
 | 操作記錄顯示器 | 在畫面上放置預設操作記錄顯示器。
 | 單筆記錄曲線圖 | 在畫面上放置默認的單筆記錄曲線圖。
 | 歷史二維分佈圖 | 在畫面上放置默認的歷史二維圖。
 | 歷史雷達圖 | 在畫面上放置默認的歷史雷達圖。
 | 配方選擇器 | 在畫面上放置預設配方選擇器。
 | 配方表 | 在畫面上放置預設配方表。
 | 次連線表 | 在畫面上放置預設次連線表。
 | 排程設置表 | 在畫面上放置默認的排程設置表。
 | 窗口畫面顯示器 | 在畫面上放置默認的窗口畫面顯示器。
 | USB相機顯示器 | 在畫面上放置預設USB相機顯示器。


繪圖工具列

圖示 | 工具提示 | 說明
 | 符號 | 在畫面上放置預設的符號。
 | 線 | 在畫面上放置預設的線。
 | 水平線 | 在畫面上放置預設的水平線。
 | 垂直線 | 在畫面上放置預設的垂直線。
 | 連接線 | 在畫面上放置預設的連接線。
 | 矩形 | 在畫面上放置預設的矩形。
 | 圓角矩形 | 在畫面上放置預設的圓角矩形。
 | 截角矩形 | 在畫面上放置預設的截角矩形。
 | 多邊形 | 在畫面上放置預設的多邊形。
 | 圓 | 在畫面上放置預設的圓。
 | 橢圓 | 在畫面上放置預設的橢圓。
 | 弧 | 在畫面上放置預設的弧。
 | 扇形 | 在畫面上放置預設的扇形。
 | 表格 | 在畫面上放置預設的表格。
 | 刻度 | 在畫面上放置預設的刻度。
 | 文字 | 在畫面上放置預設的文字。
 | 圖片 | 在畫面上放置預設的圖片。
 | 符號樣式 | 在畫面上放置預設的符號樣式。
 | 線樣式 | 設定所選取的符號樣式。
 | 邊緣色 | 設定選取幾何圖形的邊緣色。
 | 背景色 | 設定選取幾何圖形的背景色。
 | 圖樣 | 設定選取幾何圖形的圖樣。
 | 前景/圖樣色 | 設定選取幾何圖的前景/圖樣色。


文字工具列

圖示 | 工具提示 | 說明
 | 文字種類 | 選擇文字種類。
 |  | 文字種類 | 說明
 |  | 內標示文字/其他文字 | 顯示於物件內的文字
 |  | 外標示文字 | 物件外標示的文字
 | 語言 | 選擇文字所使用的語言。
 | 字體 | 設定文字所使用的字體。
 | 大小 | 設定文字的大小。
 | 文字 | 在此欄位直接編輯文字內容。點擊 [image] 會切換到文字庫選單 [image] 。
 | 文字 | 在此欄位從下拉文字庫列表中選擇文字內容。點擊 [image] 編輯文字內容。
 | 文字顏色 | 選擇文字的顏色。
 | 背景顏色 | 選擇物件的背景顏色。
 | 文字居中 | 調整文字位置至物件中央。
 | 文字水平位置 | 調整文字在物件的水平位置。
 | 文字垂直位置 | 調整文字在物件的垂直位置。
 | 文字對左 | 使文字往左對齊。
 | 文字對中 | 使文字往中央對齊。
 | 文字對右 | 使文字往右對齊。
 | 外標示位置 | 改變外標示的位置。


編輯工具列

圖示 | 工具提示 | 說明
 | 對齊左邊 | 使選取物件的左邊對齊參考物件的左邊排列。所有物件水平地移動，與參考物件的左邊界對齊。
 | 對齊垂直中線 | 使選取物件的垂直中線對齊參考物件的垂直中線排列。所有物件水平地移動，與參考物件的垂直中線對齊。
 | 對齊右邊 | 使選取物件的右邊對齊參考物件的右邊排列。所有物件水平地移動，與參考物件的右邊界對齊。
 | 對齊上邊 | 使選取物件的上邊對齊參考物件的上邊排列。所有物件垂直地移動，與參考物件的上邊界對齊。
 | 對齊水平中線 | 使選取物件的水平中線對齊參考物件的水平中線排列。所有物件垂直地移動，與參考物件的水平中線對齊。
 | 對齊下邊 | 使選取物件的下邊對齊參考物件的下邊排列。所有物件垂直地移動，與參考物件的下邊界對齊。
 | 靠齊網格 | 設定物件是否靠齊網格排列。
 | 使同寬 | 使選取物件與參考物件同寬。
 | 使同高 | 使選取物件與參考物件同高。
 | 使同大小 | 使選取物件與參考物件同寬與同高。
 | 移左 | 使選取物件向左微移。當未勾選『靠齊網格』，所有選取的物件向左移動一圖元；當勾選『靠齊網格』，選取物件向左微移至最靠近物件左上角的網格。
 | 移右 | 使選取物件向右微移。當未勾選『靠齊網格』，所有選取的物件向右移動一圖元；當勾選『靠齊網格』，選取物件向右微移至最靠近物件左上角的網格。
 | 移上 | 使選取物件向上微移。當未勾選『靠齊網格』，所有選取的物件向上移動一圖元；當勾選『靠齊網格』，選取物件向上微移至最靠近物件左上角的網格。
 | 移下 | 使選取物件向下微移。當未勾選『靠齊網格』，所有選取的物件向下移動一圖元；當勾選『靠齊網格』，選取物件向下微移至最靠近物件左上角的網格。
 | 拿到最上層 | 將選取物件移至最上層。
 | 拿到上一層 | 將選取物件移至上一層。
 | 放到下一層 | 將選取物件移至下一層。
 | 放到最下層 | 將選取物件移至最下層。
 | 集群 | 將選取的物件集群。
 | 解散 | 解散選取的集群物件。
 | 釘住 | 釘住選取的物件，使物件無法被移動。
 | 放開 | 放開選取的物件，使物件可被移動。
 | 文字大小自動調整 | 設定文字大小是否跟隨物件框的大小自動調整。


地址工具列

圖示 | 工具提示 | 說明
 | 寫入地址 | 設定選取物件的寫入地址。
 | 讀取地址 | 設定選取物件的讀取地址。
 | 監視地址 | 設定選取物件的監視地址。


圖片工具列

圖示 | 工具提示 | 說明
 | 圖片名 | 用戶可以從下拉式清單中，選擇欲導入的圖片。
 | 從檔案導入圖片 | 選擇圖片檔案導入圖片。
 | 選取/導入圖庫內圖片 | 從軟體內建的圖片庫中，選擇欲導入的圖片。
 | 透明 | 設定圖片的部分是否透明顯示。圖片顏色為透明色的部份會透明顯示。
 | 透明色 | 設定一種顏色為透明色。
 | 旋轉/翻轉 | 選擇旋轉/翻轉圖片的方式。
 | 改變色調 | 選擇是否改變圖片的色調。
 | 色調 | 選擇改變色調後，選擇一個顏色為圖片的新色調。
 | 配合物件大小 | 縮放圖片使圖片與物件同大小。
 | 中心 | 調整圖片位置至物件中央。
 | 水平位置 | 調整圖片在物件的水平位置。
 | 垂直位置 | 調整圖片在物件的垂直位置。
 | 背景色 | 設定物件的背景色。


狀態列


專案管理員

專案管理員為一停靠式視窗(可獨立停靠在Window桌面操作的視窗)，將專案以樹狀圖呈現。欲開啟專案管理員，在『檢視選單』中，選擇專案管理員。以下為專案管理員的圖例，在此範例中，專案『MyProject 01』有兩個人機應用：人機應用_1和人機應用_2。

專案節點( )

專案節點的標示文字為專案的名稱，也是此專案存檔的名字，用戶可在專案節點上，進行以下的操作：

1)雙擊滑鼠左鍵，開啟專案資訊與保護對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目:

選單項目 | 說明
新增人機應用 | 新增人機應用。
導入人機應用… | 從檔導入人機應用。
資訊與保護 | 開啟專案資訊與保護對話框。
切換展開與收納 | 收納或展開全部已展開/收納的節點和子節點。

全局節點( )

全局節點有七個子節點，用戶可在全局節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。

語言節點( )

用戶可在語言節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟語言對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目:

選單項目 | 說明
屬性 | 開啟語言屬性對話框。

字體範本節點( )

用戶可在字體範本節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟字體範本對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目

選單項目 | 說明
屬性 | 開啟字體範本屬性對話框。

圖片資料庫節點( )

用戶可在圖片資料庫節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟圖片資料庫對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目

選單項目 | 說明
屬性 | 開啟圖片資料庫屬性對話框。

聲音庫節點( )

用戶可在聲音庫節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟聲音庫對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項

選單項目 | 說明
屬性 | 開啟聲音庫屬性對話框。

文字庫節點( )

用戶可在文字庫節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟文字庫對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目

選單項目 | 說明
開啟 | 開啟文字庫視窗。

全局標籤節點( )

用戶可在全局標籤節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟全局標籤視窗。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目

選單項目 | 說明
開啟 | 開啟全局標籤視窗。

全局巨集節點( )

全局巨集節點包含兩種全局巨集節點:全局原生腳本集節點和全局VB腳本節點。用戶可在全局巨集節點上，進行以下的操 作：
1)雙擊滑鼠左鍵，可展開或收納子節點。

全局原生腳本集節點( )

全局原生腳本(巨集)集節點包含許多全局巨集子節點。每一個全局巨集節點對應專案中的全局巨集，用戶可在全局巨集節點上，進行以下的操作：

1)雙擊滑鼠左鍵，可展開或收納子節點。
2)點擊滑鼠右鍵，彈出選單中出現以下選項：

選單項目 | 說明
添加腳本 | 新增全局原生腳本(巨集)。
輸入腳本 | 從MCR檔或是TXT文本檔導入腳本程式。
按名稱排序 | 按腳本名稱排序腳本子節點清單。

全局原生腳本子節點( )

每一個全局原生腳本子節點對應專案中的全局巨集，用戶可在全局巨集子節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟巨集編輯視窗。
2)點擊滑鼠右鍵，彈出選單中出現以下選項

選單項目 | 說明
開啟 | 開啟巨集的編輯視窗。
關閉 | 關閉巨集的編輯視窗。
更名 | 更改巨集名稱。
刪除 | 刪除巨集。
輸出腳本 | 導出巨集為MCR檔或是TXT文本檔。
參加保護 | 添加巨集到巨集保護列表。
退出保護 | 從巨集保護列表中移除巨集。
啟動保護 | 啟用保護。
停止保護 | 停止保護。

人機應用節點( )

人機應用節點的標籤為關聯人機應用的名稱，用戶可在人機應用節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟人機應用一般設置視窗。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
更名 | 更改人機應用名稱。
刪除 | 刪除人機應用。
人機應用一般設置 | 開啟人機應用一般設置對話框。
導出人機應用 | 導出人機應用為 PLF 檔。
切換展開與收納 | 收納/展開全部已展開/收納的子節點。
向上移動 | 向上移動非頂端人機應用。
向下移動 | 向下移動非底部人機應用。

連線節點( )

連線節點支援1個內部記憶區子節點以及最多16個連線子節點。用戶可在連線節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
新增連線 | 新增通訊連線。
通訊驅動程式一覽表… | 開啟通訊驅動程式一覽表對話框，顯示人機所支援的所有通訊驅動。用戶可使用此對話框，導出通訊驅動一覽表為 csv 檔。

內部記憶區節點( )

用戶可在內部記憶區節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟內部記憶區對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選項：

選單項目 | 說明
屬性 | 開啟內部記憶區對話框。

連線節點( )

連線節點對應人機應用的一個通訊連線，用戶可在連線節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟關聯連線的連線屬性對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
更名 | 更改連線名稱。
刪除 | 刪除連線。
屬性 | 開啟連線屬性對話框。

標籤節點( )

用戶可在標籤節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟標籤視窗。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
開啟 | 開啟標籤視窗。

聲音表節點( )

用戶可在聲音表節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟聲音表對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 開啟聲音表對話框。

設置節點( )

設置節點共有四個子節點，用戶可在設置節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。

人機應用一般設置節點( )

用戶可在人機應用一般設置節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟人機應用一般設置對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 開啟人機應用一般設置屬性對話框。

命令與狀態節點( )

用戶可在命令與狀態節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟命令與狀態對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 開啟命令與狀態對話框。

時鐘節點( )

用戶可在時鐘節點上，進行以下的操作：

1)雙擊滑鼠左鍵，開啟時鐘對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 開啟時鐘對話框。

密碼節點( )

用戶可在密碼節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟密碼對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 開啟密碼對話框。

畫面節點( )

畫面節點包含多個畫面子節點。每一個畫面子節點對應人機應用的畫面，用戶可在畫面節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。
2)點擊滑鼠右鍵，彈出選單中出現以下選項：

選單項目 | 說明
新增畫面 | 新增畫面。
導入畫面 | 從SNF檔導入畫面。
按名稱排序 | 按畫面名稱排序畫面子節點清單。
按編號排序 | 按畫面編號排序畫面子節點清單。
關閉全部畫面 | 關閉全部開啟的畫面。
儲存畫面成圖片 | 開啟『儲存畫面成圖片』對話框。在對話框中，用戶可以儲存選取的畫面為圖片檔。

畫面子節點( )

每一個畫面子節點對應人機應用的畫面，用戶可在畫面子節點上，進行以下的操作：
1)雙擊滑鼠左鍵，若畫面尚未開啟，則開啟此畫面。
2)雙擊滑鼠左鍵，若畫面已開啟，則開啟畫面屬性對話框。
3):點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
開啟 | 開啟畫面。
刪除 | 刪除畫面。
屬性 | 開啟畫面屬性對話框。
導出畫面 | 導出畫面為SNF檔。
參加保護 | 添加畫面到畫面保護列表。
退出保護 | 從保護列表的中移除畫面保護。
啟動保護 | 啟用畫面保護。
停止保護 | 停止畫面保護。

警報節點(( )

警報節點包含多個數位警報區和類比警報區子節點，用戶可在警報節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟警報屬性對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明說明
新增數位警報區 | 新增數位警報區。
新增類比警報區 | 新增類比警報區。
屬性 | 開啟警報屬性對話框。
導出警報區 | 導出報警區到CSV或XML文件。
導入警報區 | 從 CSV或XML 檔導入警報區。

數位警報區節點( )

每一個數位警報區節點對應一個人機應用中的數位警報區，用戶可在數位警報區節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟關聯數位警報區的屬性對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
刪除 | 刪除警報區。
屬性 | 開啟數位警報區屬性對話框。

類比警報區節點( )

每一個類比警報區節點對應一個人機應用中的類比警報區，用戶可在類比警報區節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟關聯類比警報區的屬性對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
刪除 | 刪除警報區。
屬性 | 開啟類比警報區對話框。

配方節點( )

配方節點包含多個配方區子節點，每一個配方區子節點對應到人機應用的配方區，用戶可在配方節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
新增配方區 | 新增配方區。
導出… | 開啟導出配方區對話框。選擇需要導出的配方區。
導入… | 從RBF檔導入配方區。

配方區節點( )

配方區子節點對應人機應用的配方區，用戶可在配方區節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟關聯配方區的屬性對話框。
2):點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
刪除 | 刪除配方區。
屬性 | 開啟配方區屬性對話框。

數據收集器節點( )

數據收集器節點包含多個數據收集器子節點。每一個數據收集器子節點對應到人機 應用中的數據收集器，用戶可在數據收集器子節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。
2):點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
新增數據收集器 | 新增數據收集器。
導出… | 開啟導出歷史數據對話框，選擇需要導出的歷史數據到DLF檔。
導入… | 從DLF檔導入歷史數據。

數據收集器子節點( )

每一個數據收集器子節點對應到人機應用中的數據收集器，用戶可在數據收集器子節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟數據收集器對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
刪除 | 刪除數據收集器。
屬性 | 開啟數據收集器屬性對話框。

操作記錄節點( )

用戶可在操作記錄節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟操作記錄屬性對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 開啟操作記錄屬性對話框。

排程節點( )

用戶可在排程節點上，進行以下的操作：
1)雙擊滑鼠左鍵，打開排程屬性對話框。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
屬性 | 打開排程屬性對話框。
導出… | 導出排程到SCF檔。
導入… | 從SCF檔導入排程。

巨集節點( )

本地巨集節點包含兩種巨集節點: 本地原生腳本集節點和VB腳本節點，本地巨集節點包含多個巨集子節點。每一個巨集子節點可對應到人機應用的巨集。用戶可在巨集節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。

原生腳本集節點( )

原生腳本集節點包含許多巨集子節點。每一個巨集子節點對應專案中的巨集，用戶可在原生腳本集節點上，進行以下的操作：
1)雙擊滑鼠左鍵，可展開或收納子節點。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
添加本地腳本 | 新建本地腳本(巨集)。
輸入腳本 | 從MCR檔或TXT文字檔導入腳本(巨集)。
按名稱排序 | 按腳本名稱排序腳本子節點清單。

原生腳本子節點( )

每一個原生腳本(巨集)子節點可對應到人機應用的巨集，用戶可在原生腳本(巨集)子節點上，進行以下的操作：
1)雙擊滑鼠左鍵，開啟巨集編輯視窗。
2)點擊滑鼠右鍵，彈出選單中出現以下選單項目：

選單項目 | 說明
開啟 | 開啟巨集編輯視窗。
關閉 | 關閉巨集編輯視窗。
更名 | 更改巨集名稱。
刪除 | 刪除巨集。
輸出腳本 | 導出腳本巨集到 MCR 檔或 TXT 檔。
參加保護 | 添加巨集到保護列表。
退出保護 | 從保護列表中移除巨集。
啟動保護 | 啟用保護。
停止保護 | 停止保護。


畫面管理員

畫面管理員為可獨立停靠在window桌面操作的視窗，可使用戶更有效率地管理專案畫面。欲開啟畫面管理員，在『檢視選單』中，選擇畫面管理員。以下為專案“AP_1”的畫面管理員圖例，顯示此人機應用的畫面列表清單。

以下的範例為略縮圖顯示的畫面管理員 。

用戶可以在畫面管理員上點擊滑鼠右鍵，所出現的彈出式選單，將顯示以下的選單項目：

圖示 | 選單項目 | 說明
 | 新畫面 | 在當前人機應用新增畫面。
 | 開啟畫面 | 開啟選取的畫面。
 | 剪下畫面 | 剪下選取的畫面，並暫時存放於剪貼簿。
 | 複製畫面 | 複製選取的畫面並放置於剪貼簿。
 | 貼上畫面 | 於當前人機應用，插入剪貼簿中的畫面。
 | 刪除畫面 | 刪除選取的畫面。
 | 導出畫面 | 導出選取的畫面到檔案。
 | 導入畫面 | 從檔案導入畫面到當前人機應用。
 | 參加保護 | 添加畫面到畫面保護列表。
 | 退出保護 | 從保護列表中移除畫面保護。
 | 啟動保護 | 開啟畫面保護。
 | 停止保護 | 停止畫面保護。
 | 畫面屬性 | 開啟選取畫面的畫面屬性對話框。


物件彈出式選單

所有物件適用

圖示 | 選單項目 | 快捷鍵 | 說明
 | 剪下 | Ctrl+V | 剪下選取的部分，並暫時存放於剪貼簿。
 | 複製 | Ctrl+C | 複製選取的部分，並暫時存放於剪貼簿。
 | 貼上 | Ctrl+V | 在當前畫面，貼上剪貼簿的內容。
 | 刪除 | Del | 刪除選取的部份。
 | 釘住 |  | 釘住選取的物件，使物件無法被移動。
 | 放開 |  | 放開選取的物件，使釘住的物件可移動。
 | 多重複製... |  | 多重複製選取的物件。
 | 拿到最上層 |  | 將選取的物件移到最上層。
 | 拿到上一層 |  | 將選取物件上移一層。
 | 放到下一層 |  | 將選取物件上移下一層。
 | 放到最下層 |  | 將選取的物件移到最下層。
 | 物件屬性… |  | 開啟選取物件的屬性對話框。
 | 存為預設值 |  | 將所選取之物件儲存為此類物件的預設格式，預設物件儲存在物件庫的物件目錄下。
 | 存到物件庫... |  | 儲存選取物件到物件庫。
 | 存為全局物件... |  | 儲存選取物件為全局物件，儲存在物件庫的全局目錄下。全局物件可被全局物件副本使用。
 | 存當前畫面爲圖片檔 |  | 儲存當前畫面爲圖片。
 | 畫面屬性 |  | 開啟選取畫面的屬性對話框。

連接線與多邊形適用

選單項目 | 說明
插入點 | 在指定的線上位置插入點。
刪除點 | 刪除選取的點。

管線適用

選單項目 | 說明
插入接頭 | 在指定的位置插入接頭。如果指定的位置在垂直管線上，則可新增左、右或十字接頭；如果指定的位置在水平管線上，則可新增上、下或十字接頭。
刪除接頭 | 刪除接頭與管線。


畫面彈出式選單

圖示 | 選單項目 | 說明
 | 關閉畫面 | 關閉當前畫面。
 | 剪下畫面 | 剪下當前畫面，並暫時存放於剪貼簿。
 | 複製畫面 | 複製當前畫面，並放置於剪貼簿。
 | 貼上畫面 | 於當前人機應用，插入黏貼於剪貼簿中的畫面。
 | 刪除畫面 | 刪除當前畫面。
 | 存當前畫面為圖片檔... | 儲存當前畫面為圖片檔。
 | 畫面屬性 | 開啟當前畫面的畫面屬性對話框。


專案資訊與保護

用戶可使用專案資訊與保護對話框取得專案資訊，並設定密碼，保護專案檔案、畫面、密碼表和巨集。

欲開啟對話框，方法如下：
1)在專案管理員視窗中，在專案節點( [image] )上，雙擊滑鼠左鍵。
2)在主選單中，點擊“專案”，從彈出的選單中，點擊“資訊與保護...”。

下圖為專案資訊與保護的範例。

下表說明如何讀取和使用專案資訊與保護對話框中的項目。

項目 |  | 說明
專案名稱 |  | 顯示專案名稱，亦是專案的檔案名稱。
開發者 |  | 專案的開發者。
初始建立時間 |  | 專案初始建立的時間。
上次修改時間 |  | 專案最後修改儲存的時間。
版本 |  | 本軟體最後儲存專案時的版本。
開發者密碼 |  | 點擊此按鈕，將出現編輯開發者密碼對話框，可設定開發者密碼。 開發者密碼須為正整數，最多可輸入9位數字。新的專案和人機，其預設的開發者密碼為000000000(9個0)。當用戶要下載新運行數據到人機，人機將比較其本身的開發者密碼(下載目標的人機)與軟體要下載的新應用的開發者密碼，如果兩者密碼相同，則人機將立即進行下載；若兩者密碼不同，則人機將要求輸入軟體要下載的新應用的開發者密碼，這是為了確保用戶有權利使用運行數據。在輸入人機應用的開發者密碼後，人機開始下載運行數據，並以新人機應用的開發者密碼為目標人機的開發者密碼。點擊此按鈕，將出現編輯開發者密碼對話框，可設定開發者密碼。
自動恢復檔案 |  | 勾選此處可啟用或者停止檔案備份功能。指定保留備份自動檔案恢復的保存間隔（最多60分鐘）和備份時間（最多30天）。自動備份功能軟件默認是勾選的。如果用戶電腦帶有自動恢復數據功能，可手動取消該項功能。 自動恢復檔案是一個可以自動創建備份未保存的專案檔案功能。如果軟體操作崩潰或斷電丟失或意外關閉您的專案，這種備份的檔案可以被用來重建未保存的畫面資料，減少工作損失。重新打開人機編輯軟體，選擇恢復的檔案或備份數據。 用戶可指定自動備份檔案的間隔時間。此處“5”表示：每隔五分鐘會創建一個檔案備份。這就表示如果軟件意外關閉，用戶最多失去最近五分鐘工作的內容。如果用戶在短時間內改變程序的內容過多，建議調低該值。 指定備份檔案保留的時間。此處“10”表示檔案備份保留時間為10天，超過10天軟件將自動清除且不能再恢復數據。如果用戶需要保留備份時間比較長，建議調大該值。 檔案備份儲存位置:通常用戶不需要直接查看備份檔案。如果你需要查看，他們可以在DocumentsandSettings\Administrator的 檔案夾中查找。請在軟體安裝的相同名的檔案夾的Backup子檔案夾中可以找到相關的自動備份的檔案。 註：不要使用本功能作為替代定期保存你的程序，您還是要正常使用標準工具欄上單擊“ [image] 保存”功能去保存你的專案應用程序。
保護設置 | 項目 | 可被保護的項目，其中包括專案檔案，密碼表，巨集，畫面和PC圖控(組態)。
 | 保護 | 選中或取消選中此選項，可啟用或禁用相應的項目的保護。您需要輸入指定的密碼才能打開相應的選中項目。 用下面任意一種方式都可以保護任意的應用巨集: 1)禁止閱讀-巨集是不可見。當然也就不能編輯修改。 2)只讀-巨集是可見的，但不能編輯修改。 註：要停止保護，您需要在下面的對話框中輸入原密碼。
 | 使用開發者密碼 | 選中此選項，直接使用開發者密碼當保護密碼 。 註：在開發者密碼和使用指定的密碼之間切換，你需要打開密碼表進行設置。
 | 使用指定的密碼 | 當不勾選“使用開發者密碼”欄位，此選項才會出現。勾選使用指定的密碼就能進行編輯此新的保護密碼。 註：使用指定的密碼最多可以有12個字符，區分大小寫。
 | 工具 | 保留功能尚未實現。
註 |  | 可輸入專案說明文字。
確定 |  | 點擊此按鈕，關閉對話框，並接受所有改變的設定。
取消 |  | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。
 |  | 點擊此處，開啟說明檔案，提供更多關於此對話框的訊息與使用的方法。
 |  | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。


全局設定

在同一專案的多個人機應用設計中，均適用的設定即為全局設定。在專案主選單中即可進行全局設定。全局設定可使開發者建立一個具有彈性且容易更新的專案，開發者只需修改全局設定即可更新專案中所有人機應用的設定。

 用戶可以在關聯的對話框中完成所有的全局設定。欲開啟對話框，用戶可在專案管理員視窗的全局節點上各項關聯節點上，雙擊滑鼠左鍵；或點擊“專案”主選單，從彈出的次選單中，點擊相關的指令。

 全局設定包含以下項目。

■ 語言
詳閱 章節2.2.1 說明

■ 字體模板
詳閱 章節2.2.2 說明

■ 圖片資料庫
詳閱 章節2.2.3 說明

■ 聲音庫
 詳閱 章節2.2.4 說明

■ 文字庫
詳閱 章節2.2.5 說明

■ 全局標籤
詳閱 章節2.3 說明

■ 全局巨集
詳閱 第15章 說明


2.2.1 語言

語言

本章節說明如何在語言對話框中，設定專案的語言。專案中的每個人機應用最多可包含10種語言。下圖為語言對話框的範例。

下表為語言對話框中，各項屬性的說明。

項目 | 說明
語言總數 | 設定本專案可使用的語言總數。
語言 | 語言的編號。
名稱 | 設定語言的名稱，同一專案中的語言名稱不能重複。
字集 | 設定語言的字集，以決定轉換文字的位元組為畫面上的字元的方式。
導入... | 點擊此按鈕，從LNG檔導入語言設定。
導出... | 點擊此按鈕，導出語言設定為LNG檔。
確定 | 點擊此按鈕，關閉對話框，並儲存所有變更的設定。
取消 | 點擊此按鈕，關閉對話框，並放棄所有變更的設定。
 | 點擊此處，開啟說明文件，提供更多關於此對話框的訊息與使用的方法。
 | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。


2.2.2 字體模板

字體模板

下圖為字體模板對話框的範例。

下表為字體模板對話框中，各項屬性功能及使用的說明。

項目 |  |  | 說明
語言 |  |  | 設定本字體模板欲使用的對應語言。
模板清單 |  |  | 顯示所選取語言的字體模板清單。用戶可點選一模板為當前模板。
當前模板 | 名稱 |  | 當前清單上所選的字體模板名稱。
 |  |  | 點擊此按鈕，使用新設定更新選取的字體模板。
 | 視窗字體 |  | 設定當前字體模板的字體。
 | 字體樣式 |  | 設定當前字體模板的字體樣式。
 | 大小 |  | 設定當前字體模板的字體大小。
 | 效果 | 底線 | 勾選當前字體模版是否增加底線。
 |  | 刪除線 | 勾選當前字體模版是否增加刪除線。
 | 例子 |  | 展示當前字體。
導入... |  |  | 點擊此按鈕，從FTF檔導入字體模板設定。
導出... |  |  | 點擊此按鈕，導出字體模板為FTF檔。
確定 |  |  | 點擊此按鈕，關閉對話框，並儲存所有變更的設定。
取消 |  |  | 點擊此按鈕，關閉對話框，並放棄所有變更的設定。
 |  |  | 點擊此處，開啟說明文件，提供更多關於此對話框的訊息與使用的方法。
 |  |  | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。


2.2.3 圖片資料庫

圖片資料庫

圖片資料庫包含專案中使用的所有圖片，專案新建時的圖片資料庫為空白。


2.2.3.1 導入和導出圖片

導入和導出圖片

■ 導入圖片

用戶需先導入圖片，才可在專案中使用此圖片，共有5種導入圖片的方法，如下：

1)使用圖片資料庫對話框，一次可導入一個圖片檔。可導入的圖片檔案格式包含：BMP、JPG(JPEG)、GIF、WMF、PNG和SVG(Scalable Vector Graphics)。
2)使用圖片資料庫對話框，從PDB檔一次導入多張圖片。
3)使用圖片資料庫對話框，從檔案總管(WindowsExplorer)中拖拉圖片至圖片資料庫清單，導入一張或多張圖片。
4)當用戶已在對話框或屬性表中設定圖片，點擊 [image] 圖示，可選擇並導入此圖片檔。
5)當用戶已在對話框或屬性表中設定圖片，點擊 [image] 圖示，可從圖片資料庫，選擇並導入此圖片檔。

■ 導出圖片

用戶可導出專案中的圖片，使其他的專案可導入此圖片使用，共有2種導出圖片的方法，如下：

1)使用圖片資料庫對話框，一次導出一張圖片。
2)使用圖片資料庫對話框，一次可將多張圖片導出到PDB圖庫檔。


2.2.3.2 圖片群

圖片群

圖片資料庫可建立多個圖片群。

圖片群為多張圖片的集合。圖片群中的每一張圖片代表一種狀態，當設定圖片群作為某個物件的圖片外型，則將自動將個別圖片作為該物件各狀態(S0,S1..Sn)的顯示圖片。

使用圖片群最大的好處在於，可用個別圖片顯示物件的對應狀態。

當按鈕或切換開關使用圖片群作為外型，若用戶想使按鈕按壓時的外觀改變，每一個狀態需有兩張圖片，一張圖片為正常(釋放鍵時)狀態；另一張圖片為觸摸狀態。

例如，包含3個狀態的多態按鈕，若需顯示觸摸狀態，圖片群需6張圖片作為圖片外型。

下表為支援3個狀態的圖片群組和觸摸狀態的範例。

圖片群 | 狀態 | 圖片
 | 0(正常/釋放) |
 | 0(觸摸) |
 | 1(正常/釋放) |
 | 1(觸摸) |
 | 2(正常/釋放) |
 | 2(觸摸) |


2.2.3.3 圖片資料庫對話框

圖片資料庫對話框

下圖為圖片資料庫對話框的範例。

下表為圖片資料庫對話框中，各項屬性功能及使用的說明。

項目 | 說明
 | 點擊此處，開啟說明文件，提供更多關於此對話框的訊息與使用的方法。
 | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。
圖片 | 列出專案的圖片和圖片群。用戶可選擇一圖片/圖片群為當前圖片/圖片群，也可同時選擇多個圖片/圖片群。
確定 | 點擊此按鈕，關閉對話框，並儲存所有改變的設定。
取消 | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。
導入... | 從圖片檔導入圖片，可導入的圖片檔格式包含：BMP、JPG、GIF、WMF、PNG和SVG。
從圖片導入... | 從圖庫PDB檔導入圖片。
導出... | 將當前圖片導出為圖片檔。
導出到圖庫... | 導出當前圖片/圖片群為圖庫PDB檔。
加群 | 新增一圖片群到圖片資料庫。
加項 | 從圖片檔導入圖片並將此圖片新增到當前圖片群。
從圖庫加項... | 從圖庫PDB檔導入圖片並將這些圖片新增到當前圖片群。
上移 | 將選取的圖片/圖片群在清單中上移。
下移 | 將選取的圖片/圖片群在清單中下移。
刪除 | 刪除所選取的圖片/圖片群。
運行顏色轉換 | 選擇遞色處理或近似顏色為顏色轉換的方式。 當圖片的顏色解析度與人機不一致，人機將使用設定的轉換方式，使運行時人機所顯示的顏色不會產生過度的扭曲。
含觸摸狀態 | 當已勾選圖片群，此屬性才會出現。勾選此項目，當前圖片群組包含觸摸狀態。當圖片群組含觸摸狀態，每個狀態需兩張圖片，一張圖片為正常(釋放鍵時)狀態；另一張圖片為觸摸狀態。
透明 | 勾選所選取的圖片/圖片群是否顯示透明外型。若選取圖片，圖片與透明色相同的部分將為透明；若選取圖片群組，圖片群組中所有圖片與透明色相同的部分將為透明。注意，只有當圖片/圖片群作為物件的圖片外型時，此屬性才有效。 一般常利用透明屬性，顯示圖片為非矩形的外型，範例如下：
 | 原始圖片 | 透明色 | 圖片顯示
透明色 | 當勾選“透明”，此選項才會出現。從色盤選擇一種顏色為透明色。
更名 | 點擊此按鈕，更改當前圖片/圖片群名稱。
旋轉/翻轉 | 旋轉/翻轉當前圖片並將翻轉後的圖片另存新檔。 旋轉/翻轉的方式共有下面七種，如下：
 | 方式 | 說明
 | Rotate90° | 圖片順時針旋轉90度。
 | Rotate180° | 圖片順時針旋轉180度。
 | Rotate270° | 圖片順時針旋轉270度。
 | FlipX | 圖片沿X軸翻轉。
 | Rotate90°&FlipX | 圖片順時針旋轉90度並沿X軸翻轉。
 | FlipY | 圖片沿Y軸翻轉。
 | Rotate90°&FlipY | 圖片順時針旋轉90度並沿Y軸翻轉。


2.2.4 聲音庫

聲音庫

聲音庫包含專案中所使用的所有聲音，專案新建時的聲音庫為空白。目前，只有當選擇人機為PC運行(組態)和支援聲音輸出的人機才能支援聲音的使用。

用戶可使用功能按鈕播放/停止聲音，詳細說明，請參考 章節5.4.1功能按鈕-基本功能 。

用戶可使用執行通用命令($C2.f)播放聲音，詳細說明，請參考 章節3.6.7使用通用命令 。


2.2.4.1 導入和導出聲音

導入和導出聲音

■ 導入聲音

用戶欲在專案中使用聲音，須先將聲音導入，方法如下：

  1. 使用聲音庫對話框，從聲音檔一次導入一個聲音。可導入的聲音格式為：WAV。
  2. 使用聲音庫對話框，從SDB檔一次導入多個聲音。

■ 導出聲音

用戶可將專案中的聲音導出，將聲音導入其他專案中使用：

  1. 使用聲音庫對話框，導出聲音為聲音檔。
  2. 使用聲音庫對話框，導出多個聲音為SDB檔。


2.2.4.2 聲音庫對話框

聲音庫對話框

下圖為聲音庫對話框的範例。

下表為對話框中，各項屬性功能及使用的說明。

項目 | 說明
 | 點擊此處，開啟說明文件，提供更多關於此對話框的訊息與使用的方法。
 | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。
聲音 | 顯示專案中聲音檔的清單。用戶可以選擇一聲音為當前聲音，也可同時選擇多個聲音。
聲音資訊 | 顯示當前聲音的長度與格式等資訊。 用戶可點擊 [image] 圖示，播放聲音；點擊 [image] 圖示，暫停播放聲音；點擊 [image] 圖示，停止播放聲音。
確定 | 點擊此按鈕，關閉對話框，並儲存所有改變的設定。
取消 | 點擊此按鈕，關閉對話框，並放棄所有改變的設定。
導入... | 從聲音檔導入聲音，可導入的聲音檔包含：WAV,MP3,MIDI。
從聲音庫導入... | 從聲音庫SDB檔導入聲音。
導出... | 導出當前聲音到聲音檔。
導出到聲音庫... | 導出當前聲音到聲音庫SDB檔。
更名 | 點擊此按鈕，更改當前聲音名稱。
刪除 | 刪除選取的聲音。
上移 | 將所選聲音上移。
下移 | 將所選聲音下移。


2.2.5 文字庫

文字庫

文字庫為可獨立停靠在Windows桌面操作的視窗。使用文字庫，用戶即可輕鬆地管理專案中多種語言的文字。欲開啟對話框，可在專案主選單中，勾選文字庫選項或在專案管理員視窗中，雙擊文字庫操作選項。

下圖為文字庫的範例，可列出專案中所有語言的文字。

用戶可點擊以下圖示，從彈出的對話框中導入/導出文字。

圖標 | 功能 | 說明
 | 導入文字表 | 從文字檔(.txt)導入文字到所選取的表格。
 | 導出文字表 | 將文字從選取表格導出到文字檔(.txt)。
 | 導入人機應用文字 | 從選取表格導入文字到相同專案的人機應用。
 | 導出人機應用文字 | 從人機應用導出文字到選取的表格。

用戶可在文字庫上點擊滑鼠右鍵，彈出的選單將包含以下項目：

選單項目 | 說明
剪下 | 剪下選取文字並暫存於剪貼簿。
複製 | 複製選取的文字並暫存於剪貼簿。
貼上 | 插入剪貼簿上的文字於當前表格。
刪除 | 刪除選取的文字。
<語言名稱> | 勾選語言名稱，物件的文字將以該語言顯示。


2.3 使用標簽

使用標簽

標籤代表一個由系統監視或控制的輸入/輸出地址或是變數記憶區塊，標籤可以是單一標籤或陣列標籤也可以是結構標籤。只要更改標籤，用戶即可使用任何PLC或控制器，無須重新規劃人機應用。本章節將說明如何使用標籤編輯器。

在標籤編輯器中建立標籤後，用戶可以在選取標籤對話框中使用標籤。詳細說明，請參考 章節4.4.3.3選取標籤 。或者，用戶可自己設定標籤。

注意，標籤/標籤群的名稱，最長為48字元。用戶可定義連線的標籤及標籤群。


2.3.1 標簽種類

標簽種類

在本軟體中，有兩種標籤屬性：全局標籤和本地標籤。並且分為三種類型：單個標籤，陣列標籤，和結構標籤。

■ 全局標籤
全局標籤為可被專案中所有人機應用使用的標籤。使用全局標籤，專案中的人機應用即可共用標籤地址，無須在個別人機應用的標籤中設定地址。

註：全局標籤只可對應到內部變數連結。

■ 本地標籤
本地標籤為只可被標籤所在人機應用所使用。

■ 單個標籤

單個標籤代表一個由系統監控或控制單一的輸入或輸出變數。標籤的格式是連線編號\標籤群名稱\子標籤群名稱\標籤名稱。

範例：

標籤 | 說明
1\MONITOR\COREDISPLAY | 表示連線1，標籤群MONITOR中的標籤COREDISPLAY。
0\BOT\DECLARE | 0表示內部記憶區，標籤群BOT中的標籤DECLARE。
0\_ALARMSHOW | 0表示內部記憶區，"_"表示全局標籤，標籤_ALARMSHOW。

■ 陣列標籤

陣列變量代表一個連續的存儲區，它包含具有相同的數據類型的一個或多個變量。陣列中的每個變量都可作為從陣列起點位置偏移的零基準被訪問。一維陣列標籤格式有連線編號\標籤群名稱\子標籤群名稱\標籤名稱[索引]。二維陣列標籤格式有連線編號\標籤群名稱\子標籤群名稱\標籤名稱[行，列]。三維陣列標籤格式有連線編號\標籤群名稱\子標籤群名稱\標籤名稱[索引，行，列]。

範例：

標籤 | 說明
TANK[5] | 表示內部記憶區的本地一維陣列標籤6號變量被命名為TANK。
1\FLAG[1,2]
表示連線1的一個本地二維陣列標籤9號變量被命名為FLAG，16位正整數[3，6].
註：在一個陣列中變量編號=[（行*列）+當前列+1]=1*6+2+1=9。
_Temp[1,0,2] 表示內部記憶區的一個全局三維陣列標籤的第23號變量被命名為Temp，16位正整數[3.5.4]。
註：在一個陣列中變量編號=[（當前指數*行*總列）+（當前行*列）+1]=1*5*4+0*4+2+1=23。

■ 結構標籤

結構標籤提供了一種方法來容納多個變量為一個區，該區的使用方法請參照單個標籤。每個變量可以是軟件支持的任何有效數據類型。
結構標籤的格式有連線編號\標籤群名稱\子標籤群名稱\結構標籤名稱.標籤名稱。

範例：

標籤 | 說明
0\Valve_1.Position | 表示內部記憶區的本地結構標籤名為Valve_1，其內部的成員標籤名為Position。


2.3.2 開啓/關閉標籤編輯器

開啓/關閉標籤編輯器

■ 開啟標籤編輯器

欲開啟全局標籤編輯器，在專案選單中，點擊“全局標籤...”指令，或在專案管理員視窗，全局>全局標籤上點擊滑鼠右鍵，從彈出視窗中，點擊開啟。

欲開啟本地標籤編輯器，在人機應用選單中，點擊“標籤...”指令，或在專案管理員視窗，人機應用>標籤上點擊滑鼠右鍵，從彈出視窗中，點擊開啟。

■ 關閉標籤編輯器

欲關閉標籤編輯器，選擇視窗並點擊關閉按鈕，或在視窗主選單中，選擇視窗...，從對話框中，選擇欲關閉的視窗。用戶可以在專案管理員視窗中，在全局>全局標籤(人機應用>標籤)項目，點擊滑鼠右鍵，從彈出的選單中，選擇關閉指令，關閉全局/本地標籤編輯器。


2.3.3 使用標籤編輯器建立標籤

使用標籤編輯器建立標籤

用戶可使用標籤編輯器建立及管理標籤。標籤編輯器可分成兩個部分：左半部為標籤群瀏覽器(TagGroupExplorer)，右半部為標籤清單視窗(TagListWindow)。兩部份可個別水平/垂直捲動內容，用戶可將滑鼠移至視窗中間的垂直分隔線，拖拉調整兩部分的相對大小。

下圖為視窗編輯器的範例。


2.3.3.1 標籤群瀏覽器

標籤群瀏覽器

標籤群瀏覽器顯示連線、配方、數據收集器和標籤群。標籤瀏覽器可進行以下操作：

■點擊連線節點，可開啟並編輯一個連線(Link)的標籤群。

■雙擊節點展開或折疊子組的列表。

■右鍵單擊節點得到一個彈出式菜單，菜單項如下：

圖示 | 選單項目 | 說明
 | 添加群 | 創建一個新群，並把它添加在列表末尾。
 | 在上面插入群 | 插入一個新的群到選定組的上方。
 | 在下面插入群 | 插入一個新的群到選定組的下方。
 | 刪除群 | 刪除選定的群。
 | 重命名群 | 重命名選定的群。
 | 預覽/導入標籤... | 從CSV文件導入標籤[無分隔符號的CSV檔]。
 | 導出群... | 導出所選群中的所有標籤。
 | 導出群和子群.. | 導出所選組中所有的標籤和它的子群。
 | 導入數據類型 | 從CSV文件導入數據類型。只有當所選節點是一個內部存儲器或鏈接的時候才能操作。
 | 導出數據類型 | 導出所選鏈接的數據類型。只有當所選節點是一個內部存儲器或鏈接的時候才能操作。
 | 從OPC服務器載入標籤 | 從OPC服務器載入標籤。

■在連線(Link)中，導入及導出標籤 和數據類型。
詳細說明，請參考章節2.3.4。

■在連線(Link)中，新增標籤群；刪除或更名現有的標籤群。
詳細說明，請參考章節2.3.5。

■檢視配方和數據收集器的標籤(數據項)。

若人機應用中包含配方或數據收集器，標籤編輯器會顯示其數據項為標籤。所有配方或數據收集器的數據項(標籤)在標籤編輯器中只能讀取，若要編輯數據項，須在其個別關聯的對話框中編輯。
用戶可在關聯配方區的對話框中，編輯配方區中的數據項，詳細說明，請參考 章節11.5配方區 。


2.3.3.2 標籤列表頁

標籤列表頁

標籤列表頁顯示選取標籤群的所有標籤，在標籤列表頁中可進行以下操作：

■ 點擊視窗標題欄可切換標籤群和數據類型。
■ 點擊標題列可進行排序。
■ 設定標籤名稱，新增標籤；然後，點擊其他格子，可設定此標籤內容。

下表說明標籤的各項屬性。

項目 |  | 說明
名稱 |  | 設定標籤的名稱。 標籤群中標籤名稱不能重複。 名稱最多可輸入48字元，支援中文輸入。 名稱開頭不能為數字，也不能與巨集指令相同。 全局標籤開頭需為底線(_)，本地標籤開頭則不能使用底線(_)。
別名 | <編輯框> | 顯示標籤的別名。例如：core_display是sys_chang\step_1別名，這意味著當標籤core_display被使用時，將同時使用sys_chang\step_1。在軟體中，一個標籤可以具多個名稱，而且是具有相同的數據類型和設置，這幾個名稱就是該標籤的別名。除了名稱名稱可以被改變，設置不能被改變。
 |  | 點擊該圖標將會顯示選擇標簽對話框，爲<編輯框>指定標簽。如何選擇一個標記，請看4.4.3.3選擇標籤 。
數據類型 | <編輯框> | 顯示標籤的數據類型。
 |  | 點擊該圖標將顯示“選擇數據類型”的對話框，指定所需要的數據類型。下面是“選擇數據類型”對話框示例。
地址 | <編輯框> | 數據類類型為位時設定位地址；如果不是，請設定字地址。
 |  | 點擊這個圖標，顯示地址輸入小鍵盤，在編輯對話框中輸入指定地址。輸入位地址方法，請詳見第4.4.3.2位址輸入鍵盤。
掃描速度 |  | 從下拉式清單中，選擇標籤掃描速率，可選擇一般或快速。
說明 |  | 標籤註解。

■ 功能表命令或組合鍵

用戶右鍵單擊該列系統將顯示一個彈出式編輯命令功能表。編輯命令可通過選擇的功能表命令或快捷鍵實現。

下表顯示了支援編輯命令。

圖示 | 選單命令 | 快捷鍵 | 說明
 | 插入 |  | 插入一個新的標籤。
 | 刪除 | DELETE | 刪除標籤，且不暫存於剪貼簿。
 | 剪切 | CTRL+X | 將選取的標籤從視窗移除，並暫存於剪貼簿。
 | 拷貝 | CTRL+C | 複製當前視窗中的標籤。
 | 粘貼 | CTRL+V | 將剪下或複製的標籤貼上當前視窗。

注意:所有編輯指令需要先選取標籤，欲選取標籤，可點擊標籤的編號欄；欲同時選取多個標籤，可按住Ctrl鍵，再點擊標籤的編號欄。


2.3.3.3 數據類型頁

數據類型頁

數據類型頁將會顯示選定連線所支持的所有相關數據類型。

下表描述了每個數據類型的屬性。

項目 | 說明
名稱 | 數據類型的名稱。
數據類型 | 數據類型。
說明 | 數據類型注釋。

註：如果數據類型是結構型資料類型，你可以單擊 [image] 以展開或點擊 [image] 折疊收納。

利用數據類型視窗，用戶可以實現：

■ 通過點擊“窗口”選項卡之間切換選定的標籤群和支持的數據類型的標籤列表。

■ 使用菜單命令或組合鍵，剪切，複製，粘貼和刪除選定的數據類型。

用鼠標右鍵點擊數列顯示彈出菜單編輯命令。下表顯示了每項標簽所支援的編輯命令。

菜單選項 | 快捷鍵 | 說明
添加 |  | 在結構定義對話框列表的末尾插入一個新的結構。
編輯 |  | 編輯所選的結構類型定義對話框。
刪除 | DELETE | 刪除數據類型，而不會將其複製到剪貼板。如果運用程式用到該資料類型，將無法刪除。
剪切 | CTRL+X | 從活動窗口中刪除選定的數據類型，並將它們保存到剪貼板。如果該資料類型在應用程式中被使用，將無法移除該數據類型。
複製 | CTRL+C | 重複在活動窗口中選擇數據類型。
粘貼 | CTRL+V | 粘貼剪切或複製的數據類型，到當前數據類型項的前一行。

所有編輯命令需要選擇一個對象 才可以工作。要選擇一種數據類型，單擊該行的頭數列。選擇多個標籤，單擊該行聽到列，使用 Ctrl+點擊添加行的選擇。當所選的數據類型不是基本數據類型或內置保留數據類型，新增的編輯命令可用。

■ 使用結構定義對話框添加或編輯結構數據類型。下 面是結構定義對話框示例。

下表描述了對話框中的每個項目屬性。

屬性 | 說明
結構名稱 | 指定的結構名稱該名稱必須是唯一的。該名稱不能以數字開頭，不能和基本數據類型或內置的保留的數據類型名稱相同。該名稱不能包含任何以下字元“/\|（）{}[]，'<=>？”和空格。
地址 | 指定使用的尋址類型來分配該結構。有兩種類型：
 | 類型 | 說明
 | 連續 | 選擇連續創建一個連續的字或雙字地址結構。
 | 指定 | 選擇創建一個指定的地址結構。
對齊方式 | 選擇字或者雙字使每個字按照“字”對齊或選擇“雙字”對齊。僅適用於連續定址。
結構大小 | 結構區容量大小，以“字”為單位。
成員 | 以下列表是每個成員的各項屬性。
 | 項目 | 說明
 | 編號 | 結構成員編號。
 | 名稱 | 成員名稱。
 | 數據類型 | 點擊圖示，在彈出選擇資料類型“對話方塊中，為成員選擇所需的資料類型。
 | 位置 | 選擇連續地址該項目可用。在結構中顯示位址的偏移位置。
 | 大小 | 成員容量大小，以字為單位。
 | 說明 | 成員注釋。
插入 | 在選中項後插入新的成員。僅有選中某一個成員時候該選項才可用。
刪除/剪切/複製 | 刪除/剪切/複製所有被選中的對象。
粘貼 | 粘貼剪貼和複製的對象。
向上移動 | 選擇對象向上移動。
向下移動 | 選擇對象向下移動。
確認 | 保存所有的變更。
取消 | 不保存變更。


2.3.4 導入和導出標簽/數據類型

導入和導出標簽/數據類型

■ 導入標籤

  1. 在標籤群瀏覽器的內部記憶區、連線或標籤群上，點擊滑鼠右鍵，從彈出視窗中，選擇“導入標籤…”指令。
  2. 點擊欲導入的CSV檔，若欲在不同的檔案夾開啟標籤，須先點選至該檔案夾所在路徑。
  3. 點擊開啟。
  4. 檔案里所有的標簽將呈現在預覽視窗。下面是一個範例。
  5. 將選中導入預覽窗口的標籤群和標籤 拖放到標籤群瀏覽器中。
  6. 在標籤群的瀏覽器，用戶可以選擇以下四種方法來加入選擇對象：
    項目選單 | 說明
    添加群 | 創建一個新群，並將其添加到列表的末尾。
    在群上方插入群 | 在所選的群的上方插入新的一群。
    在群下方插入群 | 在所選的群的下方插入新的一群。
    合併群 | 合併兩個群作為新的群。

註：若檔案格式不正確，導入標籤的操作將會取消。

註：導入的檔案只可包含標籤或標籤群。

註：若導入的標籤，其名稱與標籤群中的標籤相同，用戶須再確認是否取代現有的標籤。
若選擇是，現有標籤將會被移除，並由檔案中的標籤取代。
若選擇否，只有名稱不重複的標籤，才能導入。
若選擇取消，導入的操作將會取消。

註：若欲導入的標籤群，其名稱與連線中的標籤群相同，用戶須再確認是否取代現有的標籤群。
若選擇是，現有標籤群的標籤將會被移除，並由檔案中的標籤取代。
若選擇否，只有名稱不重複的標籤群，才能導入。
若選擇取消，導入的操作將會取消。

■ 導出標籤
若欲將標籤導出在其他的人機應用中使用，用戶可導出選取標籤群中的標籤為CSV檔，做法如下：

1)選擇欲導出的標籤群。

2)在標籤群上點擊滑鼠右鍵，從彈出選單中，點擊第二項“導出標籤”。

3)若欲儲存標籤在不同的檔案夾，先指定路徑，再點擊儲存。

用戶可在內部記憶區或連線上，點擊滑鼠右鍵，從彈出的選單中，點擊“導出標籤及標籤群”，即可導出內部記憶區或連線的所有標籤為CSV檔。

■ 導入數據類型

右鍵單擊記憶體或標簽瀏覽器的連綫，跳出彈出式菜單。然後點擊功能表命令導入數據類型，將會跳出導入數據類型對話框。下面是一個範例。

  1. 單擊導入數據類型按鈕，選擇導入需要的CSV文件。
  2. 單擊“轉換”按鈕來獲得指定的有效數據類型。如果存在相同的數據類型名稱，軟體將跳出提示消息：“是否要覆蓋現有的數據類型"。
  3. 單擊“確定”按鈕導入數據類型，或單擊“取消”放棄本次操作。

■ 導出數據類型

如果用戶需要把現有的數據類型運用到新的人及應用中，可導出選定鏈結的數據類型為CSV檔。用戶可以按照以下方法操作：
1)右鍵點擊連綫，顯示彈出功能表，然後單擊“導出數據類型。
2)如果用戶想保存數據類型到不同的檔夾中，首先找到該文件夾并打開，然後單擊“保存”。


2.3.5 新增/刪除/重命名標簽群

新增/刪除/重命名標簽群

■ 新增標籤群:

  1. 點選欲新增標籤群的連線或內部記憶區。
  2. 在所選位置點擊滑鼠右鍵，從彈出選單中，點擊新增標籤群。
  3. 新增的標籤群會增加到連線的末端，且預設的標籤群名稱將被選取，可做更改。

■ 刪除標籤群:

  1. 移動游標點選欲刪除的標籤群。
  2. 在標籤群上點擊滑鼠右鍵，從彈出選單中，點擊刪除標籤群。

註：一次只能刪除一個標籤群。

■ 重新命名標籤群:

  1. 移動游標至欲更名的標籤群。
  2. 在標籤群上點擊滑鼠右鍵，從彈出選單中，點擊重新命名標籤群。
  3. 標籤群名稱將被選取，只要輸入新名稱，按下ENTER鍵或點擊編輯欄位以外區域即可。


3.1 設定人機應用

設定人機應用

用戶可在人機應用一般設置對話框中，設定人機應用的各項屬性。開啟對話框的方式如下：

  1. 在專案管理員視窗中，在人機應用節點( [image] )上點擊滑鼠右鍵，從彈出選單中，選擇“人機應用一般設置”。
  2. 在專案管理員視窗中，在人機應用 ( [image] )> 設置，雙擊人機應用一般設置節點( [image] )。
  3. 在專案管理員視窗中，在人機應用 > 設置，人機應用一般設置節點( [image] )上點擊滑鼠右鍵，從彈出選單中，選擇屬性。
  4. 在主選單中，點擊人機應用，從次選單中，選擇一般設置…。

人機應用一般設置對話框包含以下四個頁面，有些頁面在需要設定時才會顯現。

■ 一般頁(General)
詳閱 章節 3.1.1 說明。

■ 客制頁(Custom)

詳閱 章節 3.1.2 說明。

■ 按鍵頁(Keys)
詳閱 章節 3.2 說明。

■ 啟始巨集頁/ 主巨集頁/ 事件巨集頁/ 時間巨集頁
詳閱 章節 15.2.6.說明。


3.1.1 人機應用一般設置

人機應用一般設置

本章節說明在人機應用一般設置對話框的一般頁中，各項屬性的設定。下圖為一般頁的範例。

下表為一般頁中，各項屬性的說明。

項目 |  | 說明
人機應用名稱 |  | 人機應用的名稱。
型號 |  | 設定人機的型號。 點擊 [image] 出現人機型號對話框，可依顯示器尺寸、解析度和方向選擇型號，下圖為人機型號對話框的範例。 PC運行(圖控機型)支援的顯示解析度為600×480，800×600;1024×768,1024x600，1280×720，1280×800，1280×1024，1366×768，1440×900，1600×900;1600×1200，1680×1050，1920×1080，1920×1200，2560×1440，2560×1600。
開機畫面 | <勾選框> | 選中此選項，您可以使用此展示圖片出現在人機運行其工作程式之前。通常可以作為產品或公司形象展覽用。
 | 圖片 | 圖片的名字。您可以使用下拉列，從圖片數據庫選擇一張圖片。單擊 [image] 選擇圖片文件作為當前圖片。選擇完畢後，軟體將會導入選定的檔和圖片，並保存圖片到圖片數據庫中。 點擊選取 [image] 圖片庫導入對話框會彈出。選擇從圖片庫中的圖片文件作為開機圖片。選擇後，軟體從圖片庫導入選定的圖片，並保存到圖片數據庫中。
 | 停留時間 | 指定圖片畫面顯示的時間。
 | 配合畫面大小 | 勾選該選項圖片會自動匹配畫面大小。
啟始 | 畫面 | 設定人機開機後，所顯現的第一個畫面。
 | 延遲時間 | 設定延遲運行人機應用的時間。
 | 顯示倒數 | 勾選是否顯示延遲時間的倒數。
 | 語言 | 設定人機開機後，顯示文字所使用的語言。
 | 需要密碼登入 | 勾選此選項，在人機顯示第一個畫面之前，操作者須先輸入有效的密碼。
 | 預設用戶等級 | 當未勾選“需要密碼登入”，此選項才會出現。設定人機應用的初始用戶等級。當人機啟始人機應用時，當前用戶等級即為初始用戶等級。
閒置處理 | 顯示閒置畫面 | 勾選此選項，當操作者在一段指定的時間(閒置時間)內未進行操作時，人機將顯示閒置畫面。
 | 閒置畫面 | 用來設定閒置畫面顯現的時間。
 | 改變用戶等級 | 勾選此選項，當顯示閒置畫面時，改變當前用戶等級。
 | 閒置用戶等級 | 當勾選“改變用戶等級”，此選項才會出現。當顯示閒置畫面時，所設定的用戶等級即為當前用戶等級。
 | 閒置時間 | 設定空閒螢幕顯示的時間長度。
 | 螢幕保護器時間 | 設定螢幕保護器時間。當操作者在一段指定的時間內未進行操作時，人機將會關閉背燈。
註 |  | 可加入物件的說明文字。
巨集 | 啟始巨集 | 勾選人機應用是否包含啟始巨集。 當觸控屏運行時，第一次啟動觸控屏畫面工作程式應用時(通常指斷電後第一次重新送電執行應用畫面程式)，只執行一次啟始巨集內的全部程式指令，然後才顯示第一個畫面。所以，如果啟始巨集內的程式太長，則第一次顯示畫面會需要較長開機時間。一般而言，啟始巨集是用來執行初始化動作，可使用啟始巨集來初始化人機應用的資料和設定。
 | 主巨集 | 勾選人機應用是否包含主巨集。 當觸控屏運行時，就會不斷地循環執行主巨集內的程式指令，但每次將只執行最多30行的巨集指令。而且不論觸控屏當前所在畫面為何，此主巨集均時時刻刻會被執行。只是主巨集的執行週期時間是無法非常精準的確定時間值，通常大約為每100-1000毫秒(msec)會執行一次。(巨集程式執行時間依程式長短而定)。也就是說當人機應用執行時，主巨集會循環不斷地執行，人機應用會在主巨集執行完畢或執行到END指令時，延遲指定的時間後，再回到第一個指令重複執行。
 | 事件巨集 #1~#4 | 當觸控屏運行時，當觸發位元(bit)信號有效(由關狀態=0切為開狀態=1)時，觸控屏將立刻執行事件觸發巨集內的全部指令一次。一個人機應用最多可設定四個事件巨集。若人機應用需要使用事件巨集，選擇所需事件，再選擇事件的關聯觸發位。您也可以選擇由系統提供的觸發位元，如：MemStkInserted，MemStkRemoved，BatteryLow，BarCodeInputViaUsb。
 | 時間巨集 #1~#4 | 當觸控屏運行時，觸控屏將固定以所設時間週期循環執行時間巨集內的全部指令一次。所以為了使觸控屏的動作能合理運行，請儘量簡短時間巨集的指令數量。時間巨集的執行是週期性地重複執行。一個人機應用最多可設定四個時間巨集。每個時間巨集可設定不同的間隔時間(間隔時間 0.5 或 1 秒或每準點分鐘或每準點小時)，如下表所示：
 |  | 時間巨集 | 時間間隔範圍 |  | 說明
 |  | #1 | 0.5和1秒 |  |
 |  | #2 | 0.5，1，2，3...和59秒 |  |
 |  | #3 | 1/120，1/60，1，2，3...和59分 |  | 在0秒時執行巨集程式。
 |  | #4 | 1/7200，1/3600，1，2，3...和24時 |  | 在整點時執行巨集程式。
 |  | 勾選適當的時間巨集並指定時間巨集的間隔時間。
列印
 | 印表機 | 若人機應用需設定人機應用使用的印表機種類。800x480的觸控屏螢幕可以用不到15秒完成列印。
 |  | 支援的印表機 |  | 測試印表機型號 | 備註
 |  | BIXOLON SRP-350 (USB) |  |  | 雷射收據印表機
 |  | EPSON C79 (USB) |  |  |
 |  | EPSON C86 (USB) |  |  |
 |  | EPSON LQ-1600K (USB) |  | DPK300 Fuji Printer |
 |  | EPSON LQ-300 (USB) |  |  |
 |  | HP LaserJet (Ethernet / USB) |  | HP 1606dn, Brother HL-2030, Brother HL-2070N, 和 Brother MFC-7840W. | 印表機支援PCL和PCL 5e
 |  | Siupo SP 系列 (COM / PRT) |  |  |
 |  | SPRT A 系列 (COM / PRT) |  |  |
 | 接口 | 設定人機與印表機的連接埠。
 |  | 若印表機為單色印表機，用戶可以點擊此按鈕，在彈出的列印設定對話框中，設定顏色為黑色。下圖為列印設定對話框的範例。
硬體 | 電池保護記憶體 | 指定電池保護記憶體大小。
 | 使用外接鍵盤 | 選擇此選項，如果你想使用一個定制的鍵盤或PC的USB鍵盤，為你的HMI設備支援外部鍵盤連接。當使用外接鍵盤，觸摸屏操作仍然可以操作，你可以同時操作HMI的觸摸屏和外接鍵盤。您可以使用向上，下，左，右，和Tab鍵將游標移動到所需的物件。要啟動一個按鈕，將游標移動到按鈕，然後按Enter鍵。要輸入數值和字符，將游標移動到相關的數值或字符物件上，並使用鍵盤直接輸入資料。在過去的外接鍵盤，向上鍵和向下鍵是移動游標向上和向下，但在某些類型的應用程序，這是不方便的。現在這兩個鍵可以移動游標到左或右。當向上鍵不能進一步向上移動游標，它會嘗試將游標移動到左側。另外，當向下鍵不能進一步向下移動游標，它會嘗試將游標移動到右側。
其他 | 蜂鳴長度 | 指定蜂鳴器響聲的長度。
 | 一次觸摸啟動多個重疊按鈕 | 勾選此選項，一次觸摸即可依序啟動多個重疊按鈕。此項屬性使操作者一次觸摸可使人機發送多個指令或數據設定。然而，使用此項功能有些限制，詳細說明請參考章節 3.1.3 。
 | 顯示方向可切換 | 勾選此選項，人機在運行時可切換螢幕方向。 人機運行顯示為橫向或縱向的螢幕是可以預先定義的，有關視窗螢幕和菜單螢幕的顯示方向是根據當時的普通畫面的顯示方向而定的。 注意：此功能僅部分HMI機型支援，如果所選型號不支援此功能則此選項就不會出現。
 | 支持文字反鋸齒 | 勾選此選項，使X系列HMI產品支持文字反鋸齒。對照例:
 |  | 沒有反鋸齒文字 |  | 支持反鋸齒文字
 | 檢查上一次關電前是否執行安全停機 | 當HMI每次開始運行應用程式時，您可以設置人機界面，以檢查操作員是否成功地為上一次斷電點擊“安全停機”的功能按鈕進行安全停機。請閱讀章節 3.1.5 避免資料由於隨便關電而損壞 的說明瞭解詳情。 注意:每次HMI啟動後系統會自動檢查上次關機是否有完成安全停機的正確操作。


3.1.2 客制設定

客制設定

本章節說明人機應用的客制設定。下圖為人機應用一般設置對話框中，客制頁的範例。

下表為客制頁中，各項屬性的說明。

項目 |  | 說明
十進制數值鍵盤 | 使用客制鍵盤 | 勾選此選項，使用客制鍵盤替代內建鍵盤，輸入十進制數值。
 | 視窗畫面 | 設定十進制數值鍵盤的視窗畫面。
十六進制數值鍵盤 | 使用客制鍵盤 | 勾選此選項，使用客制鍵盤替代內建鍵盤，輸入十六進制數值。
 | 視窗畫面 | 設定十六進制數值鍵盤的視窗畫面。
八進制數值鍵盤 | 使用客制鍵盤 | 勾選此選項，使用客制鍵盤替代內建鍵盤，輸入八進制數值。
 | 視窗畫面 | 設定八進制數值鍵盤的視窗畫面。
字符鍵盤 | 使用客制鍵盤 | 勾選此選項，使用客制鍵盤替代內建鍵盤，輸入字符。
 | 視窗畫面 | 設定字符鍵盤的視窗畫面。
密碼鍵盤 | 使用客制鍵盤 | 勾選此選項，使用客制鍵盤替代內建鍵盤，輸入密碼。
 | 視窗畫面 | 設定密碼鍵盤的視窗畫面。
觸控無效標示 | 使用客制標示 | 勾選此選項，當物件的觸控操作無效時，使用客制標示替代內建的觸控無效標示。
 | 圖片 | 單擊 [image] “選擇圖片檔作為當前圖片。選擇完畢後，軟體導入選定的檔和圖片的資料庫中保存的圖片。 點擊 [image] 選取/導入庫對話方塊彈出。選擇從圖片庫中的圖片檔作為當前畫面。選擇後，軟體從選定的庫導入選定的圖片，保存圖片到圖片資料庫中。
 | 透明 | 勾選此選項，客制標示與透明色相同的部份將透明顯示。
 | 透明色 | 設定透明色。
CSV/文字檔案 | 日期格式 | 設定人機輸出日期訊息到文字檔的的格式。
 | 時間格式 | 設定人機輸出時間訊息到文字檔的的格式。
 | 分隔號 | 選擇Tab，分號或者逗號為CSV/TXT文字檔案的分隔號。
使用者等級設定 | 設定萬年曆 | 可設定人機時間和日期的最低用戶等級。
禁止上傳及複製儲存在人機的應用運行數據 |  | 勾選是否禁止上傳及複製儲存在人機的應用運行數據。
儲存擴展之應用運行數據到 |  | 對有提供擴展記憶體的人機機型，讓您可以選擇將更大資料量的應用程式，可以儲存到內置的128MByte記憶體(C:)或是微形SD卡的記憶體(D:)或外接隨身碟的記憶體(E:)。
預設檔案夾 |  | 此欄位僅適用於基於Windows的PC運行(圖控機型)和人機有快閃記憶體的機型。當機型為 Windows的PC運行(圖控機型)，此選項預設的檔案夾共有四種：同應用檔案、預先指定、每日一新夾和每月一新夾。當機型為人機時，此選項預設的檔案夾共有三種：預先指定、每日一新夾和每月一新夾。詳細說明，請參考章節3.1.4。
通訊錯誤標示 |  | 設置當HMI與控制器通訊未能正確有效讀取數據資料時要如何顯示數值物件(包含數值輸入器和數值顯示器)和字元物件(包含字元輸入器和字元顯示器)內容。可選擇的標示記號如下：
 |  | 標示 | 說明
 |  | (保持原狀) | 不顯示通訊錯誤的標示，物件顯示將保持原狀。
 |  | (清空) | 清除物件的顯示。
 |  | ? | 顯示字串‘?’。
 |  | # | 顯示字串‘#’。
視窗畫面抬頭字體 | 語言 | 你可以選擇一種語言，此語言將作為查看和編輯視窗畫面標題文字的文字字體設置和該語言的文字屬性特徵。
 | 字體 | 給視窗螢幕標題選定字體。您可以使用下拉清單中選擇一種字體，或單擊字體範本對話框 [image] ，自己另外選擇所喜歡的字體。您可以在對話框中選擇字體之前更改字體範本。
中文字碼與點陣字型 | 簡體字碼 | Unicode(PRC;Class1&2);Unicode(PRC;Class1)
 | 繁體字碼 | Big5(Class1);Big5(Class1&2);Unicode(Taiwan;Class1);Unicode(Taiwan;Class1&2);Unicode(PRC&Taiwan;Class1&2)
 | #1~#3點陣字庫對應字型 | 相應的中文漢字字體。您可以使用下拉清單選擇一種字體，或單擊語言1的字體範本 [image] 對話框選擇點陣字體的中文顯示字體。您可以在對話框中選擇字體之前更改字體範本。


3.1.3 一次觸摸啓動多個重叠按鈕

一次觸摸啓動多個重叠按鈕

欲啟動“一次觸摸啟動多個重疊按鈕”功能，開啟人機應用一般設置對話框，勾選“一次觸摸啟動多個重疊按鈕”選項。啟動此功能後，按壓最上方的按鈕即可啟動位於底下的重疊按鈕。以下為此項功能的一些限制。

  1. 支援此項功能的按鈕種類包含：位按鈕、切換開關、畫面按鈕、功能按鈕、字按鈕、多態按鈕和鍵盤按鈕。

  2. 第一個按鈕(最上方的按鈕)須為位按鈕、切換開關、字按鈕、多態按鈕和鍵盤按鈕，且不能勾選按鈕的“最少按壓時間”和“操作員確認”屬性。如果按鈕為位按鈕、切換開關或鍵盤按鈕，則按鈕不能包含巨集。如果按鈕為字按鈕，則其功能不能設置為“輸入數值”或“輸入密碼”。如果按鈕為多態按鈕，則按鈕方式不能設置為“清單”或“下拉式清單”。

  3. 若位於重疊按鈕底下的按鈕有“最少按壓時間”與“操作員確認”屬性，將無法啟動按鈕功能。

  4. 位於重疊按鈕底下的位按鈕，若功能設置“保持1”或“保持0”，將無法啟動按鈕功能。但是，若位按鈕為第二個按鈕，且第一個按鈕為鍵盤按鈕，則可啟動此位按鈕。位於重疊按鈕底下的位按鈕，若包含巨集，將無法啟動按鈕功能。

  5. 位於重疊按鈕底下的切換開關，若包含巨集將無法啟動按鈕功能。

  6. 位於重疊按鈕底下的多態按鈕，若按鈕方式設置為“清單”或“下拉式清單”，則無法啟動按鈕功能。

  7. 功能按鈕只可以作為最後一個按鈕(最下方的按鈕)，所有在功能按鈕下方的按鈕將無法啟動按鈕功能。

  8. 畫面按鈕只可作為最後一個按鈕，所有在畫面按鈕下方的按鈕將無法啟動按鈕功能。

  9. 若字按鈕的功能設置為“輸入數值”和“數入密碼”，則此字按鈕只可作為最後一個按鈕。在此設置的字按鈕，其下方的按鈕將無法啟動按鈕功能。

  10. 可經由一次觸摸間接啟動的按鈕最大個數為10個按鈕。


3.1.4 預設檔案夾

預設檔案夾

當以下三種情況之一存在，檔案輸出/輸入將使用預設的檔案夾：

  1. 檔案操作的指令中，並不需要設定檔案名。
  2. 檔案操作的指令中，需要設定檔案名，但設定的檔案名不包含路徑。
  3. 當需要將收集的歷史數據，警報數據或操作記錄保存到文件，且[存到預設文件夾]選項被勾選. 具體設定詳見 章節 13.1.2, 章節 12.2, 章節 14.2.

欲設定預設檔案夾，須先開啟人機應用一般設置對話框中的客制頁。欲開啟對話框，點選人機應用主選單下的一般設置，將出現人機應用一般設置對話框，再點選對話框中的客制頁；另一種開啟對話框的方式為，在專案管理員視窗中，雙擊“人機應用一般設置”節點。

在客制頁中，用戶可根據以下的規則，在“預設檔案夾”屬性，設定所需的預設檔案夾：

  1. 欲使用人機應用檔案(.pe2or.pl2file)的檔案夾為預設的檔案夾，在選項欄位，選擇“同應用檔案”。

若人機應用在人機上運行，由於人機應用並未儲存於檔案或目錄下，USB隨身碟的根目錄將作為預設的檔案夾。

  2. 預設的檔案夾，在選項欄位選擇“預先指定”，並在檔案夾欄位設定檔案夾路徑。

註：在運行時，預設的檔案夾，必須存在，否則檔案輸出/輸入操作將會失敗。

  3. 欲每天使用新的預設檔案夾，在選項欄位選擇“每日一新夾”，並設定以下的項目：

A)檔案夾路徑：新檔案夾的路徑，系統將每天在預設的路徑下，新增檔案夾。
B)取名格式：新增檔案夾的檔名格式。
C)<前綴>：新建檔案夾名稱的前置代號。注意，只可輸入ASCII字符。

範例:

檔案夾名稱格式 | 路徑 | <前綴> | 日期 | 檔案夾名稱
<Prefix>yymmdd | C: | ABC | December19,2008 | C:\ABC081219
<Prefix>yyyymmdd | D:\NEO | ABC_ | December19,2008 | D:\NEO\ABC_20081219
<Prefix>yyMMMdd | C: | XYZ | January10,2009 | C:\XYZ09JAN10
<Prefix>yyyyMMMdd | D:\123 | XYZ_ | January10,2009 | D:\123\XYZ_2009JAN10

  4. 欲每月使用新的預設檔案夾，在選項欄位選擇“每月一新夾”，並設定以下的項目：

A)檔案夾路徑：新檔案夾的路徑，系統將每月在預設的路徑下，新建檔案夾。
B)取名格式：新建檔案夾的檔名格式。
C)<前綴>：新建檔案夾名稱的前置代號。注意，只可輸入ASCII字 符。

範例:

檔案夾名稱格式 | 路徑 | <前綴> | 日期 | 檔案夾名稱
<Prefix>yymm | C: | ABC | December19,2008 | C:\ABC0812
<Prefix>yyyymm | D:\NEO | ABC_ | December19,2008 | D:\NEO\ABC_200812
<Prefix>yyMMM | C: | XYZ | January10,2009 | C:\XYZ09JAN
<Prefix>yyyyMMM | D:\123 | XYZ_ | January10,2009 | D:\123\XYZ_2009JAN


3.2 使用按鍵

使用按鍵

有些人機為按鍵式機型，用戶可自訂這些按鍵式機型外部按鍵的操作功能。

欲設定或改變按鍵的操作，方法如下：

■ 人機應用的預設值設定

詳閱章節 3.2.1.說明。

■ 人機畫面的設定
詳閱章節 3.2.2說明。


3.2.1 人機應用的預設按键設定

人機應用的預設按键設定

『預設設定』為可被人機應用中所有的畫面所使用的設定。若使用按鍵的預設應用設定，則人機應用的所有畫面都可使用此設定，而不需每個畫面再個別設定。

用戶可以在人機應用一般設置對話框中，進行按鍵的預設設定。欲開啟人機應用一般設置屬性對話框，請參考章節3.1 設定人機應用。人機應用一般設置對話框的按鍵頁，可設定按鍵的預設應用設定。

下圖為人機應用一般設置對話框中，按鍵頁及用途設定對話框的範例。

上面的圖例包含兩個部份：按鍵用途表和用途設定對話框。

■ 按鍵用途表(Key Usage Table)

按鍵用途表顯示人機所有按鍵的預設用途。當新建人機應用，按鍵用途表為空白(按鍵用途和組合均為“無”)。詳細說明，請參考章節3.2.3。

■ 用途設定對話框(Usage Setup Dialog)

用途設定對話框可設定按鍵及按鍵組合的用途。用戶可在按鍵用途表的格子上點擊滑鼠左鍵，即會出現對話框，用途設定對話框的詳細說明，請參考章節3.2.4.。


3.2.2 畫面設定

畫面設定

每個畫面可定義其按鍵用途。若欲使按鍵在指定的畫面執行特定的功能，用戶可在畫面屬性對話框中，設定按鍵的用途。欲開啟畫面屬性對話框，請參考章節3.9.3 設定畫面。畫面屬性對話框的按鍵頁，可設定按鍵在畫面的用途。

下圖為畫面屬性對話框，按鍵頁和用途設定對話框的範例。

上面的圖例有兩個部份：按鍵用途表和用途設定對話框。

■ 按鍵用途表(Key Usage Table)
按鍵用途表顯示人機所有按鍵的預設用途。當新建人機應用，按鍵用途表為空白(按鍵用途和組合均為“無”)。詳細說明，請參考章節3.2.3。

■ 用途設定對話框(Usage Setup Dialog)
用途設定對話框可設定指定按鍵及按鍵組合的用途。用戶可在按鍵用途的格子上點擊滑鼠左鍵，即會出現對話框。在對話框中，“使用預設值”為預設選項。用戶可取消“使用預設值”，並設定所選擇按鍵，在指定畫面的用途。有關對話框的詳細說明，請參考章節3.2.4.。


3.2.3 按鍵用途表設定

按鍵用途表設定

按鍵用途表在人機應用一般設置對話框或畫面屬性對話框的按鍵頁中，它顯示人機所有的按鍵及按鍵的預設用途。只有當人機為按鍵機型時，才會出現按鍵頁。

下圖為按鍵頁中，按鍵用途表的範例。

按鍵用途表有三個欄位，說明如下表。

項目 | 說明
鍵 | 人機可使用的按鍵。
用途 | 顯示按鍵按壓後的用途。
用途(Esc+) | 顯示按鍵組合(ESC+按鍵)按壓後的用途。人機必須支援組合鍵的功能，此欄位才會出現。

註：在格子上點擊滑鼠左鍵，開啟用途設定對話框，即可設定選取按鍵的用途。詳細說明，請參考章節 3.2.4. 。


3.2.4 按键用途設定

按键用途設定

用戶可在用途設定對話框，設定或改變按鍵和組合按鍵用途。用途設定對話框為浮動對話框，可在畫面上任意移動。

欲開啟用途設定對話框，用戶可在格子上點擊滑鼠左鍵。若改變按鍵用途表的選取項目，對話框會顯示選取按鍵的相關設定。

下圖為用途設定對話框的範例。

屬性 | 說明
使用預設值 | 勾選按鍵是否使用人機應用一般設置按鍵頁的預設值。此欄位只在畫面屬性對話框按鍵頁中出現。
用途 | 選擇按鍵或按鍵組合的用途。有以下7個選項：無、位按鈕、功能按鈕、鍵盤按鈕、多態按鈕、畫面按鈕和字按鈕。
位按鈕 | 若按鍵用途為位按鈕，需設定以下屬性：
 | 屬性 | 說明
 | 功能 | 選擇位按鈕的功能。有5個選項：設1、設0、保持1、保持0和反相。 詳細說明，請參考 章節5.1.1位元按鈕基本功能。
 | 寫入地址 | 設定位變數的地址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 壹巨集 | 勾選位按鈕是否包含壹巨集。從下拉式清單中選擇巨集，當位按鈕功能為設1、保持1或保持0時，此選項才會出現。
 | 零巨集 | 勾選位按鈕是否包含零巨集。從下拉式清單中選擇巨集。當位按鈕功能為設0、保持1和保持0時，此選項才會出現。
功能按鈕 | 若按鍵用途為功能按鈕，需設定以下屬性:
 | 屬性 | 說明
 | 功能按鈕 | 設定功能按鈕所要執行的功能，詳細說明，請參考 章節5.4.1功能 按鈕基本功能。
鍵盤按鈕 | 若按鍵用途為鍵盤按鈕，需設定以下屬性：
 | 屬性 | 說明
 | 輸入字母 | 勾選此選項，輸入指定字母於鍵盤記憶區。
 | 字母 | 勾選“輸入字母”後，出現此屬性。設定欲輸入到鍵盤記憶區的字母。
 | 輸入指令 | 勾選此選項，輸入指定指令於鍵盤記憶區。
 | 指令 | 勾選“輸入指令”後，出現此屬性。設定欲輸入到鍵盤記憶區的指令。指令如下表所示：
 |  | 指令 |  |  | 說明
 |  | 輸入 |  |  | 完成數據輸入並發送輸入的字串到關聯的物件或系統。
 |  | 離開 |  |  | 取消數據輸入的操作。
 |  | 清除 |  |  | 清除鍵盤記憶區。
 |  | 後退 |  |  | 移除鍵盤記憶區最後的字母。移除鍵盤記憶區最後的字母。
多態按鈕 | 若按鍵用途為多態按鈕，需設定以下屬性：
 | 屬性 |  | 說明
 | 狀態類別 |  | 設定監視變數的狀態類別，有2個選項：數值和最低位。詳細說明，請參考 章節4.4.1.1狀態種類 。
 | 數據類別 |  | 變數的數據類別。
 | 寫入地址 |  | 設定控制變數的位址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 總狀態數 |  | 設定監視變數的有效狀態個數。 註：當總狀態數為N，則最後狀態為N-1。
 | 次一狀態 |  | 設定按鈕計算次一狀態的方式。若當前狀態不是最後狀態，+1表示次一狀態為當前狀態加1；若當前狀態為最後狀態，次一狀態為0。若當前狀態不是狀態0，-1表示次一狀態為當前狀態減1；若當前狀態為0，則次一狀態為最後狀態。
畫面按鈕 | 若按鍵用途為畫面按鈕，需設定以下屬性：
 | 屬性 |  | 說明
 | 功能 |  | 設定畫面按鈕的功能，有四個功能選項：開啟畫面、開啟前一畫面、關閉和開啟畫面、關閉畫面。詳細說明，請參考 章節5.3.1畫面 按鈕基本功能。
 | 畫面 |  | 設定欲開啟的畫面。
 | 改變用戶等級 |  | 勾選此選項，按壓畫面按鈕可改變當前用戶等級，同時設定新用戶等級取代當前用戶等級。
 | 確認警報 |  | 勾選是否設置畫面按鈕確認警報。
字按鈕 | 按鍵用途為字按鈕，需設定以下屬性：
 | 屬性 |  | 說明
 | 功能 |  | 設定字按鈕的功能。詳細說明，請參考 章節5.6.1 字按鈕基本功能。
 | 數據類別 |  | 變數的數據類別。
 | 寫入地址 |  | 設定變數的地址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 常數 |  | 設定字按鈕功能(設常數、加、減)的常數值。
 | 最小值 |  | 設定字按鈕功能(輸入數值、輸入密碼、減)的最小值。
 | 最大值 |  | 設定字按鈕功能(輸入數值、輸入密碼、加)的最大值。
 | 總位數 |  | 數值輸入鍵盤上最大值和最小值的總位數。
 | 小數位數 |  | 當數據類別是32位浮點數，則此屬性為設定最大值和最小值的小數位數。 當數據類別不是32位浮點數，則此選項除了為最大值和最小值的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。當小數位數為一個非0的數N，輸入的數值在輸出前將依以下的公式轉換為整數。 輸出值=輸入值*(10的N次方) 範例：
 |  |  | 顯示類別 | 總位數 | 小數位數 | 輸入值 | 輸出值
 |  |  | 32位浮點數 | 4 | 2 | 12.34 | 12.34
 |  |  | 32位浮點數 | 4 | 2 | 123.4 | Error!
 |  |  | 16位整數 | 5 | 2 | 123.45 | 12345
 |  |  | 16位整數 | 5 | 2 | -0.05 | -5
 |  |  | 16位整數 | 5 | 2 | 3 | 300
 | 啟動功能 |  | 選擇“按下鍵時”，當觸摸按鍵時，啟動按鍵功能；選擇“釋放鍵時”，當釋放按鍵時，啟動按鍵功能。
進階 | 下表說明各物件中進階選項的屬性，有些屬性在需要設定時才會出現。
 | 屬性 |  | 說明
 | 由位致能 |  | 勾選此選項，物件操作的有效與否，由指定的位控制。
 | 位 |  | 設定觸控操作的致能位。點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 致能狀態 |  | 設定使觸控操作有效的狀態。
 | 由用戶等級致能 |  | 勾選此選項，物件操作的有效與否，由當前用戶等級控制。
 | 最低致能用戶等級 |  | 設定使觸控操作有效的最低用戶等級。
 | 由操作員確認 |  | 勾選此選項，操作員須確認操作。當物件進行操作，顯示確認操作的對話框。若操作員選擇“確定”，則進行操作；若操作員選擇“取消”或在指定的時間(最長等待時間)內未回應，則取消操作。
 | 最長等待時間 |  | 設定物件等待操作員確認的最長時間。若操作員未在時間內回應，則取消此項操作。
 | 通知 |  | 勾選此選項，在完成操作後，物件發送通知至指定的位。
 | 位 |  | 設定接收通知的位地址。
 | 狀態 |  | 設定通知的位狀態。


3.3 内部記憶區

内部記憶區

本章節說明人機內部記憶區的設定和使用。


3.3.1 内部記憶區種類

内部記憶區種類

下表說明可存在於或總是存在於內部記憶區的記憶區種類。

種類 | 地址格式 | 地址格式
一般用戶記憶區 | Word: $Un Bit: $Un.b; b: 0~f | 用戶可設定此記憶區大小。
電池保護用戶記憶區 | Word: $Nn Bit: $Nn.b; b: 0~f | 當人機有電池保護記憶體，才可使用此記憶區。用戶可設定此記憶區大小。
系統記憶區 | Word: $Sn Bit: $Sn.b; b: 0~f | 此記憶區保存系統所需數據與資訊。詳細說明，請參考章節3.3.3。
索引暫存器 | Word: $In n: 0~63 | 索引暫存器提供間接尋址的功能。欲使用索引暫存器設定間接尋址，請參考章節3.3.2。
32位索引暫存器 | Word: $Jn n: 0~15 | 32位元索引暫存器提供間接尋址的功能。欲使用索引寄存器設定間接尋址，请参考章節3.3.2。
命令區 | Word: $CBn Bit: $CBn.b; b: 0~f | 此記憶區儲存指定命令區所讀取的數據。


3.3.2 索引暫存器

索引暫存器

若人機有電池保護記憶區，則索引暫存器為電池備份。當人機應用更新後，索引暫存器清為零。

用戶使用索引暫存器設定間接定址。使用間接定址，在運行時，物件或巨集可指定存取不同的數據。

範例：

  1. 字地址W[$I30]相當於W2000，當$I30為2000。
  2. 字地址$U[$I0+123]相當於$U223，當$I0為100。
  3. 位地址$U[$I2].a相當於$U0.a，當$I2為0。
  4. 字地址[$I2]:W100相當於3:W100，當$I2為3。
  5. 位地址[$I0]: W[$I1+10].f相當於5:W20.f，當$I0和$I1分別為5和10。
  6. SIMATIC S7（以太網）驅動允許使用索引尋址數據。例如，下面所示的地址是可行的。

    DB[$I3].DBW100

    DB[$I5+2].DBD[$I10+16]

    DB[$I0+2].DBX[$I1].5

    註：支持的數據塊索引可以提供給任何程序驅動PLC。

註：

  1. 用戶須確認，在運行時，索引暫存器的數值是否定址於有效的地址。本軟體無法確認使用索引暫存器的地址有效與否。
  2. 偏移值須為正數，最大值為65535。使用索引暫存器的偏移值可以是一個十六進制的數字，比如數字後跟隨字母h或H。
  3. 只有$I0~$I15可作為站號(PLC地址)，且沒有偏移值。
  4. 提供32位元的索引暫存器（$J）。
  5. 請先確認PLC的驅動程式是否支援間接定址的功能。


3.3.3 系統記憶區

系統記憶區

下表列出系統記憶區中，保存系統數據及資訊的內容。

注意，請勿修改或寫入資料到系統記憶區，否則，可能導致系統失靈或損壞。.

地址 | 長度(單位:字) | 內容
$S0~$S25 | 26 | 鍵盤輸入緩存。 $S0: 鍵盤顯示的命令碼。 $S1~$S24: ASCII字串最多48字母，字串中有空白(Null碼)，字串就終止。
$S42 | 1 | 當前時間的秒與分，BCD格式。 位0~7: 秒(0x00~0x59) 位8~15: 分(0x00~0x59)
$S43 | 1 | 前時間的時，BCD格式。RTC調整參數。 位0~7: 時(0x00~0x23) 位8~15: RTC 調整數值
$S44 | 1 | 當前日期的日和月，BCD格式。 位0~7: 日(0x01~0x31) 位8~15: 月(0x01~0x12)
$S45 | 1 | 當前日期的年和週日，BCD格式。 位0~7: 年(0x00~0x99) 位8~15: 週日 (0x00~0x06); 0 代表星期日
$S46 | 1 | 當前時間的秒，二進制格式(0~59)。
$S47 | 1 | 當前時間的分，二進制格式(0~59)。
$S48 | 1 | 當前時間的時，二進制格式(0~23)。
$S49 | 1 | 當前時間的十分之一秒，二進制格式(0~9)。 9代表0.9秒。
$S50 | 1 | 當前日期的日，二進制格式(03~30)。 0代表當月的第一天。
$S51 | 1 | 當前日期的日，二進制格式(0~30)。 0代表當月的第一天。
$S52 | 1 | 當前日期的年，二進制格式(0~99)。
$S53 | 1 | 當前日期的週日，二進制格式(0~6)。 0代表星期日。
$S219 | 1 | 當前用戶等級(0~9)，9代表用戶以開發者密碼登入。
$S230~$S241 | 12 | ASCII字串，最多24個字母，顯示數值鍵盤的輸入範圍。
$S297 | 1 | 當前鍵盤密碼所能接受的最低用戶等級。當數值為0，可接受任何用戶等級；當數值為9，僅接受開發者密碼。
$S300~$S301 | 2 | 500毫秒(ms)計時器。
$S302~$S303 | 2 | 1秒計時器。
$S304 | 1 | 20Hz正弦(Sine)波(-1000 ~ 1000)。
$S305 | 1 | 20Hz餘弦(Cosine)波(-1000 ~ 1000)。
$S306 | 1 | 20Hz三角(Triangle)波(0 ~ 1000)。
$S307 | 1 | 系統訊號 $S307.0: 總是0。 $S307.1: 總是1。
$S315 | 1 | 系統狀態 $S315.0: 1代表電池保護記憶區中數據正常。
$S317 | 1 | 當前語言編號(0~9)，0代表語言#1。
$S319 | 1 | USB記憶體的狀態位 $S319.0: 磁碟C (1：正常；0:無) $S319.1: 磁碟D (1：正常；0:無) $S319.2: 磁碟E (1：正常；0:無)
$S555 | 1 | $S555.0:為1時表明至少存在一個警報點被觸發。
$S556 | 1 | 文件保存操作的訊息框可以設置為自動關閉。您可以設置系統字＄S556，在多久後將訊息框自動關閉，單位為秒。該值為0時，訊息方塊不會自動關閉（必須手動觸摸關閉按鈕）。
$S557 | 1 | 如果$S557設置為1，將不會出現存檔失敗訊息框。此功能可防止失敗訊息框彈出時阻礙操作者操作。
$S654 | 1 | 連線1~16的致能位 $S654.0代表連線1；0：無效；1：有效 $S654.1代表連線2； … $S654.f代表連線16
$S662~$S677 | 32 | 連線1~16的通訊狀態字 $S662代表連線1 $S663代表連線2 … $S677代表連線16 通訊狀態
 |  | 數值 | 意義 | 數值 | 意義
 |  | 0 | 正常 | 13 | 無效的請求
 |  | 1 | 溢出錯誤 | 14 | 設備繁忙
 |  | 2 | 中斷錯誤 | 15 | 未知錯誤
 |  | 3 | 同位錯誤 | 16 | 連接失效
 |  | 4 | 組幀錯誤 | 17 | 初始化失敗
 |  | 5 | 無回應 | 18 | 發送資料失敗
 |  | 6 | 無法識別的回應 | 19 | 接收數據失敗
 |  | 7 | 超時 | 20 | 打開連線失敗
 |  | 8 | CTS失效 | 21 | 無效的CTS
 |  | 9 | 校驗和錯誤 | 22 | 無效的次連線
 |  | 10 | 命令被拒絕 | 23 | 無效的COM Port
 |  | 11 | 無效的地址 | 24 | 無效的COM Port
 |  | 12 | 無效的範圍 | 255 | 無法確定狀態
$S838 | 1 | 當前配方區編號(0~15)
$S839~$S854 | 16 | 配方區0~15的當前配方總數 $S839 為配方區0 $S840 為配方區1 … $S854 為配方區15


3.3.4 設定内部記憶區

設定内部記憶區

用戶可使用內部記憶區對話框，設定一般用戶記憶區和電池保護用戶記憶區大小。欲開啟內部記憶區對話框，方法如下：

  1. 在專案管理員視窗中，人機應用 > 連線，雙擊內部記憶區節點( [image] )。
  2. 在專案管理員視窗中，人機應用 > 連線，在內部記憶區節點( [image] )，點擊滑鼠右鍵，從彈出選單中，選擇屬性。
    下圖為內部記憶區對話框的範例。


3.4 通訊連綫

通訊連線

本章節說明通訊連線的設定，使人機與外部裝置連接並存取數據。


3.4.1 通訊連綫的種類

通訊連線的種類

下表說明人機應用支援的五種通訊連線方式。

連線種類 | 說明
直接連線 | 直接連線為人機與指定的設備直接連接的連線方式。以下為直接連線的範例。 [範例1] 人機使用RS232與指定的裝置直接連線。 [範例2] 人機使用RS485與指定的裝置直接連線。 [範例3] 人機使用乙太網路與指定的裝置直接連線。
間接連線 | 未直接與人機連接的裝置，可透過間接連線與人機通訊。間接連線連結人機與指定的間接連線伺服器。間接連線伺服器為同一專案中的其他人機，且與指定的裝置直接連接。 [範例1] 透過2對1連接方式間接連線 [範例2] 透過N對1連接方式間接連線(串口) 範例3] 透過N對1連接方式間接連線(乙太網路)
通訊服務 | 當一裝置與目標人機直接連線，若其他人機欲與此裝置連線，用戶必須新增一適當的通訊服務連線，下表說明可行的通訊服務。
 | 通訊服務 | 說明
 | 2對1伺服器(串口) | 用戶須指定此通訊服務的數據連線(關聯的直接連線)。此通訊服務允許兩個人機與一個裝置通訊，此裝置只需一個通訊埠。
 | 2對1穿透伺服器(串口) | 此通訊服務使目標人機成為另一計算裝置(如PC、另一台目標人機或他牌人機)的閘道，用來存取關聯控制器。可行的應用方式如下圖： 此通訊服務支援的控制器，其通訊協定種類須為請求-回覆(Request-Reply)。請向當地的銷售代理商詢問該控制器是否支援此通訊協定。注意，計算裝置的通訊參數(速率、數據位元數、結束位數、校驗)以及2對1穿透服務器的通訊參數設定必須一致。
 | N對1主機(串口) | 用戶須指定此通訊服務的數據連線(關聯的直接連線)。此通訊服務最多支援16台人機與一個裝置通訊，此裝置只需一個通訊埠。
 | N對1主機(乙太網路) | 用戶須指定此通訊服務的數據連線(關聯的直接連線)。此通訊服務最多支援24台人機與一個裝置通訊，此裝置只需一個通訊埠。
閘道服務 | 閘道服務可使人機應用程式在任何的計算機裝置上運行(如PC)，並存取與HMI閘道伺服器連接的控制器數據。下表列出可用的閘道服務。
 | 閘道服務 | 說明
 | 串口閘道伺服器(串口) | 此閘道服務可使其他計算機裝置(如PC)、另一台人機或他牌人機，透過目標人機，經由串口與控制器連接。請參考下方的圖示所提供的連接方式。 在上圖中，藍色、綠色和紅色的線段，分別代表使用閘道服務，經由乙太網路傳輸的不同數據區塊。 閘道伺服器設置，可使HMI作為Modbus裝置。人機應用程式可使用Modbus protocol取存取閘道伺服器的傳輸記憶區。關於閘道伺服器的詳細說明，請參考章節3.4.8。
 | 內部存儲伺服器(乙太網路) | 內部記憶體伺服器，使得一個其他HMI單位可以訪問HMI單元的內部記憶體。需要通過乙太網訪問內部記憶體，請參閱章節 3.4.10。
 | TCP/IP閘道伺服器(乙太網路) | 此閘道服務可使其他計算機裝置(如PC)、另一台人機或他牌人機，透過目標人機，經由乙太網路與控制器連接。請參考下方的圖示所提供的連接方式。 上圖中，藍色、綠色和紅色的線段，分別代表使用閘道服務，經由乙太網路傳輸的不同數據區塊。 閘道伺服器設置，可使HMI作為Modbus裝置。人機應用程式可使用Modbus Protocol取存取閘道伺服器的傳輸記憶區。關於閘道伺服器的詳細說明，請參考章節3.4.8。
OPC連接 | OPC連接 | 說明
 | 用戶端驅動程式 | OPC用戶端驅動程式允許第三方OPC UA伺服器和HMI連線後進行任何可讀取資料的監測和收集。它提供了一個，兩個或多個計算 機設備，如PC，HMI等通訊設備，可以可靠地透過此一通信隧道，從而使要傳輸的資料安全，可靠地交換數據的通道。


3.4.2 一般設定

一般設定

本章說明連線屬性對話框中一般頁中的通訊連線設定。下圖為直接連線(串口)一般頁的範例。

下圖為通訊服務(串口)連線一般頁的範例。

下表說明連線對話框一般頁中，各項屬性的說明。

屬性 |  | 說明
連線編號 |  | 顯示通訊連線的編號，當連線建立時由系統指定。當相同人機應用的其他連線移除時，重新指定連線編號。
連線名稱 |  | 設定通訊連線的名稱。
連線種類 |  | 下表為通訊連線的種類：
 |  | 連線種類 | 說明
 |  | 直接連線(串口) | 此連線透過序列埠(串口)，直接連接人機到指定裝置。
 |  | 直接連線 (乙太網路) | 此連線透過乙太網路介面，直接連接人機到指定裝置。
 |  | 通訊服務(串口) | 此連線可透過序列埠(串口)連接至一個或多個目標人機，並且在裝置/伺服器欄位設定連線到目標人機的通訊服務。關於可行的通訊服務，請參考裝置/連線欄位說明。
 |  | 通訊服務 (乙太網路) | 此通訊透過指定的乙太網路連接至一個或多個目標人機，並且在裝置/伺服器欄位設定連線到目標人機的通訊服務。關於可行的通訊服務，請參考裝置/連線欄位說明。
 |  | 網關服務(串口) | 通過指定以序列埠鏈路連接到目標人機上提供網關服務作為網關服務器。 目標人機允許其他設備的應用程式，諸如PC，通過該人機來訪問控制器數據。
 |  | 網關服務(乙太網路) | 通過指定以乙太網埠鏈路連接到目標人機上提供網關服務作為網關服務器。 目標人機允許其他設備的應用程式，諸如PC，通過該人機來訪問控制器數據。
 |  | 透過2對1間接連線(串口) | 此連線透過指定的序列埠(串口)，連接人機到另一台做為通訊服務2對1伺服器的目標人機。此連線可使人機可透過此目標人機與關聯裝置間接通訊。
 |  | 透過N對1間接連線(串口) | 此連線透過指定的序列埠(串口)，連接人機到另一台做為通訊服務N對1伺服器的目標人機。此連線可使人機可透過此目標人機與關聯裝置間接通訊。
 |  | 透過N對1間接連線(乙太網路) | 此連線透過指定的乙太網路，連接人機到另一台做為通訊服務N對1伺服器的目標人機。此連線可使人機可透過此目標人機與關聯裝置間接通訊。
裝置/伺服器 |  | 當連線種類為直接連線，指定此連線的連線裝置。 當連線種類為通訊服務(串口)時，選擇以下的伺服器。
 |  | 伺服器 | 說明
 |  | 2對1伺服器 | 用戶需選擇一個人機應用中的直接連線，為數據連線欄位中的數據連線。2對1伺服器連接到人機，使此人機與裝置間接連線。人機必須設定為間接連線。
 |  | 2對1穿透伺服器 | 用戶需選擇一個人機應用中的直接連線，為數據連線欄位中的數據連線。2對1穿透伺服器連接到計算裝置，使此計算裝置與裝置間接連線。計算設備可能為目標人機、其他品牌的人機或PC。若為目標人機，必須設定為直接連線。
 |  | N對1主 機 | 用戶需選擇一個人機應用中的直接連線，為數據連線欄位中的數據連線。此連線最多可連接8台人機，使人機與裝置間接連線。人機必須設定為間接連線。
 |  | 當連線種類為通訊服務(乙太網路)，選擇以下的伺服器。
 |  | 伺服器 | 說明
 |  | N對1主 機 | 用戶需選擇一個人機應用中的直接連線，為數據連線欄位中的數據連線。此連線最多可連接8台人機，使人機與裝置間接連線。目標人機必須使用間接連線設定。
 |  | 當連線種類為間接連線，且間接連線伺服器位置已指定，間接連線的裝置在此顯示。
連線埠 |  | 選擇此連線的連接埠。
次連線 |  | 當一個RS485通訊線連接多個裝置，其中，與目標人機連線的裝置即為次連線。當連線種類為直接連線(串口)，此選項才會出現。若連線與多個裝置連接，而用戶欲分辨、監視或控制每個裝置的通訊，可使用此選項。
數據連線 |  | 當連線種類為通訊服務時，選擇人機應用中的直接連線，為數據連線欄位中的數據連線。
間接連線伺服器位置 | 人機應用 | 選擇為此間接連線提供通訊服務的人機應用。
 | 連線 | 選擇為此間接連線提供通訊服務的連線。
記載通訊狀態於操作紀錄中 |  | 勾選此選項，連線或次連線的通訊狀態將記載於操作記錄中。可記錄的狀態種類包含：使能(Enabled)、無效(Disabled)、失敗(Failed)和回復(Recovered)。
檢查字 |  | 人機讀取指定的字以檢查連線是否正常。
通訊異常的顯示時間長度 |  | 通訊錯誤訊息對話框將依據指定的時間長度顯示或隱藏，如果時間長度為0，將不會顯示錯誤訊息對話框。


3.4.3 參數設定(COM序列埠)

參數設定(COM序列埠)

本章說明在連線屬性對話框中參數頁，設定序列通訊連線的通訊參數。

下圖為直接連線參數頁的範例。

下圖為N對1主 站(N-to-1Master)參數頁的範例。

下表為參數頁的設置說明

屬性 | 說明
速率 | 連線所使用的速率。
數據位數 | 連線所使用數據位數的編號。
校驗 | 連線所使用的校驗種類。
結束位數 | 連線所使用的結束位數。
觸控屏地址 | 人機的地址。
PLC地址 | 連接裝置的地址。
逾時時間 | 設定通訊驅動等待連接裝置回應的時間，當時間超過逾時時間，通訊驅動將認定此連線通訊失敗。
命令延遲 | 如果命令延遲為0，表示在通訊驅動接收到最後發送訊號的回應後，會立即發送下一個訊號至連接的裝置。如果命令延遲不為0，通訊驅動延遲指定的時間後，才會發送下一個訊號至連接裝置。
重試次數 | 通訊驅動重試的次數，通訊驅動在每次發送訊號後，會以指定次數重試直到連接裝置成功地回應。如果將重試次數設為0，則通訊驅動會使用預設的重試次數。
使用區塊通訊優化畫面數據讀取 | 人機序列埠通訊讀取可以優化，有了這項功能，開發人員可以： a) 不使用優化，如果所連接的PLC不支援『區塊讀取』。 b) 使用優化，可藉由調整讀取的資料區塊，使每個應用程式能夠得到最大的優化。
指定N對1連接從屏 | 當連線為N對1主 站(N-to-1Master)，此按鈕才會出現。點擊此按鈕，出現N對1連接從屏對話框。用戶在此對話框中，設定N對1連線的從屏。
指定數據分享連接從屏 | 當連線為直接連線，連接裝置為DataSharer(RS485)。點擊此按鈕，出現數據分享連接從屏對話框。用戶可以在此對話框中，定義其他數據分享觸控屏。


3.4.4 參數設定（乙太網路）

參數設定(乙太網路)

本章節說明在連線屬性對話框參數頁，設定乙太網路連線的通訊參數。下圖為乙太網路直接連線的參數頁範例。

下表為乙太網路連線的連線屬性對話框，參數頁的各項屬性說明。

屬性 | 說明
IP地址 | 連接裝置的IP地址。
使用預設埠 | 勾選是否使用預設埠。
埠 | 設定使用的埠號。
站號 | 設定連接裝置的站號。
逾時時間 | 允許通訊驅動等待連接裝置回應的時間，當時間超過逾時時間，通訊驅動將認定連線通訊失敗。
命令延遲 | 如果命令延遲為0，表示在通訊驅動接收到最後發送訊號的回覆後，會立即發送下一個訊號至連接的裝置。如果命令延遲不為0，通訊驅動延遲指定的時間後，才會發送下一個訊號至連接裝置。
重試次數 | 通訊驅動重試的次數，通訊驅動在每次發送訊號後，會以指定次數重試直到連接裝置成功地回應。如果將重試次數設為0，則通訊驅動會使用預設的重試次數。


3.4.5 次連線設定

次連線設定

一條RS485連接線，可連接多個從 站裝置(slave devices)。人機使用相同的通訊協定與這些裝置通訊。人機與這些裝置的連線即為次連線。使用次連線表，操作員可在任何時刻開啟或關閉次連線。

本章節說明如何在連線屬性對話框次連線頁，設定直接連線中次連線的屬性。下圖為次連線頁的範例。

下圖是以太網路連缐的次連缐範例圖。

下表為直接連線的連線屬性對話框，次連線頁的各項屬性的說明。

屬性

 說明
次連線總數 | 設定次連線的裝置總數。
語言 | 設定名稱欄位的當前語言。
站名 | 所選取的次連線名稱，使用語言欄設定的語言。
IP 地址 | 設定連接設備的IP地址。
站號 | 選取次連線的地址，每一個次連線的地址不能重複。
初始通訊狀態 | 所選取次連線的初始通訊狀態。如果初始狀態為“開啟”，在人機啟動運行後，將與次連線通訊；如果初使狀態為“關閉”，在次連線表的通訊狀態變為“開啟”之前，人機將不會與次連線通訊。
顯示錯誤訊息 | 勾選此選項，當選取次連線發生通訊連線錯誤時，顯示通訊錯誤訊息。未勾選此選項，發生通訊錯誤時，將不顯示任何訊息。
命令延遲
對於乙太網次連線，您可以為每個次連線指定命令延遲和超時時間。

假如設置的命令延遲時間為0秒，表示通訊將立即回應。如果有設置需要延遲一個時間表示HMI通訊將會延後所設時間後才回應該通訊回復命令。

超時時間 | 當超過所設置的時間如果還收不到控制器的通訊回復，HMI 就會顯示通訊超時。


3.4.6 人機數據分享

人機數據分享

數據分享(Data Sharer)為一重要裝置，最多可使16台人機透過乙太網路或RS485分享數據。每一台目標人機可分享數據的最大值為256字。

欲設定數據分享的通訊連線，請先建立直接連線，選擇Data Sharer (UDP)或Data Sharer(RS485)為連接裝置。人機地址可在連線屬性參數頁中設定，不同的人機需對應不同的地址，因為此地址是用來認定數據分享連接從屏的。

連接到數據分享連線的通訊驅動主要是用來將人機的分享數據發佈到網路上。例如，某個人機的地址為10，與數據分享連接的連線個數為2，以下的巨集指令可使通訊驅動發佈關聯的數據至網路。

通訊驅動將會自動接收網路上發布的分享數據，並將數據儲存於記憶區中。

欲存取字，可使用以下地址。其中m為人機地址，n為此人機分享數據的字編號。

Pm.n m=1~16; n=0-255

欲存取位(Bit)，使用以下地址，其中b為16位數，代表指定的字的位編號。

Pm.n.b m=1~16; n=0-255; b=0~f

UDP為乙太網路的數據分享。


3.4.7 使用巨集指令建立通訊連線

使用巨集指令建立通訊連線

用戶可以編寫巨集程式，讓人機透過序列埠與計算機裝置通訊。為簡化說明，以下將用裝置來代表目標計算機裝置。

  1. 新建一通訊連線，連接人機和裝置。

或

  2. 設定連線的一般屬性。裝置/伺服器需選擇PanelMaster - General Device (COM)作為連接裝置。

  3. 設定通訊參數。

  4. 了解通訊連線巨集程序可使用的關鍵字。

關鍵字 | 規格 | 讀取/寫入 | 功能
TX | 字 | 只可寫入 | 將字寫入TX，再將低字節的字傳送到裝置。當傳送開始或結束時，才會停止寫入。 範例: $U10 = "ABC" $U20 = B2W($U10, 3) // Convert the byte array to a word array TX = MOV($U20, 3) // Transmit “ABC” to Device 運作規則: 1) 在前一次傳送尚未結束時，無法再進行傳送。 2) 當傳送開始時，字TXT_STS會被設為1。 3) 當硬體流量控制啟用(位EN_HS設為1)，在裝置允許觸控屏傳送資料後(CTS信號確定有效)，傳送才會啟動。 4) 當RTS/CTS流量控制啟動(位EN_HS設為1)，當傳送開始時，在序列埠的RTS信號將為無效，當傳送結束後，信號才會有效。 5) 若傳送在一段時間(由字TO_TIME設定)後不能開始，則傳送會被取消。當逾時條件發生時，字TX_STS將被設為2。
TX_W | 字 | 只可寫入 | TX_W提供了與TX相同的功能，不同的地方在於，TX_W在所有的位元組傳送完畢後，寫入的動作才會停止。建議使用TX_W傳送數據，因為不需浪費時間在等待巨集程式完成，另外，觸控屏的CPU可運行的更有效率。
TX_STS | 字 | 只可讀取 | 讀取這個字可取得最後傳送的狀態。
 |  |  | 數值 | 狀態
 |  |  | 1 | 成功
 |  |  | 2 | 逾時
 |  |  | 255 | 進行中
RX | 字 | 只可讀取 | 讀取這個字，可從接收緩存中複製指定個數，字的數值。接收緩存為字陣列，從裝置中接收的位元組儲存在緩存的低字節中，緩存的高字節必為0。接收的數據一經複製，即會從接收緩存中移除。如果緩存接收的數據不足，讀取的操作的等待時間將由TO_TIME所決定。除非所有的數據都已接收或逾時，讀取的操作才會完成。 範例: $U10 = MOV(RX, 3) // 從緩存中接收3個字 // $U10取得接收的第一個位元組的數值 // $U11取得接收的第二個位元組的數值 // $U12取得接收的第三個位元組的數值 運作規則: 假設從緩存讀取字的數量為n，在緩存中的字為m 1) 如果緩存中接收的數據足夠，讀取的動作將會執行以下4件事：複製緩存的前n個字，設RX_CNT為n，設RXB_CNT為m-n，設RX_STS為1。 2) 如果緩存中接收的數據不足，讀取的動作將會執行以下4件事：複製緩存的所有字，設RX_CNT為m，設RXB_CNT為0，設RX_STS為1。
RXB_CNT | 字 | 只可讀取 | 讀取這個字，取得在接收緩存，字的個數。注意，接收緩存一個字包含一個接收的位元組。
RX_CNT | 字 | 只可讀取 | 讀取這個字，取得最後接收操作中，所取出的字的個數。注意，接收緩存一個字包含一個接收的位元組。
RX_STS | 字 | 只可讀取 | 讀取這個字，取得最後接收操作的狀態。
 |  |  | 字的數值 | 說明
 |  |  | 1 | 成功
 |  |  | 2 | 逾時
 |  |  | 其他 | 逾時
RX_W | 字 | 只讀 | 讀取這個字，可從接收緩存中複製指定個數，字的數值。接收緩存為字陣列，從裝置中接收的位元組儲存在緩存的低字節中，緩存的高字節必為0。接收的數據一經複製，即會從接收緩存中移除。如果緩存接收的數據不足，讀取的操作的等待時間將由TO_TIME所決定。除非所有的數據都已接收或逾時，讀取的操作才會完成。 範例： $U10 = MOV(RX_W, 3) // 從緩存中接收3個字 // 等待未從裝置接收的數據 // $U10取得接收的第一個位元組的數值 // $U11取得接收的第二個位元組的數值 // $U12取得接收的第三個位元組的數值 運作規則: 假設從緩存讀取字的數量為n，在緩存中的字為m 1) 如果緩存中接收的數據足夠，讀取的動作將會執行以下4件事：複製緩存的前n個字，設RX_CNT為n，設RXB_CNT為m-n，設RX_STS為1。 2) 如果緩存中接收的數據不足，讀取的動作將會等待TO_TIME的時間。當接收到足夠的數據，讀取的操作將執行上面的1，若逾時發生，讀取操作取消，RX_STS設為2。
FLUSH | 位 | 只可寫入 | 將1寫到這個位，清除接收緩存，緩存是用來接收裝置的數據。
RESET | 位 | 只可寫入 | 將1寫到這個位，重置UART，UART用來作為觸控屏和裝置間的通訊。
TO_TIME | 字 | 讀取/寫入 | 寫入逾時時間到這個字，設定通訊逾時的時間。單位為0.1秒。 範例: TO_TIME = 20 (U) // 設定逾時時間為2秒。
EN_HS | 位 | 讀取/寫入 | 寫入1到這個位，使RTS/CTS可流量控制。
 |  |  | 位的數值 | 功能
 |  |  | 0 | 使硬體不能流量控制。
 |  |  | 1 | 使軟體不能流量控制。
 |  |  | 範例 EN_HS = 1 (B) // 使能流量控制
CTS_STS | 位 | 只可讀取 | 讀取這個位，從裝置取得CTS信號的狀態。
 |  |  | 位的數值 | 信號 | 說明
 |  |  | 0 | 有效 | 人機允許發送資料到裝置
 |  |  | 1 | 有效 | 人機不允許發送資料到裝置
 |  |  | 範例 IF !CTS_STS (B) // 當CTS確定有效時，執行以下動作 TX = MOV($U100, 10) // 發送10位元組到裝置 ENDIF
RTS | 位 | 讀取/寫入 | 寫0到這個位，確認RTS信號有效。
 |  |  | 位的數值 | 功能
 |  |  | 0 | 確認RTS信號有效。裝置允許發送數據至觸控屏
 |  |  | 1 | 確認RTS信號無效。裝置不允許發送數據至觸控屏
 |  |  | 範例: RTS = 1 (B) // 不允許發送數據至觸控屏

  5. 了解通訊協定。
  6. 編寫巨集程式。下圖為範例：


3.4.8 使用人機閘道伺服器

使用人機閘道伺服器

人機中的閘道伺服器設置，可使人機應用程式在任何的計算機裝置(如電腦)，存取與人機連結的控制器數據。此設置讓HMI作為Modbus裝置。人機應用程式可使用Modbus Protocol，存取閘道伺服器的傳輸記憶區。

人機應用可選擇的閘道伺服器共有兩種。序列閘道伺服器為序列埠連接使用；TCP/IP閘道伺服器為乙太網路埠連接使用。

閘道伺服器 | 使用的協議 | 連線種類
TCP/IP 閘道伺服器 | Modbus TCP/IP | 乙太網路
閘道伺服器 | Modbus RTU | RS-232/422/485

上圖所顯示的藍色虛線表示PC可透過HMI閘道伺服器的服務，存取控制器#1和控制器#N的數據。


3.4.8.1 設定閘道服務

設定閘道服務

假設人機應用中有兩個連線：一個直接連線，透過COM1連接目標人機與PanelMaster -> Null PLC 裝置；另一個直接連線，透過COM2連接目標人機與Siemens AG -> Simatic S7-300(MPI Port) 裝置。欲使用閘道服務，可依以下步驟進行：

  1. 建立一個新的連線，在連線屬性對話框中，連線種類選擇閘道服務(乙太網路)，裝置/伺服器選擇TCP/IP Gateway Server。用戶需定義閘道服務的地址對應表，原因如下：

  2. 用戶需定義閘道服務的地址對應表，原因如下:
    ■ 當人機應用程式寫入數據區到閘道伺服器的傳輸記憶區中，閘道伺服器知道數據區實際應寫入的地址，並將數據寫入此地址。
    ■ 當人機應用程式讀取閘道伺服器傳輸記憶區中的位置時，閘道伺服器知道讀取操作的實際來源，並從此處讀取數據。

    欲定義地址對應表，點擊連線屬性對話框中的地址對應表。下圖為地址對應表的範例。

下表為閘道服務(乙太網路)連線，連線屬性對話框的地址對應表中，各項屬性的說明。

选项 | 屬性
用 | 勾選欲使用的對應區 #n。
序號 | 對應區的序號。
種類 | 選擇對應區的種類。位表示位區，字表示字區。
Modbus 地址 | 設定使用Modbus Protocol的計算機裝置的地址。地址範圍和傳輸記憶區種類如下表所示。
 | 地址範圍 | 種類 | 最大讀取/寫入區大小 | 註
 | 00001~02000 | 位 | 256位 |
 | 10001~12000 | 位 | 256位 | 只能讀取
 | 30001~39999 | 字 | 128字 | 只能讀取
 | 40001~49999 | 字 | 128字 |
只能讀取 | 設定區長度，如果種類為字，字區的單位為1個字。如果種類為位，位區單位為16個位。例如，對應位區3的大小為2個字和32個位。
對應地址 | 設定對應控制器或目標人機閘道伺服器的啟始地址。
預讀隨取 | 勾選此選項，將高速取回(high-speed retrieval)的回應數據(requested data)儲存於記憶區。
更新速率 | 只有當勾選預讀隨取，此選項才會出現。選擇快速，將每秒更新記憶區中的數據；或選擇一般，將每3秒更新記憶區中的數據。

限制:

  1. 最多可設定32個對應區。
  2. 最多12個對應區可設定預讀隨取。
  3. 最多4個對應區的更新速率可設定為快速。
  4. 當讀取字區或位區，這些讀取的字或位須為單一的對應區，否則讀取的操作將會無效。


3.4.9 選擇MODBUS驅動

選擇MODBUS驅動

下表可以幫助您選擇適合您的應用程式的Modbus通信驅動。

注意,下面的控制器品牌名稱是“Modicon Corp.”

機型（連接的驅動） | 備註
Modicon 984 Device/Slave (RTU) | 協議: Modbus RTU 裝置: Modbus Master/Client 被連接設備驅動: Modbus Slave/Server 可使用位址:
 | 地址範圍 | 備註
 | 1-9999 | 位
 | 10001-19999 | 位
 | 30001-39999 | 字
 | 40001-49999 | 字
 | 驅動名稱C2C031
ModBus Device/Slave (RTU, Quantum) ModBus Device/Slave (RTU, 6-digit Addresses) | 驅動名稱: C2C031 裝置：Modbus master/client 被連接設備驅動: Modbus slave/server 可使用位址:
 | 地址範圍 | 備註
 | 1-65536 | 位
 | 100001-165536 | 位
 | 300001-365536 | 字
 | 400001-465536 | 字
 | Bh0-Bhffff | 位記憶體;十六進位數，用於指定地址
 | Wh0-Whffff | 字記憶體;十六進位數，用於指定地址
 | 驅動名稱: C2C081
ModBus Device/Slave (ASCII) | 協議: Modbus ASCII 裝置: Modbus master/client 被連接設備驅動: Modbus slave/server 可使用位址:
 | 地址範圍 | 備註
 | 1-9999 | 位
 | 10001-19999 | 位
 | 30001-39999 | 字
 | 40001-49999 | 字
 | 驅動名稱: C2C071
Modicon 984 Master (RTU) | 協議: Modbus RTU 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍
 | 備註
 | 1-4096
 | 位
 | 10001-14096
 | 位
30001-38192
字
40001-48192
字
驅動名稱: C2C021
Modicon 984 Master (RTU; Little Memory) | 協議: Modbus RTU 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-1024 | 位
 | 10001-11024 | 位
 | 30001-30512 | 字
 | 40001-40512 | 字
 | 驅動名稱: C2C022
ModBus Master (RTU; Non-volatile slave data) | 協議: Modbus RTU 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 伺服器資料：存儲在電池的RAM 可使用位址:
 | 地址範圍 | 備註
 | 1-1024 | 位
 | 10001-11024 | 位
 | 30001-34096 | 字
 | 40001-44096 | 字
 | 驅動名稱: C2C121
Modbus Master (ASCII) | 協議: Modbus ASCII 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-4096 | 位
 | 10001-14096 | 位
 | 30001-38192 | 字
 | 40001-48192 | 字
 | 驅動名稱: C2C061
Modbus Master (ASCII; Little Memory) | 協議: Modbus ASCII 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-1024 | 位
 | 10001-11024 | 位
 | 30001-30512 | 字
 | 40001-40512 | 字
 | 驅動名稱:C2C062
ModBus Master (ASCII; Non-volatile slave data) | 協議: Modbus ASCII 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 伺服器資料：存儲在電池的RAM 可使用位址:
 | 地址範圍 | 備註
 | 1-1024 | 位
 | 10001-11024 | 位
 | 30001-34096 | 字
 | 40001-44096 | 字
 | 驅動名稱: C2C161
ModBus Device/Slave (TCP/IP) | 協議：modbus TCP/IP 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-9999 | 位
 | 10001-19999 | 位
 | 30001-39999 | 字
 | 40001-49999 | 字
 | 驅動名稱: C2C011
ModBus Device/Slave (TCP/IP; Type 2) | 協議：Modbus TCP/IP 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-65535 | 位
 | 100001-165535 | 位
 | 300001-365535 | 字
 | 400001-465535 | 字
 | 驅動名稱: C2C111
ModBus Master (TCP/IP) | 協議：Modbus TCP/IP 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-9999 | 位
 | 10001-19999 | 位
 | 30001-39999 | 字
 | 40001-49999 | 字
 | 驅動名稱: C2C001
ModBus Master (TCP/IP; Type 2) | 協議：Modbus TCP/IP 裝置: Modbus slave/server 被連接設備驅動: Modbus master/client 可使用位址:
 | 地址範圍 | 備註
 | 1-9999 | 位
 | 100001-109999 | 位
 | 300001-309999 | 字
 | 400001-409999 | 字
 | 驅動名稱: C2C101


3.4.10 通過乙太網訪問內部存儲器

通過乙太網訪問內部存儲器

本節介紹如何配置HMI，使其他設備可以通過乙太網路訪問HMI內部存儲器。

■ 訪問內部存儲器

為了使一個HMI訪問另外一個HMI的內部存儲器，你需要創建以下訪問HMI的通信鏈接。

註:

1) 使用Modbus TCP/IP協議。
2) 內部存儲服務器可以支持多達8個客戶端。
3) 一次可以讀取的最大數目的字為125。
4) 一次可以寫入的最大數目的字為120。
5) 一次可以讀取的最大數目的位為2000。
6) 一次可以寫入的最大數目的位為800。
7) 如果指定的內部存儲器中的地址或地址範圍是無效的或不可用的，該請求後失敗。
8) 驅動的名稱是 C2C301。

■ 訪問內部存儲器

為了使一個HMI訪問另外一個HMI的內部存儲器，你需要創建以下訪問HMI的通信鏈接。

請註意：使用參數頁面中指定的IP地址訪問HMI。

註:
1) 每個讀，寫操作的數據的數量是沒有限制。
2) 驅動的名稱C2C311。

下表描述的是用戶可一訪問的HMI單元的內部存儲器。

地址範圍 | 相應的內部存儲器的地址範圍 | 讀/寫 | 說明
N0.0-S4094.f | $N0.0-$N4094.f | 讀 | 電池保護記憶區
U0.0-N4094.f | $U0.0-$U4094.f | 讀/寫 | 普通用戶內存
U0-U8388607 | $U0-$U8388607 | 讀/寫 | 普通用戶內存
N0-N8388607 | $N0-$N8388607 | 讀/寫 | 電池保護記憶區
R0:0-R0:8388607 | $R0:0-$R0: 8388607 | 讀/寫 | 配方0區
R1:0-R1: 8388607 | $R1:0-$R1: 8388607 | 讀/寫 | 配方1區
R2:0-R2: 8388607 | $R2:0-$R2: 8388607 | 讀/寫 | 配方2區
… | … | … | …
R15:0-R15: 8388607 | $R15:0-$R15: 8388607 | 讀/寫 | 配方15區

■ Modbus主站/客戶端

一個Modbus主站/客戶端，支持訪問內部存儲器5位數的地址。

下表描述了Modbus主站/客戶端可以使用它來訪問內部存儲器的HMI單元的地址

地址 | 內部地址 | 讀/寫 | 說明
1-65535 | $U0.0-$U4095.e | 讀/寫 | 普通用戶內存
100001-165535 | $N0.0-$N4095.e | 讀 | 電池保護記憶區
300001-365535 | $N0-$N65534 | 讀 | 電池保護記憶區
400001-465535 | $U0-$U65534 | 讀/寫 | 普通用戶內存

一個Modbus主站/客戶端，支持功能碼20（讀）和21（寫）可以訪問到內部存儲器。

下表描述了Modbus主站/客戶端可以使用它來訪問內部存儲器的HMI單元的地址

地址類型 | 參考數 | 相應的內部存儲器的地址範圍 | 說明
0 | 0-8388607 | $U0-$U8388607 | 普通用戶內存
1 | 0-8388607 | $N0-$N8388607 | 電池保護記憶區
3 | 0-8388607 | $R0:0-$R0: 8388607 | 配方0區
4 | 0-8388607 | $R1:0-$R1: 8388607 | 配方1區
5 | 0-8388607 | $R2:0-$R2: 8388607 | 配方2區
... | ... | ... | ...
18 | 0-8388607 | $R15:0-$R15: 8388607 | 配方15區

註：

1) 內部存儲服務器僅支持同一時間一組功能碼20或21。


3.4.11 通過乙太網訪問西門子PLC

通過乙太網訪問西門子PLC

本節介紹如何配置HMI設備和西門子PLC程序，通過乙太網進行通信。

■ 創建連接

要與西門子PLC通訊，你需要創建以下的通信鏈接。

SIMATIC S7（乙太網）的驅動允許數據塊索引尋址。下面例子所示的地址是有效的。

DB[$I3].DBW100

DB[$I5+2].DBD[$I10+16]

DB[$I0+2].DBX[$I1].5

註：數據塊索引支持提供任何PLC驅動。

■ 設置鏈接屬性

為了確保通信正常，西門子PLC配置完畢後，您需要設置的機架號和插槽號。下面是一個例子，它使用預設的機架和槽號。

■ 訪問西門子PLC數據塊
 要訪問西門子PLC中的數據塊，在PLC程序的所有數據塊設定，必須取消“僅訪問”"Symbolic access only" 選項。如果該數據塊設定此選項，HMI單元將無法訪問數據塊並將顯示通信錯誤。

以下是取消選中“僅訪問”選項一個數據塊的例子。


3.5 聲音表

聲音表

聲音表包含人機應用中所使用的聲音。在人機應用新建時，聲音表是空白的。

在人機應用中，用戶可使用功能按鈕，播放指定的聲音。

在使用聲音之前，需將聲音導入或新增至聲音表中。

欲開啟聲音表對話框，方法如下：

  1. 在專案管理員視窗中，雙擊人機應用的聲音表節點( [image] )。
  2. 在專案管理員視窗中，在聲音表節點( [image] )上點擊滑鼠右鍵，從彈出視窗中，點選屬性。
  3. 在人機應用選單中，點選聲音表…。

下圖為聲音表對話框的範例。

下表說明如何讀取和使用聲音表對話框中的項目。

属性 | 说明
聲音 | 列出人機應用所使用的聲音，可以選擇一個或多個聲音。欲選擇聲音，點擊該聲音所在的標題列；欲同時選取多個聲音，按住Ctrl，再點選標題列。 下表為聲音表中，每個欄位的說明。
 | 欄位 | 說明
 | 編號 | 聲音在聲音表中的編號，編號為正整數，從0開始，編號不會重覆，點擊格子可編輯編號。
 | 名稱 | 聲音的名稱。點擊格子從下拉式清單，選擇聲音庫中，預設的聲音。有關預設聲音表中的聲音，請參考 章節 2.2.4 。
 | 種類 | 顯示聲音的種類。
確定 | 關閉對話框並接受對聲音表所做的改變。
取消 | 關閉對話框並取消對聲音表所做的改變。
導入… | 從聲音檔導入聲音。導入的格式支援WAV 與 MP3檔案。
新增 | 從聲音庫新增聲音到聲音表。聲音庫的使用，請參考 章節 2.2.4 .。
插入 | 從聲音庫插入聲音。聲音庫的使用，請參考 章節 2.2.4 .。當選取聲音後，可選擇此按鈕。
刪除 | 刪除所選取的項目，當選取聲音後，可選擇此按鈕。
往上移 | 將選取的項目在清單中上移。當選取聲音後，可選擇此按鈕。
往下移 | 將選取的項目在清單中下移。當選取聲音後，可選擇此按鈕。


3.6 命令區與狀態字

命令區與狀態字

用戶可使用命令區指示人機執行多項功能。命令區為控制器或內部記憶區中的字區塊，人機定期掃瞄控制區和根據控制區的內容，並執行指定的功能。用戶可決定命令區大小、命令字、命令區的掃描時間，使讀取命令區的時間減少，以提高人機的運行效率。

人機藉由寫入狀態數值至狀態字，提供狀態的訊息。狀態字在控制器或內部記憶區中。用戶可以決定人機應用所需的狀態字，減少輸出無用的狀態數值，可提高人機的運行效率。


3.6.1 命令區與狀態字的種類

命令區與狀態字的種類

在人機應用中，有三種命令區和狀態字的分類。


3.6.1.1 種類

種類A

■ 種類A命令區
用戶可使用以下在人機應用中的命令字，命令字在命令區中的位置可調整。

畫面切換暫存器

用戶可以在此字變數設定所需的畫面編號，使人機改變主畫面或顯示視窗畫面。

命令位字(命令位#0 ~ #15)
下表說明命令位字中，每一個命令位的功能。

位 | 功能 | 說明
0 | (保留位) |
1 | 切換語言 | 改變人機顯示的語言。 參數一暫存器：設定所需語言的編號。
2 | 設當前配方編號 | 改變指定配方區的當前配方編號。 參數一暫存器：設定配方編號 參數二暫存器：設定配方區 註：若人機應用只有一個配方區，則不用設定配方區。
3 | 從PLC讀取配方 | 從配方區對話框定義的指定地址讀取配方，使用此配方取代指定配方區的配方。 參數一暫存器：設定配方編號 參數二暫存器：設定配方區 註：若人機應用只有一個配方區，則不用設定配方區。
4 | 寫出配方到PLC | 寫出指定配方區的指定配方，至配方區對話框中所指定的地址。 參數一暫存器：設定配方編號 參數二暫存器：設定配方區 註：若人機應用只有一個配方區，則不用設定配方區。
5 | 清除警報歷史 | 清除警報歷史。
6 | 清除警報計數 | 清除警報計數。
7 | 使蜂鳴器發聲 | 使蜂鳴器發聲。 參數一暫存器：設定聲音種類。
 |  | 聲音種類的數值 | 說明
 |  | 0 | 連續嗶聲。
 |  | 1 | 間隔500毫秒(ms)嗶聲。
 |  | 2 | 間隔200毫秒(ms)嗶聲。
 |  | 3 | 間隔100毫秒(ms)嗶聲。
 |  | 4 | 間隔50毫秒(ms)嗶聲。
8 | 列印畫面 | 列印指定的畫面。
 |  | 參數一暫存區 | 功能
 |  | (未定) | 列印最上層畫面。
 |  | 0 | 列印最上層畫面。
 |  | 欲列印的畫面編號 | 列印指定的畫面。
9 | 開背燈 | 開啟背燈。
10 | 關閉背燈 | 關閉背燈。
11 | 設當前用戶等級 | 設定當前用戶等級。 參數一暫存器：用戶等級。
12 | 關閉所有視窗畫面 | 關閉所有視窗畫面。
13 | (保留位) |
14 | (保留位) |
15 | (保留位) | 詳細說明，請參考 章节3.6.7 使用通用命令。

註：欲啟動上述功能，用戶必須將關聯命令位狀態，從0變為1。人機並不會自動重置命令位，因此，用戶必須在執行相同的功能之前，重置命令位。此外，命令位狀態的改變需維持，使人機可偵測到此狀態的改變。因此，最好的方式是使用關聯狀態字的回應位。當人機偵測到狀態的改變，將開啟回應位。而當看到回應位開啟，就表示需重置命令位。當命令位狀態變為0，關閉回應位。

低觸發字(觸發位#0 ~ #15)，高觸發字(觸發位#16 ~ #31)

用戶可使用觸發位啟動以下功能：

  1. 使關聯數據收集器收集數據。
  2. 使關聯數據收集器清除緩存。
  3. 執行事件巨集。
  4. 將時間增加一小時。
  5. 將時間減少一小時。
  6. 登入
  7. 登出
  8. 使關聯曲線圖讀取和繪製新的數據。
  9. 使關聯曲線圖清除內容。
  10. 使關聯二維散佈圖讀取和繪製新的數據。
  11. 使關聯二維散佈圖清除內容。

致能字(致能位#0 ~ #15)

用戶可以使用致能位啟動以下功能：

  1. 數據收集器收集數據。

參數一暫存器

此字設定參數#1的功能。

參數二暫存器

此字設定參數#2的功能。

參數三暫存器

此字設定參數#3的功能。

參數四暫存器

此字設定參數#4的功能。

■ 種類A狀態字

人機應用中有以下狀態字。

狀態字 | 說明
命令狀態字 (命令回應位#0 ~ -#15) | 儲存命令回應位#0 ~ #15。
低觸發回應字 (命令回應位#0 ~ -#15) | 儲存觸發回應位#0 ~ #15。
高觸發回應字 (觸發回應位#16 ~ #31) | 儲存觸發回應位#16 ~ #31
當前畫面編號 | 儲存當前主畫面編號。
當前配方區編號 | 儲存當前配方區編號。
當前配方編號 | 儲存當前配方編號。
當前用戶等級 | 儲存當前用戶等級。
當前語言 | 儲存當前語言。


3.6.1.2 種類H (Binary)

種類H (Binary)

■ 種類H (Binary)命令區

人機應用支援以下的命令字。

畫面編號暫存器

用戶可以在此字變數設定所需的畫面編號，使人機改變主畫面或顯示視窗畫面。另外，也可藉由此字變數的設定1)改變語言2)開啟背燈3)關閉背燈。下表說明此字變數的設定

位 | 說明
0-9 | 設定顯示的畫面。
11-13 | 設定人機顯示的語言。 000: 人機不執行任何操作。 001: 人機變更語言為語言1。 010: 人機變更語言為語言2。 ... 111: 人機變更語言為語言7。
14 | 當此位狀態為1，人機關閉背燈顯示。
15 | 當此位狀態為1，人機開啟背燈顯示。

命令旗標
 下表說明命令旗標中，每一個命令位的功能。

位 | 功能
0 | 清除警報歷史。
1 | 清除警報計數。
2 | (保留)
3 | (保留)
4 | 寫配方區#0的當前配方，到配方區對話框中配方區#0所指定的地址。
5 | 設定配方區#0的當前配方編號，為配方編號暫存器中所指定的編號。
6 | 設定配方區#0的當前配方編號，為配方編號暫存器中所指定的編號。
7 | 使蜂鳴器發聲。
8 | 觸發位#4。
9 | 觸發位#5。
10 | 觸發位#6。
11 | 觸發位#7。
12 | 觸發位#0。
13 | 觸發位#1。
14 | 觸發位#2。
15 | 觸發位#3。

註：欲啟動上述功能，用戶必須將關聯命令位狀態，從0變為1。人機並不會自動重置命令位，因此，用戶必須在執行相同的功能之前，重置命令位。此外，命令位狀態的改變需維持到使人機可偵測到此狀態的改變。因此，最好的方式是使用關聯狀態字的回應位。當人機偵測到狀態的改變，將開啟回應位。而當看到回應位開啟，就表示需重置命令位。當命令位狀態變為0，再關閉回應位。

配方編號暫存器

當命令旗標的位5的狀態由0變為1，則此字變數作為命令區#0的當前配方編號。

■ 狀態字

人機應用中可支援以下的狀態字。

狀態字 | 說明
畫面狀態 | 當前畫面編號
一般狀態 | 包含命令旗標的回應位。
當前配方編號 | 儲存配方區#0的當前配方編號。


3.6.1.3 種類H (BCD)

種類H (BCD)

人機應用支援的命令字和狀態字與種類H(Binary)相同。然而，相關命令控制的字變數的數值需為BCD格式：畫面編號器、配方編號暫存器、畫面狀態和當前配方編號等等,包含命令旗標的回應位。


3.6.2 命令區與狀態字 - 一般設定

命令區與狀態字 - 一般設定

本章節說明在命令與狀態對話框一般頁中，命令字和狀態字的一般設定。下圖為一般頁的範例。

下表為一般頁中，各項屬性的說明。

屬性 |  | 說明
種類 |  | 選擇人機應用命令區和狀態字的種類： A, H (Binary), H (BCD)
使用命令區 |  | 勾選此選項，人機可使用命令字。
讀取地址 |  | 設定命令區地址。
大小 |  | 設定命令區大小。
掃描時間 |  | 設定人機掃瞄命令區的間隔時間，選項如下： 1秒、0.5秒和0.25秒。
命令區映象 | 位地址範圍 | 顯示命令區有效的位地址範圍。注意，人機僅能讀取位變數。
 | 字地址範圍 | 顯示命令區有效的字地址範圍。注意，人機僅能讀取字變數。


3.6.3 命令區設定(種類A)

命令區設定(種類A)

本章節說明在命令與狀態對話框的命令區頁，種類A命令區的屬性設定。下圖為命令區頁的範例。

下表為命令區頁中，各項屬性的說明。

屬性 |  | 說明
命令字 | 位置安排 | 選擇“預設”，則命令字將為命令區中的預設次序。選擇“自訂”，則命令字將由用戶設定。
 | 畫面切換暫存器 | 勾選此選項，用戶可勾選此選項，用戶可以在此字變數改變所需的畫面編號，使人機改變主畫面或顯示視窗畫面。
 | 自動清零 | 當勾選此選項，當偵測到字變數中有非0的數值，人機重置畫面切換暫存器為0；當未勾選此選項，只有當畫面有效且未顯示時，人機重置畫面切換暫存器為0。
 | 參數一暫存器 | 勾選此選項，可使用此字變數，設定參數一暫存器的功能。
 | 命令位#0 ~ #15 | 勾選此選項，使用命令位控制人機執行指定的功能。
 | 觸發位#0 ~ #15 | 勾選此選項，可使用此字變數中的觸發位。
 | 參數二暫存器 | 勾選此選項，可使用此字變數，設定參數二暫存器的功能。
 | 觸發位#16 ~ #31 | 勾選此選項，可使用此字變數中的觸發位。
 | 致能位#0 ~ #15 | 勾選此選項，可使用此字變數中的致能位。
 | 參數三暫存器 | 勾選此選項，可使用此字變數，設定參數三暫存器的功能。
 | 參數四暫存器 | 勾選此選項，可使用此字變數，設定參數四暫存器的功能。
命令位 | 切換語言(#1) | 勾選是否使用命令位#1，使人機顯示指定的語言。需設定的部份如下： 1) 參數一暫存區：所需語言的編號。
 | 設當前配方編號(#2) | 勾選是否使用命令位#2，使人機設定當前配方編號。需設定的部份如下： 1)參數一暫存器：配方編號 2)參數二暫存器：配方區 註：若人機應用中只包含一個配方區，則不需設定配方區。
 | 從PLC讀取配方(#3) | 勾選是否使用命令位#3，使人機從配方區對話框中指定的地址讀取配方，並使用此配方取代配方區對話框中所指定配方。需設定的部份如下： 1)參數一暫存器：配方編號 2)參數二暫存器：配方區 註：若人機應用中只包含一個配方區，則不需設定配方區。
 | 寫出配方到PLC(#4) | 勾選是否使用命令位#4，寫出配方到配方區對話框中指定的地址。需設定的部份如下： 1)參數一暫存器：配方編號 2)參數二暫存器：配方區 註：若人機應用中只包含一個配方區，則不需設定配方區。
 | 清除警報歷史(#5) | 勾選是否使用命令位#5，使人機清除警報歷史。
 | 清除警報計數(#6) | 勾選是否使用命令位#6，使人機清除警報計數。
 | 使蜂鳴器發聲(#7) | 勾選是否使用命令位#7，使蜂鳴器發出設定的聲響。 需設定的項目如下： 1)參數一暫存器：聲音種類 下表說明蜂鳴器可發出的聲音種類。
 |  | 聲音種類數值 | 說明
 |  | 0 | 連續嗶聲。
 |  | 1 | 間隔500毫秒(ms)嗶聲。
 |  | 2 | 間隔200毫秒(ms)嗶聲。
 |  | 3 | 間隔100毫秒(ms)嗶聲。
 |  | 4 | 間隔50毫秒(ms)嗶聲。
 | 列印畫面(#8) | 勾選是否使用命令位#8，使人機列印指定畫面。 需設定的項目如下： 1)參數一暫存器：欲列印的畫面編號。 註1：若無參數一暫存器或畫面編號為0，則列印最上方的畫面。
 | 開背燈(#9) | 勾選是否使用命令位#9，使人機開啟背燈。
 | 關背燈(#10) | 勾選是否使用命令位#10，使人機關閉背燈。
 | 設當前用戶等級(#11) | 勾選是否使用命令位#11，使人機設定當前用戶等級。 需設定的項目如下： 1)參數一暫存器：用戶等級
 | 關閉所有視窗畫面(#12) | 勾選是否使用命令位#12，使人機關閉所有視窗畫面。
 | 執行通用命令(#15) | 勾選是否使用命令位#15，使人機執行指定的功能，詳細說明，請參考章節3.6.7 使用通用命令。


3.6.4 狀態字設定(種類A)

狀態字設定(種類A)

本章節說明在命令與狀態對話框的狀態字頁，種類A狀態字的屬性設定。下圖為狀態字頁的範例。

在狀態字頁，勾選人機應用所需的狀態字。所選取的狀態字，需設定接收狀態數值的字變數。

下表說明人機寫入狀態字的內容與時機。

狀態字 | 說明
命令回應位#0 ~ #15 | 當有效命令位的狀態改變時，人機寫入有效命令位的狀態到字變數。
觸發回應位#0 ~ #15 | 當觸發位#0 ~ #15的狀態改變時，人機寫入有效觸發位#0 ~ #15的狀態到字變數。
觸發回應位#16 ~ #31 | 當觸發位#16 ~ #31的狀態改變時，人機寫入有效觸發位#16 ~ #31的狀態到字變數。
當前畫面編號 | 當主畫面改變時，人機寫入當前主畫面編號至此字變數。
當前配方區編號 | 當不同的配方區變為當前配方區，人機寫入當前配方區編號至此字變數。
當前配方編號 | 當不同的配方變為當前配方，人機寫入當前配方至此字變數。
當前用戶等級 | 當當前用戶等級改變時，人機寫入當前用戶等級至此字變數。
當前語言 | 當當前語言改變時，人機寫入當前語言至此字變數。


3.6.5 命令區設定(種類H)

命令區設定(種類H)

本章節說明在命令與狀態對話框的命令區頁，種類H命令區的屬性設定。下圖為命令區頁的範例。

下表為命令區頁中，各項屬性的說明。

屬性 |  | 說明
命令區 | 畫面編號暫存器 | 用戶可以藉由在此字變數設定所需的畫面編號，使人機改變主畫面或顯示視窗畫面。此外，也可進行如下的操作：1) 改變語言 2) 開背燈 3) 關背燈。 下表說明位的安排。
 |  | 位 | 說明
 |  | 0-9 | 設定欲顯示的畫面。
 |  | 11-13 | 設定人機顯示的語言。 000: 人機進行任何操作。 001: 人機改變語言為語言1。 010: 人機改變語言為語言2。 ... 111: 人機改變語言為語言7。
 |  | 14 | 若未狀態為On，則關閉背燈顯示。
 |  | 15 | 若未狀態為On，則開啟背燈顯示。
 | 自動清零 | 當勾選此選項，當偵測到此字變數中有非0的數值，人機重置畫面切換暫存器為0；當未勾選此選項，只有當畫面有效且未顯示，人機重置畫面切換暫存器為0。
 | 命令旗標 | 用戶可使用命令旗標，使人機執行指定的功能。
 | 配方編號暫存器 | 當使用命令旗標#5，設定配方區#0的當前配方編號，用戶須在此字變數中設定配方編號。
命令旗標 | 清除警報歷史(#0) | 勾選是否使用命令旗標#0，使人機清除警報歷史。
 | 清除警報計數(#1) | 勾選是否使用命令旗標#1，使人機清除警報計數。
 | 寫配方到PLC(#4) | 勾選是否使用命令旗標#4，使人機寫入配方區#0的當前配方到配方區對話框中所指定的地址。
 | 設定當前配方編號(#5) | 勾選是否使用命令旗標#5，設定配方區#0的當前配方編號。 用戶需設定的項目包含： 1) 配方編號暫存器：配方編號
 | 從PLC讀取配方(#6) | 勾選是否使用命令旗標#6，從配方區對話框中所指定的地址讀取配方，並使用此配方取代配方區#0的當前配方。
 | 使蜂鳴器發聲(#7) | 勾選是否使用命令旗標#7，使蜂鳴器發聲。
 | 觸發位#4(#8) | 勾選是否使命令旗標#8，作為觸發位#4。
 | 觸發位#5(#9) | 勾選是否使命令旗標#9，作為觸發位#5。
 | 觸發位#6(#10) | 勾選是否使命令旗標#10，作為觸發位#6。
 | 觸發位#7(#11) | 勾選是否使命令旗標#11，作為觸發位#7。
 | 觸發位#0(#12) | 勾選是否使命令旗標#12，作為觸發位#0。
 | 觸發位#1(#13) | 勾選是否使命令旗標#13，作為觸發位#1
 | 觸發位#2(#14) | 勾選是否使命令旗標#14，作為觸發位#2。
 | 觸發位#3(#15) | 勾選是否使命令旗標#15，作為觸發位#3。


3.6.6 狀態字設定(種類H)

狀態字設定(種類H)

本章節說明在命令與狀態對話框的狀態字頁，種類H狀態字的屬性設定。下圖為狀態字頁的範例。

在狀態字頁，勾選人機應用所需的狀態字。所選取的狀態字，需設定接收狀態數值的字變數。

下表說明人機寫入狀態字的內容與時機。

狀態字 | 說明
畫面狀態 | 當主畫面改變時，人機寫入當前畫面到此字變數。
一般狀態 | 當有效命令位上的狀態改變時，人機寫入有效命令位狀態到此字變數。
當前配方編號(配方區0) | 當配方區0的當前配方被另一配方取代，人機寫入配方區0的當前配方編號到此字變數。


3.6.7 使用通用命令

使用通用命令

本章節說明如何使用種類A的命令區的通用命令。欲使用通用命令，在參數暫存器設定所需的參數，並開啟命令位字(Command Flag Register)的#15命令位。

用戶可以使用通用命令和預設檔名，使人機執行以下的功能：

功能 | 參數一暫存器(功能碼) | 參數二暫存器(數據編號) | 預設檔名格式
儲存歷史數據到TXT檔 | 1 | 數據收集器編號(0~15) | DL<ID>_<Date>_<Time>.txt
儲存歷史數據到CSV檔 | 14 | 數據收集器編號(0~15) | DL<ID>_<Date>_<Time>.csv
儲存警報歷史到TXT檔 | 1 | (不需要) | AL_<Date>_<Time>.txt
儲存警報歷史到CSV檔 | 15 | (不需要) | AL_<Date>_<Time>.csv
儲存警報計數到TXT檔 | 3 | (不需要) | AC_<Date>_<Time>.txt
儲存警報計數到CSV檔 | 16 | (不需要) | AC_<Date>_<Time>.csv
儲存配方數據到TXT檔 | 4 | 配方區編號(0~15) | RB<ID>.txt
儲存配方數據到CSV檔 | 17 | 配方區編號(0~15) | RB<ID>.csv
儲存配方數據到DAT檔 | 5 | 配方區編號(0~15) | RB<ID>.dat
列印畫面到BMP檔(256K色) | 6 | 畫面編號 | S<ID>_<Date>_<Time>.bmp
BMP檔（真彩）列印畫面在PC上運行 | 6 | 畫面編號 | S<ID>_<Date>_<Time>.bmp
列印畫面到BMP檔(64K色) | 7 | 畫面編號 | S<ID>_<Date>_<Time>.bmp
在PC上列印畫面JPG文件 | 7 | 畫面編號 | S<ID>_<Date>_<Time>.bmp
儲存操作記錄到TXT檔 | 9 | (不需要) | OL_<Date>_<Time>.txt
儲存操作記錄到CSV檔 | 18 | (不需要) | OL_<Date>_<Time>.csv
儲存操作記錄到LDF檔 | 10 | 數據收集器編號(0~15) | DL<ID>_<Date>_<Time>.ldf
拍照並儲存到BMP檔 | 12 | USB相機編號(0~3) | CAM<ID>_<Date>_<Time>.bmp
拍照並儲存到JPG檔 | 13 | USB相機編號(0~3) | CAM<ID>_<Date>_<Time>.jpg
列印畫面檔為JPG格式 | 19 | 畫面編號 | S<ID>_<Date>_<Time>.jpg
以JPG格式的圖片保存在HMI上 | 24 | 視頻通道ID（1-2） | V<ID>_<Date>_<Time>.jpg

預設檔名格式:

<ID>: 數據收集器編號、配方區編號、USB相機編號或畫面編號。

<Date>: 數據儲存的日期；格式為YYMMDD。

<Time>: 數據儲存的時間；格式為hhmmss。

用戶利用通用命令和指定的檔名，使人機執行以下的檔案操作：

功能 | 參數一暫存區(功能碼) | 參數二暫存區(數據編號) | 參數三暫存器(設定檔名)
儲存歷史數據到TXT檔 | 31 | 數據收集器編號(0~15) | 設定內部記憶區$U的地址，此地址儲存指定的檔名或完整路徑。檔名需包含有效的路徑和ASCII字的檔名。字串需為空白中止，每個字元佔一個位元空間。最大長度為127位元。路徑所指定的檔案夾必須存在，否則檔案的操作將失敗。例如，儲存在編號400的暫存器，表示檔名儲存的位址為$U400。
儲存警報歷史到TXT檔 | 32 | (不需要) | 同上
儲存警報計數到TXT檔 | 33 | (不需要) | 同上
儲存配方數據到TXT檔 | 34 | 配方區編號(0~15) | 同上
儲存配方數據到DAT檔 | 35 | 配方區編號(0~15) | 同上
儲存操作紀錄到TXT檔 | 39 | (不需要) | 同上
儲存歷史數據到LDF檔 | 40 | 數據收集器編號(0~15) | 同上
拍照並存為BMP檔 | 42 | USB相機編號(0~3) | 同上
拍照並存為JPG檔 | 43 | USB相機編號(0~3) | 同上
JPG格式的圖片保存在HMI上 | 54 | 視頻通道ID（1-2） | 同上


3.7 設定時鐘

設定時鐘

本章節說明在時鐘對話框中如何設定時鐘的各項屬性。下圖為時鐘對話框的範例。

下表為時鐘對話框中，各項屬性的說明。

屬性 |  |  | 說明
寫時間到PLC | 寫時間/日期到PLC |  | 選擇此選項，人機可寫入時間和日期的訊息至指定的變數。
 | 數據種類 |  | 選擇時間和日期輸出的數據種類，如下表：
 |  |  | 數據種類 | 說明
 |  |  | 6 BCD 位元組 | 下表顯示數據結構。
 |  |  |  | 位元組編號 | 內容
 |  |  |  | 0 | 分；0~59
 |  |  |  | 1 | 時；0~23
 |  |  |  | 2 | 日；1~31
 |  |  |  | 3 | 月；1~12
 |  |  |  | 4 | 年；00~99
 |  |  |  | 5 | 週日；0(星期天)~6(星期六)
 |  |  |  | 6 | 秒；0-59
 |  |  |  | 7 | 0
 |  |  |  | 註：所有數值皆為BCD格式。
 |  |  | 8 BCD 位元組 | 下表顯示數據結構。
 |  |  |  | 位元組編號 | 內容
 |  |  |  | 0 | 分；0~59
 |  |  |  | 1 | 時；0~23
 |  |  |  | 2 | 日；1~31
 |  |  |  | 3 | 月；1~12
 |  |  |  | 4 | 年；00~99
 |  |  |  | 5 | 週日；0(星期天)~6(星期六)
 |  |  |  | 6 | 秒；0-59
 |  |  |  | 7 | 0
 |  |  |  | 註：所有數值皆為BCD格式
 |  |  | 7 BCD 字 | 下表顯示數據結構。
 |  |  |  | 字編號 | 內容
 |  |  |  | 0 | 秒；0-59
 |  |  |  | 1 | 分；0~59
 |  |  |  | 2 | 時；0~23
 |  |  |  | 3 | 日；1~31
 |  |  |  | 4 | 月；1~12
 |  |  |  | 5 | 年；00~99
 |  |  |  | 6 | 週日；0(星期天)~6(星期六)
 |  |  | 7 二進制字 | 下表顯示數據結構。
 |  |  |  | 字編號 | 內容
 |  |  |  | 0 | 秒；0-59
 |  |  |  | 1 | 分；0~59
 |  |  |  | 2 | 時；0~23
 |  |  |  | 3 | 日；1~31
 |  |  |  | 4 | 月；1~12
 |  |  |  | 5 | 年；00~99
 |  |  |  | 6 | 週日；0(星期天)~6(星期六)
 |  |  | 7 BCD字節（8個字節的I / O） | 歐姆龍PLC的資料類型。顯示在下麵的資料類型有7個位元組，但實際操作會需要8個位元組。
 |  |  |  | 位元組編號 | 內容
 |  |  |  | 0 | 秒；0-59
 |  |  |  | 1 | 分；0~59
 |  |  |  | 2 | 時；0~23
 |  |  |  | 3 | 日；1~31
 |  |  |  | 4 | 月；1~12
 |  |  |  | 5 | 年；00~99
 |  |  |  | 6 | 週日；0(星期天)~6(星期六)
 |  |  |  | 7 | 0
 |  |  |  | 註：所有的值以BCD格式
 | 寫入地址 |  | 設定接收輸出時間與日期變數的位址。
 | 寫啟動方式 | 計時 | 當勾選此項目，在間隔欄位選擇間隔時間，人機將定時寫入時間和日期到指定的變數。時間的間隔範圍從1到255分鐘。
 |  | 觸發 | 當勾選此項目，當觸發指定的位，使位狀態從0到1時，人機將寫入時間和日期到指定的變數。
與PLC時間同步 | 與PLC時間同步 |  | 勾選此選項，可從指定的變數讀取時間和日期，並依此調整時鐘。
 | 數據種類 |  | 設定輸入時間和日期的數據種類。詳細說明，請參考“寫入“部分，數據種類的說明。
 | 讀取地址 |  | 設定人機讀取時間和日期的變數地址。
 | 啟動後首次自動同步必須成功才可運行人機應用 |  | 當勾選此選項，啟動後，自動同步須成功，才可運行人機應用。
 | 讀啟動方式 | 計時 | 當勾選此項目，在間隔欄位選擇間隔時間，人機將定時讀取時間和日期到指定的變數。時間的間隔範圍從1到255分鐘。
 |  | 觸發 | 當勾選此項目，當觸發指定的位，使位狀態從0到1時，人機將讀取時間和日期到指定的變數。
增時 |  |  | 勾選此選項，用戶可藉由改變觸發位狀態，使位狀態從0到1，將人機時鐘增時一小時。
減時 |  |  | 此選項，用戶可藉由改變觸發位狀態，使位狀態從0到1，將人機時鐘減時一小時。


3.8 設定密碼

設定密碼

本章節說明如何使用密碼對話框，設定人機應用的密碼。下圖為密碼對話框的範例。

下表為密碼對話框中，各項屬性的說明。

屬性 | 屬性
密碼 | 密碼欄包含8個欄位，用戶可在各欄位設定關聯用戶等級的密碼。密碼為最多8位的正整數。相同人機應用中的密碼不能重複。
說明 | 說明欄位為8個可編輯的欄位。用戶可以輸入密碼或用戶等級關聯欄位的說明。
等級9欄位 | 勾選是否設定開發者密碼為最高等級的密碼。
用戶等級不足時自動要求高等級者登入 | 當人機操作員觸摸物件，需要更高用戶等級才能執行物件操作時，密碼鍵盤會顯示需要輸入更高用戶等級密碼訊息。
登入之觸發位 | 當指定觸發位狀態從0變為1，密碼鍵盤顯示輸入密碼訊息。操作員需輸入有效密碼或取消密碼鍵盤。
登出之觸發位 | 當指定的觸發位狀態從0變為1，當前用戶等級重置為0。
登入逾時時間 | 當操作員超過一段時間未輸入，密碼鍵盤自動關閉。
應用程式可以支援32個用戶名稱和密碼 | 密碼對話視窗，支援以下內容： 1. 可指定用戶名，操作記錄可記錄登入者名稱。 2. 應用程式可以支援32個用戶名稱和密碼。 3. 為了使登入更安全，登錄時可以要求輸入用戶名，本功能可支援32個用戶名。 使用者管理用户名和密碼，HMI與密碼表如下圖所示:
登錄時可以要求輸入用戶名 | HMI顯示視窗，如下圖所示，要求使用者輸入用戶名和密碼。


3.9.1 畫面種類

畫面種類

共有以下三種畫面：普通畫面、視窗畫面、菜單畫面。

欲新建畫面，步驟如下：

  1. 新建畫面，預設畫面為普通畫面。欲了解如何新建畫面，詳細說明，請參考章節3.9.2。
  2. 開啟畫面屬性對話框。欲了解如何開啟畫面屬性對話框，詳細說明，請參考章節3.9.3。
  3. 在對話框中，選擇所需的畫面種類。

下表說明各種類畫面開啟、關閉和顯示的方式。

種類 | 說明
普通畫面 | 當畫面被選擇作為啟始畫面，或按壓畫面按鈕，執行開啟畫面/前一畫面，顯示此畫面。 通常在開啟其他一般畫面之前，無法關閉一般畫面。 當人機應用只有一個畫面時，普通畫面亦稱為主畫面。畫面大小依據人機機型所決定。
視窗畫面 | 視窗畫面在以下幾種情形出現： l 按壓畫面按鈕，執行開啟畫面操作。 l 作為啟始畫面。 l 使用巨集指令OPEN_WS l 若勾選在數位/類比警報區的“顯示視窗畫面”選項，當警報啟動或清除時。 l 使用選頁器物件。 l 製作客制鍵盤。 通常視窗畫面停留在普通畫面上，直到點擊標題欄的關閉按鈕或使用畫面按鈕或使用巨集指令CLOSE_WS，結束視窗畫面，視窗畫面才會關閉。 人機可同時顯示多個視窗畫面。 在運行時，視窗畫面將顯示於預設的位置。若視窗畫面有標題欄，用戶可點擊並按住滑鼠不放，即可移動視窗畫面。
菜單畫面 | 當畫面被選擇作為啟始畫面，或按壓畫面按鈕，執行開啟畫面，顯示此畫面。 通常菜單畫面停留在普通畫面或視窗畫面上，直到點擊菜單畫面以外區域或使用畫面按鈕關閉畫面，結束菜單畫面，菜單畫面才會關閉。 人機一次僅可顯示一個菜單畫面。 菜單畫面可從畫面左或右方水平地滑進畫面中，亦可以在功能按鈕左方或右方，向上或向下進入畫面。有關功能按鈕設定菜單畫面位置的方法，請參考 章节5.3.4 。


3.9.2 新建及開啓畫面

新建及開啓畫面

■ 新建畫面

欲新建畫面，步驟如下：

  1. 以下方法可擇一進行：

    * 在畫面選單，點擊新畫面…
    *     在專案管理員視窗，人機應用 > 畫面節點上，點擊滑鼠右鍵，從彈出選單中，點擊新畫面…

  2. 在新畫面對話框中，輸入畫面名稱及編號，按下Enter鍵或點擊確認按鈕，即可新建畫面。以下為新畫面對話框的範例。

註：在人機應用中，畫面名稱與編號不能重複出現。

■ 開啟畫面

欲開啟畫面，方法如下：

  1. 在專案管理員視窗中，雙擊所欲開啟的畫面。

  2. 在畫面選單中，點擊開啟畫面…，在開啟畫面對話框中，選取一個或多個畫面，點擊開啟，即可開啟所選取的畫面。

    下圖為開啟畫面對話框的範例。

■ 在開啟後，啟動畫面

欲開啟部分或全部被其他畫面擋住的畫面，方法如下：

  1. 在專案管理員視窗中，雙擊所需畫面。
  2. 在視窗選單中，點擊欲啟動的畫面。或點擊視窗…，從彈出的視窗對話框中，選擇所需的畫面並點擊啟動按鈕。
  3. 點擊畫面上任何一處。若畫面已經最大化，點擊畫面上的抬頭列。


3.9.3 設定畫面

設定畫面

用戶可在畫面屬性對話框中，設定畫面的各項屬性。

欲設定畫面，在專案管理員視窗 > 人機應用 > 畫面上，點擊滑鼠右鍵，從彈出選單中，選擇屬性。

欲設定當前畫面(即所開啟畫面中，於最上方的畫面)，方法如下：

  1. 在專案管理員視窗中，雙擊當前畫面。
  2. 在當前畫面空白處點擊滑鼠右鍵，從彈出選單中，點選畫面屬性…。
  3. 在畫面選單中，點擊畫面屬性…。

畫面屬性對話框包含以下四個頁面。某些頁面在需要設定時才會出現。

■ 一般頁(General)
 詳閱章節 3.9.3.1.說明。

■ 背景頁(Background)
 詳閱章節 3.9.3.2.說明。

■ 按鍵頁(Keys)
 詳閱章節 3.2.2.說明。

■ 開巨集頁(Open Macro) / 關巨集頁(Close Macro) / 循環巨集頁(Cycle Macro)
 詳閱章節 15.2.6..說明。


3.9.3.1 一般頁

一般頁

本章節說明畫面屬性對話框一般頁的設定。下圖為對話框一般頁的範例。

下表為一般頁中，各項屬性的說明。

屬性 |  | 說明
畫面編號 |  | 設定畫面的編號，範圍從1到7999。
畫面名稱 |  | 設定畫面的名稱。
使用本畫面 |  | 勾選是否使用此畫面。
種類 |  | 設定畫面的種類。有三個種類：普通畫面、視窗畫面和菜單畫面。詳細說明，請參考章節 3.9.1。
寬度 |  | 設定畫面寬度(單位為像素)。當畫面種類為視窗畫面或菜單畫面時，可設定此屬性。
高度 |  | 設定畫面高度(單位為像素)。當畫面種類為視窗畫面或菜單畫面時，可設定此屬性。
顯示於螢幕正中 |  | 勾選此選項，畫面將顯示於螢幕中央。當畫面種類為視窗畫面，可設定此屬性。
顯示於 |  | 勾選此選項，可設定畫面顯示於指定的位置。當畫面種類為視窗畫面，可設定此屬性。
 | X | 設定視窗畫面左上角，在普通畫面中，X軸的座標位置。
 | Y | 設定視窗畫面左上角，在普通畫面中，Y軸的座標位置。
抬頭列 |  | 勾選此選項，當畫面種類為視窗畫面時，畫面顯示抬頭列。
關閉按鈕 |  | 勾選此選項，當畫面種類為視窗畫面時，且勾選抬頭列，畫面顯示關閉按鈕。
語言 |  | 選擇檢視與編輯抬頭列設定使用的語言。當畫面種類為視窗畫面，且勾選抬頭列，此欄位才會出現。
抬頭 |  | 設定抬頭列顯示的抬頭。當畫面種類為視窗畫面，且勾選抬頭列，此欄位才會出現。
基底畫面 | <勾選框> | 勾選當前畫面是否支援基底畫面。
 | <複合框> | 設定畫面為基底畫面。勾選基底畫面後，此選項才會出現。
開巨集 |  | 勾選畫面是否支援開巨集。 當畫面開啟時，會先執行此巨集內所有程式一次。等畫面開巨集執行完畢後，畫面才會出現。用戶可使用開巨集指令，將全局數據和設定初使化。
關巨集 |  | 勾選畫面是否支援關巨集。 當畫面要被關閉時，會執行此巨集內所有全部程式一次，當關巨集執行完畢後，然後畫面才會結束。
循環巨集 | <勾選框> | 勾選畫面是否支援循環巨集。 當畫面開啟後，循環巨集會循環不斷地執行。也就是說，循環巨集從第一個指令開始，直到巨集結束或執行到END指令時，再從第一個指令開始循環，當畫面關閉時循環巨集也會立刻結束。
 | 循環巨集延遲時間 | 設定循環巨集延遲時間：0, 100, 200, 300, 400, 500, 600, 700, 800, 900, 1000毫秒。
列印 | 全畫面 | 設定循環巨集延遲時間：0, 100, 200, 300, 400, 500, 600, 700, 800, 900, 1000毫秒。
 | 左上角 | 設定畫面列印區域左上角X和Y座標位置(單位為像素)。當未勾選全畫面時，設定此項屬性。
 | 右下角 | 設定畫面列印區域右下角X和Y座標位置(單位為像素)。當未勾選全畫面時，設定此項屬性。
 | 紙上位置 | 設定畫面上指定的區域，欲列印在紙上的X和Y座標位置(單位為毫米)。
數據掃描時間中分配予快速掃瞄的百分比 |  | 選擇數據掃描時間中分配予快速掃瞄的百分比：50%, 66%, 75%, 80%, 86% 和90%。 註：百分比愈大，數據掃描中，標籤快速掃描速率愈快，而標籤一般掃瞄的速率愈慢。
在物件數據還未能掃描到之前如何顯示物件內容 | 空白 | 點選此項目，在物件數據未掃描到之前，物件內容顯示空白。
 | 上一次掃描數據或空白 | 點選此項目，在物件數據未掃描到之前，物件內容顯示上一次掃描數據或空白。
 | 上一次掃描數據或零 | 點選此項目，在物件數據未掃描到之前，物件內容顯示上一次掃描數據或零。
在視窗畫面下仍可操作 |  | 勾選此選項，使畫面在視窗畫面下仍可操作。當畫面種類為普通畫面，此選項才會出現。
在報警消息框下仍可操作 |  | 選中此選項，使正常畫面下可操作報警消息框。此字段只有當種類是正常的畫面。
數字鍵盤保持開啟供連續數據輸入 |  | 勾選此選項，使數字鍵盤保持開啟，供連續數據輸入。
註 |  | 可輸入畫面的說明文字。


3.9.3.2 背景頁

背景頁

本章節說明在畫面屬性對話框背景頁中，各項屬性的設定。下圖為對話框背景頁的範例。

下表為背景頁中，各項屬性的說明。

屬性 |  | 說明
單色 |  | 勾選是否以單色填充畫面背景。
 | <單色> | 點擊顏色按鈕，選擇填充畫面背景的顏色。當選擇單色後，設定此項屬性。
圖樣 |  | 勾選是否以圖樣填充畫面背景。
 | 圖樣 | 設定填充背景的圖樣。點擊圖樣的標示，從圖樣盤選擇所需的圖樣。當選擇圖樣後，設定此項屬性。
 | 圖樣色 | 設定填充圖樣黑色部份的顏色。當選擇全白圖樣時，不會使用此顏色。當選擇圖樣後，設定此項屬性。
 | 背景色 | 設定填充圖樣黑色部份的顏色。當選擇全白圖樣時，不會使用此顏色。當選擇圖樣後，設定此項屬性。
圖片 |  | 勾選是否使用圖片為畫面背景。
 | <名稱> | 圖片的名稱，可使用下拉式清單，從圖片資料庫中，選擇圖片。 點擊 [image] ，從檔案選擇圖片。在選擇圖片後，將導入所選取的圖片，並儲存於圖片資料庫中。 點擊 [image] ，彈出選取/導入圖庫內圖片對話框。從圖片資料庫中，選取所需圖片。所選取的圖片將導入並儲存於圖片資料庫中。
 | 延展 | 勾選此選項，圖片將依畫面大小，調整圖片大小。
保存為預設值 |  | 按一下按鈕，保存目前的背景設置成為默認設置。


3.9.4 導入/導出畫面

導入/導出畫面

本章節說明無論人機機型和畫面大小，如何將畫面導入或導出。

■ 導入畫面

  1. 在專案管理員視窗 > 人機應用 > 畫面上，點擊滑鼠右鍵，從彈出選單中，選擇導入畫面…。
  2. 選擇欲導入的*.snf檔，若檔案於其他檔案夾，先點選至該檔案夾 。
  3. 選擇開啟。

■ 導出畫面

若想將畫面在其他人機應用中使用，可將畫面導出為.snf檔，方法如下：

  1. 在專案管理員視窗中，點選欲導出的畫面。
  2. 在畫面上，點擊滑鼠右鍵，從彈出選單中，點擊導出畫面…。
  3. 若欲將畫面儲存於其它檔案夾，先點選至該資料夾，然後選擇儲存。


3.9.5 畫面 剪下/複製/貼上/刪除

畫面剪下/複製/貼上/刪除

■ 複製/剪下/貼上畫面

欲複製或剪下開啟的畫面，在畫面空白處點擊滑鼠右鍵，從彈出選單中，選擇複製或剪下，或在畫面選單中，選擇複製/剪下畫面。

在複製或剪下後，在畫面空白處，點擊滑鼠右鍵，從彈出選單中，選擇貼上畫面，或在畫面選單中，選擇貼上畫面。

■ 刪除畫面

欲刪除開啟的畫面，在畫面空白處點擊滑鼠右鍵，從彈出選單中，選擇刪除，或在畫面選單中，選擇刪除畫面。

欲從專案管理員視窗中刪除畫面，將滑鼠置於欲刪除的畫面節點上，點擊滑鼠右鍵，從彈出選單中，選擇刪除。刪除前，會彈出"是否確認刪除？"對話框，確認後將會刪除視窗。


3.9.6 存儲畫面爲圖片檔

存畫面爲圖片檔

本章節說明如何儲存畫面為圖片檔。

■ 儲存畫面為圖片檔

欲儲存當前畫面為bmp或jpg檔，方法如下：

  1. 開啟並啟動畫面為當前畫面。
  2. 在當前畫面任一處，點擊滑鼠右鍵，從彈出選單中，選擇存當前畫面為圖片檔…，或在畫面選單中，點擊存當前畫面為圖片檔…。

■ 儲存多個畫面為圖片檔

用戶可使用儲存畫面為圖片對話框，儲存一個或多個畫面為bmp或jpg檔。欲開啟對話框，在畫面選單中，點擊存畫面為圖片檔…。

下圖為存畫面為圖片檔對話框的範例。

下表為對話框中，各項屬性的說明。

屬性 |  | 說明
人機應用 |  | 顯示人機應用的名稱。
畫面 |  | 畫面清單顯示人機應用中所有的畫面。 下表為畫面清單中，各欄位的說明。
 |  | 欄位 | 說明
 |  | 編號 | 畫面的編號。欲儲存畫面為圖片檔，勾選畫面編號前的勾選框。
 |  | 名稱 | 畫面名稱。
 |  | 檔案名 | 檔案名稱。預設的檔案名為畫面名稱+語言名稱+S+狀態編號。 註：若畫面名稱出現符號如/\:*?"<>|，人機將轉換為底線(_)。
全選 |  | 點擊此按鈕可全選所有畫面。
全不選 |  | 點擊此按鈕可全不選所有畫面。
選擇 | 語言 | 顯示物件文字所使用的語言。
 | 物件狀態 | 顯示物件狀態。
 | 地址 | 選擇地址類型，以顯示對應的物件地址。有8個地址類型：無，寫/監控，寫，監視，讀，通知觸摸操作的控制和可見性控制。
 | 圖檔類別 | 選擇圖檔類別，可選擇bmp檔或jpg檔。
 | 存入檔案夾 | 設定放置檔案的檔案夾，若指定的檔案夾已存在，則舊有的檔案夾將由新的取代。
 | 畫面名稱為註解 | 勾選是否顯示一般畫面訊息為註解。註解格式為畫面名稱(#畫面編號)；畫面寬*畫面高。
進 度 | <畫面檢視> | 顯示選取的畫面或儲存中的畫面。欲選取畫面，在畫面清單中，點擊所需的畫面。
 | <進度條> | 在按下儲存按鈕後，顯示儲存進度。
儲存 |  | 點擊此按鈕，儲存對話框中的設定。
關閉 |  | 擊此按鈕，結束對話框。


3.9.7 畫面保護

畫面保護

您可以通過使用密碼保護畫面或讓任何畫面在保護的情況下 ，只允許閱讀，不能被編輯。

■ 參加保護

為了保護畫面，並把它添加到保護列表中，你可以做到以下幾點：

  1. 請執行下列操作之一：
    * 畫面上的功能表中，單擊“參加保護”。
    * 在專案管理器“視窗”中，右鍵單擊面板應用程式>畫面項，然後在彈出功能表中單擊“參加保護”。
    * 在畫面管理器“視窗”中，選擇您要保護的畫面或專案，然後單擊     [image] 圖標。
  2. 您需要輸入原始密碼才能進行。如果沒有畫面保護設置，設置畫面保護密碼對話方塊將顯示畫面保護檢查。您需要定義所需的密碼的畫面保護列表，操作 输入鍵或單擊“確定”按鈕，以驗證您的選擇。下面是一個例子的對話框。

■ 退出保護

要解除對某個畫面，並從保護列表中刪除，你可以做到以下幾點：

  1. 請執行下列操作之一：
    * 畫面的功能表上，單擊“退出保護”
    * 在專案管理器“視窗”中，右鍵單擊面板應用程式>畫面項，然後在彈出功能表中單擊“退出保護”。
    * 在畫面管理器“視窗”中，選擇一個你希望它保護的畫面或你想讓它不受保護的畫面，然後單擊     [image] 圖標。
  2. 要退出保護，你需要在下面的對話方塊中輸入原來的密碼才能繼續操作。

■ 啟動保護

要恢復以前受保護的畫面在保護列表中的保護，你可以做到以下幾點：

  1. 請執行下列操作之一：
    * 畫面上的功能表中，單擊“啟動保護”
    * 在專案管理器“視窗”中，右鍵單擊面板應用程式>畫面項，然後在彈出功能表中單擊“啟動保護”。
    * 在畫面管理器“視窗”中，單擊     [image] 圖示來啟動所有保護。

■ 停止保護

為了停止保護所有受保護的畫面列表，你可以做到以下幾點：

  1. 請執行下列操作之一：
    * 畫面上的功能表中，單擊“停止保護”。
    *在專案管理器“視窗”中，右鍵單擊面板應用程式>畫面項，然後在彈出功能表中單擊“停止保護”。
    *在螢幕管理器“視窗”中，點擊     [image] 圖示來停止所有保護。
  2. 要停止保護，您需要下面的對話方塊中輸入原來的密碼才能繼續操作。


4.1 繪製基本幾何圖

繪製基本幾何圖

本軟體提供一組繪幾何圖工具(可參考 章節1.2.2.3繪圖工具列 和 章節1.2.1.5繪圖選單 的相關操作說明)，例如線條、矩形、圓形、圓弧等，可讓使用者建立所需要的圖形物件。當繪圖物件被選擇時，使用游標將圖形正確的放置於所需畫面位置。點擊該物件後其屬性對話窗口將會出現。繪圖屬性包含了線段/框架的顏色及寬度、區域填充顏色、花紋的樣式及顏色等，皆可經由對話窗口來設定。

註：如果視窗左下方並未出現如下的繪圖工具列時，請勾選檢視選單中的繪圖工具列。在繪圖下拉表單或繪圖工具列中有些項目的文字灰顯時表示當時不能操作使用。

幾何圖範例:


4.1.1 符號

符號
  1. 首先從繪圖下拉目錄或繪圖工具列點擊符號 [image] 圖示。
  2. 將游標移至畫面中欲繪製符號的位置後，系統預設的符號將會出現在游標所指的位置。
  3. 在規劃區中欲放置符號的位置點擊滑鼠左鍵，將可在點擊處繪出符號，且就以該點擊處為符號的中心。
  4. 畫完符號後可雙擊滑鼠左鍵，會出現對話框，就可以規劃該符號的屬性設置。

下圖為符號屬性對話框的範例。

下表為符號對話框中，各項屬性的說明。

項目 |  | 說明
樣式 |  | 提供有多種樣式的符號可以選其一來使用。
顏色 |  | 設定符號的顏色。
位置 | X | 設定符號左上角與畫面左邊界的X距離。
 | Y | 設定符號左上角與畫面上邊界的Y距離。

點擊下列繪圖工具列中的圖標，以修改符號的屬性。

圖標 | 功用
 | 選擇符號的樣式。
 | 選擇符號的顏色。


4.1.2 線、水平線、垂直線

線、水平線、垂直線

  1. 首先，從繪圖下拉目錄或繪圖工具列點擊線圖標 [image] ，即可畫出直線；點擊水平線圖標 [image] ，即可畫出水平線；點擊垂直線圖標 [image] ，即可畫出垂直線。

  2. 將滑鼠移至畫面中欲繪製線的位置後，系統預設的線將會出現在滑鼠所指的位置。

  3. 在畫面中欲放置線的位置點擊滑鼠左鍵，將可在點擊處繪出線。

  4. 拖曳起始點/結束點的四方格可以改變起始點/結束點的位置。

左邊的圖片顯示線的兩個四方格。將滑鼠游標移動至四方格上，當滑鼠游標變成雙箭頭 [image] ，拖曳游標，使線顯示所需的長度與位置。

.

  5. 欲改變直線的放置位置，請將滑鼠箭頭放在直線上點一下滑鼠左鍵，然後按住滑鼠左鍵，等到滑鼠箭頭變成十字箭頭 [image] 後。按住滑鼠左鍵不放，就可以將此物件拖曵到工作區內任意位置。

  6. 點一下此直線，選擇線後，雙擊滑鼠左鍵會出現線對話框，可調整線的屬性設定。下圖為線對話框的範例。

下表為線對話框中，各項屬性的說明。

屬性 |  | 說明
種類 |  | 設定線的種類：一般、水平線、垂直線。
樣式 |  | 從右邊的下拉式選單中點選線的樣式。
顏色 | 靜態 | 勾選線的顏色不變。
 | 由位控制 | 勾選線的顏色是否由位變數控制。
 | 閃爍 | 勾選線是否閃爍。需要設定狀態On/Off的顏色，狀態顏色切換形成閃爍效果。
 | 閃爍（由位控制） | 勾選由位元變數控制線是否閃爍。
 | 狀態 | 選擇狀態及狀態的顏色。
 | 顏色 | 設定每一狀態的線的顏色。
 | 控制位 | 設定狀態顏色或是否閃爍的控制位。點擊 [image] 輸入地址。點擊 [image] 選取標籤。
起始點/結束點 | 起始點/結束點 | 勾選是否改變線的起始點/結束點的形狀。
 | 種類 | 點擊下拉式選單，選擇起始點/結束點的形狀種類。
 | 填充 | 選擇是否將起始點/結束點填充顏色。
 | 大小 | 設定形狀大小。
顯現控制 | 顯現控制 | 勾選線的顯現與否，是否受位控制。
 | 控制位 | 設定控制線是否顯現的位變數地址。點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定線的顯現狀態(狀態1顯現或0顯現)。
端點 | X1 | 設定起始點與畫面左邊界之X距離。
 | Y1 | 設定起始點與畫面上邊界之Y距離。
 | X2 | 設定結束點與畫面左邊界之X距離。
 | Y2 | 設定結束點與畫面上邊界之Y距離。

點擊下列繪圖工具列中的圖標，以修改線的屬性。

圖標 | 說明
 | 選擇線的樣式。
 | 選擇線的顏色。


4.1.3 連接缐

折缐

  1. 首先，從繪圖下拉目錄或繪圖工具列單擊 折線快選按鈕 [image] ，即可畫出折線。
  2. 單擊折線快選按鈕後，將游標移至畫面中欲繪製折線的位置後，點擊滑鼠左鍵後出現折線的起始點。
  3. 在畫面上繼續點擊滑鼠左鍵，將出現折線的第一節點。將滑鼠移到欲規劃 折線的第三個點的位置單擊滑鼠左鍵依此類推。
  4. 畫完折線後可單擊滑鼠右鍵，來完成此折線的規劃。
  5. 拖曳折線中任一藍色四方格可調整折線大小。
  6. 拖曳折線中任一黑色四方格可調整折線的節點位置。

左邊的圖片顯示折線的藍色和黑色四方格。將滑鼠游標移動至任一四方格上，當滑鼠游標變成雙箭頭 [image] 、 [image] 、 [image] 和 [image] 。拖曳游標，使多邊型顯示所需的外型與大小。

  7. 規劃完成後，想要在折線上增加一個節點或者減少一個節點，來改變物件的形狀，先點選該折線或節點，然後點擊滑鼠的右鍵，會彈出選單，可增加/刪除節點。

彈出式選單 | 說明
插入點 | 在所定位置增加一個連接節點。
刪除點 | 在所定位置刪除一個連接節點。

  8. 選擇目標折線，再雙擊此線，可開啟折線的屬性對話框來進行相關的操作。下圖為 折線對話框的範例。

下表為折線對話框中，各項屬性的說明。

屬性 |  | 說明
樣式 |  | 設定折線的樣式。
顏色 | 靜態 | 勾選折線的顏色不變。
 | 由位控制 | 勾選折線的顏色是否由位控制。
 | 閃爍 | 勾選折線是否閃爍。需要設定狀態On/Off的顏色，狀態顏色切換形成閃爍效果。
 | 閃爍（由位控制） | 勾選由位元變數控制折線是否閃爍。
 | 狀態 | 選擇狀態及狀態的顏色。
 | 顏色 | 設定特定狀態下折線的顏色.。
 | 控制位 | 設定顏色或是否閃爍的控制位。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
啟始點 | 啟始點 | 勾選是否改變折線的啟始點的形狀.
 | 種類種類 | 設定起始點的種類。
 | 填充 | 選擇是否將啟始點填充顏色。
 | 大小 | 設定形狀大小。
結束點 | 結束點 | 勾選是否改變折線的結束點的形狀。
 | 種類 | 設定結束點的種類。
 | 填充 | 選擇是否將結束點填充顏色。
 | 大小 | 設定形狀大小。
顯現控制 | 顯現受位控制 | 勾選折線的顯現與否，是否受位變數控制。
 | 控制位 | 設定控制折線是否顯現的位變數地址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定折線的顯現狀態。
外緣 | 左邊 | 設定折線左上角藍色四方格與畫面左邊界的水平X距離。
 | 上邊 | 設定折線左上角藍色四方格與畫面上邊界的垂直Y距離。
 | 寬度 | 設定折線寬度。
 | 高度 | 設定折線高度。

點擊下列繪圖工具列中的圖標，以修改折線的屬性。

圖標 | 說明
 | 選擇線樣式。
 | 選擇邊緣色。


4.1.4 矩形、圓角矩形、截角矩形

矩形、圓角矩形、截角矩形
  1. 先從繪圖下拉目錄或繪圖工具列點擊矩形圖示 [image] ，即可畫出直角矩形；點擊圓角矩形圖示 [image] ，即可畫出圓角矩形；點擊截角矩形圖示 [image] ，即可畫出截角矩形。
  2. 再將滑鼠箭頭移動到工作區內欲繪製矩形的位置後，系統預設的矩形將會出現在游標所指的位置。
  3. 在預定放置位置點一下滑鼠左鍵，就可畫出一個矩形。欲移動矩形的位置，請將滑鼠箭頭置於矩形上面，點一下滑鼠左鍵，滑鼠箭頭變成十字交叉形。按住滑鼠左鍵不動，就可將該矩形拖放到工作區的新位置。
  4. 改變矩形各頂點的位置或矩形大小。

 在左邊的圖片顯示了一個長方形的八個控點。將滑鼠指標定位在一個點。當游標變為 [image] 或 [image] 或 [image] 或 [image] 拖動該點，直到你想要的形狀和大小。

  5. 先點選該矩形，再雙擊滑鼠左鍵，開啟矩形的屬性對話框，可調整矩形的屬性設定。下圖為矩形對話框的範例。

下表為矩形對話框中，各項屬性的說明。

屬性 |  | 說明
種類 |  | 矩形的種類：分為直角矩形、圓角矩形、截角矩形三種基本造型。
 |  | 直角矩形 | 圓角矩形 | 截角矩形
點數 |  | 設定截角矩形截角的大小；設定圓角矩形圓角的半徑。
3D 立體效果 |  | 設定矩形的3D立體效果，有平、凹、凸三種。
 |  | 效果 | 範例 | 說明
 |  | 平 |  | 當選擇立體效果為“平”時，可勾選邊框並選擇顏色及樣式，但不可選擇邊框厚度。
 |  | 凸 |  | 當選擇立體效果為“凸”時，不可勾選邊框但可決定厚度及顏色，系統自動會將選擇的顏色以立體凸面，左邊、上邊為所挑選的顏色，右邊及下邊為系統搭配的同系列深色。
 |  | 凹 |  | 當選擇立體效果為“凹”時，不可勾選邊框但可決定厚度及顏色，系統自動會將選擇的顏色以立體凹面，左、上邊為系統搭配的同系列深色，右邊及下邊為所挑選的顏色。
顏色控制 | 靜態 | 勾選矩形的顏色不變。
 | 由位控制 | 勾選矩形顏色是否由位控制。
 | 閃爍 | 勾選矩形是否閃爍。需要設定狀態On/Off的邊框和顏色，狀態間切換形成閃爍效果。
 | 閃爍（由位控制） | 勾選由位元變數控制矩形是否閃爍。
 | 狀態 | 設定狀態及狀態的顏色。
 | 顏色 | 指定選中的狀態為矩形的顏色。
 | 控制位 | 設定顏色的控制位。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
狀態 |  | 選擇狀態及狀態的顏色。
邊框 | 邊框 | 勾選矩形是否有邊框。
 | 厚度 | 設定邊框的厚度。
 | 顏色 | 設定邊框的顏色。
 | 樣式 | 設定邊框的樣式。
實心 | 實心 | 當選擇立體效果為“平”時，如果不勾選邊框就不能選填充實心選項，但可以選擇顏色及背景色和填入圖樣。 勾選矩形是否為實心。實心的矩形將填充指定的圖樣與顏色。
 | 圖樣 | 設定填充的圖樣。
 | 圖樣色 | 設定填充圖樣的顏色，圖樣色填充圖樣中黑色的部份。
 | 背景色 | 設定填充背景的顏色，背景色填充圖樣中白色的部份。
外緣 | 左邊 | 設定矩形左緣與工作區左邊界之距離，數字愈小離工作區左邊界愈近，反之愈遠。
 | 上邊 | 設定矩形上緣與工作區上邊界之距離，數字愈小離工作區上邊界愈近，反之愈遠。
 | 寬度 | 設定矩形寬度，固定矩形左緣位置，依照輸入之數字往右橫伸展。設定矩形寬度。
 | 高度 | 設定矩形高度，固定矩形上緣位置，依照輸入之數字往下伸展。設定矩形高度。
顯現控制 | 顯現受位控制 | 勾選矩形顯現與否，是否受位控制。
 | 控制位 | 設定控制矩形是否顯現的位變數位址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定矩形的顯現狀態(1或0)。

點擊下列繪圖工具列中的圖標，以修改矩形的屬性。

圖標 | 說明
 | 選擇線樣式。
 | 選擇邊緣色。
 | 選擇背景色。
 | 選擇圖樣。
 | 選擇前景/圖樣色。


4.1.5 圓

圓
  1. 首先，從繪圖下拉目錄或繪圖工具列，點擊此圓快選按鈕 [image] ，即可畫出圓。
  2. 單擊此按鈕，將游標移至畫面中欲繪製圓的位置後，系統預設的圓將會出現在游標所指的位置。
  3. 在畫面中欲放置圓的位置點擊滑鼠左鍵，將可在點擊處繪出圓。
  4. 欲改變圓的大小，需將滑鼠箭頭置於圓周的方格上，直到滑鼠箭頭變成雙箭頭 [image] 或者 [image] ，拖曳方格至所需的大小。
  5. 欲改變圓的位置，需將滑鼠箭頭置於圓心的方格上，直到滑鼠箭頭變成十字交叉形 [image] ，點擊並按住滑鼠左鍵，即可移動圓至所需的位置。

左邊的圖片顯示圓的兩個四方格。

  6. 選擇圓後，雙擊滑鼠左鍵會出現屬性對話窗口，可調整圓的屬性設定。
    下圖為圓屬性對話框的範例。

下表為圓對話框中，各項屬性的說明。

屬性 |  | 說明
顏色控制 | 靜態 | 勾選圓的顏色不變。
 | 受位控制 | 勾選圓的顏色是否由位控制。
 | 閃爍 | 勾選圓是否閃爍。需要設定狀態On/Off的描邊和顏色，狀態間切換形成閃爍效果。
 | 閃爍（由位控制） | 勾選由位元變數控制圓是否閃爍。
 | 控制位 | 設定描邊和顏色或是否閃爍的控制位。 點擊 [image] 輸入位址。點擊 [image] 選取標 籤。
狀態 |  | 選擇狀態和狀態的顏色。
描邊 | 描邊 | 勾選圓是否描邊。
 | 顏色 | 設定描邊的顏色。
 | 厚度 | 設定描邊的厚度。
實心 | 實心 | 勾選圓是否為實心。實心的圓將填充指定的圖樣和顏色。
 | 圖樣 | 設定填充的圖樣。
 | 圖樣色 | 設定填充圖樣的顏色，圖樣色填充圖樣中黑色的部份。
 | 背景色 | 設定填充背景的顏色，背景色填充圖樣中白色的部份。
圓心與半徑 | X | 設定圓心與畫面左邊界的X距離。
 | Y | 設定圓心與畫面上邊界的Y距離。
 | 半徑 | 設定圓的半徑。
顯現控制 | 顯現受位控制 | 勾選圓是否顯現受位控制。
 | 控制位 | 設定控制圓是否顯現的位變數地址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定圓的顯現狀態(1或0)。

點擊下列繪圖工具列中的圖示，以修改圓的屬性.

圖標 | 說明
 | 選擇邊緣色.
 | 選擇背景色.
 | 選擇圖樣.
 | 選擇前景/圖樣色.


4.1.6 橢圓

橢圓
  1. 首先，從繪圖下拉目錄或繪圖工具列，點擊橢圓圖標 [image] ，即可畫出橢圓。
  2. 單擊此按鈕，再將游標移至畫面工作區中欲繪製橢圓的位置後，系統預設的橢圓將會出現在游標所指的位置。
  3. 在畫面中欲放置橢圓的位置點擊滑鼠左鍵，將可在點擊處繪出橢圓。
  4. 拖曳橢圓中任一四方格可調整橢圓大小。

左圖顯示橢圓八個四方格的位置。將游標箭頭移至其中一個四方格上，當滑鼠游標變成雙箭頭 [image] 或 [image] 或 [image] 或 [image] ，拖動四方格至所需的形狀及大小。

  5. 選擇橢圓後，雙擊滑鼠左鍵會出現橢圓對話框，可調整橢圓的屬性設定。下圖為橢圓屬性對話框的範例。

下表為橢圓對話框中，各項屬性的說明。

屬性 |  | 說明
顏色控制 | 靜態 | 勾選橢圓的顏色不變。
 | 受位控制 | 勾選橢圓的顏色是否由位控制。
 | 閃爍 | 勾選橢圓是否閃爍。需要設定狀態On/Off的邊框和顏色，狀態間切換形成閃爍效果。
 | 閃爍（由位控制 ） | 勾選由位元變數控制橢圓是否閃爍。
 | 控制位 | 設定顏色的控制位。 點擊 [image] 輸入地址。點擊 [image] 選取標。
狀態 |  | 選擇狀態及狀態的顏色。
描邊 | 描邊 | 勾選橢圓是否描邊。
 | 顏色 | 設定描邊的顏色。
 | 厚度 | 設定描邊的厚度。
實心 | 實心 | 勾選橢圓是否為實心。實心的橢圓將填充指定的圖樣和顏色。
 | 圖樣 | 設定填充的圖樣。
 | 圖樣色 | 設定填充圖樣的顏色，圖樣色填充圖樣中黑色的部份。
 | 背景色 | 設定填充背景的顏色，背景色填充圖樣中白色的部份。
外緣 | 左邊 | 設定橢圓左上角與畫面左邊界的距離。
 | 上邊 | 設定橢圓左上角與畫面上邊界的距離。
 | 寬度 | 設定橢圓寬度。
 | 高度 | 設定橢圓高度。
顯現控制 | 顯現受位控制 | 勾選橢圓是否顯現受位控制。
 | 控制位 | 設定控制橢圓是否顯現的位變數地址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定橢圓的顯現狀態。

點擊下列繪圖工具列中的圖示，以修改橢圓的屬性。

圖標 | 說明
 | 選擇邊緣色。
 | 選擇背景色。
 | 選擇圖樣。
 | 選擇前景/圖樣色。


4.1.7 弧

弧
  1. 首先，從繪圖下拉目錄或繪圖工具列，點擊弧圖標 [image] ，即可畫出弧。
  2. 將游標移至畫面中欲繪製弧的位置後，系統預設的弧將會出現在游標所指的位置。
  3. 在畫面中欲放置弧的位置點擊滑鼠左鍵，將可在點擊處繪出弧。
  4. 拖曳弧中任一四方格可調整弧的形狀。如欲改變弧的位置，請將滑鼠箭頭放在弧線上後按住滑鼠，等到滑鼠箭頭變成十字箭頭 [image] 後。按住滑鼠左鍵不放，就可以將其拖曵到工作區內任意位置。

左邊的圖片顯示弧的藍色/黑色四方格。其中，藍色四方格可調整形狀；弧兩端的黑色四方格可調整角度；弧中間的黑色四方格可使弧成為圓弧。

將滑鼠箭頭放在弧線上，直到滑鼠游標變成雙箭頭 [image] 或 [image] 或 [image] 或 [image] ，拖曳游標至所需的形狀及大小。

.

  5. 選擇弧後，雙擊滑鼠左鍵會出現圓弧對話框，可調整弧的屬性設定，在此選擇弧顏色、位置。下圖為弧屬性對話框的範例。

下表為弧對話框中，各項屬性的說明。

屬性 |  | 說明
顏色 |  | 設定弧的顏色。
外緣 | 左邊 | 設定弧左上角藍色四方格與畫面左邊界的距離。
 | 上邊 | 設定弧左上角藍色四方格與畫面上邊界的距離。
 | 寬度 | 設定弧寬度。
 | 高度 | 設定弧高度。

點擊下列繪圖工具列中的圖示，以修改弧的屬性。

圖標 | 說明
 | 選擇邊緣色。


4.1.8 扇形

扇形
  1. 首先，從繪圖下拉目錄或繪圖工具列，點擊扇形圖標 [image] ，即可畫出扇形。
  2. 將游標移至畫面中欲繪製扇形的位置後，系統預設的扇形將會出現在游標所指的位置。
  3. 在畫面中欲放置扇形的位置點擊滑鼠左鍵，將可在點擊處繪出扇形。
  4. 拖曳扇形中任一藍色四方格可調整扇形的形狀。欲改變扇形的位置，需將滑鼠箭頭置於扇形上，直到滑鼠箭頭變成十字交叉形 [image] ，再將其移到工作區的任意位置。

左邊的圖片顯示扇形的藍色/黑色四方格。其中，藍色四方格可調整形狀，扇形兩端的黑色四方格可調整扇形角度，扇形中間的黑色四方格可調整扇形弧度。

將滑鼠箭頭放在弧線上，直到滑鼠游標變成雙箭頭 [image] 或 [image] 或 [image] 或 [image] ，拖曳游標至所需的扇形及大小。

  5. 選擇扇形後，雙擊滑鼠左鍵會出現扇形對話框，可調整扇形的屬性設定。

下表為扇形對話框中，各項屬性的說明。

屬性 |  | 說明
描邊 | 描邊 | 勾選扇形是否描邊。
 | 顏色 | 設定描邊的顏色。
實心 | 實心 | 勾選扇形是否為實心。實心的扇形將填充指定的圖樣和顏色。
 | 圖樣 | 設定填充的圖樣。
 | 圖樣色 | 設定填充圖樣的顏色，圖樣色填充圖樣中黑色的部份。
 | 背景色 | 設定填充背景的顏色，背景色填充圖樣中白色的部份。
外緣 | 左邊 | 設定扇形左上角藍色四方格與畫面左邊界的距離。
 | 上邊 | 設定扇形左上角藍色四方格與畫面上邊界的距離。
 | 寬度 | 設定扇形寬度。
 | 高度 | 設定扇形高度。

點擊下列繪圖工具列中的圖示，以修改扇形的屬性。

圖標 | 說明
 | 選擇邊緣色。
 | 選擇背景色。
 | 選擇圖樣。
 | 選擇前景/圖樣色。


4.1.9 多邊形

多邊形
  1. 首先，從繪圖下拉目錄或繪圖工具列中，點擊多邊形圖示 [image] ，即可畫出多邊形。
  2. 將游標移至畫面中欲繪製多邊形的位置後，點擊滑鼠左鍵後出現多邊形的第一個頂點，將滑鼠移到欲規劃多邊形的第二個點的位置單擊滑鼠左鍵，依此類推。
  3. 在畫面上繼續點擊滑鼠左鍵，將出現多邊形的新頂點。
  4. 畫完多邊形後可單擊滑鼠右鍵，來完成此多邊形的繪製。
  5. 拖曳多邊形中任一藍色四方格可調整多邊形大小。
  6. 拖曳其黑色四方格，即可調整多邊形頂點的位置。

左邊的圖片顯示多邊形的藍色/黑色四方格。其中，藍色四方格可調整形狀；黑色四方格可調整頂點位置。

將滑鼠箭頭放在方格上，直到游標變成雙箭頭 [image] 或 [image] 或 [image] 或 [image] ，拖曳游標至所需的形狀及大小。

  7. 設計完成後，想要在物件邊線上增加一個節點或者減少一個節點，來改變物件的形狀，您可以在多邊形邊線上點擊滑鼠的右鍵，從彈出選單選擇增加或刪除節點到該位置上。

下表描述了“彈出表單”頁中的可選項目。

彈出式選單 | 說明
插入點 | 在物件邊線上增加一個節點。
刪除點 | 減少一個節點。

  8. 選取目標多邊形，再雙擊此多邊形，打開此物件的屬性對話方塊可進行相關的操作。在此選擇多邊形的樣式、填充圖樣、外緣位置。

下表為多邊形對話框中，各項屬性的說明。

屬性 |  | 說明
顏色控制 | 靜態 | 勾選多邊形的顏色不變。
 | 顏色由位控制 | 勾選多邊形的顏色是否由位控制。
 | 閃爍 | 勾選多邊形是否閃爍。需要設定狀態On/Off的描邊和顏色，狀態間切換形成閃爍效果。
 | 閃爍（由位控制） | 勾選由位元變數控制多邊形是否閃爍。
 | 控制位 | 設定描邊和顏色或是否閃爍的控制位。 點擊 [image] 輸入位址。點擊 [image] 選取標籤。
狀態 |  | 選擇狀態及狀態的顏色。
描邊 | 描邊 | 勾選多邊形是否描邊。
 | 厚度 | 設定描邊的厚度。
 | 厚度 | 設定描邊的顏色。
實心 | 實心 | 勾選多邊形是否為實心。實心的多邊形將填充指定的圖樣和顏色。
 | 圖樣 | 設定填充的圖樣。
 | 圖樣色 | 設定填充圖樣的顏色，圖樣色填充圖樣中黑色的部份。
 | 背景色 | 設定填充背景的顏色，背景色填充圖樣中白色的部份。
外緣 | 左邊 | 設定多邊形左上角藍色四方格與畫面左邊界的距離。
 | 上邊 | 設定多邊形左上角藍色四方格與畫面上邊界的距離。
 | 寬度 | 設定多邊形寬度。
 | 高度 | 設定多邊形高度。
顯現控制 | 顯現受位控制 | 勾選多邊形顯現是否受位控制。
 | 控制位 | 設定控制多邊形是否顯現的位元變數位址。 點擊 [image] 輸入位址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定多邊形的顯現狀態(1或0)。

點擊下列繪圖工具列中的圖示，以修改多邊形的屬性。

圖示 | 說明
 | 選擇線樣式。
 | 選擇邊緣色。
 | 選擇背景色。
 | 選擇圖樣。
 | 選擇前景/圖樣色。


4.1.10 文字

文字
  1. 要在畫面中插入文字，您可以按下繪圖工具列上的文字快捷圖示 [image] ，或是從繪圖欄中選擇“文字”。
  2. 將遊標移至畫面中欲輸入文字的位置後，系統預設的文字物件將會出現在遊標所指的位置。
  3. 在畫面中欲輸入文字的位置點擊滑鼠左鍵，將在點擊處出現文字物件。
  4. 選擇文字後，雙擊滑鼠左鍵會出現對話視窗，可調整文字的屬性設定。對話框包含下列三個頁面：

■ 一般頁(General)
 詳閱章節 4.1.10.1.說明。

■ 外框頁(Shape)
 詳閱章節 4.3.4 說明。

■ 顯現頁(Visibility)
 詳閱章節 4.4.6 說明。

註一：可使用文字工具列，快速修改文字物件中文字的屬性。

註二：可使用繪圖工具列，快速修改文字物件中外框的屬性。

小秘訣：系統已預設文字自動調整的功能，編輯選單中的選項顯示已勾選；工具列中的圖示顯示下沉效果。因此，當調整物件大小時，如不調整文字大小時，須點選取消選單中的文字自動調整，或點選工具列中下沉圖示 [image] ，使文字大小固定。


4.1.10.1 一般設定

一般設定

這個章節說明文字物件的一般頁設定。

上圖是文字物件對話框中，一般頁的範例。

下表為文字屬性對話框一般頁中，各項屬性的說明。

屬性 |  | 說明
語言 |  | 設定文字所使用的語言。多語言必須在全局語言屬性先設定語言種類後，即可在文字屬性對話框中選擇欲設定之語言，最多可設定達10種語言。
外框 |  | 當勾選”外框”就會增加此一外框設置頁。勾選文字物件是否需要框架。勾選此選項後，框架的頁面將會出現在對話窗口。
所有語言都使用第一種語言的文本 |  | 勾選後無論現在使用何種語言，都將顯示第一種語言的文本。
字體 |  | 可利用下拉式清單選擇字體。點擊 [image] 出現字體範本的對話視窗，可選擇所需要的字體。如果不喜歡目前的字體，可先變更字體範本然後才選擇。
文本 | <編輯框>/<下拉式表列> | 當前輸入的語言文字。
 | / | 設定當前所選語言的文字。點擊 [image] 圖示，用戶可以在文字編輯框中，查看與編輯所選語言的文字；或點擊 [image] 圖示，從下拉文字庫列表中選擇文字，可在選擇文字前改變文字庫的內容。
顏色 |  | 點擊相對應顏色的圖標，設定文字的顏色。
透明 |  | 勾選後文字的背景將會變成透明。
背景色 |  | 設定文字的背景色。當文字背景非透明時才出現這個選項。
對齊 |  | 設定多行文字對齊的方向。
文字方向 |  | 選擇下列文字的方向。
 |  | 方向 | 從左到右 | 從右到左 | 從上到下 | 從下到上
 |  | 輸入文字: | 這是測試 | 試測是這 | 這 是 測 試 | 試 測 是 這
位置 |  | 設定文字在文字物件中的位置。 居中擺設，指文字段落設置在整個物件框的中心點。 對齊左上角，指文字段落靠齊物件框的左上角開始擺設。
間距 | 邊緣 | 設定文字與文字物件邊框的間距(單位元為圖元)。 如果設10點，指文字段落在文字框之左邊及上邊預留10個圖元點後，靠齊文字框的左上角。
 | 行 | 設定文字行與行之間距。文字行與行之間距，在此設定為0。
 | 字 | 設定字與字之間距。字與字之間距，在此設定為0。


4.1.11 圖片

圖片
  1. 在繪圖功能表或繪圖工具欄上，單擊圖片 [image] 。
  2. 將遊標移至畫面中欲插入圖片的位置後，系統預設的圖片物件將會出現在遊標所指的位置。
  3. 在畫面中欲插入圖片的位置點擊滑鼠左鍵，將在點擊處出現圖片物件。
  4. 選擇圖片後，雙擊滑鼠左鍵會出現對話窗口，可調整圖片的屬性設定。可使用繪圖工具列立即修改圖片物件的屬性。下圖為圖片物件對話框的範例。

下表為圖片物件對話框中，各項屬性的說明。

屬性 |  | 說明
名稱 |  | 顯示的圖片名稱。可從下拉式清單的資料庫中選取圖片檔名。 單擊名稱旁的導入圖形按鈕 [image] 可從檔案夾中導入自製/其他圖片，選取檔案並單擊”導入”即可將欲選擇之圖片檔導入軟體中使用。導入後的圖片將自動保存在圖片資料庫中。 單擊圖片對話框中的選取/導入 [image] 按鈕，可以從系統圖庫中導入圖片，在此可選擇欲使用的圖片，並應用在程式中。導入後的圖片將保存在資料庫中。
檢視 |  | 檢視圖片設定後的結果。
配合物件大小 |  | 勾選圖片是否依據物件自動調整大小。
透明 |  | 勾選是否使圖片的某些部份透明，圖片顏色與透明色相同的部份將會變成透明。
透明色 |  | 設定圖片中的透明色。圖片非黑白圖片才會出現這個選項。
前景色 |  | 設定黑白圖片中，黑色部分的顏色。圖片為黑白圖片才會出現這個選項。
背景色 |  | 設定黑白圖片中，白色部分的顏色。圖片為黑白圖片才會出現這個選項。
翻轉/旋轉 |  | 設定圖片翻轉/旋轉的方式，有八個選項：
 |  | 方式 | 說明
 |  | 0° | 維持原狀。
 |  | 90° | 圖片順時針旋轉90度。
 |  | 180° | 圖片順時針旋轉180度。
 |  | 270° | 圖片順時針旋轉270度。
 |  | X | 圖片沿X軸翻轉(鏡射)。
 |  | 90° & X | 圖片順時針旋轉90度後，再沿X軸翻轉。
 |  | Y | 圖片沿Y軸翻轉(鏡射)。
 |  | 90° & Y | 圖片順時針旋轉90度後，再沿Y軸翻轉。
色調 |  | 參考指定的色調重繪圖片。有4個選項：
 |  | 參考顏色 | 說明
 |  | 無 | 不處理。
 |  | 參考：中央像素 | 使用中央像素的顏色作為參考顏色。
 |  | 參考：灰色 | 使用灰色（RGB：128,128,128）為基準色。
 |  | 參考：淺灰色 | 用淺灰色（RGB：196,196,196）為基準色。
改變色調 |  | 選要改變圖片色調的顏色。
顯現控制 | 顯現受位控制 | 勾選圖片顯現是否受位控制。
 | 控制位 | 設定是否顯現的控制位。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定圖片顯現的狀態(1或0)。
外緣 | 左邊 | 設定連接線左上角藍色四方格與畫面左邊界的水平X距離。
 | 上邊 | 設定連接線左上角藍色四方格與畫面上邊界的垂直Y距離。
 | 寬度 | 設定圖片物件的寬度。
 | 高度 | 設定圖片物件的高度。
 | 重繪 | 點擊後重繪畫面上的物件。


4.1.12 刻度

刻度
  1. 首先，從繪圖下拉目錄或繪圖工具列中，點擊此刻度圖標 [image] ，即可插入刻度。
  2. 將游標移至畫面中欲插入刻度的位置後，系統預設的刻度將會出現在游標所指的位置。
  3. 在畫面中欲插入刻度的位置點擊滑鼠左鍵，將在點擊處出現刻度。
  4. 選擇刻度後，雙擊滑鼠左鍵會出現刻度對話框，可調整圖片的屬性設定。下圖為刻度對話框的範例，對話框右邊為對應的刻度。

下表為刻度對話框中，各項屬性的說明。

屬性 |  | 說明
方向和位置 |  | 根據下表選擇刻度的方向和位置：
 |  | 方向 | 水平 |  | 垂直
 |  | 位置 | 上 | 下 | 左 | 右
 |  | 範例 |  |  |  |
動態範圍 | 動態範圍 | 勾選此選項，刻度個數和刻度記號範圍為動態，也就是在運行時，可由指定變數控制。
 | 參數區 | 設定控制刻度個數和刻度記號範圍的變數。變數為連續4個雙字(8個字)，編號如下表：
 |  | 字# | 數據類別 | 說明
 |  | 0, 1 | 32位正整數 | 主刻度數，範圍從2到101。
 |  | 2, 3 | 32位正整數 | 兩主刻度間，分隔數個數，範圍從1到100。
 |  | 4, 5 | 32位整數 | 刻度記號最小值。
 |  | 6, 7 | 32位整數 | 刻度記號最大值。
 |  | 範例 假設刻度的動態範圍控制區為$U100，以下的巨集指定，可使刻度物件的如左圖： $U100 = 3 (UD) // 主刻度數。 $U102 = 5 (UD) // 次分隔數。 $U104 = 0 (SD) //刻度記號最小值。 $U106 = 100 (SD) //刻度記號最大值。
顏色 |  | 設定刻度的顏色。
主刻度數 |  | 設定主刻度數，最小值為2。
次分隔數 |  | 設定兩個連續主刻度數中間的次分隔數。最小值為1。
次刻度長 |  | 設定次刻度的長度。
軸 |  | 勾選刻度是否顯示軸。
記號 | 記號 | 勾選刻度是否顯示記號。
 | 字體 | 設定記號的字體。
 | 最小值 | 設定記號的最小值。最小值為32位元的整數。
 | 最大值 | 設定記號的最大值。最小值為32位元的整數。
 | 總位數 | 設定記號的總位數。
 | 小數位數 | 設定記號小數位數。例如，當最大值是5000，總位數是4，小數位數是2，記號的最大值就是50.00。
 | 反向 | 勾選刻度的記號是否反向顯示。當刻度反向顯示，刻度的最大值在最左邊/下面。


4.1.13 表格

表格
  1. 首先，從繪圖下拉目錄或繪圖工具列中，點擊此表格圖標 [image] ，即可插入表格。
  2. 將遊標移至畫面中欲插入表格的位置後，系統預設的表格將會出現在遊標所指的位置。
  3. 在畫面中欲插入表格的位置點擊滑鼠左鍵，將在點擊處出現表格。
  4. 拖放現有的物件到空白的格子中。如果該物件可置於格子中，將會出現確認的訊息對話框。下圖是插入物件時，出現確認對話框的範例。

註：只有以下23種物件可以置入表格的格子中，圖片、符號、文字、位元按鈕、切換開關、字按鈕、多態按鈕、畫面按鈕、功能按鈕、鍵盤按鈕、數值顯示器、字元顯示器、字元輸入器、位元指示燈、多態指示燈、時間顯示器、日期顯示器、週日顯示器、訊息顯示器、柱狀圖、圖片顯示器、GIF圖、進階數值顯示器。

  5. 點擊表格中的格子。如果格子內有物件， [image] 圖標會出現在格子的左上角。下圖說明如何編輯表格中的物件。

  6. 將遊標箭頭放置在格線上，當游標變成雙箭頭 [image] 或 [image] ，拖動格線至所需的寬/高度。

註：當並未勾選表格對話框一般頁中的格子同寬時，可調整格子的寬度；當並未勾選表格對話框一般頁中的格子同高時，可調整格子的高度。

  7. 選擇表格後，避開圖示 [image] ，在表格區域內雙擊滑鼠左鍵會出現表格對話視窗，可調整表格的屬性設定。此對話框包含以下二個頁面。

■ 一般頁(General)

詳閱章節4.1.13.1 說明

■ 格子頁(Cell)
 詳閱章節4.1.13.2 說明


4.1.13.1 表格 - 一般頁

表格 - 一般頁

本章節說明表格物件屬性對話框中，一般頁的設定。下圖為一般頁的範例。

下表為表格對話窗口中，各種屬性的說明。

屬性 |  | 說明
編號 |  | 設定表格的編號。當表格產生，系統自動給予一組編號。同一個畫面中的編號不會重複，編號的格式為TBLnnnn。
註 |  | 可輸入物件的說明文字。
外框設定 |  | 有關 [image] 、邊框色、背景色的詳細說明，請參考 章节 4.3.4 。
格子 | 橫向行數 | 設定表格的橫向行數。
 | 縱向列數 | 設定表格的縱向列數。
 | 格子同高 | 勾選表格格子是否同高。如果欲調整個別格子的高度，請勿勾選此選項。
 | 格子同寬 | 勾選表格格子是否同寬。如果欲調整個別格子的寬度，請勿勾選此選項。
 | 拖動及放下 | 勾選是否拖動及放下物件於格子上。注意，並非所有物件均可行。
格線 | 垂直 | 勾選表格是否顯示垂直格線。
 | 水平 | 勾選表格是否顯示水平格線。
 | 樣式 | 設定格線的樣式。
 | 顏色 | 設定格線的顏色。


4.1.13.2 表格 - 格子頁

表格 - 格子頁

下圖為表格物件對話框中格子頁面的範例。當點擊插入按鈕，出現選擇物件對話框。

下表為表格對話窗口中，格子頁的各種屬性說明。欲使用右邊的按鈕來編輯格子，須先點擊(橫,縱)，從清單中選取一列。

屬性 | 說明
(橫,縱) | 以橫向行數及縱向列數定義格子在表格中的位置。
物件 | 物件的種類。如果這一欄是空白，表示這個格子沒有插入物件，為一空白格子。
 | 點擊此處出現特定物件的屬性對話框，可調整物件的屬性設定。當物件欄不為空白，才會出現此按鈕。
邊距 | 物件邊界與格子的距離，單位為像素，範圍從0到10。
刪除 | 點擊此按鈕清除所選格子的內容。當物件欄不為空白，才會出現此按鈕。
插入 | 點擊此按鈕出現如上圖的選擇物件對話框。從選擇物件對話框的清單中，選擇新增一個物件。當物件欄為空白，才會出現此按鈕。 註：無法插入不在選擇物件清單中的物件。
移上 | 點擊此按鈕將所選格子向上移一行。當同時選擇多行或沒有選擇任何一行或選擇第一行時，此按鈕不會出現。
移下 | 點擊此按鈕將所選格子向下移一行。當同時選擇多行或沒有選擇任何一行或選擇最後一行時，此按鈕不會出現。


4.2 編輯物件

編輯物件

本章節將說明在選擇物件後，如何移動、複製或編輯物件，而不影響到整個畫面。


4.2.1 選擇物件和取消選擇物件

選擇物件和取消選擇物件

■ 選擇物件

 欲選擇物件時，移動滑鼠游標至欲選擇的物件上，點擊滑鼠左鍵。
 欲增加選擇的物件時，逐一移動滑鼠游標至欲增加選擇的物件上，按住Shift再點擊滑鼠左鍵。
 要全選畫面上所有的物件時，按Ctrl + A或利用編輯選單中全選指令。全選指令會選擇在畫面上所有的物件，這使得要剪下、複製、貼上一群物件時較容易。

■ 滑鼠圈住一個區域內的所有物件全都被選定

 在畫面上空白處點擊滑鼠左鍵並按住不放。點擊的地方為矩形區域的左上角，然後任意移動滑鼠，選定你所需要的矩形區域後放開滑鼠左鍵，即可形成一矩形區域可一次複選矩形區域內的所有對象。

在矩形區域內被選入的物件周圍會有藍色的四方格， 有實心四方格的物件是標的物件。

■ 取消選擇的物件

 欲取消選擇的物件，可點擊空白處或重新選擇新的物件。


4.2.2 在選擇區域中的基本操作方式

在選擇區域中的基本操作方式

■ 移動物件

在所選擇的物件上，點擊滑鼠左鍵並按住不放，當游標變成 [image] ，即可拖曳滑鼠來移動物件至其他區塊。被選擇的物件在移動時會在畫面的最上層，所以你可以在畫面上任意移動。最後，放開滑鼠左鍵即可放置物件於該處。

■ 集群或解散物件
 點擊在編輯工具列的集群圖示 [image] 或利用編輯選單中及滑鼠右鍵選單中的集群指令將物件集合。點擊在編輯工具列的解散圖示 [image] 或利用編輯選單中及跳出式選單中的解散指令，來解散物件。

當一個區域內的某些物件(至少2個)已經先被選定後，您就可以將它們集群。可針對所選多個物件將它定義為一整個組合，在操作時可方便搬移位置或複製。而且將多個物件集群後可以存為物件群，這物件群就可以在動畫中作為移動物件來使用。

要取消對所選的組合，單擊 [image] “編輯”工具欄上，或使用“編輯”菜單上取消組合命令，或在物件的彈出式菜單。取消組合物件後，組內的物件將恢復到單一的。

■ 縮放物件
 在物件周圍的藍色四方格可供縮放物件。滑鼠左鍵點擊藍色四方格後，按住 [image] 或 [image] 或 [image] 或 [image] 不放，拖曳滑鼠即可調整物件大小。當達到你所需的物件大小，即可放開滑鼠左鍵。除了縮放物件，你還可以調整長寬的比例，使物件有被壓扁或拉長的效果。
Tip: You can’t resize more than one object at a time unless you group multiple objects before resizing.小秘訣：如果要一次調整多個物件的大小，必須先集群欲調整的物件，然後再群體做調整。

■ 自動調整文字大小
 編輯時可選自動調整文字大小 [image] ，物件內文字將隨物件大小自動成比例縮放。當選擇自動調整文字大小，字體的大小將隨物件的縮放，自動調整。

小秘訣：系統已預設文字自動調整的功能。因此，當調整物件大小時，如不希望調整文字大小時，需取消勾選文字自動調整，或再點選圖標一次，以取消預設的文字自動調整。

■ 釘住/放開物件
 點擊在編輯工具列的釘住圖示 [image] 或利用編輯選單中及滑鼠右鍵選單中的釘住指令，來釘住物件。

點擊在編輯工具列的放開圖示 [image] 或利用編輯選單中及滑鼠右鍵選單中的放開指令，來放開物件。

小秘訣：釘住的物件仍可調整大小。

■ 複製、剪下、貼上
 欲從當前畫面複製選取內容暫存至剪貼簿上，可利用快捷鍵Ctrl+C，或點擊標準工具列上的 [image] 圖示，或使用編輯選單/物件彈出視窗中的複製指令。

欲從當前畫面剪下選取內容，可利用快捷鍵Ctrl+X，或點擊標準工具列上的 [image] 圖示，或使用編輯選單/物件彈出視窗中的剪下指令。

在執行複製或剪下指令後，欲貼上選取內容，可利用快捷鍵Ctrl+V，或點擊標準工具列上的 [image] 圖示，或使用編輯選單/物件彈出視窗中的貼上指令。
先選好一個或多個要複製的物件，然後按住CTRL鍵，再按住滑鼠左鍵，出現 [image] 符號並拖曳滑鼠到所需位置，就可實現複製的快速操作。

小秘訣：剪下和貼上是使物件在同一畫面或不同畫面中移動的方法。

複製和貼上是使物件在同一畫面或不同畫面中複製物件的方法。

重複貼上多個物件，物件會有層疊效果。

當所複製的物件，是在其它畫面才貼上時，其貼上的位置將會在原物件位置的相同位置。

■ 刪除
 按Del鍵或利用編輯選單中及滑鼠右鍵選單中的刪除指令，來刪除物件。當使用刪除或剪下指令，所有選擇的物件都會被刪除。

■ 復原(撤銷)

這個選項可讓您回到上一個動作，回復到前一步驟執行前的規劃狀態。快捷鍵是Ctrl+Z。

■ 重做(重作)

重做指令重新執行復原指令所取消的動作，也就是不執行上一次之復原的動作，回復到上一次執行復原前之規劃狀態。快捷鍵是Ctrl+Y。

■ 鍵盤快捷操作工具

快捷鍵 | 功能 | 快捷鍵 | 功能 | 快捷鍵 | 功能
【Ctrl+N】 | 開新專案 | 【Ctrl+X】 | 剪下 | 【Ctrl+D】 | 多重複製
【Ctrl+O】 | 開啟舊檔 | 【Ctrl+C】 | 複製 | 【Ctrl+F】 | 尋找
【Ctrl+S】 | 儲存 | 【Ctrl+V】 | 貼上 | 【Ctrl+R】 | 替換
【Ctrl+Z】 | 復原 | 【Ctrl+Click+move】 | 複製及貼上 | 【Ctrl+A】 | 全選
【Ctrl+Y】 | 重做 | 【Del】 | 刪除 | 【Shift+Click】 | 點選多物件
 |  |  |  | 【Ctrl+Click】 | 對齊操作中選定標的物件


4.2.3 多重複製

多重複製

可針對所選之物件如數值設定、按鈕等簡便的快速多重複製，同時可自動修改其對應於控制器的變數指定位置，排列方式和相鄰物件間的間隔距離等。如下圖所示。

利用編輯選單中及滑鼠右鍵選單中的多重複製指令，來多重複製物件。當執行多重複製，會出現以下的對話窗口。

下表為多重複製對話窗口中，各種屬性的說明。

屬性 |  | 說明
複製總數 | 縱向列數 | 設定列數。
 | 橫向行數 | 設定行數。
間隔 | 橫向 | 設定兩相鄰物件橫向的距離。
 | 縱向 | 設定兩相鄰物件縱向的距離。
遞增位址 |  | 是否物件的位址是否遞增。
增量 |  | 設定物件的位址增量數。
 |  | 每一行是由上至下排列。同一行中的物件，是由左至右排列。
 |  | 每一行是由上至下排列。同一行中的物件，是由右至左排列。
 |  | 每一行是由下至上排列。同一行中的物件，是由左至右排列。
 |  | 每一行是由下至上排列。同一行中的物件，是由右至左排列。
 |  | 每一列是由左至右排列。同一列中的物件，是由上至下排列。
 |  | 每一列是由右至左排列。同一列中的物件，是由上至下排列。
 |  | 每一列是由左至右排列。同一列中的物件，是由下至上排列。
 |  | 每一列是由右至左排列。同一列中的物件，是由下至上排列。


4.2.4 對齊工具

對齊工具

要安排畫面上選定的對象，你需要在選擇範圍內選擇一個參考對象，然後按下工具欄上的圖標或單擊菜單項列示如下。做多種選擇，使用Shift +單擊。從選擇的對象要選擇參考，使用Ctrl+點擊。

使用編輯菜單上的“對齊”命令安排在畫面上的對象物件。選擇一個對象或物件單擊它，然後按住Shift鍵的同時點擊其他對象或物件對準。當所有要對齊的對象或物件被選中，選擇“對齊”子菜單中的命令或直接點擊指定物件的編輯工具欄。

下表對話中描述了每個功能的屬性。為了使按鈕可用，你需要選擇一行並左鍵單擊列（行，列）。

圖標 | 選項 |  | 說明
 | 對齊 | 對齊左邊 | 將所選擇的物件對齊最後選擇的標的物件的左垂直線上。對齊所選物件的左邊於標的物件的左邊。所有物件水平移動至對齊為止。
 |  | 對齊垂直中線 | 將所選擇的物件對齊最後選擇的標的物件的垂直中線上。對齊所選物件的垂直中線於標的物件的垂直中線。所有物件水平移動至對齊為止。
 |  | 對齊右邊 | 將所選擇的物件對齊最後選擇的標的物件的右垂直線上。對齊所選物件的右邊於標的物件的右邊。所有物件水平移動至對齊為止。
 |  | 對齊上邊 | 將所選擇的物件對齊最後選擇的標的物件上方的水平線。對齊所選物件的上邊於標的物件的上邊。所有物件垂直移動至對齊為止。
 |  | 對齊 水平中線 | 將所選擇的物件對齊最後選擇的標的物件置於同一垂直中心。對齊所選物件的 水平中線於標的物件的水平中線。所有物件垂直移動至對齊為止。
 |  | 對齊下邊 | 將所選擇的物件對齊最後選擇的標的物件下方的水平線。對齊所選物件的下邊於標的物件的下邊。所有物件垂直移動至對齊為止。
 |  | 靠齊網格 | 當執行靠齊網格時，所選擇之物件移動、放大、縮小就會自動靠齊網格。
 | 微移 | 向左 | 當未選取靠齊網格，所有的物件向左微移一圖元。當選取靠齊網格，每一物件會左移使物件左上角對齊最近的網格。
 |  | 向右 | 當未選取靠齊網格，所有的物件向右微移一圖元。當選取靠齊網格，每一物件會右移使物件左上角對齊最近的網格。
 |  | 向上 | 當未選取靠齊網格，所有的物件向上微移一圖元。當選取靠齊網格，每一物件會上移使物件左上角對齊最近的網格。
 |  | 向下 | 當未選取靠齊網格，所有的物件向下微移一圖元。當選取靠齊網格，每一物件會下移使物件左上角對齊最近的網格。


4.2.5 使同尺寸工具

使同尺寸工具

首先使用Ctrl+單擊選擇一個物件作為參考物件，按下工具欄上的圖標或單擊菜單選項， 選擇要使同尺寸的操作物件。

圖標 | 選項 |  | 說明
 | 使同尺寸 | 使同寬 | 使所選取的物件寬度與最後選擇的參照物件的寬度相同。
 |  | 使同高 | 使所選取的物件高度與最後選擇的參照物件的高度相同。
 |  | 使同寬與高 | 使所選取的物件寬度與高度和最後選擇的參照物件的大小尺寸相同。


4.2.6 調整物件顯示層次

調整物件顯示層次

圖標 | 選項 |  | 說明
 | 層次 | 移到最上層 | 將所選定的物件置於其它物件的前面。
 |  | 移上一層 | 將所選定的物件向前進一層次。
 |  | 移下一層 | 將所選定的物件向後退一層次。
 |  | 移到最下層 | 將所選定的物件置於其它物件的後面。
 | 設定順序 |  | 設定畫面上物件的編號順序。可參考章節 4.2.6.1 設定物件順序的說明。


4.2.6.1 設定物件順序

設定物件順序

物件順序是指在畫面中，游標在物件之間移動的順序。通常順序是由左至右、從上到下。在按鍵的機型，如037-LSK，是由方向鍵來設定資料輸入物件的順序。在觸控人機中，可使用功能按鈕選擇在目前物件順序前後的資料輸入物件。每個畫面中當所規劃的物件增加後，系統會自動給定順序編號，從1開始，這些物件內定編號對設計者並沒有太大用途，此內定編號主要是特別針對按鍵機型提供之設計，可以讓按鍵操作選項依據所設定的順序來進行規劃。

物件的順序同時也是資料顯示的順序。如果畫面中的物件重疊，改變順序將改變物件顯示的順序。在重疊物件中，順序在後的物件會顯示在上層。

■ 檢視順序

點選編輯選單中的設定順序，檢視現在畫面中物件的順序。

■ 改變順序

依照以下步驟，改變畫面中物件的順序：

  1. 點選編輯選單中的設定順序。物件的左上角顯示現在的順序。
  2. 依所需的順序點選物件，即可設定物件的順序。順序從1開始。
  3. 點擊畫面中空白處，離開設定順序模式。

下圖是物件順序的範例。

如果在037-LSK或是043-WSK執行，按下或右方向鍵，將會依2-4-6-8-10-12-14-16-18 -20-29的順序移動物件。如果在觸控人機中執行，按功能鈕 [image] 以相同的順序移動。順序1,3,5…的文字物件非資料輸入物件。因此，無法選取亦不做排序。


4.3 規劃物件外觀

規劃物件外觀

物件外觀由以下四個部份組成，如下表所示：

外觀組成部分 | 說明
外型 | 物件的外型可分為圖形外型(graphical shapes)及圖片外型(picture shapes)。 以下為圖形外型的範例。 以下為圖片外型的範例。 本軟體提供許多外型可供選擇。詳細說明，請參考章節 4.3.3 外型設定。圖形外型的顏色及圖樣與關聯物件的狀態相關，因此，用戶必須設定關聯物件在不同狀態下的顏色與圖樣，詳細說明，請參考章節 4.3.1 顏色設定和章節 4.3.2 圖樣設定。 欲使用圖片外型，勾選物件屬性對話框一般頁中圖片外型項目。用戶可從圖片資料庫選擇/導入圖片，圖片檔案支援BMP、JPG及WMF等格式。若使用圖片作為物件外型，則此外型與狀態變化無關，也就是說，物件外型不會隨狀態而改變。因此，若欲使圖片外型顯示物件狀態或觸摸視效，可使用圖片群為物件外型，詳細說明，請參考 章節 2.2.3.2 圖片群 。 欲了解如何設定物件外型，請參考章節 4.3.4 設定物件外型。
內標示 | 內標示為物件內的標示，內標示個數與物件狀態個數相同。用戶需設定物件每個狀態的文字和圖片。內標示為語言相關，用戶需設定內標示文字使用的語言。注意，並非所有物件均可顯示內標示，某些物件僅可顯示文字或圖片內標示。 欲了解如何設定內標示，請參考章節 4.3.5 標示設定。
VFTA (觸摸視效) | 在操作員觸摸按鈕或開關時，可設定以下的觸摸視效：
 | 觸摸視效 | 說明
 | 下沉 | 將內標示向右下角移動1到2像素。
 | 換底色 | 以 圖樣色填充物件外型邊框內部區域。
 | 畫邊框 | 以圖樣色畫物件邊框。
外標示 | 外標示為附加在物件外的標示。與內標示不同的是，外標示與物件狀態無關，外標示將不會隨物件狀態變化而變化。外標示為語言相關，用戶需設定外標示文字所使用的語言。外標示無觸控反應，觸控外標示無法啟動物件。注意，並非所有物件均有外標示。 欲了解如何設定外標示，請參考章節 4.3.8 外標示設定。

下表顯示不同物件包含的一般外觀組成部分：

物件種類 | 外型 |  | 內標示 |  | 觸摸視效 | 外標示
 | 圖形外型 | 圖片外型 | 文字 | 圖片
位按鈕、切換開關、畫面按鈕、字按鈕、多態按鈕、單選按鈕 | ● | ● | ● | ● | ● | ●
功能按鈕、鍵盤按鈕、選頁器 | ● | ● | ● | ● | ● |
步進按鈕 | ● |  | ● | ● | ● | ●
位指示燈、多態指示燈 | ● | ● | ● | ● |  | ●
訊息顯示器 | ● |  | ● |  |  | ●
圖片顯示器 | ● |  |  | ● |  | ●
週日顯示器 | ● |  | ● |  |  |
儀表 | ● | ● |  |  |  |
滑動類比開關、數值輸入器、數值顯示器、進階數值顯示器、字符輸入器、字符顯示器，柱狀圖 | ● |  |  |  |  | ●
時間顯示器、日期顯示器、扇形圖、曲線圖、二維分佈圖、警報顯示器、歷史記錄顯示器、歷史趨勢圖、單筆記錄曲線圖、操作記錄顯示器、配方選擇器、配方表、次連線表、靜態文字、表格 | ● |  |  |  |  |
動畫 |  |  |  | ● |  |

下表為依序設定物件一般外觀組成的範例：

步驟 | 設定 | 範例 1 | 範例 2 | 說明
1 | 外型 |  |  | 詳閱章節 4.3.4說明。
 |  | 支援觸摸視效的圖片群 | 外型SW_0023
2 | 圖片內標示 |  | (無) | 詳閱章節 4.3.5.2說明。
3 | 文字內標示 |  |  | 詳閱章節 4.3.5.1說明。
4 | 觸摸視效 | (無) | 換底色(圖樣色為 [image] ) |
5 | 外標示 | (無) |  | 詳閱章節 4.3.8說明。
最後外觀 (未觸摸時) |  |  |  |
最後外觀 (觸摸時) |  |  |  |


4.3.1 顔色設定

顔色設定

■ 顏色圖標

在對話窗口中，顏色圖標是用來調整物件的顏色。圖標顯示現在所選擇的顏色，點選後會出現色盤。你可以從色盤中選取所需的顏色。下面的顏色圖標顯示現在選擇的顏色是黃色。
■ 顏色盤
 你可以利用色盤(1)系統預設的顏色中，選取顏色。(2)自訂顏色。(3)從自訂顏色中，選取顏色。

點選顏色圖標後出現色盤，下面是系統中四個頁面的色盤：

在第一頁中，黃色的區塊外圍的藍色外框表示現在選擇的顏色。點選所需的顏色區塊，來選擇顏色。要切換不同的頁面，點選上方的數字標籤。點選顏色區塊和數字標籤以外的區域，即可取消顏色設定的操作。頁面1、2和3包含預設的顏色。要自訂顏色，點選 [image] 後，會出現自訂定義顏色的對話窗口。


4.3.2 圖樣設定

圖樣設定

■ 圖樣圖標

在對話窗口中，圖樣圖標是用來調整物件的圖樣。圖標顯示現在所選擇的圖樣，點選後會出現圖樣盤。你可以從圖樣盤中選取所需的圖樣。下面的圖樣圖標顯示現在選擇的圖樣是粗直紋(big dashes)。

■ 圖樣盤

你可以從圖樣盤中，選取所需的圖樣。點選圖樣圖標後，即會出現如下的圖樣盤。

粗直紋圖標外圍的藍色外框表示現在所選的圖樣。點選所需的顏色區塊，來選擇顏色。點選圖樣區塊以外的區域，即可取消圖樣設定的操作。


4.3.3 外型設定

外型設定

■ 外型按鈕

在物件的屬性對話框中，您可以單擊“選擇”按鈕，彈出外型盤選擇多款外型的形狀，選擇一個相關的圖形外形。

 ■ 外型盤

你可以從外型盤中，選取所需的外型。點選外型按鈕圖標 [image] / [image] 後，即會出現外型盤。外型盤中包含數頁預設的外型，點選選取所需的外型。要切換不同的頁面，點選上方的數字標籤。點選結束圖標 [image] ，即可取消外型設定的操作。

一共有四組外型可供選擇。每一組外型有其對應的物件。外型盤的物件顯示其對應的物件種類。四組外型盤如下所示：

按鈕及開關的外型

資料輸入物件的外型

資料顯示物件的外型

指示燈的外型


4.3.4 設定物件外型

設定物件外型

這個章節說明如何設定物件的外型。

為了讓使用者在執行觸控操作有視覺上反饋。大多數可觸控操作的外型，在觸控時會產生變化。變化效果有觸控後讓外型看起來像是被按住的，或是外型的外觀顏色產生變化的。

以下是如何設定物件外型的範例。

範例一 | 範例二
選擇外型SW_0031 | 選擇圖片外型

下表為設定外型時，可能需要設定的屬性的說明。

屬性 | 說明
透明 | 物件背景透明。
圖片外型 | 勾選是否選用圖片外型。當物件可使用圖片外型時，此選項才會出現。
 | 點擊後可設定外型。當勾選圖片外型時，會出現選取/導入圖庫內資料。反之，會出現外型盤。
觸摸視效 / VFTA | 觸摸類型響應/ VFTA的（視覺反饋和觸摸操作）。有5種類型：（無）;沉沒;返回;輪廓框（1）概述（5）。 如果概述（1）或（5）簡述被選中，它概述1或5像素（次）狀態0，當按鈕被按下時的厚度和前景顏色的按鈕的邊框。
觸摸視效測試 | 點擊此按鈕可預覽所選的觸摸視效/VFTA。
邊框色 | 設定外型的邊框，點選顏色圖標來設定顏色。
圖樣 | 圖樣會填滿外型內的區域。要設定圖樣，點選圖樣圖標後，從圖樣盤中選擇圖樣。當外型內區域可填充時，才會顯示此選項。
圖樣色 | 圖樣色填充圖樣中黑色的部份。當選擇全白色的圖樣時，圖樣色是無作用的。當勾選圖片外型時，圖樣色是觸摸視效中畫邊框選項的顏色。
 | 範例一 | 範例二
 | 點選圖樣色圖標後從色盤中選取顏色，即可設定圖樣色。當外型內的區域需填充圖樣色時，此選項才會出現。
背景色 | 背景色填充圖樣中白色的部份。點選背景色圖標後從色盤中選取顏色，即可設定背景色。當外型內的區域需填充背景色時，此選項才會出現。


4.3.5 標示設定

標示設定

這個章節說明如何設定以下物件的內標示：位按鈕、切換開關、畫面按鈕、功能按鈕、字按鈕、鍵盤按鈕和位指示燈。

上述物件的屬性如果物件只有一種狀態，則會有文字次頁面和圖片次頁面可供設定內標示的文字和圖片。如果物件有兩種狀態，標示頁面會出現以下四種次頁面：

次頁面 | 設定項
狀態0文字 | 設定狀態0的文字
狀態0圖片 | 設定狀態0的圖片
狀態1文字 | 設定狀態1的文字
狀態1圖片 | 設定狀態1的圖片

標示頁面可設定物件的內標示，物件大多數只有兩種狀態，部份物件才有四種狀態。

以下是標示頁面的範例。

 下表僅說明在標示頁面中，通用的屬性。個別物件特殊的屬性將另外個別說明：

屬性 | 說明
語言 | 設定文字所使用的語言。
邊距 | 物件外型的文字或圖片與邊界間的距離。
所有語言都使用第一種語言的文本 | 勾選後無論現在使用何種語言，都將顯示第一種語言的文本。
文字標籤 | 點選出現文字次頁面。
圖片標籤 | 點選出現圖片次頁面。
狀態0文字標籤 | 點選出現狀態0文字次頁面。
狀態1文字標籤 | 點選出現狀態1文字次頁面。
狀態0圖片標籤 | 點選出現狀態0圖片次頁面。
狀態1圖片標籤 | 點選出現狀態1圖片次頁面。


4.3.5.1 文字次頁面設定

文字次頁面設定

利用文字、狀態0文字、狀態1文字的次頁面設定內標示的文字。語言的設定可藉由標示頁面中的語言選項來完成。

以下是標示頁面的文字範例：開始

文字次頁面 | 狀態1文字次頁面

下表為文字、狀態0文字、狀態1文字，對話窗口中各種屬性的說明。

屬性 | 說明
由註抄來 | 點擊此處，一般頁面中”註”的文字將取代現在頁面中的文字。
複製到狀態1 | 點擊此處，現在頁面中的文字將取代狀態1中的文字。
複製到狀態0 | 點擊此處，現在頁面中的文字將取代狀態0中的文字。
字體 | 可利用下拉式清單選擇字體。 點擊 [image] 出現字體模板的對話窗口，可選擇字體。在選擇字體前，可先選擇字體模板。
顏色 | 點擊顏色圖標後，可從色盤中選取顏色，設定文字顏色。
閃爍 | 勾選文字是否閃爍。可以選文字與底色的顏色切換的閃爍效果或是使用文字顯示和隱藏的閃爍效果。
透明 | 勾選文字的背景是否透明。
背景色 | 設定文字的背景色。
對齊 | 設定文字對齊方式。
字距 | 設定相鄰兩字間的距離。
行距 | 設定相鄰兩行間的距離。
背景色 | 設定物件外型的背景色。
位置 | 設定文字的位置。
複製屬性到狀態1 | 點擊此按鈕，使用當前屬性取代狀態1的文字。
複製屬性到狀態0 | 點擊此按鈕，使用當前屬性取代狀態0的文字。


4.3.5.2 圖片次頁面設定

圖片次頁面設定

利用圖片、狀態0圖片、狀態1圖片的次頁面設定內標示的圖片。
 以下是圖片頁面的範例：

狀態0圖片次頁面 | 狀態1圖片次頁面

下表為圖片、狀態0圖片、狀態1圖片，對話窗口中各種屬性的說明。

屬性 | 說明
名稱 | 設定圖片的名稱。可從下拉式清單選取資料庫中的圖片。 點擊 [image] 可從檔案夾中導入圖片，導入後的圖片將保存在資料庫中。 點擊 [image] 開啟選取/導入圖庫內圖片對話框，從圖片庫檔案中選擇圖片，導入後的圖片將保存在資料庫中。
複製到狀態1 | 點擊此處，現在頁面中的圖片將取代狀態1中的圖片。
複製到狀態0 | 點擊此處，現在頁面中的圖片將取代狀態0中的圖片。
透明 | 勾選是否使圖片的某些部份透明，圖片顏色與透明色相同的部份將會變成透明。設定圖片中的透明色。圖片非黑白圖片才會出現這個選項。
透明色 | 設定透明色。
圖樣色 | 設定黑白圖片中，黑色部分的顏色。圖片為黑白圖片才會出現這個選項。
背景色 | 設定黑白圖片中，白色部分的顏色。圖片為黑白圖片才會出現這個選項。
旋轉/翻轉 | 設定圖片翻轉/旋轉的方式，有八個選項：
 | 方式 | 說明
 | 0° | 維持原狀。
 | 90° | 圖片順時針旋轉90度。
 | 180° | 圖片順時針旋轉180度。
 | 270° | 圖片順時針旋轉270度。
 | X | 圖片沿X軸翻轉。
 | 90° & X | 圖片順時針旋轉90度後，再沿X軸翻轉。
 | Y | 圖片沿Y軸翻轉。
 | 90° & Y | 圖片順時針旋轉90度後，再沿Y軸翻轉。
改色調 | 選擇是否改變圖片的色調。
新色調 | 設定圖片的新色調。
配合物件大小 | 勾選圖片是否依據物件框自動調整大小。
位置 | 設定圖片的位置。
背景色 | 設定物件外型的背景色。


4.3.6 文字次頁面設定

文字設定

利用文字、狀態0文字、狀態1文字的次頁面設定內標示的文字。語言的設定可藉由標示頁面中的語言選項來完成。

以下是標示頁面的文字範例： 啟動

下表為文字、狀態0文字、狀態1文字，對話窗口中各種屬性的說明。

屬性 |  | 說 明
語言 |  | 設定文字所使用的語言。
邊距 |  | 物件外型的文字或圖片與邊界間的距離。
所有語言都使用第一種語言的文本 |  | 勾選後無論現在使用何種語言，都將顯示第一種語言的文本。
<狀態列表> |  | 列出所有狀態和相應的文本。要查看和修改的狀態屬性和文本，請單擊該行狀態。
移上 |  | 點擊此處將現在文字(圖片)在清單中上移，同時狀態編號減1。
移下 |  | 點擊此處將現在文字(圖片)在清單中下移，同時狀態編號加1。
複製到狀態1 |  | 點擊此處，現在頁面中的文字將取代狀態1中的文字。
複製到狀態0 |  | 點擊此處，現在頁面中的文字將取代狀態0中的文字。
字體 |  | 可利用下拉式清單選擇字體。 點擊 [image] 出現字體模板的對話窗口，可選擇字體。在選擇字體前，可先選擇字體模板。
顏色 |  | 點擊顏色圖標後，可從色盤中選取顏色，設定文字顏色。
透明 |  | 勾選文字的背景是否透明。
背景色 |  | 設定文字的背景色。
 |  | 設定文字對齊方式。
位置 |  | 設定文字的位置。
閃爍 |  | 勾選文字是否閃爍。可以選文字與底色的顏色切換的閃爍效果或是使用文字顯示和隱藏的閃爍效果。
背景色 |  | 設定物件外型的背景色。
文字 | <編輯框> / <下拉式表列框> | 選擇修改狀態文字。
 | / | 設定當前所選語言的文字。點擊 [image] 圖示，用戶可以在文字編輯框中，查看與編輯所選語言的文字；或點擊 [image] 圖示，從下拉文字形檔列表中選擇文字，可在選擇文字前改變文字形檔的內容。
行距 |  | 設定相鄰兩行間的距離。
字距 |  | 設定相鄰兩字間的距離。


4.3.7 圖片設定

圖片設定

這個章節說明如何設定以下物件內部標示的圖片：多態按鈕、單選按鍵、步進按鈕、選頁器、多態指示燈、圖片顯示器和動畫。

上述物件的圖片頁面可供修改物件的圖片設定。以下是圖片頁面的範例：

下表為圖片、狀態0圖片、狀態1圖片，對話窗口中各種屬性的說明。

屬性 | 說明
邊框間距 | 設定圖片邊框和形狀邊界之間的距離（以像素為單位）。
名稱 | 設定圖片的名稱。可從下拉式清單選取資料庫中的圖片。 點擊 [image] 可從檔案夾中導入圖片，導入後的圖片將保存在資料庫中。 點擊 [image] 開啟選取/導入圖庫內圖片對話框，從圖片庫檔案中選擇圖片，導入後的圖片將保存在資料庫中。
透明 | 勾選是否使圖片的某些部份透明，圖片顏色與透明色相同的部份將會變成透明。設定圖片中的透明色。圖片非黑白圖片才會出現這個選項。
透明色 | 設定透明色。
圖樣色 | 設定黑白圖片中，黑色部分的顏色。圖片為黑白圖片才會出現這個選項。
背景色 | 設定黑白圖片中，白色部分的顏色。圖片為黑白圖片才會出現這個選項。
旋轉/翻轉 | 設定圖片翻轉/旋轉的方式，有八個選項：
 | 方式 | 說明
 | 0° | 維持原狀。
 | 90° | 圖片順時針旋轉90度。
 | 180° | 圖片順時針旋轉180度。
 | 270° | 圖片順時針旋轉270度。
 | X | 圖片沿X軸翻轉。
 | 90° & X | 圖片順時針旋轉90度後，再沿X軸翻轉。
 | Y | 圖片沿Y軸翻轉。
 | 90° & Y | 圖片順時針旋轉90度後，再沿Y軸翻轉。
改色調 | 選擇是否改變圖片的色調。
新色調 | 設定圖片的顏色。
配合物件大小 | 勾選圖片是否依據物件框自動調整大小。
位置 | 設定圖片的位置。
背景色 | 設定物件外型的背景色。


4.3.8 外標示設定

外標示設定

這個章節說明如何設定以下物件的外標示：位按鈕、切換開關、畫面按鈕、滑動類比開關、字按鈕、多態按鈕、單選按鈕、步進按鈕、數值輸入器、數值顯示器、進階數值顯示器、ASCII字輸入器、ASCII字顯示器、位指示燈、多態指示燈、訊息顯示器、圖片顯示器和柱。

可以從外標示頁面設定物件的外標示。以下是外標示頁面的範例：

下表為外標示頁面對話窗口中，各項屬性的說明。

屬性 |  | 說明
標示樣式 |  | 設定外標示的標示樣式。共有以下四種標示樣式：
 |  | 標示樣式 | 範例
 |  | 透明 |
 |  | 平 |
 |  | 描邊 |
 |  | 凸 |
位置 |  | 設定外標示相對於物件的位置。共有以下四種位置：
 |  | 位置 | 範例
 |  | 上 |
 |  | 左 |
 |  | 右 |
 |  | 下 |
顏色 | 邊框 | 點擊顏色圖標後，可從色盤中選取顏色，設定邊框顏色。
 | 底板 | 點擊顏色圖標後，可從色盤中選取顏色，設定底板顏色。
 | 文字 | 點擊顏色圖標後，可從色盤中選取顏色，設定文字顏色。
語言 |  | 設定文字使用的語言。
字體 | <下拉式清單> | 設定文字的字體。
 |  | 點擊 [image] 出現字體模板對話框，可選擇字體。在選擇字體前，可先選擇字體模板。
文字 | <編輯框> / <下拉式表列框> | 當前語言文 字。
 | / | 設定當前所選語言的文字。點擊 [image] 圖示，用戶可以在文字編輯框中，查看與編輯所選語言的文字；或點擊 [image] 圖示，從下拉文字形檔列表中選擇文字，可在選擇文字前改變文字形檔的內容。
 |  | 設定文字對齊方式。
間距 | 邊緣 | 設定文字與外標示邊緣的距離。
 | 行 | 設定相鄰兩行間的距離。
 | 字 | 設定相鄰兩字的距離。


4.4.1 物件狀態

物件狀態

當一物件有多個狀態，物件的外觀個數將與狀態個數相同，用戶須設定每個狀態的外型及內標示。通常，物件的狀態是由監視變數的數值所決定。若物件的監視變數種類為位(Bit)，則有狀態0(off)及狀態1(on)；若物件的監視變數為字(word)或雙字(double-word)，最多可有256個狀態。


4.4.1.1 狀態種類

狀態種類

用戶須指定物件的狀態類別，然後，才能決定物件的狀態。下表說明四種狀態類別的決定方式。

狀態類別 | 監視變數類別 | 狀態決定方式
位 | 位變數 | 狀態為變數的數值。 範例： 1)當$U1.3為0，則$U1.3的狀態為0(off)。 2)當WX3.f為1，則WX3.f的狀態為1(on).
數值 | 字變數、雙字變數 | 狀態為變數的數值，有效狀態從0到255。 範例： 1)當$U200為123，則$U200的狀態為123。 2)當WX20為0，則WX20狀態為0。 3)當$N300為999，則$N300狀態為無效設定。
最低位 | 字變數、雙字變數 | 狀態為最低位變數數值為1(on)的個數。若變數類別為字變數，有效狀態從0到16，16表示所有位均為0；若變數類別為雙字變數，有效狀態從0到32，32表示所有位均為0。 範例： 1)當$U200為246H，則$U200為1。 2)當WX2為80000H，則WX狀態為19。 3)當$N300為0，則$N300狀態為16。
自訂狀態值 | 字變數、雙字變數 | 當物件狀態類別設定自訂狀態值，用戶需為每一個有效狀態設定一個獨有的數字，此數字即為狀態值。狀態值用來決定物件的狀態。當變數數值與狀態值相同，則此狀態值所對應的狀態即為物件狀態。若變數數值與狀態值不相同，則物件狀態為無效設定。 範例： 物件監視$U100，其狀態類別為自訂狀態值。有三種有效狀態，分別指定300、200及100為狀態0、1、2，當$U100為100，則物件狀態為2；當$U100為300，則物件狀態為0。


4.4.1.2 設定物件自訂狀態值

設定物件自訂狀態值

在物件屬性對話框一般頁中，選擇自訂狀態值，再點擊 [image] 按鈕，將出現自訂狀態值對話框，如下圖所示。

在自訂狀態值對話框中，用戶可以為每個狀態設定一正整數數值。欲編輯此數值，可直接點擊該狀態的數值欄位。

用戶可使用往上移或往下移按鈕調整狀態值的位置。欲將狀態值往上移或往下移按鈕，用戶須先選取狀態；欲選取狀態，可點擊該狀態的標題列位置；欲同時選擇多個狀態，按住Ctrl並同時用滑鼠左鍵點選狀態的標題列。


4.4.2 物件的功能操作選項

物件的功能操作選項

下表為物件的功能操作選項，可使物件顯示更多訊息，使用上更有效率、更安全。

功能選項 | 定義
觸控有效與觸控無效 | 觸控操作是否有效可由指定的位或當前用戶等級所控制。用戶可選擇當觸控無效時，在按鈕上顯示觸控無效標示。 如果由位控制觸控操作是否有效，用戶需設定控制位地址及觸控有效的狀態值。 如果由當前用戶等級控制觸控操作是否有效，用戶需設定可使觸控有效的最低用戶等級。 在位按鈕屬性對話框的進階頁中，選擇和設定此項屬性。
最少按壓時間 | 按鈕需持續按壓超過最小按壓時間，才會執行觸控操作。 在位按鈕屬性對話框的進階頁中，選擇和設定此項屬性。
操作員確認 | 當按壓按鈕，會出現確認對話框。當操作員選擇“Yes”確認操作後，按鈕將信號寫入指定的PLC位地址；如果操作員選擇“No”或在最大等待時間內未回應，則取消操作。 以下的操作可設定此屬性： 設1、設0、設1脈波、設0脈波和反相。 在位按鈕屬性對話框的進階頁中，選擇和設定此項屬性。
觸控操作通知 | 在觸控操作執行後，通知指定的位。用戶需設定通知位地址和通知的狀態值。 在位按鈕屬性對話框的進階頁中，選擇和設定此項屬性。
操作記錄 | 將觸控操作執行時的時間、日期、寫入PLC的數值和文字記錄在人機應用的操作記錄器中。 在位按鈕屬性對話框的進階頁中，選擇和設定此項屬性。
改變用戶等級 | 當以下物件被激活時，當前用戶等級將會發生改變。 位按鈕，切換開關，字按鈕，功能按鈕，畫面按鈕，數值輸入器和字符輸入器 上述物件的對話框在進階頁中，選擇並設置此功能。
指定鍵盤 | 以下物件可以使用獨立的鍵盤輸入數字或字符，而不是系統內置鍵盤。 數值輸入器，高級數值顯示器，字符輸入器，字按钮 上述物件的對話框在進階頁中，選擇並設置此功能。
顯現與隱藏物件 | 物件的顯現與否，可由指定的位或當前用戶等級所控制，也就是說，物件可以用這兩種方式，動態設定物件的顯現或隱藏。 如果由位控制物件顯現與否，用戶需設定位地址與物件顯示狀態值。 如果由當前用戶等及控制物件顯現與否，用戶需設定可使物件顯現的最低用戶等級。 註1：當物件隱藏，觸控操作將自動無效。 註2：透過設定，亦可使物件隱藏，但觸控操作仍有效。 在物件屬性對話框的顯現頁中，選擇和設定此項屬性。


4.4.3 地址設定

地址設定

本章節說明地址設定的方式。


4.4.3.1 數據存取用語

數據存取用語

下表說明變數、地址和標籤。

用語 | 定義
內部記憶區 | 在人機中，可由人機應用存取的記憶空間。例如，一般用戶記憶區$U、電池保護記憶區$N、系統記憶區$S、配方記憶區$R，均為內部記憶區。
內部變數 | 內部變數為一地址或標籤，指示內部記憶區中，變數的地址。
內部位變數 | 內部位變數為內部記憶區中，變數種類為位(Bit)的內部變數。 註：為方便閱讀，在不會產生混淆的情形下，一般使用“內部變數”代表“內部位變數”。
內部字變數 | 內部位變數為內部記憶區中，變數種類為字(Word)的內部變數。 此變數亦可為雙字、位元區塊(位元陣列)、字區塊(字陣列)和雙字區塊(雙字陣列)。 註：為方便閱讀，在不會產生混淆的情形下，一般使用“內部變數”代表“內部字變數”。
外部記憶區 | 外部記憶區為控制器中的記憶區空間或可定址裝置，人機應用可透過通訊連線存取。
外部變數 | 外部變數為一地址或標籤，指示外部記憶區中，變數的地址。
外部位變數 | 外部位變數為外部記憶區中，變數種類為位(Bit)的內部變數。 註：為方便閱讀，在不會產生混淆的情形下，一般使用“外部變數”代表“外部位變數”。
外部字變數 | 外部位變數為外部記憶區中，變數種類為字(Word)的內部變數。 此變數亦可為雙字，位元區塊(位元陣列)、字區塊(字陣列)和雙字區塊(雙字陣列)。如果存取單位為雙字，用戶僅可使用4位元倍數的雙字或記憶區空間。 註：為方便閱讀，在不會產生混淆的情形下，一般使用“外部變數”代表“外部字變數”。
外部字節變數 | 外部位變數為外部記憶區中，變數種類為字節(Byte)的內部變數。 註：為方便閱讀，在不會產生混淆的情形下，一般使用“外部變數”代表“外部字節變數”。
變數 | 內部變數或外部變數。
位變數 | 內部位變數或外部位變數。
字變數 | 內部字變數或外部字變數。
字節變數 | 某些PLC才有提供此字節的外部變數(字節沒有提供內部變數)。
雙字變數 | 雙字的內部變數或外部變數。
字節陣列變數 | 字節陣列的外部變數。
字陣列變數 | 字陣列的內部變數或外部變數。
雙字陣列變數 | 雙字陣列的內部變數或外部變數。
標籤 | 代表內部記憶區或外部記憶區一個地址的名稱。同時，用戶需設定標籤的數據類別與掃描速率等屬性。

註: 下列PLC支持字節 (Byte) 通信:

1) Simatic S7-200 (PPI; 1-to-1)

2) Simatic S7-300 (MPI Port)

3) Simatic S7-300 Ethernet Module (CP343)

4) Simatic S7 (Ethernet)

5) S7-200 SMART (Ethernet)

6) VIPA 100V/200V MPI Port


4.4.3.2 地址輸入鍵盤

地址輸入鍵盤
用戶可利用地址輸入鍵盤輸入地址，點擊 [image] 圖示後，出現地址輸入鍵盤，如下所示：

项目 | 屬性 | 說明
1 | 連線 | 點擊向下箭頭，從下拉式清單選擇連線。
 | 次連線 | 點擊向下箭頭，從下拉列表中選擇子連線。次連線可用時 可选此項。
 | 類型 | 選擇地址類型。
2 | 地址 | 點擊向下箭頭，選擇數值從0到255或間接地址[$I0]到 [$I15]為PLC地址。 如果使用間接地址，PLC地址可動態改變。
3 | 位置種類 | 點擊向下箭頭，從下拉式清單選擇位置種類。
4 | 地址 | 設定地址。
5 | 輸入鍵盤 | 按鈕 | 說明
 |  |  | 清除地址欄位中的文字內容。
 |  |  | 刪除所選文字，或刪除地址欄中游標左方的文字。
 |  |  | 取消地址輸入並結束對話框。
 |  |  | 確認並輸入有效地址。
 |  | 其他 | 點擊按鈕輸入地址。當地址欄位中有輸入駐點時，才可輸入。
 |  | 點擊說明按鈕，在出現彈出視窗中，可檢視設定字或位裝置和連線地址的設定。


4.4.3.3 選取標籤

選取標籤

點擊 [image] 圖示，從選取標籤對話框中，選擇所需標籤。

下表描述了標籤視窗中的每一個屬性。

屬性 |  | 說明
連線 |  | 單擊向下箭頭，從下拉列表中選擇一個連線。
標籤名 |  | 指定標籤名。
<<新標籤>> |  | 點擊該按鈕，創建彈出新標籤對話框。
<<關閉>> |  | 關閉新標籤對話框。
基本標籤/地址 |  | 指定選中標籤的地址。
位編號 |  | 指定標籤位編號。
清單選項 |  | 點擊“清單選項”按鈕，創建彈出下圖對話框。
 |  | 選項 | 說明
 |  | 標籤 | 選擇此選項，列出所有的預定義的位標記和文字標記。
 |  | 可選標籤 | 選擇此選項可顯示選擇的標籤。當指定的地址類型為字，所有字標記將被列出。當指定的地址類型是位，位標籤將陸續列出。
 |  | 具指定數據類型標籤 | 選擇此選項可以顯示指定的數據類型相同的數據類型的標籤。
 |  | 顯示數據類型 | 選中此選項，顯示標籤跟踪的數據類型。
標籤群 |  | 列出了預定義的標籤為所選鏈接。要使用標籤時，您可以雙擊選定的標籤。 註：1）列出的所有的標籤和標籤組中創建標籤編輯器或新標籤定義對話框。要創建一個標籤，請參見 章節2.3 使用標籤 。 2) 列表展示可選標籤。
新標籤定義 | 標籤群 | 單擊向下箭頭，從下拉列表中選擇一個標籤組。選擇“默認”表示當前標籤組。
 | 標籤名 | 指定標籤名稱。
 | 誰的別名 | 點擊 [image] 選擇標籤對話框選擇基本標籤新標籤。
 | 數據類型 | 單擊 [image] “選擇數據類型”對話框中，選擇數據類型的標籤。
 | 地址 | 點擊 [image] 地址輸入鍵盤，輸入所需的地址。
 | 掃描速率 | 標籤從下拉列表中選擇掃描速度。
 | 說明 | 輸入一個標籤的描述。
 | 添加 | 添加新標籤。
 | 清除 | 單擊以清除定義新標籤。
確定 |  | 點擊選擇標籤。
取消 |  | 點擊它來關閉該對話框，並放棄所有更改。


4.4.4 刻度的設定

刻度的設定

這個章節說明如何設定以下物件的刻度：滑動類比開關、柱狀圖、扇形圖和儀表。

下面是刻度使用在不同物件的範例。

物件屬性對話窗口中的刻度頁面，可設定刻度。下面是刻度頁面的範例。

物件屬性對話窗口中的刻度頁面，可設定刻度。下面是刻度頁面的範例。

屬性 |  | 說明
顯示 |  | 勾選是否顯示刻度。
位置 |  | 設定物件刻度的位置。位置是監視變數相對於物件的位置。共有以下六種位置：
 |  | 位置 | 範例 | 位置 | 範例
 |  | 上 |  | 下 |
 |  | 左 |  | 右 |
 |  | 內 |  | 外 |
顏色 |  | 點擊顏色圖標後，可從色盤中選取顏色，設定刻度顏色。
主刻度數 |  | 設定主刻度數，最小值是2。
次分隔數 |  | 設定兩個連續主刻度數中間的次分隔數。最小值為1。
軸 |  | 勾選刻度是否顯示軸。
刻度記號 | 刻度記號 | 勾選刻度是否顯示記號。
 | 字體 | 刻度記號的字體。
 | 動態範圍 | 勾選刻度記號的最小及最大值是否在執行時是否被動態範圍參數區塊控制。
 | 最小值 | 設定刻度記號的最小值。最小值為32位元的整數。
 | 最大值 | 設定刻度記號的最大值。最大值為32位元的整數。
 | 總位數 | 設定刻度記號的總位數。
 | 小數位數 | 設定刻度記號小數位數。例如，當最大值是5000，總位數是4，小數位數是2，記號的最大值就是50.00。


4.4.5 進階設定

進階設定

這個章節說明以下物件的進階設定：位按鈕、切換開關、畫面按鈕、功能按鈕、滑動類比開關、字按鈕、多態按鈕、單選按鈕、步進按鈕、進階數值顯示器、ASCII字輸入器和配方選擇器。

可以從進階設定頁面調整物件的進階設定。

下圖為不同物件進階設定的範例。

針對數值顯示/輸入物件 | 針對按鈕物件

表為進階設定頁對話框中，各項屬性的說明。

屬性 |  | 說明
觸控有效 | 受位控制 | 勾選數值輸入的觸控操作是否受位控制。
 | 控制位 | 設定觸控是否有效的控制位。點擊 [image] 輸入地址。點 [image] 擊選取標籤。
 | 有效狀態 | 設定觸控操作狀態(1或0)。
 | 受用戶等級控制 | 勾選觸控操作數值輸入是否受用戶等級控制。
 | 最低有效用戶等級 | 設定最低有效用戶等級。
 | 最低有效用戶等級 | 勾選當觸控操作無效時是否顯示不可操作的圖樣在該按鈕上面。
超時 | 超時取消 | 勾選是否當停止輸入超過特定時間時，取消資料輸入。
 | 超時時間 | 設定系統等待資料輸入的最長時間。如果超過設定的時間，數字鍵將無法再輸入且輸入的資料將會被取消。
通知 | 通知 | 勾選完成數值輸入後，是否通知特定位。
 | 訊號 | 兩種訊號可供選擇：
 |  | 訊號 | 說明
 |  | 位階 | 設定特定位特定的狀態。
 |  | 脈衝 | 傳送特定位正脈衝。
 | 通知位 | 設定通知位。
 | 狀態 | 設定通知位狀態(1或0)。
操作員確認 | 操作員確認 | 勾選操作員是否須自己確認所輸入的數字。當輸入數值時，會出現確認窗口。如果操作員點選是，則數值就會輸入指定的變數；如果操作員點選否或操作員在設定的時間(等待時間)內沒有回應，將會取消數值輸入。
 | 等待時間 | 設定等待操作員確認最長的時間。
改變用戶等級 | 改變用戶等級 | 選擇此選項，當物件被啟動時 ，用戶等級發生變化。
 | 新用戶等級 | 指定新的用戶等級。
操作記錄 | 操作記錄 | 勾選以下三個項目是否要儲存在操作記錄中。 記錄的項目有三個： 開始操作的時間。 輸入的值。 預設的操作訊息。
 | 訊息 | 輸入第一種語言的操作訊息。
 |  | 點擊此處，出現操作記錄訊息，可用所有的語言編輯操作訊息。
指定鍵盤 | 指定鍵盤 | 選擇此選項，可以使用指定的的鍵盤。
 | 畫面 | 指定鍵盤所在畫面。
最少按壓時間 |  | 當物件是按鈕或開關時，會出現此選項。按鈕的操作必須要持續按壓按鈕超過一段指定的時間(最少按壓時間)後，操作才算有效。


4.4.6 顯現設定

顯現設定

在物件的屬性設定中，顯現設定頁面是讓用戶設定物件的顯現和隱藏。同時，物件的位置和大小也可在顯現設定頁面中調整。

下面是顯現頁設定的範例：

勾選受位控制 | 勾選受用戶等級控制

下表為顯現設定頁面對話窗口中，各種屬性的說明。

屬性 |  | 說 明
不顯現 |  | 勾選後物件將永不顯現。 註：不顯現設定後觸控操作仍然有效。
受位控制 | 受位控制 | 勾選物件顯現與否，是否受位控制。
 | 控制位 | 設定控制物件是否顯現的位變數地址。 點擊 [image] 輸入地址。點擊 [image] 選取標籤。
 | 顯現狀態 | 設定顯現的狀態(1或0)。
受用戶等級控制 | 受用戶等級控制 | 勾選物件顯現與否，是否受用戶等級控制。
 | 最低顯現用戶等級 | 設定最低顯現用戶等級。
外緣 | 外緣 | 設定物件左上角與畫面左邊界的距離。
 | 上邊 | 設定物件左上角與畫面上邊界的距離。
 | 寬度 | 設定物件的寬度。
 | 高度 | 設定物件的高度。
 |  | 點選此處以新設定重繪物件。


5.1 位按鈕

位按鈕

按鈕(Buttons)物件，可讓觸控屏的使用者利用觸控屏與控制器產生互動，它可以將一個位開關啟動或關閉，觸壓位按鈕可改變位的狀態。它是一個觸控按鈕，當按鈕啟動時可控制PLC上的一個位元ON或OFF，且可藉由PLC的讀取位元狀態來控制畫面物件所顯示的圖形狀態的改變。這些按鈕模擬機械的開關，0邏輯數值代表斷開，1邏輯數值代表導通。

本軟體中包含多個按鈕選項，而各按鈕功能請參考如下說明。

■ 一般頁
 詳閱章節 5.1.4.說明

■ 標示頁
 詳閱章節 4.3.5.說明

■ 進階頁
 詳閱章節 4.4.5.說明

■ 顯現頁
 詳閱章節 4.4.6.說明

■ 外標示頁
 詳閱章節 4.3.8.說明

■ 壹巨集頁
 詳閱章節 15.2.6.說明

■ 零巨集頁
 詳閱章節 15.2.6.說明


5.1.1 位按鈕 - 基本功能

位按鈕 - 基本功能

一個位按鈕可以被規劃有以下幾種動作模式：

功能 | 說明
設1 | 當觸壓按鈕時，設位為1。表示觸摸此按鈕時會將寫入地址的位(bit)設為on，放開按鈕時還是on。
設0 | 當觸壓按鈕時，設位為0。表示觸摸此按鈕時會將寫入地址的位(bit)設為off，放開按鈕時還是off。
設1脈波 | 當觸壓按鈕時，設位為1。然後，設位為0，同時產生指定脈波寬的正脈波。表示觸摸按鈕時會將寫入地址的位(bit)設為一個脈波ON輸出，可設置最小脈波ON的時間為50msec到500msec。
設0脈波 | 當觸壓按鈕時，設位為0。然後，設位為1，同時產生指定脈波寬的負脈波。表示觸摸按鈕時會將寫入地址的位(bit)設為一個脈波OFF輸出，可設置最小脈波OFF的時間為50msec到500msec。
保持1 | 當觸壓按鈕，設位為1；放開按鈕後，設位為0。表示觸摸按鈕時會將寫入地址的位(bit)設為on，放開按鈕時就設為off。 注意:設最小脈波寬，主要是按壓時會產生所設定的脈波寬度，以利PLC控制器接收信號，最小為0.05秒，但如果時間設太短可能PLC因為通訊或本身掃描時間太長，將導致PLC無法偵測到脈波而無法正確接收時，為避免這個問題，可設定適當長度的脈波寬，位0會延遲，以確保PLC能接收所有的脈波。
保持0 | 當觸壓按鈕，設位為0；放開按鈕後，設位為1。表示觸摸按鈕時會將寫入地址的位(bit)設為off，放開按鈕時就設為on。 注意:請參考上面的說明。
反相 | 當觸壓按鈕，反轉位的狀態。表示觸摸此按鈕時會將寫入地址的位(bit)設為反相，例如原本該地址的位(bit)為on狀態時，則觸摸此按鈕時會將寫入地址的位(bit)設為off (放開按鈕時還是off)，反之如果原按壓前該地址的位(bit)為off狀態時，則觸摸此按鈕時會將寫入地址的位(bit)設為on (放開按鈕時還是on)。

註：位按鈕可設置位的變數種類，除了位(bit)以外，也支援『字的位』(a bit of a word)和『雙字的位』(a bit of a double-word)。但是，這兩種變數的種類需設定位編號。


5.1.2 位按鈕 - 功能選項

位按鈕 - 功能選項

下表是位按鈕的功能選項，可使位按鈕的使用更有效率、更安全。功能選項的設定可在位按鈕的屬性對話框中完成。

選項 | 說明
監視 | 位按鈕可設置來監視位。當勾選此選項時，按鈕的狀態由監視位控制。使用者可使用監視位控制位按鈕的顏色和標示。
壹(1)巨集/零(0)巨集 | 壹(1)巨集：表示觸摸此按鈕時會執行ON巨集的程式。零(0)巨集：表示觸摸此按鈕時會執行OFF巨集的程式。當觸壓按鈕，啟動設位為1的功能時，執行壹巨集的程式。反之，當觸壓按鈕，啟動設位為0的功能時，執行零巨集的程式。各對應的巨集，可勾選巨集選項時，就會新增零(0)巨集和壹(1)巨集窗口，表示要建立執行巨集功能。 下表顯示位按鈕功能支援巨集種類。
 | 功能 | 壹巨集 | 零巨集
 | 設1 | ● |
 | 設0 |  | ●
 | 設1脈波 | ● |
 | 設0脈波 |  | ●
 | 保持1 | ● | ●
 | 保持0 | ● | ●
 | 反相 |  |
 | 位按鈕的一般頁中可勾選壹巨集或零巨集。勾選後，可在壹巨集頁面中編輯壹巨集程式；在零巨集頁面中編輯零巨集程式。 註：當已設定壹巨集或零巨集，在巨集執行結束前，位按鈕的功能不會執行。所以，壹巨集或零巨集的長度應儘可能縮短，使設定的功能順利執行。 註：如果您使用”設1位按鈕” ，當有寫了一個”1”巨集$U0=$U0+1時是否應該當此按鈕有變化時才會執行,還是每次按壓此按鈕都會執行? 答案是觸控屏每次按壓此按鈕都會執行。但是實際按鈕狀態只有第一次會變化。
觸控有效 | 觸控有效或觸控無效可由指定的位或(且)當前使用者等級控制。在進階頁中，可進行此選項的設定。 註:可以同時勾選上兩項條件都成立才啟動該按鈕操作。
最少按壓時間 | 按鈕的觸控操作必須持續按壓一段時間(最少按壓時間)後，觸控屏才將該按鈕信號寫至PLC。在進階頁中，可進行此選項的設定。
操作員確認 | 此選項在以下位按鈕功能出現：設1、設0、設1脈波、設0脈波和反相。 當觸壓此按鈕時，觸控屏會自動要求“確認”，須等操作員選擇“是”後，觸控屏才會執行位按鈕的操作並將該按鈕信號寫至PLC控制器；當操作員選擇“否”，或在最大等待時間內沒有回應，則停止位按鈕操作。最大等待時間表示觸控屏等待使用者“確認”的最長等待計時，時間內如果沒有按“確認”就自動取消該操作。 在進階頁中，可進行此選項的設定。
通知 | 當操作這一按鈕時，觸控屏可以發送位(bit) on/off信號通知另一個指定的位。在進階頁中，可進行此選項的設定。
操作記錄 | 可勾選操作記錄選項，表示該按鈕的操作事件會被觸控屏系統記錄在操作記錄器中。在進階頁中，可進行此選項的設定。
改變使用者等級 | 當操作這一按鈕時，會改變當前 使用者等級(可更改等級為0~9級)。在進階頁中，可進行此選項的設定。
不顯現 | 勾選此選項，表示此按鈕會隱藏，但觸控操作仍有效。在顯現頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由設定的位或當前使用者等級控制。在顯現頁中，可進行此選項的設定。


5.1.3 位按鈕 - 設定

位按鈕 - 設定

位按鈕所有的設定都可在屬性視窗中完成。按鈕物件屬性視窗上會出現以下幾個標籤頁，有些頁面在需要設定時才會顯現。

■ 一般頁
 詳閱章節 5.1.4.說明

■ 標示頁
 詳閱章節 4.3.5.說明

■ 進階頁
 詳閱章節 4.4.5.說明

■ 顯現頁
 詳閱章節 4.4.6.說明

■ 外標示頁
 詳閱章節 4.3.8.說明

■ 壹巨集頁
 詳閱章節 15.2.6.說明

■ 零巨集頁
 詳閱章節 15.2.6.說明


5.1.4 位按鈕 - 一般設定

位按鈕 - 一般設定

本章節說明位按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中，各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定位按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為BBnnnn。
註 |  | 可加上本物件的說明文字。
背景透明 |  | 勾選此項設置物件邊框、背景色…等外型設置會呈現透明狀態。
外型 |  | 背景透明、圖片外型、 [image] 、觸摸視效 、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 |  | 如勾選外標示選項時，就會新增外標示頁面，可直接加上本物件的外部文字說明，及其相關設置參數。
 |  | 點擊此處使位按鈕為狀態1，可檢視和設定狀態1物件的外觀。
 |  | 點擊此處使位按鈕為狀態0，可檢視和設定狀態0物件的外觀。
功能 |  | 選擇位按鈕的功能，共有7個選項： 設 1、設 0、設 1脈波、設 0脈波、保持 1、保持 0、反相。不同的按鈕代表了按鈕按下時會出現的功能特性也不同。 相關說明，請參考章節 5.1.1 基本功能。
啟動功能 |  | 選擇啟動此功能的時機點， 可以是壓下時或是放壓時，本功能只適用於設1和設0按鈕和反向按鈕。
按住不放連續設置 |  | 如勾選此選項時，按壓按鈕物件就會連續送出通訊命令給控制器。
地址種類 |  | 設定寫入地址欄變數的種類。位按鈕支援以下三個種類的變數：位、字和雙字。除了位以外，也支援字的位和雙字的位。
 |  | 變數種類 | 說明
 |  | 位 | 設定變數為位變數。
 |  | 字 | 設定變數為字變數。字變數需要設定位編號，位編號範圍從0到15。
 |  | 雙字 | 設定變數為雙字變數。雙字變數需要設定位編號，位編號範圍從0到31。
 |  | 位元組 | 設定變數為位元組變數。位元組變數需要設定位編號，位編號範圍從0〜7。『位元組』存取以8個 bit 為單位，此功能需要配合驅動支持。
寫入地址 | 寫入地址 | 設定寫入的位地址，送給控制器或PLC相對應之接點。 當地址種類為位，設定位變數的地址。 當地址種類為字，設定字變數的地址。 當地址種類為雙字，設定雙字變數的地址。 當地址種類為位元組，設定位元組變數的地址。
 |  | 點擊 [image] 圖標，會出現地址輸入鍵盤對話框，在此您可選擇您希望寫入的記憶位置或輸入所需的變數地址。
 |  | 點擊 [image] 圖標，出現選取標籤對話框。選取所需的標籤。
 | 位編號 | 設定位編號。
最小脈波寬 |  | 只有保持1和保持0可設最小脈波寬，主要是按壓時會產生設定的脈波寬度，以利PLC控制器接收信號，最小為0.05秒，如果時間設太短可能PLC因為通訊或本身掃描時間太長，無法可靠接收到時，脈波寬要增加到能接收的時間。共有六個選項：0.05、0.1、0.2、0.3、0.4、0.5秒。
脈波寬 |  | 只有保持1和保持0可設最小脈波寬，主要是按壓時會產生設定的脈波寬度，以利PLC控制器接收信號，最小為0.05秒，如果時間設太短可能PLC因為通訊或本身掃描時間太長，無法可靠接收到時，脈波寬要增加到能接收的時間。共有六個選項：0.05、0.1、0.2、0.3、0.4、0.5秒。
監視 |  | 如勾選監視選項，表示此物件的顯示狀態將依監視地址的位的狀態值來變化顯示內容。如同發光按鈕的功能效果一般，用來將觸控按鈕建立為發光按鈕。發光按鈕與按鈕的唯一區別是在發光按鈕的內容可反饋出對應PLC的位元狀態。
監視地址與寫入地址相同 |  | 如勾選『監視地址與寫入地址相同』，表示監視地址和“寫入地址”為同一讀取位置。當不勾選時亦可設不同位置。勾選此選項，不必重複輸入監視地址。當勾選監視後，即會出現此選項。
監視地址 | 監視地址 | 讀取PLC監視接點。 當地址種類為位，設定被監視的位地址。 當地址種類為字，設定字所包含的位的地址。 當地址種類為雙字，設定雙字所包含的位的地址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點擊此圖標，出現選取標籤對話框。選取所需的標籤。
 | 監視位編號 | 設定監視位編號。
壹巨集 |  | 勾選位按鈕是否需要壹巨集。在壹巨集頁可編輯巨集程式，當位按鈕的功能為設1、設1脈波、保持1和保持0，才會出現此選項。
零巨集 |  | 勾選位按鈕是否需要零巨集。在零集頁可編輯巨集程式，當位按鈕的功能為設0、設0脈波、保持1和保持0，才會出現此選項。
按鍵 |  | 操作位按鈕的按鍵。當選擇按鍵機型的人機時，才會出現此選項。
可觸控 |  | 當使用按鍵型人機介面控制位按鈕(ON/OFF)，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時（ 機型勾選使用外接鍵盤），才會出現此選項。


5.2 切換開關

切換開關

按壓切換開關可改變位的狀態。按一次，該按鈕接點設為ON，手放開仍為ON；再按一次OFF。表示觸摸此按鈕時會將寫入地址的位設為反相，例如原按壓前該地址的位為ON狀態時，則觸摸此按鈕時會將寫入地址的位設為OFF (放開按鈕時還是OFF)，反之如果原按壓前該地址的位(bit)為OFF狀態時，則觸摸此按鈕時會將寫入地址的位設為ON (放開按鈕時還是ON)。

切換開關和反相按鈕的功能差異點說明：

  1. 切換開關：工作方式是操作該物件時觸控屏先讀出該控制器信號位狀態，如為關狀態(Off=0)則切換該信號位為開狀態(就是寫入On=1)，反之如果該信號位狀態，如為開狀態(On=1)則切換該信號位為關狀態(就是寫入Off=0)。切換開關執行切換操作，是依監視位狀態，寫入反相的狀態。
  2. 反相按鈕：工作方式是操作該物件時 ，觸控屏先讀出觸控屏自己內部該信號位狀態，如為關狀態(Off=0)則切換該信號位為開狀態(就是寫入On=1)，反之如果該信號位狀態，如為開狀態(On=1)則切換該信號位為關狀態(就是寫入Off=0)。反相按鈕執行反相操作，是依目的位狀態直接轉換，與監視位無關。

反相按鈕指令沒有提供壹巨集與零巨集，如果您要使用巨集請改用切換開關。

切換開關所有的設定都可在屬性對話框中完成。切換開關的屬性對話框包含以下七個頁面，有些頁面在需要設定時才會顯現。

■ 一般頁
詳閱章節 5.1.4 .說明

■ 標示頁
 詳閱章節 4.3.5 .說明

■ 進階頁
詳閱章節 4.4.5 .說明

■ 顯現頁
詳閱章節 4.4.6 .說明

■ 外標示頁
 詳閱章節 4.3.8 .說明

■ 壹巨集頁
詳閱章節15.2.6 .說明

■ 零巨集頁
 詳閱章節15.2.6 .說明


5.2.1 切換開關 - 設定

切換開關 - 設定

所有切換開關的設定都可在屬性視窗中完成。切換開關的屬性視窗包含以下七個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節 5.1.4 .說明

■ 標示頁
 詳閱章節 4.3.5 .說明

■ 進階頁
詳閱章節 4.4.5 .說明

■ 顯現頁
詳閱章節 4.4.6 .說明

■ 外標示頁
 詳閱章節 4.3.8 .說明

■ 壹巨集頁
詳閱章節15.2.6 .說明

■ 零巨集頁
 詳閱章節15.2.6 .說明


5.2.2 切換開關 - 一般設定

切換開關 - 一般設定

本章節說明切換開關一般頁中各項屬性的設定。下圖是一般頁的圖例。

以上是切換開關屬性頁的一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定切換開關的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為TSnnnn。
註 |  | 可加入物件的說明文字。
外型 |  | 背景透明、圖片外型、 [image] 、觸摸視效、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 |  | 勾選切換開關是否需要外標示。外標示頁可設定各項屬性。
 |  | 點擊此處使切換開關為狀態1，可檢視和設定狀態1物件的外觀。
 |  | 點擊此處使切換開關為狀態0，可檢視和設定狀態0物件的外觀。
寫入地址 | 寫入地址 | 設定位變數的地址。
 |  | 點選此圖標，出現地址輸入鍵盤，輸入所需地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
監視位址與寫入位址相同 |  | 勾選監視位址是否與寫入位址相同。勾選此選項，不必重複輸入監視地址。當勾選監視後，即會出現此選項。
監視地址 | 監視地址 | 設定被監視的位地址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
壹巨集 |  | 勾選切換開關是否需要壹巨集。在壹巨集頁可編輯巨集指令。
零巨集 |  | 勾選切換開關是否需要零巨集。在零巨集頁可編輯巨集指令。
按鍵 |  | 操作切換開關的按鍵。當選擇按鍵機型的人機時，才會出現此選項。
可觸控 |  | 當使用按鍵型人機介面控制開關按鈕(ON/OFF)，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時（機型勾選使用外接鍵盤），才會出現此選項。


5.3 畫面按鈕

畫面按鈕

按壓畫面按鈕可開啟或關閉畫面。

所有畫面按鈕的設定都可在屬性視窗中完成。畫面按鈕的屬性視窗包含以下六個頁面，某些頁面在需要設定時才會出現。

■一般頁
詳閱章節5.3.4.說明

■標示頁
詳閱章節4.3.5.說明

■進階頁
詳閱章節4.4.5.說明

■顯現頁
詳閱章節4.4.6.說明

■外標示頁
詳閱章節4.3.8.說明

■巨集頁
詳閱章節15.2.6.說明


5.3.1 畫面按鈕 - 基本功能

畫面按鈕 - 基本功能

畫面按鈕可設置以下四種畫面切換的功能：

功能 | 說明
開啟畫面 | 開啟指定的畫面。按一次該按鈕，觸控屏直接切換到指定畫面。當所要切換的指定畫面為一個菜單畫面時，須設定此菜單視窗在 螢幕的出現位置。
開啟前一畫面 | 按一次該按鈕，觸控屏會切換回螢幕前一次顯示的畫面。 註：人機可顯示多個畫面，但只有一個為主畫面。人機最多可記住32個之前開啟的主畫面。
關閉和開啟畫面 | 按一次該按鈕，關掉當前視窗畫面並且開啟指定畫面。
關閉畫面 | 按一次該按鈕，觸控屏將關閉當前視窗畫面。


5.3.2 畫面按鈕 - 功能選項

畫面按鈕 - 功能選項

下表是畫面按鈕的功能選項，可使畫面按鈕的使用更安全、有效率。功能選項的設定可在屬性視窗中完成。

選項 | 說 明
改變使用者等級 | 觸摸此畫面按鈕可以同時改變目前的使用者等級(0~9)。勾選是否改變 使用者等級。
確認收到警報 | 畫面按鈕可以同時反饋收到警報告知(Alarm ACK.)。“確認警報”→ 表示觸控屏已經收到目前所發生的警報訊息。
改變按鈕顏色(交換背景與文字顏色)，表示指定畫面已經開啟 | 當觸控屏當前顯示的畫面就是畫面按鈕所指定要換的畫面時，將會自動改變按鈕顏色來對應。改變按鈕顏色，表示所要切換的畫面已經開啟，就會將按鈕背景色與文字顏色對換，表示換畫面動作已經完成了。
巨集 | 使用者可在一般頁中設定當觸壓畫面按鈕，同時執行巨集。巨集頁中編輯巨集指令。 註：在巨集 指令執行完畢之前，畫面切換不會執行。所以，儘可能縮短巨集長度，使畫面切換順利執行。
觸控有效 | 按觸控有效或觸控無效可由指定的位或當前 使用者等級控制。在進階頁中，可進行此選項的設定。
最少按壓時間 | 按鈕的觸控操作必須持續按壓一段時間(最少按壓時間)，才會執行操作。在進階頁中，可進行此選項的設定。操作者必須持續最少按住一段時間後，觸控屏才將該按鈕信號寫至PLC。
通知 | 換畫面的同時，當畫面切換完成後，可發送位(bit) on/off信號通知另一個指定的位。在進階頁中，可進行此選項的設定。
操作記錄 | 可勾選操作記錄選項，表示該操作事件會被觸控屏記錄在操作記錄器內存檔。在進階頁中，可進行此選項的設定。
不顯現 | 此畫面按鈕會隱藏顯示，但觸控操作仍有效。在顯現頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否可由指定的位或當前使用者等級控制。在顯現頁中，可進行此選項的設定。 在這裡可以設置是否控制本物件在畫面上的顯示與否，觸控物件可以有3個選項。 受位控制：例如：當$U100.2 的『顯現狀態』為指定的"1"或"0"時，此畫面按鈕才會顯示。 受使用者等級控制：當前登入的使用者等級高於或等於所設置的等級條件成立時，此畫面按鈕才會顯示。


5.3.3 畫面按鈕 - 設定

畫面按鈕 - 設定

所有畫面按鈕的設定都可在屬性視窗中完成。畫面按鈕的屬性視窗包含以下六個頁面，某些頁面在需要設定時才會出現。

■一般頁
詳閱章節5.3.4.說明

■標示頁
詳閱章節4.3.5.說明

■進階頁
詳閱章節4.4.5.說明

■顯現頁
詳閱章節4.4.6.說明

■外標示頁
詳閱章節4.3.8.說明

■巨集頁
詳閱章節15.2.6.說明


5.3.4 畫面按鈕 - 一般設定

畫面按鈕 - 一般設定

本章節說明畫面按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定畫面按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為SBnnnn。
註 |  | 可加入物件的說明文字。
外型 |  | 背景透明、圖片外型、 [image] 、觸摸視效、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 |  | 勾選畫面按鈕是否需要外標示。外標示頁可設定各項屬性。
功能 |  | 設定觸壓畫面按鈕時，所執行的功能。共有四種功能：開啟畫面、開啟前一個畫面、關閉和開啟畫面和關閉畫面。請參考章節 5.3.1 基本功能
畫面 |  | 設定開啟的畫面。
菜單視窗位置 |  | 共有以下六種菜單 視窗畫面位置。
 |  | 位置 | 說明
 |  | 螢幕左側 | 菜單水平地從畫面左邊移動進入畫面中。
 |  | 螢幕右側 | 菜單水平地從畫面右邊移動進入畫面中。
 |  | 從按鈕左側向下 | 菜單在按鈕左方，並向下移動進入畫面中。
 |  | 從按鈕左側向上 | 菜單在按鈕左方，並向上移動進入畫面中。
 |  | 從按鈕右側向下 | 菜單在按鈕右方，並向下移動進入畫面中。
 |  | 從按鈕右側向上 | 菜單在按鈕右方，並向上移動進入畫面中。
改變用戶等級 | <勾選框> | 勾選後表示此畫面按鈕可以同時改變當前用戶等級(0~9)。
 | 新用戶等級 | 新用戶等級取代舊用戶等級。
確認收到警報 |  | 勾選是否畫面按鈕確認收到警報。
改變按鈕顏色 |  | 勾選改變按鈕顏色表示顯示指定畫面已開啟。(交換背景與文字顏色)，表示指定畫面已開啟。
巨集 |  | 勾選畫面按鈕是否含有巨集。在巨集頁中可編輯巨集指令。
啟動功能(畫面) | 按下鍵時 | 當觸壓畫面按鈕時，立刻進行切換畫面操作。
 | 釋放鍵時 | 當觸摸此按鈕，必需放掉按鈕後，人機畫面才能換頁。 注意!! :實機操作時操作人員手按壓後，如果將手移出物件框後才放手，表示取消該操作。
按鍵 |  | 操作畫面按鈕的按鍵。當人機為按鍵機型的人機（機型勾選使用外接鍵盤），才會出現此選項。
可觸控 |  | 當使用按鍵型人機介面控制畫面按鈕，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時，才會出現此選項。


5.4 功能按鈕

功能按鈕

觸壓功能按鈕，可執行指定的功能。例如功能按鈕可用來將觸控螢幕建立為觸控“登入”鍵、寫出配方命令或是確認警報等。

■ 一般頁
詳閱 章節5.4.4 .說明

■ 標示頁
詳閱章節 4.3.5.說明

■ 進階頁
詳閱章節 4.4.5.說明

■ 顯現頁
詳閱章節 4.4.6.說明

■ 巨集頁
詳閱章節 15.2.6.說明


5.4.1 功能按鈕 - 基本功能

功能按鈕 - 基本功能

功能按鈕，可執行下述的特定功能。

類別 | 功能 | 說明
人機系統設定 | 增加顯示亮度 | 按此按鈕，觸控屏液晶螢幕的亮度或對比會增加。
 | 減少顯示亮度 | 按此按鈕，觸控屏液晶螢幕的亮度或對比會減少。
 | 儲存顯示亮度 | 按此按鈕，儲存亮度或對比的設定。
 | 進入觸控屏設置模式 | 結束人機應用，進入觸控屏設置模式。
 | 開始穿透通訊 | 開始穿透通訊。
 | 結束穿透通訊 | 結束穿透通訊。
 | 設置時間與日期 | 顯示時間與日期的設定。
 | 關背燈 | 觸壓按鈕關掉背燈，再觸壓螢幕則可開啟背燈。
 | 關閉嗶聲響應 | 關閉觸控屏操作時『蜂鳴器發出聲響』的功能。
 | 開啟嗶聲響應 | 開啟觸控屏操作時『蜂鳴器發出聲響』的功能。
 | 格式化內建快閃碟 | 格式化內建快閃碟(C 碟)，此動作需要 使用者等級8或其以上使用者等級執行。
 | 校正觸摸面板 | 不須進入人機設置畫面(Panel Setup)，即可校正觸摸面板。
人機操作設定 | 登入 | 按一次該按鈕，觸控屏就顯示輸入密碼的鍵盤，讓你登入使用者等級。在此輸入有效密碼登入後，可改變使用者等級。
 | 登出 | 按一次該按鈕，觸控屏就登出密碼使用者。觸控屏系統登出後就切換為密碼最低等級=0， 使用者等級變為0。
 | 顯示密碼表 | 按一次該按鈕，觸控屏就會顯示密碼表視窗，並且可以修改密碼。顯示密碼表，可用來改變使用者密碼。密碼表只會顯示低於或等於當前 使用者等級的密碼。
 | 確認警報 | 確認畫面的警報。按一次該按鈕，表示觸控屏已經回應當前所發生的警報要求確認訊息，只有當觸控屏已經確認警報後 ，才能繼續物件的正常操作。
 | 改變語言 | 改變當前的語言。
 | 選擇檔案夾 | 顯示檔案夾選擇對話框， 將所選擇的資料夾路徑儲存至路徑名存放區。
 | 選擇檔案 | 顯示選擇檔案的功能選項 顯示選擇檔案的功能選項，共有以下九個：
 |  | 功能 | 說明
 |  | 開啟(讀取數據) | 開啟指定的檔案讀取數據。該檔案必須已經存在。(註)關於『檔案讀寫控制塊』的設置，請見 章節 5.4.4 功能按鈕- 檔案讀寫控制塊 的說明。
 |  | 開啟(讀取CSV檔案) | 開啟指定的CSV檔案讀取數據。該檔案必須已經存在。(註)關於『檔案讀寫控制塊』的設置，請見 章節 5.4.4 功能按鈕- 檔案讀寫控制塊 的說明。
 |  | 開啟(寫入數據) | 開啟指定的檔案 寫入數據。當該檔案不存在時，會建立一個新檔案。當該檔案已存在時，它將被覆蓋。(註)關於『檔案讀寫控制塊』的設置，請見 章節 5.4.4 功能按鈕- 檔案讀寫控制塊 的說明。
 |  | 開啟(添加數據) | 開啟指定的檔案添加數據。當指定的檔案不存在時，會建立一個新檔案。(註) 關於『檔案讀寫控制塊』的設置，請見 章節 5.4.4 功能按鈕- 檔案讀寫控制塊 的說明。
 |  | 刪除 | 刪除指定的檔案。
 |  | 更名 | 更改指定檔案的檔名。
 |  | 取得檔案路徑名供寫檔案使用 | 取得指定檔案的完整路徑名稱供寫入檔案使用，指定的記憶區是用來存放選取檔案完整路徑名的位元組陣列。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 |  | 取得檔案路徑名供讀檔案使用 | 取得指定檔案的完整路徑名稱供讀取檔案使用，指定的記憶區是用來存放選取檔案完整路徑名的位元組陣列。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 |  | 取得檔案路徑名供刪除檔案使用 | 取得指定檔案的完整路徑名稱供刪除檔案使用，指定的記憶區是用來存放選取檔案完整路徑名的位元組陣列。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 |  | 輸入檔案延伸名可以縮小選擇檔案所列出的檔案範圍。檔案延伸名須為ASCII文字，最多3個 。 註：使用者必須設定 『檔案讀寫控制塊位址』，檔案讀寫控制塊位址是一個內部記憶區，可接收檔案開啟操作的結果。 使用者可設定當指定的檔案開啟時，執行巨集程式。當關閉檔案時，須先執行"CLOSE_FILE"指令，否則檔案內的資料將會遺失。
儲存數據到檔案 | 儲存配方數據到檔案 (.TXT) | 儲存指定的配方數據為.TXT檔。該檔案可被任何txt檔編輯器、Excel和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存配方數據到檔案 (.prd) | 儲存指定的配方數據為.prd檔。該檔案可被配方編輯器和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存歷史數據到檔案 (.TXT) | 儲存指定的歷史數據為.TXT檔。該檔案可被任何txt檔編輯器、Excel和人機讀取 。
 | 儲存歷史數據到檔案(.ldf) | 將歷史取樣資料複製到 USB 存檔，儲存指定的歷史數據為.ldf檔。該檔案只可被人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存警報記錄到檔案 | 儲存警報記錄為.TXT或.CSV格式檔案。該檔案可被任何文書編輯器、Excel和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存警報計數到檔案 | 儲存警報計數為.TXT或.CSV格式檔案。該檔案可被任何文書編輯器、Excel和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存操作記錄至檔案 | 儲存操作記錄為.TXT或.CSV格式檔。該檔案可被任何文書編輯器、Excel和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存曲線圖數據到檔案 | 儲存曲線圖數據到檔案，儲存曲線圖數據為.TXT或.CSV格式檔。該檔案可被任何文書編輯器、Excel和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 儲存二維分佈圖數據到檔案 | 儲存二維分佈圖數據到檔案，儲存二維分佈圖數據為.TXT或.CSV格式檔。該檔案可被任何文書編輯器、Excel和人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 複製人機應用規劃數據到檔案 | 儲存人機應用規劃資料檔為.plf檔案。該檔案可被軟體開啟，用於重新規劃人機畫面。 注意: 要操作此功能，需要原先人機應用規劃資料檔已經下載到人機才能執行。
 | 複製系統程式及運行數據到檔案 | 儲存系統程式及運行數據為.prp檔。該檔案只可被人機讀取。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『存檔路徑』與『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 安全取出微SD卡 | 為了確保使用者從人機介面取出微SD卡之前，所有的檔案操作均已完成，建議使用者執行功能按鈕"安全取出微SD卡"。 當畫面出現“可以安全取出微 SD 卡”視窗 後，再取出微SD卡。
 | 安全取出隨身碟 | 為了確保使用者從人機介面取出隨身碟之前，所有的檔案操作均已完成，建議使用者執行功能按鈕"安全取出隨身碟"。當畫面出現“可以安全取出隨身碟”視窗 後，再取出隨身碟。
檔案讀取數據 | 讀取配方數據檔案 | 從.PRD檔讀取配方數據並更新到人機。當勾選『檔案名由路徑存放區指定』選項，可藉由變更『路徑名存放區』記憶區內的字串，達成變更『讀檔路徑』與不同『檔案名稱』的目的。關於『路徑名存放區』的設置，請見 章節 5.4.4 功能按鈕-路徑名存放區 的說明。
 | 讀取配方數據檔案(.prd) |
 | 讀取歷史數據檔案（CSV、TXT） | 從USB碟讀取. CSV或.TXT檔案數據。
 | 讀取歷史數據檔案(.ldf) | 從USB碟讀取.ldf檔案數據。
 | 讀取曲線圖數據檔案 | 從USB碟讀取曲線圖數據，繪成曲線圖。
 | 讀取二維分佈圖數據檔案 | 從USB碟讀取二維分佈圖數據，繪成二維分佈圖。
 | 讀取警報記錄檔案 | 從USB碟讀取. CSV或.TXT檔案警報記錄檔案。
資料轉移 | 寫出配方到PLC | 寫出當前配方(當前配方區和配方數)，到指定的PLC。PLC和寫出地址在配方區屬性視窗中設定。
 | 從PLC讀取配方 | 從PLC讀取配方，來更新當前配方(當前配方區和配方數)。PLC和讀取地址在配方區中設定。
 | 儲存整區配方數據到快閃記憶體 | 儲存整區配方數據(停電保持記憶體)到人機的快閃記憶體。 注意：要操作此一功能，需要先必須勾選配方區中“須要快閃記憶體空間儲存數據備份”的選項，此功能才有效。
 | 讀取整區配方數據 (從快閃記憶體讀取) | 從人機的快閃記憶體中，讀取整區配方資料。 注意：要操作此一功能，需要先必須勾選配方區中“須要快閃記憶體空間儲存數據備份”的選項，此功能才有效。
列印畫面 | 列印畫面 | 觸壓功能按鈕後列印畫面。列印的區域為畫面屬性中所設定的區域(HARDCOPY方式)。
 | 列印畫面到檔案(256色) | 觸壓功能按鈕後列印畫面為256色的bmp檔。列印的區域為畫面屬性中所設定的區域。
 | 列印畫面到檔案(64K色) | 觸壓功能按鈕後列印畫面為64K色的bmp檔。列印的區域為畫面屬性中所設定的區域。
 | 列印畫面到檔案(.bmp) | 觸壓功能按鈕後列印畫面為bmp檔。解析度與人機的顯示器相同。列印的區域為畫面屬性中所設定的區域。
 | 列印畫面到檔案(.ipg) | 觸壓功能按鈕後列印畫面為jpg檔。列印的區域為畫面屬性中所設定的區域。
清除數據 | 清除歷史數據 | 清除指定的歷史數據區。
 | 清除全部歷史數據 | 清除全部的歷史數據。
 | 清除警報歷史 | 清除警報歷史。
 | 清除警報計數 | 清除警報計數。重置警報計數為0。
 | 清除操作記錄 | 清除操作記錄。
人機操作 | 重新運行人機應用 | 重新運行人機應用。
 | 使用.prp檔案更新作業系統及應用 | 從prp檔更新作業系統及應用，原始的程式和人機運行資料將會被新的 應用取代。可從 USB 碟或MicroSD卡更新應用，並且執行更新後新的觸控屏應用程式 。
 | 停止運行 | 停止運行應用程序。
 | 安全停機 | 功能按鈕支援一個名為“安全停機”的新操作。操作者關閉電源之前可以啟動這種功能按鈕並且保證與所使用非掉電保持性存放裝置的所有操作都安全地完成存儲資料，停止人機操作。詳細說明請參考章節 3.1.5 避免資料由於隨便關機而損壞 。
 | 載入並執行檔案內的作業系統及應用 | 從.prp檔載入和執行系統和人機應用程式。原始的資料和程式不會更新，載入的資料和程式在關機後消失。從 USB 碟或MicroSD卡暫時單次執行應用程式(並不會更新觸控屏程式)。
多媒體 | 多媒體 | 播放指定的聲音檔。
 | 停止聲音 | 停止播放當前的聲音檔 。
 | 照相 | 從指定的USB攝影機拍攝照片。
 | 選擇視訊 | 選擇一個指定的視訊通道編號ID。
 | 觀看視訊 | 觀看關聯的攝影機視訊內容。
 | 凍結視訊 | 凍結視訊顯示的影像。
 | 儲存凍結的視訊 | 將所凍結的視訊影像 ，儲存為jpg圖片檔案
 | 讀取JPEG圖片 | 經由功能按鈕讀取JPEG圖片，並顯示在其關聯的圖片顯示器，圖片顯示器的狀態類別須設定“顯示一個由關聯的功能按鈕載入的圖片”。
調整物件大小 | 放大 | 縮小關聯物件的觀看範圍為原來的一半，放大物件的內容。
 | 縮小 | 放大關聯物件的檢視範圍為原來的兩倍，縮小物件的內容。
 | 恢復原狀 | 恢復歷史曲線圖物件為原來的大小。
 | 放大或縮小達成完全顯示 | 自動放大或縮小關聯物件圖示，將所有收集到的數據， 都顯示到其區域中， 例如歷史趨勢圖。
捲動目錄 | 捲動向左 | 向左捲動關聯物件的內容。
 | 捲動向右 | 向右捲動關聯物件的內容。
 | 捲動向上 | 向上捲動關聯物件的內容。
 | 捲動向下 | 向下捲動關聯物件的內容。
 | 捲動頁向左 | 向左捲動一頁關聯物件的內容。
 | 捲動頁向右 | 向右捲動一頁關聯物件的內容。
 | 捲動頁向上 | 向上捲動一頁關聯物件的內容。
 | 捲動頁向下 | 向下捲動一頁關聯物件的內容。
 | 捲動水平到頭(開頭) | 水平捲動關聯物件的內容到開頭。
 | 捲動水平到底(結尾) | 水平捲動關聯物件的內容到結尾。
 | 捲動垂直到底(結尾) | 垂直捲動關聯物件的內容到結尾。
 | 捲動垂直到頭(開頭) | 垂直捲動關聯物件的內容到開頭。
改變數據 | 選擇日期 | 指定關聯物件對象日期 ，並顯示其日期對應數據。
 | 選擇日期和時間 | 指定關聯物件對象日期和時間 ，並顯示其日期和時間對應數據。
 | 選擇下一數據輸入物件 | 觸壓功能按鈕後，選擇下一數據輸入物件。
 | 選擇前一數據輸入物件 | 觸壓功能按鈕後，選擇前一數據輸入物件。
 | 現值加一 | 啟動選定的數值物件，觸壓功能鍵會增加現值一，以此調整數值至所需大小。多態按鈕需將啟動選項設定為間接，數值輸入需將數據輸入設為常駐式鍵盤或功能鍵。
 | 現值減一 | 啟動選定的數值物件，觸壓功能鍵會減少現值一，以此調整數值至所需大小。多態按鈕需將啟動選項設定為間接，數值輸入需將數據輸入設為常駐式鍵盤或功能鍵。
檔案操作 | 複製檔案 | 複製檔案功能按鈕支援： 1)複製所選擇的單 一檔案，需預先指定檔案延伸名。 2)複製所選擇的檔案夾底下，全部的指定延伸名檔案，需預先指定檔案延伸名。 運行時選擇執行第1項或第 2 項。
 | 刪除檔案 | 刪除檔案功能按鈕支援： 1)刪除所選擇的單 一檔案，需預先指定檔案延伸名。 2)刪除所選擇的檔案夾底下，全部的指定延伸名檔案，需預先指定檔案延伸名。 運行時選擇執行第1項或第 2 項。
 | 新增檔案夾 | 建立一個新檔案夾。
工具 | 執行.EXE程式 | 執行.EXE程式
 | 計算器 | 執行一個簡易的計算器。


5.4.2 功能按鈕 - 功能選項

功能按鈕 - 功能選項

下表是功能按鈕的功能選項，可使功能按鈕的使用更安全、有效率。功能選項的設定可在屬性視窗中完成。

選項 | 說明
巨集 | 當檔案開啟時，執行指定巨集 指令，在一般頁選擇此選項，在巨集頁中可編輯巨集指令。
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
最少按壓時間 | 觸控操作在按鈕持續按壓一段時間(最少按壓時間)，才會啟動。在進階頁中選擇和設定此選項。
最少按壓時間 | 當觸壓此按鈕時，會出現確認視窗。當使用者選"是"，則會執行功能按鈕的操作；當 使用者選"否"，或在最大等待時間內沒有回應，則停止功能按鈕操作。在進階頁中，可進行此選項的設定。
通知 | 當觸壓此按鈕時，功能按鈕操作完成後，可發送信號通知一個指定的位。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，按鈕的操作將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
改變用戶等級 | 當操作這一按鈕時，會改變當前用戶等級(可更改等級為0~9級)。在進階頁中，可進行此選項的設定。
不顯現 | 按鈕會隱藏顯示，但觸控操作仍有效。在顯現頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.4.3 功能按鈕 - 設定

功能按鈕 - 設定

所有功能按鈕的設定都可在屬性視窗中完成。功能按鈕的屬性視窗包含以下五個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
詳閱章節5.4.4 .說明

■ 標示頁(Label)
詳閱章節 4.3.5.說明

■ 進階頁(Advanced)
詳閱章節 4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節 4.4.6.說明

■ 巨集頁(Macro)
詳閱章節 15.2.6.說明


5.4.4 功能按鈕 - 一般設定

功能按鈕 - 一般設定

本章節說明功能按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

上面是功能按鈕對話框一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 |  | 屬性
編號 |  | 設定功能按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為FBnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 背景透明、圖片外型、 [image] 、觸摸視效、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考 章節 4.3.4 設定物件外 型 。
外標示 |  | 勾選功能按鈕是否需要外標示。外標示頁可設定各項屬性。
功能 |  | 設定功能按鈕要執行的功能。參考章節 5.4.1 基本功能。
檔案延伸名 |  | 指定的檔案延伸名。
用於指定文件的路徑名記憶區 |  | 如果你需要完整的路徑名或檔案名用於檔案操作，請使用此選項。
編號、目的或語言 | 關聯物件編號 | 與選擇功能關聯物件的ID編號。
 | 數據收集器 | 與選擇功能相關聯物件的ID編號。
 | 關聯物件編號 | 與選擇功能關聯曲線圖的ID編號。
 | 配方區 | 與選擇功能關聯配方區的ID編號。
 | 二維分佈圖 | 與選擇功能關聯二維分佈圖的ID編號。
 | 目的 | 儲存檔案功能的目的選項。
 | 語言 | 改變語言功能的語言選項。
 | 聲音 | 播放聲音功能聲音的ID編號。
 | 鏡頭編號和照片種類 | 照相功能鏡頭編號和照片的種類。
 | 關聯的攝影機觀看物件編號 | 選擇所觀看的攝影機物件編號。
 | 關聯 的圖片顯示器物件編號 | 選擇所要操作的圖片顯示器物件編號。
 | 視訊通道編號 | 選擇攝影機要觀看的視訊通道編號。
 | 目標 | 選擇你要執行複製或刪除的檔案。
 | 删除 | 選擇你要執行刪除的警報歷史記錄。
預設檔案名稱、檔案延伸名或方式 | 預設檔案名稱 | 設定功能的預設檔案名稱，檔名須為ASCII文字，最多80個文字。
 | 檔案延伸名 | 設定功能的檔案延伸名，檔名須為ASCII文字，最多3個文字。
 | 播放次數 | 播放聲音設定，指定您要播放的聲音次數。
可另選檔案名 |  | 當觸壓功能按鈕時，出現選擇檔案視窗。選擇的檔案將用在指定的功能。
檔案緩衝區編號 |  | 選擇一個檔案緩衝區編號，儲存所讀取的數據或警報檔案。
檔案緩衝區大小(記錄筆數) |  | 選擇檔案緩衝區大小儲存指定的數據記錄。
列表方式 |  | 選擇『每行一筆』或『每列一筆』的格式來儲存歷史數據。
檔案讀寫控制塊位址 | <地址輸入區> | 設定內部變數，接收檔案開啟操作的結果。記憶區塊需要45個字 的空間。
 |  | 字 | 說明
 |  | 0 , 1 | 存放『檔案指揮代碼』，32位不帶正負號的整數。 當執行失敗時，檔案指揮代碼等於零。當執行成功時，由系統自動產生一組非0的32位不帶正負號的整數。
 |  | 2 , 3 | 存放開啟檔案的大小(單位為位元組)，32位不帶正負號的整數。 一個新創建的檔案其大小等於零。
 |  | 4 - 44 | 存放檔案名稱和延伸檔名的位元組陣列；檔名和延伸檔名的長度，最大值為80字元。 檔案名稱是一個包含零結束字元的字串，它在文件成功打開時被賦值。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
路徑名存放區 | <輸入框> | 輸入指定的 『檔案路徑名 』存放的內部記憶區地址，指定的內部記憶區是用來存放自訂的檔案名或完整的路徑名的位元組陣列，檔案名及路徑只能是由ASCII碼組成的內部有效路徑，最大長度為127個位元組。所有檔的路徑 與資料夾必須已經事先存在，否則操作將會失敗。例如：$U100="C:\Files\alarm.csv"。 。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
 | 存放區大小 | 設定字元/位元元組的存放區大小 ，單位是字元/位元組。路徑名最多只能有127個字元/位元組。預設大小為48個字元/位元組。
播放聲音 |  | 設定播放聲音的次數（1 ∼ 10 次）。
播放的間隔時間(秒) |  | 當設定播放次數在 3 次以上，可設定聲音播放的間隔時間 ，單位為秒。（0s, 0.2s, 0.4s, 0.6s, 0.8s, 1s, 2s, 3s, 4s, 5s）
巨集 |  | 勾選此選項，設定功能按鈕 執行時是否包含巨集，在巨集頁面中可編輯巨集指令。此選項只在『選擇檔案』選項時出現。
按鍵 |  | 操作功能按鈕的按鍵。當人機有機械式按鍵時（機型設置使用外接鍵盤），才會出現此選項。
可觸控 |  | 當使用按鍵型人機介面控制功能按鈕，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時，才會出現此選項。


5.5 滑動類比開關

滑動類比開關

觸摸且持續壓住此按鈕之滑桿區域，然後操作者就可以在該物件範圍區域內左右或上下移動滑桿到另一位置然後放開，觸控屏就會依據操作者放開時手所在之位置所相對的數值，將其數值寫入PLC對應之暫存器，其功能如同一種模擬量輸入開關，對於調整馬達速度、轉速、計時時間、物件顏色等的調機操作是十分好用的。當實際在觸控屏操作滑動開關時，當前值(Current value display supported)會自動顯示在物件上方，這貼心好用的小顯示效果十分方便操作人員操控。

所有滑動類比開關的設定都可在屬性視窗中完成。屬性視窗包含以下五個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
 詳閱章節 5.5.4.說明。

■ 刻度頁(Scale)
 詳閱章節 4.4.4 說明。

■ 進階頁(Advanced)
 詳閱章節 4.4.5.說明。

■ 顯現頁(Visibility)
 詳閱章節 4.4.6.說明。

■ 外標示頁(External Label)
 詳閱章節 4.3.8.說明。


5.5.1 滑動類比開關 - 基本功能

滑動類比開關 - 基本功能

上圖是兩個滑動類比開關的範例。右邊是滑動類比開關的指標被觸壓的圖例。

用戶可設定滑動類比開關所控制的變數、變數的最大值和最小值。變數的數值、最大值和最小值決定指標的位置。移動指標選擇所需的數值，當按住指標時，當前選擇的數值會顯示在上方。當放開指標，數值將會寫入指定的地址。

設定滑動類比開關指標滑動的方向。

方向 | 說明
向上 | 指標垂直移動。當變數數值大於等於最大值，指標會停在最上端。當變數數值小於等於最小值，指標會停在最底端。當變數數值介於最大值和最小值之間，指標會在頂端和底端之間，符合比例的位置。
向下 | 指標垂直移動。當變數數值大於等於最大值，指標會停在最下端。當變數數值小於等於最小值，指標會停在最頂端。當變數數值介於最大值和最小值之間，指標會在頂端和底端之間，符合比例的位置。
向左 | 指標水平移動。當變數數值大於等於最大值，指標會停在最左端。當變數數值小於等於最小值，指標會停在最右端。當變數數值介於最大值和最小值之間，指標會在左端和右端之間，符合比例的位置。
向右 | 指標水平移動。當變數數值大於等於最大值，指標會停在最右端。當變數數值小於等於最小值，指標會停在最左端。當變數數值介於最大值和最小值之間，指標會在左端和右端之間，符合比例的位置。


5.5.2 滑動類比開關 - 功能選項

滑動類比開關 - 功能選項

下表是滑動類比開關中可增加的功能選項，可使滑動類比開關的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
刻度 | 刻度欄可設計滑動開關操作時的相關數值刻度標示。設定滑動類比開關是否顯示刻度。刻度頁中可進行此選項的設定。
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
通知 | 當觸壓此按鈕時，滑動類比開關操作完成後，可發送信號通知一個指定的位。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，指定變數的改變將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.5.3 滑動類比開關 - 設定

滑動類比開關 - 設定

所有滑動類比開關的設定都可在屬性視窗中完成。屬性視窗包含以下五個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
 詳閱章節 5.5.4.說明。

■ 刻度頁(Scale)
 詳閱章節 4.4.4 說明。

■ 進階頁(Advanced)
 詳閱章節 4.4.5.說明。

■ 顯現頁(Visibility)
 詳閱章節 4.4.6.說明。

■ 外標示頁(External Label)
 詳閱章節 4.3.8.說明。


5.5.4 滑動類比開關 - 一般設定

滑動類比開關 - 一般設定

本章節說明滑動類比開關一般頁中各項屬性的設定。下圖是一般頁的範例。

以上是滑動開關對話框一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定滑動類比開關的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為SWnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 有關 [image] 、邊框色、背景色的詳細說明，請參考 章節4.3.4 設定物件外型。
外標示 |  | 勾選滑動類比開關是否需要外標示。外標示頁可設定各項屬性。
方向 |  | 設定滑動類比開關數值遞增的方向。詳細說明，請參考章節 5.5.1 基本功能。
數據類別 |  | 由物件所控制變數的數據類別。
寫入地址 | 寫入地址 | 設定由物件所控制變數的位址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
動態範圍 | 動態範圍 | 勾選在運行時，是否可更改變數的最大值和最小值。當勾選此選項，刻度記號的最大值和最小值在運行時也可隨時改變。在動態範圍參數區中，必須正確地設定最大最小值範圍的數據。動態範圍參數區欄中需設定動態範圍參數區的地址。
 | 動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區。點擊 [image] 輸入地址，點擊 [image] 選取標籤。 下表顯示當數據類別是16位數，滑動類比開關的刻度不是動態的，參數區的數據設置。
 |  | 字 | 參數
 |  | 0 | 變數的最小值。
 |  | 1 | 變數的最大值。
 |  | 下表顯示當數據類別是16位數，滑動類比開關的刻度是動態的，參數區的數據設置。
 |  | 字 | 參數
 |  | 0 | 變數的最小值。
 |  | 1 | 變數的最大值。
 |  | 2, 3 | 刻度記號的最小值；32位整數。
 |  | 4, 5 | 刻度記號的最大值；32位整數。
 |  | 下表顯示當數據類別是32位數，滑動類比開關的刻度不是動態的，參數區的數據設置。
 |  | 字 | 參數
 |  | 0, 1 | 變數的最小值。
 |  | 2, 3 | 變數的最大值。
 |  | 下表顯示當數據類別是32位數，滑動類比開關的刻度是動態的，參數區的數據設置。
 |  | 字 | 參數
 |  | 0, 1 | 變數的最小值。
 |  | 2, 3 | 變數的最大值。
 |  | 4, 5 | 刻度記號的最小值；32位整數。
 |  | 6, 7 | 刻度記號的最大值；32位整數。
最小值 |  | 變數的最小值。
最大值 |  | 變數的最大值。
指標 | 邊框色 | 在此指定滑動按鈕指標的邊框的顏色。
 | 背景色 | 在此指定滑動按鈕指標的背景色。
指標按下時顯示當前指標位置對應的數值 |  | 勾選此選項，移動滑塊指標時，會顯示其當前位置所對應的數值。


5.6 字按鈕

字按鈕

觸壓字按鈕設定指定變數的數值。

■ 一般頁(General)
詳閱章節5.6.4.說明

■ 標示頁(Label)
詳閱章節4.3.5.說明

■ 進階頁(Advanced)
詳閱章節4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 外標示頁(ExternalLabel)
詳閱章節4.3.8.說明


5.6.1 字按鈕 - 基本功能

字按鈕 - 基本功能

下表為字按鈕可以設置的功能選項。有5個選項。

功能 | 說明
設常數 | 觸摸啟動此按鈕，觸控屏馬上就送出指定的常數值給PLC相對應之暫存器。在指定的地址，寫入指定的常數。
輸入數值 | 觸壓按鈕後，可輸入數值改變指定變數。當觸壓按鍵，觸控屏就先顯示系統內建的數值輸入鍵盤在螢幕上，您可輸入數值。在輸入數值之後，系統會檢查數值是否介於最大值和最小值之間。如果輸入數值是有效的，觸控屏就送出數值給PLC相對應之指定變數。如果輸入數值是無效的，則必須重新輸入數值或停止操作。
輸入密碼 | 觸摸此按鈕，觸控屏就顯示輸入密碼的鍵盤視窗。可輸入數值寫入指定變數，輸入的數值會以星號表示，其他人無法知道輸入的數值。當觸壓按鍵，出現數字鍵盤。 在輸入數值之後，系統會檢查數值是否介於最大值和最小值之間。如果輸入數值是有效的，則數值寫入指定變數。如果輸入數值是無效的，則必須重新輸入數值或停止操作。
加 | 觸摸此按鈕，觸控屏先從PLC讀取暫存器的內容值並加上所設數值，再將運算結果寫至PLC相對應之暫存器。增加指定變數的數值。如果增加後數值超過最大值，則變數的數值設為最大值。
減 | 觸摸此按鈕，觸控屏先從PLC讀取暫存器的內容值並減去所設數值，再將運算結果寫至PLC相對應之暫存器。減少指定變數的常數值。如果減少後數值少於最小值，則變數的數值設為最小值。


5.6.2 字按鈕 - 功能選項

字按鈕 - 功能選項

下表是字按鈕中可增加的功能選項，可使字按鈕的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
最少按壓時間 | 按鈕的觸控操作必須持續按壓一段時間(最少按壓時間)，才會執行操作。在進階頁中，可進行此選項的設定。
操作員確認 | 當觸壓此按鈕時，會出現確認視窗。當使用者選"是"， 才會執行字按鈕的操作；當使用者選"否"，或在最大等待時間內沒有回應，則停止字按鈕操作。在進階頁中，可進行此選項的設定。 註：此選項在輸入密碼功能不會出現。
通知 | 當觸壓此按鈕時，字按鈕操作完成後，會發送信號通知一個指定的位。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，按鈕的操作將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
改變用戶等級 | 當操作這一按鈕時，會改變當前用戶等級(可更改等級為 0 ∼ 9 級)。在進階頁中，可進行此選項的設定。
指定鍵盤 | 勾選此選項，使用客制視窗畫面替代內建鍵盤，在進階頁中，可進行此選項的設定。
不顯現 | 按鈕會隱藏顯示，但觸控操作仍有效。在顯現頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.6.3 字按鈕 - 設定

字按鈕 - 設定

所有字按鈕的設定都可在屬性視窗中完成。字按鈕的屬性表包含以下五個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
 詳閱章節 5.6.4.說明

■ 標示頁(Label)
 詳閱章節 4.3.5.說明

■ 進階頁(Advanced)
 詳閱章節 4.4.5.說明

■ 顯現頁(Visibility)
 詳閱章節 4.4.6.說明

■ 外標示頁(External Label)
 詳閱章節 4.3.8.說明


5.6.4 字按鈕 - 一般設定

字按鈕 - 一般設定

本章節說明字按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定字按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為WBnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 背景透明、圖片外型、 [image] 、觸摸視效、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考 章節 4.3.4 物件外型設定。
外標示 |  | 勾選字按鈕是否需要外標示。外標示頁可設定各項屬性。
功能 |  | 設定字按鈕的功能。詳細說明章節 5.6.1 基本功能 。
數據類別 |  | 由物件所控制變數的數據類別。
寫入地址 | 寫入地址 | 設定由物件所控制變數的位址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
常數 |  | 指定功能的常數。
最小值 |  | 指定功能的最小值。
最大值 |  | 指定功能的最大值。
總位數 |  | 數字輸入鍵盤上最大值和最小值的總位數。
小數位數 |  | 當數據類別是32位浮點數，則此選項為設定最大值和最小值的小數位數。 當數據類別不是32位浮點數，則此選項除了為最大值和最小值的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。當小數位數為一個非0的數"N"，輸入的數值在輸出前將依以下的公式轉換為整數。輸出值=輸入值*(10的N次方)。 範例：
 |  | 數據類別 | 總位數 | 小數位數 | 輸入值 | 輸出值
 |  | 32位浮點數 | 4 | 2 | 12.34 | 12.34
 |  | 32位浮點數 | 4 | 2 | 123.4 | Error!
 |  | 16位正整數 | 5 | 2 | 123.45 | 12345
 |  | 16位正整數 | 5 | 2 | -0.05 | -5
 |  | 16位正整數 | 5 | 2 | 3 | 300
啟動功能 | 按下鍵時 | 選擇此選項，當按下按鈕時，啟動設定的功能；當選擇“按下鍵時”，表示當按壓該字按鈕就會馬上執行寫入動作。 注意：使用加/減_字按鈕，當選擇按下鍵時，如果按壓此按鈕不放時，則數值會一直會做累加/累減，直到釋放此按鈕，數值才會停止運算。
 | 釋放鍵時 | 當選擇“釋放鍵時”，表示當按壓字按鈕後，如果將手移出按鈕區域後手才彈起，則不會執行按壓動作。使用加/減_字按鈕，選擇釋放鍵時，則每按壓一次執行一次加/減數值。
巨集 | 使用 | 按鈕執行指定的 巨集指令，可進行此選項的設定。在巨集頁可編輯巨集指令。
 | 執行時機 | 選擇巨集指令執行的時機 ，可指定數值輸出前或輸出後執行。
按鍵 | 按鍵 | 操作字按鈕的按鍵。當人機有機械式按鍵時，才會出現此選項。
 | 可觸控 | 當使用按鍵型人機的按鍵來控制畫面上的按鈕或物件，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時，才會出現此選項。


5.7. 多態按鈕

多態按鈕

多態按鈕可用在將多個選項建立為2、3或4以上多個位置選擇式按鈕或清單式捲動按鈕，可用來改變指定變數的狀態。

所有多態按鈕的設定都可在屬性視窗中完成。屬性視窗包含以下六個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
詳閱章節5.7.4.說明

■ 文字頁(Text)
詳閱章節4.3.6.說明

■ 進階頁(Advanced)
詳閱章節4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 圖片頁(Picture)
詳閱章節4.3.7.說明

■ 外標示頁(ExternalLabel)
詳閱章節4.3.8.說明


5.7.1 多態按鈕 - 基本功能

多態按鈕 - 基本功能

分成按鈕、清單(表列式清單)、下拉式清單(表列式清單)、上拉式清單(表列式清單)等四種控制選擇方式：

預設情況下，列表框列出每行開關的一個狀態從狀態0開始的所有選項。當前狀態的文字會反白顯示。如果所需的狀態沒有顯示在按鈕選項中，您可以使用右側的捲動按鈕來顯示文字。當你觸摸它的文字來選擇所需的狀態時，開關將選中狀態的值寫到指定的變量，並關閉清單列表。

控制方式 | 說明
按鈕 | 按鈕控制方式的多態按鈕。觸摸此按鈕，觸控屏馬上先從PLC讀取暫存器的內容值並加/減數值1或左/右移 動1位元(bit)，再將運算結果寫至PLC相對應之暫存器，改變指定 變數地址的狀態至次一狀態。次一狀態未必是當前狀態加一。
清單 | 清單控制方式的多態按鈕。列出所有狀態的清單，每一行為一種狀態，從狀態0開始，如 下圖所示： 當前狀態將反白顯示。如果未看到所需狀態，可利用右邊的捲動條。選擇所需狀態後，選定的狀態將寫入指定的變數地址中。 當前狀態將反白顯示。如果未看到所需狀態，可利用右邊的捲動條。選擇所需狀態後，選定的狀態將寫入指定的變數地址中。 當勾選以『表列式清單』呈現，多態按鈕將會以縱向橫列表格顯示所有的狀態文字，從狀態0開始，如下圖所示： 當前狀態將反白顯示。 透過觸控的方式，選擇所需狀態後，選定的狀態將寫入到指定的變數地址中。
下拉式清單 | 多態按鈕的『下拉式清單』控制方式。顯示當前狀態和向下的箭頭符號，如下圖所示： 當觸壓按鈕，此按鈕切換成下拉式清單或表列式清單顯示，如下圖所示： 列出所有狀態的清單，每一行為一種狀態，從狀態0開始。當前狀態以反白表示。如果未看到所需狀態，可利用右邊的捲動條。選定所需狀態後，選定的狀態將寫入指定的 變數地址中，同時關閉清單。 當清單顯示時，如果要取消操作，則觸壓清單外其他地方即可。
上拉式清單 | 多態按鈕的上拉式清單控制方式，顯示當前狀態和向上的箭頭符號，如下圖所示： 當觸壓按鈕，此按鈕切換成上拉式清單或表列式清單顯示，如下圖所示： 列出所有狀態的清單，每一行為一種狀態，從狀態0開始。當前狀態以反白表示。如果未看到所需狀態，可利用右邊的捲動條。選定所需狀態後，選定的狀態將寫入指定的 變數地址中，同時關閉清單。 當清單顯示時，如果要取消操作，則觸壓清單外其他地方即可。


5.7.2 多態按鈕 -功能選項

多態按鈕 - 功能選項

下表是多態按鈕中可增加的功能選項，可使多態按鈕的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
最少按壓時間 | 按鈕的觸控操作必須持續按壓一段時間(最少按壓時間)，才會執行操作。在進階頁中，可進行此選項的設定。
通知 | 當觸壓此按鈕時，多態按鈕操作完成後，可發送信號通知一個指定的位。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，按鈕的操作將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
不顯現 | 會隱藏顯示，但觸控操作仍有效。在顯現頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.7.3 多態按鈕 - 設定

多態按鈕 - 設定

所有多態按鈕的設定都可在屬性對話框中完成。屬性對話框包含以下六個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
詳閱章節5.7.4.說明

■ 文字頁(Text)
詳閱章節4.3.6.說明

■ 進階頁(Advanced)
詳閱章節4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 圖片頁(Picture)
詳閱章節4.3.7.說明

■ 外標示頁(ExternalLabel)
詳閱章節4.3.8.說明


5.7.4 多態按鈕 - 一般設定

多態按鈕 - 一般設定

本章節說明多態按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定多態按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為MSnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 圖片外型、 [image] 、觸摸視效、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節 4.3.4 設定 物件外型。
外標示 |  | 勾選多態按鈕是否需要外標示。外標示頁可設定各項屬性。
狀態 |  | 設定多態按鈕的當前狀態。
狀態類別 |  | 監視變數的狀態種類。有兩個選項：數值和最低位(LSB)。 詳細說明，請參考章節 4.4.1.1 狀態 種類。
控制方式 |  | 設定多態按鈕的控制方式。有四個選項：按鈕、清單、下拉式清單和上拉式清單。當勾選『表列式清單』，所有狀態會以『文字表格』形式由左向右排列，『縱向列數』為設置表格縱列的數目，當勾選『表列式清單』，此選項才會出現。詳細說明，請參考章節 5.7.1 基本功能。
數據類別 |  | 設定變數的數據類別。
寫入地址 | 寫入地址 | 設定由物件所控制變數的位址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
總狀態數 |  | 設定總狀態數。註：當總狀態數是N，則其最後的狀態是N-1。 狀態類別設為數值時，總狀態數最大值為255。狀態類別設為最低位時，16位元正整數之總狀態數最大值為16。狀態類別設為最低位時，32位元正整數之總狀態數最大值為32。
次一狀態 |  | 當控制方式為按鈕時，設定計算次一狀態的方式。可設定多態按鈕下一狀態之順序為 “+” 或“-”。
 | +1 (繞回) | 若當前狀態為最後一個狀態，次一狀態為0。若不為最後一個狀態，則次一狀態為當前狀態加一。
 | -1 (繞回) | 若當前狀態為狀態0，則次一狀態為最後一個狀態。若不是狀態0，則次一狀態為當前狀態減一。
 | +1/-1 (退回) | 多態按鈕次一狀態的順序可能遞增或遞減。預設為遞增的模式。 假設總狀態數是N。當多態按鈕是遞增模式，若當前狀態非狀態N-1，則次一狀態為當前狀態加一。如果當前狀態為狀態N-1，則多態按鈕轉換模式為遞減模式。 當多態按鈕是遞減模式，若當前狀態非狀態0，則次一狀態為當前狀態減一。如果當前狀態為狀態0，則多態按鈕轉換模式為遞增模式。
 | +1 (保持) | +1（保持）：如果當前狀態不是最後的狀態，下一個狀態是當前狀態加一，如果當前狀態是最後的狀態，下一個狀態保持在最後的狀態。
 | -1 (保持) | -1（保持）：如果當前狀態不是狀態0，下一個狀態是當前狀態減一，如果當前狀態為狀態0，下一個狀態保持在狀態0。
啟動 |  | 當控制方式為按鈕時，設定多態按鈕如何啟動，分為直接啟動與間接啟動2種。
 | 直接 | 當觸壓按鈕後，啟動多態按鈕。
 | 間接 | 間接功能是透過同一畫面中的功能按鈕的“現值加1”及“現值減1”的功能來操控此多態按鈕。
監視位址與寫入位址相同 |  | 勾選監視位址是否與寫入位址相同。勾選此選項，不必重複輸入監視地址。當勾選監視後，即會出現此選項。
監視地址 | 監視地址 | 設定被監視位的地址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
按鍵 |  | 操作多態按鈕的按鍵。當人機有機械式按鍵時，才會出現此選項。
可觸控 |  | 當使用按鍵型人機按鍵來控制畫面上的按鈕或物件，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時，才會出現此選項。


5.8 單選按鈕

單選按鈕

一個單選按鈕物件有多個按鈕狀態，但每次只能選其中一個狀態對象操作，並將數據寫入PLC的對應值或對應位(Bit)。

下表是單選按鈕中可增加的功能選項，可使單選按鈕的使用更安全、有效率。選項的設定可在屬性視窗中完成。

■ 一般頁(General)
詳閱章節5.8.4.說明

■ 文字頁(Text)
詳閱章節4.3.6.說明

■ 圖片頁(Picture)
詳閱章節4.3.7.說明

■ 進階頁(Advanced)
詳閱章節4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 外標示頁(ExternalLabel)
詳閱章節4.3.8.說明


5.8.1 單選按鈕 - 基本功能

單選按鈕 - 基本功能

一個單選按鈕物件有多個按鈕狀態，但每次只能選其中一個狀態對象操作，並將數據寫入PLC的對應值或對應位(Bit)。選LSB格式的狀態數最多可達16或32個。選數值格式的狀態數最多可達255個。當選LSB 格式時每次只有其按壓的操作對應位會被設為開(On)，其餘非對應的位將會被設為關(Off)。允許自訂狀態值表示每一個狀態的寫入對應值可以各別單獨指定，不需要連續值。


5.8.2 單選按鈕 - 功能選項

單選按鈕 - 功能選項

下表是單選按鈕中可增加的功能選項，可使單選按鈕的使用更安全、有效率。選項的設定可在屬性 視窗中完成。

選項 | 說明
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
最少按壓時間 | 按鈕的觸控操作必須持續按壓一段時間(最少按壓時間)，才會執行操作。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，按鈕的操作將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.8.3 單選按鈕 - 設定

單選按鈕 - 設定

所有單選按鈕的設定都可在屬性視窗中完成。屬性視窗包含以下六個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
詳閱章節5.8.4.說明

■ 文字頁(Text)
詳閱章節4.3.6.說明

■ 圖片頁(Picture)
詳閱章節4.3.7.說明

■ 進階頁(Advanced)
詳閱章節4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 外標示頁(ExternalLabel)
詳閱章節4.3.8.說明


5.8.4 單選按鈕 - 一般設定

單選按鈕 - 一般設定

本章節說明單選按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定單選按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為RBnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 圖片外型、 [image] 、觸摸視效、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考 章節4.3.4 物件外型設定。
外標示 |  | 勾選單選按鈕是否需要外標示。外標示頁可設定各項屬性。
狀態 |  | 設定單選按鈕的當前狀態並調整狀態的外觀。 註：雖然可以設定狀態的外觀，但無法立即看到外觀隨設定改變。因為，按鈕強調當前狀態背景色和文字顏色。所以，改變當前狀態後，設定的外觀就會顯現。
狀態類別 |  | 狀態類別分為數值、最低位(LSB)、及允許自訂狀態值等3種型態。 變數的狀態類別，有三種類別：數值、最低位和自訂狀態列。 詳細說明，請參考 章節 4.4.1.1 狀態種類 。
狀態序 |  | 設定單選按鈕排序的順序與方向，有以下四種排序方式可供選擇：
 |  | 狀態序 | 說明
 |  | 從左到右 | 狀態0的按鈕從最左邊的位置開始，其餘狀態的按鈕依序向右排序。
 |  | 從右到左 | 狀態0的按鈕從最右邊的位置開始，其餘狀態的按鈕依序向左排序。
 |  | 從上到下 | 狀態0的按鈕從最上面的位置開始，其餘狀態的按鈕依序向下排序。
 |  | 從下到上 | 狀態0的按鈕從最下面的位置開始，其餘狀態的按鈕依序向上排序。
數據類別 |  | 變數的數據類別。
寫入地址 | 寫入地址 | 設定變數的地址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
狀態總數 |  | 設定狀態總數。狀態類別設為數值時，狀態總數最大值為255。狀態類別設為最低位時，16位元正整數之狀態總數最大值為16。狀態類別設為最低位時，32位元正整數之狀態總數最大值為32。
標示當前狀態 | 方式 | 選擇標示當前選中狀態按鈕的方式。可選擇用不同顏色顯示文字或使用圓形\方形標誌來標示當前狀態。
 | 背景色 | 當前狀態的背景色。
 | 文字/標誌 | 當前狀態的文字或標誌顏色。
按鈕間隔 |  | 相鄰2按鈕的間隔距離。
自訂狀態值 |  | 點選此按鈕自訂每一個狀態的狀態值。每一按鈕相對一個值讓設計者可以自由給值，例如 s0=23, s1=11, s2=234, s3=09, s4=400 ..等，而非只能依據狀態 0-n 強迫對應給值0-n。詳細說明，請參考章節 4.4.1.2 設定物件自訂狀態值 。


5.9 鍵盤按鈕

鍵盤按鈕

鍵盤按鈕可設為觸控的鍵盤鍵。鍵盤鍵可代表功能鍵、數字鍵、方向鍵、跳出鍵、清除鍵、輸入鍵、+/-鍵、小數點鍵、還有求助鍵(Help)。使用者可使用鍵盤按鈕自訂所需的鍵盤。

所有鍵盤按鈕的設定都可在屬性視窗中完成。屬性視窗包含以下四個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
詳閱章節5.9.3.說明

■ 標示頁(Label)
詳閱章節4.3.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 巨集頁(Macro)
詳閱章節15.2.6.說明


5.9.1 鍵盤按鈕 - 功能選項

鍵盤按鈕 - 功能選項

下表是鍵盤按鈕中可增加的功能選項，可使鍵盤按鈕的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
巨集 | 鍵盤按鈕也可以配合巨集程式 使用 。在巨集頁中，可進行此巨集的設定和編程。
顯現控制 | 鍵盤按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.9.2 鍵盤按鈕 - 設定

鍵盤按鈕 - 設定

所有鍵盤按鈕的設定都可在屬性視窗中完成。屬性視窗包含以下四個頁面，某些頁面在需要設定時才會出現。

■ 一般頁(General)
詳閱章節5.9.3.說明

■ 標示頁(Label)
詳閱章節4.3.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 巨集頁(Macro)
詳閱章節15.2.6.說明


5.9.3 鍵盤按鈕 - 一般設定

鍵盤按鈕 - 一般設定

本章節說明鍵盤按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定鍵盤按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為KBnnnn。
註 | 可加入說明文字。
外型 設置 | 背景透明、圖片外型、觸摸視效、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
輸入字母 | 勾選此選項，按壓按鈕後，輸入指定的字母到鍵盤緩衝區。
字符集 | 選擇以下三個字符集，選擇輸入字符編碼。
 | 字符集 | 說明
 | ASCII (美國) | 定義128個字符。
 | ISO-8859-1 (西歐) | 涵蓋大多西歐語言。
 | ISO-8859-5 (西里爾/拉斯夫) | 涵蓋使用西里爾字母語言，如保加利亞，白俄羅斯，俄羅斯，塞爾維亞和馬其頓。
字母 | 勾選輸入字母後，出現此選項，設定輸入鍵盤緩衝區的字母。
輸入指令 | 依照內定的命令功能執行命令動作。勾選此選項，按壓按鈕後，發送指定的指令到鍵盤緩衝區。
指令 | 勾選輸入指令後出現此選項，設定發送到鍵盤緩衝區的指令。有以下四種指令：
 | 指令 | 說明
 | 輸入 | 完成數據輸入，發送輸入的字串到關聯物件或系統。
 | 離開 | 取消數據輸入操作。
 | 清除 | 清除鍵盤緩衝區。
 | 後 退 | 移除鍵盤緩衝區最後一個字母。
 | 加一 | 使鍵盤輸入緩衝區（$S0〜$S25） 現值加1。
 | 減一 | 使鍵盤輸入緩衝區（$S0〜$S25）現值減1。
 | 無作用 | 人機界面發出請求控制器回應 ，不要求其他的任何動作。可以用這樣的命令，來確認通訊正常。
鍵盤 | 操作鍵盤按鈕的按鍵。當人機有機械式按鍵時，才會出現此選項。
可觸控 | 當使用按鍵型人機界面控制位按鈕(ON/OFF)，仍需讓觸控屏可操作時，勾選此選項。當選擇按鍵機型的人機時，才會出現此選項。
巨集 | 鍵盤按鈕可以支援巨集使用。勾選鍵盤按鈕是否包含巨集，在巨集頁中設定和編輯巨集程式。


5.9.4 建立客制鍵盤

建立客制鍵盤

使用者可使用鍵盤按鈕建立客制鍵盤，下圖為客制數值鍵盤的範例。

欲建立客制鍵盤，請依以下步驟：

  1. 建立視窗畫面，詳細說明，請參考章節3.9.2新建及開啟畫面 。
  2. 使用以下設定，建立字符顯示器，當按壓鍵盤按鈕，顯示關聯字元。

  3. 使用以下設定，建立字 符顯示器，顯示可輸入範圍。

  4. 使用鍵盤按鈕，建立客制鍵盤。
  5. 從人機應用一般設置客制頁中，設定使用客制鍵盤取代內建的鍵盤。詳細說明，請參考章節 3.1.2 客制設定。


5.10 捲動按鈕

捲動按鈕

觸壓捲動按鈕捲動關聯物件的顯示內容。對於有些資料庫顯示物件可設計此滾動按鈕組，此按鈕物件可針對歷史資料表單進行瀏覽捲動或暫停的操作，當觸控屏具有停電保持記憶體時更可以回復到停電前的記錄資料。

■ 一般頁(General)
詳閱章節5.10.4.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明


5.10.1 捲動按鈕 - 基本功能

捲動按鈕 - 基本功能

橫向按鈕排列的捲動按鈕，會有以下幾種按鈕：

按鈕 | 範例 | 說明
到尾 |  | 捲動物件的內容到最右端。
右一頁 |  | 向右捲動物件內容一頁。
向右 |  | 向右捲動物件內容。
向左 |  | 向左捲動物件內容。
左一頁 |  | 向左捲動物件內容一頁。
到頭 |  | 捲動物件的內容到最左端。
暫停 |  | 暫停按鈕是一個切換開關，當觸壓此按鈕，會暫停捲動操作，當再觸壓按鈕一次，回復捲動操作。注意:當”暫停”時，目前歷史資料之記錄還是繼續的執行取樣。

直向按鈕排列的捲動按鈕，會有以下幾種按鈕：

按鈕 | 範例 | 說明
到頭 |  | 捲動物件的內容到最上端。
上一頁 |  | 向上捲動物件內容一頁。
向上 |  | 向上捲動物件內容。
向下 |  | 向下捲動物件內容。
下一頁 |  | 向下捲動物件內容一頁。
到尾 |  | 捲動物件的內容到最下端。
暫停 |  | 暫停按鈕是一個切換開關，當觸壓此按鈕，會暫停捲動操作，當再觸壓按鈕一次，回復捲動操作。


5.10.2 捲動按鈕 - 功能選項

捲動按鈕 - 功能選項

下表是捲動按鈕中可增加的功能選項，可使捲動按鈕的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.10.3 捲動按鈕 - 設定

捲動按鈕 - 設定

所有捲動按鈕的設定都可在屬性視窗中完成。屬性對話框包含以下二個頁面。

■ 一般頁(General)
詳閱章節5.10.4.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明


5.10.4 捲動按鈕 - 一般設定

捲動按鈕 - 一般設定

本章節說明捲動按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定捲動按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為SBNnnnn。
註 |  | 可加入說明文字。
外型 |  | 、邊框色、背景色 、符號顏色的詳細說明，請參考章節 4.3.4 設定物件外型。
符號顏色 |  | 設定捲動按鈕的符號顏色。
按鈕排列 | 橫向 | 設定捲動按鈕為橫向排列。
 | 直向 | 設定捲動按鈕為直向排列。
關聯物件編號 |  | 設定捲動按鈕所 關聯捲動的物件的編號。可以從下拉式選單中選擇物件編號。
到頭/到尾 |  | 勾選捲動按鈕是否包含到頭/到尾按鈕( |< >| )的控制按鈕。。可將歷史資料之記錄頁移至最前頁或最尾頁的控制按鈕。
上一頁/下一頁 或 左一頁/右一頁 |  | 勾選捲動按鈕是否包含上一頁/下一頁或左一頁/右一頁( << >> )的控制按鈕。
上/下或 左/右 |  | 勾選這個選項，滾動按鈕組將會包括上/下或 左/右( < > )的控制按鈕。。
暫停 |  | 勾選捲動按鈕是否包含暫停按鈕。暫停選項如被設定，在捲動按鈕中將多一個暫停捲動的按鈕功能圖示。 注意：如果要清空或停止歷史資料之記錄，可以使用功能鍵中有支援"清除"目前歷史資料之記錄的控制按鈕，也可以使用控制區的觸發信號或致能信號來執行這些功能。
按鈕間隔 |  | 設定兩相鄰按鈕間的間隔距離(單位為像素)。


5.11 捲動條

捲動條

使用捲動條可以捲動關聯物件的顯示內容。對於有些資料庫顯示物件可設計此捲動條，此滾動按鈕物件可針對歷史資料庫進行瀏覽捲動的操作，捲動條可對物件內容提供平滑的捲動效果，也能顯示捲動範圍。下列物件可以使用捲動條：歷史數據顯示器、歷史訊息顯示器、歷史趨勢圖、操作記錄顯示器、警報顯示器、配方表和次連線表。

■ 一般頁(General)
詳閱章節5.11.4.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明


5.11.1 捲動條 - 基本功能

捲動條 - 基本功能

水平捲動條會有以下幾種按鈕：

按鈕 | 說明
向右 | 向右捲動關聯物件的顯示內容。
右一頁 | 向右捲動關聯物件的顯示內容一頁。
滑桿 | 移動滑桿，關聯物件的顯示隨著滑桿移動的方向移動。捲動的幅度是依捲動條移動的比例。物件內容的位置決定捲動條的位置。物件內容的多寡決定捲動條的高度。
左一頁 | 向左捲動關聯物件的顯示內容一頁。
向左 | 向左捲動 關聯物件的顯示內容。

垂直捲動條會有以下幾種按鈕：

按鈕 | 說明
向上 | 向上捲動關聯物件的顯示內容。
上一頁 | 向上捲動關聯物件的顯示內容一頁。
滑桿 | 移動滑桿，關聯物件的顯示隨著滑桿移動的方向移動。捲動的幅度是依捲動條移動的比例。物件內容的位置決定捲動條的位置。物件內容的多寡決定捲動條的寬度。
下一頁 | 向下捲動關聯物件的顯示內容一頁。
向下 | 向下捲動關聯物件的顯示內容。


5.11.2 捲動條 - 功能選項

捲動條 - 功能選項

下表是捲動條中可增加的功能選項，可使捲動條的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.11.3 捲動條 - 設定

捲動條 - 設定

所有捲動條的設定都可在屬性視窗中完成。屬性視窗包含以下二個頁面。

■ 一般頁(General)
詳閱章節5.11.4.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明


5.11.4 捲動條 - 一般設定

捲動條 - 一般設定

本章節說明捲動條一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定捲動條的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為SBRnnnn。
註 | 可加入說明文字。
種類 | 捲動條的種類。共有兩種：水平和垂直。
關聯物件編號 | 捲動條所捲動的關聯物件的編號。可以從下拉式選單中選擇 關聯物件編號。同一畫面的可捲動物件才能支援此捲動操作。
本體顏色 | 捲動條的本體顏色。
符號顏色 | 捲動條的符號顏色。


5.12 步進按鈕

步進按鈕

觸壓步進按鈕，寫入『次一狀態』的值到指定的變數地址。與大部分的按鍵不同，步進按鈕同時顯示所有的狀態，包含當前狀態。步進按鈕可讓使用者知道所有狀態，和觸壓後的次一狀態。

■ 一般頁(General)
詳閱章節5.12.4.說明

■ 文字頁(Text)
詳閱章節4.3.6.說明

■ 圖片頁(Picture)
詳閱章節4.3.7.說明

■ 進階頁(Advanced)
詳閱章節4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節4.4.6.說明

■ 外標示頁(ExternalLabel)
詳閱章節4.3.8.說明


5.12.1 步進按鈕 - 基本功能

步進按鈕 - 基本功能

觸摸此按鈕，觸控屏馬上先從PLC讀取暫存器的內容值並加/減所設數值，再將運算結果寫至PLC相對應之暫存器。允許自訂狀態值表示每一個狀態的寫入對應值可以個別單獨指定，不需要連續值。

步進按鈕的狀態是由指定變數的值和狀態類別所決定，當觸壓按鈕，它會計算下個狀態的值並寫入指定的變數。若當前狀態不是最後一個狀態，則次一狀態為當前狀態加一。若當前狀態是最後一個狀態，則次一狀態回到狀態0。


5.12.2 步進按鈕 - 功能選項

步進按鈕 - 功能選項

下表是步進按鈕中可增加的操作選項，可使步進按鈕的使用更安全、有效率。選項的設定可在屬性視窗中完成。

選項 | 說明
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
最少按壓時間 | 按鈕的觸控操作必須持續按壓一段時間(最少按壓時間)，才會執行操作。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，按鈕的操作將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
顯現控制 | 按鈕的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


5.12.3 步進按鈕 - 設定

步進按鈕 - 設定

所有步進按鈕的設定都可在屬性視窗中完成。屬性視窗包含以下六個頁面。

■ 一般頁(General)
詳閱章節 5.12.4.說明

■ 文字頁(Text)
詳閱章節 4.3.6.說明

■ 圖片頁(Picture)
詳閱章節 4.3.7.說明

■ 進階頁(Advanced)
詳閱章節 4.4.5.說明

■ 顯現頁(Visibility)
詳閱章節 4.4.6.說明

■ 外標示頁(External Label)
詳閱章節 4.3.8.說明


5.12.4 步進按鈕 - 一般設定

步進按鈕 - 一般設定

本章節說明步進按鈕一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定步進按鈕的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為STBnnnn。
註 |  | 可加入說明文字。
外型設置 |  | 、觸摸視效、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 物件外型設定。
外標示 |  | 勾選步進按鈕是否需要外標示。外標示頁可設定各項屬性。
狀態 |  | 選定一個狀態為當前狀態並選擇背景色。同時可設定及瀏覽各個狀態的顯示效果和背景色。 註：狀態的顯示以當前狀態的設定為優先。當改變狀態的背景色時，若該狀態為當前狀態，則必須先設定其他狀態為當前狀態後，背景色的改變才會顯現。
狀態類別 |  | 設定步進按鈕的狀態類別，共有三種狀態類別：數值、最低位(LSB)和自訂狀態值。詳細說明，請參考章節 4.4.1.1 狀態種類。
狀態序 |  | 設定步進按鈕排列狀態之順序與方向。有4種方向順序可以選 擇：
 |  | 狀態序 | 範例
 |  | 從左到右 |
 |  | 從右到左 |
 |  | 從上到下 |
 |  | 從下到上 |
數據類型 |  | 寫入地址欄所輸入的數據類型。支援的種類有：16位正整數、16位BCD正整數、32位正整數和32位BCD正整數。
寫入地址 | 寫入地址 | 設定由步進按鈕所控制變數的地址。變數也決定步進按鈕的狀態。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點選此圖標，出現選擇標籤，選擇所需標籤。
狀態總數 |  | 設定狀態總數。
定義狀態值… |  | 當狀態類別為自訂狀態值，就需要設定個別狀態的狀態值。詳細說明，請參考章節4.4.1.2 設定物件自訂狀態值。
標示當前狀態 | 方式 | 選擇如何標示當前被選中狀態按鈕的方式。可選擇用不同顏色顯示文字或使用圓形\方形標誌來標示當前狀態。
 | 背景色 | 設定當前狀態的背景色。
文字/標誌顏色 |  | 當前狀態的文字或標誌顏色。
分隔線顏色 |  | 設定兩狀態間分隔線的顏色。


5.13 選頁器

選頁器

在選頁器中，按壓提標可檢視關聯頁面(視窗畫面)。選頁器包含一組水平排列的按鈕和一個頁面顯示區塊。每一個按鈕對應一個指定的視窗畫面作為對應的 資料頁面。在運行時，每次只會顯示一個頁面在頁顯示區內，要看某特定頁面只要觸摸相應的提標按鈕即可切換所需的畫面。同一個畫面可含多個選頁器。

■ 一般頁(General)
詳閱章節 5.13.3.說明

■ 文字頁(Text)
詳閱章節 4.3.6.說明

■ 圖片頁(Picture)
詳閱章節 4.3.7.說明


5.13.1 選頁器 - 基本功能

選頁器 - 基本功能

選頁器最多可設置8個視窗畫面。每個視窗畫面為一頁，每一頁有一對應的提標。用戶可設定每一個提標對應的文字及圖片。在運行時，選頁器只顯示其中一個畫面，按壓相對應的提標，選擇所需的頁面。


5.13.2 選頁器 - 設定

選頁器 - 設定

所有選頁器的設定都可在屬性對話框中完成。屬性對話框包含以下三個頁面。

■ 一般頁(General)
詳閱章節5.13.3.說明

■ 文字頁(Text)
詳閱章節4.3.6.說明

■ 圖片頁(Picture)
詳閱章節4.3.7.說明


5.13.3 選頁器 - 一般設定

選頁器 - 一般設定

本章節說明選頁器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定選頁器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為PSnnnn。
註 |  | 可加入說明文字。
外型設置 |  | 圖片外型、 [image] 、觸摸視效、 提標、 [image] 、邊框色、背景色的詳細說明，請參考章節4.3.4 物件 外型設定。
提標 |  | 選定一個提標為當前選擇並選擇背景色。同時可設定及瀏覽各個提標的背景色。 註：提標的顯示以當前選擇的設定為優先。當改變提標的背景色時，若該提標為當前選擇，則必須設定其他提標為當前選擇後，背景色的改變才會顯現。
提標位置 |  | 設定頁面在提標上/下或在提標 左/右。在運行時，選擇的畫面在此位置顯現。
總頁數 |  | 設定選頁器的視窗畫面的總畫面數。
指定頁面… |  | 設定頁面在提標上或在提標下。在運行時，選擇的畫面在此顯現。
當前選擇 |  | 設定當前選定頁面的背景色及文字顏色。
 | 背景色 | 設定當前頁面彈出時的背景色。
 | 文字顏色 | 設定當前頁面彈出時的文字顏色。
按鈕高度 |  | 設定提標按鈕的高度。


6.1.1 位指示燈 - 基本功能

位指示燈 - 基本功能

可以用一個位(bit)來控制指示燈的顯示內容和狀態值。位指示燈是用來指示物件的狀態 。

位指示燈有兩種狀態，狀態0和狀態1。用戶可分別設定兩種狀態的外觀，在運行時，位指示燈依監視位的狀態切換不同狀態下的外觀顯示 。

■ 一般頁
 詳閱章節6.1.4.說明

■ 標示頁
 詳閱章節4.3.5.說明

■ 顯現頁
 詳閱章節4.4.6.說明

■ 外標示頁
 詳閱章節4.3.8..說明


6.1.2 位指示燈 - 功能選項

位指示燈 - 功能選項

下表是位指示燈中可增加的功能選項。選項的設定可在屬性對話框中完成 。

選項 | 說明
顯現控制 | 設定物件的顯現與否，由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定


6.1.3 位指示燈 - 設定

位指示燈 - 設定

所有位指示燈的設定都可在屬性對話框中完成。屬性對話框包含以下四個頁面，某些頁面在需要設定時才會出現 。

■ 一般頁
 詳閱章節6.1.4.說明

■ 標示頁
 詳閱章節4.3.5.說明

■ 顯現頁
 詳閱章節4.4.6.說明

■ 外標示頁
 詳閱章節4.3.8..說明


6.1.4 位指示燈 - 一般設定

位指示燈 - 一般設定

本章節說明位指示燈一般頁中各項屬性的設定。下圖是一般頁面的對話框的例子。

下表為一般頁中各項屬性的說明：

屬性 |  | 說明
編號 |  | 設定位指示燈的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為BLnnnn。
註 |  | 可加入說明文字。
背景透明 |  | 勾選背景透明，物件背景將透明顯示。
外型 |  | 背景透明、圖片外型、 選擇、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節4.3.4設定物件外型。
外標示 |  | 勾選位指示燈是否需要外標示。外標示頁可設定各項屬性。
狀態 |  | 點擊此按鈕，設定物件為狀態1。可檢視和設定狀態1物件的外觀。
 |  | 點擊此按鈕，設定物件為狀態0。可檢視和設定狀態0物件的外觀。
監視地址 | 地址種類 | 設定監視地址欄中變數的種類:
 |  | 變數種類 | 說明
 |  | 位 | 設定變數為位變數。觸控屏讀取PLC之接點狀態值，自動顯示所指定位址的PLC位元的ON、OFF兩種狀態。依其對應狀態之規劃內容直接顯示在觸控屏幕上。
 |  | 字 | 設定變數為字變數。字變數需要設定位編號，位編號範圍從0到15。觸控屏讀取PLC之字的位狀態值，自動顯示所指定位址的PLC位元的ON、OFF兩種狀態。依其對應狀態之規劃內容直接顯示在觸控屏幕上。
 |  | 雙字 | 設定變數為雙字變數。雙字變數需要設定位編號，位編號範圍從0到31。觸控屏讀取PLC之雙字的位狀態值，自動顯示所指定位址的PLC位元的ON、OFF兩種狀態。依其對應狀態之規劃內容直接顯示在觸控屏幕上 。
 |  | 位元組 | 設定變量爲位元組變量。位元組變量需要設定位編號，位編號範圍從0到7。觸控屏讀取PLC位元組的位的狀態值，自動顯示所指定的地址的PLC位的ON，OFF兩種狀態。依其對應狀態之規劃內容直接顯示在觸控屏幕上。
 | 監視地址 | 當變數種類為位，設定監視位的地址。 當變數種類為字，設定字所包含的位的地址。 當變數種類為雙字，設定雙字所包含的位的地址。 當變數種類為位元組，設定位元組所包含的位的地址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址。
 |  | 點擊此圖標，出現選取標籤對話框。選取所需的標籤。
 | 位編號 | 當地址種類為字或雙字或位元組时，設定位編號。


6.2.1. 多態指示燈 - 基本功能

多態指示燈 - 基本功能

可以用一個變數來控制多態指示燈的顯示內容和狀態值 。

多態指示燈最多可以有256個狀態，多態指示燈的狀態值最大值是由狀態類別和監視變數的數據種類決定。下表列出不同的狀下狀態變數的最大值。

 |  | 16位變數 | 32位變數
狀態種類
 | 數值 | 256 | 256
 | 最低位 | 16 | 32
 | 自訂狀態值 | 16 | 32

用戶需設定多態按鈕的狀態數，但狀態數不能超過最大值。每一種狀態都可分別設定狀態的外觀。運行時，多態指示燈依監視位改變狀態，監視變數的狀態由狀態種類和變數的數值所決定 。

■ 一般頁
 詳閱章節6.2.4.說明

■ 文字頁
 詳閱章節4.3.6.說明

■ 圖片頁
 詳閱章節4.3.7.說明

■ 顯現頁
 詳閱章節4.4.6.說明

■ 外標示頁
 詳閱章節4.3.8.說明


6.2.2 多態指示燈 - 功能選項

多態指示燈 - 功能選項

下表是多態指示燈中可增加的功能選項。選項的設定可在屬性對話框中完成 。

選項 | 說明
顯現控制 | 設定物件的顯現與否，由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定 。


6.2.3. 多態指示燈 - 設定

多態指示燈 - 設定

所有多態指示燈的設定都可在屬性對話框中完成。屬性對話框包含以下五個頁面，某些頁面在需要設定時才會出現 。

■ 一般頁
 詳閱章節6.2.4.說明

■ 文字頁
 詳閱章節4.3.6.說明

■ 圖片頁
 詳閱章節4.3.7.說明

■ 顯現頁
 詳閱章節4.4.6.說明

■ 外標示頁
 詳閱章節4.3.8.說明


6.2.4. 多態指示燈 - 一般設定

多態指示燈 - 一般設定

本章節說明多態指示燈一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中，各項屬性的說明 。

屬性 |  | 说明
編號 |  | 設定多態指示燈的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為MLnnnn。
註 |  | 可加入說明文字 。
外型 |  | 圖片外型、 [image] 、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考 章節 4.3.4 設定物件外型 。
外標示 |  | 勾選多態指示燈是否需要外標示。外標示頁可設定各項屬性 。
狀態 |  | 選定一個狀態為訊息顯示器的當前狀態。同時可設定及瀏覽各個狀態的外觀。
數據類型 |  | 監視變數的數據類別，共有六種：16位正整數、16位整數、16位BCD正整數、32位正整數 、32位整數和32位BCD正整數 。
監視地址 | 監視地址 | 設定變數的監視地址。
 |  | 點擊此圖標，出現地址輸入鍵盤，輸入所需的地址 。
 |  | 點擊此圖標，出現選擇標籤，選擇所需標籤。
總狀態數 |  | 設定多態指示燈的總狀態數。
狀態類別 |  | 設定狀態類別，有數值，最低位(LSB)和自訂狀態值三種。詳細說明，請參考 章節 4.4.1.1 狀態種類 。
自訂狀態值 |  | 支援自訂狀態值。詳細說明，請參考章節 4.4.1.2 設定物件自訂狀態值。


6.3.1. 訊息顯示器 - 基本功能

訊息顯示器 - 基本功能

可以用一個變數來控制訊息顯示的預定內容。

訊息顯示器最多可有20000個狀態。每個狀態可預設訊息。訊息顯示器狀態數的最大值是由狀態類別和監視變數的數據種類決定。下表列出不同的狀況下狀態數的最大值。

 |  | 變數種類 | 最大值
狀態類別 | 位 | 位 | 2
 | 數值 | 16 位 | 256
 |  | 32 位 | 256
 | 最低位 | 16 位 | 17
 |  | 32 位 | 33
 | 數值作爲字符串編號 | 16 位 | 20000
 |  | 32 位 | 20000

如果狀態類型是數值或最低位，用戶需設定狀態數，狀態數需小於等於最大值。每個狀態可設定不同的訊息。在運行時，顯示相對應狀態的訊息，監視變數的狀態由狀態的類別和變數的值決定。

如果狀態類型是數值作爲字符串編號，你需要選擇文字庫中的一個表格，並在表格中指定第一個和最後一個字串的編號。字符串數量不得超過所允許的最大值。在運行時，會顯示相對應狀態的訊息。

範例：

從文字庫選中一個文字表:表A。字串號範圍是從1到100。

數據值 | 字符串編號 | 狀態 | 字串號 | 註釋
0 | 0 | 無效 |  | 沒有定義字符。因為0不是有效的字串號。
5 | 5 | 5 | A00005 |
200 | 200 | 無效 |  | 字串號超過範圍，沒有定義字符。

註：訊息顯示和多態指示燈之間的區別。

指示燈可以顯示文字或圖片，或兩者兼而有之，而訊息顯示器，只能顯示文字。訊息顯示器和指示燈兩者都可以顯示預定義的文字內容的改變，這一改變是藉由監看某一變量的數值。而且，只有訊息顯示器可以作為走馬燈的顯示，其文字移動速度可以由指定的變量運行速度所控制。

所有訊息顯示器的設定都可在屬性對話框中完成。屬性對話框包含以下四個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節6.3.4.說明

■ 文字頁
詳閱章節4.3.6.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 外標示頁
詳閱章節4.3.8.說明


6.3.2. 訊息顯示器 - 功能選項

訊息顯示器 - 功能選項

下表是訊息顯示器中可增加的功能選項。選項的設定可在屬性對話框中完成 。

選項 | 說明
走馬燈 | 訊息會自動往指定的方向捲動。當訊息無法涵蓋所有的顯示區域，訊息會自動複製填滿整個區域。 uncover
顯現控制 | 物件的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


6.3.3. 訊息顯示器 - 設定

訊息顯示器 - 設定

所有訊息顯示器的設定都可在屬性對話框中完成。屬性對話框包含以下四個頁面，某些頁面在需要設定時才會出現 。

■ 一般頁
詳閱章節6.3.4.說明

■ 文字頁
詳閱章節4.3.6.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 外標示頁
詳閱章節4.3.8.說明


6.3.4. 訊息顯示器 - 一般設定

訊息顯示器 - 一般設定

本章節說明訊息顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例 。

下表為一般頁中，各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定訊息顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為MDnnnn。
註 |  | 可加入說明文字。
背景透明 |  | 勾選背景透明，物件背景將不顯示。
外型設置 |  | 背景透明、外框、邊框色、圖樣、圖樣色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 |  | 勾選訊息顯示器是否需要外標示。外標示頁可設定各項屬性。
狀態 |  | 選定一個狀態為訊息顯示器的當前狀態。同時可設定及瀏覽各個狀態的外觀 。
狀態類別 |  | 設定訊息顯示器的狀態類別，有以下四種：位、數值、最低位和數值作為字串編號。詳細說明，請參考章節 4.4.1.1 狀態類別。
數據類別 |  | 變數的數據類別，有以下四種：16位正整數、16位整數、16位BCD正整數、32位正整數 、32位整數和32位BCD正整數。
監視地址 |  | 設定變數的監視地址。 點擊此圖標 [image] ，輸入所需的地址。點擊此圖標 [image] ，選擇所需標籤 。
總狀態數 |  | 設定訊息顯示器的總狀態數。
文字表 | 文字表 | 當狀態類別設定為"數值作為字串編號"，該物件須選擇一個文字庫中的表格，編號A~L。
 | 啟始字串編號 | 定義啟始字串編號範圍為1~19999。
 | 最後字串編號 | 定義最後字串編號範圍為2~20000。
走馬燈 | 走馬燈 | 勾選訊息是否自動捲動顯示。當設定走馬燈時，文字訊息會依照設定速度和方向依序移動 。
 | 速度 | 設定文字移動速度設定值由1~10；速度1為最慢速，速度10為最快速 。
 | 移動方向 | 訊息文字移動的方向。有向左、向右和向上三種方向 。
文字可以用捲動條或捲動按鈕作上下捲動 |  | 選擇此選項，可使用捲動條或捲動按鈕上下捲動文字訊息。


7.1. 數值輸入器

數值輸入器

用戶可以使用數值輸入器，輸入數值更改變數的數值。觸摸此數值輸入按鈕，觸控屏會彈出內建鍵盤讓您輸入數值，按ENTER時就將數值寫到控制器對應之暫存器.

■ 一般頁
詳閱章節7.1.3.說明

■ 進階頁
詳閱章節7.1.4.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 巨集頁
詳閱章節15.2.6.說明

■ 外標示頁
詳閱章節4.3.8.說明


7.1.1. 數值輸入器 - 功能選項

數值輸入器 - 功能選項

下表是數值輸入器中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 |  | 說明
縮放 | 增益和偏移量 | 監視變數的數值以縮放的方式顯現。以下是數值縮放的公式。 顯示數值 = 監視數值 * 增益 + 偏移量 當勾選此選項後，輸入的數值，會依以下的公式縮放後輸出。 輸出數值 = (輸入數值 – 偏移量) / 增益 縮放的選擇和設定可在進階頁中完成。 註：當增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件捨去造成的誤差。
 | 最大值/最小值 | 監視變數的數值按照比例的方式縮放顯示。以下是數值按比例縮放的公式。 數值比例=（顯示最大值- 顯示最小值）/（資料最大值- 資料最小值） 顯示數值=數值*數值比例 輸出數值=輸出數值*數值比例。
範圍檢查 |  | 數值輸入器會檢驗所輸入的數值是否符合最大最小值的範圍。如果所輸入的數值超過範圍，數值將為無效的輸出。在進階頁中，可進行此選項的設定。 註一：當勾選縮放選項，則將檢驗輸出數值的大小，而非輸入數值的大小。 輸出數值 = (輸入數值 – 偏移量) / 增益 註二：當勾選縮放物件，數值鍵盤上的最大值最小值範圍為縮放後的最大值和最小值。 縮放後的最大值 = 最大值 * 增益 + 偏移量 縮放後的最小值 = 最小值 * 增益 + 偏移量
觸控有效 |  | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。 註：當同時勾選『受位控制』與『受用戶等級控制』兩種選項時，『觸控有效』只在上述兩種功能條件皆成立時，觸控功能才為有效。
超時取消 |  | 當一段時間未輸入任何資料，資料輸入的操作將會取消。超時秒數設定為 5, 10, 15, 20, 25, 30 秒。
通知 |  | 當數值成功輸入後，數值輸入器會發送信號通知指定的位。在進階頁中，可進行此選項的設定。
操作員確認 |  | 當操作員輸入數值，會出現確認視窗。當操作員選『是』，則會執行數值輸入器的操作；當操作員選『否』，或在設定的『超時取消』時間內沒有回應，則停止數值輸入器操作。 在進階頁中，可進行此選項的設定。
改變用戶等級 |  | 執行該操作後，可以改變用戶當前的級別。在 『進階』頁面，選擇和設置這個選項。
操作記錄 |  | 勾選此選項，使用數值輸入器的『當下時間』與輸入的『數值』將會被記錄在操作記錄中，同時可以設定要紀錄在操作紀錄中的輔助訊息。在進階頁中，可進行此選項的設定。
呈現鍵盤在隨機位置以延長觸摸板壽命 |  | 鍵盤的位置隨機顯示在觸摸屏上的不固定位置，此選項可避免因長期使用固定的觸點（數字），造成固定的觸點提早失靈，此選項可延長觸摸板使用時間。在 『進階』頁面，選擇和設置這個選項。
指定鍵盤 |  | 指定一個自行製作的『鍵盤視窗畫面』作為輸入的鍵盤，可使用系統預設以外的鍵盤畫面。
顯現控制 |  | 物件的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


7.1.2. 數值輸入器 - 設定

數值輸入器 - 設定

所有數值輸入器的設定都可在屬性視窗中完成。數值輸入器的屬性視窗包含以下四個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節7.1.3.說明

■ 進階頁
詳閱章節7.1.4.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 巨集頁
詳閱章節15.2.6.說明

■ 外標示頁
詳閱章節4.3.8.說明


7.1.3. 數值輸入器 - 一般設定

數值輸入器 - 一般設定

本章節說明數值輸入器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性

 說明
編號 | 設定數值輸入器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為NEnnnn。
註 | 可加入說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。數值輸入/顯示時，背景色 成為透明，這樣可以方便數值物件下面的底圖搭配。如果勾選了“背景透明”，那麼字體背景顏色就不能更改。
外型 | 背景透明、外型、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 | 勾選數值輸入器是否需要外標示。外標示頁可設定各項屬性。
數據類別 | 所對應的數據的格式定義分為 ：16位正整數、32位正整數、16位整數、32位整數、8位正整數、8位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB; left_most_bit:1, 指當最左一位bit為1時該數據表示為負數)、32位BCD整數(LMB)、16位BCD整數(LMD; left_most_digit:F, 指當最左4個bit為F時該數據表示為負數)、32位BCD整數(LMD)。
顯示類別 | 變數的顯示類別，下表為不同數據類別下的顯示類別。
數據類別 | 可顯示類別
16位正整數 | 16位十進制正整數、16位十六進制數、16位八進制數 、16位二進制數
32位正整數 | 32位十進制正整數、32位十六進制數、32位八進制數 、32位二進制數、密碼 、IP 地址
16位整數 | 16位十進制整數
32位整數 | 32位十進制整數
16位BCD正整數 | 16位十進制正整數
32位BCD正整數 | 32位十進制正整數
32位浮點數 | 32位浮點數
16位BCD正整數(LMB) | 16位十 進制整數, (LMB：指當最左一位bit為1 時該數據表示為負數)
32位BCD正整數(LMB) | 32位十 進制整數, (LMB：指當最左一位bit為1 時該數據表示為負數)
16位BCD正整數(LMD) | 16位十 進制整數, (LMD：指當最左四個bit為F 時該數據表示為負數)
32位BCD正整數(LMD) | 32位十 進制整數, (LMD：指當最左四個bit為F 時該數據表示為負數)
8位正整數 | 8位十 進制正整數、8位十六進制數、8位八進制數、8位二進制數
8位整數 | 8位十 進制正整數、8位十六進制數、8位八進制數
4位分隔點 | 勾選這個選項，顯示分隔每四個二進制數字用的分隔小數點。僅當顯示類型為8位二進制，16位二進制 ，32位二進制才有此選項。
寫入地址 設定數值寫入的變數地址。
 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
監視地址與寫入地址相同 | 如勾選監視地址與寫入地址相同，表示和“寫入地址”同一讀取位置。當不勾選時亦可設不同位置。勾選此選項，不必重複輸入監視地址。當勾選監視後，即會出現此選項。
監視地址 設定監視變數的地址。
 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
字體 | 數值輸入器的字體。您可以使用下拉列表中選擇一種字體，或者單擊 [image] ，彈出字體模板對話框，選擇字體為當前文本。您可以在該對話框中選擇字體之前更改字體模板。
文字顏色 | 設定文字顯示的顏色。
總位數 | 設定數值顯示的總位數。註：這項屬 性設定適用於初始值、鍵盤輸入的最大值和最小值。
小數位數

當顯示類別是32位浮點數，則此選項為設定最大值和最小值的小數位數。

當顯示類別不是32位浮點數，則此選項除了為最大值和最小值的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。當小數位數為一個非0的數N，輸入的數值在輸出前將依以下的公式轉換為整數。

輸出值=輸入值*(10的N次方)

 範例一：

顯示類別 | 總位數 | 小數位數 | 調整 | 監視數值 | 顯示數值
32位浮點數 | 4 | 2 | 前頭去零 | 12.34 | 12.34
32位浮點數 | 4 | 2 | 前頭去零 | 123.4 | 23.40
16位十進制整數 | 5 | 2 | 前頭去零 | 12345 | 123.45
16位十進制整數 | 5 | 2 | 前頭去零 | -5 | -5.00

範例二：

顯示類別 | 總位數 | 小數位數 | 輸入數值 | 輸出數值
32位浮點數 | 4 | 2 | 12.34 | 12.34
32位浮點數 | 4 | 2 | 123.4 | Error!
16位十進制整數 | 5 | 2 | 123.45 | 123.45
16位十進制整數 | 5 | 2 | -0.05 | -5
16位十進制整數 | 5 | 2 | 3 | 300
註：這項屬性適用於初始值、鍵盤輸入的最大值和最小值。
排列 | 設定數值顯示的排列方式。有三種排列方式：居左、居中和居右。
調整 | 設定數值顯示的調整方式，有以下三種調整方式：
選項 | 說明
前頭去零 | 當前頭位數為0時，不顯示數字。
零領頭 | 顯示所有位數的數字。
空格領頭 | 前頭的位數數字為0時，顯示空白字元。
數據輸入 | 設定在運行時，數值輸入的方式。有兩個選項：彈出式鍵盤和常駐式鍵盤或功能鍵。
選項 | 說明
彈出式鍵盤 | 觸壓數值輸入器，畫面上會出現觸控屏內建的數字鍵盤(Ten-Key)。注意:為方便觸控屏的使用，每當使用者觸摸一數字輸入按鈕時，會在螢幕上自動彈出鍵盤， 方便使用者輸入資料。
常駐式鍵盤或功能鍵 | 在畫面上自行製作一個鍵盤。移動游標，點擊功能按鈕中，選擇下一數據輸入物件或選擇前一數據輸入物件。如果畫面上有鍵盤，則可輸入數值。或者，利用功能鍵中的現值加一和現值減一調整寫入的數值。
註：當屏幕上的鍵盤和/或功能鍵選項被選中，則只能利用一種鍵盤數字輸入。要設置相應的對象上輸入鍵盤，則需要單擊該對象的第一個按 鍵。
巨集
使用 | 選中此選項，數值輸入器關聯一個巨集。
執行時機 | 選擇運行巨集的時機。寫出輸入值到控制器的『之前』或『之後』，可以運行巨集。


7.1.4. 數值輸入器 - 進階設定

數值輸入器 - 進階設定

本章節說明數值輸入器進階頁中各項屬性的設定。下圖是進階頁的圖例。

下表為進階頁中各項屬性的說明。

屬性 |  | 說明
縮放 | 縮放 | 監視變數的數值以縮放的方式顯現。
 | 增益/偏移 | 以下是數值縮放的公式。 顯示數值 = 監視數值 * 增益 + 偏移量 當勾選此選項後，輸入的數值，會依以下的公式縮放後輸出。 輸出數值 = (輸入數值 – 偏移量) / 增益 縮放比例公式 Y=aX+b。 Y=觸控屏輸入/顯示值，X=PLC實際寫入值，a=增益值，b=偏移值。 例如: AO模組 4-20mA PLC對應值 0-4000 觸控屏顯示 4000-20000。 此時設定a=4，b=4000 當觸控屏輸入12000(Y=12000)時， PLC將會寫入(12000-4000)/4=2000(X=2000)。 觸控屏會顯示4*2000+4000=12000。 註：增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件捨去造成的誤差。 註：只有數值格式是二進制才提供此功能。 註：當X=(Y-b)/a 無法整除時，會導致觸控屏顯示值將不會是整數，例如輸入200觸控屏卻顯示199。
 | 最大值/最小值 | 根據數據的最大值和最小值來設置顯示的最小值和最大值。 選擇此選項，監視變量的值將被縮放至適合的顯示範圍顯示。輸入的值將被調整，以適應前的數據範圍。
範圍檢查 | 範圍檢查 | 勾選範圍可變時，最小值/最大值會變更為由『暫存器位址 』來讀取『最大值』與『最小值』的值，如果暫存器的數值為一變動數，則最大值與最小值依此變動數，成為可變範圍。 勾選此選項，數值輸入器會檢驗所輸入的數值是否符合最大最小值的範圍。如果所輸入的數值超過範圍，數值將為無效的輸出。 註一：當勾選縮放選項，則將檢驗輸出數值的大小，而非輸入數值的大小。 輸出數值 = (輸入數值 – 偏移量) / 增益 註二：當勾選縮放物件，數值鍵盤上的最大值最小值範圍為縮放後的最大值和最小值。 縮放後的最大值 = 最大值 * 增益 + 偏移量 縮放後的最小值 = 最小值 * 增益 + 偏移量
 | 範圍可變 | 勾選在運行時，最大值和最小值的範圍是否可變。當未勾選『範圍可變』時，範圍檢查依設置的固定變數作範圍檢查。
 | 最小值 | 當未勾選範圍可變，設定最小值。當勾選範圍可變，在運行時，最小值依指定地址的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。預設的最小值位址為寫入地址暫存器位址加一。
 | 最大值 | 當未勾選範圍可變，設定最大值。當勾選範圍可變，在運行時，最大值依指定地址的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。預設的最大值位址為寫入地址暫存器位址加二。
觸控有效 | 受位控制 | 勾選觸控操作有效與否，是否受位控制。可選當控制位的M0接點ON(有效狀態1)時，才可以允許數值輸入。或當控制位的Y0接點OFF(有效狀態0)時，才可以允許數值輸入。例如，某數值輸入只能在機器停止運轉時才可以允許輸入，此時可以利用此方式達成。
 | 控制位 | 設定觸控操作是否有效的位。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 | 有效狀態 | 設定觸控操作的有效狀態。
 | 受用戶等級控制 | 勾選觸控有效是否受當前用戶等級控制。
 | 最低有效用戶等級 | 設定觸控有效的最低用戶等級。當使用者的等級(8:最高，0:最低)必須大於最低有效用戶等級時，才可以允許數值輸入。例如，當操作人員的等級不夠時，將無法輸入數值。
 | 顯示觸控無效標示 | 勾選是否當觸控操作無效時，顯示觸控無效標示。
超時取消 | 超時取消 | 觸控屏運行中當數值輸入鍵盤出現後，若超過一段指定的時間，操作人員並未進行數字輸入動作，此一勾選的設置值表示多久時間後將自動取消該操作狀態，主動關閉輸入鍵盤，如此可以避免觸控屏系統停留，造成其他後台取樣工作的延誤。
 | 超時時間 | 設定數值輸入間隔的最大等待時間。如果在時間內沒有輸入，數值輸入鍵盤會關閉且輸入取消。
通知 | 通知 | 勾選在輸入數值後，是否發送信號通知指定的位。
 | 信號 | 選擇信號通知方式：
 |  | 信號 | 說明
 |  | 位階 | 設定通知位的狀態用位階形式。當數值輸入完成按Enter時，數值寫入後通知接點設為1(on)或設為0(off)，注意該接點須由PLC程式清為0(off)，這樣下次再一次操作時此通知接點才會正確動作。
 |  | 脈衝 | 設定通知位的狀態用正脈衝形式。當數值輸入完成按Enter時，數值寫入控制器後同時通知一個接點設為1(on)然後自動設為0(off)的一次脈衝。一般當客戶要用到很多通知位，是因為在PLC程式裡面他要進行龐大資料運算，一旦人機的數值輸入進入寄存器後，通知位發脈衝1，PLC馬上對這組資料運算，大概就是一個PLC的掃描週期時間後，就要依靠通知位自動設為0(off)的一次脈衝來控制停止運算。所以脈衝對他們來使用是最合適的 位。
 | 位 | 設定接收通知的位。
 | 狀態 | 設定需要發送通知的狀態。
操作員確認 | 操作員確認 | 勾選當輸入數值後，是否需要確認所輸入的數值。當觸壓此按鈕時，會出現確認視窗。當操作員選是，則會執行數值輸入器的操作；當操作員選否，或在最長等待時間內沒有回應，則停止數值輸入器操作。在進階頁中，可進行此選項的設定。
 | 等待時間 | 設定操作員確認的最長等待時間。如果超過等待時間，數值輸入器的操作將會取消。
改變用戶等級 | 改變用戶等級 | 選中此選項，執行操作後以可改變當前用戶等級。
 | 新用戶等級 | 設置新的用戶等級。
操作記錄 | 操作記錄 | 勾選以下三個項目是否會寫入在操作記錄中。 (1) 操作的時間。 (2) 輸入的數值。 (3) 預設的操作訊息。
 | 訊息 | 輸入第一種語言的操作訊息。
 |  | 點擊此處，出現操作記錄訊息，可用所有的語言編輯操作訊息。
呈現鍵盤在隨機位置以延長觸摸板壽命 |  | 勾選這個選項，在隨機位置顯示鍵盤。
指定鍵盤 | 指定鍵盤 | 選中此選項，可指定一個不同於系統預設的鍵盤，用於人機的數字輸入。
 | 畫面 | 選擇一個自己客制的鍵盤畫面作為鍵盤輸入設備。


7.2. 數值顯示器

數值顯示器

使用者可使用數值顯示器，顯示指定變數的數值。

■ 一般頁
詳閱章節7.2.3.說明

■ 進階頁
詳閱章節7.2.4.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 外標示頁
詳閱章節4.3.8.說明


7.2.1. 數值顯示器 - 功能選項

數值顯示器 - 功能選項

下表是數值顯示器中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 |  | 說明
縮放 | 增益/偏移量 | 監視變數的數值以縮放的方式顯現。以下是數值縮放的公式。 顯示數值 = 監視數值 * 增益 + 偏移量 當勾選此選項後，輸入的數值，會依以下的公式縮放後輸出。 輸出數值 = (輸入數值 – 偏移量) / 增益 縮放的選擇和設定可在進階頁中完成。 註：增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件捨去造成的誤差。
 | 最大值/最小值 | 選擇此選項，根據數據的最大值和最小值來設置顯示的最小值和最大值。 監視變數的數值按照比例的方式縮放顯示。以下是數值按比例縮放的公式。 數值比例=（顯示最大值-顯示最小值）/（資料最大值-資料最小值） 顯示數值=數值*數值比例 輸出數值=輸出數值*數值比例
範圍顯示 |  | 用戶可設定數值顯示的低限值和高限值，限值可為常數或變數。在運行時，當監視變數的數值低於低限值，數值的文字和背景色會以設定的低位色顯示。當監視變數的數值高於高限值，數值的文字和背景色會以設定的高位色顯示。
顯現控制 |  | 設定數值顯示與否，由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


7.2.2. 數值顯示器 - 設定

數值顯示器 - 設定

所有數值顯示器的設定都可在屬性視窗中完成。數值顯示器的屬性視窗包含以下四個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節7.2.3.說明

■ 進階頁
詳閱章節7.2.4.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 外標示頁
詳閱章節4.3.8.說明


7.2.3. 數值顯示器 - 一般設定

數值顯示器 - 一般設定

本章節說明數值顯示器一般頁中各項屬性的設定。下圖是一般頁的圖範例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定數值顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為NDnnnn。
註 | 可加入物件的說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。數值輸入/顯示時，背景色能透明，這樣可以方便數值物件下面的底圖搭配。如果勾選“背景透明”，那麼字體背景顏色就不能更改。
外型設置 | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 | 勾選是否數值顯示器需要外標示。外標示頁可設定各項屬性。
數據類 型 | 所對應的變數的數據類型分為，16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。 設定數據的格式；這部分的設定會隨著控制器改變。 數據類型/顯示類 型的格式；這部分的設定會隨著控制器的相容性而改變。
顯示類型 | 監視變數的顯示類 型，下表為每種數據類型下的顯示類型。
 | 數據類型 |  | 顯示類型
 | 16位正整數 |  | 1 6位十進制正整數、16位十六進制數、16位八進制數；指所對應的數據的顯示格式可選擇使用16位十進制正整數(0-65535)、16位十六進制數(0-FFFF)、16位八進制數(0-77777)、16位二 進制數(1111.1111.1111.1111)。
 | 32位正整數 |  | 32位十進制正整數、32位十六進制數、32位八進制數、密碼；指所對應的數據的顯示格式可選擇使用32位十進制正整數(0-65535)、32位十六進制數(0-FFFFFFFF)、32位八進制數(0-77777)、 密碼、32位二 進制數(1111.1111.1111.1111. 1111.1111.1111.1111)。
 | 16位整數 |  | l 6位十進制整數
 | 32位整數 |  | 32位十進制整數
 | 16位BCD正整數 |  | 16位十進制正整數
 | 32位BCD正整數 |  | 32位十進制正整數
 | 32位浮點數 |  | 32位浮點數
 | 16位BCD正整數(LMB) |  | 16 位十進制整數, (LMB：指 當最左一位 bit 為 1 時該數據表示為負數)
 | 32位BCD正整數(LMB) |  | 32 位十進制整數, (LMB：指 當最左一位 bit 為 1 時該數據表示為負數)
 | 16位BCD正整數(LMD) |  | l 6 位十進制整數, (LMD：指 當最左 4 個 bit 為 F 時該數據表示為負數)
 | 32位BCD正整數(LMD) |  | 32 位十進制整數, (LMD：指 當最左 4 個 bit 為 F 時該數據表示為負數)
 | 8位正整數 |  | 8位無符號十進制，8位十六進制，8位二進制
 | 8位整數 |  | 8位有符號十進制
4位分隔點 | 勾選這個選項，顯示分隔每四個二進制數字用的分隔小數點。僅當顯示類型為8位二進制，16位二進制32位二進制。
監視地址 | 設定欲讀取PLC的暫存器位址或內部記憶區位址。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
字體 | 數值顯示器的字體。您可以使用下拉列表中選擇一種字體，或者單擊 [image] ，彈出字體模板對話框，選擇字體為當前文本。您可以在該對話框中選擇字體之前更改字體模板。
文字顏色 | 數值顯示的文字顏色。
總位數 | 設定數值顯示的位數。 註：記住十進位的小數點並不占一位顯示位數(例如：顯示字數設4及1位小數則其所能顯示的最大值為999.9)
小數位數 | 當數據種類是32位浮點數，則此選項為設定最大值和最小值的小數位數。 當數據種類不是32位浮點數，則此選項除了為最大值和最小值的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。當小數位數為一個非0的數N，輸入的數值在輸出前將依以下的公式轉換為整數。 輸出值=輸入值*(10的N次方)。 範例：
 | 顯示類型 | 總位數 | 小數位數 | 調整 | 監視數值 | 顯示數值
 | 32位浮點數 | 4 | 2 | 前頭去零 | 12.34 | 12.34
 | 32位浮點數 | 4 | 2 | 前頭去零 | 123.4 | 23.40
 | 16位十進制整數 | 5 | 2 | 前頭去零 | 12345 | 123.45
 | 16位十進制整數 | 5 | 2 | 前頭去零 | -5 | -5.00
排列 | 設定數值顯示的排列方式。有三種排列方式：居左、居中和居右。
調整 | 設定數值顯示的調整方式：
 | 選項 | 說明
 | 前頭去零 | 前頭去零。當前頭位數為0時，不顯示數字。
 | 零領頭 | 前導零(高位數補上零) 也就是顯示所有位數的數字。。例如十進位的數字零領頭表示顯示7個數字時如果其值為2734則顯示將為0002734。
 | 空格領頭 | 前頭的位數數字為0 時，顯示空白字元。高位數補上空格。


7.2.4. 數值顯示器 - 進階設定

數值顯示器 - 進階設定

本章節說明數值顯示器進階頁中各項屬性的設定。下圖是進階頁的圖例。

下表為進階頁中各項屬性的說明。

屬性 |  |  | 說明
縮放 | <勾選框> |  | 選中此選項，以縮放的方式顯示監視的變量值。
 | 增益/偏移量 |  | 縮放功能可讓使用者依特定的規律改變出現在觸控屏上的數據。舉例來說，如果控制器回報的數值單位為攝氏溫度，但操作者熟悉的是華氏溫 度，那麼這時便可以使用算式來轉換數據，也就是讓結果以華氏溫度作為單位。在這個部分，任何的控制器傳來的數據都可以乘上一 個您希望的數值算式。 勾選此選項，監視變數的數值以縮放的方式顯現。以下是數值縮放的公式。 顯示數值 = 監視數值 * 增益 + 偏移量 當勾選此選項後，輸入的數值，會依以下的公式縮放後輸出。 輸出數值 = (輸入數值 – 偏移量) / 增益 註：增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件捨去造成的誤差。
 | 最大值/最小值 |  | 根據數據的最大值和最小值來設置顯示的最小值和最大值。 選擇此選項，監視變量的值將被縮放至適合的顯示範圍顯示。輸入的值將被調整，以適應前的數據範圍。
範圍顯示 | <勾選框> |  | 勾選當數值低於最低限或高於最高限時，是否顯示不同的顏色。
 | 範圍可變 |  | 勾選在運行時，高限值和低限值的範圍是否由『暫存器位址 』來讀取『高限值』與『低限值』的值，如果暫存器的數值為一變動數，則高限值與低限值依此變動數，成為可變範圍。
 | 低限值 |  | 當未勾選範圍可變，設定低限值。當勾選範圍可變，在運行時，低限值依指定地址的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 | 高限值 |  | 當未勾選範圍可變，設定高限值。當勾選範圍可變，在運行時，高限值依指定地址的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 | 小於低限 | 文字顏色 | 設定低限值的文字顏色。
 |  | 背景色 | 設定低值外型的背景色。
 |  | 顯示特殊字符取代數值 | 勾選在低於低限值時，設置一特殊字符，來代替數據的值低於規定的低限值的數值的例子。
 |  | 特殊字符 | 設置顯示的特殊字元。
 | 大於高限 | 文字顏色 | 設定高限值的文字顏色。
 |  | 背景色 | 設定高限值外型的背景色。
 |  | 顯示特殊字符取代數值 | 勾選在高過高限值時，設置一特殊字符，來代替數據的值超過規定的高限值的數值的例子。
 |  | 特殊字符 | 設置顯示的特殊字元。


7.3.1. 進階數值顯示器

進階數值顯示器

除了具有數值輸入和數值顯示兩種物件的所有特色之外，這個功能強大的物件還提供如下的特色:

1)能顯示算數運算式(顯示運算式)或顯示巨集所計算得出的結果。
2)能將算數運算式(輸出運算式)的結果或巨集(輸出巨集)所計算得出的數值寫出，作業員所輸入的數值可參加運算。
3)支援多達十個數值範圍可以設置。

■ 一般頁
詳閱章節7.3.4.說明

■ 範圍頁
詳閱章節7.3.5.說明

■ 進階頁
詳閱章節4.4.5.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 外標示頁
詳閱章節4.3.8.說明

■ 顯示巨集頁
詳閱章節15.2.6.說明

■ 輸出巨集頁
詳閱章節15.2.6.說明


7.3.2. 進階數值顯示器 - 功能選項

進階數值顯示器 - 功能選項

下表是進階數值顯示器中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
範圍顯示 | 進階數值顯示器最多可10組固定範圍或3組可變範圍。 使用者可設定每組範圍的文字顏色、背景色和低限值。在運行時，依數值大小決定範圍組及顏色。
範圍檢查 | 進階數值顯示器會檢驗所輸入的數值是否符合最大最小值的範圍。如果所輸入的數值超過範圍，數值將為無效的輸出。在範圍頁中進行此選項的設定。 註：如果已定義輸出算式或輸出巨集，將檢查儲存在變數$W的數值的範圍，而非輸入數值的範圍。
觸控有效 | 觸控有效或觸控無效可由指定的位或當前 使用者等級控制。在進階頁中，可進行此選項的設定。
超時取消 | 當一段時間未輸入任何資料，進階數值顯示器的鍵盤將會消失，且數值輸入的操作將會取消。
通知 | 當數值成功輸入後，物件會發送信號通知指定的位。在進階頁中，可進行此選項的設定。
操作員確認 | 當操作員輸入數值，會出現確認視窗。當操作員選“是”，則會執行進階數值顯示器的操作；當操作員選“否”，或在最長等待時間內沒有回應，則停止進階數值顯示器的操作。在進階頁中，可進行此選項的設定。
改變使用者等級 | 執行該操作後，可以改變 使用者當前的級別。在進階頁中，可進行此選項的設定。
操作記錄 | 勾選此選項，時間、輸入的數值和預設的訊息將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
指定鍵盤 | 在進階頁中整個人機物件都將有自己的系統以外的鍵盤，選擇鍵盤或自定義鍵盤，並設置這個選項。
顯現控制 | 進階數值顯示器的顯現與否，可由指定的位或當前 使用者等級控制。在顯現頁中，可進行此選項的設定。


7.3.3. 進階數值顯示器 - 設定

進階數值顯示器 - 設定

所有進階數值顯示器的設定都可在屬性視窗中完成。進階數值顯示器的屬性視窗包含以下七個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節7.3.4.說明

■ 範圍頁
詳閱章節7.3.5.說明

■ 進階頁
詳閱章節4.4.5.說明

■ 顯現頁
詳閱章節4.4.6.說明

■ 外標示頁
詳閱章節4.3.8.說明

■ 顯示巨集頁
詳閱章節15.2.6.說明

■ 輸出巨集頁
詳閱章節15.2.6.說明


7.3.4. 進階數值顯示器 - 一般設定

進階數值顯示器 - 一般設定

本章節說明進階數值顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性

 說明
編號 | 設定進階數值顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為ANDnnnn。
註 | 可加入說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。字元輸入/顯示時，背景色 選透明，這樣可以方便物件與下面的底圖搭配。如果勾選了“背景透明”，那麼字體背景顏色就不能更改。
外型 | 背景透明、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 | 勾選進階數值顯示器是否需要外標示。 在外標示頁可設定其屬性。
數據類別 | 變數、算式和巨集的數據類別，有以下的幾種：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。
顯示類別 | 設定進階數值顯示器的顯示類別，下表顯示每種數據類別下的顯示類別。
數據類別 | 支持顯示類別
16位正整數 | 16位十進制正整數、16位十六進制數、16位八進制數；指所對應的數據的顯示格式可選擇使用16位十進制正整數(0-65535)、16位十六進制數(0-FFFF)、16位八進制數(0-77777)。
32位正整數 | 32位十進制正整數、32位十六進制數、32位八進制數、密碼；指所對應的數據的顯示格式可選擇使用32位十進制正整數(0-65535)、32位十六進制數(0-FFFFFFFF)、32位八進制數(0-77777)。
16位整數 | 16位十進制整數
32位整數 | 32位十進制整數
16位BCD正整數 | 32位十進制整數
32位BCD正整數 | 32位十進制正整數
32位浮點數 | 32位浮點數
16位BCD整數(LMB) | 16位十進制整數(LMB：指 當最左一位 bit 為 1 時該數據表示為負數)
32位BCD整數(LMB) | 32位十進制整數(LMB：指 當最左一位 bit 為 1 時該數據表示為負數)
16位BCD整數(LMD) | 16位十進制整數 (LMD：指 當最左 4 個 bit 為 F 時該數據表示為負數)
32位BCD整數(LMD) | 32位十進制整數 (LMD：指 當最左 4 個 bit 為 F 時該數據表示為負數)
顯示值取得方式 監視地址

設定監視變數的地址。當選擇此選項後，使用者需設定監視變數。

點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
顯示算式

選擇是否顯示算式運算結果。選擇此選項，使用者需設定算式顯示的地址。算式範例如上圖顯示。

點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
顯示巨集 | 勾選此選項，進階數值顯示器會在顯示內部變數$D的數值前，先執行巨集頁中定義的巨集程式。巨集程式藉由儲存在內部變數$D的數值，決定顯示的數值。
允許操作員輸入 | 勾選是否允許操作員輸入數值。
寫入地址

當選擇允許操作員輸入，設定數值寫入的地址。

點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
輸出值取得方式 | 直接 | 勾選進階數值顯示器是否直接顯示輸入的數值。
輸出算式

勾選進階數值顯示器是否顯示算式結果的數值。此選項勾選後，使用者須設定算式，設定內部變數$K為輸入的數值，所輸入的數值為運算元。

點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
輸出巨集

勾選此選項，進階數值顯示器在寫入內部變數$W前，會執行在輸出巨集中所定義的巨集程式。巨集儲存所需的值在內部變數$W，以決定輸出的數值。使用在巨集指令中的鍵盤輸入數值當參數，設定內部鍵盤輸入值為$K。

字體 | 進階數值顯示器的字體。您可以使用下拉清單中選擇一種字體，或者單擊 [image] ，彈出字體範本對話框，選擇字體為當前文本。您可以在該對話框中選擇字體之前更改字體範本。
文字顏色 | 數值顯示的文字顏色。
總位數 設定顯示的總位數。

註：這項屬性適用於鍵盤操作的初始值、最大值和最小值。

小數位數

當數據種類是32位浮點數，則此選項為設定最大值和最小值的小數位數。

當數據種類不是32位浮點數，則此選項除了為最大值和最小值的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。當小數位數為一個非0的數N，輸入的數值在輸出前將依以下的公式轉換為整數。

輸出值=輸入值*(10的N次方)

範例一:

顯示類別 | 總位數 | 小數位數 | 調整 | 監視數值 | 顯示數值
32位浮點數 | 4 | 2 | 前頭去零 | 12.34 | 12.34
32位浮點數 | 4 | 2 | 前頭去零 | 123.4 | 23.40
16位十進制整數 | 5 | 2 | 前頭去零 | 12345 | 123.45
16位十進制整數 | 5 | 2 | 前頭去零 | -5 | -5.00

 範例二：
顯示類別 | 總位數 | 小數位數 | 輸入值 | 輸出數值
32位浮點數 | 4 | 2 | 12.34 | 12.34
32位浮點數 | 4 | 2 | 123.4 | Error!
16位十進制整數 | 5 | 2 | 123.45 | 12345
16位十進制整數 | 5 | 2 | -0.05 | -5
16位十進制整數 | 5 | 2 | 3 | 3.00
註：這項屬性適用於鍵盤操作的初始值、最大值和最小值。
排列 | 設定顯示數值的排列方式。有三種排列方式：居左、居中和居右。
調整 設定顯示值調整的方式。有三種調整方式：前頭去零、零領頭和空格領頭。
選項 | 說明
前頭去零 | 當前頭位數為0時，不顯示數字0。
零領頭 | 顯示所有位數的數字。
空格領頭 | 當前頭位數為0時，顯示空白字元。


7.3.5. 進階數值顯示器 - 範圍設定

進階數值顯示器 - 範圍設定

本章節說明進階數值顯示器範圍頁中各項屬性的設定。下圖是範圍頁的圖例。

下表為範圍頁中各項屬性的說明。

屬性 |  |  | 說明
範圍顯示 | 範圍顯示 |  | 勾選進階數值顯示器是否支援範圍顯示。進階數值顯示器支援最多10組固定範圍或3組可變範圍。 使用者可設定每組範圍的文字顏色、背景色和低限值。在運行時，依數值大小決定範圍及顏色。
 | 範圍低限值可變 |  | 勾選此選項，狀態1和2的低限值在運行時，由指定的變數決定。 當勾選範圍低限值可變，進階數值顯示器支援3組範圍。當未勾選範圍低限值可變，進階數值顯示器最多可支援10組範圍。 使用者需設定除了最低範圍外，每一組範圍的低限值。
 | 範圍組數 |  | 設定進階數值顯示器的範圍組數。
 | 範圍1(最高) | 低限值 | 當未勾選範圍低限值可變時，設定範圍1的低限值。當勾選範圍低限值可變，這選項設定在運行時，數值在範圍1最低限內的變數。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 |  | 數值色 | 設定範圍1 的數值顏色。
 |  | 背景色 | 設定範圍1 的背景色。
 |  | 閃爍 | 勾選範圍1 的數值，顯示時是否閃爍。
 | 範圍2 | 低限值 | 當未勾選範圍低限值可變時，設定範圍2的低限值。當勾選範圍低限值可變，這選項設定在運行時，數值在範圍2最低限內的變數。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 |  | 數值色 | 設定範圍2 的數值顏色。
 |  | 背景色 | 設定範圍2 的背景色。
 |  | 閃爍 | 勾選範圍2 的數值，顯示時是否閃爍。
 | 範圍3到範圍10 | 低限值 | 當範圍非最低範圍時，設定該範圍的低限值。
 |  | 數值色 | 設定範圍的數值顏色。
 |  | 背景色 | 設定範圍的背景色。
 |  | 閃爍 | 勾選範圍的數值，顯示時是否閃爍。
範圍檢查 | 範圍檢查 |  | 進階數值顯示器會檢驗所輸入的數值是否符合最大最小值的範圍。如果所輸入的數值超過範圍，數值將為無效的輸出。在範圍頁中進行此選項的設定。 註：如果定義了輸出算式與輸出巨集，將檢查儲存在變數$W的數值的範圍，而非輸入數值的範圍。
 | 範圍可變 |  | 勾選在運行時，最大值和最小值的範圍是否可變。當勾選範圍可變時，最小值/最大值會變更為由『暫存器位址 』來讀取『最大值』與『最小值』的值，如果暫存器的數值為一變動數，則最大值與最小值依此變動數，成為可變範圍。
 | 最小值 |  | 當未勾選範圍可變，設定最小值。當勾選範圍可變，在運行時，最小值依指定地址的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 | 最大值 |  | 當未勾選範圍可變，設定最大值。當勾選範圍可變，在運行時，最大值依指定地址的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。


7.4. 字符輸入器

字符輸入器

使用字符輸入器輸入字串，如果連接的人機是個人電腦，利用此物件可輸入Unicode文字(字串長度最多可達48個字母)。觸摸此文字輸入按鈕，觸控屏顯示系統內建ASCII文字鍵盤在螢幕上，您可以輸入ASCII文字(字串長度最多可達64個字母)，當按ENTER時觸控屏就送出文字給控制器相對應之暫存器。

■一般頁(General)

詳閱章節7.4.3.說明。

■進階頁(Advanced)

詳閱章節7.4.4.說明。

■顯現頁(Visibility)

詳閱章節4.4.6.說明。

■外標示頁(ExternalLabel)

詳閱章節4.3.8.說明。


7.4.1. 字符輸入器 - 功能選項

字符輸入器 - 功能選項

下表是字符輸入器中可增加的功能選項。選項的設定可在屬性對話框中完成。

選項 | 說明
觸控有效 | 觸控有效或觸控無效可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
超時取消 | 當一段時間未輸入任何資料，資料輸入的操作將會取消。
通知 | 當數據成功輸入後，物件會發送信號通知指定的位。在進階頁中，可進行此選項的設定。
操作員確認 | 當操作員輸入數值，會出現確認視窗。當操作員選是，則會執行字符輸入器的操作；當操作員選否，或在最長等待時間內沒有回應，則停止字符輸入器操作。 在進階頁中，可進行此選項的設定。
改變用戶等級 | 執行該操作後，可以改變用戶當前的級別。在“高級”頁面，選擇和設置這個選項。
操作記錄 | 勾選此選項，輸入的文字和時間將會被記錄在操作記錄中。在進階頁中，可進行此選項的設定。
指定鍵盤 | 整個人機物件都將有自己的系統以外的鍵盤.在高級頁中，選擇鍵盤或自定義鍵盤，並設置這個選項。
顯現控制 | 物件的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


7.4.2. 字符輸入器 - 設定

字符輸入器 - 設定

所有字符輸入器的設定都可在屬性視窗中完成。字符輸入器的屬性視窗包含以下四個頁面，某些頁面在需要設定時才會出現。

■一般頁(General)

詳閱章節7.4.3.說明。

■進階頁(Advanced)

詳閱章節7.4.4.說明。

■顯現頁(Visibility)

詳閱章節4.4.6.說明。

■外標示頁(ExternalLabel)

詳閱章節4.3.8.說明。


7.4.3. 字符輸入器 - 一般設定

字符輸入器 - 一般設定

本章節說明字符輸入器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定字符輸入器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為TEnnnn。
註 | 可加入說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。 字符輸入/顯示時背景色為透明，這樣可以方便字符物件下面的底圖搭配。如果勾選了“背景透明”，那麼字體背景顏色就不能更改。
外型 | 背景透明、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 | 勾選字符輸入器是否需要外標示。外標示頁可設定各項屬性。
字符 | 從以下四個字符集，選擇文字編碼方式。
 | 字符集 |  | 說明
 | ASCII (美國) |  | 定義128個字元，每個字元使用8或16位(Bit)。
 | ISO-8859-1 (西歐) |  | 涵蓋大部分西歐語言，每個字元使用8或16位(Bit)。
 | ISO-8859-5 (西里爾/斯拉夫) |  | 涵蓋大部分斯拉夫語言，每個字符使用8或16位。
 | Unicode (簡體與繁體) |  | 涵蓋大部分中文字。每個字符使用一個字。中文輸入部份，採用『拼音』輸入，然後顯示同音中文供選字。例如，輸入"PIN"，則會出現『拼』、『聘』、『品』等字供選字，輸入"YIN"，則會出現『音』、『因』、『引』等字供選字。
寫入地址 | 設定文字寫入的變數地址。 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
總字數 | 設定字符輸入之最大字數(2個ASCII文字佔1個Word)。
附加一個空字符 | 勾選此選項，字符輸入器附加一個空字元到輸入的字串之後。
接收USB條碼輸入 | 勾選此選項，字符輸入器將接收來自USB條碼掃描器的字符輸入。
高低位元組對調 | 勾選使字元存儲時 ，每個字元的高低位元組互相對調。
空字符結束 | 當未勾選『空字符結束』時，字符輸入器每次顯示時，不足設定字數的部份，都會以『空字元』補足字串到設定字數，但如果勾選『空字符結束』，則字符輸入器接收『空字元』後，就會以此當作此行數據的結尾，不再以『空字元』補足字串到設定字數。
密碼 | 勾選此選項，顯示的字元都會以" * "顯示，如同密碼。
監視地址與寫入地址相同 | 勾選監視地址是否與寫入地址相同。勾選此選項，不必重複輸入監視地址。當勾選監視後，即會出現此選項。
監視地址 | 設定監視變數的地址。 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
字體 | 可以在下拉列表中選擇一種字體，或單擊字體模板對話框 [image] 選擇當前顯示字符串的字體。
文字色 | 設定顯示字串的文字顏色。
排列 | 指定文字之顯示位置。有三種方式：居左、居中和居右。
字碼大小 | 有三種字碼可供選擇：
 | 種類 | 說明
 | 位元組 | 每一個字元佔用一個位元組(Byte)。
 | 字 | 每一個字元佔用一個字(Word)。
 | 當字符集為ASCII (美國)，西里爾/斯拉夫和ISO-8859-1 (西歐)時，此選項才會出現。
數據輸入 | 設定在運行時，數值輸入的方式。有兩個選項：彈出式鍵盤和常駐式鍵盤或功能鍵。
 | 選項 | 說明
 | 彈出式鍵盤 | 觸壓字符輸入器，畫面上會出現鍵盤。
 | 常駐式鍵盤或功能鍵 | 移動遊標，點擊功能按鈕中，選擇下一數據輸入物件或選擇前一數據輸入物件。如果畫面上有鍵盤，則可輸入數值。或者，利用功能鍵中的現值加一和現值減一調整寫入的數值。
 | 註：當勾選“常駐式鍵盤或功能鍵”，字符輸入器僅可在有輸入框(input focus)的物件輸入字串。欲使物件出現輸入框，可點擊該物件。


7.4.4. 字符輸入器 - 進階設定

字符輸入器 - 進階設定

本章節說明字符輸入器進階頁中各項屬性的設定。下圖是進階頁的圖例。

下表為進階頁中各項屬性的說明。

屬性 |  | 說明
觸控有效 | 受位控制 | 勾選觸控有效，是否受位控制。
 | 控制位 | 設定觸控有效的控制位。 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
 | 有效狀態 | 設定有效狀態為1或0。
 | 受用戶等級控制 | 勾選觸控操作字符輸入是否受用戶等級控制。
 | 最低有效等級 | 設定觸控操作有效的最低用戶等級。
 | 顯示觸控無效標示 | 勾選是否當觸控操作無效時，顯示觸控無效標示。
超時取消 | 超時取消 | 若超過一段指定的時間，未輸入任何數值，則將會取消字符輸入的操作。
 | 超時時間 | 設定字符輸入間隔的最大等待時間。如果在時間內沒有輸入，數值輸入鍵盤會關閉且輸入取消。
通知 | 通知 | 當字符成功輸入後，物件會發送信號通知指定的位。在進階頁中，可進行此選項的設定。
 | 訊號 | 通知的訊號有以下兩種：
 |  | 訊號 | 說明
 |  | 位階 | 設定特定位的狀態。
 |  | 脈衝 | 傳送正脈衝給指定的位。
 | 通知位 | 設定通知位。
 | 狀態 | 設定通知位狀態。
操作員確認 | 操作員確認 | 當操作員輸入 字符，會出現確認視窗。當操作員選是，則會執行字符輸入的操作；當操作員選否，或在最長等待時間內沒有回應，則停止字符輸入的操作。在進階頁中，可進行此選項的設定。
 | 最長等待時間 | 設定操作員確認的最長等待時間。如果超過等待時間， 字符輸入的操作將會取消。
改變用戶等級 | 改變用戶等級 | 執行完操作後，可以改變用戶當前的級別。在“高級”頁面，選擇和設置這個選項。
 | 新用戶等級 | 設置新的當前用戶等級。
操作記錄 | 操作記錄 | 勾選以下三個項目是否要寫入在操作記錄中。 1) 操作的時間。 2) 輸入的字符。 3) 預設的操作訊息。
 | 訊息 | 輸入第一種語言的要記錄的訊息。
 |  | 點擊此處，出現操作記錄訊息，可用所有的語言編輯操作訊息。
指定鍵盤 | 指定鍵盤 | 勾選此項，整個人機物件都將有系統以外的鍵盤在高級頁中，選擇鍵盤或自定義鍵盤，並設置這個選項。
 | 畫面 | 指定鍵盤的視窗畫面。


7.5. 字符顯示器

字符顯示器

字符顯示器可顯示儲存在變數中的字串。如果應用的人機為PC運行(組態)，此物件可以顯示Unicode文字。

提示：字符顯示器和文字物件的差異為：

字符顯示器可顯示文字、回應文字(requesttext)或兩者同時執行。字符顯示器無法在規劃畫面時設定文字，只允許在運行時設定。欲改變顯示的文字，使用者可更改關聯變數的定義。

文字物件可在規劃畫面時，用來標示控制器或物件的用途。無法在運行時作文字修改。

■一般頁
 詳閱章節7.5.3.說明

■顯現頁
 詳閱章節4.4.6.說明

■外標示頁
 詳閱章節4.3.8.說明


7.5.1. 字符顯示器 - 功能選項

字符顯示器 - 功能選項

下表是字符顯示器中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 字符顯示器的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


7.5.2. 字符顯示器 - 設定

字符顯示器 - 設定

所有字符顯示器的設定都可在屬性視窗中完成。字符顯示器的屬性視窗包含以下三個頁面，某些頁面在需要設定時才會出現。

■一般頁
 詳閱章節7.5.3.說明

■顯現頁
 詳閱章節4.4.6.說明

■外標示頁
 詳閱章節4.3.8.說明


7.5.3. 字符顯示器 - 一般設定

字符顯示器 - 一般設定

本章節說明字符顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定字符顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為TDnnnn。
註 | 可加入說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。 字符顯示時，背景色選透明，這樣可以方便字符物件下面的底圖搭配。如果勾選了“背景透明”，那麼字體背景顏色就不能更改。
外型 | 背景透明、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
外標示 | 勾選 字符顯示器是否需要外標示。外標示頁可設定各項屬性。
字符集 | 監視變量字符串的字符代碼類型。可從以下五個字符集，選擇文字編碼方式: ASCII (美國)，ISO-8859-1(西歐)， ISO-8895-5(西里爾/斯拉夫)，Unicode (中文簡體常用字與次常用字)，Unicode (中文繁體常用字與次常用字)。每個字符使用一個字(Word)。
作為按鍵輸入顯示 | 這是指當畫面中設計使用固定式鍵盤給相關的數值輸入元件作為Ten-key鍵盤時，此一選項表示這顯示物件將特定對應為鍵盤輸入顯示用，可以是ASCII 字符，也可以是0-9。
以星號(*)取代字符顯示 | 如果字符顯示用於自定義鍵盤，勾選此選項以顯示星號代替字符作顯示。
監視地址 | 設定監視變數的地址。 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
總字符數 | 設定字符顯示器，顯示的總字數。注意:ASCII文字顯示之文字數為2個ASCII文字佔1個Word。
空字符結束 | 當未勾選『空字符結束』時，字符輸入器每次顯示時，不足設定字數的部份，都會以『空字元』補足字串到設定字數，但如果勾選『空字符結束』，則字符輸入器接收『空字元』後，就會以此當作此行數據的結尾，不再以『空字元』補足字串到設定字數。
字體 | 設定顯示的字體。您可以使用下拉列表中選擇一種字體，或單擊字體模板對話框 [image] 選擇當前顯示字符串的字體。
文字顏色 | 設定顯示的文字顏色。
排列 | 指定字符顯示的排列方式。有三種排列方式：居左、居中和居右。
字碼大小 | 設定字碼的大小，可選擇位元組或字。
高低位元組對調 | 勾選使字符顯示時高低位元組對調。
字距 | 設置每個文字顯示時的間隔距離。


7.6. 時間顯示器

時間顯示器

時間顯示器可在人機上顯示時間。可讓使用者在專案上加入一時間物件，形式如HH:MM:SS(時：分：秒)。觸控屏直接讀取內部 時鐘(REAL TIME CLOCK)時間的值，顯示其內容在觸控螢幕上。

■ 一般頁
詳閱章節 7.6.1.說明


7.6.1. 時間顯示器 - 一般設定

時間顯示器 - 一般設定

所有時間顯示器的設定都可在屬性 視窗中完成。下圖是屬性視窗的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定時間顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為TDnnnn。
註 | 可加入說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。背景色 選透明，這樣可以方便物件下面的底圖搭配。
外型設置 | 背景透明、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
格式 | 設定時間顯示的格式，有多種格式可選擇。
 | 格式 | 說明
 | HH:MM | HH: 00-23 (hour); MM: 00-59 (minute)
 | HH:MM:SS | HH: 00-23 (hour); MM: 00-59 (minute); SS: 00-59 (second)
 | MM:SS | MM: 00-59 (minute); SS: 00-59 (second)
 | HH:MM PM | HH: 00-23 (hour); MM: 00-59 (minute); PM/AM: 午夜前 / 午夜後
 | HH:MM:SS PM | HH: 00-23 (hour); MM: 00-59 (minute); SS: 00-59 (second); PM/AM: 午夜前 / 午夜後
字體 | 設定顯示的字體。 可以使用下拉列表中選擇一種字體，或單擊 [image] 字體模板 視窗選擇當前顯示字符串的字體。
文字色 | 設定文字的顏色。
排列 | 設定文字顯示的排列方式。有三種排列方式：居左、居中和居右。


7.7. 日期顯示器

日期顯示器

日期顯示器可在人機上顯示日期。可讓使用者在專案上加入一日期物件，形式如yy:mm:dd或dd:mm:yy(日：月：年)。觸控屏直接讀取時鐘(REALTIMECLOCK)日期的值，顯示其內容在觸控螢幕上。

■ 一般頁
詳閱章節7.7.1.說明


7.7.1. 日期顯示器 - 一般設定

日期顯示器 - 一般設定

所有日期顯示器的設定都可在屬性視窗中完成。下圖是屬性視窗的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定日期顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為DDnnnn。
註 | 可加入物件的說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明。背景色選透明，這樣可以方便物件下面的底圖搭配。
外型設置 | 背景透明、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
格式 | 設定日期顯示的格式。如果您希望改變日期的形式，可下拉選擇所需要格式。選單中可選擇年月日的排列順序。有十三種格式可選擇：dd/mm/yy, mm/dd/yy, yy/mm/dd, dd.mm.yy, mm.dd.yy, yy.mm.dd, dd-mm-yy, mm-dd-yy, yy-mm-dd, dd-MMM-yy, MMM-dd-yy, 和 yy-MMM-dd。 註：dd: 01~31 (日); mm: 01~12 (月); yy: 00~99 (年); MMM: JAN~DEC (月)
字體 | 設定顯示的字體。可以使用下拉列表中選擇一種字體，或單擊 [image] 字體模板 視窗選擇當前顯示字符串的字體。
文字色 | 設定文字的顏色。
排列 | 設定文字顯示的排列方式。有三種排列方式：居左、居中和居右。


7.8. 周日顯示器

周日顯示器

週日顯示器可在人機上顯示星期。觸控屏直接讀取內部REALTIMECLOCK星期的對應值，顯示其內容在觸控螢幕上。

所有週日顯示器的設定都可在屬性視窗中完成。週日顯示器的屬性視窗包含以下二個頁面。

■ 一般頁
 詳閱章節7.8.2.說明

■ 文字頁
 詳閱章節4.3.6.說明

註：當在文字頁中設定個別日期對應的文字時，狀態0為星期日，狀態1為星期一，以此類推。


7.8.1. 周日顯示器 - 設定

周日顯示器 - 設定

所有週日顯示器的設定都可在屬性視窗中完成。週日顯示器的屬性視窗包含以下二個頁面。

■ 一般頁
 詳閱章節7.8.2.說明

■ 文字頁
 詳閱章節4.3.6.說明

註：當在文字頁中設定個別日期對應的文字時，狀態0為星期日，狀態1為星期一，以此類推。


7.8.2. 周日顯示器 - 一般設定

周日顯示器 - 一般設定

本章節說明週日顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定一周顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為DWnnnn。
註 | 可加入說明文字。
背景透明 | 勾選此選項後，物件的背景色為透明，背景色透明，這樣可以方便物件搭配下面的底圖。如果勾選了“背景透明”，那麼字體背景顏色就不能更改。
外型設置 | 背景透明、 [image] 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
狀態 | 選擇狀態0到6，可設定各個狀態的圖樣、圖樣色和背景色。狀態0對應星期日，狀態1對應星期一，以此類推。


8.1.1. 柱狀圖 - 基本功能

柱狀圖 - 基本功能

柱狀圖物件藉由柱狀圖長度的變化，顯示監視變數的數值。柱狀圖的長度隨數值而變化。柱狀圖支援刻度顯示，用戶可從刻度檢視柱狀圖的長度和監視變數的數值。

共有兩種類別的柱狀圖可供選擇：單極柱(PolarBar)和兩極柱(BipolarBar)。單極柱只往單一方向移動，而兩極柱可往兩個方向移動。柱狀圖和刻度可有以下四個顯示方向：

類別 | 往上 | 往下 | 往左 | 往右
單極柱 (監視數值=60) | upward-polar bar | downward-polar bar | leftward-polar bar | rightward-polar bar
兩極柱 (監視數值=60,中點=50) | upward-bipolar bar | downward-bipolar bar | leftward-bipolar bar | rightward-bipolar bar

柱狀圖可顯示刻度、前進標記、後退標記和百分比。

註:

l 兩極柱的柱狀圖不顯示前進標記和後退標記。

l 若柱狀圖顯示方向為往上或往下，刻度和前進/後退標記將會顯示在左邊或右邊。

l 若柱狀圖顯示方向為往左或往右，刻度和前進/後退標記將會顯示在頂部或底部。

■ 一般頁(General)

詳閱章節8.1.4.說明。

■ 刻度頁(Scale)

詳閱章節4.3.2.說明。

■ 前進標記頁(F.Marker)

詳閱章節8.1.5.說明。

■ 後退標記頁(B.Marker)

詳閱章節8.1.5.說明。

■ 進階頁(Advanced)

詳閱章節8.1.6.說明。

■ 顯現頁(Visibility)

詳閱章節4.4.6.說明。


8.1.2. 柱狀圖 - 功能選項

柱狀圖 - 功能選項

下表是柱狀圖中可增加的功能選項，可使柱狀圖顯示的訊息更豐富。選項的設定可在屬性對話框中完成。

選項 | 說明
說明 | 柱狀圖可以顯示監視變數數值和中點數值的差，顯示差值由中點往兩極移動，因此，稱為兩極柱。 bipolar 監視數值 數值中點＝50 在一般頁中，可進行此選項的設定。
刻度 | 柱狀圖可支援刻度顯示。在刻度頁中，可進行此選項的設定。
前進/後退標記 | 柱狀圖最多可顯示12個前進/後退標記，標記樣式可選擇正三角形、三角形、菱形和圓錐形。在運行時，標記的數量和標記相對應的數值是由前進標記控制區所決定。標記的數值決定標記的位置。標記數值與監視變數數值比較的結果，決定標記的顏色。 forwad-backward marker 在前進標記頁中，可進行前進標記選項的設定。 在後退標記頁中，可進行後退標記選項的設定。
範圍顯示 | 用戶可設定柱狀圖的低限值和高限值，限值可為常數或變數。在運行時，當監視變數的數值低於低限值，數值的文字和背景色會以設定的低位色顯示。當監視變數的數值高於高限值，數值的文字和背景色會以設定的高位色顯示。 在進階頁中，可進行此選項的設定。
百分比顯示 | 柱狀圖可以設定顯示當前柱狀圖長度與總長度的百分比比例。
 | 類別 |  | 百分比
 | 單極柱 | polar bar | D / L x 100%
 | 兩極柱 | 數值 < 中點 bipolar bar | -D / L x 100%
 |  | 數值 > 中點 bipolar bar | D / L x 100%
 | 在進階頁中，可進行此選項的設定。
顯現控制 | 設定柱狀圖的顯示與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


8.1.3. 柱狀圖 - 設定

柱狀圖 - 設定

所有柱狀圖的設定都可在屬性對話框中完成。柱狀圖的屬性對話框包含以下六個頁面。

■ 一般頁(General)

詳閱章節8.1.4.說明。

■ 刻度頁(Scale)

詳閱章節4.3.2.說明。

■ 前進標記頁(F.Marker)

詳閱章節8.1.5.說明。

■ 後退標記頁(B.Marker)

詳閱章節8.1.5.說明。

■ 進階頁(Advanced)

詳閱章節8.1.6.說明。

■ 顯現頁(Visibility)

詳閱章節4.4.6.說明。


8.1.4. 柱狀圖 - 一般設定

柱狀圖 - 一般設定

本章節說明柱狀圖一般頁中各項屬性的設定。下圖是柱狀圖屬性對話框中一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定柱狀圖的編號。當物件產生時，系統會自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為BGnnnn。
註 | 可加入物件的說明文字。
外型設置 | 可設定物件為不同的外型。邊框色、背景色的詳細說明，請參考章節4.3.4 設定物件外型。
外標示 | 勾選柱狀圖是否需要外標示。外標示頁可設定各項屬性。
方向 | 設定柱狀圖數值遞增的方向，提供往上/往下/往左/往右四種模式。
數據類別 | 設定監視變數的數據類別，支援的數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。
監視地址 | 設定監視變數的地址。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
動態範圍 | 勾選為在運行時，是否可更改監視變數的最大值和最小值。當勾選此選項，刻度記號的最大值和最小值在執行時可進行改變。在動態範圍參數區中，必須正確地設定最大最小值範圍的數據。動態範圍參數區欄位中，需設定動態範圍參數區的地址。
動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區。點擊 [image] 輸入地址，點擊 [image] 選取標籤。 下表顯示當數據類別是16位整數，柱狀圖的刻度不是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0 | 監視變數的最小值。
 | 1 | 監視變數的最大值。
 | 下表顯示當數據類別是16位整數，柱狀圖的刻度是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0 | 監視變數的最小值。
 | 1 | 監視變數的最大值。
 | 2, 3 | 刻度記號的最小值；32位整數。
 | 4, 5 | 刻度記號的最大值；32位整數。
 | 下表顯示當數據類別是32位整數，柱狀圖的刻度不是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0, 1 | 監視變數的最小值。
 | 2, 3 | 監視變數的最大值。
 | 下表顯示當數據類別是32位整數，柱狀圖的刻度是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0, 1 | 監視變數的最小值。
 | 2, 3 | 監視變數的最大值。
 | 4, 5 | 刻度記號的最小值；32位整數。
 | 6, 7 | 刻度記號的最大值；32位整數。
最小值 | 當未勾選動態範圍時，設定監視變數的最小值。
最大值 | 當未勾選動態範圍時，設定監視變數的最大值。
兩極柱 | 勾選此選項，柱狀圖將顯示監視變數數值與中點數值的差，中點欄位中可設定中點數值。
中點 | 設定兩極柱與監視數值比對的基準值。
柱圖樣 | 設定柱狀圖的圖樣，柱圖樣將填充柱狀圖物件。柱圖樣色會填充柱圖樣中黑色的部份；柱背景色會填充柱圖樣中白色的部份。
柱圖樣色 | 設定柱圖樣中，黑色部份的顏色。
柱背景色 | 設定柱圖樣中，白色部份的顏色。


8.1.5. 前進和後退的標記設定

前進和後退的標記設定

本章節說明柱狀圖前進/後退標記頁中各項屬性的設定。下圖是前進標記頁的範例。

下表為前進/後退標記頁中各項屬性的說明。

屬性 |  | 說明
記號總數 |  | 設定柱狀圖支援的記號總數。
位置 |  | 當柱狀圖方向往左或往右，設定標記位置為上或下；當柱狀圖方向往上或往下，設定標記位置為左或右。
前進/後退標記控制區 |  | 設定前進/後退標記控制區的變數地址，點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。標記控制區的暫存器排列如下：當標記位置該暫存器的數值改變；該標記位置就會對應柱狀圖實際位置跟著變化。 下表為當數據類別為16位整數，標記控制區的數據排列方式。
 |  | 字 | 說明
 |  | 0 | 記號總數
 |  | 1 | 記號 #1的位置參數
 |  | 2 | 記號 #2的位置參數
 |  | … | …
 |  | 12 | 記號 #12的位置參數
 |  | 下表為當數據類別為32位整數，標記控制區的數據排列方式。
 |  | 字 | 說明
 |  | 0,1 | 記號總數
 |  | 2,3 | 記號 #1的位置參數
 |  | 4,5 | 記號 #2的位置參數
 |  | … | …
 |  | 24,25 | 記號 #12的位置參數
 |  | 註：標記數值的格式與監視變數的格式相同。
記號編號1~記號編號12 | 樣式 | 設定記號的樣式，有四種選擇的樣式： mark styles
 | 外緣色 | 設定標記的外緣色。
 | 小於色 | 當監視變數的值小於標記的值，設定填充標記的顏色。
 | 等於色 | 當監視變數的值等於標記的值，設定填充標記的顏色。
 | 大於色 | 當監視變數的值大於標記的值，設定填充標記的顏色。


8.1.6. 柱狀圖 - 進階設定

柱狀圖 - 進階設定

本章節說明柱狀圖進階頁中各項屬性的設定。下圖是進階頁的範例。

下表為進階頁中各項屬性的說明。

屬性 |  |  | 說明
範圍顯示 | 範圍顯示 |  | 勾選當數值低於低限值或高於高限值時，是否顯示不同的顏色。
 | 範圍可變 |  | 勾選在運行時，最大值和最小值的範圍是否可變。
 | 低限值 |  | 當未勾選範圍可變，數值為低限值。當勾選範圍可變，在運行時，低限值依指定的內部記憶區的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 | 高限值 |  | 當未勾選範圍可變，數值為高限值。當勾選範圍可變，在運行時，高限值依指定的內部記憶區的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
 | 高位色 | 圖樣色 | 設定高限值的柱圖樣色。
 |  | 背景色 | 設定高限值的柱背景色。
 | 低位色 | 圖樣色 | 設定低限值的柱圖樣色。
 |  | 背景色 | 設定低限值的柱背景色。
百分比顯示 | 百分比顯示 |  | 勾選此選項，柱狀圖會顯示由以下公式所計算出來的百分比數值： 百分比 = (數值 – 最小值) / (最大值 – 最小值) * 100% 若使用兩極柱，當數值 > 中點時的公式為： 百分比 = (數值 – 中點) / (最大值 -中點) * 100% 當數值 < 中點時的公式為： 百分比 = (中點-數值) / (中點 – 最小值) * 100% 數值是監視變數的當前數值。最大值和最小值為數值表示的範圍，在屬性對話框的一般頁中可進行設定。
 | 文字顏色 |  | 設定百分比顯示的文字顏色。
 | 字型 |  | 設定百分比顯示的字型。


8.2.1. 儀表 - 基本功能

儀表 - 基本功能

儀表利用指針轉動至適當的位置，顯示監視變數的數值。指針轉動的角度隨數值大小而變化。儀表有圓/弧的刻度，用戶可從刻度觀察指針轉動的角度和監視變數的變化。儀表的樣式有以下幾種：

儀表裝置為一簡單的裝置，如同鐘錶一般，在一附有標示的圓輪上，以移動指針位置來表達數字。儀表裝置的外觀可根據您的需要做改變。您也可以使用儀表圖片，做出很有特色的儀表。最多可以插入32個儀表裝置在專案單一畫面上。

範圍和起點 | 360° & 90° | 360° & 0° | 360° & 270° | 360° & 180°
範例 | 360 & 90 | 360 & 0 | 360 270 | 360 180
範圍和起點 | 270° & 45° | 270° & 315° | 270° & 225° | 270° & 135°
範例 | 270 45 | 270 315 | 270 225 | 270 135
範圍和起點 | 180° & 90° | 180° & 0° | 180° & 270° | 180° & 180°
範例 | 180 90 | 180 0 | 180 270 | 180 180
範圍和起點 | 90° & 90° | 90° & 0° | 90° & 270° | 90° & 180°
範例 | 90 90 | 90 0 | 90 270 | 90 180
範圍和起點 | 90° & 45° | 90° & 315° | 90° & 225° | 90° & 135°
範例 | 90 45 | 90 315 | 90 225 | 90 135

註：儀表的外觀可以通過抗鋸齒的圖形功能得到改善。

儀表屬性框可以完成所有的設置。此對話框包含以下四個頁面。

■ 一般頁
詳閱章節 8.2.4.說明

■ 範圍頁
詳閱章節 8.2.5.說明

■ 刻度頁
詳閱章節 4.4.4.說 明

■ 顯現頁
詳閱章節 4.4.6.說明


8.2.2. 儀表 - 功能選項

儀表 - 功能選項

下表是儀表中可增加的功能選項，可使儀表顯示的訊息更豐富。選項的設定可在屬性對話框中完成。

選項 | 選項
範圍顯示 | 儀表在指針移動路徑上，可顯示低範圍標記和高範圍標記。在運行時，範圍標記的限值可由指定的變數控制。在範圍頁中，可進行此選項的設定。
刻度 | 儀表支援刻度顯示。在刻度頁中，可進行此選項的設定。
顯現控制 | 設定儀表的顯示與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


8.2.3. 儀表 - 設定

儀表 - 設定

所有儀表的設定都可在屬性對話框中完成。儀表的屬性對話框包含以下四個頁面。

■ 一般頁
詳閱章節 8.2.4.說明

■ 範圍頁
詳閱章節 8.2.5.說明

■ 刻度頁
詳閱章節 4.4.4.說 明

■ 顯現頁
詳閱章節 4.4.6.說明


8.2.4. 儀表 - 一般設定

儀表 - 一般設定

本章節說明儀表一般頁中各項屬性的設定。下圖是一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定儀表的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為Mnnnn。
註 |  | 可加入物件的說明文字。
背景透明 |  | 選擇這個選項，可使儀表的背景成為透明。
圖片外型 | 圖片外型 | 勾選是否使用圖片，作為儀表外型。用戶可以使用圖片設計所需儀表。如下圖： 註：當勾選圖片外型，外型…、邊框色、背景色欄位將無法設定。
 | <下拉式清單> | 顯示圖片的名稱。用戶可從下拉式清單中選擇資料庫的圖片。點陣圖可從外部檔案或是圖片檔案庫中選擇。
 |  | 點擊此圖標，可從檔案夾中導入圖片，選取所需的檔案將圖片檔導入。導入後的圖片將自動保存在圖片資料庫中。選擇檔案位置，點選欲使用的點陣圖，按下“導入”按鈕。
 |  | 點擊此圖標後，出現選取/導入圖庫內圖片對話框，可以從系統圖庫中導入圖片，在此可選擇欲使用的圖片，並應用在程式中。導入後的圖片將保存在資料庫中。
圖片外型設定 |  | 可設定物件為不同的外型。邊框色、背景色的詳細說明，請參考章節 4.3.4 設定圖片外型。
樣式 |  | 設定儀表的樣式。詳細說明，請參考章節 8.2.1基本功能。 左邊的樣式可比其他樣色有更寬廣的顯示空間，因為其可藉由改變中心X和Y的位置，使指針置於儀表之外。
方向 |  | 設定指針移動的方向。有分順時鐘以及逆時鐘2種選擇。
 |  | 逆時鐘 | 順時鐘
數據類別 |  | 監視變數的數據類別，支援的數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。
監視地址 |  | 設定監視變數的地址。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。儀表圖會讀取指定的暫存器數值並以儀表的方式顯示出來。 儀表的應用可選擇為『高塔吊車』，以下為高塔吊車應用的內部記憶區字地址，數據類型為16位：
 |  | 字 | 參數
 |  | 0 | 吊臂顯示角度位置。有效值為0到360度。
 |  | 1 | 起重機吊鉤位置與中心之間的距離。
 |  | 2 | 起重臂的迴轉半徑。此吊臂長度是使用液晶解析點數計算的。
 |  | 3 | 平衡臂的長度也就是後尾吊臂的尾端和中心之間的距離。
 |  | 4 | 高塔吊車中心的X位置是相對於觸控屏左上角。
 |  | 5 | 高塔吊車中心的Y位置是相對觸控屏左上角。
 |  | 6 | 矩形保護區的左上角的X位置。
 |  | 7 | 矩形保護區的左上角的Y位置。
 |  | 8 | 矩形保護區的右下角的X位置。
 |  | 9 | 矩形保護區的右下角的Y位置。
 |  | 下表顯示了高塔吊車應用的內部記憶區字地址，數據類型為32位：
 |  | 字 | 參數
 |  | 0,1 | 吊臂顯示角度位置。有效值為0到360度。
 |  | 2,3 | 起重機吊鉤位置與中心之間的距離。
 |  | 4,5 | 起重臂的迴轉半徑。此吊臂長度是使用液晶解析點數計算的。
 |  | 6,7 | 平衡臂的長度也就是後尾吊臂的尾端和中心之間的距離。
 |  | 8,9 | 高塔吊車中心的X位置是相對於觸控屏左上角。
 |  | 10,11 | 高塔吊車中心的Y位置是相對觸控屏左上角。
 |  | 12,13 | 矩形保護區的左上角的X位置
 |  | 14,15 | 矩形保護區的左上角的Y位置。
 |  | 16,17 | 矩形保護區的右下角的X位置。
 |  | 18,19 | 矩形保護區的右下角的Y位置。
 |  | 註：如果塔式起重機的旋轉軌道超出了保護區範圍，軌道將不被繪製。
動態範圍 | 動態範圍 | 勾選在運行時，是否可更改變數的最大值和最小值。當勾選此選項，刻度記號的最大值和最小值在執行時也可改變。在動態範圍參數區中，必須正確地設定最大最小值範圍的數據。動態範圍參數區欄位中需設定動態範圍參數區的地址。 動態範圍參數區是一塊連續的字位置，儲存著這個物件需要的全部動態範圍參數。當物件顯示數據時，會依據動態範圍參數區內當時的設定來繪製內容。考量通訊的效能，動態範圍參數區儘量不要使用外部字位置。在一般情況下，由於動態範圍無須時時更新，若需要從外部取得，利用巨集取得後放入內部位置會是較好的方式。動態範圍參數區內的數據排列方式有兩種，分別針對16位元數據和32位元數據。動態範圍參數區內的未使用數據項可以忽略不理。
 | 動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區。點擊 [image] 輸入地址，點擊 [image] 選取標籤。 下表顯示當數據類別是16位數，儀表的刻度不是動態的，參數區的數據排列方式，總共2個字。
 |  | 字 | 參數
 |  | 0 | 數據最小值；16位整數或16位正整數
 |  | 1 | 數據最大值；同上
 |  | 下表顯示當數據類別是16位數，儀表的刻度是動態的，參數區的數據排列方式，總共6個字。
 |  | 字 | 參數
 |  | 0 | 數據最小值；16位整數或16位正整數
 |  | 1 | 數據最大值；同上
 |  | 2, 3 | 刻度標示最小值；32位整數
 |  | 4, 5 | 刻度標示最大值；32位整數
 |  | 下表顯示當數據類別是32位正整數，儀表的刻度不是動態的，參數區的數據排列方式，總共4個字。
 |  | 字 | 參數
 |  | 0, 1 | 數據最小值；32位整數、32位正整數或32位浮點數
 |  | 2, 3 | 數據最大值；同上
 |  | 下表顯示當數據類別是32位正整數，儀表的刻度是動態的，參數區的數據排列方式，總共8個字。
 |  | 字 | 參數
 |  | 0, 1 | 數據最小值；32位整數、32位正整數或32位浮點數
 |  | 2, 3 | 數據最大值；同上
 |  | 4, 5 | 刻度標示最小值；32位整數
 |  | 6, 7 | 刻度標示最大值；32位整數
最小值 |  | 當未勾選動態範圍時，設定監視變數的最小值。 數據範圍可以超越-1000000和1000000。
最大值 |  | 當未勾選動態範圍時，設定監視變數的最大值。 數據範圍可以超越-1000000和1000000。
迴旋調整 | 半徑 | 用戶可利用此選項調整指針的半徑，以預設的半徑為基準做調整。此選項主要是在設定儀表物件的半徑。
 | 角度 | 用戶可利用此選項調整指針迴旋的角度，以預設的角度為基準做調整。此選項主要是在設定儀表物件的角度。
 | 中心點X | 用戶可利用此選項調整儀表中心點的水平位置，以預設的水準位置為基準做調整。設定儀表物件的中心X位置。
 | 中心點Y | 用戶可利用此選項調整儀表中心點的垂直位置，以預設的垂直位置為基準做調整。設定儀表物件的中心Y位置。
指針 | 類型 | 指針有兩種類型可以選擇：
 |  | 類型 | 說明
 |  | 1 |
 |  | 2 |
 | 顏色 | 指定儀表上指針的顏色。
 | 針座大小 | 當選擇指針種類為第二種：『圓形針座』時，可指定針座的大小。
應用 | 種類 | 儀表的應用種類選擇：
 |  | 種類 | 說明
 |  | 一般 | 對於一般應用，指針所指示的位置可顯示一個監視數值的變化。
 |  | 高塔吊車 | 塔式起重機，它顯示了吊臂旋轉和吊鉤的位置。有關詳細信息，請參見8.2.6節。防碰撞系統，高塔吊車。
 | 中心點顏色 | 只有當應用種類為高塔吊車时，可選擇中心點的顏色。
 | 吊鉤位置顏色 | 只有當應用種類為高塔吊車时，可選擇吊鉤位置顏色。


8.2.5. 儀表 - 範圍設定

儀表 - 範圍設定

本章節說明儀表範圍頁中各項屬性的設定。下圖是範圍頁的範例。

下表為範圍頁中各項屬性的說明。

屬性 | 說明
範圍顯示 | 勾選儀表指針迴旋區域是否顯示範圍標記。
範圍顯示 | 勾選在運行時，範圍標記的高限值和低限值是否由指定的變數決定。
低限值 | 當未勾選範圍可變，數值為低限值。當勾選範圍可變，在運行時，低限值依指定位的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
高限值 | 當未勾選範圍可變，數值為高限值。當勾選範圍可變，在運行時，高限值依指定位的變數決定。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
低位色 | 設定低範圍標記的顏色。
高位色 | 設定高範圍標記的顏色。


8.2.6. 高塔吊車防碰撞系統

高塔吊車防碰撞系統

儀表物件可以通過監視數值，作為高塔吊車的防碰撞系統應用。下面是使用三個儀表物件作為防碰撞系統的範例，它能避免在同一區域的高塔吊車相撞。

你可以設定物件完成以下功能：

1) 指示針擺動表示吊臂旋轉的角度。

2) 在運行時移動或指定吊鉤的位置。

3) 使用圓形的物件，使您能夠測量吊臂的旋轉角度，並顯示監視變量的當前值。

4) 指定任何類型的高塔吊車的平衡臂長度。

5) 顯示旋轉軌道與不同類型的擺動。

6) 指定矩形保護區，確保吊車安全的工作區域。


8.3.1. 扇形圖 - 基本功能

扇形圖 - 基本功能

扇形圖利用扇形圓弧的長度變化，顯示監視變數的數值。扇形的長度隨數值大小而變化。扇形圖有圓/弧的刻度，用戶可從刻度觀察指針轉動的角度和監視變數的數值。扇形圖的樣式有以下幾種：

範圍和起點 | 360° & 90° | 360° & 0° | 360° & 270° | 360° & 180°
範例 | 360 90 | 360 0 | 360 270 | 360 180
範圍和起點 | 270° & 45° | 270° & 315° | 270° & 225° | 270° & 135°
範例 | 270 45 | 270 315 | 270 225 | 270 135
範圍和起點 | 180° & 90° | 180° & 0° | 180° & 270° | 180° & 180°
範例 | 180 90 | 180 0 | 180 270 | 180 180
範圍和起點 | 90° & 90° | 90° & 0° | 90° & 270° | 90° & 180°
範例 | 90 90 | 90 0 | 90 0 | 90 180
範圍和起點 | 90° & 45° | 90° & 315° | 90° & 225° | 90° & 135°
範例 | 90 45 | 90 315 | 90 225 | 90 135

可在扇形圖屬性對話框完成所有扇形圖相關的設置。此對話框包含以下四個頁面。

■ 一般頁
詳閱章節 8.3.4.說明

■ 刻度頁
詳閱章節 4.4.4.說明

■ 進階頁
詳閱章節 8.1.6.說明

■ 顯現頁
詳閱章節 4.4.6.說明


8.3.2. 扇形圖 - 功能選項

扇形圖 - 功能選項

下表是扇形圖中可增加的功能選項，可使扇形圖顯示的訊息更豐富。選項的設定可在屬性對話框中完成。

選項 | 說明
範圍顯示 | 用戶可設定扇形圖顯示的低限值和高限值，限值可為常數或變數。在運行時，當監視變數的數值低於低限值，扇形圖的圖樣色和背景色會顯示低位色的設定；當監視變數的數值高於高限值，扇形圖的圖樣色和背景色會顯示高位色的設定。
百分比顯示 | 扇形圖可以顯示當前扇形圖長度與總長度的百分比比例。 current bar 在進階頁中，可進行此選項的設定。
刻度 | 扇形圖可支援刻度顯示。在刻度頁中，可進行此選項的設定。
顯現控制 | 設定扇形圖的顯示與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


8.3.3. 扇形圖 - 設定

扇形圖 - 設定

所有扇形圖的設定都可在屬性對話框中完成。扇形圖的屬性對話框包含以下四個頁面。

■ 一般頁
詳閱章節 8.3.4.說明

■ 刻度頁
詳閱章節 4.4.4.說明

■ 進階頁
詳閱章節 8.1.6.說明

■ 顯現頁
詳閱章節 4.4.6.說明


8.3.4. 扇形圖 - 一般設定

扇形圖 - 一般設定

本章節說明扇形圖一般頁中各項屬性的設定。

circular bar graph

上圖是扇形圖一般頁的範例。下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定扇形圖的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為PGnnnn。
註 | 可加入物件的說明文字。
外型設置 | 可設定物件為不同的外型。邊框色、背景色的詳細說明，請參考章節4.3.4 設定物件外型。
樣式 | 設定扇形圖的樣式，詳細說明，請參考章節8.3.1 基本功能。
方向 | 設定扇形圖指針移動的方向。目前只有順時針方向一種選擇。
數據類別 | 監視變數的數據類別，支援的數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數。
監視地址 | 設定監視變數的地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
動態範圍 | 勾選在運行時，是否可更改監視變數的最大值和最小值。當勾選此選項，刻度記號的最大值和最小值在運行時也可改變。在動態範圍參數區中，必須正確地設定最大最小值範圍的數據。動態範圍參數區欄位中需設定動態範圍參數區的地址。
動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區。點擊 [image] 輸入地址，點擊 [image] 選取標籤。 下表顯示當數據類別是16位整數，扇形圖的刻度設定不是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0 | 監視變數的最小值。
 | 1 | 監視變數的最大值。
 | 下表顯示當數據類別是16位整數，扇形圖的刻度設定是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0 | 監視變數的最小值。
 | 1 | 監視變數的最大值。
 | 2, 3 | 刻度記號的最小值；32位整數。
 | 4, 5 | 刻度記號的最大值；32位整數。
 | 下表顯示當數據類別是32位整數，扇形圖的刻度設定不是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0, 1 | 監視變數的最小值。
 | 2, 3 | 監視變數的最大值。
 | 下表顯示當數據類別是32位整數，扇形圖的刻度設定是動態的，參數區的數據排列方式。
 | 字 | 參數
 | 0, 1 | 監視變數的最小值。
 | 2, 3 | 監視變數的最大值。
 | 4, 5 | 刻度記號的最小值；32位整數。
 | 6, 7 | 刻度記號的最大值；32位整數。
最小值 | 當未勾選動態範圍時，設定監視變數的最小值。
最大值 | 當未勾選動態範圍時，設定監視變數的最大值。
扇形圖樣 | 設定扇形圖圖樣，圖樣將填充扇形圖的圓/弧範圍。當圖樣填入後，扇形圖樣色會填充圖樣的黑色部份；扇形背景色會填充圖樣的白色部份。
扇形圖樣色 | 設定填充扇形圖樣黑色部份的顏色。
扇形背景色 | 設定填充扇形圖樣白色部份的顏色。
底色 | 設定扇形圓/弧範圍的底色。


8.4.1. 曲線圖 - 基本功能

曲線圖 - 基本功能

曲線圖藉由在座標圖上畫出數據點的位置，並將每個點依序連接，顯示資料的特性。數據點的垂直位置是由數據的數值所決定；資料點的水平位置是由數據的次序所決定。

曲線圖最多可顯示8組數據，下圖是3組數據的範例。

用戶可利用游標選擇所需的數據點。曲線圖的游標為一垂直的線段，用戶可以水平的移動游標至所需的數據點。所選擇數據點的數值會顯示在螢幕上，並輸出到內部記憶區“游標數據接收區”。

曲線圖不僅可以水平顯示，更可以支援垂直顯示，也可以採用背景透明的方式增加此物件的實用性。

可在曲線圖屬性對話框完成所有曲線圖相關的設置。此對話框包含以下四個頁面。

■ 一般頁(General)

詳閱章節 8.4.4.說明。

■ 筆頁(Pen)

詳閱章節 8.4.5.說明。

■ 軸頁(XY Axis)

詳閱章節 8.4.6.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


8.4.2. 曲線圖 - 功能選項

曲線圖 - 功能選項

下表是曲線圖中可增加的功能選項。選項的設定可在屬性對話框中完成。

選項 | 說明
顯現控制 | 設定曲線圖的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


8.4.3. 曲線圖 - 設定

曲線圖 - 設定

所有曲線圖的設定都可在屬性對話框中完成。曲線圖的屬性對話框包含以下四個頁面。

■ 一般頁(General)

詳閱章節 8.4.4.說明。

■ 筆頁(Pen)

詳閱章節 8.4.5.說明。

■ 軸頁(XY Axis)

詳閱章節 8.4.6.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


8.4.4. 曲線圖 - 一般設定

曲線圖 - 一般設定

本章節說明曲線圖一般頁中各項屬性的設定。下圖是一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定曲線圖的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為LCnnnn。
註 |  | 可加入物件的說明文字。
背景透明 |  | 選擇這個選項，物件背景成為透明。
外 框 |  | 可設定物件為不同的外型。邊框色、背景色、圖底色的詳細說明，請參考章節 4.3.4 設定物件外型。
圖底色 |  | 設定圖表的底色。
數據類別 |  | 曲線圖顯示的數據類別，支援的數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。
讀取之觸發位 |  | 設定觸發曲線圖讀取和顯示數據的觸發位。當位變數的狀態由0變成1時，觸發曲線圖讀取數據。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
讀取地址 |  | 欲讀取變數的地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。 下表顯示變數的數據排列方式。 數據類別：16位整數；數據組數：1組
 |  | 字 | 說明
 |  | 0 | 實際數據點數
 |  | 1 | 數據點0
 |  | 2 | 數據點1
 |  | … | …
 |  | n+1 | 數據點n+1
 |  | 脈衝 | 發送一個脈衝到指定位。
 |  | 數據類別：16位整數；數據組數：2組
 |  | 字 | 說明
 |  | 0 | 實際數據點數
 |  | 1 | 數據點0；數據組1
 |  | 2 | 數據點0；數據組2
 |  | 3 | 數據點1；數據組1
 |  | 4 | 數據點1；數據組2
 |  | … | …
 |  | 2n+1 | 數據點n；數據組1
 |  | 2n+2 | 數據點n；數據組2
 |  | 數據類別：16位整數；數據組數：8組
 |  | 字 | 說明
 |  | 0 | 實際數據點數
 |  | 1 | 數據點0；數據組1
 |  | 2 | 數據點0；數據組2
 |  | 3 | 數據點0；數據組3
 |  | 4 | 數據點0；數據組4
 |  | 5 | 數據點0；數據組5
 |  | 6 | 數據點0；數據組6
 |  | 7 | 數據點0；數據組7
 |  | 8 | 數據點0；數據組8
 |  | 9 | 數據點1；數據組1
 |  | 10 | 數據點1；數據組2
 |  | … | …
 |  | 8n+7 | 數據點n；數據組7
 |  | 8n+8 | 數據點n；數據組8
 |  | 數據類別：32位整數；數據組數：1組
 |  | 字 | 說明
 |  | 0,1 | 實際數據點數
 |  | 2,3 | 數據點0
 |  | 4,5 | 數據點1
 |  | … | …
 |  | 2n+2, 2n+3 | 數據點n
 |  | 數據類別：32位整數；數據組數：2組
 |  | 字 | 說明
 |  | 0,1 | 實際數據點數
 |  | 2,3 | 數據點0；數據組1
 |  | 4,5 | 數據點0；數據組2
 |  | 6,7 | 數據點1；數據組1
 |  | 8,9 | 數據點1；數據組2
 |  | … | …
 |  | 4n+2, 4n+3 | 數據點n；數據組1
 |  | 4n+4, 4n+5 | 數據點n；數據組2
 |  | 數據類別：32位整數；數據組數：8組
 |  | 字 | 說明
 |  | 0,1 | 實際數據點數
 |  | 2,3 | 數據點0；數據組1
 |  | 4,5 | 數據點0；數據組2
 |  | 6,7 | 數據點0；數據組3
 |  | 8,9 | 數據點0；數據組4
 |  | 10,11 | 數據點0；數據組5
 |  | 12,13 | 數據點0；數據組6
 |  | 14,15 | 數據點0；數據組7
 |  | 16,17 | 數據點0；數據組8
 |  | 18,19 | 數據點1；數據組1
 |  | 20,21 | 數據點1；數據組2
 |  | … | …
 |  | 16n+14, 16n+15 | 數據點n；數據組7
 |  | 16n+16, 16n+17 | 數據點n；數據組8
數據組數 |  | 設定曲線圖的數據組數。每組數據可繪製一條曲線，最多可顯示8條曲線。
每組數據之可能最多點數 |  | 設定每組數據可顯示的最大數據點數。曲線圖最多可顯示255個數據點。 取樣規則如下，如設讀取位置D100，2條曲線，則D100=實際取樣點數， D101=第一條曲線第1點 D102=第二條曲線第1點 D103=第一條曲線第2點 D104=第二條曲線第2點 ： ： 當觸發旗標=ON時，觸控屏會把這一連串數值轉換為曲線後顯示在觸控屏幕上。 註：在運行時，需設定每組數據的實際數據點數。實際數據點數不能大於最大數據點數。
數據點水平位置 |  | 設定數據點水平分佈位置，有以下二種：
 |  | 方式 | 說明
 |  | 按可能最多點數平均分佈 | 每組數據的數據點，按可能最多數據點數，平均的分佈在曲線圖的水平線上。因此，相鄰兩數據點的距離是固定的。
 |  | 按實際點數平均分佈 | 每組數據的數據點，按實據數據點數，平均的分佈在曲線圖的水平線上。當實際數據點數減少，相鄰兩數據點的距離將增加。
方向 |  | 設定數據點連線的方向。
畫點標記 |  | 勾選是否在數據點上顯示方形標記。
畫連接線 |  | 勾選是否畫連接線連接每個數據點。
清除之觸發位 |  | 當位變數的狀態由0變成1，觸發曲線圖清除內容。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
游標 | 顯示游標 | 勾選是否顯示游標。移動游標可選擇所需的數據點。
 | 清除之觸發位 | 設定游標的顏色。
 | 數值顯示字型 | 設定數據點數值顯示字型。
 | 游標數據接收區 | 設定接收數據點數值的變數。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。 下表顯示數據類別為16位整數，接收區的數據排列方式。
 |  | 字 | 說明
 |  | 0 | 游標所選擇的數據組的序號。
 |  | 1 | 數據組1中，所選擇數據點的數值。
 |  | 2 | 數據組2中，所選擇數據點的數值。
 |  | … | …
 |  | 8 | 數據組8中，所選擇數據點的數值。
 |  | 下表顯示數據類別為32位，接收區的數據排列方式。
 |  | 字 | 說明
 |  | 0,1 | 游標所選擇的數據組的序號。
 |  | 2,3 | 數據組1中，所選擇數據點的數值。
 |  | 4,5 | 數據組2中，所選擇數據點的數值。
 |  | … | …
 |  | 16,17 | 數據組8中，所選擇數據點的數值。
動態範圍 | 動態範圍 | 勾選在運行時，是否可更改筆的最大值和最小值。當勾選此選項，X軸和Y軸標記的最大值和最小值在執行時也可改變。在動態範圍參數區中，必須正確地設定最大最小值範圍的數據。動態範圍參數區欄中需設定動態範圍參數區的地址。
 | 動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區。點擊 [image] 輸入地址，點擊 [image] 選取標籤。 下表顯示當數據類別是16位數，參數區的數據排列方式。
 |  | 字 | 說明
 |  | 0,1 | X軸刻度標示的最小值；32位整數。
 |  | 2,3 | X軸刻度標示的最大值。32位整數。
 |  | 4,5 | Y軸刻度標示的最小值。32位整數。
 |  | 6,7 | Y軸刻度標示的最大值。32位整數。
 |  | 8 | 筆#1的最小值；16位整數或16位正整數。
 |  | 9 | 筆#1的最大值；同上。
 |  | 10 | 筆#2的最小值；同上。
 |  | 11 | 筆#2的最大值；同上。
 |  | … | …
 |  | 22 | 筆#8的最小值；同上。
 |  | 23 | 筆#8的最大值；同上。
 |  | 下表顯示當數據類別是32位數，參數區的數據排列方式。
 |  | 字 | 說明
 |  | 0,1 | X軸刻度標示的最小值；32位整數。
 |  | 2,3 | X軸刻度標示的最大值。32位整數。
 |  | 4,5 | Y軸刻度標示的最小值。32位整數。
 |  | 6,7 | Y軸刻度標示的最大值。32位整數。
 |  | 8,9 | 筆#1的最小值；32位整數、32位正整數或32位浮點數。
 |  | 10,11 | 筆#1的最大值；同上。
 |  | 12,13 | 筆#2的最小值；同上。
 |  | 14,15 | 筆#2的最大值；同上。
 |  | … | …
 |  | 36,37 | 筆#8的最小值；同上。
 |  | 38,39 | 筆#8的最大值；同上。


8.4.5. 曲線圖 - 筆設定

曲線圖 - 筆設定

本章節說明曲線圖的筆頁中各項屬性的設定。下圖是筆頁的範例。

下表為筆頁中各項屬性的說明。注意，筆#1對應數據組1；筆#2對應數據組2，以此類推。

屬性 |  | 說明
筆#1 ~ 筆#8 | 動態範圍 | 勾選在運行時，是否可更改關聯數據組的最大值和最小值。當勾選一般頁中的動態範圍，此選項才會出現。
 | 最小值 | 設定關聯數據組的最小值。當未勾選動態範圍時，此選項才會出現。
 | 最大值 | 設定關聯數據組的最大值。當未勾選動態範圍時，此選項才會出現。
 | 最大值 | 設定數據點標記的大小。當勾選一般頁中的畫點標記，此項設定才有效。
 | 標記大小 | 設定連接線的樣式。當勾選一般頁中的畫連接線，此項設定才有效。
 | 線樣式 | 設定連接線的顏色。
 | 顯示數值 | 設定數據點數值的顯示方式，有以下三種選擇：
 |  | 顯示數值 | 說明
 |  | (無) | 不顯示數據點的數值。
 |  | 原始值 | 顯示未經調整的數據點數值。
 |  | 刻度值 | 顯示數據點對應到Y軸的數值。
 |  | 勾選在一般頁中的顯示游標，此項設定才有效。
 | 填充 | 勾選此項，可以用圖樣和顏色填充曲線以下的部分。
 |  | 填充 | 說明
 |  | 填充圖樣 | 指定圖樣樣式。
 |  | 圖樣色 | 指定填充圖樣的顏色。
 |  | 背景色 | 指定填充區背景顏色。


8.4.6. 曲線圖 - 軸設定

曲線圖 - 軸設定

本章節說明曲線圖的軸頁中各項屬性的設定。

下圖為軸頁的範例。

下表為軸頁中各項屬性的說明。

屬性 |  | 屬性
X軸 | 顯示刻度 | 勾選X軸是否顯示刻度。
 | 顯示Y軸格線 | 勾選X軸上是否顯示垂直格線。
 | 軸/刻度顏 | 設定X軸軸線和刻度的顏色。
 | 格線顏色 | 設定垂直格線顏色。
 | 主分隔數 | 設定X軸主分隔線的個數，最小值為1。
 | 次分隔數 | 設定兩相鄰主分隔線間的分隔線個數，最小值為1。
標示 | 顯示刻度標示 | 勾選是否顯示刻度標示。
 | 字體 | 設定刻度標示的字體。
 | 動態範圍 | 勾選在運行時，標示的最大值和最小值是否由動態範圍參數區的關聯物件所控制。
 | 最小值 | 設定刻度標示的最小值。最小值為32位整數。
 | 最大值 | 設定刻度標示的最大值。最大值為32位整數。
 | 總位數 | 設定刻度標示顯示的總位數。
 | 總位數 | 設定刻度標示的小數位數。當最大值為5000，總位數為4，小數位數為2，刻度標示顯示為50.00。
Y軸 | 顯示刻度 | 勾選Y軸是否顯示刻度。
 | 顯示X軸格線 | 勾選Y軸上是否顯示水平格線。
 | 軸/刻度顏色 | 設定Y軸軸線和刻度的顏色。
 | 格線顏色 | 設定水平格線顏色。
 | 主分隔數 | 設定Y軸主分隔線的個數，最小值為1。
 | 次分隔數 | 設定兩相鄰主分隔線間的分隔線個數，最小值為1。
標示 | 顯示刻度標示 | 勾選是否顯示刻度標示。
 | 字體 | 設定刻度標示的字體。
 | 動態範圍 | 勾選在運行時，標示的最大值和最小值是否由動態範圍參數區的關聯物件所控制。
 | 最小值 | 設定刻度標示的最小值。最小值為32位整數。
 | 最大值 | 設定刻度標示的最大值。最大值為32位整數。
 | 總位數 | 設定刻度標示顯示的總位數。
 | 小數位數 | 設定刻度標示的小數位數。當最大值為5000，總位數為4，小數位數為2，刻度標示顯示為50.00。


8.5.1. 二維分佈圖 - 基本功能

二維分佈圖 - 基本功能

二維分佈圖藉由在座標圖上點出數據點的位置，並將每個點依序連接，顯示資料的特性。每個資料點包含X軸座標和Y軸座標。X軸座標決定數據點的垂直位置；Y軸座標決定數據的水平位置。

二維分佈圖最多可顯示8組數據。下圖為3組數據的二維分佈圖。

■一般頁(General)

詳閱章節8.5.4.說明。

■筆頁(Pen)

詳閱章節8.5.5.說明。

■軸頁(XYAxis)

詳閱章節8.4.6.說明。

■顯現頁(Visibility)

詳閱章節4.4.6.說明。


8.5.2. 二維分佈圖 - 功能選項

二維分佈圖 - 功能選項

下表是二維分佈圖中可增加的功能選項。選項的設定可在屬性對話框中完成。

選項 | 說明
顯現控制 | 設定二維分佈圖的顯示與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


8.5.3. 二維分佈圖 - 設定

二維分佈圖-設定

所有二維分佈圖的設定都可在屬性對話框中完成。二維分佈圖的屬性對話框包含以下四個頁面。

■一般頁(General)

詳閱章節8.5.4.說明。

■筆頁(Pen)

詳閱章節8.5.5.說明。

■軸頁(XYAxis)

詳閱章節8.4.6.說明。

■顯現頁(Visibility)

詳閱章節4.4.6.說明。


8.5.4. 二維分佈圖 - 一般設定

二維分佈圖 - 一般設定

本章節說明二維分佈圖一般頁中各項屬性的設定。下圖是一般頁的範例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定二維分佈圖的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為SCnnnn。
註 |  | 可加入物件的說明文字。
背景透明 |  | 選擇這個選項，物件背景成為透明。
外型設置 |  | 可設定物件為不同的外型。邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
圖底色 |  | .設定二維分佈圖的底色。
數據類別 |  | 設定二維分佈圖顯示的數據類別，支援的數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。
讀取之觸發位 |  | 設定觸發二維分佈圖讀取和顯示數據的觸發位。當位變數的狀態由0變成1時，二維分佈圖讀取數據。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
讀取地址 |  | 設定被讀取和顯示變數的地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。 取樣規則如下，如設讀取位置D100，2條曲線，則D100=實際取樣點數n D101=第一條曲線第1點的X軸座標 D102=第一條曲線第1點的Y軸座標 D103=第二條曲線第1點的X軸座標 D104=第二條曲線第1點的Y軸座標 D105=第一條曲線第2點的X軸座標 D106=第一條曲線第2點的Y軸座標 D107=第二條曲線第2點的X軸座標 D108=第二條曲線第2點的Y軸座標 ： 當觸發旗標=ON時，觸控屏會把這一連串數值轉換為曲線後顯示在觸控屏幕上。 下表顯示變數的數據排列方式。 數據類別：16位整數；數據組數：1組
 |  | 字 | 說明
 |  | 0 | 實際數據點數
 |  | 1 | 數據點0的X軸座標。
 |  | 2 | 數據點0的Y軸座標。
 |  | 3 | 數據點1的X軸座標。
 |  | 4 | 數據點1的Y軸座標。
 |  | … | …
 |  | 2n+1 | 數據點n的X軸座標。
 |  | 2n+2 | 數據點n的Y軸座標。
 |  | 數據類別：16位整數；數據組數：2組
 |  | 字 | 說明
 |  | 0 | 實際數據點數
 |  | 1 | 數據點0的X軸座標；數據組1
 |  | 2 | 數據點0的Y軸座標；數據組1
 |  | 3 | 數據點0的X軸座標；數據組2
 |  | 4 | 數據點0的Y軸座標；數據組2
 |  | 5 | 數據點1的X軸座標；數據組1
 |  | 6 | 數據點1的Y軸座標；數據組1
 |  | 7 | 數據點1的X軸座標；數據組2
 |  | 8 | 數據點1的Y軸座標；數據組2
 |  | … | …
 |  | 4n+3 | 數據點n的X軸座標；數據組2
 |  | 4n+4 | 數據點n的Y軸座標；數據組2
 |  | 數據類別：16位整數；數據組數：8組
 |  | 字 | 說明 | 字 | 說明
 |  | 0 | 實際數據點數 | 11 | 數據點0的X軸座標；數據組6
 |  | 1 | 數據點0的X軸座標；數據組1 | 12 | 數據點0的Y軸座標；數據組6
 |  | 2 | 數據點0的Y軸座標；數據組1 | 13 | 數據點0的X軸座標；數據組7
 |  | 3 | 數據點0的X軸座標；數據組2 | 14 | 數據點0的Y軸座標；數據組7
 |  | 4 | 數據點0的Y軸座標；數據組2 | 15 | 數據點0的X軸座標；數據組8
 |  | 5 | 數據點0的X軸座標；數據組3 | 16 | 數據點1的Y軸座標；數據組8
 |  | 6 | 數據點0的Y軸座標；數據組3 | 17 | 數據點1的X軸座標；數據組1
 |  | 7 | 數據點0的X軸座標；數據組4 | 18 | 數據點1的Y軸座標；數據組1
 |  | 8 | 數據點0的Y軸座標；數據組4 | … | …
 |  | 9 | 數據點0的X軸座標；數據組5 | 16n+15 | 數據點n的X軸座標；數據組8
 |  | 10 | 數據點0的Y軸座標；數據組5 | 16n+16 | 數據點n的Y軸座標；數據組8
 |  | 數據類別：32位整數；數據組數：1組
 |  | 字 | 說明 | 字 | 說明
 |  | 0,1 | 實際數據點數 | 8,9 | 數據點1的Y軸座標
 |  | 2,3 | 數據點0的X軸座標 | … | …
 |  | 4,5 | 數據點0的Y軸座標 | 4n+2, 4n+3 | 數據點n的X軸座標
 |  | 6,7 | 數據點1的X軸座標 | 4n+4, 4n+5 | 數據點n的Y軸座標
 |  | 數據類別：32位整數；數據組數：2組
 |  | 字 | 說明 | 字 | 說明
 |  | 0,1 | 實際數據點數 | 12,13 | 數據點1的Y軸座標；數據組3
 |  | 2,3 | 數據點0的X軸座標；數據組1 | 14,15 | 數據點2的X軸座標；數據組1
 |  | 4,5 | 數據點0的Y軸座標；數據組1 | 16,17 | 數據點1的Y軸座標；數據組3
 |  | 6,7 | 數據點0的X軸座標；數據組2 | … | …
 |  | 8,9 | 數據點0的Y軸座標；數據組2 | 8n+6, 8n+7 | 數據點n的X軸座標；數據組2
 |  | 10,11 | 數據點1的X軸座標；數據組1 | 8n+8, 8n+9 | 數據點n的Y軸座標；數據組2
 |  | 數據類別：32位整數；數據組數：8組
 |  | 字 | 說明 | 字 | 說明
 |  | 0,1 | 實際數據點數 | 22,23 | 數據點0的X軸座標；數據組6
 |  | 2,3 | 數據點0的X軸座標；數據組1 | 24,25 | 數據點0的Y軸座標；數據組6
 |  | 4,5 | 數據點0的Y軸座標；數據組1 | 26,27 | 數據點0的X軸座標；數據組7
 |  | 6,7 | 數據點0的X軸座標；數據組2 | 28,29 | 數據點0的Y軸座標；數據組7
 |  | 8,9 | 數據點0的Y軸座標；數據組2 | 30,31 | 數據點0的X軸座標；數據組8
 |  | 10,11 | 數據點0的X軸座標；數據組3 | 32,33 | 數據點0的Y軸座標；數據組8
 |  | 12,13 | 數據點0的Y軸座標；數據組3 | 34,35 | 數據點2的X軸座標；數據組1
 |  | 14,15 | 數據點0的X軸座標；數據組4 | 36,37 | 數據點2的Y軸座標；數據組1
 |  | 16,17 | 數據點0的Y軸座標；數據組4 | … | …
 |  | 18,19 | 數據點0的X軸座標；數據組5 | 32n+30, 32n+31 | 數據點n的X軸座標；數據組8
 |  | 20,21 | 數據點0的Y軸座標；數據組5 | 32n+32, 32n+33 | 數據點n的Y軸座標；數據組8
數據組數 |  | 設定二維分佈圖所顯示的數據組數，最多可顯示8組數據。
每組數據之可能最多點數 |  | 設定二維分佈圖每組數據的數據點最大值，最多可顯示255數據點。 註：在運行時，需設定每組數據的實際數據點數。實際數據點數不能大於數據點數的最大值。
畫點標記 |  | 勾選是否在數據點上顯示方形標記。
畫連接線 |  | 勾選是否畫連接線連接每個數據點。
清除之觸發位 |  | 當位變數的狀態由0變成1，觸發二維分佈圖清除內容。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
游標 | 顯示游標 | 勾選是否顯示游標。移動游標可選擇所需的數據點。
 | 游標色 | 設定游標的顏色。
動態範圍 | 動態範圍 | 勾選在運行時，是否可更改X軸和Y軸的最大值和最小值。當勾選此選項，X軸和Y軸刻度記號的最大值和最小值在執行時也可改變。在動態範圍參數區中，必須正確地設定最大最小值範圍的數據。動態範圍參數區欄位中需設定動態範圍參數區的地址。
 | 動態範圍 | 勾選動態範圍後，設定動態範圍參數區。點擊 [image] 輸入地址，點擊 [image] 選取標籤。 下表顯示當數據類別是16位數，參數區的數據排列方式。
 |  | 字 | 說明
 |  | 0,1 | X軸刻度標示的最小值；32位整數。
 |  | 2,3 | X軸刻度標示的最大值。32位整數。
 |  | 4,5 | Y軸刻度標示的最小值。32位整數。
 |  | 6,7 | Y軸刻度標示的最大值。32位整數。
 |  | 8 | 筆#1的最小值；16位整數或16位正整數。
 |  | 9 | 筆#1 X最大值; 同上
 |  | 10 | 筆#1 Y最小值; 同上
 |  | 11 | 筆#1 Y最大值; 同上
 |  | 12 | 筆#2 X最小值; 同上
 |  | 13 | 筆#2 X最大值; 同上
 |  | … | …
 |  | 38 | 筆#8 Y最大值; 同上
 |  | 39 | 筆#8 Y最大值; 同上
 |  | 32位元數據的排列方式
 |  | 字 | 說明
 |  | 0,1 | X軸刻度標示最小值; 32位整數
 |  | 2,3 | X軸刻度標示最大值; 32位整數
 |  | 4,5 | Y軸刻度標示最小值; 32位整數
 |  | 6,7 | Y軸刻度標示最大值; 32位整數
 |  | 8,9 | 筆#1對應的X最小值; 32位整數, 32位正整數, 或32位浮點數
 |  | 10,11 | 筆#1對應的X最大值; 同上
 |  | 12,13 | 筆#1對應的Y最小值; 同上
 |  | 14,15 | 筆#1對應的Y最小值; 同上
 |  | … | …
 |  | 64,65 | 筆#8對應的X最小值; 同上
 |  | 66,67 | 筆#8對應的X最大值; 同上
 |  | 68,69 | 筆#8對應的Y最小值; 同上
 |  | 70,71 | 筆#8對應的Y最大值; 同上


8.5.5. 二維分佈圖 - 筆設定

二維分佈圖 - 筆設定

本章節說明二維分佈圖的筆頁中各項屬性的設定。下圖是筆頁的範例。

下表為筆頁中各項屬性的說明。注意，筆#1對應數據組1；筆#2對應數據組2，以此類推。

屬性 |  | 說明
筆#1 ~ 筆#8 | 動態範圍 | 勾選在運行時，是否可更改關聯數據組的最大值和最小值。當勾選一般頁中的動態範圍，此選項才會出現。
 | 最小X | 設定關聯數據組的最小X。當未勾選動態範圍時，此選項才會出現。
 | 最大X | 設定關聯數據組的最大X。當未勾選動態範圍時，此選項才會出現。
 | 最小Y | 設定關聯數據組的最小Y。當未勾選動態範圍時，此選項才會出現。
 | 最大Y | 設定關聯數據組的最大Y。當未勾選動態範圍時，此選項才會出現。
 | 標記大小 | 設定數據點標記的大小。當勾選一般頁中的畫點標記，此項設定才有效。
 | 線樣式 | 設定連接線的樣式。當勾選一般頁中的畫連接線，此項設定才有效。
 | 顏色 | 設定連接線的顏色。


8.6. 旋轉指示燈

旋轉指示燈

旋轉指示燈可顯示旋轉設備的狀態。環形底上燈的總數是4的倍數，如下圖所示。通過控制燈號的開啟與關閉，可以直覺的瞭解設備的運作狀態。

您可設定指示燈物件完成以下操作：

1) 關閉所有的燈號，表示該設備是關閉或處於無動作的狀態。

2) 只打開最接近指定角度的燈，表示該設備的位置角度。

3) 燈​輪流閃爍，產生旋轉的視覺效果。

4) 開啟『零度位置』的燈號，表示該設備已準備就緒，或在初始位置。

5) 開啟所有的燈，表示該設備已被關閉或正在初始化。

6) 所有的燈以指定的頻率閃爍，表示該設備有一個緊急狀況。

7) 零度位置的燈號可設定為：上/下/左/右。

要新建一個旋轉指示燈，選擇功能表列的“物件>>圖表>> [image] 旋轉指示燈”。


8.6.1. 旋轉指示燈 - 功能選項

旋轉指示燈 - 功能選項

下表是旋轉指示燈中可增加的功能選項，可使旋轉指示燈顯示的訊息更豐富。選項的設定可在屬性對話框中完成。

選項 | 說明
顯現控制 | 設定旋轉指示燈的顯示與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


8.6.2. 旋轉指示燈 - 設定

旋轉指示燈 - 設定

所有旋轉指示燈的設定都可在屬性對話框中完成。旋轉指示燈的屬性對話框包含以下四個頁面。

■ 一般頁
詳見第 8.6.3 節 。

■ 顯現頁
 詳見第 4.4.6 節 。


8.6.3. 旋轉指示燈 - 一般設定

旋轉指示燈 - 一般設定

本節介紹如何定義旋轉指示燈的一般設置。以下是旋轉指示燈屬性表的一般頁的範例。

下表描述了一般頁中各項屬性。

屬性 |  | 說明
編號 |  | 設定旋轉指示燈物件的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為RInnnn。
註 |  | 可加入物件的說明文字。
燈數 |  | 設定物件燈號的數量。最大值為 40。
零度位置 |  | 選擇0度燈的位置。位置可以是在左側; 或右側; 或頂部; 或底部。
環形底 | 環寬 | 設定圓環的寬度。
 | 環色 | 設定環的顏色。
 | 邊寬 | 設定環形底邊框的粗細。如果不需要邊框，請選擇 0。
 | 邊色 | 設定環形底邊框的顏色。
燈 | 半徑 | 燈號的半徑。
 | 亮色 | 設定燈號動作的顏色。
 | 暗色 | 設定燈號關閉的顏色。
 | 閃爍色 | 設定閃爍時燈號的顏色。
 | 邊寬 | 設定燈號的邊框粗細。如果不需要則邊框，請選擇0。
 | 邊色 | 設定燈號邊框的顏色。
數據格式 |  | 監視對象的數據類型。
顯示控制模塊 |  | 監視控制對象顯示控制塊的地址或標籤。顯示控制記憶區可以是一個無符號的字組或者一個有3個數據成員的無符號雙字的字組。 以下表格顯示的是顯示控制記憶區的字地址。
 |  | 字序或雙字序 | 數據列表 |  | 描述
 |  | 0 | 命令字 |  | 操作命令字。
 |  | 1 | 速度控制字 |  | 指定的旋轉動畫或燈閃爍操作的速度控制字。
 |  | 2 | 角度控制字 |  | 角度控制字。
 |  | 下表描述了每個命令字的操作。
 |  | 命令字 |  | 描述
 |  | 字 |  | 關閉所有指示燈。
 |  | 1 |  | 指示在角度控制字中指定的角度。角度計算，如下所示，沿順時針方向. 角度控制字
 |  |  |  | 數值 | 描述
 |  |  |  | 0-360 | 有效角度值
 |  |  |  | 其他 | 無效的角度。值將被忽略。
 |  | 2 |  | 指示燈角度控制字中指定的角度。角度計算按逆時針方向，如下所示。請參閱上面的儲存格中的角度控制字的說明。
 |  | 3 |  | 顯示動畫的順時針旋轉與速度控制字中指定的速度。 速度控制字
 |  |  |  | 數值 | 描述
 |  |  |  | 0 | 無效的數字。預設值為 1。
 |  |  |  | 1-1000 | 設定時間間隔。單位是 0.01 秒。如果物件具有N燈和速度控制字中的值是V，自轉一周的時間是 N x V x 0.01 秒。例如，如果物件具有20燈，值為 5，自轉一周的時間是 20 x 5 x 0.01 = 1 第二：請注意，系統可能不能執行指定的一樣快。
 |  |  |  | 其他 | 無效的數字。預設值為 1000。
 |  | 4 |  | 在速度控制字中指定的速度顯示動畫按逆時針方向旋轉。請參閱上面的儲存格中的速度控制字的描述。
 |  | 5 |  | 只打開零度角的指示燈。
 |  | 6 |  | 打開所有的指示燈。
 |  | 7 |  | 速度控制字
 |  |  |  | 數值 | 描述
 |  |  |  | 0 | 無效的數字。預設值為1。
 |  |  |  | 1-100 | 閃爍燈的間隔。單位是 0.1 秒。例如，10 的值將使燈一秒閃爍十次。請注意，系統需要同時執行其他工作，因此秒數不會非常精準的被執行。
 |  |  |  | 其他 | 無效的數字。預設值為100。
 |  | 點擊此圖示 [image] ，打開地址輸入鍵盤，並指定所需的顯示控制區的位址。點擊此圖示 [image] ，彈出選擇標籤對話框並選擇所需的標籤。


9.1.1. 管綫 - 基本功能

管線 - 基本功能

管線為數個L型/T型/十字型的接頭和管子所組成。利用本軟體， 使用者可以輕鬆且快速地建立所需的管線。在運行時，使用者可以控制管線的顏色、閃爍及流動效果。

下圖為管線流動效果的範例：

欲繪製管線，可依以下步驟進行：

  1. 在物件選單或物件工具列中，點擊管線圖示 [image] ，繪製管線。
  2. 移動游標至畫面上欲繪製管線的位置，點擊滑鼠左鍵開始繪製管線。
  3. 在畫面上繼續點擊滑鼠左鍵，可建立所需的 L 接頭。
  4. 點擊右鍵完成管線規劃。
  5. 拖動管線邊界的藍色四方格可調整管線大小。
  6. 拖動管線上藍色或黑色的四方格，可調整管子的長度與位置。選取的管子或接頭會顯示黑色的四方格。

左邊的圖片顯示管線的四方格。管線邊界的藍色的四方格可調整管線大小。管線上藍色或黑色的四方格，可移動選取管子的頂點。

將滑鼠游標移至其中一個四方格上，當游標變為 1 或 1 或 1 或 1 ，拖動游標，調整管線至所需的外型和大小。

  7. 在管線上任一處點擊滑鼠右鍵，然後，從彈出的物件選單中，點擊“插入接頭”(T或十字)；或在現有的接頭或管子上按右鍵，從彈出的物件選單，選擇“刪除接頭”，即可刪除接頭及連接的管子。

彈出選單 | 說明
插入接頭 | 在水平的管子上新增一上/下T或十字接頭。 add an up/down 在垂直的管子上新增一左/右T或十字接頭。 add a left/right
刪除接頭 | 刪除選取的管子及連接的部份。

使用者可在管線屬性設置所有的管線屬性。此表包含以下三個頁面。

■ 一般頁(General)

詳閱章節 9.1.4.說明。

■ 管子頁(Pipe)

詳閱章節 9.1.5.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


9.1.2. 管綫 - 功能選項

管線 - 功能選項

下表是管線中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯示控制 | 設定管線的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.1.3. 管綫 - 設定

管線 - 設定

所有管線的設定都可在屬性視窗中完成。管線的屬性視窗包含以下三個頁面。

■ 一般頁(General)

詳閱章節 9.1.4.說明。

■ 管子頁(Pipe)

詳閱章節 9.1.5.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


9.1.4. 管線 - 一般設定

管線 - 一般設定

本章節說明管線一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為PLnnnn。
註 |  | 加入物件的說明文字。
種類 |  | 管線的種類。有以下五種樣式：
 |  | 样式 | 圖例
 |  | 二維樣式一 | 2d type 1
 |  | 二維樣式一 | 2d type 2
 |  | 二維樣式三 | 2d type 3
 |  | 三維樣式一 | 3d type1
 |  | 三維樣式二 | 3d type 2
漸層 |  | 當管線種類為“三維樣式一”或“三維樣式二”，設定管線的漸層模式。共有三種模式： methods
直徑 |  | 設定管線的直徑。
邊緣 色 |  | 設定管線的邊緣色。
管壁/內容 色 |  | 設定管壁/內容的顏色。
管壁/內容色可變 | <勾選框> | 勾選在運行時，是否控制管壁/內容的顏色。控制管線的變數為控制字，控制字在地址欄中設定。
 | 檢視顏色 | 選擇檢視管線顯示的顏色。
 |  | 檢視顏色 | 內容色
 |  | 1 | 管壁/內容色#1
 |  | 2 | 管壁/內容色#2
 |  | 3 | 管壁/內容色#3
 | 管壁/內容色#2 | 設定管壁/內容色#2的顏色。當控制字位元0狀態為on時，管線顯示管壁/內容色#2。
 | 管壁/內容色#3 | 設定管壁/內容色#3的顏色。當控制字位元1狀態為on時，管線顯示管壁/內容色#3。
 | 閃爍控制 | 勾選在運行時，管線是否閃爍。當控制字位元2狀態為on時，管線閃爍。
流動效果控制 | <勾選框> | 勾選在運行時，是否控制管線的流動效果。當控制字位元3狀態為on時，顯示管線流動效果。
控制字 | 大小 | 設定控制字的大小為 『字』或『雙字』。
 | 地址 | 設定管線控制字的地址。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。 下表說明控制字位元與所控制的顯示屬性：
 |  | 位 | 任務
 |  | 0 | 當此控制字位元狀態為on，顯示管壁/內容色2。
 |  | 1 | 當此控制字位元狀態為on，顯示管壁/內容色3。
 |  | 2 | 當此控制字位元狀態為on，管線閃爍。
 |  | 3 | 當此控制字位元狀態為on，顯示流動效果。
流動效果 | 預設種類 | 設定流動效果的預設種類。共有14種： 點擊 apply default symbols ，使預設的流動效果種類應用到整個管線。
 | 預設顏色 | 選擇一種顏色為流動效果的預設顏色。 點擊 apply default color ，使預設的流動效果顏色應用到整個管線。
 | 預設長度比例（%） | 設定流動長度比例為流動效果的默認長度比例。 點擊 apply default length ，使預設的流動區長度應用到整個管線。


9.1.5. 管綫 - 管子設定

管線 - 管子設定

本章節說明管線物件，管子頁中各項屬性的設定。下圖是管子頁的圖例。

下表為管子頁中各項屬性的說明。

屬性 |  | 說明
管子 | 種類 | 設定所選擇的管子種類。
 | X1 | 設定管子水平座標左上角的位置。
 | Y1 | 設定管子垂直座標左上角的位置。
 | X2 | 設定管子水平座標右下角的位置。
 | Y2 | 設定管子垂直座標右下角的位置。
流動效果 | <勾選框> | 勾選是否顯示流動效果。
 | 種類 | 設定流動效果的種類。
 | 顏色 | 設定流動效果的顏色。
 | 長度比例(%) | 設定流動區的長度比例。


9.2. 動態圖

動態圓

使用者可由PLC控制一個動態圓顯示在觸控屏幕的任何位置，且能改變此圓形的中心點位置或半徑大小及顏色。

所有動態圓的設定都可在屬性視窗中完成。動態圓的屬性視窗包含以下二個頁面。

■ 一般頁
詳閱章節 9.2.3.說明

■ 顯現頁
詳閱章節 4.4.6.說明


9.2.1. 動態圓 - 功能選項

動態圓 - 功能選項

下表是動態圓中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定動態圓的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.2.2. 動態圖 - 設定

動態圓 - 設定

所有動態圓的設定都可在屬性視窗中完成。動態圓的屬性視窗包含以下二個頁面。

■ 一般頁
詳閱章節 9.2.3.說明

■ 顯現頁
詳閱章節 4.4.6.說明


9.2.3. 動態圓 - 一般設定

動態圓 - 一般設定

本章節說明動態圓一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  |  | 屬性
編號 |  |  | 設定動態圓的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為DCnnnn。
註 |  |  | 可加入物件的說明文字。
數據類別 |  |  | 變數的數據類別，支援數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數。
監視地址 |  |  | 設定控制動態圓的監視變數地址(監視地址---$U90)。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。下表顯示變數的數據設置。 註：關於顏色數值，請參考章節 9.2.4.1。
控制 |  | 圓心 | 勾選是否控制圓心位置($U90---X軸圓心位置；$U91---Y軸圓心位置)。
 |  | 半徑 | 勾選是否控制半徑大小($U92---動態圓半徑)。
圓 | 實心 | <勾選框> | 勾選動態圓是否填充指定的圖樣。
 |  | 圖樣 | 設定填充動態圓的圖樣。
 |  | 圖樣色 | 設定圖樣黑色部份的顏色。當圖樣非全白時，此選項才會出現。
 |  | 背景色 | 設定圖樣白色部分的顏色。
 | 描邊 | <勾選框> | 勾選動態圓是否描邊。
 |  | 邊框色 | 設定動態圓邊框色。


9.2.4.1. 64K色機型

64K色機型

64K色的HMI機型，使用一個『字變數』控制顏色。控制顏色的字變數包含三種顏色：紅、綠和藍，儲存這三種顏色組成的格式如下。

位 0~4: 5 位儲存藍色組成。

位 5~10: 6位儲存綠色組成。

位 11~15: 5位儲存紅色組成。

範例:

顏色 | 紅 | 綠 | 藍 | 十六進制數值 | 十進制數值
黑 | 0 | 0 | 0 | 0000H | 0
藍 | 0 | 0 | 16 | 0010H | 16
綠 | 0 | 32 | 0 | 0400H | 1024
青 | 0 | 32 | 16 | 0410H | 1040
紅 | 16 | 0 | 0 | 8000H | 32768
紫紅 | 16 | 0 | 16 | 8010H | 32784
棕 | 16 | 32 | 0 | 8400H | 33792
深灰 | 16 | 32 | 16 | 8410H | 33808
灰 | 24 | 48 | 24 | C618H | 50712
淡藍 | 0 | 0 | 31 | 001FH | 31
淡綠 | 0 | 63 | 0 | 07E0H | 2016
淡青 | 0 | 63 | 31 | 07FFH | 2047
淡紅 | 31 | 0 | 0 | F800H | 63488
淡紫紅 | 31 | 0 | 31 | F81FH | 63519
黃 | 31 | 63 | 0 | FFE0H | 65504
白 | 31 | 63 | 31 | FFFFH | 65535


9.2.4.2. 256色機型

256色機型

下表列出256色機型顏色索引數值。用戶可依照下表設定人機應用所需的顏色。

顏色索引值 | 顏色 | 顏色索引數值 | 顏色 | 顏色索引數值 | 顏色
0 | 黑 | 84 | 秋橘 | 159 | 白蝁
1 | 藍53%藍 | 85 | 淡橘 | 166 | 深河
2 | 紅53%紅 | 88 | 深海藍 | 172 | 深海
3 | 綠53%綠 | 91 | 草綠 | 174 | 曙光藍
4 | 洋紅53%洋紅 | 94 | 深紫 | 177 | 土耳其綠
5 | 青53%青 | 96 | 苔蘚綠 | 178 | 紫
6 | 棕53%黃 | 97 | 肯塔基綠 | 179 | 尊貴紫
7 | 淡藍 | 103 | 迷彩綠 | 180 | 曙光紫
8 | 灰50%黑 | 107 | 深紅色 | 182 | 淡藍綠
9 | 淡紅 | 109 | 卡其 | 186 | 紫羅蘭
10 | 淡綠 | 110 | 沉綠 | 187 | 淡紫
11 | 淡洋紅 | 113 | 豪華紅 | 189 | 鬼綠
12 | 淡灰20%黑 | 117 | 月光綠 | 193 | 粉紅
13 | 淡青 | 118 | 霓虹紅 | 194 | 弱粉紅
14 | 黃 | 120 | 熱帶粉紅 | 195 | 白黃
15 | 白 | 121 | 桃 | 200 | 天空藍
23 | 暗綠 | 123 | 淡黃 | 209 | 深天空藍
29 | 胡桃 | 125 | 海藍 | 210 | 電子藍
34 | 紅寶石 | 130 | 暴風藍 | 211 | 嬰兒藍
39 | 黃綠 | 132 | 沙漠藍 | 214 | 藍紫
41 | 磚紅 | 134 | 海洋綠 | 216 | 藍紫羅蘭
48 | 橘 | 137 | 葡萄柚 | 217 | 蠟筆藍
50 | 深黃 | 139 | 深海綠 | 219 | 冰藍
54 | 森林綠 | 142 | 深紫羅蘭 | 221 | 霓虹紫
62 | 春綠 | 144 | 土梅 | 222 | 淡紫
65 | 暗棕 | 146 | 弱綠 | 223 | 復活節紫
66 | 暗棕 | 147 | 薄荷綠 | 224 | 淺藍紫
67 | 酪梨綠 | 149 | 深玫瑰 | 229 | 淡紫羅蘭
73 | 酪梨綠 | 150 | 土玫瑰 |  |
74 | 火星綠 | 155 | 土玫瑰 |  |
78 | 紅棕 | 156 | 深粉紅 |  |
79 | 金 | 157 | 淺粉紅 |  |
80 | 香蕉黃 | 158 | 沙黃 |  |


9.3. 動態方塊

動態方塊

使用者可由PLC控制一個動態方塊顯示在觸控屏幕的任何位置，且能改變此矩形的高、寬和顏色。藉由改變其位置、大小和顏色，可創造更多變化的顯示效果。

■ 一般頁(General)

詳閱章節 9.3.3.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


9.3.1. 動態方塊 - 功能選項

動態方塊 - 功能選項

下表是動態方塊中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定動態方塊的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.3.2. 動態方塊 - 設定

動態方塊 - 設定

所有動態方塊的設定都可在屬性視窗中完成。動態方塊的屬性視窗包含以下二個頁面。

■ 一般頁(General)

詳閱章節 9.3.3.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


9.3.3. 動態方塊 - 一般設定

動態方塊 - 一般設定

本章節說明動態方塊一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  |  | 說明
編號 |  |  | 設定動態方塊的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為DRnnnn。
註 |  |  | 可加入物件的說明文字。
數據類別 |  |  | 變數的數據類別，支援數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數和32位BCD正整數。
監視地址 |  |  | 設定控制動態方塊的監視變數地址(監視地址---$U80)。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。 下表顯示變數的數據排列方式。 註：關於顏色數值，請參考章節 9.2.4.1.。
控制 |  | 位置 | 勾選是否控制動態方塊位置($U80---X軸位置；$U81---Y軸位置)。
 |  | 大小 | 勾選是否控制動態方塊大小($U82---動態矩形寬；$U83---動態矩形高)。
 |  | 圖樣色 | 勾選是否控制圖樣色($U84---圖樣色)。當動態方塊為實心且圖樣非全白，此項設定才有效。
固定點 |  |  | 當調整方塊大小時，選擇固定方塊的四個角落之一：左上、右上、左下及右下。當大小是可控制，位置是不可控制時，此選項才會出現。
方塊 | 實心 | 描邊 | 勾選動態方塊是否填充圖樣。
 |  | 圖樣 | 設定填充動態方塊的圖樣。
 |  | 圖樣色 | 設定圖樣黑色部份的顏色。當圖樣非全白時，此選項才會出現。
 |  | 背景色 | 設定圖樣白色部份的顏色。
 | 描邊 | 描邊 | 勾選動態方塊是否描邊。
 |  | 邊框色 | 設定動態方塊的邊框色。


9.4. GIF動畫顯示器

GIF動畫顯示器

GIF顯示器能顯示GIF圖形於觸控屏幕的固定位置，並自動執行GIF動畫顯示。

所有GIF圖的設定都可在屬性視窗中完成。GIF圖的屬性視窗包含以下二個頁面。

■ 一般頁
詳閱章節 9.4.3.說明

■ 顯現頁
詳閱章節 4.4.6.說明


9.4.1. GIF動畫顯示器 - 功能選項

GIF動畫顯示器 - 功能選項

下表是GIF圖中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定GIF圖的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.4.2. GIF動畫顯示器 - 設定

GIF動畫顯示器 - 設定

所有GIF圖的設定都可在屬性視窗中完成。GIF圖的屬性視窗包含以下二個頁面。

■ 一般頁
詳閱章節 9.4.3.說明

■ 顯現頁
詳閱章節 4.4.6.說明


9.4.3. GIF動畫顯示器 - 一般設定

GIF動畫顯示器 - 一般設定

本章節說明GIF圖一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定GIF圖的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為GDnnnn。
註 |  | 可加入物件的說明文字。
圖 |  | 選擇欲顯示的GIF圖。用戶可點擊下拉式清單，從圖片資料庫中選取GIF圖。點擊 [image] 圖標，從檔案中選取GIF圖；點擊 [image] 圖標，從圖片資料庫中選取GIF圖。如果所選擇的GIF圖不在圖片資料庫中，則GIF圖將導入並儲存於圖片資料庫中。
保持原大小 |  | 勾選此選項，選取圖片大小將不隨物件大小調整而調整。 當所選定的圖設置如為"保持原大小" 未勾選時，當進行人機機型改型時，軟體所提供的自動比例調整所有物件大小時，就不會自動延展調整本圖片。
動畫 | 啟動位 | 勾選此選項，動畫的啟動可由指定的位控制。GIF圖可由位控制停止和啟動，可由字控制動畫速度。
 |  | 設定啟動動畫的位變數地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。當變數狀態為on，啟動動畫。
 | 速度控制字 | 勾選此選項，動畫的播放速度由指定的字變數控制。
 |  | 設定控制動畫速度的字變數的地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。變數數值的範圍從0到10，最低速為1，最高速為10，選擇0則不啟動動畫。
 | 速度 | 設定動畫播放速度，最低速為1，最高速為10。
run testing |  | 點擊此按鈕可檢視當前動畫的運行測試。


9.5.1. 圖片顯示器 - 基本功能

圖片顯示器 - 基本功能

使用者可以利用一個變數，選擇並顯示預設的圖片。

圖片顯示器最多支援256狀態，每一個狀態可以設定其對應的圖片。圖片顯示器的最大狀態數是由狀態類別和監視變數的數據類別決定。下表顯示不同情形下的最大值。

狀態類別 | 狀態類別 | 狀態數的最大值
位 | 位 | 2
數 值 | 16位 | 256
 | 32位 | 256
最低位 | 16位 | 17
 | 32位 | 33
位(停止/啟動 自動變換) | Bit 位 | 256 註：此狀態類別僅出現在圖片顯示器物件。位變數控制動畫的啟動與否。當狀態為on，動畫啟動；當狀態為off，動畫不啟動。圖片顯示器以指定的速度依序顯示圖片來播放動畫。

使用者可以設定圖片顯示器的狀態個數，但須在最大值範圍內。每個狀態的圖片都可設定其屬性。在運行時，圖片顯示器依據監視變數的狀態顯示圖片，監視變數的狀態是由狀態類別和變數的數值所決定。

用戶可以完成所有設置在屬性表中。此表包含以下三個頁面。

■ 一般頁(General)

詳閱章節 9.5.4.說明。

■ 圖片頁(Picture)

詳閱章節 4.3.7.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


9.5.2. 圖片顯示器 - 功能選項

圖片顯示器 - 功能選項

下表是圖片顯示器中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定圖片顯示器的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.5.3. 圖片顯示器 - 設定

圖片顯示器 - 設定

所有圖片顯示器的設定都可在屬性視窗中完成。圖片顯示器的屬性視窗包含以下三個頁面。

■ 一般頁
詳閱章節 9.5.4.說明。

■ 圖片頁
詳閱章節 4.3.7.說明。

■ 顯現頁
詳閱章節 4.4.6.說明。


9.5.4. 圖片顯示器 - 一般設定

圖片顯示器 - 一般設定

本章節說明圖片顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定圖片顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為PDnnnn。
註 |  | 可加入物件的說明文字。
外框 | 外框 | 勾選圖片顯示器是否顯示外框。
 | 外框設置 | 、邊框色、圖樣、圖樣色及背景色的詳細說明，請參考章節4.3.4 設定物件外型。
外標示 |  | 勾選圖片顯示器是否需要外標示。外標示頁可設定各項屬性。
狀態 |  | 選擇一個狀態為圖片顯示器的當前狀態，可檢視和設定該狀態的圖樣、圖樣色、背景色。
狀態類別 | 位 | 狀態控制圖片顯示的變量類型。詳細說明，請參考章節 9.5.1 基本功能。
 | 最低位
 | 位(停止/啟動 自動變換)
 | 顯示一個由關聯功能按鈕載入的圖片 | 使用者可以通過功能按鈕加載JPEG圖片。此選項僅適用於高階機型。有關詳細信息，請參見。 選擇 5.4.1 基本 功能 功能按鈕。
數據類別 |  | 變數的數據類別，支援數據類別如下：位、16位正整數、16位BCD正整數、32位正整數、32位BCD正整數。
監視地址 |  | 設定控制圖片顯示器變數的位址。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
狀態總數 |  | 設定圖片顯示器的狀態總數。
自動變換頻率(Hz) |  | 設定圖片變換的速率。


9.6. 動畫

動畫

動畫物件可以自動或由PLC與HMI所提供的暫存器來控制圖型的變化與移動。在運行時，動畫物件的位置和圖片可由指定的位控制。可以在觸控屏上顯示各種位移及變化效果，支援BMP/JPG/GIF圖檔及支援物件群(Object group supported)。

使用者可以完成所有設置在屬性表中。此表包含以下三個頁面。

■ 一般頁(General)

詳閱章節 9.6.3.說明。

■ 圖片頁(Picture)

詳閱章節 4.3.7.說明。

■ GIF圖頁(GIF)

詳閱章節 9.6.4.說明。

■ 路徑頁(Path)

詳閱章節 9.6.5.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


9.6.1. 動畫 - 功能選項

動畫 - 功能選項

下表是動畫可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定動畫顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.6.2. 動畫 - 設定

動畫 - 設定

所有動畫的設定都可在屬性視窗中完成。動畫的屬性視窗包含以下五個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節 9.6.3.說明

■ 圖片頁
詳閱章節 4.3.7.說明

■ GIF圖頁
詳閱章節 9.6.4.說明

■ 路徑頁
詳閱章節 9.6.5.說明

■ 顯現頁
詳閱章節 4.4.6.說明


9.6.3. 動畫 - 一般設定

動畫 - 一般設定

本章節說明動畫一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 屬性
編號 |  | 設定動畫的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為AGnnnn。
註 |  | 可加入物件的說明文字。
圖 | 圖種類 | 選擇動畫顯示的圖種類：
 |  | 種類 | 說明
 |  | BMP圖/JPG圖/物件群 | 動畫物件最多可設置256張圖片。圖片可為BMP圖、JPG圖和物件群。在圖片頁，可進行各項屬性的設定。詳細說明，請參考章節 4.3.7 圖片設定。
 |  | GIF圖 | 動畫物件可設定一個GIF圖。在GIF圖頁，可進行各項屬性的設定。GIF圖的撥放速度可在改變速率欄中設定。
 | 狀態數 | 設定圖的狀態數。用戶可設定每個狀態對應的圖片，動畫顯示當前狀態的關聯圖片。 控制的圖片最多256張。
 | 控制方式 | 選擇動畫物件的控制方式。
 |  | 控制方式 | 說明
 |  | 自動 | 根據圖片總數循環變換。動畫從狀態0依序變換狀態，變換速度為改變速率選項所設定。若當前狀態為最後一個狀態，則次狀態會回到狀態0。
 |  | 位置 | 由PLC或HMI暫存器控制圖型的顯示位置(須搭配路徑種類:動態功能)。狀態由動畫物件所在的路徑位置決定。在路徑頁，可設定每一個路徑點的關聯狀態。詳細說明，請參考章節 9.6.5 路徑設定。
 |  | 動態 | 由暫存器控制圖型變換。在運行時，狀態由指定的變數決定。
 |  | 動畫顯示當前狀態的關聯圖片。
 | 改變速率(Hz) | 在自動的狀態下由HMI系統根據改變速率的快慢變換圖片。設定當控制方式為自動或圖種類為GIF圖時，圖片變換的速率。
移動 | 路徑種類 | 移動路徑種類有6種模式，靜止/水平/垂直/聯結線段/動態/動態；預設位置：
 |  | 路徑種類 | 說明
 |  | 靜止 | 圖片不位移。圖片只會在原地做顯示及變化。
 |  | 水平 | 圖片根據水平路徑移動。移動速率可提供10~1600 畫素/秒，定時向水平路徑單向移動或來回移動。
 |  | 垂直 | 圖片根據垂直路徑移動。移動速率可提供10~1600 畫素/秒，定時向垂直路徑單向移動或上下移動。
 |  | 連結線段 | 圖片根據所規劃的結點移動。移動速率提供10~1600 畫素/秒，定時依據已定義的路徑移動。聯結線段，可以利用滑鼠的右鍵來“插入點/刪除點”改變移動的路徑。 操作技巧:可簡單使用滑鼠移動定位點就可以重新指定新的座標。
 |  | 動態 | 在運行時，動畫的位置是由變數決定，監視地址選項中可設定變數地址。變數數據設定X軸和Y軸座標位置。
 |  | 動態；預設位置 | 在運行時，動畫的位置是由變數決定，監視地址選項中可設定變數地址。變數數據設定數據點的位置。 圖形控制方式：動態的固定預定點。由PLC或HMI暫存器控制圖型變換與位移預定點。這種路徑種類允許你為動畫在畫面上訂出一連續位置。如果訂了N個位置，第一點編號為0而最後一點編號為N-1。在執行時，移動控制字的值決定了當前位置的編號，此動畫將根據指定編號移到指定位置。
特效 | 走馬燈 | 勾選當前圖片是否捲入路徑兩端。當路徑種類為水平或垂直，此選項才會出現。
 | 複製圖片 | 勾選是否複製當前圖片。複製的圖片將一起顯示和移動，勾選走馬燈後，此選項才會出現。
 | 複製數 | 設定欲複製的圖片數量。
控圖地址 |  | 設定控制動畫的變數地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。下表顯示變數的數據設置。
數據類別 |  | 變數的數據類別，支援數據類別如下：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數。


9.6.3.1. 在動畫中使用物件群

在動畫中使用物件群

使用者可以在動畫物件中使用物件群。

欲建立物件群，首先，將所需的物件集群，然後儲存集群物件於物件庫。
 欲使用物件群，可點擊圖片頁中的 [image] 按鈕，彈出的“複製物件庫中的物件”對話框。在對話框中，可選取現有的物件群於動畫物件中使用。

當對物件群進行調整時，如移動、調整大小、刪除…，所有調整將會同時適用到物件全中所有物件。然而，物件群中的物件可個別設定其屬性。 使用者可點擊 [image] 圖示，

開啟關聯物件的屬性對話框，然後，設定該物件的屬性。

下圖說明如何編輯動畫中的物件群。物件群包含數值輸入器、數值顯示器和圖片物件。物件將沿著一組連接線移動，數值輸入/顯示器的數值將隨著物件移動而變化。

1. 設定物件群為動畫物件的圖。

2. 設定圖片物件。

3. 設定數值輸入物件。


9.6.4. 動畫 - GIF圖設定

動畫 - GIF圖設定

本章節說明動畫物件GIF圖頁中各項屬性的設定。以下為GIF圖頁的圖例。當動畫可選用圖種類：1.BMP圖/JPG圖/物件群 2. GIF圖 ；圖格式不同時；其對應的圖片對話框會不同。

下表為GIF圖頁中各項屬性的說明。

屬性 | 說明
圖片 | 選擇欲顯示的GIF圖。點擊下拉式清單中可從圖片資料庫中選取GIF圖。點擊 [image] 圖標，從檔案中選取GIF圖；點擊 [image] 圖標，從圖片資料庫中選取GIF圖。如果所選擇的GIF圖不在圖片資料庫中，則GIF圖將導入並儲存於圖片資料庫中。
保持原圖大小 | 勾選此選項，GIF圖大小將不隨物件大小調整而調整。


9.6.5. 動畫 - 路徑設定

動畫 - 路徑設定

本章節說明動畫路徑頁中各項屬性的設定。在編輯視窗中可設定動畫的路徑。欲編輯動畫的路徑，可點擊路徑，如下圖所示。

調整路徑可用拖動的方式調整。在欲插入路徑點的位置上點擊右鍵，並從彈出式選單中點選插入點，即可插入路徑點；在路徑點上點擊右鍵，並從彈出式選單中點選刪除點，即可刪除路徑點。在路徑頁中可設定各項屬性。

下圖是路徑頁的範例。

下表為路徑頁中各項屬性的說明。

屬性 |  | 說明
X |  | 設定路徑點在座標上的水平位置。
Y |  | 設定路徑點在座標上的垂直位置。
去程圖片 | 狀態 | 所選擇路徑點，去程的狀態。
 | 名稱 | 所選擇狀態的圖片名稱，也是所選擇路徑點去程的圖片名稱。
回程圖片 | 狀態 | 所選擇路徑點，回程的狀態。
 | 名稱 | 所選擇狀態的圖片名稱，也是所選擇路徑點回程的圖片名稱。


9.7. 路徑顯示器

路徑顯示器

路徑顯示是由點，線，弧，圓一個預定義的路徑顯示的畫面對象。例如，路徑顯示可用於描繪自動點膠機的工作路徑。

創建路徑顯示器，選擇 物件-動態圖-路徑顯示器 [image] 。

路徑顯示在下面圖中所示的坐標系。原點是在路徑顯示區域的左上角。

路徑顯示提供點選擇功能，可以選擇顯示路徑上的一個點，並顯示點的座標。要找到所需的點上顯示的路徑，將游標移到點的附近，路徑顯示找到的最近點的搜索半徑內的游標的坐標點，並寫入到指定的工作塊。

使用者可以完成所有設置在屬性表中。此表包含以下三個頁面。

■ 一般頁
詳閱章節 9.7.3.說明。

■ 顯現頁
詳閱章節 4.4.6.說明。


9.7.1. 路徑顯示器 - 功能選項

路徑顯示器 - 功能選項

下表是路徑顯示器中可增加的功能選項。選項的設定可在屬性 視窗中完成。

選項 | 說明
顯現控制 | 設定動畫顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


9.7.2. 路徑顯示器 - 設定

路徑顯示器 - 設定

所有路徑顯示器的設定都可在屬性視窗中完成。路徑顯示器的屬性視窗包含以下二個頁面。

■ 一般頁
詳閱章節 9.7.3.說明。

■ 顯現頁
詳閱章節 4.4.6.說明。


9.7.3. 路徑顯示器 - 一般設定

路徑顯示器 - 一般設定

本章節說明路徑顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  |  | 說明
編號 |  |  | 當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。路徑顯示的ID的格式是DPnnnn。
註 |  |  | 可加入說明文字。
背景透明 |  |  | 物件背景透明。
外形設置 |  |  | 背景透明、 [image] 、 邊框色、背景色的詳細說明，請參考 章節 4 .3.4 設定物件外型。
路徑定義區 |  |  | 指定路徑顯示器的繪圖參數地址。點擊 [image] 此圖標，出現地址輸入鍵盤，輸入所需的地址。點選 [image] 此圖標，出現選擇標籤，選擇所需標籤。路徑顯示器的數據佈置在下面的格式：
 |  |  | 字編號 | 說明
 |  |  | 0 | 路徑中的路徑元素的數目。
 |  |  | 1~8 | 定義中的第一個路徑元素。
 |  |  | 9~16 | 定義中的第二個路徑元素。
 |  |  | … | …
 |  |  | (8n-7)~8n | 定義中的第n個路徑元素。
 |  |  | 參見第 9.7.3.1路徑元素的定義，瞭解如何定義路徑元素。路徑元素包括：點，線，弧，圓。 參見第 9.7.3.2瞭解如何指定路徑元素的顏色的顏色值。
繪圖觸發位 |  |  | 定義觸發對象繪製路徑的位或字位。點擊 [image] 輸入地址。點擊 [image] 輸入標籤。 觸發位取得是依上升沿取得，動作後需要復位觸發位。
清除觸發位 |  |  | 設定觸發清除的觸發位。當位元變數的狀態由0 變成1 時，觸發清除,拭除已繪製的路徑的物件。點擊圖示 [image] ，輸入所需的位址。
選點功能 | 由位致能 |  | 啟用或禁用一個位點選擇功能，請選擇該選項。指定點選功能位地址。點擊 [image] 輸入地址。點擊 [image] 輸入標籤。
 | 游標顏色 |  | 制定光標的顏色。
 | 搜索半徑 |  | 路徑顯示器將會搜索當前光標半徑範圍內的點。搜索圈的中心，是在當前光標位置，半徑是這裡指定的搜索半徑。
 | 選點報告數據類型 |  | 下表描述了報表的數據結構，“”被選中的是16位無符號整數。
 |  |  | 字編號 | 說明
 |  |  | 0 | 選擇的點的x坐標
 |  |  | 1 | 選擇的點的y坐標
 |  |  | 2 | 點元素，其中所選擇點的序列號
 |  |  | 3 | 下表描述了不同的選定點的值和意義。
 |  |  |  | 值 |  | 描述
 |  |  |  | 0 |  | 點的一個點，一個圓的中心點，或弧的起點。
 |  |  |  | 1 |  | 一條線或弧的結束點。
 | 選點報告接收區 |  | 設置搜尋半徑的大小.路徑顯示會找到最近的點到當前游標位置搜索圈內作為所選點。搜索圓的中心是在當前游標位置並半徑是在此處指定的搜索半徑。點擊 [image] 輸入地址。點擊 [image] 輸入標籤。
 | 操作員確認 |  | 選擇該選項，操作是需要操作員再次確認操作。
 | 通知 | 勾選框 | 選擇該選項，當操作被執行後，一個位將被通知。
 |  | 信號 | 通知信號：
 |  |  | 信號 |  | 說明
 |  |  | 位階 |  | 指定位的狀態。
 |  |  | 脈衝 |  | 發出一個脈衝。
 |  | 位 | 當“通知”可用時，該功能顯示。指定操作通知位。點擊 [image] 輸入地址。點擊 [image] 輸入標籤。


9.7.3.1 路徑顯示器 - 定義路徑元素

路徑顯示器 - 定義路徑元素

點：

字 | 助記符 | 描述
0 | 類型 | 點代碼為0。
1 | 顏色 | 點的顏色。
2 | x | 點的X座標。
3 | y | 點的Y座標。
4~7 | (保留) | 一定為0。

線：

字 | 助記符 | 描述
0 | 類型 | 线的代碼是1。
1 | 顏色 | 线的顏色。
2 | x1 | 起始點X座標。
3 | y1 | 起始點Y座標。
4 | x2 | 結束點X座標。
5 | y2 | 結束點Y座標。
6 | 樣式 | 线的樣式。實線應該是0xFFFF。
7 | (保留) | 一定為0。

圓弧：

字 | 助記符 | 描述
0 | 類型 | 圓弧代碼為2。
1 | 顏色 | 圓弧顏色。
2 | X | 圓心X座標。
3 | y | 圓心Y座標。
4 | x1 | 起始點X座標。
5 | y1 | 起始點Y座標。
6 | x2 | 結束點X座標。
7 | y2 | 結束點Y座標。

圓：

字 |  | 描述
0 | 類型 | 圓代碼為3。
1 | 顏色 | 圓的顏色。
2 | x | 圓心X座標。
3 | y | 圓心Y座標。
4 | r | 圓半徑。
5~7 | (保留) | 一定為0。

厚度：

字 |  | 描述
0 | 類型 | 設定描邊厚度的代碼為8。
1 | (保留) | 一定為0。
2 | 厚度 | 描邊的厚度。單位：圖元。
3~7 | (保留) | 一定為0。


9.7.3.2 路徑顯示器 - 顏色值

路徑顯示器 - 顏色值

一個顏色值由5位的紅色成分，6位綠色成分，和下圖中所示的5位藍色成分。

下表列出了常用的顏色值。

顏色 | 值
黑色 | 0x0000
藍色 | 0x0010
綠色 | 0x0400
青色 | 0x0410
紅色 | 0x8000
品紅 | 0x8010
棕色 | 0x8400
灰色 | 0xc618
深灰色 | 0x8410
淡藍 | 0x001f
淡綠 | 0x07e0
淡青色 | 0x07ff
淡紅 | 0xf800
淡洋紅色 | 0xf81f
黃色 | 0xffe0
白色 | 0xffff


9.7.4. 路徑顯示器 - 鋼筋彎曲機

路徑顯示器 - 鋼筋彎曲機

使用路徑顯示器，可以模擬彎曲機彎曲鋼筋。下面是一個應用程式例子：

■ 新建路徑顯示器

■ 彎曲參數

允許使用者最多有32段彎曲鋼筋。下表描述了彎曲參數的存儲器 的『命令字』地址：

彎曲參數 | 段號 | 字編號 | 例（SegPar U100） | 說明
長度 | 1 | 0 | $U100 | 第1段長度
 | 2 | 2 | $U101 | 第2段長度
 | ... | ... | ... | ...
 | 32 | 62 | $U162 | 第32段長度
角度/半徑 | 1 | 64 | $U164 | 第1段角度/半徑
 | 2 | 66 | $U166 | 第2段角度/半徑
 | ... | ... | ... | ...
 | 32 | 126 | $U226 | 第32段角度/半徑
方向 | 1 | 128.0 | $U228.0 | 0:順時針方向 1:逆時針方向
 | 2 | 128.1 | $U228.1
 | ... | ... | ...
 | 32 | 129.f | $U229.f
形狀 | 1 | 130 | $U230 | 0:直線 1:弧 2:圓
 | 2 | 132 | $U232
 | ... | ... | ...
 | 32 | 192 | $U292

■ 可視化預處理請求塊

下表描述了可視化預處理請求塊的命令字地址。

字編號 | 例(@$U300) | 說明
0 | $U300 | 位0 = 1：啟用抗鋸齒繪圖功能 位1-15 保留
1 | $U301 | 線條的粗細顯示。有效數字：1至5。
2 | $U302 | 相關聯路徑顯示的寬度。
3 | $U303 | 相關聯路徑顯示的高度。
4 | $U304 | 0：自動縮放； 1：手動縮放；
5 | $U305 | 縮放比例。單為為百分比。例如，數位200是指200％，數位50是指50％ 。當選擇手動縮放，該參數是有效的。 有效的數位:30至300
6 to 199 | $U306 to $U499 | 彎曲參數。

■ 通過使用系統的巨集命令，獲取彎曲的結果

可以通過使用該系統的巨集命令"0xf105"，然後由路徑顯示器顯示所需的數據，顯示彎曲的結果。

SYS(0xf105, P1, P2)

巨集命令參數 | 說明
P1 | 可視化的的預處理請求塊，其中包含的參數如何生成的繪圖數據和參數的彎曲操作的起始地址。
P2 | 所使用的相關路徑顯示的路徑定義塊的起始位址。系統的巨集命令生成的繪圖數據預處理請求塊可視化指定的參數，並保存路徑定義塊中的數據繪製。

例：

$u300 = 1 // 抗鋸齒

$u301 = 1 // 線條粗細=1

$u302 = 400 // 關聯路徑顯示寬度

$u303 = 270 // 相關的路徑顯示的高度

$u304 = 1 // 手動縮放

$u305 = 100 // 縮放比例：100％

$U306 = MOV($U100,194) // 保存彎曲參數塊的起始處$ U100 可視化預處理請求塊起價為$ U306

SYS(0xf105, $U300, $U9999) // 保存路徑定義塊$U9999的請求開始繪製數據保存在$ U300


10.1.1. 窗口畫面顯示器 - 基本功能

窗口畫面顯示器 - 基本功能

窗口畫面顯示器允許用戶指定一個變數，以便它可以顯示變數指定的視窗畫面。

用戶可以在屬性對話框完成所有窗口畫面顯示器的設置。此對話窗口包含以下兩個頁面。

■ 一般頁
詳閱章節 10.1.4.說明

■ 顯示頁
詳閱章節 4.4.6.說明


10.1.2. 窗口畫面顯示器 - 功能選項

窗口畫面顯示器 - 功能選項

下表是窗口畫面顯示器的功能選項。選項的設定可在屬性對話框中完成

選項 | 說明
顯現控制 | 設定物件的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


10.1.3. 窗口畫面顯示器 - 設定

窗口畫面顯示器 - 設定

所有關於窗口畫面顯示器設定都可在屬性對話框中完成。屬性對話框包含以下兩個頁面，某些頁面在需要設定時才會出現。

■ 一般頁
詳閱章節 10.1.4.說明

■ 顯示頁
詳閱章節 4.4.6.說明


10.1.4. 窗口畫面顯示器 - 一般設置

窗口畫面顯示器 - 一般設置

本節介紹如何定義窗口畫面顯示器設置。下面的範例視窗是窗口畫面顯示器的一般屬性頁。

下表描述了一般頁面的各項屬性：

屬性 |  | 說明
編號 |  | 設定窗口畫面顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為BLnnnn。
註 |  | 物件的說明文字。
顯示固定視窗畫面 |  | 勾選此選項，顯示指定的視窗畫面。
顯示由變數指定的視窗畫面 |  | 勾選此選項，窗口畫面顯示器將顯示由變數指定的視窗畫面。
視窗畫面 |  | 指定在畫面顯示器將要顯示的畫面。勾選固定視窗畫面顯示時，此選項才可用。
顯示畫面背景 |  | 勾選該選項，可顯示視窗的畫面背景。勾選顯示固定視窗畫面時，此選項才可用。
監視地址 | 數據類型 | 監視變數的數據類型。 支援的數據類型包括：16位正整數，32位正整數，16位整數，32位整數，16位BCD正整數、32位BCD正整數。
 | 監視地址 | 指定監視地址。點擊 [image] 圖標，輸入所需的地址，或者點擊 [image] 圖標，選取所需的標籤。


10.2.1. 次連線表 - 基本功能

次連線表 - 基本功能

使用者可以使用次連線表禁止或者開啟次連線，顯示或者隱藏次連線通訊錯誤的資訊。

operation log display demo

以上是次連線表的一個範例。第一行是標題行，它顯示每列的標題，其他行每行顯示一個次連線的內容，下表描述次連線表的每一列的內容。

抬頭行 | 說明
名稱 | 次連線的名稱。
站號 | 次連線的站號地址。
狀態 | 次連線的初始通訊狀態。如果狀態為“開啟”，人機運行時此次連線將正常通訊 ，如果狀態為“關閉”，人機運行時此次連線不會進行通訊。由『初始通訊狀態』旁的下拉式選單可開啟或關閉此次連線。
顯示 | 勾選『顯示錯誤訊息』，運行時出現通訊錯誤將會顯示通訊錯誤提示框，否則不顯示。

用戶可通過次連線表連線屬性對話框完成所有的設置。對話框有如下兩個頁面：

■ 一般頁
 詳閱章節 10.2.4 說明

■ 顯示頁
 詳閱章節 4.4.6.說明


10.2.2. 次連線表 - 功能選項

次連線表 - 功能選項

下表是次連線表中的功能選項。選項的設定可在屬性對話框中完成。

選項 | 說明
顯現控制 | 設定物件的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


10.2.3. 次連線表 - 設定

次連線表 - 設定

使用者可使用次連線表對話框完成所有的設置。對話框有如下兩個頁面：

■ 一般頁
 詳閱章節 10.2.4 說明

■ 顯示頁
 詳閱章節 4.4.6.說明


10.2.4. 次連線表 - 一般設置

次連線表 - 一般設置

本節介紹如何設定次連線表的一般設置。下面是次連缐的一般屬性對話框。

下表描述了一般頁面中的每個項目屬性。

屬性 |  | 描述
編號 |  | 設定次連線表的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為BLnnnn。
註 |  | 可加入物件的說明文字。
外框 |  | 外框的邊框色和背景色的詳細說明，請參考 章節 4.3.4 設定物件外形。
格線 | 垂直 | 如果需要次連線表具有垂直格線，請選擇此選項。
 | 水平 | 如果需要次連線表具有水平格線，請選擇此選項。
 | 顏色 | 設定格線顏色。
連線 |  | 選擇要顯示的次連線。
抬頭 | 語言 | 選擇抬頭列各項目使用的顯示語言。
 | 字體 | 設定抬頭字體。
 | 顏色 | 設定文本顏色。
 | 背景色 | 設定背景色。
 | 站名 | 在次連線表抬頭列可指定次連線“站名”顯示的名稱。
 | 站號 | 在次連線表抬頭列可指定次連線“站號”顯示的名稱。
 | 狀態 | 在次連線表抬頭列可指定“狀態”顯示的名稱。
 | 顯示 | 在次連線表抬頭列可指定“顯示”顯示的名稱。
 | 命令延遲 | 對於乙太網連線，本表可顯示其次連線的IP位址，命令延遲和超時時間。它還允許操作員在運行時更改這三個通信參數。 在次連線表抬頭列可指定“命令延遲”顯示的名稱。
 | 超時時間 | 在次連線表抬頭列可指定“超時時間”顯示的名稱。
 | IP 地址 | 在次連線表抬頭列可指定“IP 地址”顯示的名稱。
文字 | 語言 | 設定各項文字訊息的顯示語言。
 | 字體 | 設定抬頭字體。
 | 顏色 | 設定文字顏色。
 | 開啟狀態 | 設定“開啟狀態”文字顏色。
 | 關閉狀態 | 設定“關閉狀態”文字顏色。
 | 行距 | 設定次連線表格的行距。
 | 項距 | 設定次連線表格的項距。


10.3. 使用相機顯示器監看即時影像

使用相機顯示器監看即時影像

如果軟體運行的設備是安裝Windows的個人電腦或進階版人機界面，您可以藉由USB攝影機或外接攝影機獲得現場的即時影像，並顯示在畫面上。另外，顯示在畫面上的影像能儲存為.jpg或.bmp格式的檔案。

使用者可以在相機顯示器的屬性對話框中完成相機顯示器的所有設定。該屬性對話框包括兩個頁面。

■ 一般頁
詳閱章節 10.3.2.說明

■ 顯現頁
詳閱章節 4.4.6.說明


10.3.1. 相機顯示器 - 設定

相機顯示器 - 設定

使用者可以在相機顯示器的屬性對話框中完成相機顯示器的所有設定。該屬性對話框包括兩個頁面。

■ 一般頁
詳閱章節 10.3.2.說明

■ 顯現頁
詳閱章節 4.4.6.說明


10.3.2. 相機顯示器 - 一般設定

相機顯示器 - 一般設定

本節描述了相機顯示器的一般頁設定，以下是相機顯示器屬性對話框一般頁面設定的範例。

USB攝影機（PC組態） | 攝影機（人機）
operation display |

下表描述了一般頁面的各項設定屬性。

屬性 | 說明
編號 | 當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為 CVnnnn。
註 | 物件的説明文字。
外框 | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設置 物件外型 。
訊號種類 | 選擇攝影機的訊號種類。USB選項為圖控使用，NTSC為人機外接攝影機使用。
相機編號 | 圖控運行時最多支援4個USB攝影機，人機支援攝影機為1個。用戶可以預先設定攝影機的編號，然後使用功能按鈕保存攝影機的圖片。功能按鈕的詳細資訊，參見章節 3.6.7 使用一般命令。
顯示解析度 | 攝影機的顯示解析度。
掃描速率（HZ) | 指定顯示的掃描率為60Hz，30Hz，15Hz，7.5Hz。掃描頻率越高，攝影機的顯示更新頻率越快，但其他物件的更新速度會減慢。


11.1. 配方

配方

在本章中，將說明如何設定、儲存和傳輸配方。另外，也將說明配方的基本功能設定以及配方物件的使用(配方選擇器和配方表)。

■ 配方區
 配方區為一個記憶區，將配方數據以二維陣列方式儲存於人機中。配方區的記憶區大小為配方長度 * 配方總數，以字(word)為單位。一個人機應用最多可建立16個配方區。每個配方區最多可包含65535個配方，每一個配方最多可包含8192個字。

■ 配方

配方為一群數據項的組合。用戶可使用配方編號或配方名稱，作為配方的索引。

配方編號為一組數列，範圍從0到配方總數，相同配方區的配方編號不會重覆。配方區m的當前配方編號儲存在當前配方編號暫存器$RNm(m：配方區編號)。

其中一個數據項代表配方名稱，可支援ASCII字串或Unicode字串顯示。欲設定以ASCII字串(字節)或Unicode字串(雙字節)為數據項的配方名稱，必須先開啟配方區對話框。然後，在數據項頁面中，設定數據項的數據類別為ASCII或Unicode字串。詳細說明，請參考章節 11.5.2.。

■ 配方數據項

數據項為一組數據資料，用來代表在過程及生產控制中，人機應用的相關數據或機器設定參數。用戶可以在配方區屬性對話框中，設定數據項的名稱、數據類別、大小、縮放和範圍檢查等屬性。

下麵的配方區圖例包含3個配方，每個配方包含8個數據項。

■ 配方數據
 有三種配方數據格式：CSV、TXT數據格式和PRD數據格式。 此配方資料可在PC和HMI或USB隨身碟/Micro SD卡 （微型快閃卡）之間傳輸。

配方數據 | 說明
CSV/TXT 數據 | * 可由Excel或文字編輯軟體(如記事本)建立與開啟。
PRD數據 | * 在軟體中建立的二進制數據，為人機專用數據格式。 * 可在RecipeEditor中編輯。


11.2. 配方數據傳輸和記憶區配置

配方數據傳輸和記憶區配置

假設人機應用有兩個配方區(配方區0和配方區9)。

 配方區0有3個配方，每個配方有4個數據項A、B、C和D。
 配方區9有2個配方，每個配方有3個數據項E、F和G。

 以下面圖表說明配方數據傳輸和記憶區配置的關係。


11.3. 使用配方

使用配方

使用者可依照以下步驟來使用配方：

■ 建立一個配方區
 使用者可由以下兩種方法擇一，建立配方區：
1) 在專案管理員視窗中，在配方上 [image] 點擊滑鼠右鍵，在彈出的右鍵選單中選擇『新增配方區 』。
2) 在功能列中，點選人機應用，在彈出的下拉式選單中選擇『配方區』，最後，再選擇新增。
 詳細說明，請參考章節 11.5

■ 導入和導出配方區
使用者可按照下列方法導出配方數據:
1) 在專案管理員窗口中，用鼠標右鍵單擊該配方節點（ [image] ） ，然後在彈出的右鍵選單中選擇[導出.... ]

或在功能列中單擊 『人機應用』，在彈出的下拉式選單中選擇『配方區』，然後在彈出的右方選單中選擇[導出.... ]。

使用者可按照下列方法導入配方數據：
1) 在專案管理員窗口中，用鼠標右鍵單擊該配方節點（ [image] ）然後在彈出的右鍵選單中選擇[導入.... ]
或在功能列中，單擊『人機應用』，在彈出的下拉式選單中選擇『配方區』，然後在彈出的右方選單中選擇[導入... ]。

2) 在『開啟』文件夾的視窗中，找到副檔名為.rbf的檔案，rbf為配方區導出後的副檔名，點選此檔案後選擇『開啟』，配方區會被導入到專案中。

 ■ 在PC上檢視及編輯配方數據
 在PC上，使用者可使用RecipeEditor檢視或編輯副檔名為.prd的配方數據 。

■ 在HMI上檢視及編輯配方數據
 在HMI上，使用者可使用配方表來檢視及編輯配方數據。詳細說明，請參考章節 11.7.。

■ 在HMI上選取配方
 在HMI上，使用者可以使用配方選擇器選取配方。詳細說明，請參考章節 11.6.。

■ 傳輸配方
 詳細說明，請參考章節 11.4。


11.4.1. 傳輸配方（PC和HMI)

傳輸配方（PC和HMI）

■ 使用DTH工具 (Data Transfer Helper) ( DTH )

 使用者可使用DTH從PC下載配方數據(*.prd/*.csv檔)到人機；也可以從人機將配方數據傳送到PC上。下圖為使用DTH下載或上傳配方的範例。

欲執行DTH，請由電腦程式集選擇開始 > 所有程式 > “本HMI編程軟體” > DTH Data Transfer Helper (DTH)。


11.4.2. 傳輸配方(HMI和USB隨身碟/Micro SD卡)

傳輸配方（HMI和USB隨身碟/Micro SD卡）

■ 使用功能按鈕 ( [image] )

 用戶可使用功能按鈕，複製配方數據到.txt\.csv/.prd檔案；或使用.txt\.csv/.prd檔案更新配方數據。詳細說明，請參考章節 5.4.1 基本功能。


11.4.3. 傳輸配方（電池保護記憶體和快閃記憶體）

傳輸配方（電池保護記憶體和快閃記憶體）

■ 使用巨集指令 ( [image] )

 使用者可使用巨集指令RB2ROM儲存配方區數據到快閃記憶體；使用巨集指令ROM2RB從快閃記憶體讀取配方數據到配方記憶區。詳細說明，請參考章節15.4.11 配方操作。
■ 使用功能按鈕 ( [image] )

 使用者可使用功能按鈕，儲存配方數據到快閃記憶體或是從快閃記憶體讀取配方數據到配方記憶區。詳細說明，請參考章節 5.4.1 基本功能。


11.4.4. 傳輸配方（HMI和PLC控制器）

傳輸配方（HMI和PLC控制器）

■ 使用命令區與狀態字( [image] )

 使用者可以設定命令區的命令位，使人機進行以下操作：設定當前配方編號、從PLC讀取配方或寫出配方數據到PLC。使用者也可勾選相關的配方的狀態字變數，接收當前配方區編號或當前配方編號。詳細設定，請參考章節 3.6. 命令區和狀態字。

 PLC欲改變當前配方編號，PLC先在參數二暫存器設定配方區號，在參數一暫存器設定配方編號。然後，勾選命令位中設當前配方編號($C2.2)。這樣藉由控制 PLC 命令旗標(#2)設on，就可以改變HMI的$RNm(當前配方編號暫存器，m：配方區編號)。

 欲讀取PLC的配方更新到人機，PLC先在參數二暫存器設定配方區號，在參數一暫存器設定配方編號。然後，勾選命令位中從PLC讀取配方($C2.3)。這樣藉由控制 PLC 命令旗標(#3)設on，就可以將PLC的配方數據上傳到人機，更新指定的人機配方數據。

 欲寫出配方到控制器，PLC先在參數二暫存器設定配方區號，在參數一暫存器設定配方編號。然後，勾選命令位中寫出配方到PLC($C2.4)。這樣藉由控制 PLC 命令旗標(#4)設on，就可以從人機送出指定的配方數據到PLC的配方區。

 註一：當人機應用只有一個配方區，則不須指定配方區號。
 註二：要使上述的操作有效，所指定的配方區必須存在，否則人機不會執行此項操作。另外，在參數一暫存器所設定的指令配方編號必須介於0與最大配方數-1之間，如果大於或等於最大配方數，則人機不會執行此項操作。

■ 使用功能按鈕 ( [image] )

 上述功能，使用者也可以使用功能按鈕來寫出當前配方到PLC，或從PLC讀取配方來更新當前配方。詳細說明，請參考章節 5.4.1 基本功能。


11.5. 配方区

配方區

使用者可在配方區屬性視窗中進行配方區屬性的設定，有兩種開啟配方區屬性視窗的方式：

1) 在專案管理員視窗中，在欲開啟的配方區上點擊滑鼠右鍵，在彈出的右鍵選單中選擇 『屬性』。
2) 在功能列中，點選人機應用 ，在彈出的下拉式選單中選擇『配方區』，然後在彈出的右方選單中選擇『屬性 』，會出現當前人機應用的所有配方區，再從中選取所需的配方區。

配方區屬性視窗包含以下二個頁面：

■ 一般頁
詳閱章節 11.5.1.說明

■ 數據項頁
詳閱章節 11.5.2.說明


11.5.1. 配方区 - 一般设定

配方區 - 一般設定

本章節說明配方區一般頁中各項屬性的設定，以下是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
名稱 |  | 配方區的名稱，長度不可超過48個字元。
區號 |  | 配方區的編號，範圍從0到15。在相同人機應用中此編號不會重複。
配方長度 |  | 設定配方一組數據的長度，單位為字。單組配方長度最大可達8192字(words)。
配方總數 |  | 設定配方記憶體組數的最大值。
記憶區需求量 |  | 自動試算所需配方記憶區的大小，單位為字。計算公式為：記憶區需求量 = 配方長度 * 配方總數。
儲存 | 電池保護記憶體 | 選中此選項，配方資料將儲存在人機的電池保護記憶體，配方資料在人機斷電後不 會消失。
 | 一般記憶區（停電消失） | 勾選這個選項，配方資料將儲存在人機的一般記憶體，人機斷電後，配方數據將被清除。
 | 需要快閃記憶體空間儲存數據備份 | 勾選是否需要快閃記憶體空間來儲存配方數據備份。 使用PC組態運行(HMI Runtime)需要設置檔案存放的路徑和檔案名。
寫出配方到PLC |  | 勾選是否寫出配方到PLC。
寫出地址 |  | 當勾選寫出配方到PLC後，出現此選項。設定PLC的配方區的起始位址。 點擊 [image] 圖標，輸入所需的地址；點擊 [image] 圖標，選取所需的標籤。讀/寫長度欄可設定寫出配方的長度。
顯示寫出進度 |  | 勾選此選項，當寫出配方數據到PLC / 設備的動作進行時，畫面會顯示視窗進度條，當寫出動作完畢，視窗會自動關閉。
通知 |  | 勾選此選項，設定通知位的地址。當寫出配方到PLC 動作完成，通知位狀態會變為On。
位 |  | 當勾選通知欄後，設定通知位的地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
從PLC讀取配方 |  | 勾選是否從PLC讀取配方。
讀取地址與寫出地址相同 |  | 勾選讀取位址是否與寫出位址相同。當勾選此選項，則不需設定讀取地址。另外，當勾選從PLC讀取配方，此選項才會出現。
讀取地址 |  | 當勾選從PLC讀取配方，設定PLC配方區的起始位址。 點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。讀/寫長度欄可設定讀取配方的長度。
顯示讀取進度 |  | 勾選此選項，當從PLC / 設備讀取配方數據的動作進行時，畫面會顯示視窗進度條，當讀取動作完畢，視窗會自動關閉。
通知 |  | 勾選此選項，設定通知位的地址，當 從PLC讀取配方 動作完成，通知位狀態會變為On。
位 |  | 當勾選『通知』欄後，設定通知位的地址。點擊 [image] 圖標，輸入所需的地址。點擊 [image] 圖標，選取所需的標籤。
讀/寫長度 |  | 設定寫出和讀取的配方長度。
顛倒32位元數據的高低字順序 |  | 勾選此選項，當數據項的數據類別為32位元(如32位整數或32位浮點數)，PLC的寫出和讀取地址以Big-endian位元組順序儲存數據。
配方記憶區 |  | 設定配方區在人機內部記憶區的地址範圍。
 |  | 範圍類別 | 地址格式 | 說明
 |  | 位地址範圍 | $Rm:n.b b: 0-f | 在範圍內的每個位地址，為配方字的位地址。
 |  | 位地址範圍 | $Rm:n | 在範圍內的每個字地址，為配方字地址。
 |  | 說明： m = 配方區編號 ； n = 配方字個數 ； b = 位編號
當前配方 |  | 設定當前配方在人機內部記憶區的地址範圍。
 |  | 範圍類別 | 地址格式 | 說明
 |  | 位地址範圍 | $CRm:n.b b: 0-f | 在範圍內的每個位地址，為當前配方字的位地址。
 |  | 字地址範圍 | $CRm:n | 在範圍內的每個字地址，為當前配方字地址。
 |  | 當前配方編號暫存器 | $RNm | 人機的內部暫存器，設定指定配方區的當前配方編號。
 |  | 說明： m = 配方區編號 ； n = 配方字個數 ； b = 位編號


11.5.2. 配方區 - 數據項目設定

配方區 - 數據項目設定

本章節說明配方區數據項頁中各項屬性的設定。下圖是數據項頁的圖例。

數據項頁包含兩部分。左半部是數據項清單，顯示數據項的地址和名稱。右半部顯示選擇的數據項及其屬性。點擊左半部的數據項清單可選取數據項。下表為數據項各項屬性的說明。

屬性

 說明
地址 | 顯示數據項的地址。
名稱 | 使用語言欄所設定的語言，設定數據項的名稱。
上移 | 點擊次按鈕向上移動已選對象。上移按鈕將重新排列數據項的顯示順序。
下移 | 點擊次按鈕向下移動已選對象。上移按鈕將重新排列數據項的顯示順序。
數據項名稱語言 | 設定數據項名稱所使用的語言。
數據項 | 數據類別 | 數據項的數據類別，支援以下幾種：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、ASCII字串和Unicode字串。
顯示類別

設定數據項數值的顯示類別。下表為不同數據類別下的顯示類別。

數據類別 | 顯示類別
16位正整數 | 16位十進制正整數、16位八進制數、16位十六進制數
32位正整數 | 32位十進制正整數、32位八進制數、32位十六進制數
16位整數 | 16位十進制整數
32位整數 | 32位十進制整數
16位BCD正整數 | 16位十進制正整數
32位BCD正整數 | 32位十進制正整數
32位浮點數 | 32位浮點數
ASCII字串 | ASCII字串，西歐字串，西裏爾字串
Unicode字串 | 中文（中國）字串，中國（台灣）字串，Unicode字串
總位數 | 設定數據項數值顯示的位數。
小數位數

設定數據項數值的小數部份顯示方式。當顯示類別是32位浮點數，則此選項為設定顯示的小數位數。當數據類別不是32位浮點數，則此選項除了為顯示的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。

範例：

顯示類別 | 總位數 | 小數位數 | 取樣數值 | 顯示數值
32位浮點數 | 4 | 2 | 12.34 | 12.34
32位浮點數 | 4 | 2 | 123.4 | 23.40
16位十進制整數 | 5 | 2 | 12345 | 123.45
16位十進制整數 | 5 | 2 | -5 | -0.05
註: 此屬性適用於初始值，允許的最低限度，並在數字鍵盤上允許的最大的顯示。
縮放

勾選此選項，數據項的數值以縮放的方式顯現。以下是數值縮放的公式。

顯示數值 = 監視數值 * 增益 + 偏移量

註：增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件捨去造成的誤差。
增益 | 當勾選縮放選項後，此選項才會出現。設定縮放公式中的增益參數值。
偏移量 | 當勾選縮放選項後，此選項才會出現。設定縮放公式中的偏移量 。
範圍檢查 | 勾選此選項，數據項檢驗所輸入的數值是否符合最大最小值的範圍。如果所輸入的數值超過範圍，數值將為無效的輸出。
最小值 | 設定最小值的數值。
最大值 | 設定最大值的數值。


11.6.1. 配方選擇器 - 基本功能

配方選擇器 - 基本功能

配方選擇器可以有以下幾種控制方式：

種類 | 說明
清單 | 配方選擇器為一清單方塊，顯示配方區的配方索引清單。索引字串的格式為配方名稱(配方編號)，每一行顯示一個配方索引字串。 當前配方的索引字串會反色強調，如果所需的配方不在清單中，可利用清單右方的捲動條捲動索引清單。當選擇所需配方後，配方選擇器會寫入配方編號到當前配方編號暫存區。
下拉式清單 | 配方選擇器是一個下拉式清單，顯示當前配方的索引字串和向下箭頭符號，如下圖所示： 當觸壓按鈕，在配方選擇器下方顯示清單方塊，如下圖所示： touched 清單方塊顯示所有配方的索引字串。每一行一個配方索引字串。當前配方的索引字串反色強調。如果所需的配方不在清單中，可利用清單右方的捲動調捲動索引清單。當選擇所需配方後，配方選擇器會寫入配方編號到當前配方編號暫存區並結束清單方塊。 如果要取消方塊清單的顯示。點選方塊清單以外的區域即可。
字元輸入器 | 配方選擇器是一個字元顯示器。它顯示了當前配方的索引字串。 當單擊文本欄位時，拼音中文（中國）字串或ASCII字元鍵盤[字節數組（字串）]將會顯示出來。下面是一個例子ASCII字元鍵盤。 點擊“確認”按鈕，選擇一個配方的名字開始從M.如果配方不存在時，鍵盤會顯示“？”，在輸入正確的配方名前，字元 鍵盤會一直保持在當前頁面。 如果搜尋到配方，字元鍵盤將自動關閉，選定的配方將顯示在文本欄位的索引字串。 取消操作時，按一下“ESC”鍵。
下拉式清單與字元輸入器 | 配方選擇器是一個『字元輸入器』和『下拉式清單』的組合體。點擊文本欄位，它會像字元輸入一樣的執行。如果按下向下箭頭符號的按鈕時，它像一個 下拉式清單。


11.6.2. 配方選擇器 - 功能選項

配方選擇器 - 功能選項

下表是配方選擇器中可增加的功能選項。選項的設定可在屬性對話框中完成。

選項 | 說明
觸控有效 | 觸摸操作，可以啟用或禁用或者通過指定位或當前用戶等級。在高級頁中選擇並設置此選項。
操作記錄 | 在操作 紀錄，記錄每個指定變量的變化。在高級頁中選擇並設置此選項。
顯現控制 | 設定配方選擇器的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


11.6.3. 配方選擇器 - 設定

配方選擇器 - 設定

所有配方選擇器的設定都可在屬性視窗中完成。配方選擇器的屬性視窗包含以下三個頁面。

■ 一般頁
詳閱章節 11.6.4.說明

■ 進階頁
詳閱章節 4.4.5.說明

■ 顯現頁
詳閱章節 4.4.6.說明


11.6.4. 配方選擇器 - 一般設定

配方選擇器 - 一般設定

本章節說明配方選擇器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 | 說明
編號 | 設定配方選擇器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為RSnnnn。
註 | 可加入說明文字。
外型 | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 ：設定物件外型。
種類 | 設定配方選擇器的種類：
 | 種類 | 說明
 | 清單 | 持續顯示清單方塊。
 | 下拉式清單 | 當點選向下箭頭符號，才會顯示清單方塊。
 | 字符輸入器 | 允許 使用者輸入全名或部分名稱搜尋配方。配方選擇器將試圖找到其名稱完全匹配輸入字符串的配方。如果不存在這樣的配方，選擇器將嘗試找到它的名字的前半部分完全匹配輸入字符串的第一個配方。
 | 下拉式清單與字符輸入器 | 點擊所選 擇配方左側的字符輸入器，輸入配方的全名或者部分名稱。或者你可以點擊向下箭頭圖標，從下拉列表中選擇一個配方。
配方區 | 設定欲選取配方所在的配方區。
配方名 | 從清單中選擇一數據項作為配方名。用戶可從下拉式清單中，選擇數據種類為ASCII字串的數據項作為配方名。
排序 | 勾選清單表列中的配方是否依配方名自動排序。
接收條形碼輸入 | 選中此選項，如果你要選擇從USB條形碼掃描器輸入條形碼配方。當類型為字符輸入的字符輸入或下拉列表，此功能可用 。
字體 | 設定配方選擇器顯示的字體。
文字顏色 | 設定配方選擇器顯示的文字顏色。
捲動條寬 | 設定右側捲動條的寬度。


11.7.1. 配方表 - 基本功能

配方表 - 基本功能

配方表共有三種顯示方式。

種類 | 說明
水平總覽 | 逐列顯示配方，逐行顯示數據項。 上圖為水平總覽配方表的範例。第一列為數據項的名稱，其餘每一列顯示一個配方，第一行顯示配方編號。用戶可以使用捲動按鈕和捲動條物件來捲動配方表內容。
垂直總覽 | 逐行顯示配方，逐列顯示數據項。 上圖為垂直總覽配方表的範例。第一行為數據項的名稱，其餘每一行顯示一個配方。第一列顯示配方編號。用戶可以使用捲動按鈕和捲動條物件來捲動配方表內容。
當前配方 | 逐列顯示當前配方的數據項。 上圖為當前配方表的範例。第一行為數據項的名稱，另一行為當前配方。用戶可以使用捲動按鈕和捲動條物件來捲動配方表內容。


11.7.2. 配方表 - 功能選項

配方表 - 功能選項

下表是配方表中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定配方表的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


11.7.3. 配方表 - 設定

配方表 - 設定

所有配方表的設定都可在屬性視窗中完成。配方表的屬性視窗包含以下三個頁面。

■ 一般頁
詳閱章節 11.7.4.說明

■ 數據項頁
詳閱章節 11.7.5.說明

■ 顯現頁
詳閱章節 4.4.6.說明


11.7.4. 配方表 - 一般設定

配方表 - 一般設定

本章節說明配方表一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定配方表的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為RTnnnn。
註 |  | 可加入說明文字。
外型 |  | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
種類 |  | 選擇配方表的種類：
 |  | 種類 | 說明
 |  | 水平總覽 | 逐列顯示配方，逐行顯示數據項。
 |  | 垂直總覽 | 逐行顯示配方，逐列顯示數據項。
 |  | 當前配方 | 逐列顯示當前配方的數據項。
允許操作者修改 |  | 勾選是否允許操作者更新數據項的數值。
配方 |  | 設定配方表欲顯示的配方區。
抬頭 | 語言 | 設定檢視和編輯抬頭所使用的語言。
 | 字體 | 設定抬頭文字的字體。
 | 顏色 | 設定抬頭文字的顏色。
 | 背景色 | 設定抬頭列的背景色。
 | 配方編號 | 設定抬頭的配方編號。
格線 | 垂直 | 勾選配方表是否顯示垂直格線。
 | 水平 | 勾選配方表是否顯示水平格線。
 | 顏色 | 設定格線顏色。
數據 | 字體 | 設定數據顯示的字體。
 | 預設顏色 | 設定數據顯示的預設顏色。
 | 採用預設顏色 | 點擊此按鈕，設定所有的數據項顏色為預設顏色。
配方編號 | 顏色 | 設定配方編號的顏色。
行距 |  | 設定配方表每一列的間隔距離。
項距 |  | 設定配方表每一行的間隔距離。


11.7.5. 配方表 - 數據項設定

配方表 - 數據項設定

本章節說明配方表數據項頁中各項屬性的設定。下圖是數據項頁的圖例。

下 表為數據項頁中各項屬性的說明。

屬性 |  | 說明
語言 |  | 設定檢視及編輯物件設定所使用的語言。
屬性表的第n列 | 名稱 | 數據項 #n的名稱。數據項的名稱可在數據收集器的數據項頁中進行設定。
 | 顯示 | 勾選是否顯示數據項 #n。
 | 顏色 | 設定數據項 #n的顯示顏色。
 | 欄寬 | 設定顯示欄位的寬度。選項有：標準、窄、超窄、寬、超寬。
 | 調整 | 設定顯示數據項 #n的調整。有三種調整方式，如下表所示：
 |  | 選項 | 說明
 |  | 前頭去零 | 當前頭位數為0時，不顯示數字。
 |  | 零領頭 | 顯示所有位數的數字。
 |  | 空格領頭 | 前頭的位數數字為0時，顯示空白字元。
移上 |  | 點擊此按鈕將所選數據項向上移一行。移上按鈕有助於重新排列數據項的顯示順序，當同時選擇多行或沒有選擇任何一行或選擇第一行時，此按鈕不會出現。
移下 |  | 點擊此按鈕將所選數據項向下移一行。移下按鈕有助於重新排列數據項的顯示順序，當同時選擇多行或沒有選擇任何一行或選擇最後一行時，此按鈕不會出現。


12.1. 警報

警報

欲在人機應用中使用警報顯示器，首先，須先設定警報屬性；然後，新增一個警報區。本章將說明如何設定警報屬性和警報區。同時，也將說明如何設定不同種類的警報設定，包含警報歷史、警報計數、當前警報和警報走馬燈。

欲在人機應用中使用警報，請依以下步驟操作：

  1. 設定警報屬性
     詳閱章節 12.2說明。

  2. 新增並設定數位警報區或類比警報區
     詳閱章節 12.4和章節 12.5說明。

  3. 建立並設定警報顯示器
     詳閱章節 12.6說明。

用戶可使用命令區中的命令位控制旗標或使用功能按鈕，清除人機的警報歷史記錄或清除警報計數。

關於命令區的命令位設定，請參考章節 3.6 命令區與狀態字的說明；關於功能按鈕的設定，請參考章節 5.4.1 功能按鈕的說明。


12.2. 設定警報屬性

設定警報屬性

使用者可在警報屬性視窗中設定警報屬性。在屬性視窗中，使用者可設定警報記錄所需紀錄的筆數、警報訊息預設顏色及字體、儲存歷史警報的方式及全局警報跑馬燈。雙擊專案管理員視窗中的警報圖示，即會跳出警報屬性視窗。下圖為警報屬性視窗的圖例。

下表為警報屬性視窗中各項屬性的說明。

屬性 |  | 說明
警報記錄記憶區 | 大小 | 設定警報記錄記憶區的紀錄筆數。假設，當大小設定為100，則當第101個警報發生，將會覆蓋第1 筆警報記錄。
 | 每筆報警記錄最多要附帶記錄數據個數 | 顯示每筆警報要附帶紀錄的數據個數，數據個數的數量可以在數位警報或類比警報的屬性視窗中『紀錄指定的數據』選項下設置。
 | 電池保護記憶體需求量 | 設定警報記錄記憶區大小，單位為位元組。計算公式為：電池保護記憶體需求量 = 記錄筆數 * 20 + 資料個數 * 4 + 28。
儲存警報歷史到檔案 | 儲存警報歷史到檔案 | 勾選此選項，最近的警報記錄將定期地寫入指定的檔案中。每當執行此項操作時，只有尚未儲存到檔案的警報記錄，才會被寫入到檔案中。
 | 檔案種類 | 儲存檔案相關設定：
 |  | 檔案種類 | 說明
 |  | .CSV | 歷史警報記錄儲存為CSV格式檔案，使用者可使用Microsoft Excel 瀏覽CSV檔案。
 |  | .XLS | 歷史警報記錄儲存為XLS格式檔案，使用者可使用Microsoft Excel 瀏覽XLS檔案。該檔案只在PC組態運行(HMI Runtime)的時候可用。
 | 檔案處理方式 | 指定打開保存數據檔案的方法：
 |  | 操作類型 | 說明
 |  | 新建 | 新建表示每次設定的存檔開始在指定的時間執行時，每次都會新產生一個警報檔案。
 |  | 附加或新建 | 附加表示警報紀錄為單一檔案，如果檔案已經存在，警報歷史紀錄將會被添加到單一檔案中。如果檔案不存在，系統將新建檔案以保存歷史警報記錄數據。
 | 儲存時間 | 設定儲存警報歷史記錄的間隔時間。當勾選儲存警報歷史至檔案後，此選項才會出現。共有9個選項：每小時整點、每八小時(00:00, 08:00, 16:00)、每12小時(00:00, 12:00)、每天(00:00)、每天(08:00)、每天(12:00)、每週日(00:00)、每週一(00:00)、每月一號(00:00)、每分鐘（測試使用）、每5分鐘、每10分鐘、每15分鐘、每30分鐘。
 | 預設檔案夾 | 勾選此選項，保存檔案到預設檔案夾。詳細請參閱章節3.1.4預設檔案夾的說明。
 | 檔案名稱可變 | 勾選該選項，警報紀錄的檔案名稱可由指定的內部記憶區所儲存的字串作為可變更的檔案名稱。
 | 檔案名稱 | 設定儲存歷史警報的檔案名稱。警報記錄會以文字檔的格式儲存，且副檔名為“.csv”或“.xls”。使用者可用文字編輯器或Excel直接檢視警報記錄。當勾選儲存警報歷史到檔案後，此選項才會出現。
 | 檔案名後綴 | 當操作類型被選定時，該功能確保所新增的文件名稱是唯一的，不會覆蓋其他文件。有4 種後綴名供使用者選擇。
 |  | 檔案名後綴 | 描述 | 說明
 |  | _YYMMDD_hhmmss | 年(00-99) 月(01-12) 日(01-31) 時(00-23) 分(00-59) 秒(00-59) | Log_090423_102358 假設指定的檔案名是"Log"，當前的日期是2009年4月23日，而當前的時間為10:23:58
 |  | _YYMMDD_hhmm |  | Log_090423_1023
 |  | _YYMMDD_hh |  | Log_090423_10
 |  | _YYMMDD |  | Log_090423
 | 附加輔助數據使人機能夠讀回此檔案 | 勾選此選項，保存檔案時會儲存輔助數據，能夠讓人機讀取儲存的檔案。
 | 存檔時不顯示相關訊息 | 勾選此選項，當儲存警報紀錄時不會出現表示儲存進度的視窗。
儲存警報歷史數據到數據庫 | 存儲警報歷史數據到數據庫 | 勾選此選項，警報歷史記錄將定期寫入到指定的數據庫。每次執行此操作，只寫入尚未保存的記錄到資料庫中。此選項為圖控系列運行選項。
 | 數據表名 | 設定要儲存到數據庫中的數據表名稱。
 | 數據表欄位名 | 按一下 [image] 編輯按鈕以打開下列視窗進行相關設定。請注意，名稱必須符合數據庫命名規則且不可重複。
 | 儲存時間 | 設定儲存警報歷史記錄的間隔時間。當勾選『儲存歷史景報到數據庫』時此選項才會出現。共有14個選項：每小時整點；每8小時(00:00、08:00、16:00)；每12小時(00:00、12:00)；每天00:00；每天08:00；每天12:00；每週日00:00；每週一的00:00；每個月一號00:00，每天、每分鐘（測試用）、每5分鐘、每10分鐘、每15分鐘、每30分鐘。
全局警報跑馬燈 | 任一警報發生時就顯示 | 勾選此選項，當有任一警報發生，即在當前畫面顯示全局警報跑馬燈。
 | 位置 | 設定全局警報跑馬燈顯示的位置，如下所示。
 |  | 位置 | 說明
 |  | 上 | 全局警報跑馬燈顯示於畫面的最上方。
 |  | 中 | 全局警報跑馬燈顯示於畫面的中央。
 |  | 下 | 全局警報跑馬燈顯示於畫面的最下方。
 | 屬性 | 點擊此按鈕，進入警報顯示器屬性設定視窗，可設定警報跑馬燈的屬性。詳細說明，請參考章節 12.6.4。
警報訊息預設顏色 | 等級1、 等級2… 等級8 | 設定警報等級1、2…8的預設顏色。警報顯示器將依預設的顏色顯示警報訊息。
警報訊息預設字體 | 語言 | 選擇預設語言。使用者使用預設語言，檢視及編輯警報訊息相關的語言屬性設定。相關的語言屬性包括抬頭字體，警報文字與警報狀態縮寫。
 | 字體 | 選擇預設字體。使用者使用預設字體，檢視及編輯警報訊息相關的字體屬性設定。相關的字體屬性包括抬頭字體，警報文字與警報狀態縮寫。
使用位$S555.0指示當前有警報發生 |  | 系統位$S555.0可用於 表示至少有一個警報正在發生。當該位(bit)為1，這表明至少有一個被觸發的警報。當該位為0 (off)，表示沒有警報發生。
每筆記錄加上序號 |  | 勾選此選項，每筆警報顯示前方會加上序號，方便使用者辨認警報紀錄。
警報訊息方塊的標題區域的顏色可以 與所顯示的警報的級別相關聯 |  | 要啟用該功能，請選擇“警報訊息盒的抬頭區底色採用當時警報等級對應的預設顏色”。


12.3.1. 新增警報區

新增警報區

新增數位警報區，可依以下方法擇一操作：

  1. 在專案管理員視窗中，在警報節點( [image] )上點擊滑鼠右鍵，在彈出的右鍵選單中選擇『新增數位警報區』。
  2. 在功能列中，點選人機應用，從彈出的下拉式選單中，點選『數位警報區』， 再選擇『新增』。

新增類比警報區，可依以下方法擇一操作：

  1. 在專案管理員視窗中，在警報節點( [image] ) 上點擊滑鼠右鍵，在彈出的右鍵選單中選擇『新增類比警報區』。
  2. 在功能列中，點選人機應用，從彈出的下拉式選單中，點選『類比警報區』， 再選擇『新增』。


12.3.2. 導入和導出警報區

導入和導出警報區

■ 導入警報區

導入警報區，可依以下方法操作：

1) 在專案管理員視窗中，在警報節點( [image] )按右鍵，並選擇『導入警報區... 』。或者在功能表列中，按一下『人機應用 』，然後在彈出的下拉式選單中點擊『導入警報區... 』。

2) 要導入警報區檔案，在『開啟檔案視窗』中選擇 .CSV檔案，如果警報記錄保存在不同的資料夾，請先開啟該資料夾。

3) 點擊打開。

■ 導出警報區
 使用者能以CSV格式或XML格式導出警報區或多個警報區。如果選擇CSV格式，可以自訂導出項目。也支持多個警報區導出到一個檔案。

導出警報區，可依以下方法操作：
1) 在專案管理員視窗中，在警報節點( [image] )按右鍵，在彈出的右鍵選單中選擇『導出警報區... 』。或者在功能表列中，按一下『人機應用』，然後在彈出的下拉式選單中點擊『導出警報區……』

下面是導出警報對話框的圖例。

下表描述導出警報視窗中的每個屬性。

屬性 |  | 說明
人機應用 |  | 當前人機應用的名稱。
全選 |  | 勾選該選項會全選所有列出的警報區，取消勾選該選項則取消全選所有列出的警報區。
No. |  | 勾選No.下方的選擇框來選擇要導出的警報區。
導出到檔案 | 格式 | 導出警報區檔案格式為CSV檔案。如果選擇CSV格式， 使用者可以自訂導出項目。
 |  | 如果使用者需要警報區保存在不同的資料夾，按一下該按鈕來選擇其他資料夾。在另存新檔視窗中，選擇要指定的資料夾並打開該資料夾，然後按一下保存。
導出選項 | 全部/自定義 | 選擇『全部』選項將自動導出選定的警報區的所有屬性。選擇『自定義』選項僅會導出警報區有勾選的屬性選項，自訂選項僅針對CSV檔案格式。
 | 警報區 | 選擇要導出的警報區的各項屬性和數據資料。
 | 記錄指定的數據
 | 共通屬性
 | 類比警報屬性
確定 |  | 按一下該按鈕導出所選定的警報區。


12.3.3. 刪除警報區

刪除警報區

欲刪除數位警報區，可依下列方法擇一操作：

  1. 在專案管理員視窗中，在數位警報區( [image] )上點擊滑鼠右鍵， 在彈出的右鍵選單中選擇刪除。
  2. 在功能列中，點選人機應用，然後在彈出的下拉式選單中點擊『數位警報區 』，然後在右方的下拉選單中選擇『刪除』，並從彈出的當前人機應用數位警報區清單中，選擇欲刪除的警報區。

欲刪除類比警報區，可依下列方法擇一操作：

  1. 在專案管理員視窗中，在類比警報區( [image] )上點擊滑鼠右鍵， 在彈出的右鍵選單中選擇刪除。
  2. 在功能列中，點選人機應用，然後在彈出的下拉式選單中點擊『類比警報區 』，然後在右方的下拉選單中選擇『刪除』，並從彈出的當前人機應用類比警報區清單中，選擇欲刪除的警報區。


12.3.4. 指定要記錄的數據

指定要記錄的數據

使用者最多可以記錄和顯示8個數據值於警報顯示器中。數據的數值將會以下方的格式附加於警報訊息之後：(名稱+指定地址的數值)
 例如，記錄的數值#2，名稱為溫度，數據類型為32位浮點數，儲存地址為W10，其格式為總位數4，小數位數1。
 如果W10 的 數值為123.456，當警報發生時，以下的文字將會附加在警報訊息之後：(溫度: 123.4)

 欲指定數值，可使用指定要記錄的數據視窗。以下為視窗的範例：

specify to-be-recorded data

指定要記錄的數據屬性視窗包含兩個部份。左半部列出名稱、地址和值。右半部顯示數值相關的屬性。欲選取項目，點擊清單中值所在的欄位。下表為數值屬性的說明。

屬性

 說明
名稱 | 可設定數據項名稱，方便使用者辨認。使用語言為語言欄位所設定的語言。
語言 | 指定和編輯數據所使用的語言。
地址 | 數值的讀取地址。 地址可為任何有效的字位址。
數據類型 | 支援的的數據類型分為，16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數。
顯示類型 數據項數值的顯示類 型，下表為每種數據類型下的顯示類型。
數據類型 | 顯示類型
16位正整數 | 16位十進制正整數、16位十六進制數、16位八進制數
32位正整數 | 32位十進制正整數、32位十六進制數、32位八進制數
16位整數 | 16位十進制整數
3 2位整數 | 32位十進制整數
16位BCD正整數 | 16位十進制正整數
32位BCD正整數 | 32位十進制正整數
32位浮點數 | 32位浮點數
總位數 | 設定數據數值顯示的總位數。
小數位數
設定數據數值顯示的小數位數。當顯示類型是32位浮點數，則此選項為設定顯示數值的小數位數。當顯示類型不是32位浮點數，則此選項除了為顯示數值的小數位數，也是最少有效位數的個數。因此，輸入的數值可轉換為定點數。
 範例:
顯示類型 | 總位數 | 小數位數 | 監視數值 | 顯示數值
32位浮點數 | 4 | 2 | 12.34 | 12.34
32位浮點數 | 4 | 2 | 123.4 | 23.40
16位十進制整數 | 5 | 2 | 12345 | 123.45
16位十進制整數 | 5 | 2 | -5 | -0.05
縮放

勾選此選項，監視變數的數值以縮放的結果顯現。以下是數值縮放的公式。

顯示數值 = 監視數值 * 增益 + 偏移量

當勾選此選項後，輸入的數值，會依以下的公式縮放後輸出。

輸出數值 = (輸入數值 – 偏移量) / 增益

註：增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件捨去造成的誤差。
增益 | 當縮放選項勾選後出現。設定縮放公式中的增益參數值。
偏移量 | 當縮放選項勾選後出現。設定縮放公式中的偏移量參數值。


12.4. 數位警報區

數位警報區

使用者可在數位警報區的屬性視窗中，進行數位警報區的屬性設定，有兩種開啟屬性視窗的方式：

  1. 在專案管理員視窗中，在選擇的數位警報區 ( [image] ) 上雙擊或單擊滑鼠右鍵後，在彈出的右鍵選單中選擇屬性。
  2. 在功能列中，點選人機應用，然後在彈出的下拉式選單中點擊『數位警報區 』，然後在右方的下拉選單中選擇『屬性』，再從右方彈出的當前人機應用的數位警報區列表中，選擇欲設定的警報區。


12.4.1. 數位警報區 - 設定

數位警報區 - 設定

數位警報區屬視窗可進行數位警報區屬性的設定，下圖為數位警報區屬性視窗的圖例。

discrete alarm block

下表為屬性視窗中各項屬性的說明。

屬性 |  | 說明
區名稱 |  | 設定數位警報區的名稱，最多20個字 。
區號 |  | 設定數位警報區的 區號，範圍從0 到63。在相同人機應用中，此編號不會重覆。
種類 |  | 設定數位警報區的運作種類，有以下四種：
 |  | 種類 | 說明
 |  | 連續位 | 選擇種類為連續位，從位地址M起連續N個位，建立數位警報區。
 |  | 連續字的位 | 選擇種類為連續字的位，從位0字地址M起連續N個位，建立數位警報區。
 |  | 字的值 | 選擇種類為字的值，在字地址M建立數位警報區。當M的值介於0到N時，發生警報。
 |  | 任意位 | 選擇種類為任意位，從任意的位地址建立數位警報區，有N個任意的位。
 |  | 註：M：指定的讀取地址。N：指定地址區的大小/數量。
讀取地址 |  | 設定警報區監視變數的起始位址。 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
區大小/最大值 |  | 設定警報區大小，單位為位。區大小的最大值與警報區種類有關。下表列出不同種類的大小限制:
 |  | 種類 | 區大小/最大值
 |  | 連續位 | 256
 |  | 連續字的位 | 256
 |  | 字的值 | 0-511
 |  | 任意位 | 64
掃瞄間隔 |  | 設定人機讀取警報區及檢查警報區位狀態的間隔時間，範圍從1 到3600秒。當掃瞄間隔愈短，警報顯示器的更新就會愈快，但其他物件的更新速度將會變慢。
記錄指定的數據值 | <勾選框> | 勾選此選項，即可記錄並顯示指定的數據值在警報訊息內。
 | 數據個數 | 欲記錄的數據個數。最多可記錄8個 ，可在下拉式清單中選擇。
 | 指定… | 點擊此按鈕，在彈出的屬性視窗中，設定要記錄的數據值相關屬性與設置。詳細說明，請參考章節 12.3.4 指定記錄的數據值。
強制開啟背燈 |  | 勾選此選項，在該區發生警報時，液晶螢幕背燈將會隨之點亮。

欲設定數位警報，需要設定數位警報清單和數位警報屬性欄。數位警報清單位於數位警報區視窗的左半側，顯示警報區中所有的數位警報。數位警報屬性欄位於數位警報區視窗的右半側，顯示數位警報的所有屬性。

 下表為數位警報清單中欄位的說明。

欄位 | 說明
No. | 數位警報地址在警報區的序號。
地址/位號/值 | 如果種類為連續位或任意位，則此欄位為數位警報的地址；如果種類為連續字的位，則此欄位為數位警報在字地址中的位號；如果種類為字的值，則此欄位為數位警報讀取地址的值。
使用 | 勾選是否使用此地址的警報。
訊息 | 使用指定的語言顯示警報訊息文字。欲在警 報文字中嵌入變數，請參考 12.3.4. 指定要記錄的數據 。

先選擇欲編輯的數位警報地址，再進行編輯。欲選擇數位警報，點擊 警報列表中需要編輯的行。欲選擇多行，請先點選 No.下方的各列序號，再按住Ctrl 鍵點選多行。
 當選擇了多個警報，任何警報屬性的修改，如級別、記錄、發警報嗶聲、顯示警報訊息、顯示視窗畫面、警報收悉、記錄、通知、說明畫面等，會適用到所有選擇的警報。

 下表說明數位警報區各項屬性的設定。

屬性 |  | 說明
地址/位號/值 |  | 指示警報的狀態。on 狀態指示警報發生；off 狀態指示警報清除。欄位的定義由種類決定。
 |  | 欄位名稱 | 種類 | 說明
 |  | 地址 | 連續位 | 顯示所選數位警報的地址。
 |  | 位號 | 連續字的位 | 顯示所選數位警報的位號。
 |  | 值 | 字的值 | 顯示所選數位警報的值。
 |  | 地址 | 任意位 | 設定所選數位警報的位地址。點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
警報狀態 |  | 指定相應地址警報被觸發的狀態。如果是“1（ON）”當該位 為ON狀態時，表示相應的警報被觸發，當該位為OFF狀態時，表示相應的警報被清除。
級別 |  | 設定警報的級別，範圍從1到8，可在下拉式清單中選擇。
編號 |  | 設定警報的編號， 輸入長度的最大值為6個字元。
訊息 | 語言 | 設定訊息 文字顯示使用的語言。
 | 導入全部 | 點擊此按鈕，導入CSV文字檔，以選擇的語言項儲存文字為警報訊息。
 | 導出全部 | 點擊此按鈕，以所選語言導出訊息為CSV檔。
 | 文字 | 以選擇的語言項設定文字。當警報發生時，顯示設定的文字。
 | 顯示記錄數據值 | 勾選欲在警報訊息中，記錄和顯示的數據值。注意，只有勾選的數據值會被記錄。
記錄 |  | 勾選此選項，會在警報顯示器記錄此地址的警報。
發警報嗶聲 |  | 勾選此選項，當警報發生或清除時，將發警報嗶聲。
顯示警報訊息 |  | 勾選此選項，人機在警報發生或清除時，自動顯示警報訊息。當未勾選 『顯示警報畫面』，才能勾選此選項。
顯示警報畫面 | <勾選框> | 勾選此選項，人機在警報發生或清除時，自動顯示視窗畫面。當未勾選 『顯示警報訊息』，才能勾選此選項。
 |  | 選擇當警報發生或清除時所顯示的視窗畫面。當勾選『顯示警報畫面』，此欄位才會出現。注意，只能選擇視窗畫面。欲建立視窗畫面，請參考章節 3.9.2。
警報收悉 | <勾選框> | 若勾選 警報收悉，當警報發生時，人機顯示『警報訊息視窗』及『紀錄』按鈕。 使用者應按壓紀錄按鈕 收悉警報訊息，使人機更新當前畫面。當勾選『顯示警報訊息』或『顯示警報畫面』，才能勾選此選項。
 | 記錄 | 勾選此選項，在警報顯示器記錄收悉訊息。
 | 通知 | 勾選當觸壓紀錄按鈕，是否通知指定的位。點擊 [image] 輸入地址，點擊 [image] 選擇標籤。
 | 位 | 設定接收通知的位地址。
說明畫面 | <勾選框> | 勾選此選項，當在警報顯示器選擇警報時，顯示此警報的說明畫面。
 |  | 設定一個視窗畫面為說明畫面。
播放聲音 | <勾選框> | 勾選此選項，當警報發生或解除時，人機播放指定的聲音。
 | 聲音 | 從當前人機應用的聲音表選擇聲音檔。
 | 播放次數 | 設定聲音播放次數。
 | 撥放間隔時間 | 設定播放的間隔時間。可選擇的選項有：0秒、0.2秒、0.4秒、0.6秒、0.8秒、1秒、2秒、3秒、4秒、5秒。


12.5. 類比警報區

類比警報區

使用者可在類比警報區的屬性視窗中，進行類比警報區的屬性設定，有兩種開啟屬性視窗的方式：

1. 在專案管理員視窗中，在選擇的類比警報區 ( [image] ) 上雙擊或單擊滑鼠右鍵後 ，在彈出的右鍵選單中選擇屬性。
2. 在功能列中，點選人機應用，然後在彈出的下拉式選單中點擊『類比警報區 』，然後在右方的下拉選單中選擇『屬性』，再從右方彈出的當前人機應用的類比警報區列表中，選擇欲設定的警報區。


12.5.1. 類比警報區 - 設定

類比警報區 - 設定

類比警報區屬性視窗可進行類比警報區屬性的設定，下圖為類比警報區視窗的範例。

analog alarm block

下表為屬性視窗中各項屬性的說明。

屬性 |  | 說明
區名稱 |  | 設定類比警報區的名稱，最多20個字 。
區號 |  | 設定類比警報區的區號，範圍從64到127。在同 一個人機應用中，此編號不會重覆。
種類 |  | 設定類比警報區的運作種類，有以下二種：
 |  | 種類 | 說明
 |  | 連續字 | 選擇種類為連續字，從字地址 M 起連續 N 個字，建立類比警報區。
 |  | 任意字 | 選擇種類為任意字，從任意的字地址建立 類比警報區，有 N 個任意的字。
 |  | 說明：M: 指定讀取地址 N: 警報區大小
讀取地址 |  | 設定警報區監視變數的起始位址。 點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
區大小 |  | 設定警報區大小的最大值，單位為字。最大值將依種類而有所不同。
 |  | 種類 | 最大值
 |  | 連續字 | 16
 |  | 任意字 | 64
掃瞄間隔 |  | 設定人機讀取警報區及檢查警報區位狀態的間隔時間，從1到3600秒。當掃瞄間隔愈短，警報顯示器的更新就會愈快，但其他物件的更新速度將會變慢。
記錄指定的數據值 | <勾選框> | 勾選此選項，即可記錄並顯示指定的數據值在警報訊息內。
 | 數據個數 | 欲記錄的數據個數。最多可記錄8個 ，可在下拉式清單中選擇。
 | 指定… | 點擊此按鈕，在彈出的屬性視窗中，設定要記錄的數據值相關屬性與設置。詳細說明，請參考章節 12.3.4 指定記錄的數據值。
強制開啟背燈 |  | 勾選此選項，在該區發生警報時，液晶螢幕背燈將會隨之點亮。

欲設定類比警報，需要設定 類比警報清單和類比警報屬性欄。類比警報清單位於類比警報區視窗的左半側，顯示警報區中所有的類比警報。類比警報屬性欄位於類比警報區視窗的右半側，顯示類比警報的所有屬性。

下表為類比警報清單中欄位的說明。

欄位 | 說明
No. | 類比警報地址在警報區的序號。
地址 | 顯示類比警報的地址。
使用 | 勾選是否使用此地址的警報。
訊息 | 使用指定的語言顯示警報訊息文字。欲在警報文字中嵌入變數，請參考12.3.4. 指定要記錄的數據。

 先選擇欲編輯的類比警報地址，再進行編輯。欲選擇類比警報，點擊警報列表中需要編輯的行。欲選擇多行，請先點選 No.下方的各列序號，再按住Ctrl 鍵點選多行。

當選擇了多個警報，任何警報屬性的修改，如級別、記錄、發警報嗶聲、顯示警報訊息、顯示視窗畫面、警報收悉、記錄、通知、說明畫面等，會適用到所有選擇的警報。

下表說明類比警報的各個屬性。

屬性 |  | 說明
警報種類 |  | 共有四種類比警報：
 |  | 種類 | 說明
 |  | 低低 | 設定低低限的警報值，當監視的控制器該地址的數據值低於所設的低低限值就觸發該警報。
 |  | 低 | 設定低限的警報值，當監視的控制器該地址的數據值低於所設的低限值就觸發該警報。
 |  | 高 | 設定高限的警報值，當監視的控制器該地址的數據值高於所設的高限值就觸發該警報。
 |  | 高高 | 設定高高限的警報值，當 監視的控制器該地址的數據值高於所設的高高限值就觸發該警報。
數據類別 |  | 變數的數據類別，支援以下數據類別：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數。
地址 |  | 表示警報狀態的地址。
 |  | 種類 | 說明
 |  | 連續字 | 顯示所選擇類比警報的地址。
 |  | 任意字 | 設定所選擇類比警報的字變數地址。點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。
界限 |  | 設定警報值的極限值。當監視的控制器該地址的數據值高於或低於所設的極限值，就不取該值來記錄，而是直接記錄該極限值。
遲滯區 |  | 設定警報由ON轉為OFF和由OFF轉為ON的數值差。 若警報類別為低低或低，則遲滯區的範圍為：界限 + 界限 * 遲滯區/100，若警報類別為高高或高，則遲滯區的範圍為 ：界限 - 界限 * 遲滯區/100。
級別 |  | 設定警報級別，範圍從1到8。
ID 編號 |  | 設定警報編號，輸入長度的最大值為6個字元。
訊息 | 語言 | 設定訊息 文字顯示使用的語言。
 | 導入全部 | 點擊此按鈕，導入CSV文字檔，以 選擇的語言項儲存文字為警報訊息。
 | 導出全部 | 點擊此按鈕，以所選語言導出訊息為CSV檔。
 | 文字 | 以 選擇的語言項設定文字。當警報發生時，顯示設定的文字。
 | 顯示記錄數據值 | 勾選欲在警報訊息中，記錄和顯示的數據值。注意，只有勾選的數據值會被記錄。
記錄 |  | 勾選此選項，會在警報顯示器記錄此地址的警報。
發警報嗶聲 |  | 勾選此選項，當警報發生或清除時，將發警報嗶聲。
顯示警報訊息 |  | 勾選此選項，人機在警報發生或清除時，自動顯示警報訊息。當未勾選 『顯示警報畫面』，才能勾選此選項。
顯示 警報畫面 | <勾選框> | 勾選此選項，人機在警報發生或清除時，自動顯示視窗畫面。當未勾選 『顯示警報訊息』，才能勾選此選項。
 |  | 選擇當警報發生或清除時所顯示的視窗畫面。當勾選『顯示警報畫面』，此欄位才會出現。注意，只能選擇視窗畫面。欲建立視窗畫面，請參考章節 3.9.2。
警報收悉 | <勾選框> | 若勾選 警報收悉，當警報發生時，人機顯示『警報訊息視窗』及『紀錄』按鈕。 使用者應按壓紀錄按鈕收悉警報訊息，使人機更新當前畫面。當勾選『顯示警報訊息』或『顯示警報畫面』，才能勾選此選項。
 | 記錄 | 勾勾選此選項，在警報顯示器記錄收悉訊息。
 | 通知 | 勾選當觸壓紀錄按鈕，是否通知指定的位。點擊 [image] 輸入地址，點擊 [image] 選擇標籤。
 | 位 | 設定接收通知的位地址。
說明畫面 | <勾選框> | 勾選此選項，當在警報顯示器選擇警報時，顯示此警報的說明畫面。
 |  | 設定一個視窗畫面為說明畫面。


12.6.1. 警報顯示器 - 基本功能

警報顯示器 - 基本功能

警報顯示器共有以下四種顯示方式。

種類

 說明
警報歷史 警報顯示器可顯示警報歷史的清單畫面。
 alam history

上圖為警報歷史的警報顯示器畫面。第一列為抬頭列，顯示每一行的抬頭。其餘每一列顯示一筆警報記錄。 使用者可用捲動按鈕或捲動條，捲動表格內容。警報歷史顯示最多支援七個欄位，下表說明每一個欄位的內容。

欄位 | 說明
日期 | 警報記錄建立的日期，此欄位為選擇性的。
時間 | 警報記錄建立的時間，此欄位為選擇性的。
警報區編號 | 警報區的編號，此欄位為選擇性的。
警報級別 | 警報的級別，此欄位為選擇性的。
警報編號 | 警報的編號，此欄位為選擇性的。
警報狀態

警報記錄的種類，有以下三種。

種類 | 說明
發生 | 當警報發生時，建立發生記錄。
收悉 | 當告知收到警報時，建立收悉記錄。
清除 | 當警報清除時，建立清除記錄。
警報訊息 | 該警報的預先設定建立的文字訊息，此欄位為選擇性的。
每一列的文字顏色是由警報記錄的種類(發生，清除，收悉)所決定。
警報計數

使用者可使用警報計數顯示警報發生的次數。

上圖為警報計數顯示的範例。第一列為抬頭列，顯示每一行的抬頭。其餘每一行顯示一筆警報。使用者可用捲動按鈕或捲動條，捲動表格內容。警報計數顯示最多支援五個欄位，下表說明每個欄位的內容。

欄位 | 說明
警報區編號 | 警報區的編號，此欄位為選擇性的。
警報級別 | 警報的級別，此欄位為選擇性的。
警報編號 | 警報的編號，此欄位為選擇性的。
警報計數 | 警報發生的次數。
警報訊息 | 警報的訊息，此欄位為選擇性的。
每一列的文字顏色是由警報的級別所決定 ，每個級別可設定不同的文字顏色，不同的顏色可在『警報訊息顏色』中設定。
當前警報

當前警報可顯示當前發生的警報清單。

上圖為當前警報的範例。第一列為抬頭列，顯示每一行的抬頭。其餘每一行顯示一筆警報。使用者可用捲動按鈕或捲動條，捲動表格內容。 當前警報顯示最多支援五個欄位，下表說明每一個欄位的內容。

欄位 | 說明
日期 | 警報發生的日期。
時間 | 警報發生的時間。
警報區編號 | 警報區的編號，此欄位為選擇性的。
警報級別 | 警報的級別，此欄位為選擇性的。
警報編號 | 警報的編號，此欄位為選擇性的。
警報訊息 | 警報的訊息，此欄位為選擇性的。
每一列的文字顏色是由警報的級別所決定。
警報走馬燈

警報走馬燈可顯示並捲動當前警報的訊息。

 上圖為警報走馬燈的範例。以下文字可置於警報訊息之前。
文字 | 說明
警報區編號 | 警報區的編號。
警報級別 | 警報的級別。
警報編號 | 警報的編號。
每一列的文字顏色是由警報的級別所決定 ，每個級別可設定不同的文字顏色，不同的顏色可在『警報訊息顏色』中設定。

註：在運行時，觸壓每一行的抬頭可將警報顯示的內容排序，再觸壓同一抬頭可改變排序從昇序到降序，或從降序到昇序。可排序的欄位包含：日期、時間、警報區編號、警報級別、警報編號、警報狀態及警報計數。


12.6.2. 警報顯示器 - 功能選項

警報顯示器 - 功能選項

下表是警報顯示器中的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定警報顯示器的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


12.6.3. 警報顯示器 - 設定

警報顯示器 - 設定

所有警報顯示器的設定都可在屬性視窗中完成。警報顯示器的屬性視窗包含以下三個頁面。

■ 一般頁
詳閱章節 12.6.4.說明

■ 查詢頁
詳閱章節 12.6.5.說明

■ 顯現頁
詳閱章節 4.4.6.說明


12.6.4. 警報顯示器 - 一般設定

警報顯示器 - 一般設定

本章節說明警報顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  |  | 說明
編號 |  |  | 設定警報顯示器的編號。當物件產生時，系統會自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為ADnnnn。
註 |  |  | 可加入說明文字。
外型 |  |  | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
種類 |  |  | 設定警報顯示器的種類，有以下四種：
 |  |  | 種類 | 說明
 |  |  | 警報歷史 | 警報歷史顯示發生的警報清單。
 |  |  | 警報計數 | 警報計數顯示發生的警報次數。
 |  |  | 當前警報 | 當前警報顯示當前發生的警報。
 |  |  | 警報走馬燈 | 警報走馬燈會依設定的方向移動顯示當前警報的訊息。
數據來源 |  |  | 當警報顯示器『種類』的選項是『警報歷史』，可以選擇『警報記錄器』或『檔案』作爲警報顯示器的數據來源。如果是圖控系列在 PC組態上運行時，您可以選擇數據庫作為數據收集的來源。 當『警報歷史』的數據來源選項是『警報記錄器』， 警報顯示器將顯示警報紀錄區的採樣數據。當數據來源選項是『檔案』，警報顯示器將顯示指定的檔案緩衝區 中的採樣數據。一個人機介面最多可以設定 16個檔案緩衝區，每個檔案緩衝區都有一個唯一的編號。（介於0和15）。 使用者可以新增一個功能按鈕來載入儲存在檔案緩衝區的數據資料 ，步驟如下： 1） 新增一個功能按鈕『讀取警報記錄檔案』。 2） 選擇所需的延伸檔名，支援CSV和TXT格式檔案。 3） 指定要載入的檔案緩衝區 編號。 4） 指定所需的檔案緩衝區大小（選擇預設值，或 100∼10000 筆資料）。
檔案緩衝區編號 |  |  | 當『數據來源』是『檔案』，可由『檔案緩衝區編號』指定特定的檔，或透過功能按鈕載入歷史警報記錄。詳細設定請參考 5.4 功能按鈕 。
捲動速度 |  |  | 當警報顯示器種類為警報走馬燈時， 可設定警報訊息顯示的移動速度。
移動方向 |  |  | 當警報顯示器種類為警報走馬燈時， 可設定訊息顯示的移動方向為向左或向右。
格線 | 垂直 |  | 勾選此選項，警報顯示器將顯示垂直格線。
 | 水平 |  | 勾選此選項，警報顯示器將顯示水平格線。
 | 顏色 |  | 設定格線的顏色。
警報區 |  |  | 設定警報顯示器所顯示的警報區。設定『所有警報區』，可使警報顯示器顯示所有警報。
抬頭 | <勾選框> |  | 勾選『抬頭』的勾選框，在警報顯示器會顯示抬頭列。
 | 語言 |  | 設定檢視及編輯抬頭列所使用的語言。
 | 字體 |  | 設定抬頭文字的字體。
 | 顏色 |  | 設定抬頭文字的顏色。
 | 背景色 |  | 設定抬頭列的背景色。
 | 日期 |  | 設定日期欄位的抬頭名稱。當種類為警報歷史及當前警報時，此選項才會出現。
 | 時間 |  | 設定時間欄位的抬頭名稱。當種類為警報歷史及當前警報時，此選項才會出現。
 | 警報區編號 |  | 設定警報區編號欄位的抬頭名稱。
 | 警報級別 |  | 設定警報級別欄位的抬頭名稱。
 | 警報編號 |  | 設定警報編號欄位的抬頭名稱。
 | 警報狀態 |  | 設定警報狀態欄位的抬頭名稱。當種類為警報歷史時，此選項才會出現。
 | 警報計數 |  | 設定警報計數欄位的抬頭名稱。當種類為警報計數時，此選項才會出現。
 | 警報訊息 |  | 設定警報訊息欄位的抬頭名稱。
文字 | 排序 |  | 設定警報顯示器的排序方式。當種類不是警報走馬燈時，此選項才會出現。 註：在運行時， 若想排序警報顯示器內容，只需觸壓 警報顯示器最上方該欄位的抬頭，該欄位將會自動排序。
 | 語言 |  | 設定檢視及編輯相關的文字屬性時所使用的語言。語言相關的文字屬性包含字體和警報狀態縮寫。
 | 字體 |  | 設定文字的字體。
 | 日期 | <勾選框> | 勾選警報顯示器是否顯示日期欄位。當種類為警報歷史時，此選項才會出現。
 |  | <下拉式清單> | 設定日期顯示格式。
 | 時間 | <勾選框> | 勾選警報顯示器是否顯示時間欄位。當種類為警報歷史時，此選項才會出現。
 |  | <下拉式清單> | 設定時間顯示格式。
 | 警報區編號 |  | 勾選警報顯示器是否顯示警報區編號欄位。
 | 警報級別 |  | 設定警報級別欄位的抬頭名稱。
 | 警報編號 |  | 設定警報編號欄位的抬頭名稱。
 | 警報訊息 |  | 設定警報訊息欄位的抬頭名稱。
 | 警報清除 |  | 勾選警報顯示器是否顯示警報清除欄位。當種類為警報歷史時，此選項才會出現。
 | 警報收到告知 |  | 勾選警報顯示器是否顯示警報收到告知欄位。當種類為警報歷史時，此選項才會出現。
 | 序號 |  | 勾選警報顯示器是否顯示序號。當種類為警報歷史時，此選項才會出現。
 | 合併顯示一個警報的所有狀態 |  | 勾選此選項，一個警報的所有狀態將會顯示在同一行中（發生、清除、收悉）。不同的狀態將以自定的顏色顯現來表示，顏色可在『警報訊息顏色』中設定。
 | 警報狀態縮寫 | 發生 | 當警報發生時，警報狀態欄位所顯示的警報 發生狀態，最多可輸入3 個字元。當種類為警報歷史時，此選項才會出現。
 |  | 清除 | 當警報清除時，警報狀態欄位所顯示的警報 清除狀態，最多可輸入3 個字元。當種類為警報歷史時，此選項才會出現。
 |  | 收悉 | 當警報收 悉時，警報狀態欄位所顯示的警報收悉狀態，最多可輸入3 個字元。當種類為警報歷史時，此選項才會出現。
 | 行距 |  | 設定警報顯示器相鄰兩列間的距離(單位為 像素)。當種類不是警報走馬燈時，此選項才會出現。
 | 項距 |  | 設定警報顯示器相鄰兩行間的距離(單位為 像素)。當種類不是警報走馬燈時，此選項才會出現。
警報訊息顏色 |  |  | 點選此按鈕，將級別1到級別8的警報訊息顏色設定設為預設顏色。當種類不是警報歷史時，此選項才會出現。
 | 級別1、級別2…級別8 |  | 設定警報級別1到級別8的顏色。警報顯示器將以所設定的顏色顯示級別1到級別8的警報訊息。
 | 發生 |  | 設定警報發生的警報 發生字體顏色。當種類為警報歷史時，此選項才會出現。
 | 清除 |  | 設定警報清除的警報 清除字體顏色。當種類為警報歷史時，此選項才會出現。
 | 收 悉 |  | 設定警報 收悉的警報收悉字體顏色。當種類為警報歷史時，此選項才會出現。


12.6.5. 警報顯示器 - 查詢設定

警報顯示器 - 查詢設定

本章節說明如何查詢警報。下圖為警報顯示器視窗中，查詢頁的範例。

下表為警報顯示器查詢頁中各選項屬性的說明。

屬性 |  | 說明
支持動態查詢 |  | 當勾選此選選項，物件可顯示指定的警報，或在運行時指定的時間顯示警報。 警報編號和時間區間的設定值均存放在記憶區中的查詢參數區。在查詢視窗中的查詢參數區欄位可進行設定。
支持靜態查詢 |  | 當勾選此選選項，使用者能以『自行定義』的條件來查詢（過濾）警報紀錄。在執行查詢時，任何當前發生的警報變化都不會被 帶入到查詢中。
查詢觸發位 |  | 當觸發參數位中所設定觸發位被觸發，將執行查詢和顯示指定的警報。點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。此設定選項只支援動態查詢時可用。
查詢參數區 |  | 指定查詢參數的地址。點擊 [image] 圖標，輸入所需的地址。點選 [image] 圖標，選擇所需標籤。 下表說明參數區的數據配置。
 |  | 字 | 說明
 |  | 0 | 查詢操作的位地址與字地址說明。
 |  |  | 位 |  | 說明
 |  |  | 0 |  | 根據指定的警報編號查詢警報記錄時，此位設為"ON"，警報編號在查詢參數記憶區的第一個字設定。
 |  |  | 1 |  | 當此位設為"ON"時，查詢指定時間內的警報紀錄。 日期範圍在查詢參數記憶區的第 2∼7 個字設定，時間範圍在查詢參數記憶區的第 8∼13 個字設定。
 |  |  | 2 |  | 當此位設為"ON"時，根據指定 的『警報狀態』查詢警報記錄。使用者可在查詢參數區第 14 個字設定警報狀態參數。
 |  |  | 3 |  | 當此位設為"ON"時，根據指定 的『警報區』查詢警報記錄。使用者可在查詢參數區第 15 個字設定警報狀態參數。
 |  |  | 4 |  | 當此位設為"ON"時，根據指定 的『警報級別』查詢警報記錄。使用者可在查詢參數區第 16 個字設定警報狀態參數。
 |  |  | 5 |  | 當此位設為"ON"時，根據指定 的『警報編號』查詢警報記錄。使用者可在查詢參數區第 17∼20 個字設定警報狀態參數。
 |  |  | 6~14 |  | 保留位。必須設為 0。
 |  |  | 15 |  | 客制項目，由查詢處理巨集判別。
 |  |  | 註：如果位0和位1都是1(On)時，同時按兩個查詢條件查詢警報記錄。
 |  | 1 | 警報編號。
 |  | 2,3,4 | 開始日期：年/月/日 年(字 2): 00~99; 月(字 3): 1~12; 日(字 4): 1~31
 |  | 5,6,7 | 結束日期：年/月/日 年(字 5): 00~99; 月(字 6): 1~12; 日(字 7): 1~31
 |  | 8,9,10 | 開始時間：時/分/秒 時(字 8): 00~23; 分(字 9): 00~59; 秒(字 10): 00~59
 |  | 11,12,13 | 結束時間：時/分/秒 時(字 11): 00~23; 分(字 12): 00~59; 秒(字 13): 00~59
 |  | 14 | 警報狀態。
 |  |  | 位 |  | 説明
 |  |  | 0 |  | 顯示清除的警報。
 |  |  | 1 |  | 顯示被觸發的警報。
 |  |  | 2 |  | 顯示已知悉的警報。
 |  | 15 | 警報區 0~15; 64~79
 |  | 16 | 警報等級 1~8
 |  | 17,18,19,20 | 警報編號。空字符串結尾。最多6個字符。
 |  | 註：僅有相應的查詢選項目被 設定時，查詢參數區的1-20號字才可以使用。
參數區大小 (字) |  | 查詢參數區大小（單位：字）
查詢項目 | 日期範圍 | 勾選此選選項，顯示指定日期發生的警報記錄。
 | 時間範圍 | 勾選此選選項，顯示指定時間發生的警報記錄。當勾選日期範圍時，此選項才有效。
 | 警報定義序號 | 勾選此選項，顯示指定警報序號發生的警報記錄。
 | 警報狀態 | 勾選此選項，顯示指定警報狀態發生的警報記錄。
 | 警報區編號 | 勾選此選項，顯示指定警報區編號發生的警報記錄。
 | 警報等級 | 勾選此選項，顯示指定警報等級發生的警報記錄。
 | 警報編號 | 勾選此選項，顯示指定警報編號發生的警報記錄。
 | 客制項目（由查詢處理巨集判別） | 勾選此選項， 能以『自定義』的條件巨集來做查詢。 註：查詢巨集一定要使用"QRET"指令，當前被處理的記錄符合當前查詢條件，查詢巨集會自動停止。僅有符合條件的記錄將會顯示出來。 以下是一個 範例：僅顯示『被觸發』的警報。
 | 當前數據記憶區 | 指定一塊內部記憶區，用於保存查詢所得的警報資料。 點擊 [image] 輸入地址，點擊 [image] 選擇所需的標籤。下表是記憶區的地址説明。
 |  | 字 |  | 説明
 |  | 0 |  | 警報類型。0：數位警報 1：類比警報
 |  | 1 |  | 警報編號。
 |  | 2 |  | 警報狀態。0：清除 1：觸發 2：知悉
 |  | 3 |  | 警報區。
 |  | 4 |  | 警報等級。
 |  | 5-8 |  | 警報編號。空字符串結尾。最多6個字符。
 | 記憶區大小（字） | 當前記憶區的容量。共9個字。 請保留此記憶區域供查詢使用。


13.1. 數據收集器

數據收集器

本章說明數據收集器的設定方式，使人機應用可收集所需數據；另外，也將說明歷史數據顯示器的設定方式，用以顯示所收集的數據資料。

數據收集器可收集並儲存數據區的數值。用戶可設定欲收集數據的數據區、取樣的頻率、記憶體類別以及儲存數據到檔案的方式。
 相同人機應用最多可建立16個數據收集器，最大的取樣長度為1023字元。

用戶可使用功能按鈕，清除或儲存所收集的數據(.ldf/.txt檔)。
 功能按鈕的設定，請參考章節 5.4.1 基本功能。

 欲新增數據收集器，可依以下方法擇一操作：
1)在專案管理員視窗中，數據收集器 [image] 上點擊滑鼠右鍵，選擇 『新增數據收集器』。
2)在功能列中，點擊『人機應用』；然後，從彈出的下拉式選單中，點選『數據收集器』。然後由右方的彈出式選單中，選擇『新增』。

註：一般應用程式會留給數據收集器的存儲空間是大于或等于32MB。但是這個值是不確定的，影響其大小的因素有很多。該存儲空間的大小請參考編譯結果。如果應用程式編譯通過后，該儲存空間大小是固定不變的。


13.1.1. 數據收集器 - 設定

數據收集器 - 設定

使用者可在數據收集器的屬性視窗中，進行數據收集器的屬性設定，有兩種開啟屬性視窗的方式：

  1. 在專案管理員視窗中，移動滑鼠到所需的數據收集器( [image] )，點擊滑鼠右鍵後 ，選擇『屬性』。
  2. 在功能列中，點選『人機應用』；然後，從彈出的的下拉式選單中，點選『數據收集器』，最後，選擇『屬性 』。在當前人機應用的數據收集器清單中，選擇欲設定的數據收集器。

數據收集器的屬性視窗包含以下三個頁面：

■ 一般頁
詳閱章節 13.1.2.說明

■ 數據項頁
詳閱章節 13.1.3.說明

■ 數據收集宏
詳閱章節 15.2.6.說明


13.1.2. 數據收集器 - 一般設定

數據收集器 - 一般設定

本章節說明數據收集器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
名稱 |  | 設定數據收集器的名稱，長度的最大值為48字母。
編號 |  | 設定數據收集器的編號，範圍從0-15。在相同人機應用中的數據收集器，其編號不會重複。
讀取地址 |  | 設定取樣數據區的變數位址。 點擊 [image] 圖示，輸入所需的位址。點選 [image] 圖示，選擇所需標籤。數據區長度在『取樣長度』欄中設定。
取樣長度 |  | 設定數據的取樣長度，單位為字。
取樣總數 |  | 設定數據收集器記憶區可支援的取樣總數最大值。
取樣方式 | 計時 | 數據收集器依『時距』欄所設定的秒數，定期取樣。時距的範圍從1到65535秒。例如，當使用者欲使數據收集器每5秒取樣1次，於時距欄設定5秒即可。
 | 觸發 | 當觸發指定的位，使位狀態由Off變為On，則數據收集器開始取樣。
 | 整點 | 數據收集器依『於』欄位所設定的時間，於固定時間取樣。『於』欄位共有6組固定時間可選擇。
 |  | 於 | 固定時間
 |  | 1x | 每分鐘。
 |  | 5x | 每小時中的固定時間，時間如下：00:00、05:00、10:00、15:00、20:00、25:00、30:00、35:00、40:00、45:00、50:00、55:00。
 |  | 10x | 每小時中的固定時間，時間如下：00:00、10:00、20:00、30:00、40:00、50:00。
 |  | 15x | 每小時中的固定時間，時間如下：00:00、15:00、30:00、45:00。
 |  | 30x | 每小時中的固定時間，時間如下：00:00、30:00。
 |  | 60x | 每小時整點。
 | 計時 (短於1 秒) | 數據收集器依『時距』欄所設定的秒數，定期取樣。時距的範圍從0.1到0.9秒。例如，當使用者欲使數據收集器每0.5秒取樣1次，於時距欄設定0.5秒即可。 短於1 秒的取樣要求較高的取樣效率。由於，有許多因素會影響取樣效率，因此，無法保證一定能到達到所設定的時距。
 | 非主動取樣 (從.LDF檔案載 入) | 數據收集器的數據來源由"SAVE2LB"巨集所取得，或者由LDF, CSV, TXT檔，而非數據收集器取樣數據。詳情請查看 13.1.4. 使用數據收集器巨集收集數據。
數據記錄巨集 | 數據記錄巨集 | 勾選此選項，數據收集器數據來源是由數據記錄巨集所取得。詳情請查看選項 13.1.5. 數據記錄巨集的使用方法。
 | 取樣數據暫存區 | 指定『內部記憶區』保存數據記錄巨集採樣的數據。 點擊 [image] 圖示，輸入所需的位址。點選 [image] 圖示，選擇所需標籤。
 | 巨集記錄的數據長度 | 指定由巨集收集記錄數據的大小。
記憶區容量需求 |  | 記憶區容量的單位元是字。計算暫用容量的方法如下：
 |  | 常規方法 | 記錄器容量 | 緩衝區容量 | 備註
 |  | 計時（短與1S） | 奇數 | 取樣總數：（容量+6+1） | 數值6是時間標記。 數字1匹配每一個記錄雙字
 |  |  | 偶數 | 取樣總數：（容量+6）
 |  | 其他 | 奇數 | 取樣總數：（容量+5） | 數值5是時間標記 數字1匹配每一個記錄雙字
 |  |  | 偶數 | 取樣總數：（容量+5+1）
 |  | 註：如果用數據記錄巨集時，記錄尺寸將是數據記錄巨集的大小。否則，記錄大小為樣本大小。
存儲 | 電池保護記憶體 | 勾選此選項，數據收集器使用電池備份記憶體作為記憶區。如果使用電池備份記憶體作為記憶區，斷電後收集的數據不會丟失。
 | 一般內存（停電消失） | 勾選此選項，數據收集器使用一般記憶體作為記憶區。人機每次上電都會清除數據收集器的記憶區。
 | 檔案 | 勾選此選項，數據收集器使用指定檔案作為記憶區。只有選PC組態運行的機型才能選此選項。
取滿處理 | 停止取樣 | 勾選此選項，當記憶區已滿時，則停止取樣。
 | 通知 | 勾選此選項，當取樣總數大於『滿界限』欄位的設定時，所指定的通知位狀態變為On。
 | 位 | 當勾選『通知』欄，此選項才會出現。設定取滿通知的位地址。 點擊圖標 [image] ，輸入所需的地址。點選圖標 [image] ，選擇所需標籤。
 | 滿界限 | 當勾選『通知』欄，此選項才會出現。選擇一個百分比為滿界限的標準。當已取樣數與取樣總數的比例超過滿界限欄所設定的比例時，通知位的狀態變為On。
控制 | 清空記憶區 | 勾選此選項，數據收集器可設定觸發位，控制清空記憶區。
 | 觸發位 | 當勾選清空記憶區，此選項才會出現。數據收集器可依觸發位，控制清除記憶區。當觸發位狀態由Off變為On時，觸發數據收集器清空記憶區。
 | 觸發位 | 勾選此選項，可設定由致能位控制數據收集器取樣與否。
 | 致能位 | 當勾選致能取樣，此選項才會出現。設定致能位位址，控制數據收集器的取樣與否，當致能位狀態為On時，數據收集器執行取樣操作。
當前取樣值記憶區 | 字地址範圍 | 使用者可以運用列表裏的內部記憶區地址，顯示數據收集器從物件或者巨集裏收集的最新取樣數據。
儲存數據到檔案
 | 儲存數據到檔案 | 勾選此選項，最近收集的數據將定期地寫入指定的檔案中。每當執行此項操作時，只有尚未儲存到檔案的數據，才會被寫入到檔案中。
 | 檔案種類 | 儲存數據的檔案種類。
 |  | 檔案種類 | 說明
 |  | .CSV/.TXT | 數據以CSV或TXT的格式儲存。使用者可使用任何文字編輯軟體檢視數據。更重要的是，使用者可直接將文字檔導入Excel中檢視。
 |  | .LDF | 數據以二進制格式儲存，只可導入數據收集器使用。使用者可使用LDF檔檢視和編輯歷史數據。
 | 檔案處理方式 | 設定儲存數據至檔案的方式
 |  | 處理方式 | 說明
 |  | 新建 | 建立新檔儲存數據。
 |  | 附加或新建 | 若指定的檔案存在，附加數據至檔案；否則，建立新檔儲存數據。
 | 儲存時間 | 設定儲存數據的週期。有14種週期可供選擇：
 |  | 週期
 |  | 每小時整點
 |  | 每8小時(00:00, 08:00, 16:00)
 |  | 每12小時(00:00, 12:00)
 |  | 每天(00:00)
 |  | 每天(08:00)
 |  | 每天(12:00)
 |  | 每週日(00:00)
 |  | 每週一(00:00)
 |  | 每月一號(00:00)
 |  | 每分鐘（僅用於測試）
 |  | 每五分鐘
 |  | 每十分鐘
 |  | 每十五分鐘
 |  | 每半小時
 | 預設檔案夾 | 勾選此選項，將檔案存到預設檔案夾。詳情請查看 3.1.4. 預設檔案夾。
 | 檔案名可變 | 勾選此選項，HMI 運行時可以根據指定的內部記憶區中所儲存的字串來改變檔案名稱，點擊圖示 [image] ，輸入所需的位址。點選圖示 [image] ，選擇所需標籤。
 | 檔案名稱 | 儲存數據的檔案名稱，若檔案種類為".TXT"檔，則副檔名須為txt；若檔案種類為".LDF"檔，則副檔名須為ldf。
 | 檔案名後綴 | 當檔案處理方式為新建時，此選項才會出現。此屬性使新建檔案的檔名為唯一，檔案不會被覆蓋掉。有四種檔案名後綴可選，如下表所示。
 |  | 檔案名後綴 | 說明 | 範例
 |  | _YYMMDD_hhmmss | YY: 年(00~99) MM: 月(01~12) DD: 日(01~31) hh: 時(00~23) mm: 分(00~59) ss: 秒(00~59) | Log_090423_102358 (假設檔案名稱設為"Log"，當前日期為2009年4月23日，當前時間為10:23:58)
 |  | _YYMMDD_hhmm |  | Log_090423_1023
 |  | _YYMMDD_hh |  | Log_090423_10
 |  | _YYMMDD |  | Log_090423
 | 存檔時不顯示相關訊息 | 勾選此選項，在執行保存檔案操作時，畫面上將不顯示進度條相關資訊。
儲存數據到數據庫 | 保存數據到數據庫 | 勾選此選項，數據收集器將定期的將收集的數據寫入指定的數據庫表中，數據收集器每次將只寫入之前沒有寫入的數據。
 | 數據庫名稱 | 指定保存數據收集器數據的數據庫名稱。
 | 儲存時間 | 指定保存記錄數據的時間週期。共有14個時間週期可以使用。


13.1.3. 數據收集器 - 數據項設定

數據收集器 - 數據項設定

本章節說明數據收集器數據項頁中各項屬性的設定。下圖是數據項頁的圖例。

數據項頁包含兩部份。左半部為數據項清單，顯示每個數據項的地址以及名稱。右半部顯示所選數據項的屬性。點選數據項清單可直接選取所需的數據項。

下表為數據項目頁各項屬性的說明。

屬性 |  |  | 說明
地址 |  |  | 顯示取樣的數據項地址。
名稱 |  |  | 以語言欄所設定的語言，設定數據項的名稱。
語言 |  |  | 設定檢視及編輯數據項名稱所使用的語言。
數據項 | 數據類別 |  | 設定數據項的數據類別，支援以下幾種：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、ASCII字串及Unicode字串。
 | 顯示類別 |  | 數據項數值的顯示類別。下表顯示不同數據類別下的顯示類別。
 |  |  | 數據類別 |  |  | 顯示類別
 |  |  | 16位正整數 |  |  | 16位十進制正整數、16位八進制數、16位十六進制數
 |  |  | 32位正整數 |  |  | 3 2位十進制正整數、32位八進制數、32位十六進制數
 |  |  | 16位整數 |  |  | 16位十進制整數
 |  |  | 32位整數 |  |  | 32位十進制整數
 |  |  | 16位BCD正整數 |  |  | 16位十進制正整數
 |  |  | 32位BCD正整數 |  |  | 3 2位十進制正整數
 |  |  | 32位浮點數 |  |  | 32位浮點數
 |  |  | ASCII字串 |  |  | ASCII字串
 |  |  | Unicode字串 |  |  | 中文簡體(PRC) 字符,中文(臺灣) 字符, Unicode字串
 |  |  | 註：索引字串和字串的區別，請參閱第 13.1.6節索引字串和字串標示的區別。
 | 總位數 |  | 設定數據項數值顯示的總位數。
 | 小數位數 |  | 設定數據項數值的小數部份的顯示方式。當顯示類別為32位浮點數，則此選項為設定顯示的小數位數。當數據類別非32位浮點數，則此選項除了設定顯示的小數位數，也設定最少有效位數的個數。因此，輸入的數值可轉換為定點數。 範例：
 |  |  | 顯示類別 | 總位數 | 小數位數 |  | 取樣數值 | 顯示數值
 |  |  | 32位浮點數 | 4 | 2 |  | 12.34 | 12.34
 |  |  | 32位浮點數 | 4 | 2 |  | 123.4 | 23.40
 |  |  | 16位十進制整數 | 5 | 2 |  | 123.45 | 123.45
 |  |  | 16位十進制整數 | 5 | 2 |  | -5 | -0.05
 | 文字表 |  | 當顯示類型為編號指定字串，選擇一個位於 文字庫中的文字表。
 | 起始字串編號 |  | 當顯示類型為編號指定字串和索引指定字串時，指定文字表的起始字串編號。
 | 結束字串編號 |  | 當顯示類型為編號指定字串和索引指定字串時，指定文字表的結束字串編號。
 | 縮放 | 縮放 | 勾選此選項，數據項目的數值將以縮放的方式顯現。以下是數值縮放的公式。 顯示數值 = 監視數值 * 增益 + 偏移量 註：增益和偏移量為32位浮點數，最多為6位有效位數。因此，可能會產生四捨五入或無條件 捨去造成的誤差。
 |  | 增益 | 當勾選縮放選項後，此選項才會出現。設定縮放公式中的增益參數值。
 |  | 偏移量 | 當勾選縮放選項後，此選項才會出現。設定縮放公式中的偏移量參數值。
數據庫 | 顯示數據表使用的欄位名 |  | 勾選此選項，當人機運行將顯示數據表的欄位名於數據表的左上方。
 | 欄位名 |  | 為數據項目名稱的語言選項。


13.1.4. 儲存歷史數據到檔案

儲存歷史數據到檔案

使用者可將收集的數據儲存為LDF檔，並可之後再檢視。因此，使用者欲收集的歷史數據大小將不受電池保護記憶區和數據收集器緩衝區的大小的限制。

有三種將數據收集器所收集的數據寫入LDF的方法，如下：

  1. 使用功能按鈕中“儲存歷史數據到檔案”的功能，此功能將所有歷史數據寫入指定的LDF檔。

  2. 使用命令區進行此操作。

  3. 在數據收集器中進行設定，定時將歷史數據寫入LDF檔。

欲檢視LDF檔，首先，需將LDF檔載入數據收集器內。需滿足以下條件，數據收集器才可讀取LDF檔：

  1. LDF檔數據項的設定與數據收集器相同，並且LDF檔取樣的個數不能大於數據收集器取樣的個數。

以下是數據記錄和載入的一個範例：

數據記錄器＃3 每小時保存記錄數據至LOGGDATE_YYMMDD.ldf。

數據記錄器＃1採用被動採樣方法，能夠從文件接收數據。

使用者可以使用功能鍵從文件LOGGDATE_YYMMDD.ldf 讀取數據並保存數據到數據記錄器# 1。


13.2.1. 歷史數據顯示器 - 基本功能

歷史數據顯示器 - 基本功能

依以下步驟建立歷史數據顯示器：

  1. 從物件工具欄中，點擊歷史數據顯示器圖示 [image] ，或從功能列中，點選物件 > 歷史顯示 > 歷史數據顯示器。

  2. 將游標移動到畫面上，欲新建歷史數據顯示器的位置。

  3. 點擊滑鼠，歷史數據顯示器將置於滑鼠點擊處。

使用者可以使用歷史數據顯示器，將數據收集器所收集的數據以數值清單方式呈現。

上圖為歷史數據顯示清單的範例。第一列為抬頭列，顯示每一行的抬頭，其餘每一列顯示一筆數據。使用者可使用捲動按鈕或捲動條捲動物件內容。數據的抬頭名稱為在數據收集器屬性視窗數據項頁中所定義的數據項名稱。


13.2.2. 歷史數據顯示器 - 功能選項

歷史數據顯示器 - 功能選項

下表是歷史數據顯示器中可增加的功能選項。選項的設定可在屬性對話框中完成。

選項 | 說明
顯現控制 | 設定歷史數據顯示器的顯現與否，是否由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


13.2.3.歷史數據顯示器 - 設定

歷史數據顯示器 - 設定

使用者可以在歷史數據顯示器的屬性視窗中，進行各項屬性的設定。有三種開啟屬性視窗的方式：

  1. 在物件上雙擊滑鼠左鍵。
  2. 在物件上點擊右鍵，然後，從彈出的右鍵選單中選擇屬性。
  3. 在物件清單視窗中，在欲設定的物件上，雙擊滑鼠左鍵。

所有歷史數據顯示器的設定都可在屬性視窗中完成，歷史數據顯示器的屬性視窗包含以下三個頁面。

■ 一般頁
 詳閱章节 13.2.4.說明。

■ 數據項頁
 詳閱章节 13.2.5.說明。

■ 查詢
 詳閱章节 13.2.6.說明。

■ 顯現頁
 詳閱章节 4.4.6.說明

■ 查詢處理巨集
 詳閱章节 15.2.6.說明。


13.2.4. 歷史數據顯示器 - 一般設定

歷史數據顯示器 - 一般設定

本章節說明歷史數據顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

historic data table

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定歷史數據顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為HDDnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設置物件外型。
關聯數據收集器 |  | 選擇數據收集器，歷史數據顯示器將顯示其數據。
數據來源 |  | 選擇數據收集器或檔案作為收集數據的來源。 新功能可顯示儲存在檔案中的歷史數據。 歷史趨勢圖、歷史數據顯示器、單筆紀錄曲線圖，共有兩種數據來源可供選擇。 當選擇“數據收集器”作為物件的數據來源，物件將顯示儲存在關聯數據收集器緩衝區中的取樣數據。 當選擇“檔案”做為物件的數據來源，物件將顯示儲存在檔案緩衝區中的取樣數據。 一台HMI最多可有16個檔案緩衝區，每一個檔案緩衝區都有專屬的編號。 使用者可建立功能按鈕，讀取檔案中的取樣數據。 1) 選擇功能按鈕的“讀取歷史數據檔案”功能。 2) 選擇副檔名的類別，目前可支援CSV和TXT檔。 3) 設定關聯數據收集器。 4) 設定儲存讀取數據的檔案緩衝區。 5) 設定檔案緩衝區大小。大小為檔案緩衝區可取樣的最大值。
檔案緩衝區編號 |  | 當數據來源為檔案時，設定檔案緩衝區的編號。欲設定檔案緩衝區編號，可使用功能按鈕中的讀取歷史數據檔案功能。詳細說明，請參考章節 5.4 功能按鈕。
抬頭 | 抬頭 | 設定歷史數據顯示器是否顯示抬頭列。
 | 語言 | 設定檢視與編輯抬頭列所使用的語言。
 | 字體 | 設定抬頭文字使用的字體。
 | 顏色 | 設定抬頭文字使用的顏色。
 | 日期 | 設定日期欄位的抬頭名稱。
 | 時間 | 設定時間欄位的抬頭名稱。
 | 背景顏色 | 設定抬頭列的背景顏色。
格線 | 垂直 | 勾選歷史數據顯示器是否顯示垂直格線。
 | 水平 | 勾選歷史數據顯示器是否顯示水平格線。
 | 顏色 | 設定格線顏色。
數據 | 顯示數據由上至下從舊到新 | 勾選此項，由上至下從舊到新顯示數據。
 | 顯示序號 | 勾選此項，在第一欄顯示序號。
 | 字體 | 設定數據顯示的字體。
 | 預設顏色 | 設定數據顯示的預設顏色。
 | 將所有數據項顏色設為預設顏色 | 點擊此按鈕，設定所有數據項的顏色為預設顏色。
時間/日期顯示 | 日期 | 勾選歷史數據顯示器是否顯示日期欄位。勾選此選項，需設定日期顯示的格式。
 | 時間 | 勾選歷史數據顯示器是否顯示時間欄位。勾選此選項，需設定時間顯示的格式。
 | 顏色 | 設定時間/日期顯示的顏色。
 | 顯示相對時間 | 勾選此選項，顯示相對時間。
行距 |  | 設定歷史數據顯示器相鄰兩列的間隔距離。
項距 |  | 設定歷史數據顯示器相鄰兩行的間隔距離。


13.2.5. 歷史數據顯示器 - 數據項設定

歷史數據顯示器 - 數據項設定

本章節說明歷史數據顯示器數據項頁中各項屬性的設定。下圖是數據項頁的圖例。

historic data table

下表為數據項頁中各項屬性的說明。

屬性 |  | 說明
語言 |  | 設定檢視及編輯物件設定所使用的語言。
屬性表的抬頭列 | 名稱 | 數據項#的名稱。數據項的名稱可在數據收集器的數據項頁中進行設定。
 | 顯示 | 勾選是否顯示數據項#。
 | 顏色 | 設定數據項#的顯示顏色。
 | 欄寬 | 數據顯示器欄寬為標準欄寬。
 | 調整 | 設定顯示數據項#的調整方式。有三種調整方式，如下表所示：
 |  | 選項 | 說明
 |  | 前頭去零 | 當前頭位數為 0 時，不顯示數字。
 |  | 零領頭 | 顯示所有位數的數字。
 |  | 空格領頭 | 前頭的位數數字為 0 時，顯示空白字元。


13.2.6. 歷史數據顯示器 - 查詢頁設定

歷史數據顯示器 - 查詢頁設定

本節描述如何查詢記錄的數據。以下是對歷史據顯示器屬性對話方框查詢頁面的例子。

下表描述了歷史數據顯示器屬性對話方框查詢頁面各項屬性的說明 ：

屬性 |  | 描述
支援動態查詢 |  | 勾選此選項，可以在HMI運行時，通過動態的條件設置，對歷史數據進行篩選，顯示用戶需要展示的數據記錄。只有在運行狀態下，觸發位元由off變為on時，才會執行動態查詢功能。
支援靜態查詢 |  | 勾選此選項，可以在HMI運行時通過靜態的預定條件設置，對歷史數據進行篩選，顯示客戶希望展示的數據。在運行狀態下，查詢條件的任何更改，都不會使靜態查詢結果產生改變。
查詢觸發位 |  | 在運行狀態下，執行查詢操作指定的位。當查詢觸發位由off變為on時，人機讀取查詢參數區並且根據查詢條件刷新物件。點擊 [image] 圖標，輸入所需的位址。點選 [image] 圖標，選擇所需標籤。該選項只支援動態查詢功能。
查詢參數區 |  | 指定存儲查詢參數的位置。 點擊 [image] 圖示，輸入所需的位址。點選 [image] 圖示，選擇所需標籤。 下表顯示的查詢參數記憶區的功能字佈局。
 |  | 字 | 描述
 |  | 0 | 查詢標誌位元
 |  |  | 位 | 描述
 |  |  | 0 | 保留位。必須是0。
 |  |  | 1 | 第1位值為1，按時間範圍查詢。日期範圍在字地址1、2、3、4、5、6中設定；時間範圍在字地址7、8、9、10、11、12中設定。
 |  |  | 2~14 | 保留位。必須是0。
 |  |  | 15 | 如果第15位值為1，按查詢處理巨集所指定的條件查詢歷史記錄。
 |  |  | 註：如果位1和位15都是1，同時按兩個查詢條件查詢。
 |  | 1,2,3 | 日期範圍的開始日期。 年（字1）：0 ~ 99；月（字2）：1 ~ 12；天（字3）：1 ~ 31
 |  | 4,5,6 | 日期範圍的結束 日期。 年（字4）：0 ~ 99；月（字5）：1 ~ 12；天（字6）：1 ~ 31
 |  | 7,8,9 | 時間範圍的開始時間 時（字7）：0~23；分（字8）：0~59；秒（字9）：0~59
 |  | 10,11,12 | 時間範圍的結束時間 時（字10）：0~23；分（字11）：0~59；秒（字12）：0~59.
 |  | 註：只有勾選查詢項目時，才可以使用查詢參數區的第1-12個字。
參數區大小（字） |  | 查詢參數區的大小，以字為單位。
查詢項目 | 日期範圍 | 勾選此選項，在指定的日期範圍內執行查詢功能。
 | 時間範圍 | 勾選此選項，在指定的時間範圍內執行查詢功能。
 | 客制項目（由查詢處理巨集判別） | 勾選此選項，可以在查詢處理巨集中設置查詢條件。 註：如果當前處理的記錄是符合當前查詢和終止條件，查詢處理巨集必須使用QRET命令報告只顯示符合查詢條件的記錄 。
 | 當前數據暫存區 | 指定查詢處理巨集保存當前記錄的內部記憶區。 點擊 [image] 圖示，輸入所需的位址。點選 [image] 圖示，選擇所需標籤。
 | 內部記憶區大小（字） | 保存查詢處理巨集當前記錄內部記憶區的大小，以字為單位。


13.3.1. 歷史趨勢圖 - 基本功能

歷史趨勢圖 - 基本功能

請依以下步驟建立歷史趨勢圖：

  1. 從物件工具列中，點擊歷史趨勢圖圖標 [image] ，或從功能列中，點選物件-> 歷史顯示 -> 歷史趨勢圖。

  2. 直接拖曳滑鼠指標至畫面中欲新建歷史趨勢圖的位置。

  3. 點擊滑鼠，歷史趨勢圖將置於滑鼠點擊處。

使用者可以使用歷史趨勢圖，將數據收集器所收集的數據以趨勢圖呈現。

歷史趨勢圖最多可支援16個曲線，上方為2個曲線的歷史趨勢圖。使用者可使用游標得知某個時間點的數據估計值。

1) 歷史趨勢圖提供一個『游標』，移動游標，可得知選定的時間點的數值，時間和資料值可以顯示在歷史趨勢圖。同時，選定的時間點資料可以被寫入內部記憶區。

2) 歷史趨勢圖可以由指定一個字地址的值，在指定的位置顯示一條『輔助參考線』。一個歷史趨勢圖可以顯示一條或兩條參考線，以幫助操作者有效地讀取圖形。趨勢圖的參考線可以是一條“從左至右”的水平線或“自上而下”的垂直線，也可以是任何方向的折線。你可以在運行時控制參考線的位置。如果參考線是一條折線，您也可以控制它的形狀。

3) 在運行時，可以更改歷史趨勢圖的數值比例。

4) 歷史趨勢圖可以因應『微觀』或『全觀』的需求進行圖的縮放。

5) 歷史趨勢圖可以藉由讀取『指定位』進行動態隱藏。


13.3.2. 曆史趨勢圖 - 功能選項

歷史趨勢圖 - 功能選項

下表是歷史趨勢圖中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定歷史趨勢圖的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


13.3.3. 曆史趨勢圖 - 設定

歷史趨勢圖 - 設定

用戶可以在歷史趨勢圖的屬性視窗中，進行各項屬性的設定。有三種開啟屬性視窗的方式：

1) 在歷史趨勢圖物件上雙擊滑鼠左鍵。

2) 在歷史趨勢圖物件上點擊右鍵，然後，從彈出的視窗中選擇『屬性』。

3) 在歷史趨勢圖物件清單視窗中，在欲設定的物件上，雙擊滑鼠左鍵。

 所有歷史趨勢圖的設定都可在屬性視窗中完成。歷史趨勢圖的屬性視窗包含以下四個頁面。

■ 一般頁(General)

詳閱 章節 13.3.4. 說明。

■ 曲線頁(Curve)

詳閱 章節 13.3.5. 說明。

■ 軸頁(Axis)

詳閱 章節 13.3.6 .說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


13.3.4. 歷史趨勢圖 - 一般設定

歷史趨勢圖 - 一般設定

本章節說明歷史趨勢圖一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定歷史趨勢圖的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為HTDnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 外型設置。
圖底色 |  | 設定圖的背景顏色。
關聯數據收集器 |  | 設定歷史趨勢圖顯示的數據收集器。
數據來源 |  | 選擇數據收集器或檔案做為數據來源。
檔案緩衝區編號 |  | 當數據來源為檔案時，設定檔案緩衝區的編號。欲設定檔案緩衝區編號，可使用功能按鈕中的『讀取歷史數據檔案』功能。詳細說明，請參考章節 5.4 功能按鈕。
曲線總數 |  | 設定曲線總數。最多支持16條曲綫。
方向 | 從左到右 | 勾選此選項，歷史趨勢圖呈水平方向顯示。
 | 從上到下 | 勾選此選項，歷史趨勢圖呈垂直方向顯示。
鄰點間隔 | 根據時間 | 勾選此選項，歷史趨勢圖繪圖時，兩個相鄰點之間是以『時間』作為單位。
 | 固定距離 | 歷史趨勢圖的兩個相鄰數據點之間的空間可以是一個固定的距離（以像素為單位），而不是由兩個時間點決定的距離。
游標 | <勾選框> | 勾選此選項，歷史趨勢圖將顯示游標。使用者可以移動游標至所需的數據點。
 | 游標色 | 設定游標的顏色。
 | 數值顯示字型 | 設定所選數據點的數值顯示字型 。
 | 日期 | 勾選此選項，將在歷史趨勢圖的左上角顯示日期。勾選後，需選擇顯示日期的格式。 共有12種日期顯示的格式，如下：dd/mm/yy, mm/dd/yy, yy/mm/dd, dd.mm.yy, mm.dd.yy, yy.mm.dd, dd-mm-yy, mm-dd-yy, yy-mm-dd, dd-MMM-yy, MMM-dd-yy, and yy-MMM-dd。 註: dd: 01~31 (日); mm: 01~12 (月); yy: 00~99 (年); MMM: JAN~DEC (月)
 | 時間 | 勾選此選項，將在歷史趨勢圖的左上角顯示時間。勾選後，需選擇顯示時間的格式。 註: hh: 00-23 (小時); mm: 00-50 分鐘); ss: 00-59 (秒);
 | 日期/時間顏色 | 選擇日期/時間顯示的顏色。
 | 游標數據接收區 | 設定游標數據讀取和顯示的變數地址。 點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。
顯示相對時間 |  | 勾選此選項，物件將顯示相對時間。
支持放大縮小 |  | 勾選此選項，在運行時，人機支援放大縮小選項。當未勾選動態範圍，此選項才會出現。
動態範圍 | 動態範圍 | 當勾選此選項，以下三個範圍將在運行時設定： * 曲線Y軸數值的 『最大值」和『最小值 』。 * X軸時間範圍的 『最大值』。 * 曲線Y軸記號的 『最大值』和『最小值』。 以上三組範圍應該在動態範圍參數區中被正確地設定。使用者需在動態範圍參數區中設定動態範圍參數區。
 | 動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區的變數地址。 點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。 下表為參數區的數據設置。
 |  | 字 | 說明
 |  | 0,1 | 時間軸(X軸)時間範圍的最大值。
 |  | 2,3 | 時間軸(X軸)主分隔數個數；32位整數，最小值為1。
 |  | 4,5 | 時間軸(X軸)次分隔數個數；32位整數，最小值為1。
 |  | 6,7 | Y軸記號的最小值。
 |  | 8,9 | Y軸記號的最大值。
 |  | 10,11 | 曲線 #1 的最小Y值。
 |  | 12,13 | 曲線 #1 的最大Y值。
 |  | 14,15 | 曲線 #2 的最小Y值。
 |  | 16,17 | 曲線 #2 的最大Y值。
 |  | … | …
 |  | 70,71 | 曲線 #16 的最小Y值。
 |  | 72,73 | 曲線 #16 的最大Y值。
曲線顯示/隱藏可控 |  | 勾選此選項，可以由指定的控制字控制顯示/隱藏曲線。
曲線顯示控制字 |  | 當勾選曲線顯示/隱藏可控時，指定控制曲線顯示/隱藏的變數。 點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。當勾選”顯示/隱藏”選項時，可透過設置一個字地址來控制曲線的顯示/隱藏，藉由設置字地址中的『位地址』來控制曲線，如欲設置第一條曲線，請設置『第 0 位』為On或Off，要設置第二條曲線，設置『第 1 位』為On或Off，以此類推。
數值軸刻度種類可選 |  | 勾選此選項，可以在運行時通過數值軸刻度字變數，來更改數值軸刻度 。
數值軸刻度種類選擇字 |  | 當勾選曲線顯示控制字時，指定用來存數數值軸刻度設置的變數。點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。在歷史趨勢圖中最多可以定義5種數值軸刻度。在歷史趨勢圖的屬性對話方框軸頁面可以設置該項。下表是該項設置的一個例子。
參考線 | 種類<勾選> | 勾選此選項，可以在指定變數所指定的位置顯示參考線種類。
 | 樣式 | 為參考線選擇一種樣式。
 | 顏色 | 為參考線選擇一種顏色。
 | 位置參數類型 | 位置參數的數據類型。支持的數據類型包括：16位元無符號整數，32位元無符號整數，16位元有符號整數，32位元有符號整數，16位BCD碼，32位BCD碼，32位浮點數。
 | 位置參數 | 指定存放位置參數的字地址。點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。
 | 最小/最大值 | 指定位置參數的最小值和最大值。


13.3.5. 歷史趨勢圖 - 曲線設定

歷史趨勢圖 - 曲線設定

本章節說明歷史趨勢圖曲線頁中各項屬性的設定。下圖是曲線頁的圖例。

下表為曲線頁中各項屬性的說明。

屬性 | 屬性
編號 | 曲線編號。
數據來源 | 設定曲線顯示的數據收集器。
數據範圍 | 勾選此選項，可在運行時設定Y軸數值的最小和最大值。當勾選一般頁中的『動態範圍』，此選項才會出現。
最小值 | 曲線Y軸數值的最小值，當未勾選動態範圍，此選項才會出現。
最大值 | 曲線Y軸數值的最大值，當未勾選動態範圍，此選項才會出現。
線樣式 | 設定曲線的樣式。
顏色 | 設定曲線的顏色。
顯示數值 | 設定數據點數值的顯示方式。
顯示數值 | 說明
(無) | 不顯示數據點數值。
原始值 | 顯示原始數據點數值。
刻度值 | 顯示數據點在Y軸的刻度值。
填充 | 勾選此選項，可以在歷史曲線圖曲線下方部分的區域進行『指定色』的填充，可以選擇填充區域的樣式和顏色。
線樣式 | 設定曲線的樣式。
顏色 | 設定曲線的顏色。
背景色
為選定的曲線選擇一種顏色，用來填充圖案的白色部分。


13.3.6. 歷史趨勢圖 - 軸設定

歷史趨勢圖 - 軸設定

本章節說明歷史趨勢圖時間軸(X軸)和Y軸中，各項屬性的設定。

下表為軸頁中各項屬性的說明。

屬性 |  | 說明
時間軸 (X軸) 時間範圍 | 動態範圍 | 勾選此選項，在運行時，刻度記號的最小和最大值由物件的動態範圍參數區所控制。當勾選一般頁中的『動態範圍』，此選項才會出現。
 | 單位 | 設定動態範圍的單位。當勾選動態範圍，此選項才會出現。
 | 日/時/分/秒 | 若未勾選一般頁和軸頁中的動態範圍，須設定時間範圍的最大值。
時間軸 | 主分隔數 | 設定X軸的主分隔數，最小值為1。
 | 次分隔數 | 設定兩相鄰主要刻度間的分隔數，最小值為1。
 | 顯示刻度 | 勾選X軸是否顯示刻度。
 | 顯示Y軸格線 | 設定是否顯示垂直格線。
 | 格線顏色 | 設定垂直格線顏色。
 | 顯示時間 | 勾選是否顯示時間。當勾選此選項，需設定時間的顯示格式。
 | 顯示時間 | 設定時間顯示的格式，有兩種格式。
 |  | 格式 | 說明
 |  | HH:MM | HH: 00~23 (時); MM: 00~59 (分)
 |  | HH:MM:SS | HH: 00~23 (時); MM: 00~59 (分); SS: 00~59 (秒)
 | 時間/日期字體 | 選擇時間日期的字體。
 | 時間/日期/刻度顏色 | 設定X軸和X軸刻度的顏色。
數值 軸 | 顯示刻度 | 勾選主刻度是否顯示刻度。
 | 顯示數值格線 | 設定是否顯示水平格線。
 | 格線顏色 | 設定水平格線顏色
 | 顯示刻度記號 | 勾選主刻度是否顯示刻度記號
 | 字體 | 設定刻度記號的字體。
 | 動態範圍 | 勾選此選項，在運行時，刻度記號的最小和最大值由物件的動態範圍參數區所控制。
 | 位置 | 設定刻度的位置。刻度可顯示於物件的左邊、右邊或左右兩邊同時顯示。
 | 刻度/記號顏色 | 設定刻度/記號的顏色
數值刻度_類型 | 刻度種類數 | 刻度種類的數目。在歷史趨勢圖中最多可以設置5 種刻度種類。
 | 編號 | 數值刻度種類的編號。
 | 當前顯示 | 選擇一個類型，這樣您可以查看歷史趨勢圖的數值刻度類型設置。
 | 主分隔數 | 設定數軸的主分隔數，最小值為1。
 | 次分隔數 | 設定兩相鄰主要刻度間的分隔數，最小值為1。
 | 最小值 | 設定刻度記號的最小值，可設定32位元整數。
 | 最大值 | 設定刻度記號的最大值，可設定32位元整數。
 | 總位數 | 設定刻度記號顯示的總位元數。
 | 小數位數 | 設定刻度記號的小數位數。例如，當最大值為5000，總位數為4，小數字數為2，則刻度記號的最大值為50.00。


13.2.6. 歷史數據顯示器 - 查詢頁設定

歷史趨勢圖 - 查詢頁設定

本節描述如何查詢記錄的數據。以下是對歷史趨勢圖屬性對話方框查詢頁面的例子。

下表描述了歷史趨勢圖屬性對話方框查詢頁面各項屬性的說明 ：

屬性 |  | 描述
支援動態查詢 |  | 勾選此選項，可以在HMI運行時，通過動態的條件設置，對歷史數據進行篩選，顯示用戶需要展示的數據記錄。只有在運行狀態下，觸發位元由off變為on時，才會執行動態查詢功能。
支援靜態查詢 |  | 勾選此選項，可以在HMI運行時通過靜態的預定條件設置，對歷史數據進行篩選，顯示客戶希望展示的數據。在運行狀態下，查詢條件的任何更改，都不會使靜態查詢結果產生改變。
查詢觸發位 |  | 在運行狀態下，執行查詢操作指定的位。當查詢觸發位由off變為on時，人機讀取查詢參數區並且根據查詢條件刷新物件。點擊 [image] 圖標，輸入所需的位址。點選 [image] 圖標，選擇所需標籤。該選項只支援動態查詢功能。
查詢參數區 |  | 指定存儲查詢參數的位置。 點擊 [image] 圖示，輸入所需的位址。點選 [image] 圖示，選擇所需標籤。 下表顯示的查詢參數記憶區的功能字佈局。
 |  | 字 | 描述
 |  | 0 | 查詢標誌位元
 |  |  | 位 | 描述
 |  |  | 0 | 保留位。必須是0。
 |  |  | 1 | 第1位值為1，按時間範圍查詢。日期範圍在字地址1、2、3、4、5、6中設定；時間範圍在字地址7、8、9、10、11、12中設定。
 |  |  | 2~14 | 保留位。必須是0。
 |  |  | 15 | 如果第15位值為1，按查詢處理巨集所指定的條件查詢歷史記錄。
 |  |  | 註：如果位1和位15都是1，同時按兩個查詢條件查詢。
 |  | 1,2,3 | 日期範圍的開始日期。 年（字1）：0 ~ 99；月（字2）：1 ~ 12；天（字3）：1 ~ 31
 |  | 4,5,6 | 日期範圍的結束 日期。 年（字4）：0 ~ 99；月（字5）：1 ~ 12；天（字6）：1 ~ 31
 |  | 7,8,9 | 時間範圍的開始時間 時（字7）：0~23；分（字8）：0~59；秒（字9）：0~59
 |  | 10,11,12 | 時間範圍的結束時間 時（字10）：0~23；分（字11）：0~59；秒（字12）：0~59.
 |  | 註：只有勾選查詢項目時，才可以使用查詢參數區的第1-12個字。
參數區大小（字） |  | 查詢參數區的大小，以字為單位。
查詢項目 | 日期範圍 | 在指定的日期範圍內執行查詢功能。
 | 時間範圍 | 勾選此選項，在指定的時間範圍內執行查詢功能。


13.4.1. 歷史訊息顯示器 - 基本功能

歷史訊息顯示器 - 基本功能

依以下步驟建立歷史訊息顯示器：

  1. 從物件工具欄中，點擊歷史訊息顯示器圖示 [image] ，或從功能列中，點選物件> 歷史顯示> 歷史訊息顯示器。

  2. 直接拖曳滑鼠指標至畫面中欲新建歷史訊息顯示器的位置。

  3. 點擊滑鼠，歷史訊息顯示器將置於滑鼠點擊處。

使用者可以將人機應用中的事件編號，在運行時，儲存當前事件的編號於人機的字地址，並使數據收集器收集字地址的數值。人機依此記錄人機應用中的事件。使用者可使用歷史訊息顯示器顯示歷史訊息。歷史訊息顯示器的訊息與訊息編號有關聯。

如上圖所示，歷史數據顯示器和歷史訊息顯示器以不同的方式顯示相同的歷史數據 。


13.4.2. 歷史訊息顯示器 - 功能選項

歷史訊息顯示器 - 功能選項

下表是歷史訊息顯示器中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯現控制 | 設定歷史訊息顯示器的顯現與否，由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


13.4.3. 歷史訊息顯示器 - 設定

歷史訊息顯示器 - 設定

使用者可以在歷史訊息顯示器的屬性視窗中，進行各項屬性的設定。有三種開啟屬性視窗的方式：

  1. 在歷史訊息顯示器物件上雙擊滑鼠左鍵。
  2. 在歷史訊息顯示器物件上點擊右鍵，然後，從彈出的右鍵選單中選擇『屬性』。
  3. 在物件清單視窗中，在欲設定的物件上，雙擊滑鼠左鍵。

所有歷史訊息顯示器的設定都可在屬性視窗中完成。歷史訊息顯示器的屬性視窗包含以下三個頁面。

■ 一般頁(General)
 詳閱 章節 13.4.4. 說明。

■ 訊息頁(Message)

詳閱 章節 13.4.5. 說明。

■ 顯現頁(Visibility)
 詳閱章節 4.4.6.說明。


13.4.4. 歷史訊息顯示器 - 一般設定

歷史訊息顯示器 - 一般設定

本章節說明歷史訊息顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

historic evet table

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定歷史訊息顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為 HMDnnnn.。
註 |  | 可加入物件的說明文字。
外型設置 |  | 邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
數據收集器 |  | 設定關聯的數據收集器。歷史訊息顯示器將使用數據收集器中指定的字所收集的數據為事件編號，並依編號顯示訊息。
字 |  | 設定數據收集器中的字編號。
訊息總數 |  | 設定事件訊息總數。
抬頭 | 抬頭 | 勾選是否顯示抬頭列。
 | 語言 | 設定檢視與編輯抬頭列所使用的語言。
 | 字體 | 設定抬頭文字的字體。
 | 顏色 | 設定抬頭文字的顏色。
 | 日期 | 設定日期欄位的抬頭名稱。
 | 時間 | 設定時間欄位的抬頭名稱。
 | 訊息 | 設定訊息欄位的抬頭名稱。
 | 背景顏色 | 設定抬頭列的背景顏色。
格線 | 格線 | 勾選物件是否顯示垂直格線。
 | 水平 | 勾選物件是否顯示水平格線。
 | 顏色 | 設定格線顏色。
訊息
 | 預設顏色 | 設定訊息的預設顏色。
 | 將所有訊息顏色設為預設顏色 | 點擊此按鈕將所有訊息顏色設為預設顏色。
日期/時間顯示 | 日期 | 勾選物件是否顯示日期欄位。當勾選此選項，需設定日期顯示格式。
 | 時間 | 勾選物件是否顯示時間欄位。當勾選此選項，需設定時間顯示格式。
 | 顏色 | 為日期和時間選擇一種顏色。
行距 |  | 設定歷史訊息顯示器相鄰兩列的間隔距離。


13.4.5. 歷史訊息顯示器 - 訊息設定

歷史訊息顯示器 - 訊息設定

本章節說明歷史訊息顯示器訊息頁中各項屬性的設定。下圖是訊息頁的圖例

historic event table

下表為訊息頁中各項屬性的說明。

屬性 |  | 說明
語言 |  | 設定檢視及編輯訊息所使用的語言。
字體 |  | 設定訊息顯示的字體。
訊息編號1~N | 顏色 | 設定訊息顯示的顏色。
 | 訊息 | 設定關聯事件的訊息內容。


13.5.1. 單筆記錄曲線圖

單筆記錄曲線圖 - 基本功能

依以下步驟建立單筆記錄曲線圖：

  1. 從物件工具欄中，點擊單筆記錄曲線圖圖標 [image] ，或從功能列中，點選物件> 歷史顯示> 單筆記錄曲線圖。

  2. 直接拖曳滑鼠指標至畫面中欲新建單筆記錄曲線圖的位置。

  3. 點擊滑鼠，單筆記錄曲線圖將置於滑鼠點擊處。

使用者可使用單筆記錄曲線圖，將數據收集器所收集的數據以曲線圖呈現。

單筆記錄曲線圖最多可顯示255數據點，上方圖例為顯示8個數據點的單筆記錄曲線圖。單筆記錄曲線圖支援游標顯示，可顯示游標所在點的數值。


13.5.2. 單筆記錄曲線圖 - 功能選項

單筆記錄曲線圖 - 功能選項

下表是單筆記錄曲線圖中可增加的功能選項。選項的設定可在屬性視窗中完成。

選項 | 說明
顯示控制 | 設定單筆記錄曲線圖的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


13.5.3. 單筆記錄曲線圖 - 設定

單筆記錄曲線圖 - 設定

使用者可以在單筆記錄曲線圖的屬性視窗中，進行各項屬性的設定。有三種開啟屬性視窗的方式：

  1. 在單筆記錄曲線圖物件上雙擊滑鼠左鍵。
  2. 在單筆記錄曲線圖物件上點擊右鍵，然後，從彈出的視窗中選擇『屬性』。
  3. 在物件清單視窗中，在欲設定的物件上，雙擊滑鼠左鍵。

單筆記錄曲線圖的屬性視窗包含以下四個頁面。

■ 一般頁(General)
 詳閱 章節 13.5.4. 說明。

■ 筆頁(Pen)
 詳閱 章節 13.5.5. 說明。

■ 軸頁(Axis)
 詳閱章節 13.5.6.說明。

■ 顯現頁(Visibility)

詳閱章節 4.4.6.說明。


13.5.4. 單筆記錄曲線圖 - 一般設定

單筆記錄曲線圖 - 一般設定

本章節說明單筆記錄曲線圖一般頁中各選項屬性的設定。下圖是一般頁的圖例。

single record line chart

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定單筆記錄曲線圖的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為。
註 |  | 可加入物件的說明文字
外型設置 |  | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 設定物件外型。
圖底色 |  | 選擇一種顏色作為圖表的底色。
關聯數據收集器 |  | 選擇關聯的數據收集器。
數據來源 |  | 選擇數據收集器或檔案做為數據來源。
檔案緩衝區編號 |  | 當數據來源為檔案時，設定檔案緩衝區的編號。欲設定檔案緩衝區編號，可使用功能按鈕中的讀取歷史數據檔案功能。詳細說明，請參考章節5.4功能按鈕。
數據點數 |  | 設定數據點個數。
數據類別 |  | 設定數據項的數據類別，支援以下幾種：16位正整數、32位正整數、16位整數、32位整數、16位BCD正整數、32位BCD正整數、32位浮點數、16位BCD整數(LMB)、32位BCD整數(LMB)、16位BCD整數(LMD)、32位BCD整數(LMD)。
畫點記號 |  | 勾選數據點上是否顯示方型記號。
畫連接線 |  | 勾選單筆記錄曲線圖是否在數據點間顯示連接線。
時間/日期顯示 | 日期 | 勾選物件是否顯示日期欄位。勾選此選項，需設定日期的格式。
 | 時間 | 勾選物件是否顯示時間欄位。勾選此選項，需設定時間的格式。
 | 顏色 | 設定文字的顏色。
 | 字型 | 設定文字的字型。
 | 顯示相對時間 | 勾選此選項，物件將顯示相對時間。
顯示 游標 | <><勾選框> | 勾選單筆記錄曲線圖是否顯示 游標，用戶可移動游標至所需的數據點。
 | 游標色 | 設定 游標的顏色。
 | 數值顯示字型 | 設定所選數據點的顯示字型。
 | 游標數據接收區 | 設定游標數據讀取和顯示的變數地址。 點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。
參考曲線 | <勾選框> | 勾選單筆記錄曲線圖是否顯示參考曲線。
 | 參考曲線數據區 | 設定參考數據線讀取和顯示的變數地址。參考曲線可幫助使用者直觀的判讀圖表，簡易的判別該數據點是否符合標準。 點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。
 | /顯示/隱藏由位控制 | 勾選參考曲線的顯示或隱藏是否由指定的位控制。
 | /顯示/隱藏控制位 | 設定控制參考曲線是否顯示的位地址。 點擊圖標 [image] ，輸入所需的地址。點擊圖標 [image] ，選取所需的標籤。


13.5.5. 單筆記錄曲線圖 - 筆設定

單筆記錄曲線圖 - 筆設定

本章節說明單筆記錄曲線圖筆頁中各選項屬性的設定。下圖是筆頁的圖例。

single record line chart

下表為筆頁中各 選項屬性的說明。

屬性 |  | 說明
歷史數據筆 | 最小值 | 設定關聯數據組的最小值，當未勾選動態範圍 選項時，此選項才會出現。
 | 最大值 | 設定關聯數據組的最大值，當未勾選動態範圍 選項時，此選項才會出現。
 | 標記大小 | 設定數據點標記大小，當勾選一般頁中的『畫點標記』選項，此選項設定才有效。
 | 線樣式 | 設定連接線的樣式，當勾選一般頁中的『畫連接線』選項，此選項設定才有效。
 | 顏色 | 設定連接線顏色。
 | 顯示數值 | 設定數據點數值的顯示方式。
 |  | 顯示數值 | 說明
 |  | (無) | 不顯示數據點數值。
 |  | 原始值 | 顯示原始數據點數值。
 |  | 刻度值 | 顯示數據點在Y軸的刻度值。
 |  | 當勾選一般頁中的顯示游標，此選項才會出現。
參考數據筆 | 最小值 | 設定關聯數據組的最小值，當未勾選動態範圍選項時，此選項才會出現。
 | 最大值 | 設定關聯數據組的最大值，當未勾選動態範圍選項時，此選項才會出現。
 | 最大值 | 設定數據點標記大小，當勾選一般頁中的畫點記號選項，此選項設定才有效。
 | 線樣式 | 設定連接線的樣式，當勾選一般頁中的畫連接線選項，此選項設定才有效。
 | 顏色 | 設定連接線顏色。
 | 顯示數值 | 設定數據點數值的顯示方式。
 |  | 顯示數值 | 說明
 |  | ( )(無) | 不顯示數據點數值。
 |  | 原始值 | 顯示原始數據點數值。
 |  | 刻度值 | 顯示數據點在Y軸的刻度值。
 |  | 當勾選一般頁中的顯示游標，此選項才會出現。
個別線段顏色可設 |  | 勾選此選項，可在下方的清單視窗中設定個別線段的顏色。清單視窗有三個欄位，第一行為線段編號，第二行為數據曲線的顏色設定，第三行為參考曲線的顏色設定。


13.5.6. 單筆記錄曲線圖 - 軸設定

單筆記錄曲線圖 - 軸設定

本章節說明單筆記錄曲線圖軸頁中各項屬性的設定。下圖是軸頁的圖例。

single record line chart

下表為軸頁中各項屬性的說明。

屬性 |  | 說明
X軸 | 顯示刻度 | 勾選X軸是否顯示刻度。
 | 顯示軸格線 | 勾選是否顯示垂直格線。
 | 軸/刻度顏色 | 設定X軸和Y軸刻度的顏色。
 | 格線顏色 | 設定垂直格線的顏色。
 | 主分隔數 | 設定X軸的主分隔數，最小值為1。
 | 次分隔數 | 設定兩相鄰主要刻度間的分隔數，最小值為1。
刻度標示 | 顯示刻度標示 | 勾選是否顯示刻度標示。
 | 字體 | 設定刻度標示的字體。
 | 動態範圍 | 勾選此選項，在運行時，刻度標示的最小和最大值由物件的動態範圍參數區所控制。
 | 最小值 | 設定刻度標示的最小值，為32位整數。
 | 最大值 | 設定刻度標示的最大值，為32位整數。
 | 總位數 | 設定刻度標示顯示的總位數。
 | 小數位數 | 設定刻度標示的小數位數。例如，當最大值為5000，總位數為4，小數位數為2，則刻度標示的最大值為5000。
Y軸 | 顯示刻度 | 勾選軸是否顯示刻度。
 | 顯示軸格線 | 勾選是否顯示水準格線。
 | 軸/刻度顏色 | 設定X軸和Y軸刻度的顏色。
 | 格線顏色 | 設定水準格線的顏色。
 | 主分隔數 | 設定Y軸的主分隔數，最小值為1。
 | 次分隔數 | 設定兩相鄰主要刻度間的分隔數，最小值為1。
刻度標示 | 顯示刻度標示 | 勾選是否顯示刻度標示。
 | 字體 | 設定刻度標示的字體。
 | 動態範圍 | 勾選此選項，在運行時，刻度標示的最小和最大值由物件的動態範圍參數區所控制。
 | 最小值 | 設定刻度標示的最小值，為32位整數。
 | 最大值 | 設定刻度標示的最大值，為32位整數。
 | 總位數 | 設定刻度標示顯示的總位數。
 | 小數位數 | 設定刻度標示的小數位數。例如，當最大值為5000，總位數為4，小數位數為2，則刻度標示的最大值為5000。


13.6.1. 歷史二維分佈圖 - 基本功能

歷史二維分佈圖 - 基本功能

按照以下操作步驟，可創建一個歷史二維分佈圖：

  1. 在物件工具欄中點擊歷史二維分佈圖 圖標 [image] ，或者在物件功能表中選擇歷史二維分佈圖。

  2. 直接拖曳滑鼠指標至畫面中欲新建創建該物件的位置。

  3. 點擊目標位置，在畫面上放置該物件。

歷史二維分佈圖顯示指定的數據收集器在一定的時間範圍內收集的數據。他為每個數據設置一個數據點，並且用線順序連接所有的數據點。每個數據點都是一個座標，包括X值和Y值。X值，就是X軸的座標值，即數據點的垂直位置。Y值，就是Y軸的座標值，即數據點的水 平位置。X值和Y值都是由相應的數據收集器決定的。

歷史二維分佈圖可以提供一個游標供使用者選擇所需的數據點。歷史二維分佈圖的游標是一個十字，使用者可以快速的移動游標到歷史二維分佈圖中水平和垂直距離最近的數據點。選擇的數據點的值可以顯示和輸出到內部或外部變數稱為輸出選定點數據。


13.6.2. 歷史二維分佈圖 - 功能選擇

歷史二維分佈圖 - 功能選擇

下表是歷史二維分佈圖中可增加的功能選項。選項的設定可在屬性視窗中完成。

屬性 | 說明
顯現控制 | 用戶可以通過觸發位元和用戶等級控制歷史二維分佈圖的顯現與否。在歷史二維分佈圖屬性對話方框的顯現頁面可設置該屬性。


13.6.3. 歷史二維分佈圖 - 設定

歷史二維分佈圖 - 設定

用戶可以在歷史二維分佈圖的屬性視窗中設置歷史二維分佈圖，下面是三種打開該屬性視窗的方法：

  1. 雙擊歷史二維分佈圖物件。
  2. 右鍵點擊歷史二維分佈圖，打開彈出式功能表，在該功能表中選擇物件屬性。
  3. 在物件列表中，雙擊列表中顯示的歷史二維分佈圖。

歷史二維分佈圖的屬性視窗包括以下四個頁面：

■ 一般頁

詳閱章節 13.6.4.說明.

■ 選點
詳閱章節 13.6.5 . 說明。

■ 軸
詳閱章節 13.6.6. 說明。

■ 顯現頁
詳閱章節 4.4.6.說明。


13.6.4. 歷史二維分佈圖 - 一般設定

歷史二維分佈圖 - 一般設定

本章節說明歷史二維分佈圖一般頁中各項屬性的設定。下圖是一般頁的圖例。

single record line chart

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定歷史二維圖的編號。當物件產生時，系統自動給予一組編號，該編號是不可變的。同一個畫面中的編號不會重複。編號的格式為HSCnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 外框、 背景透明、邊框色、背景色的詳細說明，請參考章節 4.3.4 外型設置。
圖底色 |  | 設定圖的背景顏色.
相應數據收集器 |  | 設定歷史二維分佈圖顯示的數據收集器。
數據源 |  | 選擇數據收集器或檔案做為數據來源。
文件緩衝區編號 |  | 數據來源為檔案時，設定檔緩衝區的編號。欲設定檔緩衝區編號，可使用功能按鈕中的讀取歷史數據檔案功能。詳細說明，請參考章 節 5.4 功能按鈕 。
X座標 | 數據項目 | 選擇數據項目關聯的數據記錄器的X座標。
 | 最小 | 動態範圍沒有被選定的時候，指定X座標數據項目最小值。
 | 最大 | 動態範圍沒有被選定的時候，指定X座標數據項目最大值。
Y座標 | 數據項目 | 選擇數據項目關聯的數據記錄器的Y座標。
 | 最小 | 動態範圍沒有被選定的時候，指定Y座標數據項目最小值。
 | 最大 | 動態範圍沒有被選定的時候，指定Y座標數據項目最大值。
動態範圍 | <勾選框> | 當勾選此選項，HMI在運行時以下三個範圍將被設定： 1. 數據收集器時間範圍的最大值。 2. X值和Y值的最大值和最小值 。 3. X軸和Y軸的最大和最小標誌值 。 4. X軸和Y軸的主與次分隔數， 以上四組範圍應該在動態範圍參數區中被正確地設定。使用者需在動態範圍參數區中設定動態範圍參數區。你需要指定在動態範圍參數欄位內的動態範圍參數區。
 | 動態範圍參數區 | 勾選動態範圍後，設定動態範圍參數區的變數地址。點擊 [image] 輸入位址，點擊 [image] 選取標籤。 下表為參數區的數據設置。
 |  | 字 | 說明
 |  | 0,1 | 時間軸(X軸)時間範圍的最大值。
 |  | 2,3 | X軸 數值的最小值。
 |  | 4,5 | X軸 數值的最大值。
 |  | 6,7 | Y軸 數值的最小值。
 |  | 8,9 | Y軸 數值的最大值。
 |  | 10,11 | X軸主分隔數個數；32位元整數，最小值為1。
 |  | 12,13 | X軸次分隔數個數；32位元整數，最小值為1。
 |  | 14,15 | X 軸刻度的最小值，32位元整數。
 |  | 16,17 | X 軸刻度的最大值，32位元整數。
 |  | 18,19 | Y軸主分隔數個數；32位元整數，最小值為1。
 |  | 20,21 | Y軸次分隔數個數；32位元整數，最小值為1。
 |  | 22,23 | Y軸刻度的最小值，32位元整數。
 |  | 24,25 | Y軸刻度的最大值，32位元整數。
點 | 顯示記號 | 勾選此選項，歷史二維分佈圖會標記所有的數據點。
 | 標記大小 | 為數據點標記選擇大小，『顯示記號』選項被勾選時才會顯示此選項。
 | 顯示線 | 勾選此選項，歷史二維分佈圖會以線段連接各個數據點。
 | 線樣式 | 選擇連接線的形式，只有勾選『顯示線』時，才會顯示此選項。
 | 顏色 | 為連接線選擇一種顏色。
 | 起始點顏色 | 為起始點選擇顏色。
 | 結束點顏色 | 為結束點選擇顏色。
 | 標示結束點 | 若要啟用該功能，請檢查"標示結束點"選項，該物件可以將曲線的結束點標 示成一個小十字架來引人注目。在下面的圖片中，黃色十字標識為結束點。
時間範圍 | 日 | 選擇從1到31之間的一個整數。作為月中的日。
 | 時 | 選擇0到23的一個整數，作為日中的時
 | 分 | 選擇0到59的一個整數 ，作為時中的分。
 | 秒 | 選擇0到59的一個整數，作為分鐘的秒。


13.6.5. 二維歷史分佈圖 - 選點設置

歷史二維分佈圖 - 選點設置

本節描述了如何設定歷史二維分佈圖的選點。下面是一個選點設定的頁面

single record line chart

下表描述了選點設定頁各項屬性的說明。

屬性 |  |  | 說明
啟用 |  |  | 勾選此選項，選擇資料點時。歷史二維分佈圖會顯示游標。使用者可以觸摸並拖動游標到想要選擇的資料點。
停用 |  |  | 勾選此選項，禁止選點操作。
由位致能 |  |  | 勾選此選項，可以使用一個位來禁用和啟用選點功能。 當該選項被選中時，需要設定一個位元地址。點擊 [image] 輸入位地址，點擊 [image] 選取標籤。
 | 游標顏色 |  | 設定游標的顏色。
 | 搜尋半徑（像素） |  | 歷史二維分佈圖搜索當前游標位置最接近的資料點作為被選中點。搜索圓的中心是當前游標位置，半徑是指設置的『像素』作為搜索半徑。
 | 輸出選點數據 |  | 游標所選擇的點的數值，可以輸出保存至內部記憶區或其他的字地址，作為檢查或紀錄用途。
 | 寫地址 |  | 用來存儲被游標所選擇的點相關資訊的字記憶區的位址。點擊 [image] 輸入位地址，點擊 [image] 選取標籤。
 | 操作員確認 |  | 勾選此選項，在報告被選中的點之前，必須要有操作員確認。
 | 通知 | 通知 | 勾選此選項，在報告被選中的點之前，會通知一個位地址。
 |  | 信號 | 位元通知選擇下列一種信號。
 |  |  | 信號 | 說明
 |  |  | 位階 | 設置指定的點為"0"或"1"的狀態。
 |  |  | 脈衝 | 發送一個正脈衝到指定的位地址。
 |  | 通知位 | 勾選時，用來指定操作完成時的通知位。點擊 [image] 輸入位地址，點擊 [image] 選取標籤。
 |  | 狀態 | 指定通知位元的狀態 是1或0.
選點數據顯示 | 字型 |  | 為選擇的資料點的值選擇一種字型。
 | 日期 |  | 勾選此選項，將在歷史二維分佈圖的左上方顯示日期。需要選擇一種日期格式。 共有17種格式可以選擇： dd/mm/yy, mm/dd/yy, yy/mm/dd, dd.mm.yy, mm.dd.yy, yy.mm.dd, dd-mm-yy, mm-dd-yy, yy-mm-dd, MMMdd, dd/mm, mm/dd, dd.mm, mm.dd, dd-mm, mm-dd, yyyy/mm/dd 註： dd: 01-31 (日); mm: 01-12 （月); yy: 00-99 (年); yyyy: 0000-9999(年); MMM: JAN-DEC (月)
 | 時間 |  | 勾選此選項，將在歷史二維分佈圖的左上方顯示時間。需要選擇一種時間格式。 有3種格式：HH：MM，HH：MM：SS；HH：SS。 註：HH：00-23（小時）；MM：00-50（分鐘）；SS：00-59（秒）
 | 日期/時間顏色 |  | 為時間和日期顯示選擇一種顏色。
 | 顯示相對時間 |  | 勾選此選項，歷史二維分佈圖將會顯示相對的時間。
 | 座標 |  | 勾選此選項，將會顯示選定資料點的座標。
 | 座標顏色 |  | 為座標選擇一種顏色。


13.6.6. 歷史二維分佈圖 - 軸設置

歷史二維分佈圖 - 軸設置

本節介紹如何定義歷史二維分佈圖的X軸和Y軸，下圖是一個軸設定的例子

single record line chart

下表描述了在軸設定頁面各項屬性的說明。

屬性 |  | 說明
X軸 | 顯示刻度 | 勾選此選項，X軸將會顯示刻度。
 | 顯示Y軸格線 | 勾選此選項，X軸將顯示垂直格線。
 | 軸/刻度顏色 | 為X軸和X軸刻度選擇一種顏色。
 | 格線顏色 | 為垂直格線選擇一種顏色。
 | 主分隔數 | 軸主分隔線的數目，可以指定的最小值是1
 | 次分隔數 | 兩個主分隔線之間次分隔線的數目，可以指定的最小值是1。
顯示刻度標示（X軸） | 顯示刻度標示 | 勾選此選項，刻度會顯示刻度數值。
 | 字體 | 刻度數值的字體。
 | 最小值 | 標示的最小值，它是32位元整數。
 | 最大值 | 標示的最大值，它是32位元整數 。
 | 總位數 | 標示的總位數。
 | 小數位數 | 標示的小數位數。例如，當最大值為5000，總位數是4，小數字數是2，則最大標記值將是50.00。
Y軸 | 顯示刻度 | 勾選此選項，Y軸將會顯示刻度。
 | 顯示X軸格線 | 勾選此選項，Y軸將顯示水平格線。
 | 軸/刻度顏色 | 為Y軸和Y軸刻度選擇一種顏色。
 | 格線顏色 | 為水平格線選擇一種顏色。
 | 主分隔數 | Y軸主分隔線的數目，可以指定的最小值是1。
 | 次分隔數 | 兩個主分隔線之間次分隔線的數目，可以指定的最小值是1。
顯示刻度標示（Y軸） | 顯示刻度標示 | 勾選此選項，刻度會顯示刻度數值。
 | 字體 | 刻度數值的字體。
 | 最小值 | 標示的最小值，它是32位元整數
 | 最大值 | 標示的最大值，它是32位元整數。
 | 總位數 | 標示的總位數。
 | 小數位數 | 標示的小數位數。例如，當最大值為5000，總位數是4，小數字數是2，則最大標記值將是50.00。


13.7.1. 歷史雷達圖 - 基本功能

歷史雷達圖 - 基本功能

使用以下操作步驟，創建一個歷史雷達圖：

  1. 在物件工具列中點擊 [image] 歷史雷達圖圖示，或者在物件功能表中選擇歷史雷達圖。

  2. 拖曳滑鼠游標到畫面上你想要創建該物件的位置。

  3. 點擊目標位置，在畫面上放置該物件。

歷史雷達圖以雷達圖的形式顯示指定的資料收集器在一定的時間範圍內收集的資料。下圖是在運行中顯示了4條曲線的歷史雷達圖。

歷史雷達圖可以結合時間，數值，游標……

歷史雷達圖可以實現以下功能：

1) 顯示曲線數目高達8條。

2) 雷達圖曲線可以用來選擇所需的時間。日期，時間，和選定的數值可以在圖表上顯示。同時，在選定的時間可以將資料寫入到一個接收緩衝區。

3) 趨勢曲線可以被縮放為不同的時間解析度。

4) 趨勢曲線可以被動態隱藏。


13.6.2. 歷史雷達圖 - 功能選項

歷史雷達圖 - 功能選項

歷史雷達圖可以應用下面的操作，在歷史雷達圖的屬性視窗中設定該項操作。

屬性 | 說明
顯現控制 | 你可以通過觸發位元和使用者等級控制歷史二維分佈圖的顯現與否。在歷史二維分佈圖屬性對話方塊的顯現頁面設置該屬性。


13.7.3. 歷史雷達圖 - 設定

歷史雷達圖 - 設定

你可以在歷史雷達圖的屬性視窗中設置歷史雷達圖，下面是三種打開該屬性視窗的方法：

1) 按兩下歷史雷達圖。
2) 右鍵點擊歷史雷達圖，打開彈出式功能表，在該功能表中選擇物件屬性。
3) 在物件清單中，按兩下清單中顯示的歷史雷達圖。

 歷史雷達圖的屬性對話框包括以下四個頁面：

■ 一般頁
 詳閱章節 13.7.4.說明 。

■ 曲線
 詳閱章節 13.7.5.說明 。

■ 刻度
 詳閱章節 13.7.6. 說明。

■ 顯現
 詳閱章 節 4.4.6.說明。


13.7.4. 歷史雷達圖 - 一般設定

歷史雷達圖 - 一般設定

本章節說明歷史雷達圖一般頁中各項屬性的設定。下圖是一般頁的圖例 。

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定歷史雷達圖的編號。當物件產生時，系統自動給予一組編號，該編號是不可變的。同一個畫面中的編號不會重複。編號的格式為HRCnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 、邊框色、背景色的詳細說明，請參考章節 4.3.4 外型設置. 。
關聯數據收集器 |  | 設定歷史雷達圖顯示的資料收集器。
數據來源 |  | 選擇資料收集器或檔案做為數據來源。
檔案緩衝區編號 |  | 當數據來源為檔案時，設定檔案緩衝區的編號。欲設定檔案緩衝區編號，可使用功能按鈕中的讀取歷史資料檔案功能。詳細說明，請參考章節 5.4 功能按鈕 。
曲線總數 |  | 指定曲線的總數。最多支援8條曲線。
游標 | <勾選框> | 勾選此選項，歷史雷達圖將會顯示游標。你可以觸摸和拖動游標到你要選擇的資料點 。
 | 游標色 | 為游標選擇一種顏色。
 | 數值顯示字 | 選擇一個用來顯示選定資料點數值的字體。
 | 日期 | 勾選此選項，將在歷史雷達圖的左上方顯示日期。你需要選擇一種日期格式。 共有17種格式可以選擇： dd/mm/yy, mm/dd/yy, yy/mm/dd, dd.mm.yy, mm.dd.yy, yy.mm.dd, dd-mm-yy, mm-dd-yy, yy-mm-dd, MMMdd, dd/mm, mm/dd, dd.mm, mm.dd, dd-mm, mm-dd, yyyy/mm/dd 註： dd: 01-31 (日); mm: 01-12 （月); yy: 00-99 (年); yyyy: 0000-9999(年); MMM: JAN-DEC (月)
 | 時間 | 勾選此選項，將在歷史雷達圖的左上方顯示時間。你需要選擇一種時間格式。有3種格式：HH：MM，HH：MM：SS；HH：SS。 註：HH：00-23（小時）；MM：00-50（分鐘）；SS：00-59（秒）
 | 時間/日期顏色 | 為日期和時間選擇一種顏色
 | 游標數據接收區 | 輸出由游標所選擇的點的數值到指定的記憶區。記憶區所需的大小是相關聯的數據收集器的取樣大小。點擊 [image] 輸入位址，點擊 [image] 選取標籤。
顯示相對時間 |  | 勾選此選項， 歷史雷達圖將會顯示相對的時間 。
支持放大縮小 |  | 勾選此選項，在運行時支援放大縮小歷史雷達圖。使用者可以通過功能按鈕來實現此功能。
曲線顯示/隱藏可控 |  | 勾選此選項，可透過設置一個字地址來控制曲線的顯示或隱藏，藉由設置字地址中的位地址來控制曲線。
曲線顯示控制字 |  | 設置控制曲線的存放的字地址。例如，設置控制曲線字地址為$U1300，則$U1300的第1個位元（$U1300.0）為On時，第一條曲線會顯現，當要設置第二條曲線顯現時，則設置$U1300.1為 On，以此類推。點擊 [image] 輸入位址，點擊 [image] 選取標籤 。


13.7.5. 歷史雷達圖 - 曲線設定

歷史雷達圖 - 曲線設定

本節描述了如何設定歷史雷達圖的的曲線。下面是一個曲線設定頁面的例子。

下表描述了曲線設定頁面的各項屬性

屬性 | 說明
數據來源 | 選取某一個相關聯的數據收集器作為曲線的數據來源。
最小值 | 相關曲線的最小值。
最大值 | 相關曲線的最大值。
線樣 | 為曲線選擇一種線樣式。
顏色 | 為曲線選擇一種顏色。
顯示數值 | 選擇下列一種方式，用來顯示選定資料點的值:
 | 資料顯示 | 說明
 | (None) | 不顯示資料點的值。
 | 原始值 | 顯示未修正過的資料點的值。
 | X軸刻度值 | 顯示資料點X軸的數值 。
 | Y軸刻度值 | 顯示資料點Y軸的數值 。


13.7.6. 歷史雷達圖 - 刻度設定

歷史雷達圖 - 刻度設定

本節介紹如何定義歷史雷達圖的刻度。下圖是一個刻度設定的例子

下表描述了刻度頁的各項屬性

屬性 |  | 說明
時間片--時間範圍
 | 時/分/秒 | 指定歷史雷達圖『一圓周』的時間值。例如，當設置為 1小時，有4個主分隔數時，每個主分隔將是15分鐘的時距。
時間片 | 主分隔數 | X軸主分隔線的數目，你可以指定的最小值是1。
 | 次分隔數 | 兩個主分隔線之間次分割線的數目，你可以指定的最小值是1。
 | 分割線顏色 | 為分割線指定一種顏色
 | 顯示時間 | 勾選此選項，將會顯示時間。你需要為時間選擇一種顯示格式。
 | 時間格式 | 下表展示了時間顯示的格式，有兩種格式可供選擇 ：
 |  | 格式 | 描述
 |  | HH:MM | HH: 00-23 (時); MM: 00-59 （分)
 |  | HH:MM:SS | HH: 00-23 (時); MM: 00-59 (分); SS: 00-59 (秒)
 | 顯示日期 | 勾選此選項，將會顯示日期。你需要為日期選擇一種顯示格式。
 | 日期格式 | 日期顯示的格式，有17種格式可供選擇。
 | 時間/日期字體 | 為時間/日期顯示選擇一種字體。
 | 時間/日期顏色 | 為時間/日期顯示選擇一種顏色。
數值刻度 | 主分隔數 | 數值刻度的主分隔數，你可以指定的最小值是1。
 | 次分隔數 | 兩個主分隔線之間次分割線的數目，你可以指定的最小值是1。
 | 主分隔線顏色 | 為主分隔線指定一種顏色。
 | 次分隔線顏色 | 為次分隔線指定一種顏色。
 | 顯示X軸刻度值 | 勾選此選項，X軸會顯示刻度數值。
 | 顯示Y軸刻度值 | 勾選此選項，Y軸會顯示刻度數值。
 | 刻度值字體 | 為刻度標記選擇一種字體。
數值刻度—軸 | 指定X/Y軸的數值刻度
 | 軸 | 數值刻度的軸名稱。
 | 最小刻度值 | 數值刻度的最小值，你可以指定一個32位元的有符號整數。
 | 最大刻度值 | 數值刻度的最大值，你可以指定一個32位元的有符號整數。
 | 總位數 | 數值刻度的總位數。
 | 小數位數 | 數值刻度的小數位數。例如，當最大值為5000，總位數是4，小數字數是2，則最大標記值將是50.00。
 | 刻度值顏色 | 為數值刻度選擇一種顏色。


14.1. 使用操作記錄

使用操作記錄

本章說明如何設定操作記錄，以及使用操作記錄顯示器顯示操作歷史記錄。

欲使用操作記錄，請依以下步驟進行操作：

  1. 啟用操作記錄。

詳閱章節 14.2說明。

  2. 在關聯物件的進階頁中，設定操作記錄訊息。

詳閱章節 4.4.5.說明。

輸入第一語言的操作的訊息。

點擊按鈕，彈出操作資訊對話框，可編輯所有語言的訊息。請參見第14.2.1節的說明。

  3. 新增並設定操作記錄顯示器。

    詳閱章節 14.3.1說明。

在本軟體中，亦可使用功能按鈕清除操作記錄。有關使用功能按鈕清除操作記錄的設定，請參考章節5.4.1 基本功能。


14.2. 設定操作記錄

設定操作記錄

用戶可在操作記錄的屬性對話框中，進行各項屬性的設定。在屬性對話框中，用戶可決定記錄記憶區大小、儲存操作記錄到檔案的方式。欲開啟屬性對話框，在專案管理員視窗中， 操作記錄節點處雙擊滑鼠左鍵；或點選功能列上人機應用- > 操作記錄…。下圖為操作記錄屬性對話框的範例。

下表為操作記錄屬性對話框中，各項屬性的說明。

屬性 |  | 說明
啟用操作記錄 | <勾選框> | 勾選是否啟用操作記錄。
 | 記錄記憶區大小 | 設定記錄記憶區的大小，單位為仟字，範圍從1到512仟字。
 | 預估可記錄筆數 | 預估操作記錄可記錄的筆數，計算公式為： 可記錄筆數 = 記憶區大小 * 1024 * 2 / 64
記錄開始運行時間 | <勾選框> | 勾選此選項，啟動操作記錄。
 | 訊息 | 輸入當人機運用開始運行時的操作訊息(預設為第一種語言)。
 | operation message | 點擊此按鈕，開啟操作記錄訊息對話框，可編輯所有語言的操作訊息。詳細說明，請參考章節 14.2.1。
記錄停止運行時間 | <勾選框> | 勾選此選項，啟動記錄停止運行時間記錄。
 | 訊息 | 輸入當人機停止運行時的時間訊息(預設為第一種語言)。
 | operation message | 點擊此按鈕，開啟記錄停止運行時間對話框，可編輯所有語言的停止運行時間訊息。詳細說明，請參考章節 14.2.1。
記錄用戶登入時間 | <勾選框> | 勾選此選項，啟動用戶登入記錄。
 | 訊息 | 輸入當用戶登入時的登入訊息(預設為第一種語言)。
 | operation message | 點擊此按鈕，開啟用戶登入訊息對話框，可編輯所有語言的用戶登入訊息。詳細說明，請參考章節 14.2.1。
儲存 | <勾選框> | 勾選此選項，最近的操作記錄將定期地寫入指定的檔案中。每當執行此項操作時，只有尚未儲存到檔案的操作記錄，才會被寫入到檔案中。
 | 檔案種類 | 保存操作記錄的檔案種類
 |  | 檔案種類 |  | 說明
 |  | .CSV |  | 操作記錄以.CSV 格式保存。使用者可以使用任何文字編輯器或微軟Excel查看該檔。
 | 檔案處理方式 | 指定如何執行保存操作
 |  | 檔案處理方式 |  | 說明
 |  | 新建 |  | 以指定的檔案名新建一個檔案來保存操作記錄 。
 |  | 附加或新建 |  | 如果指定的檔案存在，添加操作記錄到該檔。否則，以指定的檔案名新建一個檔案來保存操作記錄。
 | 儲存時間 | 設定儲存操作記錄的週期。當勾選儲存，此選項才會出現。共有九種週期時間：每小時整點、每8小時(00:00, 08:00, 16:00)、每12小時(00:00, 12:00)、每天(00:00)、每天(08:00)、每天(12:00)、每週日(00:00)、每週一(00:00)、每月一號(00:00)。
 | 存到預設檔案夾 | 勾選此選項，將檔案直接存到預設檔案夾。 請參考章節 3.1.4 有關存到預設檔案夾的詳細說明。
 | 檔案名稱可變 | 勾選此選項，可以在應用運行中更改保存操作記錄檔案的名稱。
 | 檔案名稱 | 設定儲存操作記錄的檔案名稱。操作記錄以文字檔的格式儲存，副檔名須為txt，用戶可使用任何文字編輯器和Excel檢視操作記錄。當勾選儲存，此選項才會出現。
 | 檔案後綴名 | 當檔案的處理方式是新建時，這個屬性確保新建的檔都有一個唯一的名稱，以及不存在的檔將被覆蓋。共有四種類型的檔案名尾碼可用，如下表所示。
 |  | 檔案後綴名 | 描述 | 例
 |  | _YYMMDD_hhmmss | 年（00~99） 月（01~12） 日（01~31） 時（00~23） 分（00~59） 秒（00~59） | Log_090423_102358 (假設指定的檔案名是“Log”，當前的日期是2009年4月23日，而現在的時間是10:23:58。)
 |  | _YYMMDD_hhmm | Log_090423_1023
 |  | _YYMMDD_hh | Log_090423_10
 |  | _YYMMDD | Log_090423
 | 存檔時不顯示相關訊息 | 勾選此選項，隱藏在運行時保存檔案的訊息。
保存操作記錄到資料庫 | <勾選框> | 勾選此選型，操作記錄將被定期的寫入指定的資料庫。每次執行此操作，只寫尚未保存的操作記錄至資料庫。此專案只有在目標人機為本運行軟體時可見。
 | 數據表名 | 指定一個名稱為數據庫中的欄位名稱。
 | 數據表欄位 | 單擊“編輯”按鈕，在彈出的以下對話框中指定欄位名稱。注意，該名稱必須符合資料庫的規則識別字。
 | 保存時間 | 指定保存操作記錄的時間，此選項在保存操作記錄至資料庫被勾選時可用。有十四個保存時間可以選擇：每小時整點；每8小時（00:00，08:00，16:00）；每12小時（00:00，12:00）每天在00:00；每天08:00；每天12:00；每星期日00:00；每星期一00:00 00:00；每月一號00:00，每分鐘（僅供測試），每5分鐘，每10分鐘，每15分鐘，每30分鐘。


14.2.1. 操作記錄訊息

操作記錄訊息

本章節將說明如何設定所有語言的操作記錄訊息。下圖為操作記錄訊息對話框的範例。

下表為操作記錄訊息對話框中，各項屬性的說明。

屬性 | 說明
所有語言都使用第一種語言的文字 | 勾選此選項，物件將顯示第一種語言的操作記訊息，不論當前語言為何。用戶須在第一種語言的編輯框中輸入文字。
使用文字庫的字串 | 勾選此選項，可從文字庫中選擇文字。下圖為從文字庫選擇和編輯文字的範例。


14.3.1. 操作記錄顯示器 - 基本操作

操作記錄顯示器 - 基本操作

用戶可使用操作記錄顯示器，顯示操作記錄清單。

operation log display demo

上圖為操作記錄顯示器的範例。第一列為抬頭列，顯示每個欄位的抬頭。其餘每一列顯示一筆操作記錄。用戶可使用捲動條或捲動按鈕捲動物件內容。操作記錄顯示器可顯示三個欄位，下表說明每個欄位的內容：

欄位 | 說明
日期 | 顯示操作記錄建立的日期，此欄位為可選擇的。
時間 | 顯示操作記錄建立的時間，此欄位為可選擇的。
訊息 | 顯示關聯操作的訊息，此欄位為可選擇的。

註:操作記錄器文字的顏色和字體可在屬性對話框的一般頁中設定。


14.3.2. 操作記錄顯示器 - 功能選項

操作記錄顯示器 - 功能選項

下表是操作記錄顯示器中可增加的功能選項，選項的設定可在屬性對話框中完成。

選項 | 說明
顯現控制 | 設定操作記錄顯示器的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


14.3.3. 操作記錄顯示器 - 設定

操作記錄顯示器 - 設定

所有操作記錄顯示器的設定都可在屬性對話框中完成，操作記錄顯示器的屬性對話框包含以下二個頁面。

■ 一般頁
詳閱章節 14.3.4.說明

■ 顯現頁
詳閱章節 4.4.6.說明


14.3.4. 操作記錄顯示器 - 一般設定

操作記錄顯示器 - 一般設定

本章節說明操作記錄顯示器一般頁中各項屬性的設定。下圖是一般頁的圖例。

下表為一般頁中各項屬性的說明。

屬性 |  |  | 說明
編號 |  |  | 設定操作記錄顯示器的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為HODnnnn。
註 |  |  | 可加入物件的說明文字。
外框 |  |  | 設定物件的外型樣式、 [image] 邊框色、背景色等，有關此屬性的詳細信息，請參考章節 4.3.4 設定物件外型 。
語言 |  |  | 在抬頭與訊息顯示之中，與語言有關的屬性，以此語言檢視與編輯。抬頭屬性包含字體和訊息，訊息屬性包含字體。
抬頭 | <勾選框> |  | 勾選操作記錄顯示器是否顯示抬頭列。
 | 字體 |  | 設定抬頭文字的字體。
 | 顏色 |  | 設定抬頭文字的顏色。
 | 日期 |  | 設定日期欄位的抬頭名稱。
 | 時間 |  | 設定時間欄位的抬頭名稱。
 | 訊息 |  | 設定訊息欄位的抬頭名稱。
 | 背景顏色 |  | 設定抬頭列的背景顏色。
格線 | 水平 |  | 勾選操作記錄顯示器是否顯示水平格線。
 | 垂直 |  | 勾選操作記錄顯示器是否顯示垂直格線。
 | 顏色 |  | 設定格線顏色。
訊息 | 字體 |  | 設定訊息的字體。
 | 顏色 |  | 設定訊息顯示的顏色。
日期/時間顯示 | 日期 | <勾選框> | 勾選操作記錄顯示器是否顯示日期欄位。
 |  | <下拉式清單> | 選擇一種格式來顯示日期。有10種格式：日/月/年; MM/DD/YY，YY/MM/DD; DD.MM.YY; MM.DD.YY; YY.MM.DD，DD-MM-YY，MM-DD-YY，YY-MM-DD，YYYY/MM/DD 註：YY：年份（00-99）yyyy：年（0000-9999）mm：月（01-12）日：天（01-31）
 | 時間 | <勾選框> | 勾選操作記錄顯示器是否顯示時間欄位。
 |  | <下拉式清單> | 選擇一種格式，用於顯示時間。有兩種格式：HH：MM，HH：MM：SS 註：HH：小時（00-23）MM：分鐘（00-59）SS：秒（00-59）
 | 顏色 |  | 設定日期/時間顏色。
行距 |  |  | 設定操作記錄顯示器相鄰上下兩列的間隔距離。
項距 |  |  | 設定操作記錄顯示器相鄰左右兩行的間隔距離。


15 使用巨集

使用巨集

本章節說明如何編寫巨集來操作人機(觸控屏)。一個巨集包含一系列的巨集指令，當巨集在人機上執行時，就如同執行簡單的電腦程式，像流程控制、數據轉換、條件操作、序列運算等基本的人機物件不容易完成的工作，都可以使用巨集來輕鬆完成所需求的任務。

注意：請勿使用巨集來控制系統I/O的動作，這可能導致非常嚴重且威脅生命的傷害。

注意：人機(觸控屏)運行時，其作業系統所要執行的工作非常多。所以巨集內的程式應儘量減短，以免造成人機運作不正常。

注意：所有巨集都是獨立且個別執行。當巨集間共用一般功能時，人機可能會產生衝突。當迴圈巨集在更新某位址的值，而事件巨集也同時在使用這個位址。此時，如果事件巨集在迴圈巨集使用前更改位址的值，則迴圈巨集的結果會是不正確的。


15.1. 巨集種類

巨集種類

■ 全局巨集
 全局巨集是指在同一個專案中，能被所有人機應用所使用的巨集。在專案中的多個人機應用，使用全局巨集即可共用同一巨集功能，因此不需保留相同的本地巨集。所以全局巨集所規劃的巨集程式，可以在整個專案中，被全部的所有畫面巨集和物件巨集所使用的稱之全局巨集，所以顧名思議，另一種為本地巨集就只能被該單獨的人機所使用。
 只有全局巨集可設為保護模式，也就是須輸入合格進入密碼才能查看和編輯巨集指令，所以說可以充份保護設計者的特殊程式或重要程式的智慧財產權，例如將一段PID運演算法則或通訊程式利用全局巨集設計，然後就可以在各種物件中呼叫調用，但其內容非設計者就無法修改。要設置全局巨集的密碼保護請在專案欄的資訊和保護項目中設定。

注意：全局巨集只可以使用內部變數。

■ 本地巨集
 本地巨集只能使用於巨集所在的人機應用。

■ 子巨集
 子巨集是其他巨集可以使用CALL指令，來執行的巨集。當巨集執行遇到CALL指令時，將停止目前巨集的執行，並執行子巨集。子巨集最後一個指令必須是RET，RET會結束子巨集的執行並且回去執行原先的巨集。RET指令也可以放在任意的位置。當子巨集結束並回到原巨集時，會接著CALL指令的下一行指令，繼續執行之後的操作。

藉由執行子巨集的一般功能，可使巨集模組化、共用化、易於閱讀和維護。

■ 整個應用提供了四種系統巨集：啟始巨集、主巨集、事件巨集、時間巨集。

■ 畫面提供了三種巨集：開巨集、關巨集、循環巨集。

■ 物件提供了三種巨集： 壹巨集、零巨集和物件巨集。

■ 警報顯示器和歷史數據顯示器提供一種巨集：查詢處理巨集。

■ 數據收集器提供一種巨集：數據收集巨集。

■ 排程提供兩種巨集：開始巨集、結束巨集。

請在適當的時機和目的使用適當的巨集，可以讓您整個人機應用得到最好的運行效益。

巨集執行時機 | 執行目的
開機，當人機應用開啟時，只執行一次(初始化用)。 | 啟始巨集(Startup Macro) 當觸控屏運行，第一次啟動觸控屏畫面工作程式應用時(通常指斷電後第一次重新送電執行應用畫面程式)，執行一次啟始巨集內的全部程式指令，然後才顯示第一個畫面。所以，如果啟始巨集內的程式太長，則第一次顯示畫面會需要較長開機時間；一般而言，啟始巨集是用來初始化人機應用的數據和設定。啟始巨集可以在人機應用一般設置對話框中設定。
開機後，當人機應用開始執行時，不斷地執行。 | 主巨集(Main Macro) 當觸控屏運行時，就會不斷地循環執行主巨集內的程式指令，但每次將只執行最多30行的巨集指令。而且不論觸控屏當前所在畫面為何，此主巨集均時時刻刻會被執行。只是主巨集的執行週期時間是無法非常精準的確定時間值，通常大約為每100-1000毫秒(msec)會執行一次。(巨集程式執行時間依程式長短而定)。也就是說當人機應用執行時，主巨集會循環不斷地執行，人機應用會在主巨集執行完畢或執行到END指令時，回到第一個指令重複執行。主巨集可以在人機應用一般設置對話框中設定。
當特定的觸發位從0變到1，觸發執行巨集一次。 | 事件巨集(Event Macro) 當觸控屏運行時，當觸發位(bit)信號有效(由關狀態=0切為開狀態=1)時，觸控屏將立刻執行事件觸發巨集內的全部指令一次。一個人機應用最多可設定四個事件巨集。事件巨集可以在人機應用一般設置對話框中設定。
所設間隔時間循環執行巨集程式。 | 時間巨集(Time Macro) 當觸控屏運行時，觸控屏將固定以所設時間週期循環執行時間巨集內的全部指令一次。所以為了使觸控屏的動作能合理運行，請儘量簡短時間巨集的指令數量。時間巨集的執行是週期性地重複執行。一個人機應用最多可設定四個時間巨集。每個時間巨集可設定不同的間隔時間(間隔時間0.5或1秒或每準點分鐘或每準點小時)。時間巨集可以在人機應用一般設置對話框中設定。
開啟此畫面時，執行巨集一次。 | 畫面開巨集(Screen Open Macro) 當畫面開啟時，會先執行此巨集內所有程式一次。等畫面開巨集執行完畢後，畫面才會出現。開巨集可以在畫面屬性的對話框中設定。
顯示此畫面時，依所設間隔時間循環執行巨集程式。 | 循環巨集(Cycle Macro) 當畫面開啟後，循環巨集會循環不斷地執行。也就是說，循環巨集從第一個指令開始，直到巨集結束或執行到END指令時，再從第一個指令開始循環，當畫面關閉時循環巨集也會立刻結束。循環巨集可以在畫面屬性的對話框中設定。循環巨集的程式指令間隔時間0.1、0.2、1.0 sec.區間可設。
當關閉此畫面時，執行巨集ㄧ次。 | 畫面關巨集(Screen Close Macro) 當畫面要被關閉時，會執行此巨集內所有全部程式一次，當關巨集執行完畢後，然後畫面才會結束。關巨集可以在畫面屬性的對話框中設定。
按鈕為 1 時，執行巨集一次。當按壓或放開按鈕使控制接點為1時。 | 壹巨集(On Macro) 當按壓或放開按鈕使控制接點為1時，會執行壹巨集內所有全部程式一次。當壹巨集結束，位的設定才會執行。所以，壹巨集的長度應該要儘可能縮短，才不會延遲位的執行。只有位按鈕及切換開關兩者提供壹巨集。壹巨集可以在按鈕的對話框中設定。
按鈕為 0 時，執行巨集一次。當按壓或放開按鈕使控制接點為0時。 | 零巨集(Off Macro) 當按壓或放開按鈕使控制接點為0時，會執行一次零巨集內所有全部程式。當零巨集結束，位的設定才會執行。所以，零巨集的長度應該要儘可能縮短，才不會延遲位的執行。只有位按鈕及切換開關兩者提供零巨集。零巨集可以在按鈕的對話框中設定。
當物件執行操作時，執行特定巨集一次。 | 物件巨集(Object Macro) 當物件執行特定操作時，會執行物件巨集一次。在操作前或操作後執行巨集，是依據該操作的種類。畫面按鈕、功能按鈕和鍵盤按鈕可設定物件巨集。物件巨集可以在物件的對話框中設定。 畫面按鈕巨集：當執行換畫面按鈕時，執行該巨集一次。 功能按鈕巨集：選擇檔案的功能按鈕物件提供了一個巨集。 鍵盤按鈕巨集：當執行鍵盤按鈕時，執行巨集。 進階數值顯示巨集：當執行高級數值顯示器時，可以執行顯示巨集。 進階數值輸出巨集：當執行高級數值顯示器_輸入操作時，可以執行輸出巨集。
當物件需要顯示由查詢過濾的數據時，執行該巨集 | 查詢處理巨集(Query Processing Macro) 當物件顯示或者相關觸發位由0 觸發為1時，運行查詢處理巨集。 警報顯示器和歷史數據收集器可以使用查詢處理巨集。在物件的屬性對話框中配置該巨集。
當數據收集器記錄的數據是處理過的數據，而不是原始數據時，使用該巨集。 | 數據收集巨集(Data Logging Macro) 數據收集器取樣數據是，運行數據收集巨集。數據收集巨集通過指令SAVE2LB來處理收集的數據並保存轉換後的數據到取樣數據緩衝區。在數據收集器的屬性對話框中配置數據收集巨集。
排程在開始時間執行特定的操作 | 開始巨集(Start Macro) 在排程的開始時間執行一次開始巨集。在勾選了運行巨集的排程屬性對話框中配置開始巨集。
排程在結束時間執行特定的操作 | 結束巨集(End Macro) 在排程的結束時間執行一次結束巨集。在勾選了運行巨集的排程屬性對話框中配置結束巨集。


15.2.1. 建立巨集

建立巨集

■ 建立一個新的巨集

1) 在專案 > 全局巨集，點選新增…按鈕即可建立全局巨集；或在專案管理員 > 全局 > 全局巨集中，點擊滑鼠右鍵後，從彈出的選單中點選新增巨集。

在人機應用 > 巨集，點選新增…按鈕即可建立本地巨集；或在專案管理員 > 人機應用 > 巨集中，點選滑鼠右鍵後，從彈出的選單中點選新增巨集。

2) 在新增巨集對話框中，輸入巨集名稱，然後按下ENTETR鍵或用滑鼠點擊確定鍵，然後完成建立巨集。

■ 導入巨集

1) 在專案管理員中 > 全局 > 全局巨集中，點擊滑鼠右鍵後，從彈出的選單中點選導入巨集…，即可導入現有的巨集為全局巨集。

在專案管理員中 > 人機應用 > 巨集中，點擊滑鼠右鍵後，從彈出的選單中點選導入巨集…，即可導入現有的巨集為本地巨集。

2) 從所需的*.mcr或*.txt檔中，點選並建立新的巨集。如果想要導入的巨集在不同的資料夾，請先點選該資料夾。

3) 用滑鼠點擊開啟舊檔。所建立的巨集就是原始建立的巨集。


15.2.2. 開啓和結束巨集

開啓和結束巨集

■ 開啟現有的巨集

在專案 > 全局巨集 > 編輯中，點選開啟所需的全局巨集，或在專案管理員 > 全局中，用滑鼠雙擊全局巨集，或從物件對話框的巨集設定中，選擇下拉式清單中，在"-------------全局-----------"後的全局巨集。

在人機應用 > 巨集 > 編輯中，點選開啟所需的本地巨集，或在專案管理員>人機應用中，用滑鼠雙擊本地巨集，或從物件對話框的巨集設定中，選擇下拉式清單中，在"-------------全局-----------"前的本地巨集。

■ 在巨集編輯器視窗中，開啟*.txt或*.mcr檔：

可利用拖放完成：

1) 點選現有的巨集來開啟巨集編輯器視窗。
2) 拖曳.mcr或.txt檔至巨集編輯器中後，放開滑鼠即可。
 注意：在巨集編輯器視窗中的原巨集將會被讀入的巨集所取代。

■ 關閉巨集編輯器視窗：

要關閉單一視窗，選擇該視窗並點擊關閉鈕。
 要關閉所有視窗，選擇視窗選單中的Windows…，在視窗對話框中，選擇所有想要關閉的視窗，並按下關閉視窗鈕。
 注意：當關閉巨集編輯器視窗時，巨集指令屬性視窗會自動關閉。即使關閉巨集編輯器視窗，巨集的變更仍會儲存，除非結束軟體時沒有儲存變更。

■ 結束巨集指令屬性視窗：

點擊在巨集指令屬性視窗的關閉鈕或勾選/取消在檢視選單中的巨集指令屬性，來結束巨集指令屬性視窗。


15.2.3. 設定巨集名稱

設定巨集名稱

當新增全局或本地巨集，必須在以下的視窗中輸入巨集的名稱。

當導入檔案為巨集時，預設的巨集名稱就是該檔案的名稱。

在每一個人機應用中，本地巨集的名稱必須是唯一的，但可與全局巨集的名稱相同。

■ 從專案管理員中更改巨集名稱：

  1. 點選欲更名的巨集。

  2. 點擊滑鼠右鍵後，彈出選單，然後點選更名。

  3. 輸入新的巨集名稱後，按下ENTER鍵後完成。

■ 搜尋巨集：

在菜單“編輯>搜尋和替換”中，運用搜尋巨集功能，搜尋在整個應用中使用的巨集。

在搜尋結果窗口中，顯示搜尋結果。下面是一個搜尋結果的範例。搜尋結果窗口的詳細資訊，參見 17.1.2搜尋结果窗口。


15.2.4. 刪除巨集

刪除巨集

■ 從專案管理員中刪除巨集：

  1. 點選欲刪除的巨集。

  2. 點擊滑鼠右鍵後，彈出選單，然後點選刪除。

■ 從選單中刪除巨集

在專案選單中，選取全局巨集、刪除的子選單，點選欲刪除的全局巨集。

 在人機應用選單中，選取本地巨集、刪除的子選單，點選欲刪除的本地巨集。

 注意：一次只能刪除一個巨集。如果要刪除的巨集已經被人機應用或物件使用中，會出現確認刪除視窗。


15.2.5. 存儲和導出巨集

儲存和導出巨集

如果想讓巨集在其他人機應用中使用，可將巨集導出為.txt或.mcr檔，步驟如下：

  1. 點選欲導出的巨集。

  2. 點擊滑鼠右鍵後，彈出選單，然後點選導出巨集。

  3. 如果要將巨集另存在其他的資料夾，點選要儲存的資料夾，然後用滑鼠點擊存檔。


15.2.6. 巨集對話框的設定

巨集對話框的設定

用戶可以在有巨集頁面的對話框中，開啟和編輯巨集或建立一個新的巨集。下面範例是位按鈕的巨集頁面的範例。

bit button configuration dialog

下表為一般頁面各項屬性的說明：

項目 | 說明
巨集名稱 | 從下拉式清單中選擇現有的本地或全局巨集。下面是範例：
新增... | 點選此處出現新增巨集對話框，可建立新的巨集。
巨集編輯器視窗 | 在巨集編輯器視窗中編寫巨集。參考章節1 5.3.1 ，取得更詳細的說明。如果編輯器視窗太小，你可以拖曳視窗來調整大小。要移動視窗，在視窗的邊框上點擊並按住滑鼠左鍵不放，拖曳滑鼠來移動視窗，當拖曳視窗時，該視窗會置於最上層，使你可以任意移動視窗。然後，在你想要放置視窗的位置，放開滑鼠左鍵。點擊在視窗右下角調整大小的標籤，可調整視窗大小。點擊關閉按鈕來結束視窗。下面是巨集編輯器視窗的範例：
指令屬性編輯 | 在屬性對話框可設定巨集指令屬性編輯。參考章節 15.3.2.，取得更詳細的說明。巨集屬性對話框可以移動、調整大小。但必須先結束巨集編輯器視窗，才能結束屬性對話框。


15.3. 編寫巨集

編寫巨集

在本軟體中，編寫巨集的地方包含兩個部分：巨集編輯器視窗和巨集指令屬性工具視窗。

當你從專案管理員中開啟巨集時，將會看見以下的範例：


15.3.1. 巨集編輯器視窗

巨集編輯器視窗

巨集編輯器是一種文字的編輯器，有語法標色和給予行編號。視窗左邊每一行的編號，使指定巨集的特定位置容易。不同的語法標色使巨集的架構清楚，利用不同的顏色區分不同的語法。如：關鍵字是黑色、註解是綠色、位址是藍色、常數是紅色。

■ 編輯巨集

用戶可以使用選單的指令、組合鍵和拖放三種操作方式，將選取的文字剪下、複製或貼上。

你也可以復原或重做。點擊滑鼠右鍵彈出編輯指令選單。出現的編輯指令依箭頭所指的位置而定。

巨集編輯器可進行以下的編輯動作：

* 剪下、複製、貼上和刪除選取單行、多行或文字。
* 復原或重做。
* 在同一個視窗或兩個不同的視窗中，使用拖放來移動、複製所選的文字。

下表為支援的編輯指令。

選單指令 | 快捷鍵 | 說明
剪下 | CTRL+X | 從巨集編輯器視窗將選的文字移除。
複製 | CTRL+C | 從巨集編輯器視窗複製選取的文字。
貼上 | CTRL+V | 將複製或剪下的文字貼上巨集視窗中。
刪除 | DELETE | 直接刪除文字，不放到剪貼簿中。
復原 | CTRL+Z | 回到上一個編輯動作。
重做 | CTRL+Y | 重做被復原的編輯動作。
全選 | CTRL+A | 選取巨集編輯器中所有的文字。

注意：所有的編輯指令需要先選取才能進行編輯操作。一些指令可以在游標所在的位置選取。

■ 巨集的註解

 註解是巨集在執行時並不會被執行的補助說明。巨集支援單行註解或區塊註解。單行註解以雙斜線開始(//)，到該行最後結束。下面是單行註解的範例：

IF $U0.0 (B) // Key Down

 區塊註解以開始分隔號(/*)開始，到結束分隔號(*/)結束。下面是區塊註解的範例：
/* $N1001=WH2021
$N1010=$N1001 */

■ 設定巨集的常數
 設定十六進位數，使用h或H做字尾。例如：12abH和3ABh是有效的十六進位數。

另外，也可使用0x或0X做字首，例如：0x1278abc和0XFFFF0000是有效的十六進位數。

設定二進位數，使用b或B做字尾，例如：001100111b和11110000B是有效的二進位數。

 十進位則輸入要設定常數的數字即可。然而，當常數與有效的外部變數相同時，會產生混淆。例如：如果人機應用連接到一個Modicon Modbus從設備，則無法區分40001是常數還是控制器的 暫存器地址。為避免這樣情形產生，用以下的方法宣告數字為常數：

1) 使用K、k、D或d作為整數的字尾，例如：-123K和-123d是有效的常數-123。
2) 使用F或f作為有小數數字的字尾，例如：-12.3F或-12.3f是有效的浮點常數-12.3。


15.3.2. 巨集指令工具視窗

巨集指令工具視窗

巨集指令屬性工具視窗可幫助你快速、簡單地增加或修改巨集指令。

打開專案管理員或是選單，開啟巨集後，巨集屬性工具視窗開啟後為停靠視窗。停靠工具視窗會自動地顯示、隱藏、以標籤頁型式與其他工具視窗連結或停靠在視窗邊緣或自由浮動。當巨集編輯器打開時，你可以選擇開啟或結束巨集指令屬性工具視窗，點選檢視選單中的巨集指令屬性即可。

如果你從物件的對話框開啟巨集，巨集屬性工具視窗會漂浮在巨集編輯器的旁邊。巨集屬性工具視窗可以任意移動，但無法關閉。

 下表為巨集屬性工作視窗中，各種屬性的說明。

項目屬性 |  | 說明
指令 |  | 點擊下拉式清單，出現巨集指令選擇對話框。從標籤頁中瀏覽巨集指令的關鍵字，然後，點選巨集指令。指令的格式在對話框關閉後，將會出現在下拉式清單中。點選巨集指令選擇對話框外的任何區域，即可取消操作。
數據類別 |  | 從下拉式清單選擇巨集指令的數據類別。不同的巨集指令支援不同的數據類別。數據類別如下：(S)整數、(U)正整數、(SD)32位整數、(UD)32位正整數、(F)浮點數、(B)位/接點。
參數 | <輸入欄> | 資料類別是(B)時，輸入位變數。 資料類別是(U)/(S)時，輸入字變數或常數。 資料類別是(UD)/(SD)/(F)時，輸入雙字變數或常數。
 |  | 點擊此圖標，出現變數地址輸入鍵盤，可設定地址。
 |  | 點擊此圖標，出現選取標籤對話框，可選取標籤變數。
巨集指令提示視窗 |  | 顯示巨集指令的操作、參數類別。

注意：在屬性對話框中的任何修改都會改變在巨集編輯器的巨集指令。


15.4.1. 巨集的符號和用語

巨集的符號和用語

下面是巨集指令和範例所使用的符號和用語。

■ 符號
1)P1, P2, P3, P4, P5: 巨集指令的參數。
2)I, E, C, A, CS, M, AE, CE: 指示巨集指令可使用的參數種類。

縮寫 | 縮寫
I | 內部變數
E | 外部變數
C | 常數
A | ASCII文字串
CS | 文字標記對應巨集程式
M | 次巨集名稱
AE | 算術運算式
CE | 比較運算式

3) U, S, UD, SD, F, B: 指出巨集指令可支援的數據類別。

縮寫 | 數據類別
U | 16位正整數
S | 16位正負整數
UD | 32位正整數
SD | 32位正負整數
F | 32位浮點數
B | 位

■ 用語

用語 | 定義

內部記憶區

在HMI的系統記憶區中，可被人機應用所存取的部分。例如：用戶記憶區$U、非揮發性記憶區$N(有停電保持)、系統記憶區$S和配方記憶區$R(有停電保持)，都是內部記憶區。
內部變數 | 對應到內部記憶區的地址或標籤。

內部位變數

內部位變數指的是在內部記憶區的一個位。為了閱讀方便，在不會產生混淆的前提下，文章中我們通常用“內部變數”，而不用“內部位變數”。

內部字變數

內部字變數指的是在內部記憶區的一個字。這個變數同時還可代表雙字、位元組區塊(位元組陣列)、字區塊(字陣列)和雙字區塊(雙字陣列)。

為了閱讀方便，在不會產生混淆的前提下，文章中我們通常用“內部變數”，而不用“內部字變數”。
外部記憶區 | 在控制器的記憶區或是設備的可定址的數據地址，人機應用可經由通訊連結來存取的部份。
外部變數 | 在外部記憶區的變數數據位址或標籤。

外部位變數

外部位變數指的是在外部記憶區的一個位。為了閱讀方便，在不會產生混淆的前提下，文章中我們通常用外部變數，而不用外部位變數。

外部字變數

外部字變數指的是在外部記憶區的一個字。如果相關地址存取單位是字，這個變數同時還可代表雙字、位元組區塊(位元組陣列)、字區塊(字陣列)和雙字區塊(雙字陣列)。如果相關地址存取單位是雙字，這個變數只可代表雙字或長度是4的倍數的記憶區塊。為了閱讀方便，在不會產生混淆的前提下，文章中我們通常用外部變數，而不用外部字變數。
運算式
種類 | 縮寫 | 說明
算術運算式 | AE | 運算元和參數的順序是用來計算參數的值
比較運算式 | CE | 運算元和參數的順序是用來比較參數的值
本軟體提供以下種類的運算元:
 software provide
注意：上表是依照運算元的優先執行順序排序上到下(由高至低)。在表中，相同的運算式有相同的優先順序。除非運算式有出現括號，否則依從由左至右的順序執行運算。


15.4.2. 數據搬移和設值

數據搬移和設值

■ ( = )→設值

指令格式 | P1 = P2 | 數據類別 | U/S/UD/SD/F/B
功能 | 將 P2 的值指派給 P1或是將參數 P2 的數據複製到參數 P1的目標位置。
P1 (I/E) | 目標值。
P2 (I/E/C/AE) | 原始值。
例 1 | $U2 = 123.45 (F) /* 將浮點數123.45指派給$U2(包括$U3)。*/
例 2 | $U100.f = 1d (B) /* 將On信號指派給指定地址位。 */
例 3 | W60 = ($U30 + W50 - 1000) / 2 (SD) /* 算術運算式的運算結果指派給W60。 */
例 4 | V0.0 = 2\M0 (B) /*2\M0表示Link2接三菱PLC M0; V0.0 表示Link1接S7-200 PLC。 */ /* 當 Link2 PLC M0=0 則Link1西門子PLC V0.0=0。/

■ ( = ! )→位邏輯反相

指令格式 | P1 = ! P2 | 數據類別 | B
功能 | P1對 P2 位取邏輯反相，並將運算結果保存到 P1。
P1 (I/E) | 位邏輯運算結果。
P2 (I/E) | 運算位元。
例 1 | $U2.3 = !$U3.4 (B) /* 當$U3.4為1(On)時，則$U2.3為0(Off)。 */

■ " "→ASCII設值

指令格式 | P1 = "P2"
功能 | 將P2的文字串轉換為ASCII碼複製到P1的目標位置。需要注意的是這個字串是一個帶空格中止符的字串00h，如果這個字串的長度是N，那麼複製給 P1 的有N+1個字且最後一個字為0。
P1 (I) | 運算結果。(內部字地址)
P2 (A) | 被複製ASCII文字串來源。
例 1 | $U60 = "TEST" /* $U60=7748 ("T"+"E")、$U61=1587 ("S"+"T")、$U62為空格字串00h。 */
例 2 | $U20 = "ABCDE" /* 則 $U20=4241 H (BA)，$U21=4443 H (DC)，$U22=0045 H (E)。$U22的高字節為空格字串0x00。 */

■ MOV→區塊搬移

指令格式 | P1 = MOV(P2,P3) | 數據類別 | U/S/UD/SD/F
功能 | 複製從地址 P2 起 P3 個連續字暫存器到目標地址 P1。
P1 (I/E) | 複製目標記憶區的首地址。
P2 (I/E) | 複製來源記憶區的首地址。
P3 (I/C) | 複製 數據的長度。
例 1 | $U100 = MOV($U200, 16) /* 從$U200起複製16個字暫存器的數據給$U100。*/
例 2 | W60 = MOV($U200, $U2) /*從$U200起複製一個數據組給W60，數據組的長度由$U2決定。*/
例 3 | $U10 = MOV(2\D100,10) /* 將Link2 PLC的D100~D109暫存器的值複製到觸控屏內部暫存器$U10~19。*/

■ SETM→多筆設值

指令格式 | P1 = SETM(P2,P3) | 數據類別 | U
功能 | 將同一 P2 的值設定給從 P1 為起始位址且連續 P3 個字。
P1 (I/E) | 設定值或內容值寫入記憶區陣列的起始位址
P2 (I/C) | 設定值或該指定地址的暫存器內容值。
P3 (I/C) | 要被設定的暫存器個數。最大可設個數為512。
例 1 | $U100 = SETM(0, 16) /*將數值0設定給$U100∼$U115。 */
例 2 | W60 = SETM($U200, $U2) /*依照$U2的值為數據複製個數，將$U200的數據相同值設給從W60為起始位址的每一個位址。*/

■ MOV_BITS→位區塊搬移

指令格式 | P1 = MOV_BITS(P2,P3) | 數據類別 | B
功 能 | 複製目標從地址P2起複製P3個位的值到起始地址為P1的位區塊中。
P1 (I) | 複製目標記憶區的首地址。
P2 (I/E) | 複製來源記憶區的首地址。
P3 (C) | 複製數據的長度。
例 1 | $U100.0 = MOV_BITS($U200.0, 16)(B) /* 從$U200起複製16個位的值給$U100。*/
例 2 | $U10.1 = MOV_BITS(W60.1, 10) (B)/*從W60.1起複製10個位的值給$U10.E。*/


15.4.3. 算術運算

算術運算

■ ( + )→加法

指令格式 | P1 = P2 + P3 | 數據類別 | U/S/UD/SD/F
功能 | 將 P2 加上 P3 的運算結果保存到 P1。
P1 (I/E) | 運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例 1 | $U100 = $U101 + $U102 (U)
例 2 | W100 = 0.3*$U0 + 0.1*$U2 + 0.6*$U4 (F)

■ ( - )→減法

指令格式 | P1 = P2 - P3 | 數據類別 | U/S/UD/SD/F
功能 | 將 P2 減去 P3，運算結果保存到 P1。
P1 (I/E) | 運算結果
P2,P3 (I/E/C/AE) | 運算元。
例 1 | $U100 = $U101 - $U102 (U)
例 2 | W100 = 0.3*$U0 - 10.75 (F)

■ ( * ) →乘法

指令格式 | P1 = P2 * P3 | 數據類別 | U/S/UD/SD/F
功能 | 將 P2 乘以 P3，運算結果保存到 P1。
P1 (I/E) | 運算結果，如果運算結果產生了溢出，溢出的高位將被釋放，低位則保存到 P1。雙字的乘法則 P1 是雙字(doublewords)，P2 單字(word)乘 P3 單字(word)的乘法則 P1 是單字(word)。
P2,P3 (I/E/C/AE) | 運算元。
例 1 | $U100 = $U102 * 0x192
例 2 | W100 = ($U0 + $U2) * ($U4 + $U6) (F)

■ ( / )→除法

指令格式 | P1 = P2 / P3 | 數據類別 | U/S/UD/SD/F
功能 | 將 P2 除以 P3 的運算結果保存到 P1。
P1 (I/E) | 運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例 1 | $U100 = $U101 / $U102 (U)
例 2 | W100 = ($U0 + $U2) / ($U4 + $U6) (F)

■ ( % )→取餘數

指令格式 | P1 = P2 % P3 | 數據類別 | U/S/UD/SD
功能 | 將 P2 除以 P3 後的餘數保存到 P1。
P1 (I/E) | 運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例 1 | $U100 = $U30 % 16(U)
例 2 | W100 = $U200 % ($U402 + $U106) (SD)


15.4.4. 邏輯運算

邏輯運算

■ ( | )→相對位元邏輯_或(OR)

指令格式 | P1 = P2 | P3 | 數據類別 | U/UD/B
功能 | P1.將 P2 和 P3 做「或」（OR）位元邏輯運算，並將運算結果保存到 P1。
P1 (I/E) | 運算結果。
P2,P3 (I/E/C) | 運算元。
例 1 | W60 = 1111000000001111b $U100 = 0000111100001111b | W60 (U) /* 當$U101為0000111100001111(B)，而W60為1111000000001111(B)時，則$U100為1111111100001111(B)。 */
例 2 | B15 = $U1.2 | B14 (B) /* 當$U1.2為0(Off)且B14也為0(Off)時，則B15為0(Off)其他情況為1(On)。*/

■ ( & )→相對位元邏輯_且(AND)

指令格式 | P1 = P2 & P3 | 數據類別 | U/UD/B
功能 | 將 P2 和 P3 做「且」（AND）位元邏輯運算，並將運算結果保存到 P1。
P1 (I/E) | 運算結果。
P2,P3 (I/E/C) | 運算元。
例 1 | W60 = 1111000000001111b $U100 = 0000111100001111b & W60 (U) /* 當$U101為0000111100001111(B)，而W60為1111000000001111(B)時，則$U100為0000000000001111(B)。*/
例 2 | B15 = $U1.2 & B14 (B) /*當$U1.2為1(On)且B14也為1(On)時，則B15為1(On)其他情況為0(Off)。 */

■ ( ^ ) →相對位元邏輯_互斥或(XOR)

指令格式 | P1 = P2 ^ P3 | 數據類別 | U/UD/B
功能 | 將 P2 和 P3 做「互斥」(XOR)位元邏輯運算，並將運算結果保存到 P1。
P1 (I/E) | 運算結果。
P2,P3 (I/E/C) | 運算元。
例 1 | W60 = 1111000000001111b $U100 = 0000111100001111b ^ W60 (U) /* 當$U101為0000111100001111(B)，而W60為1111000000001111(B)時，則$U100為1111111100000000(B)。*/
例 2 | B15 = $U1.2 ^ B14 (B) /*當$U1.2為1(On)且B14也為1(On)時，則B15為0(Off)，當$U1.2為1(On)而B14為0(Off)時，則B15為1(On)。*/

■ ( << )→左移

指令格式 | P1 = P2 << P3 | 數據類別 | U/UD
功能 | 將 P2 的值向左移動 P3 個位元(bits)，並將運算結果保存到 P1 這個運算操作只支援邏輯移動。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被移動的值。
P3 (I/E/C) | 被移動的位元數(bits)。
例 1 | $U100 = $U101 << 8 (U)
例 2 | W200 = W100 << $U10 (UD)

■ ( >> )→右移

指令格式 | P1 = P2 >> P3 | 數據類別 | U/UD
功能 | 將 P2 的值向右移動 P3 個位元(bits)，並將運算結果保存到 P1。這個運算操作只支援邏輯移動。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被移動的值。
P3 (I/E/C) | 被移動的位元數(bits)。
例 1 | $U100 = $U101 >> 8 (U)
例 2 | W200 = W100 >> $U10 (UD)

■ ( && )→位邏輯_且

指令格式 | P1 = P2 && P3 | 數據類別 | B
功能 | 若位 P2 和位 P3 的值都為1，那麼將位 P1 置1，否則清為0。
P1 (I/E) | 運算結果。
P2,P3(I/E/C) | 運算元。
例 1 | $U100.0 = $U101.0 && $U101.1 (B)

■ ( || )→位邏輯_或

指令格式 | P1 = P2 || P3 | 數據類別 | B
功能 | 若位 P2 和位 P3 之中至少有一個的狀態值為1，那麼將位 P1 置1，否則清為0。
P1 (I/E) | 運算結果。
P2,P3(I/E/C) | 運算元。
例 1 | $U100.0 = $U101.0 || $U101.1 (B)


15.4.5. 計算

計算

■ MAX →兩值比較取最大值

指令格式 | P1 = MAX(P2,P3) | 數據類別 | U/S/UD/SD/F
功能 | 在 P2 和 P3 兩值中取較大值，並將該值保存到 P1。
(I/E) | 運算結果。
(I/E/C) | 運算元。
例 1 | $U100 = MAX(100, 200) /* 將常數200保存到$U100。 */

■ MIN→兩值比較取最小值

指令格式 | P1 = MIN(P2,P3) | 數據類別 | U/S/UD/SD/F
功能 | 在 P2 和 P3 兩值中取最小值，並將該值保存到 P1。
P1 (I/E) | 運算結果。
P2,P3(I/E/C) | 運算元。
例 1 | $U100 = MIN(100, 200)/* $U100=100。*/

■ BMAX →陣列取最大值

指令格式 | P1 = BMAX(P2,P3) | 數據類別 | U/S/UD/SD/F
功能 | 在以 P2 為起始位址，以 P3 為數據長度的一組陣列數據中，查找最大值，並將該值保存到 P1。
P1 (I) | 運算結果。
P2 (I) | 數據組（陣列）的起始位址。
P3 (I/C) | 數據組（陣列）的長度。
例 1 | $U100 = BMAX($U200, 16) (F) /* 以$U200為起始位址，連續16個浮點數，查找最大值，並將該值保存到$U100。 */

■ BMIN→陣列取最小值

指令格式 | P1 = BMIN(P2,P3) | 數據類別 | U/S/UD/SD/F
功能 | 在以 P2 為起始位址，以 P3 為數據長度的一組陣列數據，查找最小值，並將該值保存到 P1。
P1 (I) | 運算結果。
P2 (I) | 數據組（陣列）的起始位址。
P3 (I/C) | 數據組（陣列）的長度。
例 1 | $U100 = BMIN($U200, 60) (F) /*以$U200為起始位址的連續60個浮點數，查找最小值，並將該值保存到$U100。 */

■ SUM →陣列加總

指令格式 | P1 = SUM(P2,P3) | 數據類別 | U/S/UD/SD/F
功能 | 將參數 P2 指定的起始位置連續 P3 個數據，整組陣列數據加總，並將運算結果保存到 P1。
P1 (I) | 運算結果。
P2 (I) | 數據組（陣列）的起始位址。
P3 (I/C) | 數據組（陣列）的長度。
例 1 | $U100 = SUM($U200, 16) (F) /* 計算出以$U200起始位址的連續16個浮點數的總和，並將運算結果保存到$U100。 */

■ XSUM→邏輯互斥或(XOR) 加總和

指令格式 | P1 = XSUM(P2,P3) | 數據類別 | U/UD
功能 | 以 P2 為起始位址，連續 P3 個數據長度的一組陣列數據中，對所有對應位做「互斥或」(XOR) 位元邏輯運算和，並將運算結果保存到 P1 的目標位置。
P1 (I) | 運算結果。
P2 (I) | 數據組（陣列）的起始位址。
P3 (I/C) | 數據組（陣列）的長度。
例 1 | $U100 = XSUM($U200, 5) (UD) /* 計算從$U200開始的80個32位正整數的互斥或加總和，並將運算結果保存到雙字$U100。它的另一種表達方式為 $U100 = $U200 ^ $U202 ^ $U204 ^ $U206 ^ $U208 (UD).. .. */ $U100 = 1001B $U101 = 1100B $U102 = 0110B $U120 = XSUM($U100,3) /* $U120=0011B */

■ SWAP→位元組(位元組Byte)交換

指令格式 | SWAP(P1,P2) | 數據類別 | U
功能 | 以 P1 為起始位址，以 P2 為數據長度的整組陣列數據中，每個字的高位元組(高字節)與低位元組(低字節)進行交換。
P1 (I) | 數據組（陣列）的起始位址。
P2 (I/C) | 數據組（陣列）的長度。
例 1 | $U120=1111111100000000B $U121=1000000100000000B SWAP($U120, 2) /* $U120的值等於0000000011111111B，$U121的值等於0000000010000001B。 */

■ INIT_CRC→初始化CRC演算法

指令格式 | INIT_CRC(P1) | 數據類別 | U
功能 | 初始化巨集指令 CRC8和巨集指令CRC16的迴圈冗餘校驗(CRC)的演算法。
P1 (I) 存儲用於初始化CRC演算法的字數據塊的起始位址。初始化CRC演算法需要8個字，字數據塊中各個字的描述如下表：
字序號 | 參數
0 CRC校驗和大小
值 | 大小
8 | 8位校驗和
16 | 16位校驗和
1 數據屬性
位 | 屬性
0 | 數據發送順序 0：最高有效位(MSB)第一 1：最低有效位(LSB)第一
1-15 | 保留位。 必須為 0。
2 CRC多項式表示法的低位字
值(最高為有效) | 值(最低位有效) | 多項式 | 名稱
0x07 | 0xE0 | x8 + x2 + x + 1 | CRC-8-CCITT
0x31 | 0x8C | x8 + x5 + x4 + 1 | CRC-8-Dallas/Maxim
0xD5 | 0xAB | x8 + x7 + x6 + x4 + x2 + 1 | CRC-8
0x1D | 0xB8 | x8 + x4 + x3 + x2 + 1 | CRC-8-SAE-J1850
0x9B | 0xD9 | x8 + x7 + x4 + x3 + x + 1 | CRC-8-WCDMA
0x8005 | 0xA001 | x16 + x15 + x2 + 1 | CRC-16
0x1021 | 0x8408 | x16 + x12 + x5 + 1 | CRC-16-CCITT
0x8BB7 | 0xEDD1 | x16 + x15 + x11 + x9 + x8 + x7 + x5 + x4 + x2 + x + 1 | CRC-16-T10-DIF
0x3D65 | 0xA8BC | x16 + x13 + x12 + x11 + x10 + x8 + x6 + x5 + x2 + 1 | CRC-16-DNP
0xD589 | 0x91A0 | x16 + x10 + x8 + x7 + x3 + 1 | CRC-16-DECT
3 | 多項式表示法的高位字；預留給CRC-32。
4 | CRC 初始值的低位字。
5 | CRC初始值的高位字；預留給CRC-32。
6 | 最終異或值的低位字。
7 | 最終異或值的高位字；預留給CRC-32。
例 1 $U100 = 16 /* CRC-16 */
$U101 = 1 /* 按最低有效位第一的順序發送 */
$U102 = 0xA001 /* CRC-16-ANSI*/
$U104 = 0xFFFF/* CRC初始值 */
$U106 = 0/* 沒有最終異或值 */
INIT_CRC($U100) /* 為Modbus初始化CRC演算法 */

■ CRC8→計算8位CRC校驗和

指令格式 | P1 = CRC8(P2,P3) | 數據類別 | U
功能 | 計算長度為 P3，存儲在起始位址為P2的數據的8位CRC校驗和，並將結果保存在P1中。
P1 (I) 用來保存結果的字，字的高位元組為0。

注意：必須先執行INIT_CRC 命令來初始化CRC演算法，否則，此結果將無意義。如果使用相同的CRC演算法，就無需再次初始化。

P2 (I) | 計算校驗和的字數據塊的起始位址。注意，只計算字的低位元元組，高位元組被忽略。
P3 (I/C) | 字數據塊的長度，同時也指定校驗和演算法中的位元組數。
例 1 $U100 = “ABCDEEFGH”
$U110 = B2W($U100, 9) /* 將位元組數組轉化為字數組*/
$U120 = CRC8($U100, 9) /* 將字串“ABCDEFGH” 的8位CRC校驗和保存到$U120 */

■ CRC16→計算8位CRC校驗和

指令格式 | P1 = CRC16(P2,P3) | 數據類別 | U
功能 | 計算長度為 P3，存儲在起始位址為P2的數據的16位CRC校驗和，並將結果保存在P1中。
P1 (I) 用來存儲結果的字數據塊。
字序號 | 參數
0 | 字的低位元組用來保存校驗和的低位元組，字的高位元組設為 0。
1 | 字的低位元組用來保存校驗和的高位元組，字的高位元組設為 0。
必須先執行INIT_CRC 命令來初始化CRC演算法，否則，此結果將無意義。如果使用相同的CRC演算法，就無需再次初始化。
P2 (I) | 計算校驗和的字數據塊的起始位址。注意，只計算字的低位元元組，高位元組被忽略。
P3 (I/C) | 字數據塊的長度，同時也指定校驗和演算法中的位元組數。
例 1 $U100 = “ABCDEEFGH”
$U110 = B2W($U100, 9) /* 將位元組數組轉化為字數組*/

$U120 = CRC16($U100, 9)/* 將字串“ABCDEFGH” 的16位CRC校驗和保存到$U120和$U121 */


15.4.6. 數據轉換

數據轉換

■ BCD→二進位碼轉換為十進位 BCD碼

指令格式 | P1 = BCD(P2) | 數據類別 | U/UD
功能 | 將參數P2二進位碼轉換為十進位BCD碼，傳送到參數P1的目標位置。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的二進位數字。
例 1 | $U100 = BCD(0x1234) (U) /* $U100 的值等於1234。 */

■ BIN→十進位BCD碼轉換為二進位碼

指令格式 | P1 = BIN(P2) | 數據類別 | U/UD
功能 | 將參數P2十進位BCD碼轉換為二進位碼，傳送到參數P1的目標位置。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的BCD碼。
例 1 | $U100 = BIN(1234) (U) /* $U100 的值等於0x1234。 */

■ DW→字傳送至雙字

指令格式 | P1 = DW(P2) | 數據類別 | U/S
功能 | 將16位整數 P2 轉換為32位整數，並將轉換結果保存到 P1，高字補零。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的16位整數。
例 1 | $U100 = DW(12345) (S) /*$U100的值等於 12345，而$U101的值等於0。*/
例 2 | $U200 = DW(-12345) (S) /* $U200的值等於-12345，而 $U201 的值等於0xFFFF。*/

■ W→雙字取低字

指令格式 | P1 = W(P2) | 數據類別 | UD/SD
功能 | 將32位整數 P2 轉換成16位整數，並將轉換結果保存到 P1。運算可能會產生溢位元，高位將被釋放。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的32位整數。
例 1 | $U100 = W(0x12345678) (UD) /* $U100 的值等於 0x5678。 */
Example 例 2 | $U200 = W(-12345) (SD) /* $U200 的值等於 -12345。 */

■ B2W→高低字節轉換到連續字存放

指令格式 | P1 = B2W(P2,P3) | 數據類別 | U
功能 | 以 P2 為起始位址，P3 為數據長度的位元組(Byte)陣列，轉換成 P3 個數據長度的字(Word)陣列，並將轉換結果保存到以 P1 為起始位址的陣列數據中。所有字的高位元組(high Byte)都補0。
P1 (I) | 運算結果的起始位址。
P2 (I) | 被轉換的位元組數的起始位址。
P3 (I/C) | 數據組的長度。
例 1 | $U200 = 0x45FA $U201 = 0xEB29 $U100 = B2W($U200, 3) /* 將以$U200為起始位址的連續3個位元組轉換成3個字，並將結果保存到以$U100為起始位址的連續3個字中。$U100 = 0xFA，$U101 = 0x45，$U102 = 0x29。 */

■ W2B→單獨取字的低字節轉換至另一字存放

指令格式 | P1 = W2B(P2,P3) | 數據類別 | U
功能 | 將 P2 為起始位址，以 P3 為數據長度的字陣列，轉換成以 P3 為數據長度的位元組，並將轉換結果保存到以 P1 為起始位址的陣列數據中。所有被轉換的字數據內的高位元組都被釋放。數據組陣列最大不能超過256個字。
P1 (I) | 運算結果存放的起始位址。
P2 (I) | 被轉換的字數據組（陣列）的起始位址。
P3 (I/C) | 數據組（陣列）的長度。
例 1 | $U200 = 0x45FA $U201 = 0xEB29 $U202 = 0xC781 $U100 = W2B($U200, 3) /* 將以$U200為起始位址的連續3個字轉換成3個位元組(Byte)，並將結果保存到以$U100為起始位址的連續3個位元組中。$U100的值等於0x29FA，$U101的低位元組等於 0x81，$U101的高位元組等於 0x00。*/

■ A2X→A SCII碼轉換成16位正整數

指令格式 | P1 = A2X(P2) | 數據類別 | U
功能 | 將4個以 P2 為起始位元址的ASCII文字轉換為一個二進位的數，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。
P2 (I) | 被轉換參數的起始位址。P2 的ASCII文字需為0-F方為有效。
例 1 | $U20 = 49 // '1' $U21 = 50 // '2' $U22 = 69 // 'E' $U23 = 70 // 'F' $U100 = A2X($U20) /* $U100 的值等於0x12EF。*/

■ X2A→16位正整數轉換成4個ASCII

指令格式 | P1 = X2A(P2) | 數據類別 | U
功能 | 將一個16位整數 P2 轉換成4個連續的ASCII文字碼，並將轉換結果保存到 P1 為起始位址的數組中，高字節補零。
P1 (I) | 運算結果的起始字位址。
P2 (I/C) | 被轉換的16位整數。
例 1 | $U10 = X2A(0x34AB) /*從$U10開始 數據依次為：51('3'), 52('4'), 65('A'), 66('B')。*/

■ W2F→字格式轉換成浮點數

指令格式 | P1 = W2F(P2) | 數據類別 | U/S
功能 | 將16位整數 P2 轉換成浮點數，並將轉換結果保存到 P1。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的16位整數。
例 1 | $U200 = W2F($U10) (S)

■ D2F→雙字格式轉換成浮點數

指令格式 | P1 = D2F(P2) | 數據類別 | UD/SD
功能 | 將32位整數 P2 轉換成浮點數，並將轉換結果保存到 P1。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的32位整數。
例 1 | $U200 = D2F($U10) (SD)

■ F2W→浮點數轉換成字格式

指令格式 | P1 = F2W(P2) | 數據類別 | F
功能 | 將浮點數 P2 轉換成16位整數，並將轉換結果保存到 P1。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的浮點數。
例 1 | $U200 = F2W($U10) (F)

■ F2D→浮點數轉換成雙字格式

指令格式 | P1 = F2D(P2) | 數據類別 | F
功能 | 將浮點數 P2 轉換成32位整數，並將轉換結果保存到 P1。
P1 (I/E) | 運算結果。
P2 (I/E/C) | 被轉換的浮點數。
例 1 | $U200 = F2D($U10) (F)

■ EXTRACT_BI T→提取位狀態

指令格式 | P1 = EXTRACT_BIT(P2,P3) | 數據類別 | U/UD
功能 | 從 P2 中提取第 P3 位元的狀態，並將運算結果保存到 P1。
P1 (I) | 運算結果。
P2 (I) | 提取位的所在字地址或雙字地址。
P3 (I/C) | 提取的位位址，0-31可以接受，設超過32等於回到位地址0開始算。
例 1 | $U2.0 = EXTRACT_BIT($U10, 31) (UD) /*從雙字$U10中提取第31位元的狀態，並將運算結果保存到$U2.0。*/


15.4.7. 條件運算

條件運算

■ IF ==→P1=P2(等於)條件執行

指令格式 | IF P2 == P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 等於 P3 時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF !=→P1≠P2(不等於)條件執行

指令格式 | IF P2 != P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 不等於 P3 時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF > →P1>P2(大於)條件執行

指令格式 | IF P2 > P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於 P3 時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF >=→P1>=P2(大於,等於)條件執行

指令格式 | IF P2 >= P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於或等於 P3 時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF <→小於條件執行

指令格式 | IF P2 < P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於 P3 時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF <=→小於或等於條件成立時執行

指令格式 | IF P2 <= P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於或等於 P3 時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF &→且條件成立時執行

指令格式 | IF P2 & P3 | 數據類別 | U/UD
功能 | 當 P2 和 P3 相對位元做「且」（AND）邏輯運算結果為非0時，執行 IF 後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF !&→非且條件成立時執行

指令格式 | IF !(P2 & P3) | 數據類別 | U/UD
功能 | 當 P2 和 P3 相對位元做「且」（AND）邏輯運算結果為0時，執行 IF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ IF <bit>→條件成立時執行

指令格式 | IF P2 | 數據類別 | B
功能 | 當判斷條件 P2 成立(1/On)時，執行 IF 語句後的命令。
P2 (I/E/CE) | 判斷條件。

■ IF !<bit>→條件不成立時執行

指令格式 | IF !P2 | 數據類別 | B
功能 | 當判斷條件 P2 不成立(0/Off)時，執行 IF 語句後的命令。
P2 (I/E/CE) | 判斷條件。

■ ELIF ==→等於時執行

指令格式 | ELIF P2 == P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 等於 P3 時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF !=→不等於時執行

指令格式 | ELIF P2 != P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 不等於 P3 時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF >→大於時執行

指令格式 | ELIF P2 > P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於 P3 時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF >=→大於或等於時執行

指令格式 | ELIF P2 >= P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於或等於 P3 時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF <→小於時執行

指令格式 | ELIF P2 < P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於 P3 時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF <=→小於或等於時執行

指令格式 | ELIF P2 <= P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於或等於 P3 時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF &→且條件成立時執行

指令格式 | ELIF P2 & P3 | 數據類別 | U/UD
功能 | 當 P2 和 P3 相對位元做「且」（AND）邏輯運算結果為非0時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF !&→非且 條件成立時執行

指令格式 | ELIF !(P2 & P3) | 數據類別 | U/UD
功能 | 當 P2 和 P3 相對位元做 「且」（AND）邏輯運算結果為0時，執行 ELIF 語句後的命令。
P2,P3 (I/E/C/AE) | 運算元。

■ ELIF <bit> →條件成立時執行

指令格式 | ELIF P2 | 數據類別 | B
功能 | 當判斷條件 P2 成立(1/On)時，執行 ELIF 語句後的命令。
P2 (I/E/CE) | 判斷條件。

■ ELIF !<bit>→條件不成立時執行

指令格式 | ELIF !P2 | 數據類別 | B
功能 | 當判斷條件 P2 不成立(0/Off)時，執行 ELIF 語句後的命令。
P2 (I/E/CE) | 判斷條件。

■ ELSE→前條件不成立時執行

指令格式 | ELSE
功能 | 這個命令所指定的命令語句，要在其前面所有 IF 和 ELIF 條件都不成立的情況下才能被執行。這個命令不可單獨執行。

■ ENDIF→條件結束

指令格式 | ENDIF
功能 | 這個命令用來提示一段以 IF、ELIF、或者ELSE 語句開始命令的結束。這個命令不可單獨執行。
例 IF命令結構
命令與結構 | 描述
IF <condition> … ENDIF | 當條件成立時，執行 IF 與 ENDIF 之間的命令，否則跳過這段命令。
IF <condition> … ELSE … ENDIF | 當條件成立時，執行 IF 與 ELSE 之間的命令，否則執行 ELSE 與 ENDIF 之間的命令
IF <condition> … ELIF <condition_2> … ELIF <condition_3> . . . ELIF <condition_N> … ENDIF | 當條件1成立時，執行 IF 與第1個 ELIF 之間的命令，並跳過餘下所有的命令，否則檢查條件2。當條件2成立時，執行第1個 ELIF 與第2個 ELIF 之間的命令， 並跳過餘下所有的命令，否則檢查條件3。依此類推。若所有條件都不成立，不執行這段語句的所有命令。
IF <condition> … ELIF <condition_2> … ELIF <condition_3> . . ELIF <condition_N> … ELSE … ENDIF | 當條件1成立時，執行 IF 與第1個 ELIF 之間的命令，並跳過餘下所有的命令，否則檢查條件2。當條件2成立時，執行第1個 ELIF 與第2個 ELIF 之間的命令，並跳過餘下所有的命令，否則檢查條件3。依此類推。若所有條件都不成立，執行 ELSE 與 ENDIF 之間的命令。

注意：最多只能嵌套20個IF命令結構


15.4.8. 流程控制

流程控制

■ JMP→無條件跳轉

指令格式 | JMP P1
功能 | 程式無條件跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
例1 | IF $U10 == 0 JMP SKIP /* 跳過命令"$U20 = $U10 / 2". */ ENDIF $U20 = $U10 / 2 SKIP: $U10 = 1

■ <label>→標籤記號字串

指令格式 | P1:
功能 | P1 是標記程式跳轉點位置的標籤記號。這個命令不可單獨執行。
P1 (CS) | 標記程式跳轉點位置的標籤記號，後面必須加上符號“:“。
例 1 | IF $U10 == 0 JMP SKIP /* 跳過命令"$U20 = $U10 / 2" */ ENDIF $U20 = $U10 / 2 SKIP: $U10 = 1

■ JMP ==→等於時跳轉

指令格式 | JMP(P1,P2 == P3) | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 等於 P3 時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號
P2,P3 (I/E/C/AE) | 運算元。

■ JMP !=→不等於時跳轉

指令格式 | JMP(P1,P2 != P3) | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 不等於 P3 時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP >→大於時跳轉

指令格式 | JMP(P1,P2 > P3) | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於 P3 時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP >=→大於或等於時跳轉

指令格式 | JMP(P1,P2 >= P3) | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於或等於 P3 時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP <→小於時跳轉

指令格式 | JMP(P1,P2 < P3) | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於 P3 時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP <=→小於或等於時跳轉

指令格式 | JMP(P1,P2 <= P3) | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於或等於 P3 時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP &→且結果為非0時跳轉

指令格式 | JMP(P1,P2 & P3) | 數據類別 | U/UD
功能 | 當 P2 和 P3 相對位元做「且」（AND）邏輯運算運結果為非0時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP !&→且結果為0時跳轉

指令格式 | JMP(P1,!(P2 & P3)) | 數據類別 | U/UD
功能 | 當 P2 和 P3 相對位元做「且」（AND）邏輯運算結果為0時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/C/AE) | 運算元。

■ JMP <bit>→條件成立時跳轉

指令格式 | JMP(P1,P2) | 數據類別 | B
功能 | 當判斷條件 P2 成立(1/On)時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/CE) | 運算元。

■ JMP !<bit>→條件不成立時跳轉

指令格式 | JMP(P1,!P2) | 數據類別 | B
功能 | 當判斷條件 P2 不成立(0/Off)時，程式跳轉到標籤記號 P1 的地方。
P1 (CS) | 跳轉點的程式標籤記號。
P2,P3 (I/E/CE) | 運算元。

■ CALL→調用子巨集

指令格式 | CALL P1
功能 | 調用子巨集 P1。
P1 (Sub-macro name) | 調用的子巨集名。
例 1 | CALL CommonFunction_01 /* 調用名稱為 CommonFuncation_01 的巨集當作子巨集(Sub-macro)。 */

■ RET→從子巨集回

指令格式 | RET
功能 | 從當前子巨集回到原先的巨集中。這個命令只能用在子巨集中。

■ FOR→迴圈

指令格式 | FOR P2 | 數據類別 | U
功能 | 執行 P2 次 FOR 迴圈的命令。一個 FOR 迴圈是從 FOR 命令開始，NEXT 命令結束。一共可以嵌入20個 FOR ..NEXT迴圈。
P2 (I/C) | 迴圈的全部次數。 注意：如果P2是一個內部變量，P2的值，將每個循環之後被減1;如果P2的值是1，循環將退出之前被執行。
例 1 | FOR 10 $U100 = $U100 + 1 /*這個命令將總共被執行10次 */ FOR 12 $U200 = $U200 + 1 /* 這個命令將總共被執行120次 */ NEXT NEXT
例 2 | $U1 = 10 FOR $U1 $U100 = $U100 + 1 /* 該命令將被執行10次 */ $U2 = 12 FOR $U2 $U200 = $U200 + 1 /* 該命令將被執行120次 */ NEXT NEXT

■ NEXT→迴圈結束

指令格式 | NEXT
功能 | 這個命令用了表示一個FOR迴圈的結束。這個命令不可單獨執行。
例 1 | 例 : $U1 = 10 $U2 = 12 FOR $U1 $U100 = $U100 + 1 /* 這個命令將總共被執行10次 */ FOR $U2 $U200 = $U200 + 1 /* 這個命令將總共被執行120次 */ NEXT NEXT
例 2 | $U1 = 10 $U2 = 12 FOR $U1 $U100 = $U100 + 1 /* 該命令將被執行10次. */ FOR $U2 /* $U2的值在每次循環之後被減1;如果$U2的值是1，循環運行，然後退出循環。 */ $U200 = $U200 + 1 /* 該命令將被執行21次。 */ NEXT NEXT

■ STOP→立即停止

指令格式 | STOP
功能 | 立即停止運行當前巨集。如果這個巨集是在畫面循環巨集，那麼它將會立即停止繼續運行當前巨集，這個巨集只有在其關聯的畫面被再次重新開啟的時後才會從頭開始運行。 如果這個巨集是在主巨集，那麼它將會立即停止繼續運行當前巨集，這個巨集只有在觸控屏的應用程式被重新啟動的時後才會從新從頭開始運行。 注意:這個命令不能使用在子巨集(Sub-macro)中。

■ END→結束

指令格式 | END
功能 | 表示巨集或者當前循環的結束。它可以放在巨集的任何位置，去終止當前巨集的運行。如果這個巨集是一個循環巨集(例如主巨集或是畫面循環巨集)，它可以終止當前的循環程式，並從巨集的第一個指令重新開始新的循環。 這個命令不能被使用在被調用的子巨集(Sub-macro)中。

■ QRET

指令格式 | QRET(P1) | 數據類別 | U
功能 | 判斷條件 P1 是否成立，若條件成立當前記錄則符合查詢條件並結束宏。
P1 (I) | 運行條件。當值等於 1時，符合條件；當值等於0時，則不符合條件。
例 1 | QRET($U100) /*當$U100為1時，當前記錄符合查詢條件。*/


15.4.9. 計時器操作

計時器操作

■ SET_T

指令格式 | SET_T(P1,P2) | 數據類型 | U
功能 | 根據計時控制區 P2 來啟動計時器 P1。
P1 (C) | 計時器編號。總共有8個可用的計時器，它們的編號為0∼7。基於 Windows， WinCE，和 ARM11 CPU的型號有4個擴展計時器，編號為8∼11。
P2 (I) 計時器所使用的計時控制區所佔用的記憶體(位元組陣列)的起始位址。計時控制區的結構如下表所示：
地址 | 數據項目 | 描述
0 | 運行模式 | 0：一次計時； 1：迴圈計時，到時標誌位0、1交替 ; 2: 一次計時並繼續; 3: 迴圈計時且指定位數迴圈左移
1 | 現在值 | 計時器編號為0∼7時，計時器當前值，每100ms加1；計時器編號為8∼11時，計時器當前值，每10ms加1。
2 | 設定值 | 當計時器的當前值等於期限值時，計時器將根據運行模式完成下列操作： 1)當運行模式為0 (一次計時)，到時標誌位設為1，當前值複位為0，並停止計時。 2)當運行模式為1 (迴圈計時)， 到時標誌位0、1交替，當前值複位為0，並重新開始計時。 3)當運行模式為2 (一次計時並繼續)，到時標誌位設為1，當前值會繼續累加，直到當前值達到期限值或65535，計時器停止記時。 4)當運行模式為3 (迴圈計時且指定位數迴圈左移)，到時標誌位0、1交替，當前值複位為0，指定位迴圈左移，並重新開始計時。
3 | 標誌位元 | 當當前值等於期限值時，標誌位被設置為0或者1。
4 | 位數 | 迴圈移位的最大位數，最大值是32。僅在運行模式3(迴圈計時且指定位數迴圈左移)需要該字。 例如:當迴圈移位的最大位數是24時，0∼23位將會被迴圈左移， 而25∼31位保持不變。每次迴圈位0∼位22都依次向左移動一位，第23位移動到第0位。
5 | 0∼15位 | 該字包含迴圈移位操作中的0∼15位。僅在運行模式3(迴圈計時且指定位數迴圈左移)需要該字。
6 | 16∼31位 | 該字包含迴圈移位操作中的16∼31位。僅在運行模式3(迴圈計時且指定位數迴圈左移)需要該字。
計時器的運行需要單獨使用計時器控制區，所以請不要使用控制區中的任何字塊作為他用。
 一個計時器控制 區可能需要4個字 或6個字或7個字的空間大小。
例 1 $U100 = 1 /*運行模式為迴圈計時。 */
$U101 = 0 /* 初始化現在值為0。 */
$U102 = 5 /* 計時時間設定為0.5秒(5*100毫秒)*/
$U103 = 0 /* 初始化標誌位元0。*/
SET_T(3, $U100) /* 使用3號計時器讓$U103.0產生1Hz的方波。*/

■ STOP_T →停止計時器

指令格式 | STOP_T(P1) | 数据类别 | U
功能 | 停止計時器 P1 的運行。
P1 (C) | 計時器編號。
例 1 | STOP_T(1) /* Stop timer #1 停止1號計時器運行*/

■ WAIT_T

指令格式 | WAIT_T(P1) | 数据类别 | U
Function 功能 | 等待計時器 P1 計時完成。在計時完成之前這個巨集指令之後的指令將不會執行。
P1 (C) | The ID of the timer.計時器編號。
例1 | $U100 = 0 /* 運行模式為一次計時。*/ $U101 = 0 /*初始化現在值為0。 */ $U102 = 5 /* 計時時間設定為0.5秒(5*100毫秒)。*/ $U103 = 0 /* 初始化標誌位元0。*/ SET_T(7, $U100) /* 啟動7號計時器進行一個0.5秒的計時。*/ WAIT_T(7) /*等待0.5秒*/


15.4.10. 鍵盤操作

鍵盤操作

■ KB_MCR→接收或忽略當前鍵盤輸入

指令格式 | KB_MCR(P1) | 數據類型 | U
功能 | 接收或忽略當前鍵盤輸入的字元/指令。這個命令只能使用在鍵盤按鈕的巨集中。當指定鍵盤按鈕被按下時，執行該巨集。你可以使用這個鍵盤按鈕巨集的指令來選擇或忽略這個當前按鈕的輸入。
P1 (I/C) | 用來決定是否接收當前輸入的指示值或該指示值的位址。當這個值等於0時，接收當前輸入；非0則表示將忽略，不接受當前輸入。
例1 | KB_MCR(1) /*忽略當前輸入。 */

■ KPD_TEXT→初始化鍵盤

指令格式 | KPD_TEXT(P1) | 數據類型 | U
功能 | 初始化鍵盤顯示器，並將字串 P1 存入緩存。
P1 (I) | 包含一個零結束字元ASCII碼字串的記憶區(或位元組陣列)，用來初始化鍵盤顯示器和緩存。
例1 $U100 = "initial text"
KPD_TEXT($U100) /* 初始化鍵盤顯示器，並將字串"initial text" 存入緩存。*/


15.4.11. 配方操作

配方操作

■ RB2ROM→配方數據保存到快閃記憶體

指令格式 | P1 = RB2ROM(P2 ) | 數據類別 | U
功能 | 將 P2 配方區的數據保存到快閃記憶體，並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；否則操作失敗。
P2 (I/C) | 要被保存配方區的編號。配方屬性中的“需要在快閃記憶體空間中保存數據備份”選項必須要先勾選。
例1 | $U10 = RB2ROM(3) /* 將3號配方區的 數據保存到快閃記憶體。 */

■ ROM2RB→快閃記憶體中的數據讀到配方區

指令格式 | P1 = ROM2RB(P2 ) | 數據類別 | U
功能 | 從快閃記憶體中讀取數據到 P2 配方區，並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；否則操作失敗。
P2 (I/C) | 將快閃記憶體 數據回存到配方區的編號。配方屬性中的“需要在快閃記憶體空間中保存數據備份”選項必須要勾選。
例 1 | $U10 = ROM2RB(3) /*將快閃記憶體內的 數據回存到3號配方區的 數據。 */

■ REF_RCP_OBJ→更新配方物件

指令格式 | REF_RCP_OBJ(P1 ) | 數據類別 | U
功能 | 更新 P1 配方區的關聯配方物件，配方物件包含配方選擇器和配方表。調整配方區數據後，可使用此巨集指令更新關聯配方物件的顯示內容。
P1 (I/C) | 配方區區號。
例1 | REF_RCP_OBJ(3) /*更新3號配方區的關聯配方物件*/


15.4.12. 數據收集器操作

數據收集器操作

■ SAVE2LB→儲存數據至數據搜集器

指令格式 | SAVE2LB(P1, P2, P3) | 數據類別 | U
功能 | 將記憶區 P2 內的 P3 個字的數據保存到數據收集器 P1。
P1 (I/C) | 數據收集器編號。支持 16個數據收集器，編號從0到15。
P2 (I) | 儲存採樣數據的內部記憶區。
P3 (I/C) | 採樣數據的大小。
例 1 | $U103 = 200 /* 設置數據塊大小為100。 */ SAVE2LB(3, $U100, $U103) /* 將從$U100開始的100個字的數據保存到數據收集器3。 */

■ CLR_LB→清除數據搜集器的內容

指令格式 | CLR_LB(P1 ) | 數據類別 | U
功能 | 將記憶區 P2 內的 P3 個字的數據保存到數據收集器 P1。
P1 (I/C) | 清除數據收集器 P1 緩衝區中的數據。
例 1 | CLR_LB(1) /* 清除數據收集器1中的數據。*/

■ REF_H_OBJ→刷新數據收集器所關聯的所有歷史數據顯示物件

指令格式 | REF_H_OBJ(P1,P2 ) | 數據類別 | U
功能 | 當P2條件成立時，刷新數據收集器 P1 所關聯的所有歷史數據顯示物件。
P1 (I/C) | 數據收集器編號。支持 16個數據收集器，編號從0到15。
P2 (I/C) 條件.
值 | 描述
0 | 指定數據收集器中數據發生變化。
1 | 歷史數據顯示物件的數據來源於指定的數據收集器 。
2 | 歷史數據顯示物件的數據來源於指定的檔緩存區。
例 1 $U100 = 1 /* 設置數據收集器編號為1。*/
REF_H_OBJ($U100, 0) /* 當數據收集器1中數據發生變化時，刷新數據收集器1所關聯的所有歷史數據顯示物件。*/


15.4.13. 通訊操作

通訊操作

■ EN_LINK →開啟或斷開通訊連線

指令格式 | EN_LINK(P1,P2,P3) | 數據類別 | U
功能 | 當 P3 等於1時，開啟通訊連線編號 P1 或者是連線編號 P1 的次連線站號 P2 。當 P3 等於0時，斷開指定的通訊連線或者次連線。
P1 (I/C) | 被開啟或斷開的通訊連線編號: Link1, Link2, Link3, 或Link4
P2 (I/C) | 被開啟或斷開的次連線站號。如果指定的通訊連線沒有次連線，這個參數將被忽略。如果指定的通訊連線有次連線，而你想讓它經由畫面的次連線物件來控制其自動開啟或斷開，請將該參數設為0。
P3 (I/C) | 當該參數為1時，開啟指定的通訊連線或次連線；當該參數為0時，斷開指定的通訊連線或次連線。
例 1 | ENABLE_LINK(1, 20, 0) /* 斷開連線編號1的次連線中站號20號的設備的連線。*/

■ LINK_STS →通訊連線狀態

指令格式 | P1 = LINK_STS(P2,P3 ) | 數據類別 | U
功能 | 讀取通訊連線編號 P2 或者通訊連線編號 P2 的站號 P3 的次連線的狀態，並將讀取結果保存到 P1。
P1 (I/C) 所獲取的指定連線或次連線的狀態值。所有狀態以一個16位元的數值來表示其對應的意義如下表所示：

狀態值 | 說明 | 狀態值 | 說明
0 | 正常 | 14 | 設備繁忙
1 | 溢出錯誤 | 15 | 未知錯誤
2 | 中斷錯誤 | 16 | 連接失效
3 | 同位錯誤 | 17 | 初始化失敗
4 | 組幀錯誤 | 18 | 發送 數據失敗
5 | 無回應 | 19 | 發送 數據失敗
6 | 未知的回應 | 20 | 打開連線失敗
7 | 超時 | 21 | 連線沒有準備好
8 | 無效的CTS | 22 | 無效的次連線
9 | 校驗和錯誤 | 23 | 無效的COM Port
10 | 命令被拒絕 | 24 | 出錯
11 | 無效的地址 | 255 | 無法確定狀態
12 | 無效的範圍 | 65535 | 獲取狀態失敗
13 | 無效的請求 |  |
P2 (I/C) | 被開啟或斷開的通訊連線編號。
P3 (I/C) | 被開啟或斷開的通訊次連線站號。如果指定的通訊連線沒有次連線，這個參數將被忽略。
例1 | $U100 = LINK_STS(2, 0) /* 獲取連線編號2的狀態，並將結果保存到$U100。*/
例2 | $U12 = LINK_STS(1, 128) /* 獲取連線編號1的次連線站號128的設備的連線狀態，並將結果保存到$U12。 */

■ LINK_PAR →獲取和設置乙太網連線和次連線的三個通信參數。

指令格式 | LINK_PAR(P1,P2,P3,P4) | 數據類別 | U
功能 | 允許您獲取和設置乙太網連線和次連線的三個通信參數。
P1 (I/C) 操作設置。
操作 | 狀態值
獲取參數 | 0
設置參數 | 1
P2 (I/C) | 通訊連接編號，例如，第一個連接的編號是1，注意連接種類必須是乙太網連接，否則操作失敗。
P3 (I/C) | 次連接編號，如果指定的通訊連接有次連接，該參數可以忽略。
P4 (I) 保存通訊參數記憶體區塊的起始地址。 記憶體區分佈見下表：
字編號 | 說明
0 | 命令延遲，單位是1毫秒。
1 | 超時時間，單位是0.1秒。
2,3 | IP地址，該雙字的4個字節分別存放IP地址的4個號碼。
 | 字節 |  | 內容
 | 第3個字的高位字節 |  | 第一個號碼
 | 第3個字的低位字節 |  | 第二個號碼
 | 第2個字的高位字節 |  | 第三個號碼
 | 第2個字的低位字節 |  | 第四個號碼
 | [範例] 下表舉例說明了如何將IP地址為 '192.168.1.100' 存入以$U100開始的記憶體區。
 | 字節 | 數值 |  | 說明
 | $U103 的高位字節 | C0H (192) |  | 字$U103的值是C0A8H
 | $U103 的低位字節 | A8H (168) |  |
 | $U102 的高位字節 | 01H (1) |  | 字$U102的值是0164H
 | $U102 的低位字節 | 64H (100) |  |
 | [注意] 你可以使用數值輸入器顯示和輸入IP地址。 在設定數值輸入器顯示IP地址時，請選擇32位元正整數作為資料類型，選擇IP地址作為顯示類型。
4 | IP埠號(Port)。
5 | 保留
6 | 保留
7 | 保留

例 1 | LINK_PAR(0, 1, 2, $U100) /* 獲取連接1中次連接為2的通訊參數並保存到$U100開始的記憶體區。 */
例 2 $U200 = 10 (U) /* 設定命令延遲為10毫秒 */
$U201 = 1 (U) /* 設定超時時間為0.1秒 */
$U202 = C0A80164H (UD) /* 設定IP地址為192.168.1.100 */
$U204 = 2000 (U) /* 設定IP埠為2000 */
 LINK_PAR(1, 2, 0, $U200) /* 使用保存在由$U200開始的記憶體區內的資料設定連接2的通訊參數。 */


15.4.14. 系統服務

系統服務

■ GET_RTC→讀取萬年曆時間

指令格式 | GET_RTC(P1 ) | 數據類別 | U
功能 | 讀取當前觸控屏萬年曆時間(RTC)，並將所獲取的時間保存到 P1。
P1 (I) 將所讀取的RTC萬年曆時間 數據存入此一記憶區起始位址。一個RTC數據塊需要8個字的空間大小。RTC數據塊的結構如下表所示：
數據項目 | 數據類型/長度 | 地址範圍
秒 | 16位不帶正負號的整數 | 0
分 | 16位不帶正負號的整數 | 1
時 | 16位不帶正負號的整數 | 2
RTC 精度調整 | 16位元有符號整數 | 3
日 | 16位不帶正負號的整數 | 4
月 | 16位不帶正負號的整數 | 5
年 | 16位不帶正負號的整數 | 6
星期 | 位不帶正負號的整數 | 7
秒: 0~59; 分: 0~59; 時: 0~23; RTC精度調整: -63~63; 日: 1~31; 月: 1~12; 年: 0(2000)~99(2099); 星期: 0(星期日)~6(星期六)
例 1 | GET_RTC($U100) /*讀取當前萬年曆時間。秒被保存到$U100，而星期被保存到$U107。*/

■ SET_RTC→設置萬年曆時間

指令格式 | SET_RTC(P1 ) | 數據類別 | U
功能 | 將 P1 內的時間數據設置為觸控屏的萬年曆時間(RTC)。
P1 (I) | 用來設置RTC萬年曆時間 數據塊的記憶區起始位址。RTC數據塊的結構詳見GET_RTC 說明。
例1 | $U100 = 0 // 秒 $U101 = 30 // 分 $U102 = 8 // 時 $U103 = 0 // 精度調整 $U104 = 1 // 日 $U105 = 7 // 七月 $U106 = 10 // 年 2010 $U107 = 4 // 星期四 SET_RTC($U100) /* Thursday 將2010年7月1日 8:30:00 星期四設置為當前即時時間。*/

■ SYS →系統服務

指令格式 | SYS(P1,P2,P3) | 數據類別 | U
功能 | 根據參數 P2 和 P3 請求系統服務 P1。注意:這個指令是留給系統使用的。
P1 (I) | 系統服務代碼。
P2,P3 (I/C) | 系統服務參數。
例 1 | SYS(0x6630, 0, 0) /* 重新運行應用程式 */
例 2 | SYS(0x6631, 0, 0) /* 運行人機應用*/
例 3 | 根據給定的乾球溫度和露點溫度計算相對濕度。詳細資訊參見 15.4.14.1 計算相對濕度。
 | $U200 = 70 (F) // 設定乾球溫度計的攝氏溫度 $U202 = 65 (F) // 設定露點溫度計的攝氏溫度 SYS(31,1,$U200) // 計算相對濕度 // 保存在$U204和$U205內的結果應該是80.2547

■ SetBacklight→開關背燈

指令格式 SetBacklight(P1) 數據類別 U
功能
開關LCD背燈。
P1 (I/C) 設定背燈的切換操作。
P1 | 操作
0 | 關閉背燈。
1 | 打開背燈
例
SetBacklight(0) /* 關閉背燈。 */

■ SetScreenSaver→設定螢幕保護的等待時間

指令格式 | SetScreenSaver(P1) | 數據類別 | U
功能 | 設定螢幕保護的等待時間。
P1 (I/C) | 指定等待時間。時間的單位是分。當等待時間為0時，不使用螢幕保護功能。
例 | SetScreenSaver(20) /* 設定螢幕保護的等待時間為20分鐘。*/

■ SetIdleProc→設定閒置處理的屬性

指令格式 | SetIdleProc(P1,P2) | 數據類別 | U
功能
設定閒置處理的屬性。
P1 (I/C) 設定操作。
P1 | 操作
0 | 將所有屬性恢復為原始設置。
1 | 設定閒置時間。
2 | 設定閒置畫面。
3 | 設定用戶等級
P2 (I/C) 設定相關操作的屬性
P1 | P2
0 | 0
1 | 指定閒置時間。時間的單位是分。當閒置時間為0時，不使用閒置處理功能。
2 | 指定作為閒置畫面的畫面編號。當進入閒置模式時，人機將顯示閒置畫面。
3 | 指定用戶等級，當進入閒置模式時，人機將當前的用戶等級變為所設定的用戶等級。有效的用戶等級為0-8。如果不需要改變用戶等級，將P2 設為255。
例 | SetIdleProc(2, 10) /* 當進入閒置模式時，人機將顯示畫面編號為10的畫面。 */

■ GetID→獲得觸摸屏的識別碼

指令格式 | P1 = GetID(P2) | 數據類別 | U
功能 | 獲得類型由P2指定的觸摸屏的識別碼，並將結果保存到起始位址為P1 的記憶區中。
P1 (I) 用來存儲識別碼的記憶區起始位址。

觸摸屏的產品序列號與觸摸屏上乙太網口的MAC地址都可做為觸摸屏的識別碼。這兩種識別碼需要不同大小的記憶區。產品序列號需要7個字的空間，因為序列號是由14個字元組成的字串。MAC位元元元址則需要6個字的空間，因為這個地址是由6個數字組成的。
P2 (I/C) 識別碼的類型。

下表描述的是類型編號和支持的觸摸屏型號:

類型編號 | 標示符的類型 | 支持的型號
0 | 產品序列號 | T系列觸摸屏
1 | 第一個乙太網口的MAC位址 | T系列觸摸屏; 圖控軟體
2 | 第二個乙太網口的MAC位址 | 圖控軟體
例 $U100 = GetID(0) /* 取得觸摸屏的序列號，將結果保存到$U100-$U106*/
$U110 = “07WT4DX1130118”
$U120 = STRNCMP($U100, $U110, 14) /* 如果序列號是07WT4DX1130118，就將$U120設為0*/

■ SetBrightness→設置亮度

指令格式 | SetBrightness(P1 ) | 數據類別 | U
功能 | 設定LCD的亮度。
P1 (I/C) | 指定的亮度等級。一個有效的等級是0到15之間。級別0是最暗和15級是最亮的。

■ SetBriRange→設定LCD背光亮度的可調範圍

指令格式 | SetBriRange(P1,P2) | 數據類別 | U
功能 | 設定LCD背光亮度的可調範圍。 可調範圍是由最暗百分比(P1) 和最亮百分比(P2) 兩個數值決定。
P1 (I/C) | 指定最暗百分比。最暗百分比是調整到最暗時的亮度相對于全亮的百分比。有效值為0-99, 且必須小於最亮百分比。
P2 (I/C) | 指定最亮百分比。最亮百分比則是調整到最亮時的亮度相對于全亮的百分比。有效值為1-100, 且必須大於最暗百分比。
例 | SetBriRange(10, 85) /* 最暗百分比和最亮百分比分別為10與85, 則可調範圍在全亮的10%與85%之間。 */


15.4.14.1. 計算相對濕度

計算相對濕度

通過巨集指令SYS和服務代碼31可以進行下面的四種運算：

1. 根據給定的乾球溫度和露點溫度計算相對濕度。

2. 根據給定的乾球溫度和濕球溫度計算相對濕度。

3. 根據給定的相對濕度和乾球溫度計算露點溫度。

4. 根據給定的相對濕度和乾球溫度計算濕球溫度。

所有的計算都是基於由Hyland和韋克斯勒定義的蒸氣壓力計算公式。

1. 根據給定的乾球溫度和露點溫度計算相對濕度，使用下面的一個巨集指令：

SYS(31, 1, P3) 或 SYS(31,2,P3)

參數：

P1 (I/C) | 系統服務代碼。必須是31。
P2 (I/C) | 操作代碼
 | 操作代碼 | 描述
 | 1 | 攝氏溫度
 | 2 | 華氏溫度
P3 (I) | 用來儲存溫度和結果的記憶區。給定的溫度和結果都是32位的浮點數，因此記憶區需要六個字的長度。下表是記憶區得相關設置
 | 字序號 | 描述
 | 0,1 | 給定的乾球溫度
 | 2,3 | 露點溫度
 | 4,5 | 計算出的相對濕度。//註：如果計算失敗，該值為0.
例 | $U200 = 70 (F) // 設置乾球的攝氏溫度 $U202 = 65 (F) // 設置露點的攝氏溫度 SYS(31,1,$U200) // 計算相對濕度 // 計算結果保存在 $U204和 $U205， 結果應該是 80.2547 。

2. 根據給定的乾球溫度和濕球溫度計算相對濕度，使用下面的一個巨集指令：

SYS(31, 3, P3) 或 SYS(31,4,P3)

參數：

P1 (I/C) | 系統服務代碼。必須是31.
P2 (I/C) | 操作代碼
 | 操作代碼 | 描述
 | 3 | 攝氏溫度
 | 4 | 華氏溫度
P3 (I) | 用來儲存溫度和結果的記憶區。給定的溫度和結果都是32位的浮點數，因此記憶區需要六個字的長度。下表是記憶區得相關設置 ：
 | 字序號 | 描述
 | 0,1 | 給定的乾球溫度
 | 2,3 | 給定的濕球溫度
 | 4,5 | 計算出的相對濕度。//註：如果計算失敗，該值為0.
例 | $U500 = 60 (F) // 設置乾球的攝氏溫度 $U502 = 29 (F) // 設置露點的攝氏溫度 SYS(31,3,$U500) // 計算相對濕度 // 計算結果保存在 $U504 和 $U505， 結果應該是 9.4905。

3.根據給定的相對濕度和乾球溫度計算露點溫度。使用下面的一個巨集指令：

SYS(31, 5, P3) 或 SYS(31,6,P3)

參數：

P1 (I/C) | 系統服務代碼。必須是31.
P2 (I/C) | 操作代碼
 | 操作代碼 | 描述
 | 5 | 攝氏溫度
 | 6 | 華氏溫度
P3 (I) | 用來儲存溫度和結果的記憶區。給定的溫度和結果都是32位的浮點數，因此記憶區需要六個字的長度。下表是記憶區得相關設置
 | 字序號 | 描述
 | 0,1 | 給定的相對濕度
 | 2,3 | 給定的乾球溫度
 | 4,5 | 計算出的露點溫度。//註：如果計算失敗，該值為－99990.
例 | $U300 = 80.2547 (F) //設置相對濕度 $U302 = 70 (F) //設置乾球溫度 SYS(31,5,$U300) //計算露點溫度 //計算結果保存在 $U504 和 $U505， 結果應該是 65。

4. 根據給定的相對濕度和乾球溫度計算濕球溫度。使用下面的一個巨集指令：

SYS(31, 7, P3) 或 SYS(31,8,P3)

參數：

P1 (I/C) | 系統服務代碼。必須是31.
P2 (I/C) | 操作代碼
 | 操作代碼 | 描述
 | 7 | 攝氏溫度
 | 8 | 華氏溫度
P3 (I) | 用來儲存溫度和結果的記憶區。給定的溫度和結果都是32位的浮點數，因此記憶區需要六個字的長度。下表是記憶區得相關設置
 | 字序號 | 描述
 | 0,1 | 給定的相對濕度
 | 2,3 | 給定的乾球溫度
 | 4,5 | 計算出的濕球溫度。//註：如果計算失敗，該值為－99990.
例 | $U600 = 9.4905 (F) // 設置相對濕度 $U602 = 60 (F) // 設置乾球溫度 SYS(31,7,$U600) // 計算濕球溫度 // 計算結果保存在 $U604 和 $U605， 結果應該是 29。


15.4.15. 畫面操作

畫面操作

■ OPEN_WS→打開視窗畫面

指令格式 | OPEN_WS P1 | 數據類別 | U
功能 | 需要被打開的視窗畫面編號。如果給予的畫面號碼是一個普通畫面或菜單畫面，而不是視窗畫面時，畫面將不會被打開。 當使用這個指令開啟一個視窗畫面後，這時候這個主畫面就不能被換畫面按鈕或以任何方式關閉或切換畫面了，必須等到這個視窗畫面被關閉後才能操作該主畫面，而且當此一指令被執行了，在巨集內其下面的指令將不會被執行，只有在被打開的視窗畫面關閉後，本指令之後的其他指令才會被繼續執行。
P1 (I/C) | 需要被打開的視窗畫面編號。如果給予的畫面號碼是一個普通畫面或菜單畫面，而不是視窗畫面時，畫面將不會被打開。

■ CLOSE_WS→關閉視窗畫面

指令格式 | CLOSE_WS
功能 | 關閉由巨集指令OPEN_WS所打開的視窗畫面。

■ InitWndPos→設置指定窗口畫面的初始位置

指令格式 | InitWndPos( P1,P2,P3) | 數據類別 | U
功能 | 設置指定視窗畫面的初始位置。視窗畫面將在打開時顯示在指定的位置。
P1 (I/C) | 設定視窗畫面的畫面編號。
P2 (I/C) | 設定視窗畫面位置的X座標，如果需要居中顯示視窗畫面，將P2 設為65535。
P3 (I/C) | 設定視窗畫面位置的Y座標。
例 | InitWndPos(10, 120, 100) /* 畫面編號為10的視窗畫面打開時顯示在(120, 100)位置。*/

■ OpenScreen→打開畫面

指令格式 | OpenScreen( P1,P2,P3) | 數據類別 | U
功能 | 在指定的位置 (P2, P3)處打開畫面編號為 P1 的畫面。
P1 (I) 要打開畫面的畫面編號。

這個命令可以打開任意類型的畫面。如果指定的畫面是普通畫面，則本命令會關閉當前的普通畫面然後打開指定的畫面。如果被指定的畫面是功能表畫面，這個畫面會從指定位置向下移出。如果指定的畫面不存在或已經打開則本操作取消。
P2 (I) 畫面左上角的X座標要放置的位置。

如果要打開的畫面是普通畫面這個參數就被忽略，因為普通畫面永遠都在(0, 0)位置顯示。如果此座標值使畫面的右側不可見，此指令將向左移動此畫面，使整個畫面可見。

如果想讓此畫面打開後在螢幕上居中顯示，要將P2 設成 65535 (0xffff)。
P3 (I/C) 畫面左上角的Y座標要放置的位置。

如果要打開的畫面是普通畫面或 P2 的值是65535 (0xffff)這個參數就被忽略。如果此座標值使畫面的下側不可見，此命令將向上移動此畫面，使整個畫面可見。
例 OpenScreen(10, 0, 0) /* 打開畫面編號為10的普通畫面 */

OpenScreen(35, 120, 200)/* 在 (120, 200)處打開畫面編號為35的視窗畫面*/
OpenScreen($U50, 65535, 0)/* 居中打開畫面編號由內部變數$U50 指定的視窗畫面*/

■ CloseScreen→關閉指定的窗口畫面或菜單畫面

指令格式 | CloseScreen(P1) | 數據類別 | U
功能 | 關閉由P1 指定的視窗畫面或功能表畫面。
P1 (I/C) | 要被關閉的視窗畫面或功能表畫面的編號。
例 | CloseScreen(27) /*關閉畫面編號為27的視窗畫面 */


15.4.16. 檔案操作

檔案操作

■ FILE_IO→保存檔案

指令格式 | P1 = FILE_IO(P2,P3 ) | 數據類別 | U
功能 | 根據 P2 和 P3 所指定的形式以默認檔案名保存檔案，並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2,P3 (I/C)

P2 指定操作類型。 P3 指定數據來源的編號。具體 P2 和 P3 設置如下表所示：

檔案操作 | P2 | P3 | 默認檔案名格式
保存歷史數據 (.txt) | 1 | 數據收集器編號 ID (0-15) | DL<ID>_<Date>_<Time>.txt
保存歷史數據 (.csv) | 14 |  | DL<ID>_<Date>_<Time>.csv
保存歷史警報 (.txt) | 2 | 0 | AL_<Date>_<Time>.txt
保存歷史警報 (.csv) | 15 |  | AL_<Date>_<Time>.csv
保存警報計數 (.txt) | 3 | 0 | AC_<Date>_<Time>.txt
保存警報計數 (.csv) | 16 |  | AC_<Date>_<Time>.csv
保存配方數據 (.txt) | 4 | 配方編號(0-15) | RB<ID>.txt
保存配方數據 (.csv) | 17 |  | RB<ID>.csv
保存配方數據 (.prd) | 5 |  | RB<ID>.prd
獲取配方數據 (.csv) | 19 |  | RB<ID>.csv
獲取配方數據 (.txt) | 20 |  | RB<ID>.txt
獲取配方數據 (.prd) | 21 |  | RB<ID>.prd
保存畫面為圖片 (256-color .bmp) | 6 | 畫面編號(1-7999) | S<ID>_<Date>_<Time>.bmp
保存畫面為圖片 (64K-color .bmp) | 7 |  | S<ID>_<Date>_<Time>.bmp
保存操作記錄 (.txt) | 9 | 0 | OL_<Date>_<Time>.txt
保存操作記錄 (.csv) | 18 | 0 | OL_<Date>_<Time>.csv
保存歷史數據 (.ldf) | 10 | 數據收集器編號 ID (0-15) | DL<ID>_<Date>_<Time>.ldf
獲取攝像頭圖像 (.bmp) | 12 | 攝像頭編號 ID (0-3) | CAM<ID>_<Date>_<Time>.bmp
獲取攝像頭圖像 (.jpg) | 13 |  | CAM<ID>_<Date>_<Time>.jpg
保存畫面為圖片 (.jpg) | 22 | 畫面編號(1-7999) | S<ID>_<Date>_<Time>.jpg
獲取視頻圖像 (.jpg) | 23 | 視頻編號(1-2) | V<ID>_<Date>_<Time>.jpg

注意:

<ID>:數據記錄器，配方区，USB攝像頭的ID，或者螢幕的數量，身份證號。

<Date>: 數據保存的日期。 <Time>: 數據保存的時間。

你可以在 General Setup 對話方塊內的“客制頁面”自訂 <Date> 和 <Time>的格式。

你可以選擇不顯示進度條在執行巨集命令時。要隱藏進度條，使用正常的操作代碼加100。例如，要保存記錄的數據到CSV檔而不顯示進度條，用它代替14碼114（100+14）。

■ FILE_IO_N→另存新檔案

指令格式 | P1 = FILE_IO_N(P2,P3,P4) | 數據類別 | U
功能 | 根據 P2 和 P3 所指定的形式保存檔案，並以 P4 為檔案名。執行後並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2,P3 (I/C)

P2 指定操作檔案類型。 P3 指定數據來源的編號。具體 P2 和 P3 設置如下表所示：

檔案操作 | P2 | P3
保存歷史數據 (.csv/.txt) | 31 | 數據收集器編號 (0-15)
保存歷史警報 (.txt) | 32 | 0
保存警報計數(.txt) | 33 | 0
保存配方數據 (.csv/.txt) | 34 | 配方編號 (0-15)
保存配方數據 (.prd) | 35 | 配方編號 (0-15)
保存畫面為圖片 (256-color .bmp) | 36 | 畫面編號 (1-7999)
保存畫面為圖片 (64K-color .bmp) | 37 | 畫面編號 (1-7999)
保存操作記錄 (.txt) | 39 | 0
保存歷史數據 (.ldf) | 40 | 畫面編號 (0-15)
獲取攝像頭圖像 (.bmp) | 42 | 攝像頭編號 (0-3)
獲取攝像頭圖像 (.jpg) | 43 | 攝像頭編號 (0-3)
保存畫面為圖片 (.jpg) | 52 | 畫面編號 (1-7999)
獲取視頻圖像 (.jpg) | 53 | 視頻編號 (1-2)
獲取歷史數據（CSV/TXT格式） | 231 | 數據收集器編號(0~15)
獲取歷史報警 | 232 | 0
記錄 | 239 | 0

 注意: 當該巨集指令運行的時候你可以選擇隱藏進度條。請使用正常的操作碼加 100來隱藏進度條。例如，保存歷史數據到CSV檔而不顯示進度條，使用代碼131(100 + 31)而不是31。
P4 (I) | 用來儲存自訂的檔案名或完整的路徑的位元組陣列。檔案名及路徑只能是由ASCII碼組成的Windows有效路徑。這個字串必須含零結束字元，每個字元佔用一個位元組。它的最大長度為127個位元組。所有檔案的路徑必須已經存在(例如USB隨身碟或SD卡)，否則操作將會失敗。

■ MKDIR→創建一個目錄

指令格式 | P1 = MKDIR(P2 )
功能 | 根據 P2 所指定的名稱創建一個目錄。並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2 (I) | 這個位元組(Byte)陣列包含了新目錄的名稱。這個名稱必須是一個有效的目錄名，包不包含路徑均可，它只能由ASCII碼字元組成。

■ OPEN_FILE→新建或打開檔案

指令格式 | P1 = OPEN_FILE(P2,P3 ) | 數據類別 | U
功能 | 新建或打開一個檔案。
P1 (I)

用來存儲接收到的檔案訊息塊的記憶區起始位址。

檔案訊息塊的數據結構如下表所示：
數據項目 | 數據類型 | 數據類型
檔案指揮代碼 | 32位不帶正負號的整數 | 0 和 1
文件大小 | 32位不帶正負號的整數 | 2 和 3
文件大小 | 81個元素的位元元元元元組陣列 | 4 到 44

當執行失敗時，檔案指揮代碼等於零。當執行成功時此代碼由系統自動產生一組非0的32位不帶正負號的整數。

一個新創建的檔其文件大小等於零。

檔案名稱是一個包含零結束字元的字串。它的最大允許範圍是80字。它在檔被成功打開時被賦值。

一個檔案訊息塊一共需要45個字的記憶體空間。
P2 (I) | 這個位元組陣列包含要被打開的檔案名，包不包含路徑均可，它只能由ASCII碼字元組成，並包含一個零結束字元。
P3 (I/C)

指定檔案打開方式

打開方式 | 打開方式
讀 | 0
寫 | 1
添加 | 3
讀CSV 檔案 | 5
例1 $U10 = “test.txt”
$U100 = OPEN_FILE($U10, 0) /* 以唯讀方式打開檔案 “test.txt” 。其中雙字$100 存儲檔案控制代碼，雙字$102存儲檔案大小，位元組陣列$104~$109存儲檔案名。*/

■ READ_FILE →讀檔案的數據

指令格式 | P1 = READ_FILE(P2,P3,P4 ) | 數據類別 | U
功能 | 從檔案 P2 讀取 P4 個位元組到內存記憶體 P3，並將運行結果保存到 P1。
P1 (I) | 實際讀取到的位元組數。如果操作失敗，這個數字是 65535(0xFFFF)
P2 (I) | 被讀文件的檔案指揮代碼。檔案指揮代碼(File handle)是類似C語言的檔案使用方式。檔案指揮代碼是由系統執行OPEN_FILE自動產生的；可以參考OPEN_FILE的說明。
P3 (I) | 存放從檔案讀取到的數據到此一記憶體首地址。
P4 (I/C) | 要讀取檔案的位元組數。你可以設定的最大值是32767(0x7FFF)。
例1 | $U200 = READ_FILE($U100,$U150,20) /* 從$U100所指定檔案控制代碼的檔案中讀取20個位元組，並將所讀取的 數據保存到以$U150為起始位址的記憶體中。*/

■ WRITE_FILE→將數據寫入檔案

指令格式 | P1 = WRITE_FILE(P2,P3,P4 ) | 數據類別 | U
功能 | 將數據地址 P3 開始一共 P4 個位元組寫入檔案 P2 中，並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2 (I) | 文件的檔案指揮代碼。檔案指揮代碼(File handle)是類似C語言的檔案使用方式。檔案指揮代碼是由系統執行OPEN_FILE自動產生的；可以參考OPEN_FILE的說明。
P3 (I) | 源 數據記憶體首地址，源數據是指要被寫入檔案的數據(位元組陣列)。
P4 (I/C) | 要被寫入的位元組數。
例1 | $U200=WRITE_FILE($U100,$U150,30) /* 將 數據記憶區$U150開始的30個位元組的 數據寫入由$U100所指定的檔中。*/

■ CLOSE_FILE→關閉已打開的檔案

指令格式 | P1 = CLOSE_FILE(P2,P3 ) | 數據類別 | U
功能 | 關閉一個已打開的檔案 P2，並將完成代碼保存到 P1。
P1 (I) | 運行後完成產生的代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2 (I) | 被關閉文件的檔案名。
例1 | $U200=CLOSE_FILE($U100) /* 關閉由$U100指定檔名的檔案。*/

■ DELETE_FILE→刪除檔案

指令格式 | P1 = DELETE_FILE(P2 ) | 數據類別 | U
功能 | 刪除一個檔名為 P2 的檔案，並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2 (I) | 要被刪除的檔案名或是含完整路徑的位元元元元組文字數據（陣列）。這個位元組（陣列）必須是ASCII字串且包含零結束字元。
例1 | $U10 = “test.txt” $U200 = DELETE_FILE($U10) /* Delete the file “test.txt”. 刪除檔 “test.txt*/

■ RENAME_FILE→重新命名檔案

指令格式 | P1 = RENAME_FILE(P2,P3 ) | 數據類別 | U
功能 | 使用新名稱 P3 來重新命名檔案 P2，並將完成代碼保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2 (I) | 這個位元組陣列包含了要被重新命名的原檔案名，包不包含路徑均可，它只能由ASCII碼字元組成，並包含一個零結束字元。
P3 (I) | 這個位元組陣列包含了新檔案名。它只能由ASCII字元組成，並包含一個零結束字元。
例1 | $U10 = “test.txt” $U50 = “new.txt” $U200 = RENAME_FILE($U10, $U50) /* 將文件 “test.txt” 重新命名為 “new.txt”。*/

■ COPY_FILE →複製檔 案

指令格式 | P1 = COPY_FILE(P2,P3 ) | 數據類別 | U
功能 | 複製檔P2到新文件P3，並將完成代碼保存到P1。
P1 (I) | 運行後完成產生的代碼。如果這個代碼等於0，表示操作成功；否則操作失敗。 注意: 這個指令只能使用在主巨集，事件巨集，時間巨集，以及迴圈巨集中。
P2 (I) | 這個位元組陣列包含了被複製的檔案名或完整路徑。它只能是由ASCII字元組成，並包含一個零結束符。
P3 (I) | 這個位元組陣列包含了新檔的檔案名或完整路徑。它只能是由ASCII字元組成，並包含一個零終止符。
例1 | $U10 = “c:\abc.txt” $U50 = “d:\new.txt” $U200 = COPY_FILE($U10, $U50) /* 複製檔 C:\abc.txt 到新文件 D:\new.txt */

■ GET_VOL_INFO →讀取的標籤資訊

指令格式 | P1 = GET_VOL_INFO(P2,P3 ) | 數據類別 | U
功能 | 讀取標籤 P2 的資訊，並將所獲取的標籤資訊保存到 P3。而完成代碼則保存到 P1。
P1 (I) | 運行後產生的完成代碼。如果這個代碼等於0，表示操作成功；不等於0表示操作失敗。
P2 (I/C)

驅動器編號

ID | 驅動器
0 | 當前驅動器 (內建快閃記憶體)
3 | 驅動器C (USB存儲盤或SD卡)
4 | 驅動器D (USB存儲盤或SD卡)
5 | 驅動器E (USB存儲盤或SD卡)
P3 (I) 執行讀取標籤資訊指令後將所得到的標籤區塊儲存到這個起始位址。標籤區塊的結構如下所示：
數據項目 | 數據類型/大小 | 地址範圍
標籤名 | Byte array with 32 elements 32個元素的位元元元元元組陣列 | 0 到 15
標籤大小 | 32-bit Unsigned Integer 32位不帶正負號的整數 | 16 和 17
可用空間大小 | 32-bit Unsigned Integer 32位不帶正負號的整數 | 18 和 19
驅動器編號 | 16-bit Unsigned Integer 16位不帶正負號的整數 | 20

標籤名是一個帶零結束字元的字串。它的最大允許範圍是31個字元。

標籤大小和可用空間大小都是2個字。

一個標籤區塊需要21個字的記憶體空間大小。
例1 | $U100 = GET_VOL_INFO(0, $U0) /*獲取當前標籤資訊。標籤名儲存到$U0~$U15中；驅動器大小儲存到$U16~$U17；驅動器可用空間大小儲存到$U18~$U19；當前驅動器編號儲存到$U20。*/

■ READ_CSV→讀取CSV檔案

指令格式 | P1 = READ_CSV(P2,P3,P4 ) | 數據類別 | S/U/SD/UD/F
功能 | 讀CSV檔案 P2 中位置在 P3 行 P4 列的欄位並將讀取的數值存到 P1。
P1（I） | 存放讀取結果的字位置。替這個命令選取的數據類別必須與要讀取欄位的數據類別一致，否則可能造成執行失敗。若執行失敗，如數據類別不對或欄位不存在，則都不會寫值到 P1。要知道執行是否失敗，須檢查字$S522。當字$S522的值不為0，就表示執行失敗。
P2（I） | 被讀CSV檔案的檔案指揮代碼。指揮代碼是執行OPEN_FILE產生的。被讀檔案必須是一個CSV檔案，並且是以"讀CSV檔案"方式打開。分隔字元必須是TAB。
P3（I/C） | 被讀欄位的行數。行數從0開始算起。
P4（I/C） | 被讀欄位的列數。列數從0開始算起。
例1 $U10 = "test.csv"
$U100 = OPEN_FILE($U10,5) /*以"讀取CSV檔案"方式打開檔案"test.csv*/
$U200 = READ_CSV($U100,2,3) (F) /* 從行2列3欄位讀取一個浮點數並存放結果到字$U200及$U201*/

■ READ_CSV_STR→讀取CSV字串

指令格式 | P1 = READ_CSV_STR (P2,P3,P4 )
功能 | 讀CSV檔案 P2 中位置在 P3 行 P4 列的欄位並將讀取的字串存到 P1。
P1（I） | 存放讀取結果的位元組陣列位置。這個命令可讀取字串的最大長度是128。如果被讀字串長度超過128，則會造成執行失敗。若執行失敗，如字串太長或欄位不存在，則都不會寫值到 P1。要知道執行是否失敗，須檢查字$S522。當字$S522的值不為0，就表示執行失敗。
P2（I） | 被讀CSV檔案的檔案指揮代碼。指揮代碼是執行OPEN_FILE產生的。被讀檔案必須是一個CSV檔案，並且是以"讀CSV檔案"方式打開。分隔字元必須是TAB。
P3（I/C） | 被讀欄位的行數。行數從0開始算起。
P4（I/C） | 被讀欄位的列數。列數從0開始算起。
例1 $U10 = "test.csv"
$U100 = OPEN_FILE($U10,5) /* 以"讀取CSV檔案"方式打開檔案"test.csv"*/
$U200 = READ_CSV_STR($U100,2,4) /*從行2列6欄位讀取一個字串並存放結果到啟始位置在$U200的位元組陣列/


15.4.17. 比較指令

比較指令

■ ==→等於

指令格式 | P1 = P2 == P3 | 數據類別 | U/S/UD/SD/F/B
功能 | 當 P2 等於 P3 時，將位(Bit) P1 置1，否則清0。
P1 (I/E) | 位(Bit)運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例1 | $U3.3 = ($U10 + $U20) == 25.75 (F)

■ !=→不等於

指令格式 | P1 = P2 != P3 | 數據類別 | U/S/UD/SD/F/B
功能 | 當 P2 不等於 P3 時，將位(Bit) P1 置1，否則清0。
P1 (I/E) | 位(Bit)運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例1 | $U3.3 = ($U10 + $U20) != -700 (S)

■ >→大於

指令格式 | P1 = P2 > P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於 P3 時，將位(Bit) P1 置1，否則清0。
P1 (I/E) | 位(Bit)運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例1 | $U3.3 = ($U10 + $U20) > $U30 (UD)

■ >=→大於或等於

指令格式 | P1 = P2 >= P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 大於或等於 P3 時，將位(Bit) P1 置1，否則清0。
P1 (I/E) | 位(Bit)運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例1 | $U3.3 = ($U10 + $U20) >= 25.75 (F)

■ <→小於

指令格式 | P1 = P2 < P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於 P3 時，將位(Bit) P1 置1，否則清0。
P1 (I/E) | 位(Bit)運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例1 | $U3.3 = ($U10 + $U20) < 25.75 (F)

■ <= →小於或等於

指令格式 | P1 = P2 <= P3 | 數據類別 | U/S/UD/SD/F
功能 | 當 P2 小於或等於 P3 時，將位(Bit) P1 置1，否則清0。
P1 (I/E) | 位(Bit)運算結果。
P2,P3 (I/E/C/AE) | 運算元。
例1 | $U3.3 = ($U10 + $U20) <= 25.75 (F)


15.4.18. 列印操作

列印操作

■ PRINT→列印

指令格式 | P1 = PRINT(P2,P3 ) | 數據類別 | U
功能 | 將 P2 的 數據依 P3 所指定的位元組個數輸出到印表機通訊介面，並將完成代碼保存到 P1。
P1 (I)

運行後產生的完成代碼。代碼描述見下表。

代碼 | 描述
0 | 成功
1 | 印表機沒有準備好
3 | 系統錯誤
4 | 印表機正忙
7 | 未指定印表機
P2 (I) | 來源數據記憶體首位址，來源數據是指要被輸出的數據(位元組陣列)。注意如果要列印中文字需要先確認該台印表機是否內建中文字集庫。
P3 (I/C) | 要被輸出到印表機的位元組數。
例 1 $U10 = "This is a test."
$U20 = PRINT($U10, 15) /* 發送This is a test.字串到印表機。*/
$U10 = 10
$U20 = PRINT($U10, 1) /*發送換行字元到印表機。*/
$U10 = 12
$U20 = PRINT($U10, 1) /*發送換頁字元到印表機。 */
例 2 $U10 = 0x401b /* ESC, '@' */
$U20 = PRINT($U10, 2) /* 初始化EPSON 印表機。*/

■ PRINT_SCREEN→列印畫面

指令格式 | P1 = PRINT_SCREEN(P2,P3 ) | 數據類別 | U
功能 | 列印畫面編號 P2 的畫面內容到印表機，並將完成代碼保存到 P1。
P1 (I)

運行後產生的完成代碼。代碼描述見下表。

代碼 | 描述
0 | 操作成功
1 | 印表機沒有準備好
2 | 畫面編號無效
3 | 系統錯誤
4 | 印表機正忙
5 | 系統正忙
6 | 非正當使用該指令(見注)
7 | 未指定印表機

注意：該指令只能用在主巨集，事件巨集，時間巨集和循環巨集中。

P2 (I/C) | 要列印的畫面編號。畫面列印區域的指定是在每一畫面的畫面屬性對話框來設置。
P3 (I/C) | 保留將來擴充功能使用，目前必須為零。
例 1 | $U0 = PRINT_SCREEN(28, 0) /* Print screen #28 列印畫面編號28 的畫面。*/

■ BLANK→清空列印緩衝區

指令格式 | P1 = BLANK (P2) | 數據類別 | U
功能 | 清空列印緩衝區 P1，也就是讓列印緩衝區 P1 僅含有空白字元。
P1 (I) | 要清空的列印緩衝區。列印緩衝區是一個位元組陣列。在列印任何字串到一個列印緩衝區之前，必須將它清空。
P2 (I/C) | 列印緩衝區的長度。長度的單位是位元組。 舉例而言，一個長度為40的列印緩衝區, 是一個含有40 個位元組的陣列，它可以含有40 個英文字元或20 個中文字。
例 1 | BLANK($U100, 80) /* 清空長度為40，位置在$U100的列印緩衝區。 */

■ P2B→列印字串

指令格式 | P1 = P2B (P2,P3 ) | 數據類別 | U
功能 | 列印字串 P1 到列印緩衝區 P2 的位置 P3。
P1 (I) | 要列印的字串。字串是一個位元組陣列。要列印的字串必須是以零結束的字串。
P2 (I) | 要列印的字串。字串是一個位元組陣列。要列印的字串必須是以零結束的字串。
P3 (I/C) | 在列印緩衝區中擺放字串 P1 的位元組位置。位元組位置是從0開始算起。 舉例而言，要列印字串到列印緩衝區的起頭位置，就要設 P3 為0。
例 1 | 清空列印緩衝區 */ $U10 = “Weight:” 列印字串“Weight:” 到列印緩衝區的位元組位置0**/ 位元組陣列將含有字串“12.34”*/ 列印字串“12.34” 到列印緩衝區的位元組位置8*/ $U10 = “kg” 列印字串“kg” 到列印緩衝區的位元組位置14*/ 列印字串“Weight: 12.34 kg”到印表機*/

■ P2B_R→列印字串 (靠右對齊)

指令格式 | P1 = P2B_R (P2,P3 ) | 數據類別 | U
功能 | 列印字串 P1 到列印緩衝區 P2 。列印位置 P3.是字串在列印緩衝區內靠右對齊的位置。
P1 (I) | 要列印的字串。字串是一個位元組陣列。要列印的字串必須是以零結束的字串。
P2 (I) | 接受字串 P1 的列印緩衝區。列印緩衝區是一個位元組陣列。
P3 (I/C) | 字串靠右對齊的位置，也就是字串的最後一個字元在列印緩衝區中要擺放的位元組位置。位元組位置是從0開始算起。 舉例而言，要列印長度為6的字串到列印緩衝區的起頭位置，就要設 P3 為5。
例 1 | 清空列印緩衝區*/ $U10 = “Weight:” 列印字串“Weight:” 到列印緩衝區並將字串靠右對齊到位元組位置6*/ 位元組陣列將含有字串“12.34”*/ 列印字串“12.34” 到列印緩衝區並將字串靠右對齊到位元組位置12*/ $U10 = “kg” 列印字串“kg” 到列印緩衝區並將字串靠右對齊到位元組位置15*/ 列印字串“Weight: 12.34 kg”到印表機**/


15.4.19. 聲音操作

聲音操作

■ SOUND→播放聲音

指令格式 | SOUND (P1,P2,P3 ) | 數據類別 | U
功能 | 播放聲音。
P1 (I/C) | 聲音編號。 註: 聲音與編號是在人機應用的聲音表中定義。
P2 (I/C) | 播放次數。如果只播放一次，就設為1。
P3 (I/C) | 連續播放的間隔時間。時間單位是0.1秒。如果不需間隔，就設為0。
例 1 | SOUND(10, 5, 3) /* 播放編號10的聲音 5次，重播的間隔時間為0.3秒 */

■ STOP_SOUND→停止播放聲音

指令格式 | STOP_SOUND
功能 | 停止播放當前聲音。
例 1 | STOP_SOUND /* 停止播放當前聲音 */


15.4.20. 字串操作

字串操作

■ STRCPY→文字串複製

指令格式 | STRCPY(P1, P2 ) | 數據類別 | U
功能 | 將 P2 內的字串複製到 P1。
P1 (I) | 接收 P2 字串的位元組數據（陣列）。這個位元組數據（陣列）必須有足夠的空間去存放ASCII字串和零結束字元。
P2 (I) | 數據來源，即被複製的包含零結束字元的位元元組文字數據（陣列）
例1 $U10 = “ABCDE”
STRCPY($U20, $U10)

執行 STRCPY 命令後，位元組數據（陣列）$U10 所包含的文字“ABCDE” 轉存為ASCII文字碼到 $U20，具體記憶區分配如下：

字 | 低位元組 | 高位元組
$U20 | 'A' | 'B'
$U21 | 'C' | 'D'
$U22 | 'E' | 0
例2 $U10 = “12”
STRCPY($U20, $U10)
 執行 STRCPY 命令後，位元組數據組（陣列）$U10 所包含的文字“12” 轉存為ASCII文字碼到 $U20，具體記憶區分配如下：
字 | 低位元組 | 高位元組
$U20 | '1' | '2'
$U21 | 0 | 未定義

■ STRCAT→文字串添加

指令格式 | STRCAT(P1, P2 )
功能 | 將 P2 內的文字串添加到 P1 裡。
P1 (I) | 被添加的位元元組文字數據（陣列）添加後 P1 包含被添加的 P2 字串和一個零結束字元。P1 必須有足夠的空間去存放新字串和零結束字元。
P2 (I) | 要添加到 P1 的位元元組文字數據（陣列），它是包含了一個零結束字元的字串。
例1 | $U10 = “ABC” $U20 = “12345” STRCAT($U10, $U20) /* 執行命令後，位元組數據（陣列）$U10所包含的字串為“ABC12345”。*/
例2 | $U100 = “C:\MyFolder\” $U130 = “Test” $U140 = “.txt“ STRCAT($U100, $U130) STRCAT($U100, $U140) /* 執行命令後，位元組數據（陣列）$U100所包含的字串為 “C:\MyFolder\Test.txt”。 */

■ STRLEN→計算字串長度

指令格式 | P1 = STRLEN(P2 )
功能 | 計算 P2 字串的文字長度(零結束字元不計入)，並將運算結果保存到 P1。
P1 (I) | 計算結果。
P2 (I) | 包含零結束字元字串的位元組數據（陣列）。
例1 | $U10 = “ABC” $U20 = STRLEN($U10) /* 執行命令後，$U20的值等於3。*/

■ STRCMP→比較字串

指令格式 | P1 = STRCMP(P2,P3 )
功能 | 按照字典順序,比較字串 P2 和 P3 (大小寫敏感),並將比較結果保存到 P1。
P1 (I) 比較結果。
值 | 描述
0 | P2 等於 P3
1 | P2 大於 P3
0xFFFF | P2 小於 P3
P2,P3 (I) | 包含零終止符字串的位元組陣列。
例1 $U10 = “ABC”
$U20 = “abc”
$U30 = STRCMP($U10, $U20) /* 執行命令後，$U30的值等於0xFFFF。*/
例2 $U10 = “XYZ”
$U20 = “ABC”
$U30 = STRCMP($U10, $U20) /* 執行命令後，$U30的值等於1。*/
例3 $U10 = “ABC”
$U20 = “ABC”
$U30 = STRCMP($U10, $U20) /*執行命令後，$U30的值等於0。*/

■ STRICMP→比較字串(大小寫不區分)

指令格式 | P1 = STRICMP(P2,P3 )
功能 | 按照字典順序,以不區分字母大小寫的方式比較字串 P2 和 P3 ,並將比較結果保存到 P1。
P1 (I)

比較結果。

值 | 值
0 | P2 等於 P3
1 | P2 大於 P3
0xFFFF | P2 小於 P3
P2,P3 (I) | 包含零終止符字串的位元組陣列。
例1 $U10 = “ABC”
$U20 = “abc”
$U30 = STRICMP($U10, $U20) /* 執行命令後，$U30的值等於0。*/
例2 $U10 = “XYZ”
$U20 = “ABC”
$U30 = STRICMP($U10, $U20) /* 執行命令後，$U30的值等於1。*/
例3 $U10 = “ABC”
$U20 = “ABC”
$U30 = STRCMP($U10, $U20) /* 執行命令後，$U30的值等於0xFFFF。*/

■ STRNCMP→比較字串的前n個字元

指令格式 | P1 = STRNCMP(P2,P3,P4 )
功能 | 按照字典順序,比較字串 P2 和 P3 的前 P4 個字元(大小寫敏感)。並將比較結果保存到 P1。
P1 (I)

比較結果。

值 | 描述
0 | P2 的子串等於 P3 的子串
1 | P2 的子串大於 P3 的子串
0xFFFF | P2 的子串小於 P3 的子串

注意： 在對 P4 個字元比較時，遇到任意一個字串的零終止符，比較結束。如果在比較結束時兩字元子串相等，字元子串短的更小。

在ASCII碼表中，字元代碼從91到96 ('[', '\', ']', '^', '_', and '`')的字元比任何字母都小。
P2,P3 (I) | 包含零終止符字串的位元組陣列。
P4 (I/C) | 需要比較的字元個數
例1 $U10 = “XYZ”
$U20 = “XYZAB”
$U30 = STRNCMP($U10, $U20,4) /* 執行命令後，$U30的值等於0xFFFF。*/
例2 $U10 = “ABZ”
$U20 = “ABC”
$U30 = STRNCMP($U10, $U20,2) /* 執行命令後，$U30的值等於0。*/
例3 $U10 = “AXC”
$U20 = “ABC”
$U30 = STRNCMP($U10, $U20,3) /* 執行命令後，$U30的值等於1。*/
$U30 = STRCMP($U10, $U20) /* 執行命令後，$U30的值等於0。*/

■ STRCHR→查找字串中首次出現字元的位置

指令格式 | P1 = STRCHR(P2,P3 )
功能 | 查找字串 P2 中首次出現字元 P3 的位置,並將查找結果保存到 P1。
P1 (I) | 查找結果。如果字串 P2 中不包括 P3 字元,查找結果為0xFFFF。否則為字串 P2 中首次出現字元 P3 的位置。
P2 (I) | 包含零終止符字串的位元組陣列。
P3 (I/C) | 字元的ASCII代碼
例1 | $U10 = “The quick brown dog jumps over the lazy fox.” $U20 = 0x72 /* 字元‘r' 的 ASCII代碼 */ $U30 = STRCHR($U10, $U20) /* 執行命令後，$U30的值等於11。*/

■ NUM2STR→數值轉換ASCII字元

指令格式 | P1 = NUM2STR(P2,P3 ) | 數據類別 | U/UD
功能 | 數值轉換ASCII字元
P1 (I) | 轉換結果。
P2 (I/C) | 轉換的常數或是存儲數值的位址。
P3 (I/C) | 指定轉換字元數的確切數目。如果 P2 數值的位數小於 P3，那麼要在轉換後的字串前補上相應數量的零；如果 P2 數值的位數大於 P3，那麼超出的字元就要被釋放；如果 P3 等於0，那麼轉換後的字串就根據實際長度保存到 P1。
例1 | $U120 = 123 $U100 = NUM2STR($U120, 0) (U) /* 執行命令後，位元組數據$U100所包含ASCII文字串為“123” */
例2 | $U120 = 1234567 (UD) $U100 = NUM2STR($U120, 10) (UD) /* 執行命令後，位元組數據$U100所包含ASCII文字串為 “0001234567”。 */
例3 | $U120 = 1234567 (UD) $U100 = NUM2STR($U120, 5) (UD) /* 執行命令後，位元組數據$U100所包含ASCII文字串為 “34567”。 */

■ TIME2STR→系統時間轉換成字串

指令格式 | P1 = TIME2STR(P2 ) | 數據類別 | U
功能 | 將當前系統時間轉換成字串形式，字串的格式由 P2 決定，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。
P2 (I/C) 指定轉換後的格式:
格式 | 值 | 備註
hhmmss | 0 | hh: hour(00-23); mm: minute(00-59); ss: second(00-59)
hhmm | 1 | hh, mm: same as above 同上
例1 | $U10 = TIME2STR(0) /* 假設當前系統時間是12:30:59，執行該命令後，位元組陣列$U10~$U11所包含的字元轉存為“123059”。*/

■ DATE2STR→系統日期轉換成字串

指令格式 | P1 = DATE2STR(P2 ) | 數據類別 | U
功能 | 將當前系統日期轉換成ASCII文字串形式，字串的格式由 P2 決定，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。
P2 (I/C)

指定轉換後的格式

格式 | 值 | 備註
YYMMDD | 0 | YY: year (00-99); MM: month(01-12); DD: day(01-31)
YYMM | 1 | YY, MM: same as above
YYMMMDD | 2 | YY: year (00-99); MMM: month(JAN-DEC); DD: day(01-31)
YYMMM | 3 | YY, MMM: same as above
例1 | $U10 = DATE2STR(0) /*假設當前系統日期是2008年12月7日，執行該命令後，位元組陣列$U10所包含的字元轉存為“081207”。*/
例2 | $U20 = DATE2STR(3) /* 假設當前系統日期是2008年12月31日，執行該命令後，位元組陣列$U20所包含的字元轉存為“08DEC”。*/

■ TD2STR→系統時間和日期轉換成字串

指令格式 | P1 = TD2STR(P2 ) | 數據類別 | U
功能 | 將當前系統時間和日期轉換成字串形式，字串的格式由 P2 決定，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。
P2 (I/C)

指定轉換後的格式 :

格式 | 值 | 備註
YYMMDD_hhmmss 0 YY: year (00-99); MM: month(01-12); DD: day(01-31)
hh: hour(00-23); mm: minute(00-59) ; ss: second(00-59)
YYMMMDD_hhmmss 1 YY, DD, hh, mm, ss: same as above 同上
MMM: month(JAN-DEC)
YYMMDD_hhmm | 2 | YY, DD, hh, mm: same as above 同上; MM: month(01-12)
YYMMMDD_hhmm 3 YY, DD, hh, mm: same as above 同上;
MMM: month(JAN-DEC)
例1 | $U10 = TD2STR(0) /* 假設當前系統日期是2008年12月7日， 系統時間是15:18:30。執行該命令後，位元組陣列$U10所包含的字元轉存為“081207_151830”。*/
例2 | $U20 = TD2STR(3) /* 假設當前系統日期是2008年12月31日，系統時間是13:30:00。執行該命令後，位元組陣列$U20所包含的字元轉存為“08DEC31_1330”。 */

■ I2A→整數轉換成ASCII文字串

指令格式 | P1 = I2A(P2,P3 ) | 數據類別 | U/S/UD/SD
功能 | 將整數 P2 轉換成ASCII字串形式，字串的格式由 P2 和 P3 決定，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。轉換結果為帶空格中止符的字串。
P2 (I/C) | 需轉換的整數或是儲存數值的位址。
P3 (I/C) | 字串中小數點插入位置。當 P3 為n，則小數點於字串中第n位數左邊；當 P3 為0，字串無小數點。
例1 | $U120 = 123 $U100 = I2A($U120, 0) /* 執行命令後，位元組數據$U100所包含ASCII文字串為“123”。*/
例2 | $U120 = 1234567 (UD) $U100 = I2A($U120, 2) (UD) /* .執行命令後，位元組數據$U100所包含ASCII文字串為“12345.67” */
例3 | $U120 = -12345 (S) $U100 = I2A($U120, 1) (UD) /* 執行命令後，位元組數據$U100所包含ASCII文字串為“-1234.5”。*/

■ A2I→ASCII文字串轉換成整數

指令格式 | P1 = A2I(P2,P3,P4 ) | 數據類別 | U/S/UD/SD
功能 | 將ASCII文字串 P2 轉換成整數形式，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。若轉換發生錯誤，則結果為0。
P2 (I) | 需轉換的字串。
P3 (I/C) | 字串的長度，若 P3 為0，則字串為帶空格中止符的字串。
P4 (I/C) | 字串小數位數轉換的個數。
例1 | $U120 = “123” $U100 = A2I($U120, 0, 0) /* 執行命令後，字$U100所包含數值為“123”*/
例2 | $U120 = “1234567” $U100 = A2I($U120, 6, 0) (UD) /*執行命令後，雙字$U100所包含數值為“123456 */
例3 | $U120 = “-123.45” $U100 = A2I($U120, 0, 2) (S) /* 執行命令後，字$U100所包含數值為“-12345” */

■ F2A→浮點數轉換成ASCII文字串

指令格式 | P1 = F2A(P2,P3 ) | 數據類別 | F
功能 | 將浮點數 P2 轉換成ASCII文字串形式，字串的格式由 P3 和 P4 決定，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。轉換結果為帶空格中止符的字串。
P2 (I/C) | 需轉換的浮點數或是儲存數值的位址。
P3 (I/C) | 字串的小數位數。
例1 | $U120 = 123.45 (F) $U100 = F2A($U120, 2) /* 執行命令後，位元組數據$U100所包含ASCII文字串為“123.45”。*/
例2 | $U120 = 567.89 (F) $U100 = F2A($U120, 1) (UD) /* 執行命令後，位元組數據$U100所包含ASCII文字串為“567.8” */
例3 | $U120 = -1234.5 (S) $U100 = F2A($U120, 1) (UD) /* 執行命令後，位元組數據$U100所包含ASCII文字串為“-1234.5”。 */

■ A2F→ASCII文字串轉換成浮點數

指令格式 | P1 = A2F(P2,P3 ) | 數據類別 | F
功能 | 將ASCII文字串 P2 轉換成浮點數形式，並將轉換結果保存到 P1。
P1 (I) | 轉換結果。若轉換發生錯誤，則結果為0。
P2 (I) | 需轉換的字串。
P3 (I/C) | 字串的長度，若 P3 為0，則字串為帶空格中止符的字串。
例1 | $U120 = “123.4” $U100 = A2F($U120, 0) /*雙字$U100的浮點數數值為“123.4”。*/
例2 | $U120 = “1234567” $U100 = A2F($U120, 6) (UD) /* 雙字$U100的浮點數數值為“123456”。**/
例3 | $U120 = “-123.45” $U100 = A2F($U120, 0) (S) /* 雙字$U100的浮點數數值為“-123.45”。*/

■ GET_BAR_CODE→取得條碼

指令格式 | P1 = GET_BAR_CODE(P2) | 數據類別 | U
功能 | 取得由連接在指定 USB口上的條碼讀入器所讀到的條碼。
P1 (I) 保存條碼的記憶區(位元組數組)的起始位置。

 條碼是以字串(含空(null)字結束符)的形式保存在位元組數組中。條碼最多可包含1024個字元。在您的應用中請確保位元組數組有足夠有效的空間保存讀到的條碼。如果沒有條碼輸入，位元組數組的前兩個位元組會設為0。因為系統只有一個條碼緩衝區，如果輸入的條碼沒有被即時取走，新輸入的條碼會覆蓋原先的條碼。因此，要確保執行此命令的頻繁度要足夠多以避免丟失輸入。另外，輸入的條碼被取走後，條碼緩衝區會立即被清除。因此，一個條碼輸入只能使用這個命令取一次。

 取得條碼最有效的方法是使用本命令在一個事件巨集，並且這個事件巨集採用BarCodeInputViaUsb做為觸發位。當有條碼輸入時，這個觸發位會觸發這個事件 巨集一次。這保證有條碼輸入時，一定有相應的巨集取得並處理這個條碼。

 註: 僅T系列觸控屏支持本命令。
P2 (I/C) 用來連接條碼讀入器的 USB 接口 編號。
對於 T系列觸控屏，只能設為1。
例1 | $U100 = GET_BAR_CODE(1) /* 取得連接在1號USB口上條碼讀入器讀到的條碼*/

■ GB2U

指令格式 | P1 = GB2U(P2,P3 ) | 數據類別 | U
功能 | 將保存在 P3 中的國標碼的字串轉換成UNICODE編碼的字串，並將轉換後的UNICODE編碼的字串保存到P2，字串長度保存到 P1。
P1 (I) | 字串的長度。
P2 (I) | 轉換後的UNICODE編碼的字串的起始位址。字串必須是一個含零終止符的字串。
P3 (I) | 需轉換的國標碼字串的起始位址。字串必須是一個含零終止符的字串。
例1 | $U20 = “ABC” $U30 = GB2U($U10, $U20) /*執行命令後,$U30內的值為3, $U10 內的值為0x41, $U11內的值為0x42, $U12 內的值為0x43。*/

■ U2GB

指令格式 | P1 = U2GB(P2,P3 ) | 數據類別 | U
功能 | 將保存在 P3 中的UNICODE編碼的字串轉換成 國標碼字串，並將轉換後的國標碼字串保存到P2，字串長度保存到 P1。
P1 (I) | 字串的長度。
P2 (I) | 轉換後的國標碼字串的起始位址。字串必須是一個含零終止符的字串。
P3 (I) | 需轉換的UNICODE編碼的字串的起始位址。字串必須是一個含零終止符的字串。
例1 | $U20 = 0x41 // "A" $U21 = 0x42 // "B" $U22 = 0x43 // "C" $U23 = 0 $U30 = U2GB($U10, $U20) /* 執行命令後,$U30內的值為3, $U10 內的值為0x4241, $U11內的值為0x43 */

■ WCSLEN

指令格式 | P1 = WCSLEN(P2) | 數據類別 | U
功能 | 讀取UNICODE編碼的字串P2 的長度，並將運行結果保存到 P1。
P1 (I) | 字元個數
P2 (I) | 包含零終止符的UNICODE編碼的字串的字陣列
例1 | $U10 = 0x41 // "A" $U11 = 0x42 // "B" $U12 = 0x43 // "C" $U13 = 0 $U20 = WCSLEN($U10) /* 執行命令後，$U20的值等於3。 */


15.4.21. 數學運算

數學運算

■ ACOS→反餘弦值

指令格式 | P1 = ACOS( P2 ) | 數據類別 | F
功能 | 計算 P2 的反餘弦值，並將結果保存到 P1 。
P1 (I) | 運行結果，數值範圍為 0 到 π。若P2 的數值小於-1且大於1，則運行結果將默認為無限值。
P2 (I/C) | 運算元，數值範圍為 -1 到 1。
例1 | $U100 = 0 (F) /* 將數值 0 賦值給$U100和$U101。 */ $U200 = ACOS($U100) (F) /* 將 0 的反餘弦值1.570796寫入$U200和$U201。 */

■ ASIN→反正弦值

指令格式 | P1 = ASIN( P2 ) | 數據類別 | F
功能 | 計算 P2 的反正弦值，並將結果保存到 P1 。
P1 (I) | 運行結果，數值範圍為 -π/2 到 π/2。若P2 的數值小於-1且大於1，則運行結果將默認為無限值。
P2 (I/C) | 運算元，數值範圍為 -1 到 1。
例1 | $U100 = -0.5 (F)/* 將數值 -0.5 賦值給$U100和$U101。 */ $U200 = ASIN($U100) (F)/* 將 -0.5 的反正弦值 -0.523599 寫入$U200和$U201。 */

■ ATAN→反正切值

指令格式 | P1 = ATAN( P2 ) | 數據類別 | F
功能 | 計算 P2 的反正切值，並將結果保存到 P1 。
P1 (I) | 運行結果，數值範圍為 -π/2 到 π/2。若P2 的數值為 0，則運行結果為0。
P2 (I/C) | 運算元
例1 | $U100 = 236.89 (F)/* 將數值 236.89 賦值給$U100和$U101。 */ $U200 = ATAN($U100) (F) /* 將 236.89 的反正切值 1.566575 寫入$U200和$U201。 */

■ ATAN2→反正切值

指令格式 | P1 = ATAN2( P2,P3 ) | 數據類別 | F
功能 | 計算 P2 / P3 的反正切值，並將結果保存到 P1 。
P1 (I) | 運行結果，數值範圍為 -π 到 π。若P2 和P3 的數值都為 0，則運行結果為0。
P2 (I/C) | 運算元
P3 (I/C) | 運算元
例1 | $U100 = 60 (F) /* 將數值 60 賦值給$U100和$U101。 */ $U102 = 3 (F) /* 將數值 3 賦值給$U102和$U103。 */ $U200 = ATAN($U100,$U102) (F) /* 將 60/3 的反正切值 1.520838 寫入$U200和$U201。 */

■ COS→餘弦值

指令格式 | P1 = COS( P2 ) | 數據類別 | F
功能 | 計算 P2 的餘弦值，並將結果保存到 P1 。
P1 (I) | 運行結果，數值範圍為 -1 到 1。
P2 (I/C) | 運算元
例1 | $U100 = 1.570796 (F) /* 將數值 1.570796 賦值給$U100和$U101。 */ $U200 = COS($U100) (F) /* 將1.570796的餘弦值0寫入$U200和$U201。 */

■ SIN→正弦值

指令格式 | P1 = SIN( P2 ) | 數據類別 | F
功能 | 計算 P2 的正弦值，並將結果保存到 P1 。
P1 (I) | 運行結果，數值範圍為 -1 到 1。
P2 (I/C) | 運算元
例1 | $U100 = 1.570796 (F) /* 將數值 1.570796(2/π) 賦值給$U100和$U101。 */ $U200 = SIN($U100) (F) /* 將 1.570796 的正弦值 1 寫入$U200和$U201。 */

■ TAN→正切 值

指令格式 | P1 = TAN( P2 ) | 數據類別 | F
功能 | 計算 P2 的正切值，並將結果保存到 P1 。
P1 (I) | 運行結果
P2 (I/C) | 運算元
例1 | $U100 = 0.785398 (F) /* 將數值 0.785398 賦值給$U100和$U101。 */ $U200 = TAN($U100) (F) /* 將 0.785398 的正切值 1 寫入$U200和$U201。 */

■ EXP→指數 值

指令格式 | P1 = EXP( P2 ) | 數據類別 | F
功能 | 計算 P2 的指數值，並將結果保存到 P1 。
P1 (I) | 運行結果
P2 (I/C) | 浮點參數，計算其指數。
例1 | $U100 = 2.302585 (F)/* 將數值 2.302585 賦值給$U100和$U101。 */ $U200 = EXP($U100) (F) /* 將 2.302585 的指數值 10 寫入$U200和$U201。 */

■ LOG→自然對數(以e為底)值

指令格式 | P1 = LOG( P2 ) | 數據類別 | F
功能 | 計算 P2 的自然對數(以e為底)值，並將結果保存到 P1 。
P1 (I) | 運行結果
P2 (I/C) | 浮點參數，計算其指數。
例1 | $U100 = 9000 (F) /* 將數值 9000 賦值給$U100和$U101。*/ $U200 = LOG($U100) (F) /* 將 9000 的自然對數值 9.104980 寫入$U200和$U201。*/

■ LOG1 0→常用對數(以10為底)值

指令格式 | P1 = LOG10( P2 ) | 數據類別 | F
功能 | 計算 P2 的常用對數(以10為底)值，並將結果保存到 P1 。
P1 (I) | 運行結果
P2 (I/C) | 浮點參數，計算其指數。
例1 | $U100 = 9000 (F) /* 將數值 9000 賦值給$U100和$U101。*/ $U200 = LOG10($U100) (F) /* 將 9000 的常用對數值 3.954242 寫入$U200和$U201。*/

■ POW→计算次方

指令格式 | P1 = POW(P2,P3 ) | 數據類別 | U
功能 | 計算 P2 的 P3 次方，並將結果保存到 P1 。
P1 (I) | 運行結果
P2 (I/C) | 基數。
P3 (I/C) | 指數。
例1 | $U100 = 2 (F)/* 將數值 2 賦值給$U100和$U101。*/ $U102 = 3 (F) /* 將數值 3 賦值給$U100和$U101。 */ $U200 = POW($U100,$U102) (F) /* 將 2 的 3 次方值 8 寫入$U200和$U201。*/

■ SQRT→計算平方根

指令格式 | P1 = SQRT( P2 ) | 數據類別 | F
功能 | 計算 P2 的平方根，並將結果保存到 P1 。
P1 (I) | 運行結果
P2 (I/C) | 運算元
例1 | $U100 = 45.35 (F) /* 將數值 45.35 賦值給$U100和$U101。 */ $U200 = SQRT($U100) (F) /* 將 45.35 的平方根 6.73 寫入$U200和$U201。*/


15.4.22. 運行操作

運行操作

■ RUN→運行

指令格式 | RUN(P1)
功能 | 運行在同一電腦上的可執行程式 P1。這個命令只能在本運行軟體上使用。
P1 (I/A) | 需要運行的可執行程式的檔案名。
例 1 | RUN "ABC.exe" /* 運行程式 ABC */
例 2 | $U10 = "XYZ.bat" RUN ($U10) /* 運行批次檔案XYZ */

■ RUNW→運行並且等待

指令格式 | P1 = RUNW(P2)
功能 | 運行在同一電腦上的可執行程式 P2，並將運行結果保存到 P1。需要注意的是這個命令之後的命令語句，需要等到此一可執行程式結束運行後才會執行。這個命令只能在本運行軟體上使用。
P1 (I) | 運行結果；如果這個代碼等於0，表示運行成功；否則運行失敗。
P2 (I/A) | 需要運行的可執行程式的檔案名。
例 1 | $U10 = RUNW "ABC.exe" /* 運行程式 ABC，並將運行結果保存到 $U10。*/ IF $U10 == 0 /*如果運行結果為0，那麼運行批次檔 XYZ*/ $U20 = "XYZ.bat" $U11 = RUNW ($U20) /* 運行批次檔 XYZ。 */ ENDIF


16.1. 使用排程

使用排程

排程功能可使人機在指定的時間執行預先排定的操作。例如，人機可在指定的開始/結束時間去打開/關閉馬達。另一個例子是，人機可以在控制過程中指定的開始時間設定運行模式溫度，在控制過程指定的結束時間重設溫度為待機溫度。

 同一個人機應用中最多可設置80個排程。每一個排程都可規劃改變特定位置PLC的值或在設定的時間執行巨集程式。在人機運行畫面為使操作員檢視/改變排程的設定，畫面中可使用『排程設置表』物件來操作和監看。

欲使用排程，請按以下步驟進行操作：

  1. 設定排程
     詳見 第 16.2 節 。

  2. 建立並設定排程設置表
     詳見 第 16.3 節 。

注意：

1. 排程時間為一次性動作。當到達指定開始時間，排程動作開始運作，指定的裝置位址只會寫入一次，寫入的動作將不會重複執行。

2. 開始值和禁止動作位在指定時間開始時讀取一次，如果由於通訊等因素造成讀取延遲，則開始時間也將延遲，同樣的，結束時間也會發生延遲。

3. 當排程的時間範圍改變，若當前時間在時間範圍內，仍將執行指定的動作。

4. 當多個排程出現相同的開始時間和結束時間，將會依排程編號，由小到大，依序執行指定的排程操作。

5. 如果開始動作完成後，電源發生中斷，結束動作將在電源恢復時執行。


16.2. 設定排程

設定排程

用戶可在排程的屬性視窗中，進行各項排程的設定。欲打開排程視窗，可依以下方法擇一操作：
1) 在軟體的專案管理員視窗中，在人機應用 -> 設置，雙擊排程節點( [image] )。

2) 在軟體的專案管理員視窗中，在人機應用 -> 設置，在排程節點( [image] )上 按滑鼠右鍵，從彈出的右鍵功能表中，選擇屬性。

3) 在軟體 上方的功能列中，點擊 ->人機應用，在彈出的下拉選單中，選擇排程…。

排程視窗包含以下兩個頁面，有些頁面在需要設定時才會顯現。

■ 一般頁
 詳見 第 16.2.1 節 。

■ 開始巨集頁 / 停止巨集頁
 詳見 第 15.2.6 節 。


16.2.1. 排程 - 一般設定

排程 - 一般設定

在排程視窗中，可檢視排程的一般設定。欲打開人機應用排程視窗，有下面兩種方式：

1) 在軟體的專案管理員視窗中，選擇的人機應用專案下，在畫面 -> 排程專案節點上按兩下滑鼠左鍵。

2) 在軟體上方的功能列中，點擊 ->人機應用，在彈出的下拉選單中，選擇排程。

注意：排程將在當前人機應用中執行，所以，排程功能表中所指定的應用，必須為當前人機應用。

欲啟用人機應用的排程功能，勾選排程視窗中的“啟用”。

下表為排程設置各屬性的說明。

項目

 說明
啟用 | 欲使用排程，首先，勾選排程的“啟用”。在專案規劃中，可取消個別排程在每列前方“用”的勾選 框，來暫停個別排程的使用，排程的設置在取消勾選後也不會消失。
編號 | 排程的編號。
排程名稱 | 設定各種語言的排程名稱。排程名稱會顯示在排程設置表上。排程名稱的最大長度為24字元，欲選擇編輯的語言，在設置視窗下 方的 『語言: 』選擇設置。
開始動作

設定人機在開始時間和結束時間要執行的動作。下表說明開始動作的5種選項。

動作 | 說明
設位為1 | 在開始時間到來時，設指定的位為1。如果勾選『結束動作』，在結束時間，重設位為0。 開始時間：09:00:00 結束時間：17:00:00 set bit
設位為0 | 在開始時間到來，設指定的位為0。如果勾選『結束動作』，在結束時間，重設位為1。 範例: 開始時間：09:00:00 結束時間：17:00:00
寫值到字 | 在開始時間到來時，寫『開始值』到指定的字地址。若勾選結束動作，在結束時間到來時，寫『結束值』到指定的字地址。 範例: 開始時間：09:00:00 結束時間：17:00:00 開始值: 100 結束值: 60 寫地址: W100
寫值到雙字 | 在開始時間 到來時，寫『開始值』到雙字地址。若勾選結束動作，在結束時間到來時，寫『結束值』到指定的雙字地址。
執行巨集 | 在開始時間到來時，執行指定的開始巨集。如果勾選『結束動作』，在結束時間，執行指定的結束巨集。當選擇執行巨集，將會顯示關聯的開始巨集編輯頁面，可在該頁面編輯開始巨集。當勾選『結束動作』，將會顯示關聯的結束巨集頁面，可在該頁面編輯結束巨集。
註：上表所提的開始時間、結束時間、開始值、結束值都可在排程設定視窗中設定。
寫地址

設定動作的目標位址

動作 | 數據類型
設位為1 | 位地址
設位為0 | 位地址
寫值到字 | 屬於16位元資料的位址。
寫值到雙字 | 屬於32位元資料的位址。
開機動作

選擇電源打開後欲執行的動作。

啟動開機動作(已勾選)
若HMI在排程的時間範圍內開機，執行開始動作。
 power on-inside
若HMI在排程的時間範圍外開機，且勾選結束動作，則執行結束動作。
 power on-outside

開機動作關閉(未勾選)
若勾選『結束動作』，當人機開機後，執行結束動作。
結束動作

勾選此選項啟動結束動作。如果啟動結束動作，在指定的結束時間，人機將根據指定時間開始動作，執行以下的操作。

開始動作 | 結束動作
設位為1 | 在結束時間，重設指定的位為0。
設位為0 | 在結束時間，重設指定的位為1。
寫值到字 | 在結束時間，寫結束值到指定的字。
寫值到雙字 | 在結束時間，寫結束值到指定的雙字。
執行巨集 | 執行指定的結束巨集。
詳細設置 | 點擊 [image] 按鈕 來打開排程詳細設置視窗。在此視窗中，可設定排程的開始時間、結束時間、開始數值和結束數值。詳見第 16.2.2 節 。
禁止動作位 | 藉由設定禁止動作位來禁止特定的排程功能。在開始時間，禁止動作位的數值將在開始動作執行前讀取。如果數值為1，則在當前迴圈中，排程動作將不會執行。


16.2.2. 排程詳細設定視窗

排程詳細設定視窗

在排程詳細設定視窗中，使用者可設定排程的開始時間/日期、結束時間/日期、開始值和結束值。欲打開排程詳細設定視窗，點擊排程 視窗中，排程的 [image] 按鈕。

註：如果排程中 『特別日』被禁用，排程中『正常日』的設定會影響『特別日』。必須在特別日來臨之前，取消特別日的設定。比如，特別日是9/13，那麼使用者必須在9/13號00:00之前取消該特別日的設定。

範例一

  1. 時間範圍於星期一09:00:00開始，於星期四18:00:00結束。
  2. 使用者可於運行時，使用排程 設定表修改時間範圍。
  3. 開始值和結束值為浮點數。當排程開始，人機從內部字$U120和$U121 讀取開始值，寫入指定的地址。當排程結束，人機從內部字$U122和$U123讀取結束值，寫入指定的地址。

範例二

  1. 時間範圍可由裝置/PLC設定。記憶區從PLC的W100開始設定時間範圍。

  2. 在運行時，有效時間範圍設定前，將使用對話方框中預設的時間範圍。預設的時間範圍開始為每個工作日，從09:00:00到17:00:00。本範例為每週一到週五，且本設定可以藉由畫面設計一個排程設定表物件來修改。

  3. 使用者可於運行時，使用排程設定表修改時間範圍。

  4. 『開始值』和『結束值』的數據類型為16位正整數。當排程開始時，人機從PLC字位置W30讀取開始值，寫入指定的地址。當排程結束，人機從PLC字位置W31讀取結束值，寫入指定的地址。

範例三

  1. 時間範圍開始於：4月10日07:30:00，結束於 ：4月10日20:30:00

  2. 未勾選『在排程設定表內可改 』勾選框表示，無法在運行時，使用『排程設定表物件』來修改時間範圍。

  3. 『開始值』和『結束值 』的數據類型為16位正整數。當排程開始時，人機寫入"100"到指定的寫入地址。當排程結束，人機寫入"60"到指定的寫入地址。

範例四

  1. 一周時程的開始時間和結束時間在以下視窗中設定。例如，時間範圍開始於每週周日07:00:00，結束於07:30:00。

  2. 使用者不可於運行時，使用排程設定表修改時間範圍。

下表為排程詳細設定視窗各項目的說明。

項目 |  |  | 說明
排程編號 |  |  | 排程的編號 。此數值不可變更。
種類 | 特別日 |  | 點選此選項，排程只在特別日有效。
 | 開始日與結束日個別設定 |  | 點選此選項， 『開始日』與『結束日』設定為不同的日期。
 | 單一時程 |  | 點選此選項， 設定為單一的時間範圍。
 | 一周時程 |  | 點選此選項， 設定一周內，個別排程的時間範圍。
寫出值 |  | 常數 | 點選此選項，設定 『開始值』和『結束值』的類型為常數。
 |  | 變數 | 點選此選項，設定『開始值』和『結束值』的類型為變數。
 |  | 數據類型 | 設定開始/結束值的數據類型。
 |  | 開始值 | 設定開始值或開始值的地址。
 |  | 結束值 | 設定結束值或結束值的地址。
時間範圍 |  | 常數 | 選擇常數，則時間範圍無法由裝置/PLC設定。
 |  | 變數 | 選擇變數，則時間範圍可由裝置/PLC設定。
 |  | 在排程設定表內可改 | 選擇此選項，使用者可使用物件『排程設定表』來更改時間範圍 。
 |  | 時間設定地址 | 設定裝置/PLC設定排程時間範圍的開始地址。關於時間設定地址，詳見 16.2.3 節 的說明。
 |  | 預定時間 | 設定排程是否啟用預定時間範圍。此屬性只有在時間範圍選擇『變數』時才會出現。若使用者或 PLC未設定有效的時間範圍，人機將使用預 設時間範圍。
 |  | 月 | 指定『特別日』的月份。
 |  | 日 | 指定『特別日』的日期。
 |  | 開始時間 | 設定排程的開始時間。
 |  | 開始日 | 排程的開始日（禮拜幾）。只有在點選『開始日與結束日個別設定』後，此選項才會出現。
 |  | 結束時間 | 設定排程的結束時間。
 |  | 結束日 | 排程的結束日（禮拜幾）。只有在點選『開始日與結束日個別設定』後，此選項才會出現。
 |  | 適用日 | 選擇一周中，排程的適用日。 只有在點選『單一時程』選項時，此選項才會出現。


16.2.3. 時間設定區

時間設定區

下表說明『時間設定地址』，功能字的編排方式。

字編號 | 用途 | 描述
0 | 時間設置控制字 | bit 0 位0：時間取得請求位 註： 1).當人機偵測到時間取得請求位打開(從0到1)，將讀取從時間設置區的字2到字10，以取得排程的動作模式、開始時間、結束時間。
1 | 時間設置狀態字 | bit 1 位0：時間取得完成位 0： 時間取得已執行或尚未執行。 1： 時間取得完成 。 位1：錯誤通知位 0： 時間資料已被正確的資料所取代。 1： 時間資料包含錯誤。 註： 1) 當時間取得完成位從0到1，裝置/PLC必須將時間取得請求位由1設為0。 2) 當人機偵測到時間取得請求位從1到0，時間取得完成位和錯誤通知位將會立刻從0變到1。 time setting status word
2 | 動作模式 | bit 1 位0：結束動作位 0： 使排程的結束動作無效。 1： 啟動排程的結束動作。 位 1： 個別日設定位 0： 排程的開始日和結束日相同 。 1： 排程的開始日和結束日不同 。 註： 1) 如果個別日設定位為"1"，且超過兩個的開始/結束日的位同時打開，將發生錯誤。
3 | 開始日或特別日的日 | 指定觸發開始/結束動作的日。 bit 06 位00：日(0：無, 1：指定) 位01：一(0：無, 1：指定) 位02：二(0：無, 1：指定) 位03：三(0：無, 1：指定) 位04：四(0：無, 1：指定) 位05： 五(0：無, 1：指定) 位06：六(0：無, 1：指定) 若排程設置為特別日，字3(開始日)的高位元組應包含特別日的月(1-12)，且字3(開始日)的低位元組應包含特別日的日(1-31)，字7(結束日)應為0。 bit
4 | 開始時間(時) | 時： 0-23
5 | 開始時間(分) | 分： 0-59
6 | 開始時間(秒) | 秒： 0-59
7 | 結束日或特別日的日 | 同“開始日或特別日”的日。
8 | 結束時間(時) | 時： 0-23
9 | 結束時間(分) | 分： 0-59
10 | 結束時間(秒) | 秒： 0-59


16.3.1. 排程 - 基本功能

排程 - 基本功能

使用者可以通過排程設置表將排程以列表方式呈現。且可以在運行時直接在排程設置表中修改排程的時間範圍。

以上以一個排程設置表的圖例。第一行是抬頭行，顯示每個欄位的抬頭。其餘行每一行顯示一項排程。 使用者可以同滾動按鈕或捲軸滾動物件內容。一個排程設置表共有七個欄位。下表為排程設置表各項屬性的說明。

欄位 | 描述
排程編號 | 相關排程的編號。這一個欄位可以不顯示。
排程名稱 | 相關排程的名稱。
狀態 | 相關排程的當前狀態。當前狀態包括：動作、未動作、禁止、錯誤。
設置 | 若相關排程是可更改的，該欄位會出現一個按鈕。點擊該按鈕， 使用者可以看到以下兩個設置排程的對話框，可以設置相關排程的時間範圍。 set set 詳細說明，請參考 第 16.2.2 節 。
開始時間 | 排程的開始時間。
結束時間 | 排程的結束時間。
適用日 | 一周內排程運行的個別日期。

註: 每一排的文字顏色和字體的設置在一般頁內設置。


16.3.2. 排程 - 功能選項

排程 - 功能選項

下表是排程設置表中可增加的功能選項。選項的設定可在屬性對話方框中完成。

選項 | 說明
觸控有效 | 排程設置表觸控操作是否有效 ，可由指定的位或當前用戶等級控制。在進階頁中，可進行此選項的設定。
顯現控制 | 設定排程設置表的顯現與否，可由指定的位或當前用戶等級控制。在顯現頁中，可進行此選項的設定。


16.3.3. 排程 - 設定

排程 - 設定

所有排程設置表的設定都可在屬性視窗中完成。排程設置表的屬性視窗包含以下三個頁面。

■ 一般頁
 詳見 第 16.3.4 節 。

■ 進階頁

詳見 第 4.4.5 節 。

■ 顯現頁
 詳見 第 4.4.6 節 。


16.3.4. 排程 - 一般設定

排程 - 一般設定

本章節說明排程設置表一般頁中各項屬性的設定。下圖是一般頁的圖例。

schedule setting table

下表為一般頁中各項屬性的說明。

屬性 |  | 說明
編號 |  | 設定排程設置表的編號。當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為SSTnnnn。
註 |  | 可加入物件的說明文字。
外型設置 |  | 、邊框色、背景色的詳細說明，請參考 第 4.3.4 節 設定物件的外型 。
抬頭 | 語言 | 設定查看及編輯抬頭行所使用的語言。語言相關的文字屬性包含抬頭的字體和名稱。
 | 字體 | 設定抬頭文字的字體。
 | 顏色 | 設定抬頭文字的顏色。
 | 背景色 | 設定抬頭行的背景色。
 | 顯示排程編號 | 勾選排程設置表是否顯示排程編號欄位。
 | 排程編號 | 設定排程編號欄位的抬頭名稱。當勾選了顯示排程編號選項時，此選項才會出現。
 | 排程名稱/狀態/設置/開始時間/結束時間/適用日 | 設定排程名稱/狀態/設置/開始時間/結束時間/適用日欄位的抬頭名稱。
訊息 | 語言 | 設定查看及編輯語言相關的文字屬性設定所使用的語言。語言相關的文字屬性包含字體和簡寫。
 | 字體 | 設定文字的字體。
 | 顏色 | 設定文字的顏色。
 | 日期格式 | 選擇日期顯示格式。
 | 日期格式 | 設定排程名稱/狀態/設置/開始時間/結束時間/適用日欄位元的簡寫文字。
狀態顏色 | 動作 | 設定排程動作時，顯示在狀態欄位中的顏色。
 | 未動作 | 設定排程未動作時，顯示在狀態欄位中的顏色。
 | 禁止 | 設定排程禁止時，顯示在顯示在狀態欄位中的顏色。
 | 錯誤 | 設定排程動 作錯誤時，顯示在顯示在狀態欄位中的顏色。
格線 | 垂直 | 勾選排程設置表是否顯示垂直格線。
 | 水 平 | 勾選排程設置表是否顯示水平格線。
 | 顏色 | 設定格線顏色。
行距 |  | 設定排程設置表相鄰兩行間的距離(單位為像素)。
項距 |  | 設定排程設置表相鄰兩列間的距離(單位為像素)。
顯示排程 | <勾選框> | 勾選此選項，即可在排程設置表中顯示指定排程。
 | 全選 | 勾選此選項，選擇所有排程。
 | 全刪 | 勾選此選項，取消所有排程。


17.1. 搜尋與替換

搜尋與替換

使用者可使用“搜尋與替換”工具搜尋或替換專案中所使用的文字或位址。


17.1.1. 搜尋/替換文字或位址

搜尋/替換文字或位址

本章節說明如何利用搜尋/替換停靠式視窗或搜尋/替換對話框來搜尋/替換文字或位址。

下圖為使用搜尋/替換停靠式視窗搜尋文字/位址的範例。欲開啟視窗，從“編輯” > “搜尋與替換”選單中，點選“搜尋…”。

下圖為使用搜尋/替換對話框取代文字/位址的範例。欲開啟對話框，從“編輯” > “搜尋與替換”選單中，點選“替換…”。

下表為搜尋/替換停靠式視窗/對話框中，各項屬性的說明。

屬性 |  | 說明
查找字串 | <複合框> | 輸入欲搜尋的文字/位址，可從剪貼簿貼上或從下拉式清單中選擇最近輸入過的文字/位址。
 | 符合大小寫 | 勾選此選項，只搜尋大小寫均符合“搜尋字串”欄位內容的字串。
 | 需全字符合 | 勾選此選項，只搜尋全字符合的文字/位址。在一個字串中，只有部分字串符合者，將不在搜尋範圍內。
查找對象 | <複合框> | 選擇專案中，欲搜尋的部份，如下： 當前畫面、當前人機應用的畫面、所有畫面、當前巨集、當前人機應用的巨集、所有巨集、當前人機應用的標籤、所有人機應用的標籤。
 | 文字/位址 | 從列出的清單中，勾選欲搜尋的文字/位址種類。
停靠式視窗 | 查找 | 點擊此按鈕，在勾選的項目中，搜尋指定的文字/位址。符合的項目將出現在“搜尋結果”視窗中。關於搜尋結果視窗的詳細說明，請參考章節 17.1.2. 。
 | 取代… | 點擊此按鈕，開啟搜尋/替換對話框，可設定取代文字/位址。
搜尋/替換 對話框 | 代換字串 | 輸入欲取代“搜尋文字”欄位元中文字的內容，可從剪貼簿貼上或從清單中選取最近輸入過的文字清單。
 | 找下一個 | 點擊此按鈕，從勾選的項目中，尋找下一個“搜尋對象”欄位元中的文字/位址，直到尋找完畢。符合的項目會出現在搜尋結果視窗中。有關搜尋視窗的詳細說明，請參考章節 17.1.2.。
 | 取代 | 點擊此按鈕，搜尋符合的文字，然後，用取代欄位元的文字取代。取代的資訊會顯示在搜尋結果視窗中。有關搜尋視窗的詳細說明，請參考章節 17.1.2.。
 | 取代全部 | 取代全部符合搜尋欄位元中的文字/位址。取代的資訊會顯示在搜尋結果視窗中。有關搜尋視窗的詳細說明，請參考章節 17.1.2.。
 | 關閉 | 點擊此按鈕，可結束對話框。


17.1.2. 查找結果視窗

查找結果視窗

查找結果視窗為停靠式視窗，可顯示全部尋找所符合的結果和取代的資訊。下圖為查找結果視窗的範例。雙擊滑鼠左鍵可瀏覽查找/取代清單中的項目。

用戶可以在查找結果視窗中點擊滑鼠右鍵，下表為彈出視窗中的選單項目：

選單項目 | 說明
清除 | 清除所有清單中項目。


17.1.3. 巨集編輯視窗的快速搜尋和替換

巨集編輯視窗的快速搜尋和替換

使用者可在當前巨集編輯視窗中，使用快速搜尋和替換來搜尋文字。符合的項目將逐項顯示，使用者可以檢視每個符合的項目及相關的內容。
 在當前巨集編輯視窗中，快速搜尋和替換可從插入點向下搜尋，搜尋和取代會自動搜尋未搜尋的內容，直到整個巨集搜尋完畢，將出現完成訊息。

註：符合的項目將不會出現在查找結果視窗中。
 欲顯示取代視窗，點擊編輯 > 搜尋和替換選單中，“替換…”選項。下圖為取代視窗的範例。

下表為取代視窗中，各項屬性的說明。

屬性

 說明
查找對象 | 輸入或從剪貼簿貼上欲查找的文字。
代換字串 | 輸入或從剪貼簿貼上欲代換的文字。
需全字符合 | 勾選此選項，只搜尋全字符合的文字/位址，在一個字串中，只有部分字串符合者，將不在搜尋範圍內。
符合大小寫 | 勾選此選項，只搜尋符合在“查找對象”框中，大小寫均符合的字串。
符合大小寫 選擇專案中欲搜尋的部份，如下表：
選項 | 說明
選擇 | 只搜尋或替換當前文件中選取的部份。
全檔案 | 搜尋或替換視窗中，符合查找欄位的部份。
找下一個 | 點擊此按鈕，可從勾選的選項中，尋找下一個符合“查找對象”欄位元中的文字/位址，直到尋找完畢。符合的項目在視窗中會反白顯示。
取代 | 點擊此按鈕，查找符合的文字，然後，用取代欄位元的文字取代。
取代全部 | 取代全部符合查找欄位元中的文字/位址。
取消 | 點擊此按鈕，可結束視窗。


17.2. 畫面全覽

畫面全覽

畫面全覽顯示當前人機應用各畫面間的關係。畫面全覽以直線和箭頭顯示畫面間的連結。連結為畫面間以畫面按鈕或選頁器連結的關係。
 欲開啟畫面全覽，勾選主選單中，檢視 > 畫面全覽選項。下圖為畫面全覽的範例。

選取了畫面或連結後，可進行以下操作：
* 開啟畫面或畫面屬性。
 若畫面未開啟，雙擊縮圖可開啟畫面。
 若畫面已開啟，雙擊縮圖可開啟畫面屬性視窗。

* 移動畫面和連結
 滑鼠左鍵點擊畫面的縮圖並按住不放，當游標變成 [image] 圖標，拖動滑鼠可移動選取的畫面/連結到畫面全覽視窗中的任意位置。移動中的畫面/連結會顯示在畫面的最上層，方便移動畫面/連結。放開滑鼠左鍵即可放置畫面/連線。

以下為畫面全覽視窗中，圖標的說明。

圖標

 工具提示 說明
更新 | 重新載入當前畫面的內容。只有在畫面間的關係改變時，才可點擊此圖標。
新畫面 | 在當前人機應用建立新畫面。
加畫面連結 | 為選取的畫面新增一畫面按鈕，在彈出的視窗中，設定按鈕屬性。選取畫面後，才可點擊此圖標。
加選頁器連結 | 為選取的畫面新增一選頁器，在彈出的視窗中，設定選頁器屬性。選取畫面後，才可點擊此圖標。
放大 | 放大畫面全覽。
縮小 | 縮小畫面全覽。
正常大小 | 回復畫面全覽至正常大小。
顯示內容 顯示畫面所有內容，如右圖。

顯示名稱/編號 | 在矩形方塊中顯示畫面名稱和畫面編號，如右圖。
列印 | 列印人機應用的資訊、畫面索引和畫面全覽。人機應用資訊包含人機名稱、機型、起始畫面、總畫面數、人機應用名稱。畫面索引為顯示全部畫面的清單和畫面所在的頁面編號。
列印預覽

在列印前預覽畫面全覽。下圖為列印預覽視窗的範例。

使用以下的指令，可客制預覽的顯示畫面。

點擊此按鈕 | 操作
列印… | 設定列印選項和列印頁面。
下頁 | 顯示要列印的下一頁。
上頁 | 顯示要列印的上一頁。
整頁 | 在畫面中顯示一整頁。
放大 | 預覽頁面。
縮小 | 縮小預覽頁面。
關閉 | 關閉列印預覽畫面。

在畫面全覽空白處點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選項 | 說明
新增畫面… | 在當前人機應用建立一新畫面，並顯示畫面全覽。
選取全部 | 選取全部畫面與連結。

在選取的畫面點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選項 | 說明
加畫面連結… | 為選取的畫面新增一畫面按鈕，在彈出的視窗中，設定按鈕屬性。
開啟畫面… | 開啟選取畫面。
刪除畫面 | 刪除選取畫面。
畫面屬性… | 開啟畫面屬性視窗。

在選取的連結點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選項 | 說明
插入點 | 在指定的位置插入一個點。
刪除點 | 刪除一個點。
刪除畫面連結 | 刪除選取的連結。
刪除畫面連結和按鈕 | 刪除選取的連結和按鈕。
畫面連結屬性 | 在彈出視窗中，設定畫面屬性，如下圖：


17.3. 連缐全覽

連缐全覽

連線全覽顯示整個專案中，裝置/伺服器和人機間的關係。連線全覽為線和區塊組合的示意圖。區塊代表了目標人機或裝置/伺服器，線代表連線。帶有箭頭的線表示連結關係。
 在連線全覽視窗中，有兩種區塊：目標人機區塊和裝置/伺服器區塊。目標人機區塊包含人機用名稱和支援的連線埠，例如，C代表COM(C1=COM1)，E代表乙太網路埠。裝置/伺服器區塊包含裝置種類。

 欲開啟連線全覽，在檢視選單中，勾選連線全覽項目。以下為連線全覽的範例。

使用者可將游標移至目標人機區塊、裝置/伺服器區塊或連線上，選取相關的項目。選取後，可進行以下的操作：

■ 開啟屬性視窗並設定屬性

雙擊目標人機區塊可開啟一般設置視窗，設定人機應用。

雙擊連線可開啟連線屬性視窗，設定連線。

雙擊裝置/伺服器區塊，開啟連線屬性視窗，選擇連線裝置。

■ 移動區塊
 在欲移動的區塊上，按住滑鼠左鍵不放，等到游標變成 [image] 圖標，拖動滑鼠即可移動區塊。選取的區塊會顯示在視窗的最上層，讓使用者可移動至任意位置。放開滑鼠左鍵即可將區塊放置在所需的位置。

■ 調整連接線
 將滑鼠遊標移至連接線的端點上，拖動端點可調整連接線大小和形狀。

■ 建立連線

1. 將滑鼠游標置於通訊埠端點上，例如：

2. 拖動滑鼠將點移動到另一台人機的裝置/伺服器通訊埠上。例如：

3. 放開滑鼠左鍵開啟連線屬性視窗，設定連線屬性。

4. 按壓確定按鈕，接受連線設定；按壓取消按鈕，取消此連線設定。下圖為兩人機間新連線的設定。

下表為連線全覽視窗中，圖標的說明。

圖標 | 工具提示 | 說明
 | 新增人機應用 | 新增人機應用並在彈出的視窗中設定人機的種類和人機應用名稱。
 | 新增連線 | 在人機上新增連線，並在彈出視窗中設定屬性。只有在目標人機為當前人機時，此選項才有效。
 | 新增裝置/伺服器 | 新增裝置/伺服器。
 | 重新整理 | 重新載入專案中，人機與裝置/伺服器的關係。
 | 顯示關係 | 用線與箭頭顯示人機與裝置/伺服器間的關係。

使用者可在連線全覽的目標人機區塊上點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選單項目 | 說明
新增連線 | 建立新通訊連線。
刪除人機應用 | 刪除人機應用。
人機應用屬性 | 開啟人機應用一般設置視窗。

使用者可在連線全覽的連線上點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選單項目 | 說明
插入點 | 在指定的位置新增點。
刪除點 | 刪除選取的點。
刪除連線 | 刪除一關聯的通訊連線。
連線屬性 | 開啟關聯連線的連線屬性視窗。

使用者可在連線全覽的空白處上點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選單項目 | 說明
新增裝置/伺服器 | 新增裝置/伺服器 。
新增人機應用 | 新增人機應用。
重新整理 | 重新載入專案中，人機與裝置/伺服器間的關係。

使用者可在連線全覽的裝置/伺服器區塊上點擊滑鼠右鍵，將出現彈出式選單，選單包含以下選項：

選單項目 | 說明
刪除裝置/伺服器 | 刪除選取的裝置/伺服器。
裝置/伺服器屬性 | 開啟連線屬性視窗。


17.4. 物件庫

物件庫

物件庫視窗為一停靠式視窗。利用物件庫可使物件設置、管理和共用變得更容易。它包含預設物件、一般物件、物件群和全局物件。

■ 預設物件
 每一種物件均有一預設物件，此預設物件存於物件庫中。每一種物件新建物件的設定即為預設物件之設定。欲檢視所有專案中的預設物件，可點擊物件庫視窗上方“Objects”標籤。

 使用者可以設定任何物件為該種類物件的預設物件。當設定一新的物件為預設物件，原本的預設物件將會捨棄不用。欲設定一物件為預設物件，在物件上點擊滑鼠右鍵，從彈出式選單中，點選“存為預設值”。

■ 一般物件/物件群
 一般物件/物件群可在全專案中使用。欲檢視一般物件/物件群， 使用者可以點擊視窗中的標籤。

 欲設定物件為一般物件/物件群，使用者可在物件/物件群上點擊滑鼠右鍵，從彈出的選單中，點擊“存到物件庫…”指令，開啟存到物件庫 視窗。在視窗中，輸入名稱並選擇一存入類別。

■ 全局物件

全局物件可在全專案中使用，任何全局物件的修改會適用於專案中的所有全局物件上。欲檢視專案中所有全局物件，使用者可點擊視窗中的“Global”標籤。

 欲設定物件為全局物件，在物件/物件群上點擊滑鼠右鍵，開啟彈出選單，點擊“存為全局物件…”指令，開啟存為全局物件 視窗。在視窗中，輸入名稱並選擇一存入類別。

 欲開啟物件庫，勾選主選單中檢視 > 物件庫選項，下圖為物件庫全覽的範例。

使用者可在物件庫視窗上方點擊滑鼠右鍵，將出現以下的選單項目：

選單項目 | 說明
新增類別… | 新增一般物件/物件群的類別。左圖為新增類別視窗的範例，使用者可在此視窗中設定類別名稱和物件顯示的圖標大小。
刪除類別… | 刪除選取的類別。
類別屬性… | 點擊此指令，會出現下圖的視窗。使用者可在此視窗中，更改類別名稱和物件顯示的圖標大小。
導入物件庫… | 從物件庫檔案(*.pol)導入現有的類別。
導出物件庫… | 導出物件庫中選取的類別為物件庫檔案(*.pol)。
清除物件庫內無用數據 | 點擊此指令，清除選取類別中，無用的物件。

使用者可以在全局類別視窗或使用者定義類別視窗中，在物件上點擊滑鼠右鍵，彈出選單中將出現以下項目：

選單項目 | 說明
重新命名物件… | 點擊此選項，開啟重新命名視窗，更改選取物件的名稱。
刪除物件… | 刪除選取物件。
物件屬性… | 點擊此選項，開啟物件屬性視窗，此屬性只存在於在全局物件。


17.5. 物件表

物件表

物件清單視窗為一停靠式視窗，顯示畫面物件和關聯的輸出入地址。
 使用者可以在物件表視窗中雙擊目錄項目，即可在開啟的物件屬性對話框，修改物件屬性。
 使用者可在物件表視窗空白處點擊滑鼠右鍵，然後，在彈出式選單中，勾選欲顯示的欄位，如：編號、寫入、監視、讀取、通知、觸控致能地址、顯示致能地址、註；勾選選擇全部，即可顯示所有欄位。

 欲開啟物件表，在主選單中，勾選檢視 > 物件表項目。下圖為物件表的範例。


17.6. 輸出入表

輸出入表

輸出入表視窗為一停靠式視窗，可顯示所有專案的輸出入位址和使用者。
 在輸出入表視窗中，雙擊滑鼠右鍵可修改每個項目。
 若位址被物件使用，可在關聯物件的屬性對話框中，重新定義位址。
 若位址被巨集使用，可在巨集編輯器視窗中，重新定義位址。

 使用者可在地址欄位直接輸入地址。
 欲開啟輸出入表，在主選單中，勾選檢視 > 輸出入表項目。下圖為輸出入表的範例。


18.1. 編譯人機應用

編譯人機應用

使用本軟體提供的編譯功能，可驗證所有設定和規劃的正確性、控制器的通訊設定等，並將巨集指令轉換成可執行的機器碼和建立人機運行所需的數據。人機運行數據為當前人機應用在人機上執行時所需的數據。使用者編譯人機應用後，將產生人機運行數據 包(PRP)並儲存人機運行數據為PL2或PL3檔案。


18.1.1. 編譯人機應用

編譯人機應用

欲編譯人機應用，可依以下步驟進行：

  1. 在功能列中，點擊“人機”，在彈出的下拉式選單中，點選 [image] “編譯…”。
     或在圖示工具列上，點擊 [image] 編譯圖示。

  2. 彈出編譯人機應用 視窗，顯示編譯的進度，欲取消編譯操作，點擊取消按鈕。下圖為正在進行編譯的編譯人機應用視窗的範例。

  3. 在編譯完成後，編譯人機應用 視窗會顯示人機運行數據的錯誤個數、警告個數和檔案大小。詳細的數據會顯示在工作執行清單視窗中。有關工作執行清單的詳細說明，請參考章節 18.1.3 工作執行清單。

下表為編譯完成後的觸控屏運行數據視窗和工作執行清單視窗。

編譯結果 | 編譯視窗與工作執行清單
編譯失敗 | 如果使用者程序設置有錯誤，編譯完成後的觸控屏數據視窗會提示錯誤數量和警告數量。
编譯成功 | 編譯完成後的觸控屏運行數據視窗會顯示出整個應用的檔案大小。當前應用程序運行時的數據將​​被保存到一個"應用名稱".pl3文件下。擴展運行數據將被保存在另一個擴展存儲裝置（如內建C:或USB隨身碟）。你需要在『一般設定』視窗中指定擴展運行數據的保存位置。詳細設置請參考第3.1.2 節 自定義設置
目標人機為本運行軟體機型且編譯成功 | 編譯完成後的觸控屏運行數據視窗會顯示出整個應用文件的大小和靜態I/O點數。當前應用程序運行時的數據將​​被保存到一個"應用名稱".pl3文件下。可以在工作執行清單查看詳細的I/O點的統計數據，包括位的I/O點數，字的I/O點數，索引字和索引位計數。
編譯提示 | 提示安全關機，當HMI有使用電池記憶体當儲存資料時编譯後出现的警告说明。


18.1.2. 產生人機運行包（PRP）檔案

產生人機運行包（PRP）檔案

人機運行包(Panel Runtime Package)包含人機運行數據和系統程式，欲建立人機運行包(PRP)，可依以下步驟進行：

  1. 在功能列上，點擊“人機應用”，接下來在彈出的下拉式選單中，點擊“產生人機運行包(PRP)檔案…”

  2. 如果編譯成功，使用者需要在：『另存新檔』視窗設定欲儲存的檔名。

註: PRP檔為可攜帶式的檔案，內容是人機應用的執行檔。也就是說，使用者可以將PRP檔儲存在PC或USB隨身碟上，然後在未安裝本軟體的情形下，使用PC或USB隨身碟即可對目標人機進行下載應用的動作。

PRP 密碼

當軟體成功編譯了PRP檔（人機運行包）時會告訴你一個我們所說的PRP密碼。你執行更新HMI的PRP檔需要密碼時，你可以使用它。在過去，如果別人是負責用PRP檔更新HMI，你需要給那個人開發者的密碼。由於開發者密碼幾乎可以讓一個人在HMI上做任何操作，給予了開發者的密碼是有風險的。現在，隨著提供的PRP密碼，你將不再有這種擔憂。

注意事項:

1) PRP密碼是從專案的開發者密碼產生。如果開發者密碼不改變一個專案的PRP密碼將保持不變。

2) 開發者密碼仍然是可以使用於更新HMI產品的PRP檔。產生PRP檔的同時會提供一組PRP密碼，當您使用 PC或USB隨身碟對目標人機進行下載 此PRP應用的操作時請輸入此組密碼才能正常下載此PRP到人機。

3) 僅在HMI產品使用V2.0.5.00的OS或更高版本的OS時能夠使用此PRP密碼。


18.1.3. 工作執行清單

工作執行清單

工作執行清單中會顯示所有資訊，包含：編譯過程、錯誤訊息、警告訊息。工作執行清單視窗為停靠式視窗，在視窗中，錯誤訊息前會顯示紅色圓圈 ( [image] ) ，警告訊息前會顯示黃色三角形( [image] )。

下圖為工作執行清單視窗的範例：

用戶在工作執行清單視窗中，點擊滑鼠右鍵，在彈出的右鍵選單出現以下項目：

選單項目 | 說明
清除 | 清除視窗中所有的項目


18.2. 模擬運行人機應用

模擬運行人機應用

模擬運行可驗證專案規劃的正確性。使用模擬運行功能，使用者不必下載人機應用到目標人機，在PC上即可模擬人機應用在人機上運行的情況。
 本軟體提供以下兩種模擬方式：模擬運行(連線)和模擬運行(離線)。


18.2.1. 模擬運行(連綫)/(離綫)

模擬運行(連線)/(離線)

類型 | 說明
模擬運行(離線 ） | 在模擬運行(離線)模式，PC將會建立一個記憶區給裝置/伺服器的暫存器使用。模擬器將與電腦的記憶體通訊，因此在離線模擬時不會產生通訊錯誤。 離線模擬可用於畫面虛擬效果和物件操作邏輯驗證。
模擬運行(連線) | 模擬運行(連線)時，PC將以人機應用與裝置/伺服器做直接通訊，而非與PC的記憶體中的虛擬暫存器做通訊。 連線模擬可用於通訊問題的除錯。


18.2.2.模擬運行人機應用

模擬運行人機應用

欲模擬運行人機應用，可依以下步驟進行：

  1. 在模擬器開始執行時，須先儲存與編譯人機應用。

  2. 在功能列中，點擊“工具”，在彈出的下拉式選單中，點 擊“模擬運行(離線)…”。或在圖示工具列中，點擊模擬運行(離線)圖示 [image] 。使用PanelSim.exe執行檔(可單獨執行的程式)：PanelSim.exe。點擊開始 -> 所有程式 -> 軟體 -> [image] PanelSim

  3. 在 PanelSim 視窗中，點擊Run按鈕開始模擬。

註：如果在本軟體上模擬運行，會顯示上圖的視窗，並在開始進行模擬前自動關閉此視窗。在此情況下，使用者不需對此視窗進行設定。

  4. 在模擬器視窗上模擬運行人機應用，模擬器視窗的外觀與目標人機相似。下圖為模擬器視窗運行人機應用的畫面。


18.3. PC與人機間的數據傳輸

PC與人機間的數據傳輸

在本軟體中，每當目標人機運行時，用戶可以透過序列埠(Serial port)、乙太網路和USB傳輸運行數據。
 用戶也可使用Micro SD卡或USB隨身碟來更新人機應用。


18.3.1. 下載數據至觸控屏

下載數據至觸控屏

1. 欲使用本軟體下載數據，可依以下步驟進行：
 在功能列中，點擊『人機應用 』，在彈出的下拉式選單中，選擇 [image] 『下載數據到觸控屏』。或在圖示工具列上，點擊下載圖示 [image] 。

2. 在 『下載數據至觸控屏』視窗，可進行選項的選擇和設定。下圖為下載數據至觸控屏的範例：

註：如果人機應用被修改，在下載數據前，本軟體會自動編譯人機應用。

下表為下載數據選項中，各項屬性的說明。

屬性 | 説明
數據源 | 選擇欲下載的數據。“當前人機應用”為軟體編譯後產生的數據；“人機運行包(PRP)檔案”，包含當前人機應用數據與系統程式。若選擇人機運行包(PRP)檔案，需再選擇欲下載的PRP檔。
下載 | 勾選欲下載的項目，包含：運行數據和系統程式、應用規劃數據、時間和日期。只有數據源為當前人機應用，才會出現此選項。 使用者可選擇應用規劃數據，將人機應用備份到目標人機中。數據的格式與PLF檔相同。 註:只有勾選將人機應用規劃數據下載到HMI，日後您才能將它上載回來並且可以重新編輯或是修改HMI的應用畫面。
保留人機原數據 | 勾選保留人機原數據中的使用者數據($N)、警報記錄、配方數據、取樣數據，即是在下載後，人機仍保留所選擇的數據項目，而不會被清除。 須符合以下條件，選取項目的數據將才會被保留： 1) 原人機應用使用軟體版本為V1.2.26或之後的版本編譯或下載。 2) 在新舊人機應用中，電池保護記憶區、配方區、數據收集器、警報區和警報記錄記憶區的設定必須一致。
連線設置 | 選擇下載數據所使用的通訊埠。
 | 通訊埠 | 說明
 | COM | 使用序列埠(serial port)下載數據，並選擇通訊埠和速率。
 | 乙太網路 | 使用乙太網路下載數據，輸入目標人機的IP位址或從清單中選擇最近連接過的網路。
 | USB | 使用USB下載數據，在使用USB線下載數據前，須先安裝USB的驅動程式。關於USB驅動程式的詳細說明，請參考章節 18.3.3。
 | 若目標人機有足夠的記憶體，可在安全模式下傳輸數據。
 | 模式 | 說明
 | 直接模式 | 下載數據至快閃記憶體。
 | 安全模式 | 將下載數據先緩存於目標人機的工作記憶體中，可防止在下載時出現錯誤。在傳輸成功後，工作記憶體中的數據才會被燒寫於快閃記憶體中。
狀態 | 顯示傳輸的狀態和進度。
開始 | 點擊此按鈕開始下載數據。
取消 | 取消下載。
關閉 | 關閉視窗。

註：點擊 圖示工具列上的 [image] 圖示，即可使用“立即下載”視窗中的設定，立即下載數據至目標人機中。


18.3.2. 上載運行數據至電腦

上載運行數據至電腦

欲使用本軟體上載儲存於人機中的運行數據包(prp)，可依以下方式進行：

  1. 在功能列中，點擊人機應用，在彈出的下拉式選單中，選擇上載數據至電腦…。
  2. 在上載數據至電腦視窗中，進行設定後即可上載。

下圖為上載數據至電腦視窗的範例。

下表為上載數據至電腦視窗中，各項屬性的說明。

屬性 | 說明
上載 | 選擇欲上載的數據類別，一為運行數據和系統程式，另一選項為人機應用規劃數據。請指定要儲存上載的數據到指定的檔案名。 要上載人機應用規劃數據的前提是：該 HMI 原設計者有將其應用規劃數據下載到該台 HMI，此上載的應用規劃數據為PLF檔案格式，用戶可將此PLF檔導入現有人機應用編輯軟體中，然後就可以重新編輯該應用。
連線設置 | 選擇上載數據所使用的通訊埠。
 | 通訊埠 | 說明
 | COM | 使用序列埠(serial port)上載數據，並選擇通訊埠和速率。
 | 乙太網路 | 使用乙太網路上載數據，輸入目標人機的IP位址或從清單中選擇最近連接過的網路。
 | USB | 使用USB上載數據，在使用USB線上載數據前，須先安裝USB的驅動程式。關於USB驅動程式的詳細說明，請參考章節 183.3。
狀態 | 顯示傳輸的狀態和進度。
開始 | 點擊此按鈕開始下載數據。
取消 | 取消下載。
關閉 | 關閉視窗。


18.3.3. 使用USB缐傳輸數據和安裝USB驅動程式

使用USB缐傳輸數據和安裝USB驅動程式

本章節說明如何安裝USB驅動程式，從微軟Winodws系統的 PC，下載人機應用至目標人機。

步驟1: 以Administrator身分登入。

步驟2: 用USB線連接目標人機和電腦。

步驟3: 開始安裝驅動程式。

使用者可從以下的方式，選擇適合的方式安裝驅動程式：

■ 尋找新增硬體精靈
 啟動目標人機，Windows會自動彈出“尋找新增硬體”視窗，引導您安裝驅動程式。

■ 硬體更新精靈

若未出現“硬體更新精靈”視窗或視窗已關閉，依以下步驟可使視窗出現：
1. 在我的電腦上點擊滑鼠右鍵，然後選擇管理。
2. 在系統工具下，點擊裝置管理員。
 在右邊的頁面中會列出安裝在電腦所有裝置。
3. 展開其他裝置。
4.在Neo HMI上點擊滑鼠右鍵，並選擇屬性。

5. 點擊驅動程式標籤頁，然後選擇更新驅動程式，即開始更新驅動程式。

步驟4: 依指示安裝驅動程式

1.點擊下一步(Next)。

2. 點擊從清單或特定位置安裝 (進階)，然後選擇下一步。

3. 點擊在這些位置中搜尋最好的驅動程式，然後，選擇搜尋時包含這個位置。點擊瀏覽，選擇\安裝目錄\USB，為驅動程式的檔案夾，然後點擊下一步。

4. 若出現以下視窗，點擊"繼續安裝"。

步驟5: 點擊完成即可完成Neo HMI 驅動程式的安裝。

註：當第一次連接目標人機與電腦上的USB埠，須先安裝驅動程式。

在安裝驅動程式後，支援USB傳輸的人機，即可使用USB線與電腦連接，傳輸數據。在本軟體中，須先在下載數據至觸控屏/上載數據至電腦視窗中，選擇USB為傳輸方式，才可使用USB傳輸數據。


19.1. 設置/開始/結束/穿透通訊

設置/開始/結束/穿透通訊

穿透通訊為一序列埠(serial port)的通訊模式，透過人機連接PC和裝置/伺服器，並取得數據，通訊方式如下圖所示。人機在此通訊模式中，如同一可穿透的裝置，作為PC與裝置/伺服器可直接通訊的工具。


19.1.1. 設置穿透通訊(序列埠)

設置穿透通訊(序列埠)

欲使目標人機可穿透，取得或控制PC上的裝置數據，須設置穿透通訊。

欲設置穿透通訊，點擊主選單中的工具，然後，從次選單中，點選設置穿透通訊…

下圖為穿透通訊連線和設置穿透通訊對話框的範例。

如果目標人機中的人機應用，其連線設定與目標人機和裝置/伺服器間的實際連接設定相同，只需要按壓 [image] 按鈕，在開始穿透通訊前，即可從

人機取得所有通訊參數。

下圖為目標人機與裝置/伺服器連線設定的範例。

註：在連線屬性對話框中，通訊參數的設定，必須與裝置/伺服器的通訊參數一致。

 如果目標人機沒有人機應用或連線的設定與實際連接不一致，在開始穿透通訊前，用戶需在對話框中重新設定通訊參數。


19.1.2. 設置穿透通訊(乙太網)

設置穿透通訊(乙太網)

當用户利用PLC軟體監控或修改一些PLC的數據或設置時，PLC唯一的COM口被用來與人機相連。除了斷開PLC與人機的鏈接，把PLC與電腦連接之外，還能怎麼做了？這裏有一個解決方案。我們的人機軟體允許用户使用人機介面作為乙太網串口轉換器，因此，可以提供給PLC一個虛擬的COM埠，PLC利用這個虛擬的COM埠通過乙太網和人機介面通信。由於這一特點，在只有一個串口的情況下，同時運行操作介面和PLC程式比以前更加簡單方便。要先把Panel Setup上的『允許乙太網穿透通訊』設置打開。

 下圖是一個連接的實例：

為了安裝通過乙太網的穿透通信服務驅動，請按照以下步驟：

1).使用“管理員身份”運行人機軟體。

2).單擊菜單“工具>穿透通訊> 乙太網穿透>設置”，打開通過 乙太網穿透通訊的設置對話框。

3).如果在乙太網穿透通訊設置對話框中，虛擬串口驅動程式的的狀態是“未安裝”，點擊安裝按鈕安裝這個驅動。如果虛擬串口驅動已經安裝，那麼不需要重複安裝。

4) 在安裝的過程中，當驅動程式已在本地磁片中時，跳過windows系統提供的自動搜索驅動程式/軟體。

5) 安裝完成以後，會顯示以下對話框。

下表為對話框中，各項屬性的說明。

屬性 | 說明
電腦序列埠 | 安裝的驅動提供虛擬序列埠。你需要設定PLC 軟體使用這個串口與PLC通信。
觸控屏IP 地址 | 被用來作為乙太網串口轉換器的人機的IP 地址。默認的地址是192.168.0.100.。
觸控屏序列埠 | 人機在物理上連接到PLC 的串口。默認的是COM1。

乙太網的穿透通信開始或結束，請執行以下操作：
1）將HMI設備連接到LAN並打開其電源。運行触摸屏人機設置。

a. 按一般設定按鈕，打開 一般設定對話方塊。

b. 把一般設定裏面的允許乙太網穿透通訊選項設置為是。

c. 按“正確”按鈕保存設置。

2) 運行該軟體。
a. 點擊功能表項“工具|穿透通信|乙太網穿透|設置...”，彈出乙太網穿透通訊設置對話方塊。
b. 請確認虛擬串口驅動程式的狀態為“已安裝”。
c. 記住PC的COM口，即由觸控屏軟體提供的虛擬COM口，連接PLC軟體。
d. 設置電腦的IP地址到HMI設備的IP地址。
e. 設置觸摸屏的COM埠到HMI設備連接到PLC的序列埠。
f. 點擊“開始穿透通訊”按鈕。當它進行穿透通信時，在HMI設備將顯示訊息方塊如圖所示。

g. 點擊結束按鈕退出對話方塊。

3) 運行PLC軟體。

a. 設置由軟體提供的串列通信口的虛擬COM埠。

b. 開始您的操作。

4) 要結束的穿透通信，首先關閉PLC軟體然後在軟體的功能表欄上單擊功能表項“工具|穿透通信| |乙太網穿透|結束”。


19.1.3. 開始/结束穿透通讯

開始/结束穿透通讯

■ 開始穿透通訊
 欲開始穿透通訊，可依以下步驟進行：
1. 在設置穿透通訊對話框中，點擊 [image] 按鈕。

2. 在主選單中，點擊工具，然後，再從次選單中，選擇開始穿透通訊。

 如果穿透通訊已成功建立，目標人機上會顯示如下圖的對話框，可控制和取得PC上的數據。

■ 結束穿透通訊
 欲結束穿透通訊，可依以下步驟進行：
1. 在設置通透通訊對話框，點擊 [image] 按鈕。

2.在主選單中，點擊工具，然後，再從次選單中，選擇結束穿透通訊。
3. 點擊人機上的結束按鈕。


19.2. 數據傳輸幫手 (Data Transfer Helper)

數據傳輸幫手 (Data Transfer Helper)

Data Transfer Helper (DTH)為一可獨立執行的程式，用戶可利用DTH透過序列埠(serial port)或乙太網路取得/更新人機應用數據。

 欲執行DTH，可從開始 > 所有程式 > “本軟體” > [image] Data Transfer Helper (DTH)。

 用戶可使用DTH從PC下載配方數據或 OS & AP到HMI。使用DTH，用戶也可以從HMI取得歷史數據、操作記錄、警報計數、歷史警報、配方數據、OS & AP和將數據以指定的格式，儲存為在PC上。下圖為Data Transfer Helper對話框的範例。

下表為Data Transfer Helper (DTH)對話框中，各項屬性的說明。

屬性 | 說明
操作類別 | 選擇欲在目標人機上進行的操作。
連線設置 | 選擇連接目標人機的通訊埠。
 | 通訊埠 | 說明
 | 序列埠(串口) | 使用序列埠(serial port)連接目標人機，並選擇通訊埠與速率。
 | 乙太網 | 使用乙太網路連接目標人機，輸入目標人機的IP位址或從清單中選擇最近輸入過的項目。
密碼 | 輸入用戶等級8或以上的有效密碼。
狀態 | 顯示傳輸狀態和進度
停止 | 停止通訊
下一步 | 如果通訊已成功建立，點擊此按鈕可開始操作並進行操作屬性的設定。
結束 | 離開對話框
取消 | 取消操作。


19.2.1. 數據傳輸幫手 - 操作設置

數據傳輸幫手 - 操作設置

下表為DTH所支援的所有操作類別和其設定方式。

操作類別 | 設定
取得數據收集器數據 (.csv/.txt) | 將數據收集器所收集的數據儲存為指定的檔案。 上圖的對話框列出人機應用中所有的數據收集器。此對話框中，需進行以下設定： * 勾選欲取得數據的數據收集器。 * 點擊時間範圍(Time Range) 欄位的 [image] 按鈕，開啟時間範圍對話框，設定收集數據的期間。關於時間範圍對話框的詳細說明，請參考章節 19.2.3。 * 輸入檔案名稱或點擊Save To(File Name) [image] 按鈕，開啟開啟舊檔對話框，設定檔案名。
取得操作記錄(.csv/.txt) | 儲存操作歷史記錄為txt檔或csv檔。 此對話框中，需進行以下設定： * 點擊 [image] 按鈕，開啟時間範圍對話框，設定操作歷史數據的期間。關於時間範圍對話框，請參考章節 19.2.3 * 輸入檔案名稱或點擊 [image] 按鈕，開啟開啟舊檔對話框，設定檔案名。
取得警報計數(.csv/.txt) | 儲存警報計數為txt檔或csv檔。 輸入檔案名稱或點擊 [image] 按鈕，開啟開啟舊檔對話框，設定檔案名，格式可為txt或csv。
取得警報歷史(.csv/.txt) | 儲存警報歷史為文字檔或csv檔。 此對話框中，需進行以下設定： * 點擊 [image] 按鈕，開啟時間範圍對話框，設定警報歷史的期間。關於時間範圍對話框，請參考章節 19.2.3 * 輸入檔案名稱或點擊 [image] 按鈕，開啟開啟舊檔對話框，設定檔案名。
取得配方數據(.csv/.txt/.prd) | 儲存配方區數據為CSV/TXT/PRD檔。 上述對話框顯示人機應用中的所有配方區。在此對話框中可進行以下設定： * 勾選欲取得數據所在的配方區。 * 輸入檔案名稱或點擊Save To(File Name) [image] 按鈕，開啟舊檔對話框，設定檔案名。
更新配方數據(.csv/.txt/.prd) | 從CSV、TXT或PRP檔更新配方數據。 上述對話框顯示人機應用中的所有配方區。在此對話框中可進行以下設定： * 勾選欲更新數據所在的配方區。 * 輸入檔案名稱或點擊From(File Name) [image] 按鈕，開啟舊檔對話框，設定檔案名。
取得OS & AP (.prp) | 用戶需輸入正確的開發者密碼，以取得並儲存系統程式和人機應用運行數據 (PRP檔)。
更新OS & AP(.prp) | 從指定的PRP檔更新系統程式和人機應用運行數據，原始的系統程式和人機應用運行數據將會被新的所取代。


19.2.2. 操作狀態

操作狀態

操作狀態對話框中將顯示所有操作歷史和狀態。下圖為操作狀態對話框的範例。


19.2.3. 時間範圍

時間範圍

時間範圍對話框可設定收集數據的時間範圍。

下表為時間範圍對話框中，各項屬性的說明。

屬性 | 說明
全部 | 選擇此選項，取得關聯記憶區的所有數據。
前(一)天 | 擇此選項，取得數天前的數據。勾選包含今天，即可取得今天的數據。
前(一)小時 | 選擇此選項，取得數小時前的數據。勾選包含當前小時，即可取得當前小時的數據。
自訂 | 選擇此選項可自訂數據收集的期間，需設定起始/結束日期和時間。


19.3.1. 導出文字

導出文字

用戶可從當前人機應用導出文字檔為PTX檔，PTX檔可在PM TextEditor中開啟及編輯，詳細說明，請參考章節 19.3.3.。
 欲導出人機應用的文字，在主選單中，點擊工具；然後，從次選單中，選擇導出文字…。

 下圖為導出文字對話框的範例。

註：如果人機應用只使用一種語言，導出文字的操作將無效。


19.3.2. 導入文字

導入文字

用戶可以從PTX檔導入文字到人機應用。

欲導入人機應用的文字，在主選單中，點擊工具，然後，再從次選單中，選擇導入文字…。

下圖為導入文字對話框的範例

下表為導入文字對話框中，各項屬性的說明。

屬性 | 說明
人機應用 | 選擇欲儲存導入文字的人機應用。
導入選擇 | 勾選要導入的語言。
開啟… | 點擊此按鈕，開啟PTX檔。 註：人機應用中須包含與導入的PTX檔中相同的語言名稱，否則將無法導入。
關閉 | 關閉此對話框。
導入條件 | 選擇相同用途選項，導入與檔案來源有相同用途的文字。 選擇相同參照文字，導入與參照文字相同的文字。
導入 | 點擊此按鈕導入所有選取的文字。


19.3.3. 文字編輯器

文字編輯器

文字編輯器(TextEditor) 為一個可獨立執行的程式，它可用來編輯所有畫面中的多語言文字。
 欲執行TextEditor，可從開始 > 所有程式 > “本軟體” > [image] TextEditor。或在主選單中，點擊工具；然後，從次選單中，選擇TextEditor。

下圖為TextEditor的範例:

下表為工具列上所有按鈕的說明。

圖示 | 圖示提示 | 說明
 | 開啟舊檔 | 開啟PTX檔案，用戶可以使用導出文字工具建立PTX檔。關於導出文字，請參考章節 19.3.1。
 | 儲存檔案 | 儲存當前的PTX檔。
 | 剪下 | 剪下選取的項目並暫存於剪貼簿。
 | 複製 | 複製選取的項目並暫存於剪貼簿。
 | 貼上 | 將剪貼簿上的內容置於當前畫面。
 | Alt+Dn | 將選取項目移至前一專案。
 | Alt+Up | 將選取項目移至次一專案。


19.4.配方編輯器

配方編輯器

Recipe Editor為一個可獨立執行的程式，它可用來檢視和編輯儲存在PC上PRD檔的配方數據。
 欲執行Recipe Editor，可從開始 > 所有程式 > “本軟體” > [image] RecipeEditor

 用戶可設定以列為主或以行為主顯示配方數據。

下圖為以列為主的RecipeEditor範例。以列為主表示以列顯示配方編號，用戶可點擊工具列上的 [image] 按鈕或使用檢視選單中的以列為主指令，使配方數據以列為主顯示。

下圖為以行為主的RecipeEditor範例。以行為主表示以行顯示配方編號，用戶可點擊工具列上的 [image] 按鈕或使用檢視選單中的以行為主指令，使配方數據以行為主顯示。


20.1. 系統畫面

系統畫面

系統畫面為內建於人機應用中且可被用戶使用的畫面。系統畫面為視窗畫面，每一個系統畫面最上方為抬頭列，顯示一行文字代表此畫面的用途。用戶可按住抬頭列不放，移動視窗畫面至所需的位置，然後，放開滑鼠即可將畫面置於所需的位置。

 系統畫面包含：
     內建鍵盤，做為輸入數值、ASCII字元和密碼使用。
     選擇檔案視窗和更名視窗，做為檔案操作使用。

 使用內建鍵盤，可省下規劃客制鍵盤的時間。


20.1.1. 數值鍵盤

數值鍵盤

當按壓數值輸入物件、字按鈕物件和配方表物件，人機將顯示數值鍵盤，用以輸入數值。下圖為數值鍵盤的範例。

本產品支持多語言文字為方便更好的操作鍵盤按鍵，鍵盤可以通過多種語言來展示。只要在專案.. 語言中選擇語言字集為 Chinese (PRC) 或 Chinese (Taiwan) 就會得到如下的鍵盤畫面。

十進制數值鍵盤 | 十六進制數值鍵盤 | 八進制數值鍵盤

下表為數值鍵盤畫面中，各操作項目的說明。

項目 |  | 說明
抬頭列 |  | 按住抬頭列不放，可移動畫面視窗。
鍵盤顯示 |  | 顯示當前所輸入的數值。
可輸入範圍顯示 |  | 顯示可輸入的數值範圍。
按鈕 | + | 按壓此按鈕，數值增加一。
 | - | 按壓此按鈕，數值減少一。
 | 0-7 | 按壓八進制數值鍵盤的數位按鈕，輸入數位0到7。
 | 0-9 | 按壓十進制數值鍵盤的數位按鈕，輸入數位0到9。
 | 0-F | 按壓十六進制數值鍵盤的數位按鈕，輸入數位0到F。
 |  | 按壓此按鈕，打開計算器，你可以利用計算器進行簡單的運算，如加、減、乘、除。有關計算器的詳細資訊，請參考第20.1.2節。
 | 離開(Esc) | 按壓此按鈕，關閉畫面並放棄所有改變的設定。
 | 清空(Clr) | 按壓此按鈕，清除輸入的數值。
 | 刪除(Del) | 按壓此按鈕，刪除前一個輸入的字元。
 | 輸入(Ent) | 按壓此按鈕，關閉鍵盤畫面並接收全部改變的設定。


20.1.2. 計算器

計算器

當按壓此按鈕 [image] ，人機將顯示十進制的計算器鍵盤。可以運用這個執行運算的計算器立即進行一些簡單的運算，比如加、減、乘、除。使用此計算器，用戶通過按壓按鍵來進行每一步的操作，在顯示最終計算結果之前，通過按壓計算器的按鍵可以計算所有的中間計算結果。用戶在按下下一步操作之前，上一步的操作已經被執行，因此，在一個數學運算中，不用考慮操作順序的問題。計算器最多可輸入13個字元，包括數字，+/-符號和 小數點，以下是一個計算器的例子。

下表為計算器鍵盤畫面中，各項目的說明。

項目 |  | 説明
抬頭列 |  | 按住抬頭列不放，可移動鍵盤畫面視窗。
M |  | 當有存儲值時，“存儲值M”會顯示在左側。
鍵盤顯示 |  | 顯示當前所輸入的數值，中間計算結果或者錯誤資訊。在使用計算器過程中，用戶如果有一些錯誤，計算器將會顯示資訊提示錯誤，也許還有一些進一步的描述性資訊。對於某些錯誤 ，計算器的功能會被禁用，您需要按下C或CE按鈕來清除錯誤。
按鈕 |  | 清除記憶體，按壓此按鈕清除計算器的存儲數值。
 |  | 回復記憶體，按壓此按鈕恢復並顯示計算器的存儲數值。
 |  | 記憶區數值加，按壓此按鈕將計算器記憶區數值與當前值相加，點擊MR，查看相加結果。
 |  | 記憶區數值減，按壓此按鈕將計算器記憶區數值減去當前值，點擊MR，查看相減結果。
 |  | 清除輸入，按壓此按鈕擦除最後一個輸入的數值或者執行的操作，例如 計算結果：3.（輸入數值3被清除）
 |  | 清除，按壓此按鈕移除之前所有的輸入。例如 計算結果：1
 |  | 按壓此按鈕，移除計算器的當前值，按壓一次移除一位。
 | 0 ~ 9 | 按壓數字鍵，輸入數字0 ~ 9。
 |  | 按壓此按鈕，執行除法操作。
 |  | 按壓此按鈕，改變計算器當前值的符號。為了得到正確的計算結果，+/- 號按鈕一定要最後按壓，雖然在公式中，- 號不是最後才標記的。
 |  | 按壓此按鈕，執行乘法操作。
 |  | 按壓此按鈕計算當前值的平方根，注意，先輸入數值，然後按壓此按鈕。
 |  | 按壓此按鈕，執行減法操作。
 |  | 按壓此百分比按鈕，將一個算術運算的結果顯示為百分比的形式。 計算結果：31.25
 |  | 按壓此按鈕，輸入一個十進位的小數點，用於從十進位數的整體中分開小數部分。
 |  | 按壓等於按鈕顯示一個數學運算的結果。一個數學運算中可，此按鈕以用來確認中間運算結果。還有一種可能的情況就是，操作沒有執行完成的時候，按壓此按鈕，可以通過按壓此按鈕，確認是否有操作正在執行。
 |  | 按壓此按鈕，執行加法操作。
 |  | 按壓此按鈕，計算當前值的倒數數值。
 |  | 按壓此按鈕關閉計算器鍵盤畫面，並根據計算結果對目標數值進行更改。
 |  | 按壓此按鈕關閉計算器鍵盤畫面，並忽略所有通過計算器執行的操作。


20.1.3. 字元鍵盤

字符鍵盤

當按壓字符輸入物件，人機將顯示ASCII字符鍵盤，用以輸入ASCII字符。下圖為字符鍵盤的範例。

下表為字符鍵盤畫面中，各項目的說明。

項目 |  | 說明
抬頭列 |  | 按住抬頭列不放，可移動畫面視窗。
鍵盤顯示 |  | 顯示當前所輸入的數值。
按鈕 | 字元 | 按壓此按鈕輸入ASCII字符。
 | 離開(Esc) | 按壓此按鈕，關閉此畫面並放棄所有改變的設定。
 | 清空(Clr) | 按壓此按鈕，清除輸入的字符或數值。
 | 刪除(Del) | 按壓此按鈕，刪除前一個輸入的字符。
 | 輸入(Ent) | 按壓此按鈕，關閉鍵盤畫面並接收全部改變的設定。


20.1.4. 拼音和ASCII字元鍵盤

拼音和ASCII字符鍵盤

用戶按下和釋放字符集為：Unicode（中文簡體常用與次常用字）的字符輸入器的時候，目標人機會顯示拼音和ASCII字符鍵盤 ，可用來輸入中文。下面是拼音和ASCII字符鍵盤的例子。

下表為拼音和ASCII字符鍵盤畫面中，各項目的說明。

項目 |  | 說明
抬頭列 |  | 按住抬頭列不放，可移動畫面視窗。
漢字或ASCII字符顯示 |  | 顯示當前所輸入的漢字或ASCII字符。
拼音顯示 |  | 顯示當前輸入的拼音。
顯示可能的字符 |  | 列表顯示拼音拼出的可能的字符。
按鈕 | 清空 | 按壓此按鈕，清除輸入的拼音。
 | 刪除 | 按壓此按鈕，刪除前一個輸入的拼音。
 | ASCII 字符 | 按壓此按鈕，輸入ASCII字符。
 | 中文拼音 | 按壓此按鈕，輸入中文的有聲母和韻母組成的拼音。
 |  | 按壓此按鈕，將鍵盤的格式在拼音和ASCII字符之間轉換。
 |  | 按壓此按鈕，向上滾動可能的字符列表。
 |  | 按壓此按鈕，向下滾動可能的字符列表。
 | 離開 | 按壓此按鈕，關閉鍵盤畫面並忽略全部改變的設定。
 | 清空 | 按壓此按鈕，清除輸入的中文字符。
 | 刪除 | 按壓此按鈕，刪除前一個輸入的中文字符。
 | 輸入 | 按壓此按鈕，關閉鍵盤畫面並接收全部改變的設定。


20.1.5. 密碼鍵盤

密碼鍵盤

下圖為密碼鍵盤的範例。

下表為鍵盤畫面中，各項目的說明。

項目 |  | 說明
抬頭列 |  | 按住抬頭列不放，可移動畫面視窗。
密碼顯示 |  | 顯示當前所輸入的密碼。
按鈕 | 0-9 | 按壓按鈕輸入數位0到9，將顯示星號而非數字。
 | 離開 | 按壓此按鈕，關閉此畫面並放棄所有改變。
 | 清空 | 按壓此按鈕，清除輸入的數值。
 | 輸入 | 按壓此按鈕，關閉鍵盤畫面並輸入密碼。


20.1.6. 密碼表

密碼表

欲註冊新的密碼或修改現有人機應用的密碼，用戶需在畫面上建立一個功能按鈕，指定功能按鈕“顯示密碼表功能”，當人機應用開始運行，用戶等級8的用戶按壓功能按鈕，可取得如下的密碼表。

註：用戶只能取得用戶等級低於或等於本身的密碼。例如，如果當前用戶等級為5，密碼表只顯示等級1到等級5的密碼。

下圖為當前用戶等級為8，所顯示的密碼表。

下表為密碼表畫面中，各項屬性的說明。

項目 | 說明
抬頭列 | 按住抬頭列不放，可移動畫面視窗。
密碼 | 按壓此欄位，開啟十進位數字鍵盤，設定關聯用戶等級的密碼。密碼為最多8位數的正整數，且在相同人機應用中不可重複。
確認 | 按壓此按鈕，關閉此畫面並確認所有改變的設定。
取消 | 按壓此按鈕，關閉此畫面並放棄所有改變的設定。


20.1.7. 選取檔

選取檔案

選取檔畫面只有在人機支援此項操作出現。用戶可在選取檔畫面進行以下的操作：

 | 操作 |  | 操作
1 | 選取檔更新OS&AP | 15 | 從TXT檔讀取配方資料
2 | 選取檔並執行OS&AP | 16 | 從DAT檔讀取配方資料
3 | 選取檔讀取資料 | 17 | 寫入OS和AP到檔案
4 | 選取檔寫入資料 | 18 | 列印畫面到檔案(256色)
5 | 選取檔附加資料 | 19 | 列印畫面到檔案(64色)
6 | 選取檔刪除資料 | 20 | 寫入收集資料到.LDF檔案
7 | 選取檔更名 | 21 | 從.LDF檔案讀取收集資料
8 | 寫入配方資料到TXT檔 案 | 22 | 寫入曲線圖資料到檔案
9 | 寫入配方資料到DAT檔 案 | 23 | 從檔案讀取曲線圖資料
10 | 寫入歷史資料到.CSV/TXT 檔 案 | 24 | 寫入二維分佈圖資料到檔案
11 | 寫入歷史警報到檔案 | 25 | 從檔案讀取二維分佈圖資料
12 | 寫入警報計數到檔案 | 26 | 選取檔案複製
13 | 寫入操作紀錄到檔案 | 27 | 從.CSV/TXT 檔案讀取收集資料
14 | 寫入人機資料到檔案 |  |

下圖為選取檔案的範例。


20.1.8. 選取檔案夾

選取檔案夾

支持檔案操作的人機才會顯示檔案夾選取的畫面。允許用戶從系統中選取一個檔案夾，而且，被選取的檔案夾名稱會被保存在可選取檔案夾名稱的列表中。

下面是檔案夾選取畫面的範例。

點擊【新建檔案夾】按鈕，可以建一個新的檔案夾。下面是新建檔案夾畫面的範例。


20.1.9. 重新命名/複製/刪除檔案

重新命名/複製/刪除檔案

只有在支持檔案操作的人機才會出現支持重新命名，複製，刪除檔案的操作。

  • 重新命名檔

在系統中允許用戶給一個檔案重新命名。

  • 複製檔案

在系統中允許用戶複製一個或多個檔案到其他的位置。

  • 刪除檔案

在系統中允許用戶刪除一個或多個檔案。


20.1.10. 時間和日期設定

時間和日期設定

當“時間和日期設定”的功能按鈕被觸發的時候，人機會顯示時間和日期設定畫面。這個畫面是用來選擇任意的歷史數據表，歷史趨勢圖和歷史雷達圖中的時間和日期的設定。

  • 日期選擇

允許用戶選擇關聯物件的日期。

  • 時間選擇

允許用戶選擇關聯物件的時間。


20.2. 人機設置

人機設置

在開啟電源後，人機將顯示人機設置畫面，下圖為 HMI 070的人機設置畫面。

註：人機設置畫面中的某些按鈕只在需要設定時才會顯現。

註：開機後，如果在一般設置中設定“開機後運行人機應用(Run AP After Power On)”旗標為是(True)，目標人機將不會顯示人機設置畫面，而是直接運行人機應用畫面。

下表為人機設置畫面中，各項屬性的說明。

屬性 | 按壓按鈕
English/中文(繁體)/中文(簡体) | 設定人機設置畫面所顯示的語言。
一般設定 | 設定顯示器的對比和亮度，詳細說明，請參考第20.2.2節。
觸控螢幕 | 校正觸控螢幕，詳細說明，請參考第20.2.3節。
設定時間/日期 | 設定萬年曆的時間與日期，詳細說明，請參考第20.2.4節。
硬體資訊 | 顯示目標人機的硬體資訊，下圖為硬體資訊顯示畫面。
連接1~連接4 | 設定通訊連接的參數，詳細說明，請參考第20.2.5節和第20.2.6節。
網路印表機位址 | 設定網路印表機的IP位址，詳細說明，請參考第20.2.7節
將人機應用複製到HMI | 複製人機應用到另一台HMI。
將人機應用複製到文件 | 儲存系統程式和人機運行資料為PRP檔。PRP檔可被本軟體和相容的目標人機所使用。
複製檔案 | 複製檔案。
删除檔案 | 删除檔案。
格式化C:磁 碟 | 將內建的快閃碟(C:)格式化。此項操作需用戶等級高於或等於8才能進行。
FTP/VNC | 設定用戶名稱和允許目標人機作為FTP站。設定允許通過遠程監控軟體VNC對目標人機進行監控。詳細說明，請參考第 20.2.8 節。
從檔案開機 | 從PRP檔載入和運行系統程式和人機應用運行資料。原始的系統程式和運行資料將保留，載入的系統程式和運行資料將在關機後將消失。
從檔案更新 | 從PRP檔更新系統程式和人機應用運行資料。原始的檔將被新的檔所取代。
清除記錄資料 | 清除儲存在電池保護記憶區的資料，包含操作歷史記錄、警報歷史、警報計數和資料收集器所收集的資料。此操作需要用戶等級高於或等於7才能進行。
運行 | 開始運行人機應用。如果需要登入，操作員需輸入正確的密碼後，才會顯示啟始畫面。所輸入密碼的用戶等級將成為當前用戶等級。在人機應用開始運行後，需要用戶等級高於當前用戶等級的操作則無法進行。


20.2.1. 進入人機設置模式

進入人機設置模式

有時，用戶需進入人機設置模式，調整人機的各項設定。以下說明當人機畫面運行時，

如何進入人機設置模式(Panel Setup)：方法一.

步驟1: 觸碰螢幕的左上角。如果此操作成功，在角落會閃爍一次。

步驟2: 觸碰螢幕的右上角。如果此操作成功，在角落會閃爍一次。

步驟3: 觸碰螢幕的左上角。如果此操作成功，在角落會閃爍一次。

只有在依左-右-左上角的順序觸控螢幕的角落，才可使人機進入設置模式。

註：如果以上的方法無法進入設置模式時，必須檢查是否人機設置(Panel Setup)的一般設置畫面中的允許運行人機設置(Allow To Run Panel Setup)旗標是否設為:是(True)，如果此旗標設為:否(False)，則人機將無法進入設置模式。

如何進入人機設置模式(Panel Setup)：方法二.

人機開機送電的同時，按住人機顯示區域的右上角按住最少 3-5秒，當聽到一聲蜂鳴器的聲音就可以放開按壓，然後人機就會進入人機設置模式(Panel Setup)。


20.2.2. 一般設置

一般設定

用戶可在人機設置畫面上，按壓一般設定按鈕，開啟一般設定窗口畫面進行設定。下圖為一般設定畫面的範例。

下表為一般設置畫面中，各項屬性的說明。

屬性 |  | 說明
檢查電池 |  | 如果欲使人機在運行人機應用前，檢查電池，選擇:是(True)。如果電池檢查失敗，將會出現“電池備份記憶區錯誤，所有記錄資料將被清除!”的錯誤訊息。此屬性預設為:是(True)。
螢幕保護程式時間(分) |  | 輸入一數字，範圍為0到60，在所設定的時間內(單位為分)，如果沒有人觸控螢幕，人機將關閉顯示器背燈。此設定是為了延長液晶的背燈的使用年限，如果設螢幕保護程式時間為0，人機將不會關閉背燈。
允許運行人機設置 |  | 如果欲離開運行中的人機應用，進入人機設置畫面，請選擇:是(True)。
起始語言 |  | 當下載人機應用時，如果欲使用與其他資料傳輸相同的起始語言，請選擇預設值(Default)，或從語言1到10擇一。
開機後運行人機應用 |  | 欲在開機後立即運行人機應用，請選擇是(True)，預設為否(False)。
翻轉顯示 |  | 欲使畫面上下翻轉顯示，請選擇是(True)，預設為否(False)。
IP地址 |  | 按下編輯欄位，使用彈出的數值鍵盤輸入IP地址。每個IP地址的數值範圍為0到255。
子網掩碼 |  | 點擊編輯區域，在彈出的數字鍵盤上輸入子網掩碼。每個數值都是0~255間的一個數。
網關 |  | 點擊編輯區域，在彈出的數字鍵盤上輸入網關。每個數值都是0~255間的一個數。
LCD 亮度 | 增加 | 點擊此處增加LCD亮度 。
 | 減少 | 點擊此處減少LCD亮度。
 | 儲存 | 點擊此處儲存當前LCD亮度。
確認 |  | 點擊按鈕關閉對話方塊並儲存所有改變的設定。
取消 |  | 點擊按鈕關閉對話方塊並放棄所有改變的設定。


20.2.3. 校正觸控屏

校正觸控屏

欲校正觸控螢幕，用戶可按壓在人機設置畫面上的觸控螢幕按鈕。然後，依以下的步驟，用非尖銳的筆頭觸碰白點和畫面上的確認按鈕。

1,觸碰畫面左上角的白點。

2,觸碰畫面右下角的白點。

3,按壓畫面左上角的重做按鈕可回到步驟1。

或觸控左下角的ok按鈕進行下一步驟。

4,按壓畫面左上角的重做按鈕可回到步驟1。

或觸控右上角的ok按鈕進行下一步驟。

5,按壓畫面左上角的重做按鈕可回到步驟1。

或觸控畫面中間的ok按鈕完成校正。

在校正完成後，人機設置畫面會再顯現。

註：請勿使用任何金屬制或尖銳的物品，如螺絲起子或原子筆，觸碰螢幕。


20.2.4. 時間和日期設定

時間和日期設定

按壓設置畫面上的設定時間/日期按鈕，開啟設定時間和日期畫面。下圖為設定時間和日期畫面的範例。

下表為時間與日期設置畫面中，各項屬性的說明。

屬性 | 說明
當前時間(hh:mm:ss) | 顯示萬年曆晶片中的當前時間。
當前日期(yy/mm/dd) | 顯示萬年曆晶片中的當前日期。
當前星期 | 顯示萬年曆晶片中的當前星期。
時 | 選擇介於0到23的整數，代表時。
分 | 選擇介於0到59的整數，代表分。
秒 | 選擇介於0到59的整數，代表秒。
年 | 選擇介於0到99的整數，代表年。
月 | 選擇介於1到12的整數，代表月。
日 | 選擇介於1到31的整數，代表日。
星期 | 選擇星期一、星期二、星期三、星期四、星期五、星期六、星期日代表周日。
萬年曆調整(sec./day) | 設定每天調整萬年 曆時間的秒數補償。
設定 | 儲存所有改變的設定。
設定後離開 | 點擊此處結束對話方框並接受所有改變的設定。
取消 | 點擊此處結束對話方框並放棄所有改變的設定。


20.2.5. 連接設定（序列埠）

連線設定（序列埠）

本章節說明如何使用目標人機中的連接畫面，設定序列通訊連接的通訊參數。預設的通訊參數與人機應用資料下載所使用的設定相同。

按壓人機設置畫面上的連接按鈕，可開啟連接畫面。如果為序列連接，目標人機會顯示序列埠參數畫面，如下圖。

屬性 | 說明
通訊 | 如果欲使人機和控制器間的通訊無效，選擇:否。當通訊無效時，人機不與控制器連線但仍會顯示畫面。
埠 | 連接界面可以選擇COM1或COM2或COM3，指定目標人機與控制器連接的序列埠。
串列傳輸速率 | 設定使用的串列傳輸速率。
數據位元數 | 設定使用的資料位元數。
奇偶校驗 | 設定校驗的方式。
停止位元 | 設定使用的停止位元數。
命令延遲 | 如果命令延遲為0，表示在通訊驅動接收到最後發送訊號的回應後，會立即發送下一個訊號至連接的裝置。如果命令延遲不為0，通訊驅動延遲指定的時間後，才會發送下一個訊號至連接裝置。
重試次數 | 通訊驅動重試的次數，通訊驅動在每次發送訊號後，會以指定次數重試直到連接裝置成功地回應。如果將重試次數設為0，則通訊驅動會使用預設的重試次數。
超時時間(0.1s) | 設定通訊驅動等待連接裝置回應的時間，當時間超過超時時間，通訊驅動將認定此聯機通訊失敗。
人機地址 | 設定人機應用地址。
PLC地址 | 設定連接控制裝置的位址。


20.2.6. 連接設定（乙太網路）

連線設定（乙太網路）

本章節說明如何使用目標人機中的連接畫面設定乙太網路連接的通訊參數。預設的通訊參數與下載人機應用資料所使用的設定相同。

按壓人機設置畫面上的連接按鈕，可開啟連接畫面。如果為乙太網路連接，目標人機會顯示乙太網路參數畫面，如下圖。

下表為乙太網路連接中，會出現的選項：

屬性 | 說明
通訊 | 如果欲使人機和控制器間的通訊無效，選擇:否(False)。當通訊無效時，人機連介面與控制器連接但仍會顯示畫面
命令延遲 | 如果命令延遲為0，表示在通訊驅動接收到最後發送訊號的回應後，會立即發送下一個訊號至連接的裝置。如果命令延遲不為0，通訊驅動延遲指定的時間後，才會發送下一個訊號至連接裝置。
重試次數 | 通訊驅動重試的次數，通訊驅動在每次發送訊號後，會以指定次數重試直到連接裝置成功地回應。如果將重試次數設為0，則通訊驅動會使用預設的重試次數。
超時時間 | 設定通訊驅動等待連接裝置回應的時間，當時間超過超時時間，通訊驅動將認定此連接通訊失敗。
埠 | 顯示使用的IP。
IP地址 | 設定連接裝置的IP地址。用戶可以按壓關聯欄位，開啟數值鍵盤，輸入數 字。
確認 | 點擊此處結束對話方塊並接受所有改變的設定。
取消 | 點擊此處結束對話方塊並放棄所有改變的設定。


20.2.7. 網絡印表機地址

網路印表機地址

欲使用網路印表機，用戶需設定IP地址和印表機在人機上的連接埠。用戶可按下在人機設置畫面上的網路印表機按鈕，開啟畫面，下圖為範例。

下表為網路印表機畫面中，會出現的選項:

屬性 | 說明
IP 地址 | 設定連接的網路印表機地址。用戶可以按壓關聯欄位，開啟十進位數字鍵盤，輸入IP地址，範圍從0到255。
埠 | 設定使用的IP 埠。用戶可以按壓關聯欄位，開啟十進位數字鍵盤，輸入0到65535間的整數。
確認 | 點擊此處結束對話方塊並接受所有改變。
取消 | 點擊此處結束對話方塊並放棄所有改變。


20.2.8. FTP/VNC網站

FTP/VNC設定

欲從遠端存取目標人機中的檔，可依以下步驟進行：
1. 開啟IE(或其他網頁流覽器)，在網址欄輸入位址。輸入ftp://然後再輸入目標人機的位址。例如，可輸入 ftp://192.168.10.163。欲設定目標人機的IP地址，請參考第 20.2.2 節。
2. 目標人機(FTP網站)需要使用者名稱與密碼登入。如果目標人機有人機應用，用戶需要輸入對應用戶等級的密碼，才可進入FTP網站讀/寫檔案。

註：可寫入檔的用戶亦可讀取檔。

如果目標人機沒有人機應用，用戶可使用預設密碼“123”遠端存取FTP網站。

成功登入目標人機(FTP網站)，將可看到符合存取許可權的檔。畫面和微軟流覽器或我的電腦類似。用戶可以從自己的硬碟讀取和寫入檔到目標人機(FTP網站)中，反之亦然。請記住需要相對應的用戶等級才可進行此項操作。用戶的許可權可在人機中設定。

 欲設定用戶名稱讀取/寫入目標人機(FTP網站)的許可權，用戶可以按壓在人機設置畫面上的FTP網站按鈕，開啟如下的畫面：

下表為FTP網站畫面中，各項屬性的說明。

屬性 | 說明
用戶名稱 | 設定目標人機的用戶名稱。按壓此欄位，出現ASCII字元鍵盤，可輸入8個字元，預設的用戶名為“user”。
寫入操作的用戶等級 | 設定寫入檔到人機所需的用戶等級。
讀寫操作的用戶等級 | 設定從人機讀取檔的用戶等級。
FTP伺服器使用的檔案夾 | 設定伺服器使用的預設檔案夾。
確認 | 點擊此處結束對話方塊並接受所有改變的設定。
取消 | 點擊此處結束對話方塊並放棄所有改變的設定。


20.2.9. VNC 連接

VNC 連接

第一部分：局域網

1. 設置人機的IP地址

  • 进入“人機設置”界面，點擊“一般 設定”。
  • 設置IP 地址為：192.168.10.84 子網路遮罩：255.255.255.0 網關：192.168.10.1
  • 點擊”確定“保存設置。

2. 用網線將人機連接到交換機。

3. 確認新的 IP位址。

 選取一個不在起始和結束 IP地址範圍內的IP地址，比如192.168.10.84.
 在局域網中的任何一臺電腦上，將滑鼠移動到“開始->程式->附件->命令提示符”，輸入“ping192.168.10.84”

如果出現““Destination host unreachable” ，這個IP 位址可以使用，否則，重新選取一個IP位址，重複上述步驟。

4. 在 PC或Android系統或iPhone和iPad上打開VNC用戶端，並連接到人機。在伺服器列表中輸入人機的IP地址。比如192.168.10.84.。

第二部分：遠端網路

1. 拿出一個路由器或交換機，例如

2. 用網線將人機連接到路由器或者交換機。

3. 登入路由器
 打開 web瀏覽器，在瀏覽器地址欄中輸入DI--604的IP地址 ，並點擊”Enter“鍵。DI--604默認的IP地址是192.168.10.1.例如 http://192.168.10.1

建立連接後會彈出登錄介面。以管理員身份登錄，輸入用戶名“admin”和密碼（沒有默認密碼，讓它空白）。單擊“確定”按鈕。如果密碼正確，會彈出Web管理介面。

如果用戶名或者密碼錯誤，這個登陸介面會再次出現。請檢查您的用戶名和密碼 。

4. 檢查起始 IP位址和結束IP地址 。

 移動滑鼠到左側的 DHCP按鈕，並點擊。

這裏“起始 IP位址”和“結束IP地址”，分別是192.168.10.100和192.168.10.199。
 選取一個不在這個範圍內的 IP地址，比如192.168.10.84.

5. 在人機 設置界面設置 IP地址

  • 給帶有網口的HMI通電。
  • 进入“人機設置”界面，點擊“一般 設定”。
  • 設置IP 地址為：192.168.10.84 子網路遮罩：255.255.255.0 網關：192.168.10.1
  • 點擊”確定“保存設置。

6. 確認新的 IP位址

在該網路中的任何一台電腦上，將滑鼠移動到“開始->程式->附件->命令提示符”，輸入“ping192.168.10.84”

如果出現““Destination host unreachable” ，這個IP 位址可以使用，否則，重新選取一個·IP位址，重複上述步驟。

7. 再次回到路由器設置頁面。點擊在上面一行的“Advanced”按鈕和左側一欄的按“Virtual Serve”按鈕。
ID-604 可以被配置為一個虛擬伺服器，遠程用戶通過公共IP地址訪問Web或FTP服務可以被自動重定向到本地伺服器的局域網網路。

下表為虛擬伺服器中各項屬性的說明。

屬性 | 説明 | 備注
名称（Name） | 伺服器名稱。 |
伺服器 IP地址 （Private IP） | 接在LAN口下的伺服電腦，將提供虛擬服務。 |
通訊協議類型(Protocol Type) | 虛擬伺服器的通訊協議類型。 |
伺服器通訊埠(Private Port) | 服務端口號碼通常使用的伺服器的IP。 |
WAN端通訊埠(Public Port) | WAN端的通訊端口，用於和伺服器通訊。 |
時程(Schedule) | 虛擬伺服器將被啟用的時間表。 | 時程可以被設置為始終啟用。如果設定時間，那麼就可以選擇伺服器的啟用時間範圍。如果系統時間超出時程設定時間，伺服器將會關閉。

設定完成之後，點擊底部的“套用”按鈕保存新的設置。下面是一個範例：

 名稱： VNC server
 伺服器 IP地址：192.168.10.84
 通訊協議類型： TCP
服器通訊埠： 5900
 WAN 端通訊埠：5900
 時程： always

8. 獲取外部 IP地址

這是路由器的屬性設置畫面，注意 WAN的設置。寫入IP地址，這是一個开放的網路地址。.
 在這個例子中，這個IP地址是10.80.1.105

9. 測試 IP地址

運行人機應用，人機應用-->下載數據至觸控屏->以太網-->IP地址。輸入從路由器的屬性畫面中獲取的IP地址。例子中的是10.80.1.105，然後點擊“開始”按鈕，開始下載程式。

10. 發佈該 IP地址給需要用戶。

一般情況下，這是一個動態的 IP地址，在幾天或幾個月內這個IP地址可以保持不變，但它隨時都可能發生變化。所以，在每次下載之前，請檢查一下此IP地址。

11. 在PC或Android系統或iPhone和ipad上打開VNC用戶端，並連接到人機。人機的外部IP地址來自步驟8.


20.3. 使用系统载入程式(System Loader)恢复系统

使用系统载入程式(System Loader)恢复系统

當出現系統問題影響到人機的正常操作時，用戶需要重新開機，進入系統載入程式(System Loader)模式修改人機的錯誤，或更新系統程式。在問題修正後，重新開機，人機即可正常運作。

欲進入系統載入程式(System Loader)模式，在人機送電後，立即按住人機畫面的左上角3到5秒，等待出現嗶聲，放開後即會出現如下的系統載入程式(System Loader)畫面。

下表為系統載入程式(System Loader)畫面中，各按鈕功能的說明。

屬性

 按壓按鈕
English/中文(繁體)/中文(簡体) 設定畫面文字所顯示的語言。
一般設定

設定IP地址和顯示器的亮度，下圖為一般畫面的範例。

下表為一般畫面中，各項屬性的說明。

屬性 |  | 說明
IP地址 |  | 按壓此欄位，彈出數值鍵盤，輸入IP位址。IP byte可輸入0到255數位。
LCD亮度 | 增加 | 點擊此處增加LCD亮度。
 | 減少 | 點擊此處減少LCD亮度。
 | 儲存 | 點擊此處儲存當前LCD亮度的設定。
確認 |  | 點擊此處結束對話方塊並接受所有改變。
取消 |  | 點擊此處結束對話方塊並放棄所有改變。
觸控螢幕 | 校正觸控螢幕，詳細說明，請參考第 20.2.3 節。
格式化C:碟 | 格式化內建的快閃碟(C:)，此項操作需要用戶等級高於或等於8。
硬體信息(H/W Information)

顯示目標人機硬體的資訊，下圖為硬體資訊畫面的範例。

從檔案更新應用 | 從PRP檔更新系統程式和人機應用運行資料。原始的系統程式和運行資料將被新的取代。
運行 | 進入人機設置模式。


13.1.5. 使用數據收集器巨集進行數據收集

使用數據收集器巨集進行數據收集

當一個數據收集器需要用巨集收集數據時，需要使用數據收集器巨集。數據收集器巨集被啟動時，記錄的數據被取樣，它將處理數據並且使用巨集命令(SAVE2LB)保存轉換後的數據至數據記錄器記錄緩存區。

下面是一個使用數據收集巨集記錄數據的例子：

  1. 人機將從W200每秒讀取35個字。

  2. 當記錄的數據取樣時，人機將會通過數據收集巨集寫長度35個字的取樣數據到內部緩存$U200，數據記錄巨集將被啟動。

  3. 在數據收集巨集中，可以從$U200記錄長度35個字的取樣數據。

  4. 然後使用巨集指令SAVE2LB保存從$U1000 更新的30個字長的數據到數據收集器#3。


13.1.6. 引數指定字串和編號指定字串的區別

引數指定字串和編號指定字串的區別

運用以下三個例子來說明引數指定字串和編號指定字串的區別。

設在文字庫的文字表A中有5個字串，其他的全部是空的。

文字表A

字串編號 | 語言 1
A00001 | S1
A00002 | S2
A00003 | S3
A00004 | S4
A00005 | S5
A05000 | S5000
A20000 | S20000

假設有一個數據收集器收集$U100的值，並且在歷史數據顯示器中顯示該值。

例1（引數指定字串）

數據收集器數據項目的設置如下

根據數據收集器的數值，將會在歷史數據顯示器中顯示下表中的字串。

數據值 | 字串編號 | 字串 | 注釋
0 | 0+1 = 1 | A00001 |
1 | 1+1 = 2 | A00002 |
2 | 2+1 = 3 | A00003 |
3 | 3+1 = 4 | A00004 |
4 | 4+1 = 5 | A00005 |
5~65535 | 6~65536 |  | 通過起始字串編號和結束字串編號的引數指定字串，1~5以外不是有效範圍內的字串編號.

註：字串編號是數值和起始字串編號的和。

例2（引數指定字串）
數據收集器數據項目的設置如下

根據數據收集器的數值，將會在歷史數據顯示器中顯示下表中的字串。

數據值 | 字串編號 | 字串 | 注釋
0 | 0+3 = 3 | A00003 |
1 | 1+3 = 4 | A00004 |
2 | 2+3 = 5 | A00005 |
3~4996 | 6~4999 | A00006~ A04999 | 未定義的索引字串
4997 | 4997+3 = 5000 | A05000 |
4998~65535 | 5001~65538 |  | 通過起始字串編號和結束字串編號的引數指定字串，3~5以外不是有效範圍內的字串編號.

註：字串編號是數值和起始字串編號的和。

例3（編號指定字串）
 數據收集器數據項目的設置如下 。

根據數據收集器的數值，將會在歷史數據顯示其中顯示下表中的字串。

數據值 | 字串編號 | 字串 | 註釋
0 | 0 |  | 未定義字串
1 | 1 | A00001 |
2 | 2 | A00002 |
3 | 3 | A00003 |
4 | 4 | A00004 |
5 | 5 | A00005 |
6~4999 | 6~4999 | A00006~A04999 | 未定義的索引字串
5000 | 5000 | A05000 |
5001~19999 | 5001~19999 | A05001~A19999 | 未定義的索引字串
20000 | 20000 | A20000 |
20001~65535 | 20001~65535 |  | 未定義字串

註：字串編號就是數據值。

引數指定字串

  • 引數指定字串編號是數據值和起始字串編號的和。

  • 使用不直觀

  • 需要更多的記憶體

  • 更快的顯示速度

  • 一個文字表可有多種用途

編號指定字串

  • 數據值就是字串編號

  • 直觀使用

  • 高效的記憶體使用率

  • 較慢的顯示速度

  • 一個文字表只可用於一種用途


3.1.5 避免資料由於隨便關機而損壞

避免資料由於隨便關機而損壞

在HMI存儲的各種非掉電性存儲裝置的資料。該資料包括歷史數據記錄，報警記錄，操作記錄，配方，排程表，非掉電型使用者資料($N)，依此類推。該存放裝置包括內置電池供電的RAM，內置快閃記憶體，Micro SD卡和USB記憶棒。這是在關閉HMI時將資料寫入存放裝置可能導致失敗的操作。這會導致資料丟失，在存儲裝置中規劃的磁區中破壞資料的完整性。為了避免這個問題，功能按鈕支援一個名為“安全停機”的新操作。操作者可以關閉電源停止人機操作之前啟動這種功能按鈕，並且保證與上述非掉電性存放裝置的所有操作都安全地完成。雖然資料損壞的機會是罕見的，我們還是建議您使用以上方法，這會讓你的產品/專案系統更安全。

1. 下圖顯示了如何選擇“安全停機”操作的功能按鈕。

2. 當您按下“安全停機”功能按鈕在HMI中將顯示以下消息。 在HMI要顯示中文訊息您需要先在設定專案的語言中選語言為中文，詳細請參閱章節2.2.1的說明。

3. 在HMI中將顯示以下消息檢查關電前確實有完成執行安全停機。

4. 當HMI每次開始檢查運行應用程式時，您可以設置人機界面，以檢查操作員是否成功地為上一次斷電點擊“安全停機”的功能按鈕進行安全停機。

5. 每次HMI啟動後系統會自動檢查上次關機是否有完成安全停機的正確操作，當上一次在HMI關電前沒有完成執行安全停機。HMI將顯示以下消息。

6. 本軟體在編譯應用程式時，如果應用程式需要的安全停止，但軟體檢查在應用程式中沒有發現“安全停機”功能按鈕它將在螢幕上顯示以下警告消息。

7. 本軟體將編譯應用程式時，如果應用程式將資料保存到電池供電的RAM，但該軟體檢查在應用程式中沒有發現“安全停機”功能按鈕它將在螢幕上顯示以下警告訊息。如果您不希望當前應用程式再次看到該訊息為，請按一下操作方塊"否"按鈕。請注意，該訊息將只在V2.0.4.11或更高版本創建的應用程式時顯示。


3.4.12 OPC UA 使用者端驅動程式

OPC UA 使用者端驅動程式

配置程式提供了一個內置的OPC UA用戶端，使其連接到OPC伺服器。這個NEO OPC用戶端與OPC用戶端SDK建立，可用於互動式流覽和檢索伺服器的位址空間。伺服器的位址空間（或位址空間的一部分）被導入到配置程式之後，位址空間的物件位址可以被選擇為標籤。

■ NEO OPC 用戶端驅動

NEO OPC用戶端可以通過新的連接配置OPC連結啟動或添加連結對話方塊為以下幾點：

1) 從連接種類選項中，選擇OPC連接。

2) 從驅動器選項中，選擇OPC UA用戶端驅動程式。

3) 點擊流覽伺服器按鈕後內置的OPC用戶端可以發現在本地機器上運行的任何註冊的OPC伺服器。按一下此按鈕後註冊的OPC伺服器的清單會顯示出來。

搜尋在其他網路中的主機上運行的任何OPC伺服器，輸入目的電腦的主機的正確位址或電腦名到主機欄位中，然後按Find按鈕來查找指定的遠端主機上運行的所有已註冊的OPC伺服器。

4) 選擇目標OPC伺服器後，按連接測試按鈕來創建一個新的會話，以確認OPC伺服器是否正在運行。如果需要使用者身份驗證所OPC伺服器，用戶名和密碼都是必需要的。該認證方式取決於伺服器的端點。可用於當前端點的唯一選項將被顯示。用戶名/密碼，可以留空。如果指定一個用戶名，那麼它必須是電腦伺服器上有效的Windows帳戶。

5) 一個連接測試成功的連接到一個OPC伺服器後，該OPC伺服器的位址將被程式配置，以供保存將來使用。

■ NEO OPC UA 人機用戶端

一旦連接到一個已經建立的OPC UA伺服器，OPC UA人機用戶端，如下圖中的畫面：

伺服器的地址http://jack-computer:51211/UA/SampleServer的空間的一個例子，在伺服器的左邊流覽畫面會顯示位址空間的物件，而在屬性畫面右側顯示一個給定物件的詳細資訊。

在伺服器的位址空間的物件中可以在OPC UA伺服器的位址空間任何流覽畫面中擴大顯示被視為一個完整的網狀網路的節點。請點擊其對應的節點進行查看。請參閱OPC文檔，瞭解關於UA伺服器位址空間更加詳細的描述。

本次連接可以在任何時候通過按一下在伺服器功能表中有一個斷開連接的功能表選項關閉。

■ 從OPC伺服器導入標籤到配置程式

一個物件的資料類型（如整型，浮點）和陣列變數（例如一維或二維）通過支援被載入到配置程式作為標籤使用到所有的OPC伺服器的位址空間的全部或部分配置程式。目前，
所支援的資料類型如下：

- Boolean (位元)

- Byte (字節)

- SByte

- Float (浮點數)

- Int16 (有符號16位整數)

- Int32 (有符號32位整數)

- ByteString (位元組字串)

- String (字符串)

- UInt16 (無符號16位整數)

- UInt32 (無符號32位整數)

可支援的多陣列變數種類:

- Scalar (變數)

- One Dimension (一維)

- Two Dimensions (二維)

不支援的資料類型或值排名OPC伺服器的位址空間的物件中的OPC伺服器載入標籤會被自動淘汰進入配置程式。

正在從OPC伺服器的位址空間到配置程式載入的標籤可以完成在標籤表對話方塊中。從如下圖所示在連結名稱彈出功能表中按一下從OPC伺服器的載 入標籤。（注：連結的驅動程式必須是一個OPC UA使用者端驅動程式。）

該OPC UA使用者端填入以下畫面中，伺服器的位址空間可以被選中。在這裡，我們選擇載入在資料節點中的所有標籤作為一個例子。

點擊從OPC伺服器的載入選定的標籤之後，所有的資料節點下所支援的資料標籤將被載入到配置程式為圖中所示。

在此之後，將導入標籤組（或子組），如下LINK1節點的OPCServer的資料夾。

點擊下LINK1節點（這裡取變數節點為例）對應的節點，該標籤的詳細資訊顯示在右側清單中。

在上面的圖中，資料類型給定的標籤，位址和描述在一個表的行中被列出。在這裡，位址並不代表物理位址，但是一個抽象的位址，其中一個物件停留在OPC伺服器的位址空間，而R/W在描述欄位W表明一個物件的屬性是允許讀取和寫入的。如果它是唯讀的，在這一領域只顯示R。

然後，所有的標籤可以作為你已經熟悉的配置程式。


9.8.1 動態線 - 操作選項

動態線 - 操作選項

下面的動態線屬性工作表操作選項可以添加到一個動態線的選擇和設置選項中。

選項 | 說明
顯現控制 | 您可以通過指定的位元或當前使用者等級顯示或隱藏一個動態線。在顯現頁選擇並設置這個選項。


9.8.2 動態線 - 設置

動態線 - 設置

你可以完成動態線在動態線屬性工作表中的所有設置。這個對話方塊包含以下兩頁。

■ 一般頁
詳閱章節 9.8.3.說明

■ 顯現頁
詳閱章節 4.4.6.說明


9.8.3 動態線 - 一般設置

動態線 - 一般設置

本節介紹如何定義動態線的一般設置。以下是動態線屬性工作表的一般頁的範例。

下表描述了一般頁中各項​​屬性。

屬性 |  |  | 說明
編號 |  |  | 當物件產生時，系統自動給予一組編號。同一個畫面中的編號不會重複。編號的格式為DLnnnn。
註 |  |  | 加入物件的說明文字。
數據類型 |  |  | 控制動態線的變數的數據類型。所支持的數據類型包括：16位元不帶正負號的整數，32位元不帶正負號的整數，16位元整數和32位元有符號整數。
監視地址 |  |  | 指定控制的動態線的變數。 點擊 [image] 圖示，輸入所需的位址。點擊 [image] 圖示，選取所需的標籤。 下表顯示了所監視的變數的資料的排列。
 |  |  | 可控制 | 16 位元數據 |  | 32 位元數據
 |  |  | 位置，顏色和樣式 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | X1 (注) | 0,1 | X1
 |  |  |  | 1 | Y1 (注) | 2,3 | Y1
 |  |  |  | 2 | X2 (注) | 4,5 | X2
 |  |  |  | 3 | Y2 (注) | 6,7 | Y2
 |  |  |  | 4 | 顏色 (注) | 8,9 | 顏色
 |  |  |  | 5 | 樣式 (注) | 10,11 | 樣式
 |  |  | 位置和顏色 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | X1 | 0,1 | X1
 |  |  |  | 1 | Y1 | 2,3 | Y1
 |  |  |  | 2 | X2 | 4,5 | X2
 |  |  |  | 3 | Y2 | 6,7 | Y2
 |  |  |  | 4 | 顏色 | 8,9 | 顏色
 |  |  | 位置和樣式 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | X1 | 0,1 | X1
 |  |  |  | 1 | Y1 | 2,3 | Y1
 |  |  |  | 2 | X2 | 4,5 | X2
 |  |  |  | 3 | Y2 | 6,7 | Y2
 |  |  |  | 4 | 樣式 | 8,9 | 樣式
 |  |  | 位置 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | X1 | 0,1 | X1
 |  |  |  | 1 | Y1 | 2,3 | Y1
 |  |  |  | 2 | X2 | 4,5 | X2
 |  |  |  | 3 | Y2 | 6,7 | Y2
 |  |  | 顏色和樣式 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | 顏色 | 0,1 | 顏色
 |  |  |  | 1 | 樣式 | 2,3 | 樣式
 |  |  | 顏色 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | 顏色 | 0,1 | 顏色
 |  |  | 樣式 | 字編號 | 數據 | 字編號 | 數據
 |  |  |  | 0 | 樣式 | 0,1 | 樣式
 |  |  | 注:
 |  |  | 變數 | 說明
 |  |  | X1 | 動態線的起點的X座標。
 |  |  | Y1 | 動態線的起點的Y座標。
 |  |  | X2 | 動態線線的終點的X座標。
 |  |  | Y2 | 動態線線的終點的Y座標。
 |  |  | 顏色 | 動態線的顏色。你可以在這裡指定一個16位的顏色值。 16位顏色值的格式說明如下：
 |  |  |  | 位 | 說明
 |  |  |  | 15-11 | 指定的紅色成分值。
 |  |  |  | 10-5 | 指定的綠色成分值。
 |  |  |  | 4-0 | 指定的藍色成分值。
 |  |  |  | 關於顏色值，請參見章節 9.2.4.的說明
 |  |  | 樣式 | 動態線的樣式。 下圖顯示了可用的線條樣式和相關的樣式值。
控制 |  | 位置 | 當你想控制動態線的位置，請選中此選項。
 |  | 顏色 | 當你想控制動態線的顏色，請選中此選項。
 |  | 樣式 | 當你想控制動態線的樣式，請選中此選項。
預設 | 顏色 |  | 動態線的預設顏色。
 | 樣式 |  | 動態線的預設樣式。


9.8 動態線

動態線

您可以同時更改或是單獨指定位置，長度，顏色和動態線在運行時的樣式。

你可以完成動態線在動態線屬性表裡面的所有設置。這個對話方塊包含以下兩頁。

■ 一般頁
詳閱章節 9.8.3.說明

■ 顯現頁
詳閱章節 4.4.6.說明